Vous êtes sur la page 1sur 6

 LYCEE secondaire :  MATIERE : INFORMATIQUE DATE: 08-03-2016

Sadok Feki CLASSE : 2ème T I


Sakiet Eddeyer  Coefficient : 3
 DUREE : 1 HEURE
Devoir de contrôle N° 2 – Sujet A
PROF. : Mme
MKAOUAR Laila Pratique – 2ème Semestre Note: /20
Nom : ………………………………… Prénom :…………………………………………N° :……..

SUJET PRATIQUE
Soit l’algorithme incomplet suivant permettant de saisir un entier M avec (5 ≤ M ≤ 25),
de remplir un tableau « A » par « M » entiers de deux chiffres, de remplir un 2ème tableau
« AM » par les entiers multiples de « M » et un 3ème tableau « AR » par les entiers restants de
« A » puis afficher les éléments de chaque tableau.
Algorithme Travail demandé :
0) début devoir
1) Créer un dossier portant le nom « votre
1) Ecrire (‘’Donner la taille du tableau’’)
nom&prénom ».
Lire (M)
2) Traduire et compléter cet algorithme en
2) Pour ……………………………..
pascal.
Ecrire ( "A [ ", i , " ] = ")
3) Ajouter les contrôles de saisie de M ainsi
Lire (A [ i ] ) que pour les éléments du tableau « A ».
Fin pour 4) Compléter les structures convenables des
3) j  0 ; k  0 actions (4), (5) et (6) pour afficher les 3
Pour i de 1 à M faire tableaux.
Si A [ i ] mod m = 0 alors 5) Enregistrer votre programme sous le nom
jj+1 « devoir » sous le dossier créé en (1).
AM [ j ]  A[ i ]
Sinon Exp : pour M = 8 et le tableau « A » :
k k+1
A 12 48 35 64 56 25 32 72
AR [ k ]  A[ i ]
1 2 3 4 5 6 7 8
Fin Si
Alors le programme affichera :
Fin pour
4) ………..{Afficher les éléments de A } Les éléments multiples de « m » sont :
5) ……….{Afficher les éléments de AM}
6) ……….{Afficher les éléments de AR} 48 64 56 32 72
7) Fin devoir
Les éléments restants sont :

12 35 25

Grille d’évaluation :
Création de Contrôle de Structures
Question : Traduction Enregistrement
dossier saisie d’affichage
Nbre de points 1 7 2+2 2+2+2 2
 LYCEE secondaire :  MATIERE : INFORMATIQUE DATE: 08-03-2016
Sadok Feki CLASSE : 2ème T I
Sakiet Eddeyer  Coefficient : 3
 DUREE : 1 HEURE
Devoir de contrôle N° 2 – Sujet B
PROF. : Mme
MKAOUAR Laila Pratique – 2ème Semestre Note: /20
Nom : ………………………………… Prénom :…………………………………………N° :……..

SUJET PRATIQUE
Soit l’algorithme incomplet suivant permettant de saisir un entier X avec (6 ≤ X ≤ 20),
de remplir un tableau « B » par « X » chaines non vides, de remplir un 2ème tableau « BL »
par les chaines de longueur paire de « B » et un 3ème tableau « BI » par les chaines de
longueur impaire de « B » puis afficher les éléments de chaque tableau.
Algorithme Travail demandé :
0) début transfert 1) Créer un dossier portant le nom « votre
1) Ecrire (‘’Donner la taille du nom&prénom ».
tableau’’) 2) Traduire et compléter cet algorithme en
Lire (X) pascal.
2) Pour …………………………….. 3) Ajouter les contrôles de saisie de X ainsi
que pour les éléments du tableau « B ».
Ecrire ( "B [ ", c , " ] = ")
4) Compléter les structures convenables des
Lire (B [ c ] )
actions (4), (5) et (6) pour afficher les 3
Fin pour
tableaux.
3) a  0 ; m  0
5) Enregistrer votre programme sous le nom
Pour c de 1 à M faire
« transfert » sous le dossier créé en (1).
Si long (B[c ]) MOD 2 = 0 alors
aa+1 Exp : pour X = 5 et le tableau « B » :
BL [ a ]  B[ c ]
Sinon B Sadok Zied Rihem Zaineb Jihene
m m+1 1 2 3 4 5
BI [ m ]  B[ c ] Alors le programme affichera :
Fin Si Les éléments de BL :
Fin pour
4) ………..{Afficher les éléments de B } Zied Zaineb Jihene
5) …….{Afficher les éléments de BL }
Les éléments de BI :
6) ……….{Afficher les éléments de BI }
7) Fin transfert Sadok Rihem

Grille d’évaluation :
Création de contrôle de Structures
Question : traduction Enregistrement
dossier saisie d’affichage
Nbre de points 1 7 2+2 2+2+2 2
 LYCEE secondaire :  MATIERE : INFORMATIQUE DATE: 08-03-2016
Sadok Feki CLASSE : 2ème T I
Sakiet Eddeyer  Coefficient : 3
 DUREE : 1 HEURE
Devoir de contrôle N° 2 – Sujet C
PROF. : Mme
MKAOUAR Laila Pratique – 2ème Semestre Note: /20
Nom : ………………………………… Prénom :…………………………………………N° :……..

SUJET PRATIQUE
Soit l’algorithme incomplet suivant qui permet de saisir un entier n avec (n pair et
positif ), de remplir un tableau « V » par n entiers de deux ou trois chiffres, de remplir
un 2ème tableau « VD » par les entiers formés de deux chiffres de « V » et un 3ème tableau
« VT » par les entiers de trois chiffres de « V » puis afficher les éléments de chaque tableau.
Algorithme Travail demandé :
0) début eclater 1) Créer un dossier portant le nom « votre
1) Ecrire (‘’Donner la taille du tableau’’) nom&prénom ».
Lire (n) 2) Traduire et compléter cet algorithme en
2) Pour …………………………….. pascal.
Ecrire ( "V [ ", i , " ] = ") 3) Ajouter les contrôles de saisie de n
ainsi que pour les éléments du tableau
Lire (V [ i ] )
« V ».
Fin pour
4) Compléter les structures convenables
3) j  0 ; k  0
des actions (4), (5) et (6) pour afficher
Pour i de 1 à M faire
les 3 tableaux.
Si V [ i ] dans [10..99] alors
5) Enregistrer votre programme sous le
jj+1
nom « eclater » sous le dossier créé en
VD [ j ]  V[ i ] (1).
Sinon
k k+1 Exp : pour n = 6 et le tableau « V » :
VT [ k ]  V [ i ]
Fin Si V 69 126 65 312 53 485
Fin pour 1 2 3 4 5 6
Alors le programme affichera :
4) ……….{Afficher les éléments de V }
5) ……….{Afficher les éléments de VD} Les éléments de VD :
6) ……….{Afficher les éléments de VT}
7) Fin eclater 69 65 53

Les éléments de VT :

126 312 485


Grille d’évaluation :
Création de contrôle de Structures
Question : traduction Enregistrement
dossier saisie d’affichage
Nbre de points 1 7 2+2 2+2+2 2
 LYCEE secondaire :  MATIERE : INFORMATIQUE DATE: 08-03-2016
Sadok Feki CLASSE : 2ème T I
Sakiet Eddeyer  Coefficient : 3
 DUREE : 1 HEURE
Devoir de contrôle N° 2 – Sujet D
PROF. : Mme
MKAOUAR Laila Pratique – 2ème Semestre Note: /20
Nom : ………………………………… Prénom :…………………………………………N° :……..

SUJET PRATIQUE
Soit l’algorithme incomplet suivant permettant de saisir un entier p avec ( p impair et
positif), de remplir un tableau « C » par p lettres alphabétiques minuscules, de remplir
un 2ème tableau « CV » par les lettres voyelles de « C » et un 3ème tableau « CC » par les
lettres consonnes de « C » puis afficher les éléments de chaque tableau.
Algorithme Travail demandé :
0) début fraction 1) Créer un dossier portant le nom « votre
1) Ecrire (‘’Donner la taille du tableau’’) nom&prénom ».
Lire (p) 2) Traduire et compléter cet algorithme en
2) Pour …………………………….. pascal.
Ecrire ( "C [ ", k , " ] = ") 3) Ajouter les contrôles de saisie de p ainsi
que pour les éléments du tableau « C ».
Lire (C [ k ] )
4) Compléter les structures convenables des
Fin pour
actions (4), (5) et (6) pour afficher les 3
3) j  0 ; h  0
tableaux.
Pour k de 1 à p faire
5) Enregistrer votre programme sous le nom
Si C [k] dans [‘’a’’,’’e’’,’’y’’,’’u’’,’’i’’,’’o’’] alors
« fraction » sous le dossier créé en (1).
jj+1
CV [ j ]  C [ k ] Exp : pour p = 9 et le tableau « C » :
Sinon
h h+1 C a d y h i k o p u
CC [ h ]  C[ k ] 1 2 3 4 5 6 7 8 9
Fin Si Alors le programme affichera :
Fin pour Les éléments de CV :
4) ……..{Afficher les éléments de C }
5) …….{Afficher les éléments de CV} a y i o u
6) …….{Afficher les éléments de CC}
7) Fin fraction Les éléments de CC :

d h k p

Grille d’évaluation :
Création de contrôle de Structures
Question : traduction Enregistrement
dossier saisie d’affichage
Nbre de points 1 7 2+2 2+2+2 2
Correction Sujet A Correction sujet B
program devoir; program transfert;
uses wincrt; uses wincrt;

type tab = array[1..20] of integer; type tab = array[1..20] of string;

var A,AM,AR:tab; var B,BL,BI:tab;


i,j,k,m :integer; x,c,a,m:integer;

begin begin
repeat repeat
write('donner la taille du tableau : '); write('donner la taille du tableau : ');
readln(m); readln(x);
until m in [5..25];
until x in [3..25];
for i:= 1 to m do for c:= 1 to x do
repeat repeat
write('A[',i,'] = '); write('B[',c,'] = ');
readln(A[i]); readln(b[c]);
until A[i] in [10..99]; until b[c] <>'';

j:=0; k:=0;
for i:= 1 to m do a:=0; m:=0;
if (A[i]) mod m =0 then for c:= 1 to x do
begin if length(b[c]) mod 2 =0 then
j:=j+1; begin
AM[j]:= a[i]; a:=a+1;
end bl[a]:= b[c];
else
end
begin
k:=k+1; else
AR[k]:= A[i]; begin
end ; m:=m+1;
writeln('Affichage de A '); bi[m]:= b[c];
for i:= 1 to m do end ;
write(A[i],' '); writeln; writeln('Affichage de B ');
writeln('Affichage de AM ');
for c:= 1 to x do
for i:= 1 to j do
write(AM[i],' '); writeln; write(b[c],' '); writeln;
writeln('Affichage de AR '); writeln('Affichage de BL ');
for i:= 1 to k do for c:= 1 to a do
write(AR[i],' '); writeln; write(bl[c],' '); writeln;
readln; writeln('Affichage de BI ');
end.
for c:= 1 to m do
write(bi[c],' '); writeln;
readln;
end.
Correction sujet C Correction Sujet D:
program eclater; program fraction;
uses wincrt; uses wincrt;
type tab = array[1..20] of integer; type tab = array[1..20] of char;
var V, VD,VT:tab; var C, CV,CC:tab;
i,j,k,n :integer; p,j,k,h :integer;

begin begin
repeat repeat
write('donner la taille du tableau : '); write('donner la taille du tableau : ');
readln(n); readln(p);
until (p mod 2 =1) and (p >0) ;
until (n mod 2 =0) and (n >0) ;
for k:= 1 to p do
for i:= 1 to n do repeat
repeat write('C[',k,'] = ');
write('V[',i,'] = '); readln(C[k]);
readln(V[i]); until (C[k] in ['a'..'z']);
until (V[i]>=10) and (v[i] <=99 ) or
(V[i]>=100) and (V[i]<=999); j:=0; h:=0;
for k:= 1 to p do
j:=0; k:=0; if (C[k]) in ['a','e','y','u','i','o' ] then
for i:= 1 to n do begin
if (V[i]) in [10..99] then j:=j+1;
begin CV[j]:= C[k];
j:=j+1; end
VD[j]:= V[i]; else
end begin
else h:=h+1;
begin CC[h]:= C[k];
k:=k+1; end ;
VT[k]:= V[i]; writeln('Affichage de C ');
end ; for k:= 1 to p do
writeln('Affichage de V '); write(c[k],' '); writeln;
for i:= 1 to n do writeln('Affichage de VD ');
write(V[i],' '); writeln; for k:= 1 to j do
writeln('Affichage de VD '); write(CV[k],' '); writeln;
for i:= 1 to j do writeln('Affichage de VT ');
write(VD[i],' '); writeln; for k:= 1 to h do
writeln('Affichage de VT '); write(CC[k],' '); writeln;
for i:= 1 to k do
write(VT[i],' '); writeln; readln;
readln;
end.
end.