Vous êtes sur la page 1sur 50

Introduction Structure Conditionnelle Simple S. C. Composée S. C.

de choix multiple Le Branchement

Matière : Algorithmique et structure de données


Semestre : 01

Les Structures Conditionnelles en langage


Algorithmique et en C

Tayeb BAHRAM

Université Dr Tahar Moulay de Saida


Faculté des sciences, Département de mathématiques
tayeb.bahram@univ-saida.dz

30 October 2018

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Plan

1 Introduction

2 Structure Conditionnelle Simple

3 S. C. Composée

4 S. C. de choix multiple

5 Le Branchement

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Dans un algorithme (ou un programme), les instructions sont


exécutées séquentiellement, c’est-à-dire dans l’ordre où elles
apparaissent.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Dans un algorithme (ou un programme), les instructions sont


exécutées séquentiellement, c’est-à-dire dans l’ordre où elles
apparaissent.
La structure alternative ou conditionnelle permet d’exécuter
ou non une série d’instructions selon la valeur d’une condition.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Dans un algorithme (ou un programme), les instructions sont


exécutées séquentiellement, c’est-à-dire dans l’ordre où elles
apparaissent.
La structure alternative ou conditionnelle permet d’exécuter
ou non une série d’instructions selon la valeur d’une condition.
Donc, sans conditions, nos programmes informatiques feraient
toujours la même chose !

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Syntaxe algorithmique
Si (condition) alors
liste d’instructions
FinSi

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Syntaxe algorithmique Organigramme


Si (condition) alors
liste d’instructions
FinSi

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions {
liste d’instructions
FinSi
}

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions {
liste d’instructions
FinSi
}

Fonctionnement :

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions {
liste d’instructions
FinSi
}

Fonctionnement :
1 Évaluer l’expression condition.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions {
liste d’instructions
FinSi
}

Fonctionnement :
1 Évaluer l’expression condition.
2 Si condition est vraie, le bloc d’instructions sera exécuté.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Ce type d’instruction présente une seule possibilité ; elle ne


s’exécute que dans le cas où la condition est vérifiée.
Le cas contraire entraîne une sortie immédiate de l’instruction
en ignorant le reste des actions qui viennent.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions {
liste d’instructions
FinSi
}

Fonctionnement :
1 Évaluer l’expression condition.
2 Si condition est vraie, le bloc d’instructions sera exécuté.
3 Si condition est fausse, le bloc d’instructions ne sera pas exécuté.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Écrire un algorithme qui demande un entier nb à l’utilisateur, teste si ce nombre est
positif (nb ≥ 0) et affiche positif.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Écrire un algorithme qui demande un entier nb à l’utilisateur, teste si ce nombre est
positif (nb ≥ 0) et affiche positif.

Algorithmique
Algorithme Positif
Var nb : entier
debut
Ecrire("Entrer la valeur de nb :")
Lire(nb)
Si (nb ≥ 0 ) alors
Ecrire("positif")
FinSi
fin

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Écrire un algorithme qui demande un entier nb à l’utilisateur, teste si ce nombre est
positif (nb ≥ 0) et affiche positif.

Algorithmique Programme C
Algorithme Positif #include <stdio.h>
Var nb : entier int main()
debut {
Ecrire("Entrer la valeur de nb :") int nb ;
Lire(nb) printf("Entrer la valeur de nb :") ;
Si (nb ≥ 0 ) alors scanf("%d",&nb) ;
Ecrire("positif") if (nb ≥ 0 )
FinSi {
fin printf("positif") ;
}
return 0 ;
}

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Syntaxe algorithmique
Si (condition) alors
liste d’instructions 1
Sinon
liste d’instructions 2
FinSi

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Syntaxe algorithmique Organigramme


Si (condition) alors
liste d’instructions 1
Sinon
liste d’instructions 2
FinSi

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions 1 {
Sinon liste d’instructions 1
liste d’instructions 2 }
else
FinSi
{
liste d’instructions 2
}

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions 1 {
Sinon liste d’instructions 1
liste d’instructions 2 }
else
FinSi
{
liste d’instructions 2
}
Fonctionnement :

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions 1 {
Sinon liste d’instructions 1
liste d’instructions 2 }
else
FinSi
{
liste d’instructions 2
}
Fonctionnement :
1 Évaluer l’expression condition.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions 1 {
Sinon liste d’instructions 1
liste d’instructions 2 }
else
FinSi
{
liste d’instructions 2
}
Fonctionnement :
1 Évaluer l’expression condition.
2 Si condition est vraie, la série d’instructions 1 est exécutée et l’ensemble
d’instructions 2 est ignoré, la machine sautera directement à la première
instruction située après FinSi.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette instruction offre un choix entre deux possibilités, selon


le résultat du test de la condition.

Syntaxe algorithmique Organigramme Traduction en C


Si (condition) alors if (condition)
liste d’instructions 1 {
Sinon liste d’instructions 1
liste d’instructions 2 }
else
FinSi
{
liste d’instructions 2
}
Fonctionnement :
1 Évaluer l’expression condition.
2 Si condition est vraie, la série d’instructions 1 est exécutée et l’ensemble
d’instructions 2 est ignoré, la machine sautera directement à la première
instruction située après FinSi.
3 Si condition est fausse (a comme valeur Faux), la machine saute directement à
la première ligne située après le Sinon et exécute le bloc d’instructions 2.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Écrire un algorithme (et un programme en C) qui affiche si un nombre entier saisi au
clavier est pair ou impair.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Écrire un algorithme (et un programme en C) qui affiche si un nombre entier saisi au
clavier est pair ou impair.

Algorithmique
Algorithme Parite
Var n, r : entiers
debut
Ecrire("Ecrire la valeur de n :")
Lire(n)
r ← n mod 2
Si (r = 1 ) alors
Ecrire(n,"est impair")
Sinon
Ecrire(n,"est pair")
FinSi
fin

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Écrire un algorithme (et un programme en C) qui affiche si un nombre entier saisi au
clavier est pair ou impair.

Algorithmique Programme C
Algorithme Parite #include <stdio.h>
Var n, r : entiers int main()
debut {
Ecrire("Ecrire la valeur de n :") int n, r ;
Lire(n) printf("Ecrire la valeur de n :") ;
r ← n mod 2 scanf("%d",&n) ;
Si (r = 1 ) alors if (n == 1 )
Ecrire(n,"est impair") {
Sinon printf("%d est impair",n) ;
Ecrire(n,"est pair") }
FinSi else
fin {
printf("%d est pair",n) ;
}
return 0 ;
}

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette structure offre un choix entre plusieurs possibilités (choix multiple), selon
le résultat du test de la condition.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette structure offre un choix entre plusieurs possibilités (choix multiple), selon
le résultat du test de la condition.

Exemple : Tests imbriqués

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette structure offre un choix entre plusieurs possibilités (choix multiple), selon
le résultat du test de la condition.

Exemple : Tests imbriqués


Algorithmique
Algorithme EtatEau
Var temp : entier
debut
Ecrire("Temperature de l’eau ?")
Lire(temp)
Si (temp <= 0 ) alors
Ecrire("C’est de la glace")
Sinon
Si(temp >= 100 ) alors
Ecrire("C’est de la vapeur")
Sinon
Ecrire("C’est du liquide")
FinSi
FinSi
fin

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Cette structure offre un choix entre plusieurs possibilités (choix multiple), selon
le résultat du test de la condition.

Exemple : Tests imbriqués


Algorithmique Programme C
Algorithme EtatEau #include <stdio.h>
Var temp : entier int main()
debut {
Ecrire("Temperature de l’eau ?") int temp ;
Lire(temp) printf("Temperature de l’eau ?") ;
Si (temp <= 0 ) alors scanf("%d",&temp) ;
Ecrire("C’est de la glace") if (temp <= 0 )
Sinon printf("C’est de la glace") ;
Si(temp >= 100 ) alors else if(temp >= 100 )
Ecrire("C’est de la vapeur") printf("C’est de la vapeur") ;
Sinon else
Ecrire("C’est du liquide") printf("C’est du liquide") ;
FinSi return 0 ;
FinSi }
fin

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C


1 Branchement inconditionnel (goto, break, continue, stop...etc.)

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C


1 Branchement inconditionnel (goto, break, continue, stop...etc.)
2 Branchement conditionnel

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C


1 Branchement inconditionnel (goto, break, continue, stop...etc.)
2 Branchement conditionnel
if—else

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C


1 Branchement inconditionnel (goto, break, continue, stop...etc.)
2 Branchement conditionnel
if—else
Multiple (switch)

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C


1 Branchement inconditionnel (goto, break, continue, stop...etc.)
2 Branchement conditionnel
if—else
Multiple (switch)

La structure conditionnelle Selon (switch en C) permet de choisir le traitement


à effectuer en fonction de la valeur d’une variable.

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C


1 Branchement inconditionnel (goto, break, continue, stop...etc.)
2 Branchement conditionnel
if—else
Multiple (switch)

La structure conditionnelle Selon (switch en C) permet de choisir le traitement


à effectuer en fonction de la valeur d’une variable.

Syntaxe algorithmique
Selon ( variable )
Cas 1 : liste d’instructions 1
Cas 2 : liste d’instructions 2
Cas 3 : liste d’instructions 3
.......
Cas n : liste d’instructions n
Sinon
liste d’instructions n + 1
FinSelon

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Types de branchement en langage C


1 Branchement inconditionnel (goto, break, continue, stop...etc.)
2 Branchement conditionnel
if—else
Multiple (switch)

La structure conditionnelle Selon (switch en C) permet de choisir le traitement


à effectuer en fonction de la valeur d’une variable.

Syntaxe algorithmique Traduction en C


Selon ( variable ) switch ( variable )
Cas 1 : liste d’instructions 1 {
Cas 2 : liste d’instructions 2 case 1 : liste d’instructions 1 ; break ;
Cas 3 : liste d’instructions 3 case 2 : liste d’instructions 2 ; break ;
....... case 3 : liste d’instructions 3 ; break ;
Cas n : liste d’instructions n .......
Sinon case n : liste d’instructions n ; break ;
liste d’instructions n + 1 default : liste d’instructions n + 1 ;
FinSelon }

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Algorithmique
Algorithme Mois
Var n : entier
debut
Ecrire("N˚ du mois ?")
Lire(n)
Selon (n)
Cas 1 : Ecrire("Janvier")
Cas 2 : Ecrire("Fevrier")
Cas 3 : Ecrire("Mars")
.......
Cas 10 : Ecrire("Octobre")
Cas 11 : Ecrire("Novembre")
Cas 12 : Ecrire(Decembre)
Sinon
Ecrire("Incorrecte")
FinSelon
fin

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C
Introduction Structure Conditionnelle Simple S. C. Composée S. C. de choix multiple Le Branchement

Exemple
Algorithmique Programme C
Algorithme Mois #include <stdio.h>
Var n : entier int main()
debut {
Ecrire("N˚ du mois ?") int n ;
Lire(n) printf("N˚ du mois ?") ;
Selon (n) scanf("%d",&n) ;
Cas 1 : Ecrire("Janvier") switch (n)
Cas 2 : Ecrire("Fevrier") {
Cas 3 : Ecrire("Mars") case 1 : printf("Janvier") ; break ;
....... case 2 : printf("Fevrier") ; break ;
Cas 10 : Ecrire("Octobre") case 3 : printf("Mars") ; break ;
Cas 11 : Ecrire("Novembre") .......
Cas 12 : Ecrire(Decembre) case 10 : printf("Octobre") ; break ;
Sinon case 11 : printf("Novembre") ; break ;
Ecrire("Incorrecte") case 12 : printf("Decembre") ; break ;
FinSelon default : printf("Incorrecte") ;
fin }
return 0 ;
}

Tayeb BAHRAM Université Dr Tahar Moulay de Saida


Les Structures Conditionnelles en langage Algorithmique et en C