Vous êtes sur la page 1sur 63

Se familiariser avec les formules

En quelques étapes, vous serez en mesure de créer des formules et des fonctions dans Excel, le tableur le pl
puissant au monde.

Commencer >

Pour revenir au début, appuyez sur CTRL+ORIGINE. Pour commencer la visite, appuyez sur CTRL+PAGE SUIVANTE.
correspondant
e. Cela peut
rendre les
modifications
ultérieures
difficiles. Il est
préférable de
placer vos
constantes
dans des
Informations de base : faire des maths avec
Informations
Dans Excel,
cellules,
de base : faire des maths avec Excel
où vous pouvez additionner, soustraire, multiplier et diviser sans utiliser la moindre fonction intégrée. Il vous suffit d’utiliser quelques opérateurs de base : +, -, *, /. Toutes
Chiffres à utiliser : Opération :
elles
Pour peuvent
additionner, sélectionnez la cellule F3, entrez =C3+C4, puis appuyez sur la touche Entrée.
facilement
Excel
être ajustées
1 Addition (+)
Pour
et soustraire,
référencées
Pour sélectionnez la
multiplier, sélectionnez la cellule
cellule F5,
F4, entrez
entrez =C3*C4,
=C3-C4, puis
puis appuyez
appuyez sursur la
la touche
touche Entrée.
Entrée. 2 Soustraction (-)
dans vos
Pour diviser, sélectionnez la cellule F6, entrez =C3/C4, puis appuyez sur la touche Entrée. Multiplication (*)
formules. Dans Excel, vous pouvez additionner, soustraire, multiplier et diviser sans utiliser la Division (/)
moindre fonction intégrée. Il vous suffit d’utiliser quelques opérateurs de base : +, -,
Essayez
Par ça : modifiez
exemple les chiffres des cellules C3 et C4, et vous verrez que les résultats de la formule changent automatiquement. Puissance (^)
*, /.: Toutes les formules commencent par un signe égal (=).
sélectionnez la
BONUS SUPPLÉMENTAIRE : Pour élever une valeur à une puissance, utilisez le symbole accent circonflexe (^), par exemple, =A1^A2. Pour entrer ce symbole, appuyez sur ^+Espace
cellule jaune
Poursuivez
comportantvotre le lecture pour plus d’informations ESSAYEZ ÇA
Modifiez ces chiffres et vous
Étape suivante
nombre 1 Pour additionner, sélectionnez la cellule F3, entrez =C3+C4, puis appuyez
12 ci-
verrez que les résultats de la
dessous.
InformationsVouscomplémentaires
surcellules
la touche surEntrée.
les formules, les cellules et lesetplages
Excel
pouvez est composé de individuelles regroupées en lignes en colonnes. Les lignes sont numérotées, et les formule
colonnes sontchangent
représentées par des lettres. Plus d’un million de
constater que automatiquement.
nous
Dans avons 2 exemple
le troisième
utilisé la
Pour soustraire, sélectionnez
ci-dessus, vous la celluleque
pouvez constater F4,nous
entrez =C3-C4
avons utilisé, la
puis appuyez
fonction sur Une fonction est une commande prédéfinie qui, à partir d’une ou plusieurs
SOMME.
Les formules
fonction qui la touche
incluent des Entrée
fonctions. commencent par un signe égal, suivi du nom de la fonction, puis de ses arguments (valeurs utilisées par une fonction pour effectuer un cal
SOMME suivie
d’une plage de
cellules. Nous
Explications 3 Pour multiplier, sélectionnez la cellule F5, entrez =C3*C4, puis appuyez sur
n’avons pas sur leslaformules
touche
=10+20 est une formule,
directement dansEntrée.
laquelle 10 et 20 sont des constantes et le signe + est un opérateur.
entré « 4 » ou
=SOMME(A1:A10) est une formule, dans laquelle SOMME est le nom de la fonction, les parenthèses ouvrante et fermante contiennent les arguments de la formule, et A1:A10 est
« 8 » dans la
4 Pour diviser,
=SOMME(A1:A10;C1:C10)
formule. est unesélectionnez
formule, danslalaquelle
cellule SOMME
F6, entrezest=C3/C4,
le nom depuis appuyez
la fonction, lessur la
parenthèses ouvrante et fermante contiennent les arguments de la formule, et A1:
touche Entrée.
Précédent
Suivant
Poursuivez votre lecture pour plus Étape
Plus d’informations sur le web
d’informations suivante
Utiliser Excel comme calculatrice
Vue d’ensemble des formules dans Excel
Fonctions Excel (par catégorie)
Informations complémentaires sur les Opérateur Opérateur

formules, les cellules et les plages


Informations complémentaires sur les Opérateur Opérateur
Fonctions Excel (par ordre alphabétique)
formules, les cellules et les plages
Formation en ligne gratuite sur Excel
=A1+B1 =10+20
Excel est composé de cellules individuelles regroupées en lignes et en colonnes. Les
lignes sont numérotées, et les colonnes sont représentées par des lettres. Plus d’un Référence Référence
Constante
million de lignes et 16 000 colonnes sont disponibles, et vous pouvez insérer des de cellule de cellule
formules dans chacune d’entre elles.

Les formules peuvent contenir des références de cellule, des plages de références
de cellule, des opérateurs et des constantes. Les exemples suivants correspondent Fonction Argument
tous à des formules :

=A1+B1 =SOMME(A1:A10)
=10+20
=SOMME(A1:A10) Une plage de cellules comporte une cellule de début, deux
cellule de fin. Lorsque vous sélectionnez une plage de cellule
Dans le troisième exemple ci-dessus, vous pouvez constater que nous avons utilisé la une formule, Excel ajoute automatiquement les deu
fonction SOMME. Une fonction est une commande prédéfinie qui, à partir d’une ou
plusieurs valeurs, effectue un calcul et renvoie un résultat. Par exemple, la fonction
SOMME additionne les références ou plages de cellules que vous spécifiez. Dans cet
exemple, elle additionne les cellules A1 à A10. Excel propose plus de 400 fonctions,
que vous pouvez explorer sous l’onglet Formules. Fonction Argument

Les formules qui incluent des fonctions commencent par un signe égal, suivi du nom
de la fonction, puis de ses arguments (valeurs utilisées par une fonction pour
effectuer un calcul) entre parenthèses.
=SOMME(A1:A10;C
Pour confirmer une formule, appuyez sur la touche Entrée. La formule effectue alors Plage de cellules
le calcul et le résultat s’affiche dans la cellule. Pour voir la formule proprement dite,
consultez la barre de formule située sous le ruban, ou appuyez sur la touche F2 pour Parenthèse ouvrante
passer en mode Modifier afin d’afficher la formule dans la cellule. Appuyez de
nouveau sur la touche Entrée pour finaliser la formule et calculer le résultat.
Précédent Suivant

Plus d’informations sur le web


Utiliser Excel comme calculatrice

Vue d’ensemble des formules dans Excel

Fonctions Excel (par catégorie)

Fonctions Excel (par ordre alphabétique) 

Formation en ligne gratuite sur Excel


Formules : Réponses :
3
-1
2
0.5
1
bole, appuyez sur ^+Espace. Dans la cellule F7, entrez =C3^C4.
BONUS
SUPPLÉMENTAIRE
Pour élever une valeur à une
puissance,
lettres. Plus d’un million de lignes et 16 000utilisez le symbole
colonnes sont disponibles, et vous pouvez insérer des formules dans chacune d’entre elles.
accent circonflexe (^), par
exemple, =C3^C4. Pour entrer
ce symbole,
, à partir d’une ou plusieurs valeurs, effectueappuyez
un calculsur
et renvoie un résultat. Par exemple, la fonction SOMME additionne les références ou plages de cellules que vous spécifiez. Dans cet exe
^+Espace.
nction pour effectuer un calcul) entre parenthèses.

e la formule, et A1:A10 est la plage de cellules de la fonction.


ments de la formule, et A1:A10;C1:C10 sont les plages de cellules de la fonction séparées par une virgule.

BON À SAVOIR
Opérateur Les constantes sont des valeurs que vous entrez dans des cellules ou dans
des formules. Même si =10+20 permet d’effectuer le même calcul que
=A1+B1, nous vous déconseillons d’utiliser des constantes. Pourquoi ?
Parce qu’une constante n’est pas facile à voir sans rechercher et
sélectionner la cellule correspondante. Cela peut rendre les modifications
ultérieures difficiles. Il est préférable de placer vos constantes dans des
BON À SAVOIR
Opérateur Les constantes sont des valeurs que vous entrez dans des cellules ou dans
des formules. Même si =10+20 permet d’effectuer le même calcul que

=10+20 =A1+B1, nous vous déconseillons d’utiliser des constantes. Pourquoi ?


Parce qu’une constante n’est pas facile à voir sans rechercher et
sélectionner la cellule correspondante. Cela peut rendre les modifications
ultérieures difficiles. Il est préférable de placer vos constantes dans des
cellules, où elles peuvent facilement être ajustées et référencées dans vos
Constante Constante formules.

Par exemple : sélectionnez la cellule jaune comportant le nombre 12 ci-


dessous. Vous pouvez constater que nous avons utilisé la fonction
SOMME suivie d’une plage de cellules. Nous n’avons pas directement
entré « 4 » ou « 8 » dans la formule.
Argument

1:A10) Valeurs
4
e une cellule de début, deux-points et une
tionnez une plage de cellules pour l’ajouter à 8
e automatiquement les deux-points. 12

Des virgules séparent les différents arguments

Argument Argument

1:A10;C1:C10)
Plage de cellules Autre plage de cellules

ouvrante Parenthèse fermante. Généralement, Excel


l’ajoute automatiquement lorsque vous appuyez
sur la touche Entrée.
ue vous spécifiez. Dans cet exemple, elle additionne les cellules A1 à A10. Excel propose plus de 400 fonctions, que vous pouvez explorer sous l’onglet Formules.
placer
avec lades
également souris
et
nombres
les appuyez dans
sur
la touche
une formule
arguments
Entrée.
de ce type,
La
formule
cela est
obligatoires
additionne
déconseillé
et facultatifs. les
valeurs
sauf nécessité
des
cellules D3,
absolue. Il
D4, D5d’une
s’agit et D6.
Vous
constante,
Introduction aux fonctions
obtenez
Introduction
le résultat
est
Les
facile
fonctions
etaux
il fonctions
Examinons
suivant
d’oublier : 170. vous permettent d’effectuer différentes actions, comme des opérations mathématiques, des recherches Fruits Quantité
qu’elle
maintenant
Essayons estmaintenant
là. la fonctionnalité Somme automatique. Sélectionnez la cellule G7 du tableau Viande, puis accédezPommes à Formules > Somme automatique50 > et sélectionnez SOMM
Nous vousLes fonctions vous permettent d’effectuer différentes actions, comme des opérations Oranges 20
l’anatomie
recommandon de
quelques
Vous pouvez
s de plutôt mathématiques,
aussi utiliser undes recherches
raccourci clavier.deSélectionnez
valeurs ou la même
celluledes calculs
D15, de dates
puis appuyez suretAlt
d’heures.
= et sur Entrée. La Bananes 60
faire Nous
référence
fonctions.
Poursuivez allons essayer différentes
La lecture pour plus d’informations
votre méthodes pour additionner des valeurs avec la Citrons 40
BONUS SUPPLÉMENTAIRE
àUtilisez
une autre fonction SOMME.
structure
cellule, parde
la fonction NB avec l’une des méthodes que vous avez déjà essayées. La fonction NB compte le nombre de cellules SOMMEd’une> plage qui contient170
des nombres.
la fonction
Étape suivante
exemple la
cellule
SOMME F51.
Informations 1complémentaires
estEn
Sous la colonne Quantité du tableau Fruits (cellule D7), entrez
sur les fonctions Article Montant
effet, celle-ci =SOMME(D3:D6). Ou entrez =SOMME(, sélectionnez cette plage avec la
la suivante :
Si la fonction SOMME pouvait parler, elle Pain 50
est facilement souris et appuyez surdirait ceci : renvoyer
la touche Entrée. Lala somme
formuledeadditionne
toutes les valeurs des cellules
les valeurs des D38 à D41 et toutes celles de la colonne H. SOMME est le nom de la fonc
identifiable et Beignets 100
n’est pas AUJOURDHUI cellules D3, D4, D5 et D6. Vous obtenez le résultat suivant : 170.
La fonction
ESSAYEZ ÇAau renvoie la date du jour. Elle se met automatiquement à jour dès qu’Excel procède à un nouve
Cookies 40
dissimulée
sein d’une 2ces cellules.
Sélectionnez Essayons Puis, dans le coinlainférieur
maintenant droit deSomme
fonctionnalité la fenêtreautomatique.
Excel, recherchez SOMME : 170 sur la barre inférieure.
Sélectionnez GâteauxIl s’agit de la barre d’état,
50 qui vous permet de trouve
formule. la cellule jaune (G7) du tableau Viande, puis accédez à Formules > Somme Tartes 20
Plus d’informationsautomatique
sur le web > et sélectionnez SOMME. Excel entre automatiquement la SOMME >
À propos de la fonction SOMME
formule pour vous. Appuyez sur la touche Entrée pour confirmer. La
Utiliser Somme automatique pour Somme
fonctionnalité additionner des nombrescontient les fonctions les plus
automatique
À propos de la fonction NB
courantes.
Formation en ligne gratuite sur Excel
Retour au début 3 Vous pouvez aussi utiliser un raccourci clavier. Sélectionnez la cellule D15,
Étape suivante puis appuyez sur Aet l t sur Entrée.
= La fonction SOMME est
automatiquement entrée.

Poursuivez votre lecture pour plus Étape


d’informations suivante

Informations complémentaires sur les


fonctions
Informations complémentaires sur les
fonctions
Fruits Montant
Accédez à l’onglet Formules et parcourez la Bibliothèque de fonctions, dans laquelle Pommes 50
les fonctions sont répertoriées par catégorie (Texte, DateHeure, etc.). Insérer une Oranges 20
fonction vous permet de rechercher des fonctions par nom et de lancer un Assistant Bananes 60
pour vous aider à créer votre formule. Citrons 40
SOMME > 170
Lorsque vous commencez à entrer un nom de fonction après avoir appuyé sur =, Excel
lance la fonctionnalité IntelliSense, qui répertorie toutes les fonctions commençant par
les lettres que vous tapez. Dès que vous voyez la fonction souhaitée, appuyez sur Tab et
Excel entrera automatiquement le nom complet de la fonction ainsi que la parenthèse
ouvrante. Excel affichera également les arguments obligatoires et facultatifs. Article Montant
Voitures 20
Camions 10
Vélos 10
Patins 40

Examinons maintenant l’anatomie de quelques fonctions. La structure de la fonction Total :


SOMME est la suivante : 180

Nom de la Premier argument. Arguments


fonction. Celui-ci est supplémentaires,
presque toujours séparés par des DÉTAIL IMPORTANT
obligatoire. virgules (;). Double-cliquez sur cette cellule. Vous pouvez voir le
à la fin. Bien qu’il soit possible de placer des nombre
dans une formule de ce type, cela est déconseillé sau
nécessité absolue. Il s’agit d’une constante, et il est f
d’oublier qu’elle est là. Nous vous recommandons pl
de faire référence à une autre cellule, par exemple la
cellule F51. En effet, celle-ci est facilement identifiab
=SOMME(D38:D41;H:H) n’est pas dissimulée au sein d’une formule.

Si la fonction SOMME pouvait parler, elle dirait ceci : « Renvoyer la somme de


toutes les valeurs des cellules D38 à D41 ainsi que celles de la colonne H ».

Essayons à présent une formule qui ne nécessite aucun argument.


=SOMME(D38:D41;H:H)
Si la fonction SOMME pouvait parler, elle dirait ceci : « Renvoyer la somme de
toutes les valeurs des cellules D38 à D41 ainsi que celles de la colonne H ».

Essayons à présent une formule qui ne nécessite aucun argument.

La fonction AUJOURDHUI renvoie la date du jour. Elle se met


automatiquement à jour dès qu’Excel procède à un nouveau calcul.

=AUJOURDHUI()

Plus d’informations sur le web


À propos de la fonction SOMME

Utiliser Somme automatique pour additionner des nombres

À propos de la fonction NB

Formation en ligne gratuite sur Excel


Formation en ligne gratuite sur Excel
Retournez au début en appuyant sur CTRL+ORIGINE. Pour passer à l’étape suivante, appuyez sur CTRL+ PAGE SUIVANTE.

Étape
Retour au début
suivante
Viande Quantité
Bœuf 50
Poulet 30
Porc 10
Poisson 50
SOMME >

Article Quantité
Pain 50
Beignets 100
Cookies 40
Gâteaux 50
Tartes 20
NB >

BONUS
SUPPLÉMENTAIRE
Utilisez la fonction NB avec l’une des
méthodes que vous avez déjà
essayées. La fonction NB compte le
nombre de cellules d’une plage qui
contient des nombres.
ESSAYEZ ÇA
Sélectionnez ces cellules. Dans le coin inférieur
droit de la fenêtre Excel, recherchez ceci :

Il s’agit de la barre d’état, qui vous permet de


trouver rapidement un total ainsi que d’autres
informations sur une cellule ou une plage
sélectionnée.

Valeur supplémentaire Nouveau Total


100 180

PORTANT
sur cette cellule. Vous pouvez voir le 100
il soit possible de placer des nombres
le de ce type, cela est déconseillé sauf
ue. Il s’agit d’une constante, et il est facile
est là. Nous vous recommandons plutôt
ce à une autre cellule, par exemple la
effet, celle-ci est facilement identifiable et
ulée au sein d’une formule.
BONUS
SUPPLÉMENTA
IRE
Essayez
d’utiliser ici
MEDIANE ou
MODE.
ESSAYEZ
Fonction ÇA
MEDIANE
renvoie
MOYENNE
une
valeur
Fonction MOYENNE
Sélectionnez
la
plage
qui de
Utilisez
nombres la se
fonction MOYENNE pour obtenir la moyenne des nombres d’une plage de cellules. Fruits Quantité
trouve auet
Sélectionnez
consultez
centre Utilisez la fonction MOYENNE pour obtenir la moyenne des nombres
de la la cellule D7, puis utilisez Somme automatique pour ajouter une fonction MOYENNE. d’une plage Pommes 50
barre d’état
l’ensemble
Sélectionnez dedecellules.
maintenant la cellule G7, et entrez une fonction MOYENNE en tapant =MOYENNE(G3:G6). Oranges 20
pour connaître
données,
À
la la cellule
que D15, vous pouvez utiliser Somme automatique ou entrer manuellement une autre fonction MOYENNE.
moyenne.
tandis Bananes 60
MODE renvoie 1 Sélectionnez la cellule D7, puis utilisez Somme automatique pour ajouter Citrons 40
la valeur la une
Activer la feuille précédente fonction MOYENNE. MOYENNE >
plus
Accéder
fréquente.à la feuille suivante
2 Sélectionnez maintenant la cellule G7, puis entrez une fonction MOYENNE Article Quantité
en tapant =MOYENNE(G3:G6).
Liens pour accéder à des informations complémentaires sur le web Pain 50
Sélectionnez ce lien pour accéder sur le web à des informations complémentaires sur la fonction MOYENNE Beignets 100
Cookies 40
3
Sélectionnez ce lien pour accéder sur le web à des informations complémentaires sur la
À la cellule D15, vous pouvez utiliser Somme automatique ou entrer fonction MEDIANE
Gâteaux 50
Sélectionnez ce lien pour accéder sur leune
manuellement webautre
à des fonction
informations complémentaires sur la fonction MODE
MOYENNE.
Sélectionnez ce lien pour accéder sur le web à une formation gratuite sur Excel Tartes 20
Précédent Suivant MOYENNE >

Précédent Suivant

Plus d’informations sur le web


À propos de la fonction MOYENNE

À propos de la fonction MEDIANE

À propos de la fonction MODE

Formation en ligne gratuite sur Excel


Informations complémentaires sur la fonction SOMME
Dans certains conseils ci-dessus, nous vous avons appris à uti
Les cellules C37 à D41 contiennent des données réparties su
La formule de la cellule D42 est =SOMME(D38:D41).
Si la fonction SOMME de la cellule D42 pouvait parler, voici c
Vous pouvez également utiliser cette fonction de la manière
Les cellules C47 à D48 contiennent des données réparties su

Plus d’informations sur le web


À propos de la fonction SOMME
À propos de la fonction SOMME.SI
Utiliser Excel comme calculatrice
Formation en ligne gratuite sur Excel
Retournez au début en appuyant sur CTRL+ORIGINE. Pour pa
Viande Montant
Bœuf 50 ESSAYEZ ÇA
Sélectionnez une plage de
Poulet 30 nombres et consultez la barre
Porc 10 d’état pour connaître la
Poisson 50 moyenne.
MOYENNE >

Article Quantité
Pain 50
Beignets 100
Cookies 40
Gâteaux 50
Tourtes 20

BONUS
SUPPLÉMENTAIRE
Essayez d’utiliser ici la fonction
MEDIANE ou MODE.
MEDIANE renvoie la valeur qui se
trouve au centre de l’ensemble de
données, tandis que MODE
renvoie la valeur la plus
fréquente.

entaires sur la fonction SOMME


i-dessus, nous vous avons appris à utiliser la fonction SOMME. Voici des informations complémentaires à ce sujet.
ontiennent des données réparties sur deux colonnes : Fruits et Montant.
D42 est =SOMME(D38:D41).
e la cellule D42 pouvait parler, voici ce qu’elle dirait : Additionner les valeurs des cellules D38, D39, D40 et D41.
utiliser cette fonction de la manière suivante :
ontiennent des données réparties sur deux colonnes : Article et Quantité.

uite sur Excel


appuyant sur CTRL+ORIGINE. Pour passer à l’étape suivante, appuyez sur CTRL+PAGE SUIVANTE.
BON À SAVOIR
Vous pouvez
utiliser MIN ou
MAX avec
plusieurs plages,
Sélectionnez
ou avec des la
cellule
valeursD7, pourpuis
utilisez
À
renvoyer la D15,
la cellule plus
l’Assistant
vous pouvez
Fonctions MIN et MAX
grande ou la
Sélectionnez
Somme
utiliser
maintenant
plus petiteMIN
Fonctions de
la et MAX
l’Assistant
automatique
cellule
ces valeurs,
G7 etpar Fruits Quantité
Somme
Utilisez
pour ajouter
la fonction MIN pour obtenir le nombre minimum d’une plage de cellules.
exemple,
entrez une
automatique
une fonction ou
Utilisez la fonction MINle pour obtenir le plus
=MIN(A1:A10;B
Utilisez
fonction
entrer laMAX
fonction MAX pour obtenir nombre maximum d’unepetit
plagenombre d’une plage de cellules.
de cellules. Pommes 50
MIN.
1:B10) ou Utilisez la fonction MAX pour obtenir le plus grand nombre d’une plage de cellules.
en tapant Oranges 20
manuellement
=MAX(A1:A10;B
=MAX(D3:D6).
une
Plusoù
1), fonction
B1 Bananes 60
MIN ou MAX.
contient
valeur 1
une
d’informations
seuil, par
sur le web
Sélectionnez la cellule D7, puis utilisez l’Assistant Somme automatique Citrons 40
exemple 10, pour ajouter une fonction MIN. MIN >
auquel cas la
À proposne
formule de la fonction MIN
renverra 2
À proposjamais Sélectionnez
de la fonction MAX maintenant la cellule G7 et entrez une fonction MAX en Article Quantité
un résultat
Formation tapantsur
en ligne gratuite =MAX(D3:D6).
Excel Pain 50
inférieur à 10.
Beignets 100
3 À la cellule D15, vous pouvez utiliser l’Assistant Somme automatique ou Cookies 40
entrer manuellement une fonction MIN ou MAX. Gâteaux 50
Tartes 20
MIN ou MAX >
Précédent Suivant

BON À SAVOIR
Vous pouvez utiliser MIN ou MAX a
Plus d’informations sur le web
Vous pouvez utiliser MIN ou MAX avec plusieurs plages, ou avec des valeurs pour renvoyer la plus grande ou la plus petite de ces valeurs, par exemple, =MIN(A1:A10;B1:B10) ou =MAX(A1:A10;10)
plages, ou avec des valeurs pour ren
grande ou la plus petite de ces valeu
Plus d’informations sur le web exemple, =MIN(A1:A10;B1:B10) ou
À MIN
propos de la fonction MIN =MAX(A1:A10;B1), où B1 contient u
À propos de la fonction par exemple 10, auquel cas la formu
À propos de la fonction MAX jamais un résultat inférieur à 10.
À propos de la fonction MAX
Utiliser Excel comme calculatrice
Formation en ligne gratuite sur Excel
Formation en ligne gratuite sur Excel
Viande Montant
Bœuf 50
Poulet 30
Porc 10
Poisson 50
MAX >

Article Quantité
Pain 50
Beignets 100
Cookies 40
Gâteaux 50
Tourtes 20
10

BON À SAVOIR
Vous pouvez utiliser MIN ou MAX avec plusieurs
N(A1:A10;B1:B10) ou =MAX(A1:A10;10).
plages, ou avec des valeurs pour renvoyer la plus
grande ou la plus petite de ces valeurs, par
exemple, =MIN(A1:A10;B1:B10) ou
=MAX(A1:A10;B1), où B1 contient une valeur seuil,
par exemple 10, auquel cas la formule ne renverra
jamais un résultat inférieur à 10.
entré votre
1/01/2017
date
12:30 est
d’anniversaire,
représenté
vous pouvez
sous la forme
utiliser une
suivante :
fonction SI
42736.5208. Si
telle queoucelle-
l’heure la
ci pour
date
empêcher
apparaissent
Excel d’afficher
sous
Fonctions
un nombre
forme,
négatif
Fonctions de date
cette
vous
:
de date
Excel peut vous donner la date actuelle, telle que définie dans les paramètres régionaux de votre ordinateur. Vous pouvez également ajouter et soustraire des dates.
pouvez
=SI(D7="";"";D
appuyer
7-D6),
La cesur
fonction quiAUJOURDHUI renvoie la date du jour. Il s’agit d’une fonction dite « volatile » car elle est quotidiennement mise à jour. Ainsi, en rouvrant votre classeur demain, vous y v
Ctrl+1 > Excel
signifie « SI D7 peut vous donner la date actuelle, telle que définie dans les paramètres
Nombre
Soustraire > et
des dates : de
entrez la date de votreVous
prochain anniversaire au format
n’est égal àrégionaux
sélectionner votre ordinateur. pouvez également ajouterJJ/MM/AA dansdes
et soustraire la cellule D7 et Excel indiquera le nombre de jours restants dans la cellule D8 en utili
Ajouter
rien, ne des
rien
dedates : supposons que vous voulez connaître la date d’échéance d’une facture ou savoir quand vous devez rendre un livre à la bibliothèque.
dates. Vous pouvez ajouter des jo
un format
afficher, sinon Fonctions de date
Date ou D7
afficher
moins D6 ». 1
d’Heure. La fonction AUJOURDHUI renvoie la date du jour. Il s’agit d’une fonction dite Date du jour :
« volatile » car elle est quotidiennement mise à jour. Ainsi, en rouvrant votre Votre anniversaire :
Fonctions
Excel peutd’heure classeur
vous donner demain,
l’heure vous
actuelle, y verrez
telle la date
que définie deles
dans demain. Dansrégionaux
paramètres la cellulede
D6, entrez
votre Jourségalement
ordinateur. Vous pouvez restants avant votre
ajouter ou anniversaire : heures. Par exempl
soustraire des
Dans la cellule D28,=AUJOURDHUI().
entrez =MAINTENANT(). Cette fonction renvoie l’heure actuelle et se met à jour à chaque calcul d’Excel. Pour changer le format d’heure, accédez à Ctrl+1 > No
Délai de grâce (en jours) :
2 Soustraire des dates : entrez la date de votre prochain anniversaire au format Date d’échéance de la facture :
JJ/MM/AA dans la cellule D7 et Excel indiquera le nombre de jours restants
Si cette formule pouvait parler, elle dirait ceci : « Prendre l’Heure d’arrivée et l’Heure de départ, puis soustraire les heures de Début de déjeuner/Fin de déjeuner, et multiplier celle
dans la cellule D8 en utilisant la formule =D7-D6.
Précédent
Suivant BON À SAVOIR
3 Ajouter des dates : supposons que vous voulez connaître la date d’échéance
Plus d’informations sur le web Pour représenter les dates, Excel c
d’une facture ou savoir quand vous devez rendre un livre à la bibliothèque. jours écoulés depuis le 1 janvier 19
À propos de la fonction VousAUJOURDHUI
pouvez ajouter des jours à une date. Dans la cellule D10, entrez un exprimées en fractions de journée
À propos de la fonction MAINTENANT nombre de minutes. Par exemple,
nombre de jours aléatoire. Nous avons entré la formule =D6+D10 dans la est représenté sous la forme suiva
À propos de la fonction DATE
cellule D11 pour calculer la date d’échéance à partir d’aujourd'hui. l’heure ou la date apparaissent so
Formation en ligne gratuite sur Excel pouvez appuyer sur Ctrl+1 > Nomb
un format de Date ou d’Heure.

Fonctions d’heure
Excel peut vous donner l’heure actuelle, telle que définie dans les paramètres
régionaux de votre ordinateur. Vous pouvez également ajouter ou soustraire des Fonctions d’heure
heures. Par exemple, vous pouvez suivre le nombre d’heures de travail
hebdomadaires d’un employé pour calculer son salaire et ses heures
supplémentaires.
Excel peut vous donner l’heure actuelle, telle que définie dans les paramètres
régionaux de votre ordinateur. Vous pouvez également ajouter ou soustraire des
heures. Par exemple, vous pouvez suivre le nombre d’heures de travail Heure actuelle :
hebdomadaires d’un employé pour calculer son salaire et ses heures
supplémentaires.
Heures de travail quotidiennes
1 Dans la cellule D28, entrez =MAINTENANT(). Cette fonction renvoie Heure d’arrivée :
l’heure actuelle et se met à jour à chaque calcul d’Excel. Pour changer le Début du déjeuner :
format d’heure, accédez à Ctrl+1 > Nombre > Heure > et sélectionnez le Fin du déjeuner :
format souhaité.
Heure de départ :
Nombre total d’heures :
2 Additionner des heures : à la cellule D36, nous avons entré la formule
=((D35-D32)-(D34-D33))*24, qui calcule les heures de début et de fin
d’un employé, puis soustrait le temps qu’il a pris pour déjeuner. En fin de
formule, *24 convertit en heures la fraction de la journée prise en compte
par Excel. Mais vous allez devoir sélectionner le format Nombre pour la
cellule. Pour ce faire, accédez à Accueil > Format > Cellules (Ctrl+1) >
Nombre > Nombre > 2 décimales.

3 Si cette formule pouvait parler, elle dirait ceci : « Prendre l’Heure d’arrivée
et l’Heure de départ, puis soustraire les heures de Début de déjeuner/Fin Date et heure statiques
de déjeuner, et multiplier celles-ci par 24 pour convertir le temps Date :
fractionné d’Excel en heures », ou =((Heure d’arrivée-Heure de départ)- Heure :
(Début du déjeuner-Fin du déjeuner))*24.

*24 pour convertir la


Heure de Début du fraction de journée
départ déjeuner d’Excel en heures BON À SAVOIR
Vous pouvez utiliser les raccourcis clavier po
entrer des dates et heures statiques :

Date : Ctrl+;
=((D35-D32)-(D34-D33))*24 Heure : Ctrl+:

Heure d’arrivée Fin du déjeuner


Les parenthèses intérieures () indiquent à Excel de calculer
séparément les portions correspondantes de la formule. Les parenthèses extérieures
indiquent à Excel de multiplier le résultat final des calculs intérieurs par 24.

Précédent Suivant

Plus d’informations sur le web


À propos de la fonction AUJOURDHUI

À propos de la fonction MAINTENANT

À propos de la fonction DATE

Formation en ligne gratuite sur Excel


re des dates.

e classeur demain, vous y verrez la date de demain. Dans la cellule D6, entrez =AUJOURDHUI().
s dans la cellule D8 en utilisant la formule =D7-D6.

de date

DÉTAIL IMPORTANT
ire des heures. Par exemple, 0vous pouvez suivre le nombre
Si vous d’heures
n’avez pas encorede travail
entré hebdomadaires
votre d’un employé pour calculer son salaire et ses heures supplémentaires.
date d’anniversaire,
vous pouvez utiliser une fonction SI telle que celle-ci pour
empêcher Excel d’afficher un nombre négatif :
=SI(D7="";"";D7-D6), ce qui signifie « SI D7 n’est égal à
30/12/99 rien, ne rien afficher, sinon afficher D7 moins D6 ».
déjeuner, et multiplier celles-ci par 24 pour convertir le temps fractionné d’Excel en heures », ou =((Heure d’arrivée-Heure de départ)-(Début du déjeuner-Fin du déjeuner))*24.

À SAVOIR
présenter les dates, Excel compte le nombre de
oulés depuis le 1 janvier 1900. Les heures sont
ées en fractions de journée basées sur le
e de minutes. Par exemple, 01/01/2017 12:30
ésenté sous la forme suivante : 42736.5208. Si
ou la date apparaissent sous cette forme, vous
appuyer sur Ctrl+1 > Nombre > et sélectionner
mat de Date ou d’Heure.

d’heure
quotidiennes
8:00
12:00
13:00
17:00
8

statiques
27/09/17
8:52

OIR
ser les raccourcis clavier pour
et heures statiques :

Date : Ctrl+;
Heure : Ctrl+:
Combiner
Combiner du texte à partir de différentes
Dans Excel,duil est
texte à partirutile
souvent de différentes
de combiner cellules
du texte réparti dans des cellules différentes. Cet exemple est très courant : vous disposez de prénoms et de noms que vous souhaitez
Prénom
Dans la cellule E3, entrez =D3&C3 pour combiner les noms et prénoms.
cellules
Cela dit, la forme DurandNicole n’est pas idéale. Une virgule et un espace doivent être ajoutés. Pour ce faire, nous allons Nicole
utiliser des guillemets afin de créer une nouvelle chaîne d
Roger
Pour créer le nom complet, nous allons combiner le prénom et le nom, mais utiliser un espace sans virgule. Dans la cellule F3, entrez =C3&" "&D3.
Dans Excel, il est souvent utile de combiner du texte réparti dans des cellules Jean
Poursuivezdifférentes.
votre lecture pour
Cet plus d’informations
exemple est très courant : vous disposez de prénoms et de noms que Marie
Suivant vous souhaitez combiner sous la forme « Prénom, Nom » ou « Nom complet ». Pour Stéphane
Combinerce dufaire,
texte vous
et despouvez
nombres utiliser le signe esperluette (&), disponible sous la touche & du Raymond
Examinez les cellules
clavier.
Dans la cellule C28:D29.
C36, entrez Comme
=C28&" vous pouvez le constater, laAAAA-MM-JJ
"&TEXTE(D28;"AAAA-MM-JJ"). date et l’heure figurent dans
correspond des de
au code cellules
formatdistinctes. Vous
françaisRobert pouvez les combiner
Année/Mois/Jour, avec 2017-09-25.
par exemple le symbole &, comme dans
Yvonne
1 Dans la cellule E3, entrez =D3&C3 pour combiner les noms et prénoms.
=C28 & " "
À APPROFONDIR& TEXTE(D28;"AAAA-MM-JJ")
Si vous ne savez pas quel code de format utiliser, vous pouvez utiliser Ctrl+1 > Nombre pour appliquer le format de votre choix à une cellule. Sélectionnez ensuite l’option Personn
2 Cela
Plus d’informations
dit, la forme DurandNicole n’est pas idéale. Une virgule et un espace
sur le web
doivent être ajoutés. Pour ce faire, nous allons utiliser des guillemets afin
À propos de la fonction TEXTE
de créer une nouvelle chaîne de texte. Cette fois, entrez =D3&", "&C3. La
Combiner du texte et des nombres
portion &", "& nous permet d’ajouter une virgule et un espace au texte
Formation en ligne gratuite sur Excel
des cellules.

3 Pour créer le nom complet, nous allons combiner le prénom et le nom, mais
utiliser un espace sans virgule. Dans la cellule F3, entrez =C3&" "&D3.

Poursuivez votre lecture pour plus


Suivant
d’informations

Utiliser du texte et des nombres


Date du jour :
Heure actuelle :
Combiner du texte et des nombres
Combiner du texte et des nombres
Combiner du texte et des nombres
Date du jour : 43435
Nous allons maintenant utiliser le symbole & pour combiner du texte et des nombres.
Heure actuelle : 43435.3977083199
Examinez les cellules C28:D29. Comme vous pouvez le constater, la date et l’heure
figurent dans des cellules distinctes. Vous pouvez les combiner avec le symbole &, Mise en forme de texte et de nombres
comme dans les cellules C32:C33, mais le résultat ne convient pas. Dans la mesure où Date du jour : Shabbat-09-JJ
Excel n’est pas capable de deviner de quelle façon vous souhaitez afficher les chiffres, Heure actuelle : 9:32
il retourne la date au format de base, sous forme de numéros de série. Nous devons
explicitement indiquer à Excel comment mettre en forme la portion numérique de la
formule afin qu’il l’affiche au format de notre choix dans la chaîne de texte qui en
résulte. Pour ce faire, nous allons utiliser la fonction TEXTE et un code de format.

À APPROFONDIR
Si vous ne savez pas quel code de format utiliser, vous
1 Dans la cellule C36, entrez =C28&" "&TEXTE(D28;"AAAA-MM-JJ"). pouvez utiliser Ctrl+1 > Nombre pour appliquer le
format de votre choix à une cellule. Sélectionnez
AAAA-MM-JJ correspond au code de format français Année/Mois/Jour, par
ensuite l’option Personnalisée. Vous pouvez alors copier
exemple 2017-09-25. le code de format affiché dans votre formule.

2 Dans la cellule C37, entrez =C29&" "&TEXTE(D29;"H:MM"). H:MM


correspond au code de format français Heures:Minutes, par exemple 13:30.

Précédent Suivant

Plus d’informations sur le web


À propos de la fonction TEXTE

Combiner du texte et des nombres


Combiner du texte et des nombres

Formation en ligne gratuite sur Excel


Nom Nom, Prénom Nom complet
Durand Durand, Nicole Nicole Durand
Neurisse
Michelet
Jamet
Tessier
Normand
Troyat
Martin

ctionnez ensuite l’option Personnalisée. Vous pouvez alors copier le code de format affiché dans votre formule.

Date du jour : Shabbat-09-JJ

et des nombres
01/12/18
9:32
et des nombres

ESSAYEZ ÇA
xte et de nombres Les formules sont parfois difficiles à lire, en
particulier lorsqu’elles sont longues, mais
vous pouvez séparer des portions de celles-
ci à l’aide d’espaces, comme dans l’exemple
suivant :

=C28 & " " & TEXTE(D28;"AAAA-MM-JJ")

code de format utiliser, vous


ombre pour appliquer le
ne cellule. Sélectionnez
lisée. Vous pouvez alors copier
dans votre formule.
une
pour
cellule instruction
entrer
D12. ce
avons
SI pour
terme.
Nous y Ilavons
configuré s’agit
calculer
d’une
entré les
plage
la
TaxeVente
frais de port, en
CONSEIL
nommée,
formule
tant que quesi
plage
ceux-ci
D’EXPERT
nous avons
=SI(C12<100;"I
nommée
s’appliquent.
Copiez
Les plages avec
entrée
nférieur
une
Dans àlecellule
valeur
la àpartir
de
La
de cellule
contenu
nommées
Formules
100";"Supérie deF35
vous
la>
0,0825.
D9, entrez
contient
cellule
permettent D9 Notre
la dans
Définir
ur ou égal
formule
=SI(C9="Pomm un dit à de
formule
la
définir
cellule
nom.
100"). des D10.
ceci
La
termes : siQue
e";VRAI;FAUX).
=SI(E35="Oui";
réponse la se
ou est
Désormais, si
Instructions SI
passe-t-il
cellule
La bonne E33 si est
Instructions
SOMME(D28:D
FAUX
valeurs
vous carà un
souhaitez
entrez une SI
égale
réponse
29)*1,25;0).
orange
emplacement, est un
à n’est
Oui,
Les
modifier
nombreinstructions
multiplier
VRAI. vos
la SI vous permettent d’établir des comparaisons logiques entre les conditions. Une instruction SI dit généralement ceci : si une condition est vraie, faire telle chose. S
Cette
pas
puis
frais une
supérieurde
deformule
les
port,
ou il
cellule
signifie
pomme.
réutiliser F31
ceci par
à de :
vous
égal àsuffira
TaxeVente, 100
« Si la
d’autres
les
dans changercellule
la celluleLesà instructions SI vous permettent d’établir des comparaisons logiques entre les
sinon
E35 est
emplacements Oui,
un
C12 seul
?
retourner conditions. Une instruction SI dit généralement ceci : si une condition est vraie, faire
Contrairement
calculer
du classeur.
emplacement, la 0. à d’autres termes employés dans les formules Excel, il n’est pas nécessaire de mettre VRAI et FAUX entre guillemets, et Excel les met automatiquement en majuscu
Pour
et vous detelle
afficher la chose. Sinon, faire autre chose. Les formules peuvent renvoyer du texte, des
=SI(C3="Pomme";"Oui";"Non")
somme
Remplacez
colonne
toutes les Oui ou d’autres calculs.
valeurs
Poursuivez
pourrez
par Non dans votre lecture pour plus d’informations
Quantité
plages
ensuite du Instructions SI
Suivant
la celluleci-E33
tableau
nommées
réutiliser lede1
et vous
Association
dessus,
ce classeur, puisde de Dans la
la l’instruction cellule D9, entrez
SI et d’une forcer =SI(C9="Pomme";VRAI;FAUX).
autre fonction La bonne Pomme
Les
terme instructions
constaterez Frais SI peuvent également l’exécution de calculs supplémentaires si une condition donnée est remplie. Nous allons ici évaluer une cellule pour déterminer si une
multiplier
accédez
port à
n’importe par réponse est VRAI. Orange
que
1,25,
Formuleslesinon
résultat
où dans
change. le>
retourner
classeur. 0 ».
Gestionnaire
de noms. 2 Copiez le contenu de la cellule D9 dans la cellule D10. La réponse est FAUX 50
Cliquez ici car une orange n’est pas une pomme.
BON
pour À enSAVOIR
savoir
Lorsque
plus. vous créez une formule, Excel affiche automatiquement des bordures de couleur autour des plages référencées par la formule, et les plages correspondantes apparaissen
3 Prenons un autre exemple : examinez la cellule D12. Nous y avons entré la DÉTAIL IMPORTANT
Précédent formule =SI(C12<100;"Inférieur à 100";"Supérieur ou égal à 100"). Que Contrairement à d’autres termes employés da
formules Excel, il n’est pas nécessaire de mettr
Suivant se passe-t-il si vous entrez un nombre supérieur ou égal à FAUX entre guillemets, et Excel les met autom
Plus d’informations100 sur dans
le webla cellule C12 ? en majuscules. Il n’est pas non plus nécessaire
À propos de la fonction SI les chiffres entre guillemets. Les termes ou exp
ordinaires, tels que Oui ou Non doivent être m
À propos de la Poursuivez fonction SI.CONDITIONS
votre lecture pour plus guillemets. Par exemple :
Instructions SI avancées Suivant =SI(C3="Pomme";"Oui";"Non")
d’informations
Formation en ligne gratuite sur Excel

Association de l’instruction SI et d’une autre Article


fonction Machin
Bidule
Les instructions SI peuvent également forcer l’exécution de calculs supplémentaires
si une condition donnée est remplie. Nous allons ici évaluer une cellule pour
déterminer si une taxe doit s’appliquer à la vente, et calculer celle-ci si la condition
est vraie.
Les instructions SI peuvent également forcer l’exécution de calculs supplémentaires
si une condition donnée est remplie. Nous allons ici évaluer une cellule pour
déterminer si une taxe doit s’appliquer à la vente, et calculer celle-ci si la condition
est vraie.

1 À la cellule F33, nous avons entré la formule


=SI(E33="Oui";F31*TaxVente;0), dans laquelle nous avons configuré
TaxeVente en tant que plage nommée avec une valeur de 0,0825. Notre
formule dit ceci : si la cellule E33 est égale à Oui, multiplier la cellule F31 par
TaxeVente, sinon retourner 0.

Remplacez Oui par Non dans la cellule E33 et vous constaterez que le résultat
change.

2 Nous avons ensuite ajouté une instruction SI pour calculer les frais de port, CONSEIL D’EXPERT
si ceux-ci s’appliquent. La cellule F35 contient la formule Les plages nommées vous permettent de définir des
termes ou valeurs à un emplacement, puis de les
=SI(E35="Oui";SOMME(D28:D29)*1,25;0). Cette formule signifie ceci : réutiliser à d’autres emplacements du classeur. Pour
« Si la cellule E35 est Oui, calculer la somme de la colonne Quantité du afficher toutes les plages nommées de ce classeur,
tableau ci-dessus, puis la multiplier par 1,25, sinon retourner 0 ». accédez à Formules > Gestionnaire de noms. Cliquez ici
pour en savoir plus.

3 Ensuite, dans la formule de la cellule F35, remplacez 1,25 par "Frais de


port". Lorsque vous commencez à taper les premières lettres, la fonction de
correction automatique d’Excel affiche le terme pour vous. Appuyez alors
sur Tab pour entrer ce terme. Il s’agit d’une plage nommée, que nous
avons entrée à partir de Formules > Définir un nom. Désormais, si vous
souhaitez modifier vos frais de port, il vous suffira de les changer à un seul
emplacement, et vous pourrez ensuite réutiliser le terme Frais de port
n’importe où dans le classeur.

Précédent Suivant

Plus d’informations sur le web


Plus d’informations sur le web
À propos de la fonction SI

À propos de la fonction SI.CONDITIONS

Instructions SI avancées

Formation en ligne gratuite sur Excel


nt ceci : si une condition est vraie, faire telle chose. Sinon, faire autre chose. Les formules peuvent renvoyer du texte, des valeurs ou d’autres calculs.

ets, et Excel les met automatiquement en majuscules. Il n’est pas non plus nécessaire de mettre les chiffres entre guillemets. Les termes ou expressions ordinaires, tels que Oui ou Non doiven

Instructions SI

Inférieur à 100

ormule, et les plages correspondantes apparaissent dans la même couleur au sein de la formule proprement dite. Ces couleurs sont également visibles si vous sélectionnez la cellule F33 et ap
DÉTAIL IMPORTANT
Contrairement à d’autres termes employés dans les
formules Excel, il n’est pas nécessaire de mettre VRAI et
FAUX entre guillemets, et Excel les met automatiquement
en majuscules. Il n’est pas non plus nécessaire de mettre
les chiffres entre guillemets. Les termes ou expressions
ordinaires, tels que Oui ou Non doivent être mis entre
guillemets. Par exemple :
=SI(C3="Pomme";"Oui";"Non")

Quantité Coût Total


2 9.76 € 19.52 €
3 3.42 € 10.26 €
Sous-total 13.18 € 29.78 €

Taxe de vente ? Oui 2.46 € BON À SAVOIR


Lorsque vous créez une formule, Excel affiche
automatiquement des bordures de couleur autour des
Frais de port ? Oui 6.25 € plages référencées par la formule, et les plages
correspondantes apparaissent dans la même couleur au
sein de la formule proprement dite. Ces couleurs sont
Total 38.48 € également visibles si vous sélectionnez la cellule F33 et
appuyez sur F2 pour modifier la formule.

NSEIL D’EXPERT
lages nommées vous permettent de définir des
es ou valeurs à un emplacement, puis de les
iser à d’autres emplacements du classeur. Pour
her toutes les plages nommées de ce classeur,
dez à Formules > Gestionnaire de noms. Cliquez ici
en savoir plus.
naires, tels que Oui ou Non doivent être mis entre guillemets. Par exemple :

us sélectionnez la cellule F33 et appuyez sur F2 pour modifier la formule.


de la cellule
gestion
2;FAUX). Pour
D43 comme
d’erreur
l’article
ceci :
SIERREUR
Pommes, laà la
cellule G43 :
bonne réponse
=SI(C43="";"";
=SIERREUR(RE
est 50.
RECHERCHEV(
CHERCHEV(F4
RECHERCHEV a
C43;C37:D41;2
3;F37:G41;2;F
recherché
Faites
;FAUX))
AUX);"").
l’article
maintenant La un
fonction
Pommes
essai avec puis,
la
Cette formule
RECHERCHEV
SIERREUR
après
section l’avoir
RECHERCHEV
signifie
RECHERCHEV
signifie : si
ceci la est l’une des fonctions les plus fréquemment utilisées dans Excel (et l’une de nos préférées). Elle permet de rechercher une valeur dans une colonne située à gauche
trouvé,
Viande,C43
cellule à la : si
est
la fonction
passé
cellule àG22.
la
n’est égale
RECHERCHEV
colonne deà
=RECHERCHEV(A1;B:C;2;FAUX)
Vous
rien devez
(""), ne
renvoie
droite
obtenir un
etla aRECHERCHEV est l’une des fonctions les plus fréquemment utilisées dans Excel (et
Que
rien renvoyer,
résultat
renvoyé voulez-vous
valide,
le rechercher ?
formule l’une de nosvous
préférées). Elle àpermet dederechercher unela valeur dans une colonne
sinon
nombre
suivante
renvoyer
l’afficher,
Si vous trouvez:sinon ce que recherchez, combien colonnes sur droite voulez-vous afficher située
une valeur ?
les
ne résultats
rien
correspondant à de
gauche et, si elle trouve une correspondance, elle renvoie des informations dans
Où voulez-vous effectuer la recherche ?
=RECHERCHEV
la fonction
afficher
.(F22;F17:G20;("").
une autre colonne située à droite. RECHERCHEV dit ceci :?
RECHERCHEV.
Souhaitez-vous
Nous n’avons obtenir une correspondance parfaite ou approximative
2;FAUX).
Notez que
ici rien affiché Que voulez-vous Si vous trouvez ce que vous recherchez,
nous avons
(""), mais vous
ajouté rechercher ? à combien de colonnes sur la droite
pouvezune
EXPÉRIMENTEZ
voulez-vous afficher une valeur
deuxième
Essayez de sélectionner différents éléments dans les listes déroulantes.
également Vous verrez alors que ?les cellules de résultat affichent instantanément de nouvelles valeurs.
parenthèse
utiliser des votre lecture pour plus d’informations
Poursuivez
fermante à la2,
chiffres (0,1,
Suivant
fin de la
etc.) ou du
formule.
RECHERCHEV
texte (par Celle-et #N/A
Parfois,
ci ferme
exemple, « La
l’instruction
=RECHERCHEV(A1;B:C;2;FAUX)
la fonction RECHERCHEV ne trouve pas ce que vous recherchez et renvoie une erreur (#N/A). Cette erreur peut être due à l’une des deux causes suivantes : la valeur reche
formule est SI.
DÉTAIL IMPORTANT
incorrecte
La fonction»). SIERREUR est un gestionnaire d’erreurs global, ce qui signifie qu’elle supprimera toutes les erreurs renvoyées par votre formule. Cela peut entraîner des problèmes si E
Fruits Montant
Où voulez-vous Souhaitez-vous
En règle générale, il est préférable de ne pas ajouter de gestionnaires d’erreurs à vos formules tant que vous n’êtes pasPommes absolument certain qu’elles fonctionnent
50 correctement.
effectuer la obtenir une
Précédent recherche ? correspondance Oranges 20
Suivant parfaite ou Bananes 60
Plus d’informations sur le web approximative ? Citrons 40
À propos de la fonction RECHERCHEV
À propos des fonctions INDEX/EQUIV Pommes
1 Dans la cellule D22, entrez =RECHERCHEV(C22;C17:D20;2;FAUX). Pour
À propos de la fonction SIERREUR
l’article Pommes, la bonne réponse est 50. RECHERCHEV a recherché
Utiliser un tableau croisé dynamique pour analyser les données d’une feuille de calcul
l’article Pommes puis, après l’avoir trouvé, est passé à la colonne de droite
Formation en ligne gratuite sur Excel EXPÉRIMENTEZ
et a renvoyé le nombre correspondant. Essayez de sélectionner différents éléments dans les listes
déroulantes. Vous verrez alors que les cellules de résultat
2 Faites maintenant un essai avec la section Viande, à la cellule G22. Vous affichent instantanément de nouvelles valeurs.
devez obtenir la formule suivante : =RECHERCHEV(F22;F17:G20;2;FAUX).
Poursuivez votre lecture pour plus Suivant
d’informations

Si la fonction SOMME de la cellule D42 pouvait parler, voici ce qu’elle dirait : Additionner les v
Article Quantité
RECHERCHEV et #N/A Pain 50
Beignets 100
Parfois, la fonction RECHERCHEV ne trouve pas ce que vous recherchez et renvoie Cookies 40
une erreur (#N/A). Cette erreur peut être due à l’une des deux causes suivantes : la Gâteaux 50
valeur recherchée n’existe pas ou la cellule de référence ne comporte encore aucune Tourtes 20
valeur.
#N/A
1 Si vous savez que la valeur recherchée existe et souhaitez masquer l’erreur
lorsque la cellule de recherche est vide, vous pouvez utiliser une instruction
SI. Nous allons encapsuler la formule RECHERCHEV de la cellule D43 comme
ceci : DÉTAIL IMPORTANT
La fonction SIERREUR est un g
qui signifie qu’elle supprimera
=SI(C43="";"";RECHERCHEV(C43;C37:D41;2;FAUX)) par votre formule. Cela peut e
vous envoie une notification p
Cette formule signifie : « Si la cellule C43 n’est égale à rien (""), ne rien formule contient une erreur lé
renvoyer, sinon renvoyer les résultats de la fonction RECHERCHEV ». Notez En règle générale, il est préfér
que nous avons ajouté une deuxième parenthèse fermante à la fin de la gestionnaires d’erreurs à vos f
formule. Celle-ci ferme l’instruction SI. pas absolument certain qu’ell

2 Si vous n’êtes pas sûr de l’existence de la valeur recherchée mais que vous
souhaitez malgré tout supprimer l’erreur #N/A, vous pouvez utiliser une
fonction de gestion d’erreur SIERREUR à la cellule G43 :
=SIERREUR(RECHERCHEV(F43;F37:G41;2;FAUX);""). La fonction
SIERREUR signifie ceci : « Si la fonction RECHERCHEV renvoie un résultat
valide, l’afficher, sinon ne rien afficher ("") ». Nous n’avons ici rien affiché
(""), mais vous pouvez également utiliser des chiffres (0,1, 2, etc.) ou du
texte (par exemple, « La formule est incorrecte »).
=SIERREUR(RECHERCHEV(F43;F37:G41;2;FAUX);""). La fonction
SIERREUR signifie ceci : « Si la fonction RECHERCHEV renvoie un résultat
valide, l’afficher, sinon ne rien afficher ("") ». Nous n’avons ici rien affiché
(""), mais vous pouvez également utiliser des chiffres (0,1, 2, etc.) ou du
texte (par exemple, « La formule est incorrecte »).

Précédent Suivant

Plus d’informations sur le web


À propos de la fonction RECHERCHEV

À propos des fonctions INDEX/EQUIV

À propos de la fonction SIERREUR

Utiliser un tableau croisé dynamique pour analyser les données


d’une feuille de calcul

Formation en ligne gratuite sur Excel


ur dans une colonne située à gauche et, si elle trouve une correspondance, elle renvoie des informations dans une autre colonne située à droite. RECHERCHEV dit ceci :

de nouvelles valeurs.

ux causes suivantes : la valeur recherchée n’existe pas ou la cellule de référence ne comporte encore aucune valeur.

Viande Quantité
Bœuf 50
Poulet 30
Porc 10
Poisson 50

Porc

Z
er différents éléments dans les listes
rez alors que les cellules de résultat
ent de nouvelles valeurs.
ci ce qu’elle dirait : Additionner les valeurs des cellules D38, D39, D40 et D41.
Article Quantité
Pain 50
Beignets 100
Cookies 40
Gâteaux 50
Tartes 20

Pâtisserie

DÉTAIL IMPORTANT
La fonction SIERREUR est un gestionnaire d’erreurs global, ce
qui signifie qu’elle supprimera toutes les erreurs renvoyées
par votre formule. Cela peut entraîner des problèmes si Excel
vous envoie une notification pour vous signaler que votre
formule contient une erreur légitime qui doit être résolue.

En règle générale, il est préférable de ne pas ajouter de


gestionnaires d’erreurs à vos formules tant que vous n’êtes
pas absolument certain qu’elles fonctionnent correctement.
effectuer une
recherche sur
les critères
Fruits et Type,
et pas
seulement sur
Fruits.
Sélectionnez la
cellule H17 et

Fonctions conditionnelles - SOMME.SI


entrez
Fonctions conditionnelles - SOMME.SI
=SOMME.SI.E
Les fonctions conditionnelles vous permettent d’additionner, de calculer la moyenne, de compter ou d’obtenir les valeurs
NS(H3:H14;F3: Fruits
minimum ou maximum Quantité
d’une plage par rapport à une co
F14;F17;G3:G1
SOMME.SI vous permet d’additionner une plage d’après un critère spécifique recherché dans une autre plage, par exemple Pommesle nombre de pommes 50 dont vous disposez. Sélectionne
La fonction
4;G17). LaLes fonctions conditionnelles vous permettent d’additionner, de calculer la moyenne,
NB.SI.ENS
structure de 150
estlacompter ou d’obtenir les valeurs minimum ou maximum d’une plage par rapport à Oranges 20
de
identique
Quelle plage
fonction à voulez-vous examiner ? Bananes 60
SOMME.SI,
SOMME.SI.ENS unesi condition donnée ou en fonction de critères que vous spécifiez. Par exemple,
Quelle valeur (texte ou nombre) voulez-vous rechercher ? Citrons 40
ce
estn’est
la qu’elle
parmi tous les fruits de la liste, combien correspondent à des pommes ? Ou, combien
Pour
vous chaque
permet
suivante correspondance trouvée, quelle plage voulez-vous additionner ?
: d’oranges Pommes 50
appartiennent au type Floride ?
d’utiliser Oranges 20
plusieurs
=SOMME.SI(H3:H14;F3:F14;F17;G3:G14;G17)
Par1 Bananes 60
Deuxième
critères. SOMME.SI vous permet d’additionner une plage d’après un critère
Quelleàplage
plage
exemple, vousvoulez-vous additionner ? dans une autre plage, par exemple le nombre de Citrons 40
spécifique recherché
examiner
pouvez ici pour
Première plage à examiner pour rechercher des correspondances Pommes 50
rechercher
effectuer unedes pommes dont vous disposez. Sélectionnez la cellule D17 et entrez
Critère de
correspondanc
recherche la
surpremière correspondance
=SOMME.SI(C3:C14;C17;D3:D14). La structure de la fonction SOMME.SI Oranges 20
es critères
les est la suivante : Bananes 60
Fruits
Critère et Type,
de la deuxième correspondance Citrons 40
CONSEIL
et pas D’EXPERT
Chacune des
seulement surcellules Fruits et Type s’accompagne
Quelle d’une liste déroulante
plage voulez-vous danscorrespondance
Pour chaque laquelle vous pouvez sélectionner différents fruits. Faites un essai et vous verrez que les formules se
trouvée,
Poursuivez votre lecture pour plusexaminer
Fruits. ?
d’informations quelle plage voulez-vous additionner ? Fruits SOMME.SI
Sélectionnez
Étape suivante la Pommes 150
cellule H64 et
Fonctions conditionnelles - NB.SI
entrez orange 60
=NB.SI.ENS(F5
Les fonctions NB.SI et NB.SI.ENS vous permettent de compter les valeurs d’une plage en utilisant le critère de votre choix. Elles sont un peu différentes des autres fonctions SI et SI
0:F61;F64;G50
Sélectionnez
=SOMME.SI(C3:C14;C17;D3:D14)
:G61;G64). Lala cellule D64 et entrez =NB.SI(C50:C61;C64). La structure de la fonction NB.SI est la suivante :
=NB.SI.ENS(C50:C61;C64)
structure de la Pommes 150
fonction
Quelle plage voulez-vous examiner ?
NB.SI.ENS est Quelle valeur (texte ou nombre)
Quelle valeur
la suivante : (texte ou nombre) voulez-vous rechercher ?
voulez-vous rechercher ?

=NB.SI.ENS(F50:F61;F64;G50:G61;G64)
2 à compter
Première plage SOMME.SI.ENS est identique à SOMME.SI, si ce n’est qu’elle vous permet
d’utiliser
Critère de la première plusieurs critères. Par exemple, vous pouvez ici effectuer une
correspondance
Deuxième plage à recherche
compter sur les critères Fruits et Type, et pas seulement sur Fruits.
Sélectionnez la cellule H17 et entrez
Critère de la deuxième correspondance
=SOMME.SI.ENS(H3:H14;F3:F14;F17;G3:G14;G17). La structure de la
fonction SOMME.SI.ENS est la suivante :
92:D103;D106) SOMME.SI.ENS est identique à SOMME.SI, si ce n’est qu’elle vous permet
MAX.SI.ENS
=MAX.SI.ENS(E d’utiliser plusieurs critères. Par exemple, vous pouvez ici effectuer une
92:E103;C92:C recherche sur les critères Fruits et Type, et pas seulement sur Fruits.
103;C10;D92:D Sélectionnez la cellule H17 et entrez
103;D106)
=SOMME.SI.ENS(H3:H14;F3:F14;F17;G3:G14;G17).
Poursuivez votre lecture
MIN.SI.ENS pour plus d’informations La structure de la
=MIN.SI.ENS(E
Suivant fonction SOMME.SI.ENS est la suivante :
92:E103;C92:C
Autres fonctions conditionnelles
103;C106;D92: Quelle plage Critère de la Critère de la
D103;D106) voulez-vous première deuxième
Poursuivez votre lecture pour plus d’informations
additionner ? correspondance correspondance
Suivant
SOMME.SI avec un argument de valeur
Voici un exemple de fonction SOMME.SI associée à l’opérateur Supérieur à (>) pour trouver toutes les valeurs supérieures à un nombre donné :
=SOMME.SI(D118:D122;">50")
=SOMME.SI(H3:H14;F3:F14;F17;G3:G14;G17)
Additionner
....Examiner cescertaines valeurs en fonction de ce critère :
cellules...
...et si la valeur est supérieure à 50, l’additionner.
Première plage à Deuxième plage à
REMARQUE : si vous utilisez beaucoup de formules conditionnelles,
examiner pour un tableau croisé dynamique
examiner pour peut être une solution plus adaptée. Pour plus d’informations, consultez cet artic
Plus d’informations sur le web rechercher des rechercher des
correspondances correspondances
À propos de la fonction SOMME.SI
À propos de la fonction SOMME.SI.ENS
À propos de la fonction NB.SI
À propos de la fonction NB.SI.ENS
À propos de laPoursuivez votre lecture pour plus
fonction MOYENNE.SI
Suivant
d’informations
À propos de la fonction MOYENNE.SI.ENS Fruits Quantité
À propos de la fonction MIN.SI.ENS Pommes 50
À propos de la fonction MAX.SI.ENS Oranges 20
Créer une liste déroulante Bananes 60
Formation en ligne gratuite sur Excel Citrons 40
Fonctions conditionnelles - NB.SI
Retour au début Pommes 50
Suivant Oranges 20
Les fonctions NB.SI et NB.SI.ENS vous permettent de compter les valeurs d’une plage Bananes 60
en utilisant le critère de votre choix. Elles sont un peu différentes des autres fonctions Citrons 40
SI et SI.CONDITIONS car elles comportent uniquement une plage de critères et un Pommes 50
critère. Elles n’évaluent pas une plage pour examiner ensuite une autre plage à Oranges 20
synthétiser. Bananes 60
Citrons 40
1 Sélectionnez la cellule D64 et entrez =NB.SI(C50:C61;C64). La structure de
la fonction NB.SI est la suivante :
1 Sélectionnez la cellule D64 et entrez =NB.SI(C50:C61;C64). La structure de
la fonction NB.SI est la suivante :
Fruits NB.SI
Quelle plage voulez-vous Pommes 3
examiner ?

=NB.SI.ENS(C50:C61;C64)

Quelle valeur (texte ou nombre)


voulez-vous rechercher ?

2 La fonction NB.SI.ENS est identique à SOMME.SI, si ce n’est qu’elle vous


permet d’utiliser plusieurs critères. Par exemple, vous pouvez ici effectuer
une recherche sur les critères Fruits et Type, et pas seulement sur Fruits.
Sélectionnez la cellule H64 et entrez

=NB.SI.ENS(F50:F61;F64;G50:G61;G64). La structure de la fonction


NB.SI.ENS est la suivante :
Première plage Deuxième plage à
à compter compter

=NB.SI.ENS(F50:F61;F64;G50:G61;G64)

Critère de la première Critère de la deuxième


correspondance correspondance
Fruits Type Quantité
Pommes Fuji 50
Oranges Floride 20
Poursuivez votre lecture pour plus
Suivant
d’informations
Poursuivez votre lecture pour plus
Suivant Bananes Cavendish 60
d’informations
Citrons Rough 40
Pommes Honeycrisp 50
Oranges Navel 20
Bananes Lady Finger 60
Autres fonctions conditionnelles Citrons
Pommes
Eureka
Honeycrisp
40
50
Oranges Navel 20
Maintenant que vous connaissez les fonctions SOMME.SI, SOMME.SI.ENS, NB.SI et Bananes Cavendish 60
NB.SI.ENS, vous pouvez essayer d’autres fonctions, telles que MOYENNE.SI/.ENS, Citrons Eureka 40
MAX.SI.ENS et MIN.SI.ENS. Ces fonctions sont toutes structurées de la même façon.
Par conséquent, une fois la formule créée, il vous suffit de remplacer le nom d’une Fruits Type vous-même
fonction par celui d’une autre fonction. Nous avons créé toutes les formules dont vous Citrons Eureka 80
aurez besoin pour la cellule E106. Vous pouvez donc les copier/coller, ou essayer de les
entrer manuellement pour vous entraîner.

SOMME.SI =SOMME.SI(C92:C103;C106;E92:E103)
SOMME.SI.ENS =SOMME.SI.ENS(E92:E103;C92:C103;C106;D92:D103;D106)
MOYENNE.SI =MOYENNE.SI(C92:C103;C106;E92:E103)
MOYENNE.SI.ENS =MOYENNE.SI.ENS(E92:E103;C92:C103;C106;D92:D92;D106)
NB.SI =NB.SI(C92:C103;C106)
NB.SI.ENS =NB.SI.ENS(C92:C103;C106;D92:D103;D106)
MAX.SI.ENS =MAX.SI.ENS(E92:E103;C92:C103;C106;D92:D103;D106)
MIN.SI.ENS =MIN.SI.ENS(E92:E103;C92:C103;C106;D92:D103;D106)
Article Quantité
Pain 50
Poursuivez votre lecture pour plus Beignets 100
Suivant
d’informations Cookies 40
Gâteaux 50
Tourtes 20
100

SOMME.SI avec un argument de valeur


SOMME.SI avec un argument de valeur
Voici un exemple de fonction SOMME.SI associée à l’opérateur Supérieur à (>) pour
trouver toutes les valeurs supérieures à un nombre donné :

Additionner ....Examiner ces ...et si la valeur


certaines valeurs cellules... est supérieure à
en fonction de ce 50, l’additionner.
critère :

=SOMME.SI(D118:D122;">50")
REMARQUE : si vous utilisez beaucoup de formules conditionnelles, un tableau croisé
dynamique peut être une solution plus adaptée. Pour plus d’informations, consultez
cet article consacré aux tableaux croisés dynamiques.

Plus d’informations sur le web


À propos de la fonction À propos de la fonction
SOMME.SI SOMME.SI.ENS
À propos de la fonction
À propos de la fonction NB.SI
NB.SI.ENS
À propos de la fonction À propos de la fonction
MOYENNE.SI MOYENNE.SI.ENS
À propos de la fonction À propos de la fonction
MIN.SI.ENS MAX.SI.ENS

Créer une liste déroulante Formation en ligne gratuite


sur Excel
Étape
Retour au début
suivante
Fruits Type Quantité
Pommes Fuji 50
Oranges Floride 20
Bananes Cavendish 60
Citrons Rough 40
Pommes Honeycrisp 50
Oranges Navel 20
Bananes Lady Finger 60
Citrons Eureka 40
Pommes Honeycrisp 50
Oranges Navel 20
Bananes Cavendish 60
Citrons Eureka 40
ous verrez que les formules se mettent automatiquement à jour.
Fruits Type SOMME.SI.ENS
Oranges Floride

es des autres fonctions SI et SI.CONDITIONS car ellesCONSEIL


comportent uniquement
D’EXPERT une plage de critères et un critère. Elles n’évaluent pas une plage pour examiner ensuite une autre plage à synth
Chacune des cellules Fruits et Type
s’accompagne d’une liste déroulante
dans laquelle vous pouvez sélectionner
différents fruits. Faites un essai et vous
verrez que les formules se mettent
automatiquement à jour.
nformations, consultez cet article consacré aux tableaux croisés dynamiques.

Fruits Type Quantité


Pommes Fuji 50
Oranges Floride 20
Bananes Cavendish 60
Citrons Rough 40
Pommes Honeycrisp 50
Oranges Navel 20
Bananes Lady Finger 60
Citrons Eureka 40
Pommes Honeycrisp 50
Oranges Navel 20
Bananes Cavendish 60
Citrons Eureka 40
Fruits Type NB.SI.ENS
Oranges Floride 1
ner ensuite une autre plage à synthétiser.
BON À SAVOIR
Double-cliquez sur cette cellule. Vous pouvez
constater que la formule est différente. Plus
précisément, le critère de somme est ">=50", ce qui
signifie supérieur ou égal à 50. Vous disposez
d’autres opérateurs, notamment "<=50" qui
correspond à inférieur ou égal à 50. Ou encore
"<>50" qui correspond à n’est pas égal à 50.
chaque
RECHERCHEV
argument
est en
apparaissent
surbrillance,
en bas du
cliquez
formulaire.sur OK,
en bas
Lorsque
BON du vous
À SAVOIR
formulaire.
avez
Lorsqueterminé,
vous
Lorsque
appuyez
entrez lavous
sur
sélectionnez
OK, et
section Excel
de
ESSAYEZ
une ÇA
fonction
entrera
chaque
Vous devez
Laissez-vous guider par l’Assistant Fonction
dans la liste,
Laissez-vous
obtenir
Excel la la guider
automatiquem
argument,
Si vous connaissez
affiche sa lepar
noml’Assistant Fonction
de la fonction que vous souhaitez utiliser, mais que vous ne savez pas comment la créer, vous pouvez utiliser l’Assistant Fonction pour vous aider.
ent la formule.
description
formule de
syntaxe.
l’argument
suivante :
s’affiche
=RECHERCHEV( en bas
du Si vous connaissez le nom de la fonction que vous souhaitez utiliser, mais que vous
formulaire,
C10;C5:D8;2;FA Fruits Quantité
au-dessus
UX). du
ne savez pas comment la créer, vous pouvez utiliser l’Assistant Fonction pour vous Pommes 50
BON À SAVOIR
résultat de la
Vous
formule.pouvezaider.
entrer manuellement les références de cellule et de plage, ou les sélectionner avec la souris. Oranges 20
Bananes 60
Précédent 1 Sélectionnez la cellule D10, accédez à Formules > Insérer une fonction > Citrons 40
Suivant entrez RECHERCHEV dans la zone Recherchez une fonction,puis appuyez
Plus d’informationssur sur Rechercher.
le web Lorsque RECHERCHEV est en surbrillance, cliquez sur OK, en Pommes 50
bas du formulaire. Lorsque vous sélectionnez une fonction dans la liste, Excel
Vue d’ensemble des formules dans Excel
affiche sa syntaxe.
Fonctions Excel (par catégorie)
Fonctions Excel (parEntrezordre ensuite
alphabétique) ESSAYEZ ÇA
2
Formation en lignerespectives.
gratuite sur Excel
les arguments de la fonction dans leurs zones de texte Vous devez obtenir la formule suivante :
À mesure que vous entrez les arguments, Excel les évalue et =RECHERCHEV(C10;C5:D8;2;FAUX).
affiche leur résultat, avec le résultat final en bas du formulaire. Lorsque vous
avez terminé, appuyez sur OK, et Excel entrera automatiquement la formule.

BON À SAVOIR
Vous pouvez entrer manuellement les références de
cellule et de plage, ou les sélectionner avec la souris.

BON À SAVOIR
Lorsque vous entrez la section de chaque argument, la
description de l’argument s’affiche en bas du formulaire, au
dessus du résultat de la formule.
BON À SAVOIR
Lorsque vous entrez la section de chaque argument, la
description de l’argument s’affiche en bas du formulaire, au
dessus du résultat de la formule.

Précédent Suivant

Plus d’informations sur le web


Vue d’ensemble des formules dans Excel

Fonctions Excel (par catégorie)

Fonctions Excel (par ordre alphabétique)

Formation en ligne gratuite sur Excel


tion pour vous aider.

ÇA
tenir la formule suivante :
(C10;C5:D8;2;FAUX).

ment les références de


ctionner avec la souris.

de chaque argument, la
che en bas du formulaire, au-
e.
de chaque argument, la
che en bas du formulaire, au-
e.
BON À SAVOIR
Cliquez sur
Résoudre
Options Résoudre les erreurs présentes dans les
lesvous
pour
Tôt ou tard,
définir les
erreurs présentesune
rencontrerez dansformule
les formules
comportant une erreur (#ErrorName!). Les erreurs sont parfois utiles car elles mettent un problème en évidence, mais elles peuvent au
Vérification des erreurs : accédez à Formules > Vérification des erreurs. Une boîte de dialogue s’affiche en indiquant la cause générale de l’erreur. À la cellule D9, l’erreur #N/A est d
formules
règles
Cliquez sur Aide sur cette erreur pour ouvrir la rubrique d’aide correspondant à ce message d’erreur. Cliquez sur Afficher
permettant Fruits Quantité
les étapes du calcul pour ouvrir la boîte de dialogue Évalu
d’afficher
Chaque fois ouque vous cliquez sur Évaluer, Excel examine la formule section par section. Excel ne vous indiquera pas forcément pourquoi l’erreur s’est 50
Pommes produite, mais il vous signaler
d’ignorer les
Tôt ou tard, vous rencontrerez une formule comportant une erreur (#ErrorName!). Les Oranges 20
EXPÉRIMENTEZ
erreurs dans
Excel.est leerreurs
Quel problèmesont
iciparfois
? Astuceutiles car elles
: l’objectif mettent un problème
est d’additionner en évidence,
tous les articles mais
à l’aide de elles SOMME.
la fonction Bananes 60
peuvent aussi être difficiles à résoudre. Heureusement, différentes options permettent Citrons 40
Précédent de remonter jusqu’à la source de l’erreur pour la corriger.
Suivant Pomme #N/A
1 Vérification
Plus d’informations sur le web des erreurs : accédez à Formules > Vérification des erreurs.
Une boîte de dialogue s’affiche en indiquant la cause générale de l’erreur. À
Détecter les erreurs dans les formules
la cellule D9, l’erreur #N/A est due à l’absence de valeur correspondant à
Comment éviter les formules incorrectes
« Pomme ». Pour résoudre cette erreur, vous pouvez utiliser une valeur
Évaluer une formule imbriquée étape par étape
existante, supprimer l’erreur à l’aide de la fonction SIERREUR, ou l’ignorer
Formation en ligne gratuite sur Excel
sachant qu’elle disparaîtra lorsque vous utiliserez une valeur existante.

BON À SAVOIR
Cliquez sur Options pour définir les
2 Cliquez sur Aide sur cette erreur pour ouvrir la rubrique d’aide règles permettant d’afficher ou
correspondant à ce message d’erreur. Cliquez sur Afficher les étapes du d’ignorer les erreurs dans Excel.
calcul pour ouvrir la boîte de dialogue Évaluation la formule.
Fruits Quantité
Pommes 50
Oranges 20
Bananes 60
Citrons 40

Total #NAME?

EXPÉRIMENTEZ
Quel est le problème ici ? Astuce : l’obje
d’additionner tous les articles à l’aide de
fonction SOMME.

3 Chaque fois que vous cliquez sur Évaluer, Excel examine la formule section
par section. Excel ne vous indiquera pas forcément pourquoi l’erreur s’est
produite, mais il vous signalera d’où elle vient. À partir de là, consultez la
rubrique d’aide pour tenter de déterminer la cause de l’erreur.

Précédent Suivant

Plus d’informations sur le web


Détecter les erreurs dans les formules

Comment éviter les formules incorrectes

Évaluer une formule imbriquée étape par étape


Formation en ligne gratuite sur Excel
dence, mais elles peuvent aussi être difficiles à résoudre. Heureusement, différentes options permettent de remonter jusqu’à la source de l’erreur pour la corriger.

définir les
er ou
Excel.
MENTEZ
problème ici ? Astuce : l’objectif est
er tous les articles à l’aide de la
MME.
Vous avez d’autres questions sur Excel ?
Appuyez sur ALT+Q et tapez ce que vous voulez savoir.
Vous avez d’autres questions sur Excel ?
Ne vous arrêtez pas là. Excel vous offre d’autres opportunités d’apprentissage :
LinkedIn Learning : Cours vidéo pour tous les niveaux, de débutant à avancé. Apprenez à votre rythme.
Communauté : Posez des questions et communiquez avec d’autres adeptes d’Excel.
Quelles sont les autres nouveautés ?Les abonnés à Office 365 reçoivent des mises à jour et de nouvelles fonctionnalités en continu.

Cliquez sur le bouton En savoir plus , puis indiquez ce


que vous voulez savoir.

Ne vous arrêtez pas là. Excel vous offre d’autres opportunités d’apprentissage :

LinkedIn Learning Communauté Quelles sont les autres


Cours vidéo pour tous Posez des nouveautés ?
les niveaux, de questions et Les abonnés à Office 365
débutant à avancé. communiquez reçoivent des mises à jour
Apprenez à votre avec d’autres et de nouvelles
rythme. adeptes d’Excel. fonctionnalités en continu.

En savoir plus En savoir plus En savoir plus


(anglais uniquement)
sont les autres
tés ?
és à Office 365
des mises à jour
elles
alités en continu.

Vous aimerez peut-être aussi