Vous êtes sur la page 1sur 32

Réalisé par : Moumen Raii

Pour la révision (ccna2 –ccna3 –ccna4) :


Sommaire
1. Configuration d`un routeur
2. Configuration de base
d’un switch
3. Routage statique (ipv4-
CCNA2
ipv6 )
4. Routage dynamique (rip v2
(OSPFv2 –v3 Unique
zone/MULTIZONES )
5. Les vlan
6. Les inter-vlan
7. DHCPV4 ET DHCPV6
1. spanning tree protocol
2. Virtual Gateway : HSRP –
GLBP
3. Agrégation de liaison :
CCNA3
etherchannel (Lacp –pagp)
4. EIGRP IPV4 –IPV6
5. ACCESS CONTROL LIST
(ACL)

CCNA4
Technolgie wan
6. PPP (CHAP –PAP )
7. Encapsulation ppp –HDLC
8. Frame relay (point to
point –multiponit)
9. NAT –PAT
10. VPN (Tunnel GRE+tunnel
IPV6 )
11. SYSLOG
12. NETFLOW-SNMP.
Réalisé par : Moumen Raii

CCNA 2
Configuration d`un routeur

Mode privilégié : Interface Console : Ajouter une


Router> enable R1(config)# line console 0 description pour
Mode Configuration globale : R1(config-line)# logging l'interface :
Router# configur terminal synchronous R1(config-if)#
(désactiver messages de non description # votre
Changer le nom d’équipement : solicitations)
Router(config)# hostname R1 Description#
R1(config-line)# password cisco1234
Mot de passe (non-crypté) : R1(config-line)# login Enregistrer les
Router(config)# enable password cisco1234 R1(config-line)# exit
modifications
Mot de passe (crypté) :
apportées à un
Router(config)# enable secret cisco1234 Interface VTY :
routeur
Appliquer un cryptage simple à tous R1(config)# line vty 0 4
les mots de passe : R1(config-line)# password cisco1234 R1#copy running-config
R1(config-line)# login startup-config
Router(config)# service password-
encryption R1(config-line)# exit
Donne des
Création d’une entrée statique de
Configurer une interface de informations sur les
résolution de nom dans la tabe de voisins CDP
bouclage :
host : Router(config)#interface loopback 0 comme l’ID
Router(config)# ip host TRI 69 192.168.1.33
Router(config-if)#ip address R1#show cdp neighbors
Activer le serveur http (service 192.168.1.2
web) : 255.255.255.0 Désactiver le
Router(config)# ip http server Désactiver la recherche DNS : protocole CDP :
Router (config)# no ip doman- R1(config)#no cdp run
Configurer une interface : lookup
R1(config)#interface Serial0/0 Arrêter les
Message de bannière de annonces CDP sur
R1(config-if)# ip add 192.168.2.1
255.255.255.0
connexion : une interface
R1(config-if)# no shutdown R1(config)# banner mtd #message
de jour#
précise.
Afficher les informations de R1(config-if)# no cdp
Configurer l'heure sur le enable
l’interface :
R1# show interface Serial0/0
routeur :
Router(config)# clock set 22:30:44
Configurer la vitesse de liaison
13 4 2015
WAN :
Router(config-if)# clock rate 64000
- Afficher l'heure du système :
Router# show clock
Réalisé par : Moumen Raii

Configuration de base d’un switch

Configuration vlan de gestion : Désactiver les ports inutilisés :


S1#conf t S1#show run
S1(config)# interface vlan 99
S1(config-if)# ip address 172.17.99.11 255.255.0.0 S1(config)# interface range F0/0-5
S1(config-if)# no shutdown S1(config-if)# shutdown
S1(config-if)# end
S1# copy running-config startup-config
S1# copy running-config startup-config
--------------------------------------------------------------------------------------
------------------------------------------------------------------
Configurer la surveillance DHCP :
Configuration de la passerelle par défaut :
S1(config)#ip dhcp snooping
S1#configure terminal S1(config)# ip dhcp snooping vlan 10,20
S1(config)# ip default-gateway 172.17.99.1 S1(config)# interface fastethernet 0/1
S1# end S1(config-if)# ip dhcp snooping limit rate 5 (limite de
requête)
S1# copy running-config startup-config S1'config-if)# ip dhcp snooping trust
------------------------------------------------------------------
----------------------------------------------------------------------------
Vérifier la configuration :
-----
S1#show ip interface brief Vérifier l'état surveillance DHCP :
------------------------------------------------------------------
S1#show ip dhcp snooping
Configuration du mode bidirectionnel de la vitesse
----------------------------------------------------------------------------------
(Full-duplex) : Modifier le mode de violation d'un port :
S1# configure terminal S1(conft-if)# switchport port-security
S1(config)# interface FastEthernet 0/1 violation{protect | restrict | shutdown}
S1(config-if) # duplex full ----------------------------------------------------------------------------------------
S1(config-if)# speed 100 -------
Configurer port security :
S1(config-if)# end
S1(config)#interface fastethernet 0/19
S1# copy running-config startup-config
------------------------------------------------------------------ S1(config-if)# switchport mode access
Configurer l'auto-MDIX : S1(config-if)# switchport port-security
S1(config-if)# mdix auto S1(config-if)# switchport port-security
-------------------------------------------------------------------------
Vérifier l'auto-MDIX : maximum 50
S1(config-if)# show controllers ethernet- S1(config-if)# switchport port-security mac-
controller fa 0/1 phy|include auto-mdix address
------------------------------------------------------------------------- S1(config-if)# switchport port-security mac-
Configuration de SSH :
address sticky
S1#configure terminal ---------------------------------------------------------------------------------------
S1(config)# username admin Vérifier les adresses MAC sécurisées :
secret/password raii S1# show port-security address
S1(config) # ip ssh version 2 S1#show port-security interface f/019
----------------------------------------------------------------------------------------
S1(config)# crypto key generate rsa
Vérifier l'état du port :
S1(config)# ip domain-name raii.com
S1# show interface f0/18 status
S1{config-line)# line vty 0 15 --------------------------------------------------------------------------------
S1(config-line)# transport input ssh Configurer NTP :
S1(config-line)# login local R1(config)# ntp master 1
R2(config)# ntp server 10.1.1.1
R2# show ntp associations
R2# show ntp status
Réalisé par : Moumen Raii

Routage statique

Syntaxee de la commande de route statique Syntaxe de la commande de route statique ipv6


ipv4 :

La syntaxe : LA même configuration dans ipv6 :


Router(config)# ip route address le masque
{adress ip de nexte hope ou le numéro Configuration des routes statiques :
d`interface de sortie ] R1(config)# ip route 2001:DB8:ACAD:3::/64
- 2001:DB8:ACAD:4::2 (Route statique en utilisant le
Exemple1 :Configuration d’une route statique de tronçon suivant)
tronçon suivant (next hope ) : -----------------------------------------------------------------------------------
----------------
R1(config)# ip route 192.168.1.0 255.255.255.0
R1(config)# ip route 2001:DB8:ACAD:3::/64 s0/0/0
172.16.2.2
(Route statique directement connecté)
Exemple2 : :Configuration d’une route statique par
dans le cas du protocole CEF est désactivé.
le numero d`interface de sortie -----------------------------------------------------------------------------------
R1(config)# ip route 172.16.1.0 255.255.255.0 -----------
s0/0/0 R1(config)# ip route 2001:DB8:ACAD:3::/64 fe80::2
Exemple3 : configuration d`une route statique par (Route statique entièrement spécifiée ).
défaut
R1(config)# ip route 0.0.0.0 0.0.0.0 172.16.2.2 R1(config)# ip route ::/0 2001:DB8:ACAD:4::2
Exemple4 configuration d`une route statique ( Route statique par défaut )
flottante (route de secours) : -----------------------------------------------------------------------------------
R1(config)# ip route 0.0.0.0 0.0.0.0 172.16.2.2 5 R1(config)# ip route ::/0 2001:DB8:ACAD:4::2 5 ( Route
( Route statique flottante DA = 5 ).le Cinque c`est statique flottante DA =5).
la distance administrative
LES COMMANDES DE VERIFICATION LES COMMANDES DE VERIFICATION
R1# Show ip route ou R1(config)# do sh ip route
R1# Show ipv6 route ou R1(config)# do sh ipv6 route
R1# show ip route static
R1# show ipv6 route static
R1# show ip route 192.168.2.1
R1# show running config | section ip route R1# show ipv6 route 192.168.2.1
R1# show running config | section ipv6 route
Tp : configurer une route statique vers 192.168.1.0/24
Tp :configurer une route statique par le numéro d`interface :
Réalisé par : Moumen Raii

Routage dynamique

RIPV2

Activer le Routage Rip V2 (IPV4) RIPng (IPV6)


R1(config)# router rip
R1(config)# version 2 Activer le Routage Ripv2 :
-------- R1(config)# interface gigabitethernet 0/0/0
Annonce des réseaux : R1(config-if)# ipv6 rip Raii enable
R1(config-router) network 192.168.1.0 -
------- Maximum Path (pour la repartions de la charge ) :
Vérifier les paramètres / les réseaux R1(config-if)# ipv6 rip Raii enable
annoncés dans RIP : R1(config-router)# maximum-paths 1
R1# show ip protocols -------------
------ Désactiver les mise a jours sur les interface
Afficher la table de routage Rip : R1(config-router)# no auto-summary
R1# show ip route - Configurer et vérifier passive interface :
------ R1(config-router)# passive-interface g0/0
Désactiver la récapitulation automatique : --
R1(config-router)# no auto-summary Propager une route par defaut :
----- Router(config-if)# ipv6 rip Raii default-information originate
Désactiver les mise a jours sur les --
interface Propager une route static :
R1(config-router)# passive-interface g0/0 Router(config)# ipv6 router rip Raii
----- Router(config-rtr)# redistribute static
Propager une route par défaut : Commandes de verification :
R1(config-router)# default-information R1# show ipv6 protocols ( Parametres de Rip ipv6)
originate R1#show ipv6 route (afficher la table de routage )
----- R1# show ipv6 route rip (Vérifier les routes rip )
Propager une route statique : Activation de Ripng IPV6 :
R1(config-router)# redistribute static R1(config)# interface S0/0/0
----- R1(config-if)# ipv6 rip RIP-AS enable
Activer l`authentification Rip R1(config-if)# no shut
R1(config-if)# ip rip authentification key-chain
nom
R1(config-if)# ip rip authentification mode md5
-----
Commandes de verfication:
R1# show ip protocols ( Parametres de Rip )
R1#show ip route (afficher la table de routage )
Réalisé par : Moumen Raii

OSPFv2 (IPV4)

Activer le Routage OSPFv2 : Propagation d'une route par défaut :


R1(config)# router ospf 10 R1(config)# ip route 0.0.0.0 0.0.0.0
10=le numéro de système autonome 209.165.200.226
------------------------------------------------------------------------------------------------------------ R1(config)# router ospf 10
--
R1(config-router)# default-information
Configurer l'ID de routeur : originate
R1(config-router)# router-id 1.1.1.1
-------------------------------------------------------------------------------------
R1(config-router)# end
---------------------------------------------------------------
Affectation d'interface à une zone OSPF :
-
R1(config-router)# network 172.16.1.0 0.0.0.255 area 0
--------------------------------------------------------------------------------------------- Modification des intervalles OSPF sur
Effacer le processus de routage OSPF : une interface :
R1# clear ip ospf process R1(config)# interface serial 0/0/0
--------------------------------------------------------------------------------------------- R1(config-if)# ip ospf hello-interval 5
Configurer une interface de bouclage pour R1(config-if)# ip ospf dead-interval 20
l'utiliser comme ID : R1(config-router)# end
R1(config)# interface loopback 0 -------------------------------------------------------------
R1(config-if)# ip address 1.1.1.1 255.255.255.255 Modifier de la priorité d'un interface :
R1(config-if)# end R1(config)# interface G0/0
---------------------------------------------------------------------------------------------
R1(config-if)# ip ospf priority 255
Configurer une interface passive : R1(config-if)# end
R1(config-router)# passive-interface g0/0 R1# clear ip ospf process-
---------------------------------------------------------------------------------------------
TP :Configurer avec ospf
Configurer la métrique de la BP :
R1(config)# interface s0/0/1
R1(config-if)# bandwith 64 (en kilo)
Réglage manuel de cout (commande alternative
à BP) :
R1(config)# interface s0/0/1
R1(config-if)# ip ospf cost 15625
------------------------------------------------------------------------------------------------------------
Changer la référence de la BP :
R1(config-router)# auto-cost reference -bandwith 1000
------------------------------------------------------------------------------------------------------------
--
Afficher la table de voisinage :
R1# show ip ospf neighbors
------------------------------------------------------------------------------------------------------------
Vérifier le processus OSPF :
R1# show ip ospf
------------------------------------------------------------------------------------------------------------
Vérifier les paramètres OSPF d'une interface :
R1# show ip ospf interface brief
Réalisé par : Moumen Raii

OSPFv3 (IPV6)

Activation de routage ipv6 : Activation de l'authentification MD5 OSFP


R1(config)# ipv6 unicast-routing R1(config)#router ospf 10
R1(config-if)# area 0 authentication message-
Activer le Routage OSPFv3 : digest
R1(config)# ipv6 router ospf 20 R1(config-if)# end
20 = le numéro de système autonome R1(config)# interface G0/0
R1(confg-if)#ip ospf message-digest_key 1 md5
AZERTY1234
Configurer les adresses link-local : R1(config-if)#exit
R1(config)# interface g0/0
R1(config-if)# ipv6 adresse fe80::1 link-local OSPF Multizone
R1(config)# exit R1(config-router)# network 10.1.1.0 0.0.0.255
area 1
Effacer le processus de routage OSPF : R1(config-router)# network 10.1.2.0 0.0.0.255
R1# clear ipv6 ospf process area 1
R1(config-router)# network 192.168.10.0 0.0.0.3
area 0
Affectation d'interface à une zone OSPF :
TP : configurer avec ospf (Multizone)
R1(config)# interface g0/0
R1(config-if)# ipv6 ospf 10 area 0

Afficher la configuration des interfaces :


R1# show ipv6 ospf interfaces brief

Afficher la table de voisinage :


R1# show ipv6 ospf neighbors

Vérifier la table de routage ipv6 OSPF


R1# show ipv6 route ospf

Propagation d'une route par défaut :


R1(config)# ipv6 route ::/0 2001:DB8:FEED:1::2
R1(config)# ipv6 router ospf 10
R1(config-router)# default-information originate
R1(config-router)# end

Modification des intervalles OSPF sur une


interface :
R1(config)# interface serial 0/0/0
R1(config-if)# ipv6 ospf hello-interval 5
R1(config-if)# ipv6 ospf dead-interval 20
R1(config-router)# end
Réalisé par : Moumen Raii

LES VLANS

VLAN Creation Switch Port Modes


Switch(config)# vlan 100 trunk
Switch(config-vlan)# name Engineering Forms an unconditional trunk
dynamic desirable
Access Port Configuration Attempts to negotiate a trunk with the far end
Switch(config-if)# switchport mode access dynamic auto
Switch(config-if)# switchport nonegotiate Forms a trunk only if requested by the far end
Switch(config-if)# switchport access vlan 100
access
Switch(config-if)# switchport voice vlan 150
Will never form a trunk
Trunk Port Configuration
Terminology
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk Trunking
encapsulation dot1q Carrying multiple VLANs over the same
Switch(config-if)# switchport trunk allowed vlan physical connection
10,20-30 Access VLAN
Switch(config-if)# switchport trunk native vlan 10 The VLAN to which an access port is
assigned
VLAN Trunking Protocol (VTP) Voice VLAN
Domain If configured, enables minimal trunking to
Commun à tous les commutateurs participant à support voice traffic in addition to data traffic
VTP on an access port
Server Mode
Génère et propage des messages VTP sur les commandes de vérification
clients.
mode par défaut sur les commutateurs non show vlan
configurés show interface [status | switchport]
Client Mode show interface trunk
Reçoit et transfère les messages des serveurs; show vtp status
VLAN ne peut pas être configuré manuellement show vtp password
sur les commutateurs en mode client
Transparent Mode Interface virtuelle commutée (SVI)
Renvoie des messagess mais ne participe pas Une interface virtuelle qui fournit un
au VTP; routage
Les VLAN doivent être configurés manuellement
passerelle dans et hors d'un VLAN
Pruning
Les VLAN n'ayant pas de ports d'accès sur un
commutateur final sont retiré du coffre pour réduire le
trafic inondé
VTP Configuration
Switch(config)# vtp mode {server | client |
transparent}
Switch(config)# vtp domain <name>
Switch(config)# vtp password <passsword>
Switch(config)# vtp version {1 | 2}
Switch(config)# vtp pruning
Réalisé par : Moumen Raii

INTERVLAN

Configuration du routage inter-VLAN


existant : Configuration du routage inter-VLAN
Créer les vlans de type router on a stick
S1(config)# vlan 10 Sur le Routeur :
S1(config)# vlan 30 R1(config)# interface g0/0.10
S1(config-vlan)# interface f0/11 R1(config-subif)# encapsulation dotlq/isl 10
S1(config-if)# switchport access vlan 10 R1(config-subif)# ip address 172.17.10.1
S1(config-if)# interface f0/4 255.255.255.0
S1(config-if)# switchport access vlan 10 R1(config-subif)# interface g0/0.30
S1(config-if)# interface f0/6 R1(config-subif)# encapsulation dotlq/isl 30
S1(config-if)# switchport access vlan 30 R1(config-subif)# ip address 172.17.30.1
S1(config-if)# interface f0/5 255.255.255.0
S1(config-if)# switchport access vlan 30 R1(config)# interface g0/0
S1(config-if)# end R1(config-if)# no shut

Vérifier les Vlans que nous avons créé


S1# show vlans
Configuration du routage inter-VLAN TP :
existant :
Sur le Routeur : Créez les vlans 10 et 20 et creez intervlan
R1(config)# interface g0/0 entre eux
R1(config)# ip address 172.17.10.1 255.255.255.0
R1(config)# no shut
R1(config)# interface g0/1
R1(config)# ip address 172.17.30.1 255.255.255.0
R1(config)# no shut

Configuration du routage inter-VLAN de


type router on a stick
Commutateur :
S1(config)# vlan 10
S1(config-vlan)# vlan 30
S1(config-vlan)# interface f0/5
S1(config-if)# switchport mode trunk
S1(config-if) # end
Réalisé par : Moumen Raii

DHCPv4 et DHCPv6

Configuration pour ipv4 : Configuration pour ipv6 :


Activation de service dhcp Activation de routage ipv6 :
R(config)# service dhcp R1(config)# ipv6 unicast-routing
Configuration d'un pool :
Configuration en tant que serveur DHCP : R1(config)# ipv6 dhcp pool pool-name
Exclusion des adresses ipv4 : Définir les parametres de Pool :
R1(config)# ip dhcp excluded-address 192.168.10.1 ( une R1(dhcpv6-config)# dns-server ServeurDNS
adresse ) R1(dhcpv6-config)# domain-name ServeurDNS
R1(config)# ip dhcp excluded-address 192.168.10.1 Configuration de l'interface DHCPv6 :
192.168.10.9 R1(config)# interface type-name
Configuration d'un pool : R1(config-if)# ipv6 dhcp server pool-name
R1(config)# ip dhcp pool pool-name R1(config-if)#ipv6 nd other-config-flag
Configuration des taches spécifique : Verification d'un serveur sans etat :
R1# show ipv6 dhcp pool
Définir le pool d'adresses :
R1(dhcp-config)#network 192.168.10.0 255.255.255.0 Configuration en tant que client sans etat :
R1(config)# interface g0/1
Définir le routeur/ l'adresses de passerelle par
R1(config-if)# ipv6 enable
defaut : R1(config-if)#ipv6 address autoconfig
R1(config-dhcp)#default -router 192.168.10.1
Verification d'un client sans etat :
Définir un serveur DNS : R1# show ipv6 dhcp pool ou
R1(config-dhcp)# domain-name ServeurDNS R1# debug ipv6 dhcp detail
Définir la durée du bail DHCP : Configuration en tant que serveur avec
R1(config-dhcp)# lease { j H M} ou infinite (durée infinie) etat :
Définir le serveur WINS de Netbios : (GNS3 Ou Configuration d'un pool :
autre R1(config)# ipv6 dhcp pool pool-name
R1(config-dhcp)# netbios-name-server 192.168.10.22 Définir les parametres de Pool :
Commandes Show de verification (gns3 ou autre) R1(dhcpv6-config)#address prefix
R1# show running-config | section dhcp 2001:DB8:CAFE:1::/64
Afficher la liste de toutes les liaisons entre adresse lifetime infinite
R1(dhcpv6-config)# domain-name tri2a.ma
IPv4 et
R1(dhcpv6-config)# dns-server 192.168.10.22
adresse MAC / Clients :
Configuration de l'interface DHCPv6 :
R1# show ip dhcp binding
R1(config)# interface type-name
Afficher les statistiques : R1(config-if)# ipv6 dhcp server pool-name
R1# show ip dhcp server statistics R1(config-if)#ipv6 nd managed-config-flag
Afficher les conflits : Verification d'un serveur avec etat :
R1# show ip dhcp server conflict R1# show ipv6 dhcp binding
Commande de Relais de DHCPv4 : Configuration en tant que client avec etat :
R(config)# interface g0/0 R1(config)# interface g0/1
R(config-if)# ip helper-address 192.168.11.6 R1(config-if)# ipv6 enable
R# show ip interface (pour vérifier) R1(config-if)#ipv6 address dhcp
Configuration d'un routeur en tant que Client Verification d'un client avec etat :
DHCP : R1# show ipv6 interface g0/1
R1(config)# interface g0/1 R1# debug ipv6 dhcp detail
R1(config-if)# ip address dhcp Commande de Relais de DHCPv6 :
R1(config-if)# no shutdown R(config)# interface g0/0
R1(config-if# end R(config-if)# ipv6 dhcp relay destination
R1# show ip interface g0/1 (pour vérifier) 2001:db8:cafe:1::6
R# show ipv6 dhcp interface g0/0 (pour vérifier)
Réalisé par : Moumen Raii

CCNA3
spanning tree protocol
Réalisé par : Moumen Raii
Réalisé par : Moumen Raii
Réalisé par : Moumen Raii
Réalisé par : Moumen Raii

Les commandes

Configurer le cout de port :


S1#Conf t
S1(config)# Interface f0/1
S1(config-if)# Spanning-tree cost 25
S1(config-if)# End
Réinitialiser le cout de port :
S1(config-if)# No spanning-tree cost
vérifier le coût de chemin et de port vers le pont racine
S1# Show spanning-tree
PVSTP+ : Configuration :
Methode 1 :
S1(config)# spanning-tree VLAN 1 root primary
S1(config)# end
S2(config)#spanning-tree VLAN 1 root secondary
S1(config)# end
Methode 2 :
S3(config)#spanning-tree VLAN 1 priority 24576
Verifier ID de pont :
S3# Show spanning –tree

Configuration de PortFast et de la protection BPDU :


S3(config)# interface f0/11
S3(config-if)# spanning-tree portfast
S3(config-if)# spanning-tree bpduguard enable
S3(config-if)# end
Verifier Portfast :
S2# show running-config interface f0/11
affiche le détail de la configuration Spanning Tree
S1# show spanning-tree active

RPVSTP+ :
S1#configure terminal
S1(config)# spanning-tree mode rapid-pvst
S1(config)# interface f0/2
S1(config-if)# spanning-tree link-type point-to-point
S1(config-if)# end
S1# clear spanning-tree detected-protocols
Réalisé par : Moumen Raii

Virtual Gateway : HSRP –GLBP

HSRP GLBP

Configurez le protocole GLBP sur R1.


R1(config)# interface g0/1
R1(config-if)# glbp 1 ip 192.168.1.254
R1(config-if)# glbp 1 preempt
Configurez HSRP sur R1 : R1(config-if)# glbp 1 priority 150
R1(config)# interface g0/1 R1(config-if)# glbp 1 load-balancing round-robin
R1(config-if)# standby 1 ip 192.168.1.1 Configurez le protocole GLBP sur R2.
R1(config-if)# standby 1 priority 150 R3(config)# interface g0/1
R1(config-if)# standby 1 preempt R3(config-if)# glbp 1 ip 192.168.1.254
Configurez HSRP sur R2: R3(config-if)# glbp 1 load-balancing round-robin
R3(config)# interface g0/1
R3(config-if)# standby 1 ip 192.168.1.1 Vérifiez le protocole GLBP.
Vérifiez le protocole HSRP. R1# show glbp
R1# show standby R1# show glpb brief
R1# show standby brief
Désactivez HSRP : Désactivez GLPB :
R1(config)# interface g0/1 R1(config)# interface g0/1
R1(config-if)# no standby 1 R1(config-if)# no glbp 1
Réalisé par : Moumen Raii

Agrégation de liaison : etherchannel (Lacp –pagp)

LACP
Réalisé par : Moumen Raii

Pagp
Réalisé par : Moumen Raii

EIGRP IPV4 –IPV6

Ipv4 Ipv6
Activer le Routage EIGRP : Activation de routage ipv6 :
R1(config)# router eigrp 1 R1(config)# ipv6 unicast-routing
1=le numéro de système autonome Activer le Routage EIGRP :
Configurer l'ID de routeur R1(config)# ipv6 router eigrp 2
R1(config-router) eigrp router-id 1.1.1.1 R1(config-rtr) # no shut
Annonce des réseaux : 2=le numéro de système autonome
R1(config-router) network 192.168.1.0 0.0.0.255 Configurer les adresses link-local :
Configurer et vérifier passive interface : R1(config)# interface s0/0/0
R1(config-router)# passive-interface g0/0 R1(config-if)# ipv6 adresse fe80::1 link-local
Afficher la table de voisinage : Configurer l'ID de routeur
R1# show ip eigrp neighbors R1(config-router) eigrp router-id 1.1.1.1
Affiche d'autres informations sur le routage : Activation du protocole EIGRP dans les interfaces:
R1# show ip protocols R1(config)# interface g0/0
Désactiver la récapitulation automatique : R1(config-if) ipv6 eigrp 2
R1(config-router)# no auto-summary R1(config-if) exit
Configurer la récapitulation automatique : Configurer et vérifier passive interface :
R1(config)# router eigrp 2 R1(config)# ipv6 router eigrp 2
R1(config-router)# auto-summary R1(config-rtr)# passive-interface g0/0
---------------------------------------------------------------------------------------------- Afficher la table de voisinage :
Configurer la métrique de la Bande Passante : R1# show ip eigrp neighbors
R1(config)# interface s0/0/0 Configurer une route récapitulative manuel :
R1(config-if)# bandwith 64 (en kilo) R1(config)# interface serial 0/0/0
Afficher la table Topologique de EIGRP : R1(config-if)# ip v6 summary-address eigrp 2
R1# show ip eirgp topology- 2001:db8:acad::/48
Afficher la table Topologique de EIGRP (tous les Configurer et propager une route statique par défaut
liens:) R1(config)# ipv6 route ::/0 s0/0/0
R1# show ip eirgp topology all-links R1(config)# ipv6 router eigrp 2
Configurer une route récapitulative manuel : R1(config-rtr)# redistribute static
R1(config)# interface serial 0/0/0 Configurer l'utilisation de BP :
R1(config-if)# ip summary-address eigrp R1(config)# interface serial 0/0/0
192.168.0.0 255.255.252.0 R1(config-if) ipv6 bandwith-percent eigrp 2 40 (40
Vérifier la route récupitulative : kilo)
R1# show ip route eigrp Configurer le minuteurs Helle et mise en attente :
Configurer et propager une route statique par R1(config)# interface serial 0/0/0
défaut R1(config-if) ipv6 hello-interval eigrp 2 50 (50 s)
R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/0 R1(config-if) ipv6 hold-time eigrp 2 150 (150 s)
R1(config)# router eigrp 1 -------------------------------------------------------------------------------------------
R1(config-router) redistribute static Créer une chaine de clés et d'une clé :
-Configurer l'utilisation de Bande Passante : R1(config) # key chain EIGRP_KEY
R1(config)# interface serial 0/0/0 R1(config-keychain)# key 1
R1(config-if) ip bandwith-percent eigrp 1 40 (40 R1(config-keychain_key)# key-string cisco123
kilo) Configurer l'autentification EIGRRP :
Configurer le minuteurs Hello et mise en attente : R1(config)# interface g0/0
R1(config)# interface serial 0/0/0 R1(config-if)# ip authentication mode eigrp as-
R1(config-if) ip hello-interval eigrp 1 50 (50 s) number md5
R1(config-if) ip hold-time eigrp 1 150 (150 s) R1(config-if)# ip authentication mode eigrp as-
Equilibrage de la charge : number EIGRP_KEY
Router(config-router)# maximum-paths 4 ( 4 route)
Réalisé par : Moumen Raii

ACCESS CONTROL LIST (ACL)


IPV4

Définition

Une ACL permet de soit autoriser du trafic (permit) ou de le bloquer (deny).

Types des ACLs

ACL standard (numérotée)

ACL étendue (numérotée)

ACL nommée (peut être de type standard ou étendue).

ACL Standard

Permet d’analyser du trafic en fonction de: · Adresse IP source

Les ACLs standard sont à appliquer le plus proche possible de la destination en raison de
leur faible précision.

Configuration d’une ACL numérique standard

R1(config)#access-list 1 permit 192.168.0.0 0.0.0.255 R1(config)#access-list 1 permit


192.168.1.0 0.0.0.255 R1(config)#access-list 1 deny 192.168.0.0 0.0.3.255
R1(config)#access-list 1 permit any

Configuration d’une ACL nommée étendue

R1(config)#ip access-list extended monACLextended

R1(config-ext-nacl)#permit tcp any host 192.168.1.100 eq 80

R1(config-ext-nacl)#permit icmp 192.168.0.0 0.0.0.255 host 192.168.1.100 R1(config-ext-


nacl)#exit

Appliquer une ACL sur une interface


Réalisé par : Moumen Raii

ACLS IP V6
Réalisé par : Moumen Raii

Une fois que la liste de contrôle d'accès IPv6 est configurée, elle est associée à une interface à
l'aide de la commande ipv6 traffic-filter :

Router(config-if)# ipv6 traffic-filter access-list-name { in | out }


Réalisé par : Moumen Raii

CCNA4
Technolgie wan

encapsulation PPP (PAP-CHAP) ET HDLC


Configuration de l'authentification PAP Configuration de l'authentification
(bidirectionnel) CHAP
R1(config)# username User2 password User2-
password R1(config)# username User2 password User2-
R1(config)#interface S0/0/0 password
R1(config-if)# encapsulation ppp R1(config)# interface S0/0/0
R1(config-if)# ppp authentication pap R1(config-if)# encapsulation ppp
R1(config-if)# ppp pap sent-username User1 R1(config-if)# ppp authentication chap
password User1-password R1(config-if)# ppp chap hostname User1
R2(config)# username User1 password User1- R1(config-if)# ppp chap password User1-
password password
R2(config)#interface S0/0/0 R2(config)# username User1 password User1-
R2(config-if)# encapsulation ppp password
R2(config-if)# ppp authentication pap R2(config)# interface S0/0/0
R2(config-if)# ppp pap sent-username User2 R2(config-if)# encapsulation ppp
password User2-password R2(config-if)# ppp authentication chap
R2(config-if)# ppp chap hostname User2
R2(config-if)# ppp chap password User2-
password

Configuration de l'encapsulation HDLC


Router(config)# interface S 0/0/0
Router(config-if)# encapsulation hdlc
Dépannage d'une interface série :
R1# show interface serial 0/0/0
R1# show controllers serial 0/0/0
Réalisé par : Moumen Raii

Frame relay (point to point)


Frame Relay avec sous interfaces
R1(config)# interface serial 0/0/1
Activer encapsulatipm frame relay
R1(config-if)# encapsulation frame-relay
R1(config-if)# no shut
R1(config-if)# exit
Créer des sous interface
R1(config)# interface serial 0/0/1.102
point-to-point
R1(config-subif)# ip address 10.1.1.1
255.255.255.252
Déclaré les DLCI
R1(config-subif)#frame -relay interface-
dlci 102
R1(config-subif-dlci)# exit
R1(config-subif)# exit
R1(config)# interface serial 0/0/1.103
point-to-point
R1(config-subif)# ip address 10.1.1.5
255.255.255.252
R1(config-subif)#frame -relay interface-
dlci 103
Vérification d'un mappage statique
Frame Relay
R1# show frame-relay map
FRAME RELAY IPV6
R1(config)# interface serial 0/0/1
R1(config-if)# ipv6 address
2001:db8:cafe:1::1 /64
Declare les link local
R1(config-if)# ipv6 address fe80::1 link -
local
R1(config-if)# encapsulation frame-relay
R1(config-if)# frame-relay map ipv6
2001:DB8:CAFE:1::2 102
R1(config-if)# frame-relay map ipv6
FE80::2 102 brodcast
R2(config)# interface serial 0/0/1
R2(config-if)# ipv6 address
2001:db8:cafe:1::2 /64
R2(config-if)# ipv6 address fe80::2 link -
local
R2(config-if)# encapsulation frame-relay
R2(config-if)# frame-relay map ipv6
2001:DB8:CAFE:1::1 102
R2(config-if)# frame-relay map ipv6
FE80::1 201 brodcast
Réalisé par : Moumen Raii

Frame-Relay (Multipoint)
pour Multipoint; tous les liaisons est dans un seul sous-réseau.

Règle :
Router(config)#interface type numéro
Router(config-if)#no shutdown
Router(config-if)#ip address x.x.x.x masque
Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay map ip @ip dlci broadcast
vérification
Router#show frame-relay map

sur cloud
-création dlci sur les interfaces
-sur le bouton frame relay liée les dlci

Exemple :

sur Hub
Hub(config)#interface serial 0/0
Hub(config-if)#no shutdown
Hub(config-if)#ip address 192.168.123.1 255.255.255.0
Hub(config-if)#encapsulation frame-relay
Hub(config-if)#frame-relay map ip 192.168.123.2 102 broadcast
Hub(config-if)#frame-relay map ip 192.168.123.3 103 broadcast
Hub(config-if)#exit
sur Spoke1
Spoke1(config)#interface serial 0/0
Spoke1(config-if)#no shutdown
Réalisé par : Moumen Raii

Spoke1(config-if)#ip address 192.168.123.2 255.255.255.0


Spoke1(config-if)#encapsulation frame-relay
Spoke1(config-if)#frame-relay map ip 192.168.123.1 201 broadcast
Spoke1(config-if)#exit
sur Spoke2
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#no shutdown
Spoke2(config-if)#ip address 192.168.123.3 255.255.255.0
Spoke2(config-if)#encapsulation frame-relay
Spoke2(config-if)#frame-relay map ip 192.168.123.1 301 broadcast
Spoke2(config-if)#exit

NAT –PAT
Configuration de la fonction NAT statique : Configuration de la fonction NAT
R2(config)# ip nat inside source static 192.168.10.254 Dynamique :
209.165.201.5 R2(config)# ip nat pool NAT-POOL1
R2(config)#interface Serial 0/0//0 209.165.200.226
R2(config-if)#ip address 10.1.1.2 255.255.255.252 209.165.200.240 netmask 255.255.255.224
R2(config_if)# ip nat inside R2(config)# access-list 1 permit 192.168.0.0
R2(config-if)# exit 0.0.255.255
R2(config)# interface Serial 0/1//0 R2(config-if)#ip address 10.1.1.2 255.255.255.252
R2(config-if)# ip address 209.165.200.225 R2(config_if)# ip nat inside source list 1 pool NAT-
255.255.255.224 POOL1
R2(config_if)# ip nat outside R2(config-if)# exit
R2(config-if)# exit R2(config)# interface Serial 0/0//0
R2(config_if)# ip nat inside
R2(config-if)# exit
R2(config)# interface Serial 0/1//0
R2(config_if)# ip nat outside
R2(config-if)# exit

Vérification des traductions NAT statique :


R2# show ip nat translations
Effacer les statistiques des traductions
passées :
R2# clear ip nat statics
Réalisé par : Moumen Raii

PAT
Configuration de la fonction PAT
R2(config)# ip nat pool NAT-POOL2 209.165.200.226 209.165.200.240
netmask 255.255.255.224
R2(config)# acces-list 1 permit 192.168.0.0 0.0.255.255
R2(config)# ip nat inside source list 1 pool NAT-POOL2 overload
R2(config)# interface Serial 0/0/0
R2(config-if)# ip nat inside
R2(config)# interface Serial 0/1/0
R2(config-if)# ip nat outside
PAT avec une seule adresse :
R2(config)# ip nat source list 1 interface serial 0/1/0 overload
R2(config)# access-list 1 permit 192.168.0.0 0.0.255.255
R2(config)# interface serial 0/0/0
R2(config-if)# ip nat inside
R2(config-if)#exit
R2(config)# interface serial 0/1/0
R2(config-if)# ip nat outside
R2(config-if)#exit
Réalisé par : Moumen Raii

VPN (Tunnel GRE )

Configuration de tunnel GRE

Pour Routeur 1 :
R1(config)# interface Tunnel 0
R1(config-if)# tunnel mode gre ip
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)# tunnel source 1.1.1.1
R1(config-if)# tunnel destination 2.2.2.2
R1(config-if)# router ospf 1
R1(config-if)# network 192.168.2.0 0.0.0.255 area 0

Pour Routeur 2 :
R2(config)# interface Tunnel0
R2(config-if)# tunnel mode gre ip
R2(config-if)#ip address 172.16.1.2 255.255.255.0
R2(config-if)# tunnel source 2.2.2.2
R2(config-if)# tunnel destination 1.1.1.1
R2(config-if)# router ospf 1
R2(config-if)# network 192.168.2.0 0.0.0.255 area 0
Réalisé par : Moumen Raii

Configuration du tunnel Ipv6

RouteurDroite

Router(config)#interface Tunnel0
Router(config-if)#ipv6 address FC00:F::2/64
Router(config-if)#tunnel source s0/0/0
Router(config-if)#tunnel destination 192.168.1.1
Router(config-if)#no shutdown
Router(config-if)#tunnel mode ipv6ip
Router(config-if)#exit
Router(config)#ipv6 route FC00:A::/64 FC00:F::1

Routeur Gauche

Router(config)#interface Tunnel0
Router(config-if)#ipv6 address FC00:F::1/64
Router(config-if)#tunnel source s0/0/0
Router(config-if)#tunnel destination 192.168.1.2
Router(config-if)#no shutdown
Router(config-if)#tunnel mode ipv6ip
Router(config-if)#exit
Router(config)#ipv6 route FC00:B::/64 FC00:F::2
Router(config)#
Réalisé par : Moumen Raii

SYSLOG –Ntp-Netflow
Résumé des Commandes Syslog : Résumé des Commandes NetFlow :
Configurez R1 de telle sorte que les
événements consignés Consigne les messages dans une mémoire
soient envoyés au serveur Syslog : tampon par défaut :
R1(config)# logging 192.168.1.3 R1(config)# logging buffered
Modifiez le niveau de gravité de la
journalisation à 4 : Envoyer des messages journaux à la console
R1(config)# logging trap 4 pour tous les niveaux de
Configurer l'interface source : gravité : R1(config)#logging console
R1(config)# logging source-interface g0/0
Envoyer Les horodatages avec les journaux Configuration de la capture des données
au serveur Syslog : NetFlow (Entrant et Sortant) :
R1(config) # interface g0/1
R1(config)# service timestamps log datetime msec
R1(config-if)# ip flow ingress
Vérification de Syslog : R1(config-if)# ip flow egress
R1 # show logging R1(config-if)# exit
Afficher l'heur
R1# show clock Configuration de l'exportation des données
Régler l'heure NetFlow vers le Collecteur :
R1# clock set 9:39:00 05 july 2013 R1(config)# flow export destination 192.168.1.3 2055
Configuration NTP :
Version de NetFlow à utiliser lors du formatage
des enregistrements
NetFlow envoyés au collecteur :
R1(config)# ip flow-export version 5

Vérification de la configuration Netflow :


R1# show ip cache flow
Sur pt : show flow cache
R1# show ip flow interface
R1# show ip flow export

Configuration R1 en tant que NTP Maitre :


R2(config)# ntp master 1
Configurer R2 en tant que NTP Client :
R1(config)# ntp server 10.118.112.1
R1(config)# ntp update-calendar
Réalisé par : Moumen Raii

SNMP
Configurez l'identifiant de communauté et
le niveau d'accès :
R1(config) # snmp-server community batonaug ro/rw
SNMP_ACL

Documentez l'emplacement du
périphérique :
R1(config) # snmp-server location
NOC_SNMP_MANAGER
Documentez le contact du système
R1(config) # snmp-server contact Wayne World
Limitez l'accès SNMP aux hôtes NMS :
R1(config) # snmp-server community string access-
list-number-or-name.
Spécifiez le destinataire des opérations de
déroutement SNMP :
R1(config) # snmp-server host 192.168.1.3
version{1| 2c | 3 [auth | noauth |priv]}] batonaug
Activer les déroutements sur un agent
SNMP :
R1(config) # snmp-server enable traps

Activer l’access list :


R1(config) # ip access-list standard SNMP_ACL
R1(config-std-nacl) # permit 192.168.1.3
Verification de la configuration SNMP :
R1 # show snmp
Service de communauté SNMP :
R1 # show snmp community
Créer un nouveau groupe SNMP sur le
périphérique :
R1 (config) # snmp-server group groupname {v1 |
v2c | v3 {auth | noauth | priv}
Ajouter un nouvel utilisateur au groupe
SNMP :
R1(config) # snmp-server user username groupname
v3 [encrypted] [auth {md5 |
sha} auth-password] [priv {des | 3des | aes {128
|192 | 256}} priv-password]
Réalisé par : Moumen Raii

Groupe sur facebook :

https://www.facebook.com/groups/NetworkArea.TRI/

Ma chaine sur youtube :

https://www.youtube.com/c/NETWORKINGAREA

Mon compte facebook :

https://www.facebook.com/profile.php?id=1000133
32913249