Vous êtes sur la page 1sur 7

LAB 7

Problem iBGP (Full Mesh)

Topologi :

Konfigurasi :

R1
/system identity
set name=R1
/interface bridge
add name=LAN
add name=loopback
/routing ospf network
add area=backbone network=1.1.1.1/32
add area=backbone network=192.168.12.0/24
/ip address
add address=1.1.1.1 interface=loopback network=1.1.1.1
add address=11.11.11.11 interface=LAN network=11.11.11.11
add address=192.168.12.1/24 interface=ether1 network=192.168.12.0
/routing bgp instance
set default as=123 router-id=1.1.1.1
/routing bgp peer
add name=peer1 remote-address=2.2.2.2 remote-as=123 update-source=1.1.1.1
/routing bgp network
add network=11.11.11.11/32

R2
/system identity
set name=R2
/interface bridge
add name=LAN
add name=loopback
/ip address
add address=2.2.2.2 interface=loopback network=2.2.2.2
add address=22.22.22.22 interface=LAN network=22.22.22.22
add address=192.168.12.2/24 interface=ether1 network=192.168.12.0
add address=192.168.23.2/24 interface=ether2 network=192.168.23.0
/routing ospf network
add area=backbone network=2.2.2.2/32
add area=backbone network=192.168.12.0/24
add area=backbone network=192.168.23.0/24/routing bgp instance
set default as=123 router-id=2.2.2.2
/routing bgp network
add network=22.22.22.22/32
/routing bgp peer
add name=peer1 remote-address=3.3.3.3 remote-as=123 update-source=2.2.2.2
add name=peer2 remote-address=1.1.1.1 remote-as=123 update-source=2.2.2.2

R3
/system identity
set name=R3
/interface bridge
add name=LAN
add name=loopback
/ip address
add address=3.3.3.3 interface=loopback network=3.3.3.3
add address=33.33.33.33 interface=LAN network=33.33.33.33
add address=192.168.23.3/24 interface=ether1 network=192.168.23.0
/routing ospf network
add area=backbone network=3.3.3.3/32
add area=backbone network=192.168.23.0/24
/routing bgp instance
set default as=123 router-id=3.3.3.3
/routing bgp network
add network=33.33.33.33/32
/routing bgp peer
add name=peer1 remote-address=2.2.2.2 remote-as=123 update-source=3.3.3.3

Verifikasi :

- Pastikan peer sudah established /routing bgp peer print


- Pastikan network BGP sudah diadvertised /routing bgp peer advertisements print
- Pastikan network BGP yang diadvertised sudah lengkap di routing tabel /ip route print
- Ping antar network BGP sudah bisa dilakukan
- Seharusnya R1 tidak memperoleh network R3 dan sebaliknya (karena masalah BGP split horizon),
solusinya adalah dengan membuat peer BGP antara R1 dan R3.
LAB 8
BGP Route-Reflector (Alternative Full-Mesh)

Topologi :

Konfigurasi :

R1
/system identity
set name=R1
/interface bridge
add name=LAN
add name=loopback
/ip address
add address=1.1.1.1 interface=loopback network=1.1.1.1
add address=11.11.11.11 interface=LAN network=11.11.11.11
add address=192.168.12.1/24 interface=ether1 network=192.168.12.0
/routing ospf network
add area=backbone network=1.1.1.1/32
add area=backbone network=192.168.12.0/24
/routing bgp instance
set default as=123 router-id=1.1.1.1
/routing bgp network
add network=11.11.11.11/32
/routing bgp peer
add name=peer1 remote-address=2.2.2.2 remote-as=123 update-source=1.1.1.1

R2
/system identity
set name=R2
/interface bridge
add name=LAN
add name=loopback
/ip address
add address=2.2.2.2 interface=loopback network=2.2.2.2
add address=22.22.22.22 interface=LAN network=22.22.22.22
add address=192.168.12.2/24 interface=ether1 network=192.168.12.0
add address=192.168.23.2/24 interface=ether2 network=192.168.23.0
/routing ospf network
add area=backbone network=2.2.2.2/32
add area=backbone network=192.168.12.0/24
add area=backbone network=192.168.23.0/24
/routing bgp instance
set default as=123 router-id=2.2.2.2 client-to-client-reflection=yes
/routing bgp network
add network=22.22.22.22/32
/routing bgp peer
add name=peer1 remote-address=3.3.3.3 remote-as=123 route-reflect=yes \
update-source=2.2.2.2

add name=peer2 remote-address=1.1.1.1 remote-as=123 route-reflect=yes \


update-source=2.2.2.2
add name=peer3 remote-address=4.4.4.4 remote-as=123 route-reflect=yes

R3
/system identity
set name=R3
/interface bridge
add name=LAN
add name=loopback
/ip address
add address=3.3.3.3 interface=loopback network=3.3.3.3
add address=33.33.33.33 interface=LAN network=33.33.33.33
add address=192.168.23.3/24 interface=ether1 network=192.168.23.0
add address=192.168.34.3/24 interface=ether2 network=192.168.34.0
/routing ospf network
add area=backbone network=3.3.3.3/32
add area=backbone network=192.168.23.0/24
add area=backbone network=192.168.34.0/24
/routing bgp instance
set default as=123 router-id=3.3.3.3
/routing bgp network
add network=33.33.33.33/32
/routing bgp peer
add name=peer1 remote-address=2.2.2.2 remote-as=123 update-source=3.3.3.3

R4
/system identity
set name=R4
/interface bridge
add name=LAN
add name=loopback
/ip address
add address=4.4.4.4 interface=loopback network=4.4.4.4
add address=44.44.44.44 interface=LAN network=44.44.44.44
add address=192.168.34.4/24 interface=ether1 network=192.168.34.0
/routing ospf network
add area=backbone network=192.168.34.0/24
add area=backbone network=4.4.4.4/32
/routing bgp instance
set default as=123 router-id=4.4.4.4
/routing bgp network
add network=44.44.44.44/32
/routing bgp peer
add name=peer1 remote-address=2.2.2.2 remote-as=123 update-source=4.4.4.4

Verifikasi :

- Pastikan semua peer established


- Pastikan network BGP sudah diadvertised
- Pastikan semua network BGP yang diadvertised muncul di tabel routing
- Pastikan semua network BGP bisa diping
LAB 9
BGP Confederation

Topologi

Konfigurasi

R1
/interface bridge
add name=LAN
add name=loopback
/routing bgp instance
set default as=100 router-id=1.1.1.1
/ip address
add address=192.168.1.1/24 interface=LAN network=192.168.1.0
add address=1.1.1.1 interface=loopback network=1.1.1.1
add address=192.168.12.1/24 interface=ether1 network=192.168.12.0
/routing bgp network
add network=192.168.1.0/24
/routing bgp peer
add name=peer1 remote-address=192.168.12.2 remote-as=234
/system identity
set name=R1

R2
/interface bridge
add name=loopback
/routing bgp instance
set default as=20 confederation=234 confederation-peers=30,40 router-id=\
2.2.2.2
/ip address
add address=192.168.12.2/24 interface=ether1 network=192.168.12.0
add address=192.168.23.2/24 interface=ether2 network=192.168.23.0
add address=192.168.24.2/24 interface=ether3 network=192.168.24.0
add address=2.2.2.2 interface=loopback network=2.2.2.2
/routing bgp peer
add name=peer1 remote-address=192.168.12.1 remote-as=100
add name=peer2 nexthop-choice=force-self remote-address=192.168.23.3 \
remote-as=30
/system identity
set name=R2

R3
/interface bridge
add name=loopback
/routing bgp instance
set default as=30 confederation=234 confederation-peers=20,40 router-id=\
3.3.3.3
/ip address
add address=3.3.3.3 interface=loopback network=3.3.3.3
add address=192.168.23.3/24 interface=ether1 network=192.168.23.0
add address=192.168.34.3/24 interface=ether2 network=192.168.34.0
/routing bgp peer
add name=peer1 nexthop-choice=force-self remote-address=192.168.23.2 \
remote-as=20
add name=peer2 nexthop-choice=force-self remote-address=192.168.34.4 \
remote-as=40
/system identity
set name=R3

R4
/interface bridge
add name=loopback
/routing bgp instance
set default as=40 confederation=234 confederation-peers=20,30 router-id=\
4.4.4.4
/ip address
add address=4.4.4.4 interface=loopback network=4.4.4.4
add address=192.168.24.4/24 interface=ether1 network=192.168.24.0
add address=192.168.34.4/24 interface=ether2 network=192.168.34.0
add address=192.168.45.4/24 interface=ether3 network=192.168.45.0
/routing bgp peer
add name=peer1 nexthop-choice=force-self remote-address=192.168.34.3 \
remote-as=30
add name=peer2 remote-address=192.168.45.5 remote-as=500
/system identity
set name=R4

R5
/interface bridge
add name=LAN
/routing bgp instance
set default as=500 router-id=5.5.5.5
/ip address
add address=192.168.5.1/24 interface=LAN network=192.168.5.0
add address=192.168.45.5/24 interface=ether1 network=192.168.45.0
/routing bgp network
add network=192.168.5.0/24
/routing bgp peer
add name=peer1 remote-address=192.168.45.4 remote-as=234
/system identity
set name=R5

Verifikasi
[admin@R1] > ip route p detail
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 ADC dst-address=1.1.1.1/32 pref-src=1.1.1.1 gateway=loopback
gateway-status=loopback reachable distance=0 scope=10

1 ADC dst-address=192.168.1.0/24 pref-src=192.168.1.1 gateway=LAN


gateway-status=LAN reachable distance=0 scope=10

2 ADb dst-address=192.168.5.0/24 gateway=192.168.12.2


gateway-status=192.168.12.2 reachable via ether1 distance=20
scope=40 target-scope=10 bgp-as-path="234,500" bgp-origin=igp
received-from=peer1

3 ADC dst-address=192.168.12.0/24 pref-src=192.168.12.1 gateway=ether1


gateway-status=ether1 reachable distance=0 scope=10
[admin@R5] > ip route print detail
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 ADb dst-address=192.168.1.0/24 gateway=192.168.45.4
gateway-status=192.168.45.4 reachable via ether1 distance=20
scope=40 target-scope=10 bgp-as-path="234,100" bgp-origin=igp
received-from=peer1

1 ADC dst-address=192.168.5.0/24 pref-src=192.168.5.1 gateway=LAN


gateway-status=LAN reachable distance=0 scope=10

2 ADC dst-address=192.168.45.0/24 pref-src=192.168.45.5 gateway=ether1


gateway-status=ether1 reachable distance=0 scope=10

Vous aimerez peut-être aussi