Vous êtes sur la page 1sur 10

Objetivo Aula: Fixação da linguagem Pascal. Exercícios Nível Básico.

ESTRUTURA SEQÜENCIAL

1) Calcular o custo de um bolo de aniversário, sabendo-se que o preço por quilo de bolo é

R$ 16,00. Dado: Peso total do bolo.

Programa BoloAniver;
Variáveis
Custo, Peso: Real;
Início
Custo ß 0;
Escreva (“Digite o peso total do bolo de aniversário:”);
Leia (Peso);
Custo ß Peso * 16,00;
Escreva (“O custo total do bolo é : ”, Custo);
Fim.

2) Um automóvel tem um consumo médio de 1 litro de gasolina para cada 16 km rodados.

Dados: Distância percorrida. Calcule a quantidade de gasolina consumida.

Programa ConsGasolina;
Variáveis
Consumo: Real;
Distancia: Inteiro;
Início
Consumo ß 0;
Escreva (“Digite o valor da distância percorrida:”);
Leia (Distancia);
Consumo ß Distancia/16;
Escreva(“A quantidade de gasolina consumida é: ”, Consumo);

- 1 -
ESTRUTURA CONDICIONAL

3) Dados: Nome do usuário e senha fornecidos pelo usuário. Verifique se o nome e a senha
são válidos considerando a tabela abaixo. Emita mensagem informando.

Usuário Senha
990870 AMARELO
234100 MAXIMO
355423 AMETISTA

Programa SenhaUsuario;
Variáveis
Usuario: Inteiro;
Senha: Caracter;
Início
Escreva (“Digite o usuário:”);
Leia (Usuario);
Escreva (“Digite a senha:”);
Leia (Senha);
Se (Usuario = 990870) e (Senha = “AMARELO”) então
Escreva (“Usuário e senha são válidos!”);
Senão
Se (Usuario = 234100) e (Senha = “MAXIMO”) então
Escreva (“Usuário e senha são válidos!”);
Senão
Se (Usuario = 355423) e (Senha = “AMETISTA”) então
Escreva (“Usuário e senha são válidos!”);
Senão
Escreva (“Usuários ou senha inválidos!”);
Fim Se;
Fim Se;
Fim Se;
Fim.

- 2 -
4) Dado: Consumo em KWH. Construa algoritmo para calcular a conta de energia elétrica
de uma fábrica conforme a tabela abaixo.
Consumo em Kwh Valor por Kwh - R$.
Até 300 1,25
De 301 até 500 1,50
De 501 até 600 1,75
De 601 até 800 2,00
Acima de 800 2,50
Programa ConsumoKWH;
Variáveis
Valor_Conta: Real; Consumo: Inteiro;
Início
Escreva (“Digite o consumo em KWH:”); Leia (Consumo);
Se (Consumo <= 300) então
Valor_Conta ß Consumo * 1,25;
Senão
Se (Consumo <= 500) então
Valor_Conta ß Consumo * 1,50;
Senão
Se (Consumo <= 600) então
Valor_Conta ß Consumo * 1,75;
Senão
Se (Consumo <= 800) então
Valor_Conta ß Consumo * 2,00;
Senão
Valor_Conta ß Consumo * 2,50;
Fim Se;
Fim Se;
Fim Se;
Fim Se;
Escreva (“O valor da conta é ”, Valor_Conta);
Fim.

- 3 -
5) Dados: Valores A, B e C. Construa algoritmo que leia esses os valores e verifique se a
soma deles é maior que 50, se for escreva uma mensagem informando.

Programa SomaValores;
Variáveis
A, B, C, Soma: Real;
Início
Escreva (“Digite o valor A:”);
Leia (A);
Escreva (“Digite o valor B:”);
Leia (B);
Escreva (“Digite o valor C:”);
Leia (C);
Soma ß A + B + C;
Se (Soma > 50) então
Escreva (“A soma dos números é maior que 50.”);
Senão
Escreva (“A soma dos números não é maior que 50.”);
Fim Se;
Fim.

- 4 -
6) Construa algoritmo para calcular a área de um retângulo e mostrá-la em vídeo. Sabe-se
que Área = Base * Altura. São dados: Valor da Base e da Altura.

Programa Retangulo;
Variáveis
Area, Base, Altura: Real;
Início
Area ß 0;
Escreva (“Digite o valor da Base:”);
Leia (Base);
Escreva (“Digite o valor da Altura:”);
Leia (Altura);
Se (Base = 0) ou (Altura = 0) então
Escreva (“Não forma um retângulo!”);
Senão
Area ß Base * Altura;
Escreva (“ A área do retângulo é:”, Area);
Fim Se;
Fim.

- 5 -
7) Dados: três números. Verifique qual é o maior e se existirem iguais, informe mensagem.

Programa MaiorTres;
Variáveis
A, B, C, Maior: Real;
Início
Maior ß 0;
Escreva (“Digite o valor A:”);
Leia (A);
Escreva (“Digite o valor B:”);
Leia (B);
Escreva (“Digite o valor C:”);
Leia (C);
Se (A > B) e (A > C) então
Escreva (“O maior é “, A);
Senão
Se (B > A) e (B > C) então
Escreva (“O maior é “, B);
Senão
Se (C > A) e (C > B) então
Escreva (“O maior é “, C);
Senão
Escreva (“Existem números iguais.”);
Fim Se;
Fim Se;
Fim Se;
Fim.

- 6 -
8) Dados: dois números digitados pelo usuário. Verifique qual é o maior e mostre a
diferença entre os dois. Emitir mensagem alertando o usuário que os números devem ser
diferentes.

Programa DiferencaMaior;
Variáveis
N1, N2, Diferenca: Real;
Início
Diferenca ß 0;
Escreva (“Digite o valor do primeiro número:”);
Leia (N1);
Escreva (“Digite o valor do segundo número:”);
Leia (N2);
Se (N1 = N2) então
Escreva (“Os números devem ser diferentes.”);
Senão
Se (N1 > N2) então
Diferenca ß N1 – N2;
Escreva (“O maior é “, N1, “ e a diferença entres os dois é “, Diferença);
Senão
Diferenca ß N2 – N1;
Escreva (“O maior é “, N2, “ e a diferença entres os dois é “, Diferença);
Fim Se;
Fim Se;
Fim.

- 7 -
9) Dados: dois números diferentes introduzidos pelo usuário. Mostre-os em ordem
crescente.

Programa OrdemCrescente;
Variáveis
N1, N2: Real;
Início
Escreva (“Digite o valor do primeiro número:”);
Leia (N1);
Escreva (“Digite o valor do segundo número:”);
Leia (N2);
Se (N1 = N2) então
Escreva (“Os números são iguais.”);
Senão
Se (N1 > N2) então
Escreva (N2, N1);
Senão
Escreva (N1, N2);
Fim Se;
Fim Se;
Fim.

- 8 -
ESTRUTURA DE REPETIÇÃO
10) Construa algoritmo para mostrar os funcionários aprovados em um concurso interno.
Dados: Matrícula, nome e nota que o funcionário tirou no concurso. Sabe-se que a nota de
corte é menor que 7,0. Parar o programa quando matrícula for igual a 000.

Programa ConcursoInterno;
Variáveis
Nome: Caracter;
Matricula: Inteiro;
Nota: Real;
Início
Escreva (“Digite o nº da matrícula:”);
Leia (Matricula);
Enquanto (Matricula <> 000) faça
Escreva (“Digite o nome do funcionário:”);
Leia (Nome);
Escreva (“Digite a nota do funcionário:”);
Leia (Nota);
Se (Nota >= 7) então
Escreva (Matricula, Nome, Nota);
Fim Se;
Escreva (“Digite o nº da matrícula:”);
Leia (Matricula);
Fim Enquanto;
Fim.

- 9 -
11) Dados: 10 números digitados pelo usuário. Construa algoritmo para mostrar os valores
negativos e que calcule e mostre a média dos valores menores que zero.

Programa DezNumeros;
Variáveis
Cont, CN: Inteiro;
Num, MediaN, SomaN: Real;
Início
Cont ß 1;
CN ß 0;
MediaN ß 0;
SomaN ß 0;
Enquanto (Cont <= 10) faça
Escreva (“Digite um número:”);
Leia (Num);
Se (Num < 0) então
SomaN ß SomaN + Num;
CN ß CN + 1;
Escreva (Num);
Fim Se;
Cont ß Cont + 1;
Fim Enquanto;
MediaN ß SomaN/ CN;
Escreva (MediaN);
Fim.

- 10 -