Vous êtes sur la page 1sur 13

UNIVERSIDAD TÉCNICA DE COTOPAXI

ELABORADO POR:

FABIAN QUILUMBA

FECHA DE ENTREGA:

12 de enero . 2017

NIVEL

II CICLO “A”

ESPECILIDAD:

Ing. ELECTRICA

ASIGNATURA:

LENGUAJE DE PROGRAMACION
(EL SÍMBOLO ! REPRESENTA AL FACTORIAL EJ. 5! = 120)

Ejercicio 1.- Encontrar el valor de la siguiente expresión, hasta n.

𝒂𝒃𝒄𝟏 𝒂𝒃𝒄𝟏 𝒂𝒃𝒄𝟐 𝒂𝒃𝒄𝟑 𝒂𝒃𝒄𝟓 𝒂𝒃𝒄𝟖


− + − + − …𝒏
𝟑 𝟔 𝟗 𝟏𝟐 𝟏𝟓 𝟏𝟖

Proceso ejercicio_1

ESCRIBIR "Ingrese la cantidad de repeticiones que desee"

LEER n

ESCRIBIR "Ingrese por teclado los valores que desee para el numerador"

Escribir "Ingrese el valor de a"

LEER a

Escribir "Ingrese el valor de b"

Leer b

ESCRIBIR "Ingrese el valor de c"

LEER c

P=3

acum=0

d=1

e=0

Num=0

Sig=(1)

Para i<-1 Hasta n Con Paso 1 Hacer

Num= (a*b*c)

den=P

d=d+e

e=d-e
p=p+3

Num1= Num^e

div=(Num1/den)

r=div*Sig

acum= acum+r

Sig= Sig*(-1)

Fin Para

ESCRIBIR "El resultado de la operación es ", acum

FinProceso

Ejercicio 2.- Encontrar el valor de la siguiente expresión, hasta n.

𝟐𝒎𝒏 𝟔𝒎𝒏 𝟏𝟎𝒎𝒏 𝟏𝟒𝒎𝒏 𝟏𝟖𝒎𝒏 𝟐𝟐𝒎𝒏


− 𝟏 + − + − …𝒏
𝟒𝟏 𝟖 𝟏𝟐𝟐 𝟏𝟔𝟑 𝟐𝟎𝟓 𝟐𝟒𝟖

Proceso Ejericio_2

ESCRIBIR "Ingrese la cantidad de repeticiones que desee"

LEER N

ESCRIBIR "INGRESE EL VALOR DEL NUMERADOR"

Escribir "Ingrese el valor de m"

LEER m

Escribir "Ingrese el valor de n"

Leer n

p=2

x=4

acum=0

a=1
b=0

c=0

Sig=(1)

Para I<-1 Hasta N Con Paso 1 Hacer

c=(m*n)

a=a+b

b=a-b

v=x^b

t=c*p

p=p+4

x=x+4

div=(t/v)

r=div*Sig

acum=acum+r

sig=sig*(-1)

Fin Para

ESCRIBIR "El resultado de la operación es ", acum

FinProceso

Ejercicio 3.- Encontrar el valor de la siguiente expresión, hasta n.

𝒎! 𝒏𝟒 − 𝒎! 𝒏𝟖 + 𝒎! 𝒏𝟏𝟐 − 𝒎! 𝒏𝟏𝟔 + 𝒎! 𝒏𝟐𝟎 − 𝒎! 𝒏𝟐𝟒 … … . 𝒏

Proceso ejercicio_3

Escribir "ingrese n"

Leer n

Escribir "ingrese x"

Leer x

Escribir "ingrese y1"


Leer y1

sig = 1

acu=0

sup=4

Para i<-1 Hasta n Con Paso 1 Hacer

f=1

Para j<-1 Hasta x Con Paso 1 Hacer

f=f*j

Escribir ,f

Fin Para

der=y1^sup

div=f*der

div=div*sig

acu=acu+div

sig=sig*(-1)

sup=sup+4

Fin Para

Escribir "el resultado es ", acu

FinProceso

Ejercicio 4.- Encontrar el valor de la siguiente expresión, hasta n.

𝒑𝒎𝟐 𝒑𝒎𝟒 𝒑𝒎𝟔 𝒑𝒎𝟖 𝒑𝒎𝟏𝟎 𝒑𝒎𝟏𝟐


− 𝟒 + 𝟔 − 𝟖 + 𝟏𝟎 − 𝟏𝟐 … … . 𝒏
𝟏𝟐 𝟏 𝟐 𝟑 𝟓 𝟖

Proceso EJERCICIO_4

ESCRIBIR "ingrese el numero de repeticiones..."

leer c

ESCRIBIR "introduce el valor de p..."

leer p
ESCRIBIR "introduce el valor de m..."

leer m

Para i<-1 Hasta c Con Paso 1 Hacer

A=1

B=0

ex= 2

acum = 0

sig = (1)

Para I<-1 Hasta c Con Paso 1 Hacer

ESCRIBIR A

n=p*(m^ex)

den = a^ex

div= n/den

acum = acum +div *(sig)

sig = sig * (-1)

A=A+B

B=A-B

ex=ex+2

Fin Para

escribir "el resultado total es " acum

Fin Para

FinProceso

Ejercicio 5.-
Realizar un programa que permita obtener el factorial de cada uno de los n números de la serie de
los Fibonacci (Fibonacci: 1,1,2,3,5,8,13,etc) (UTILIZAR EL CICLO MIENTRAS )

Ej: n=5

Resultado:

fibonacci: 1......... Factorial: 1

fibonacci: 1......... Factorial: 1

fibonacci: 2......... Factorial: 2

fibonacci: 3......... Factorial: 6

fibonacci: 5......... Factorial: 120

Proceso ejercicio_5

ac=1

z=0

i=0

fac=1

Escribir "Ingrese un numero de la serie de finonacci"

Leer n

Mientras i<=n Hacer

Escribir "Fibonacci es ",ac, " el factorial de la serie de fibonacci es ", fac

i=ac+z

z=ac

ac=i

fac=fac*ac

Fin Mientras

FinProceso

Ejercicio 6.-
Realizar un programa que pida a usuario el ingreso de un valor numérico de tres cifras. Si el
usuario ingresa un valor distinto al solicitado, el programa debe solicitar el ingreso nuevamente
hasta que el usuario ingrese un valor de acuerdo con lo solicitado.Se debe especificar mediante
mensaje, en qué intento el usuario ingreso correctamente el valor. Imprimir por pantalla en orden
ascendente los tres dígitos, además de su suma.

Proceso Ejercicio_6

x=0

Repetir

x=x+1

Escribir "Ingrese un valor de 3 cifras"

Leer v

Si v>99 Y v<1000 Entonces

Escribir "El valor ingresado es correcto"

Sino

Escribir "El valor ingresado no posee 3 cifras"

Fin Si

Hasta Que v>99 Y v<1000

FinProceso

Ejercicio 7.- Encontrar el valor de la siguiente expresión, hasta n.

𝟒𝒑! 𝟖𝒑! 𝟏𝟐𝒑! 𝟏𝟔𝒑! 𝟐𝟎𝒑! 𝟐𝟒𝒑!


− + − + − .….𝒏
𝟏𝒒 𝟏𝒒 𝟐𝒒 𝟑𝒒 𝟓𝒒 𝟖𝒒

Algoritmo Ejercicio_7

Escribir "INGRESE EL VALOR A REPETIR"

Leer n
Escribir "ingrese el valor de numerador p:"

Leer p

Escribir "Ingrese el valor del numerador q: "

Leer q

ge=n*4

x=1

z=0

r=0

t=0

Para t<-4 Hasta ge Con Paso 4 Hacer

tr=q*t

fact<-1

c<-1

Mientras c<=p Hacer

fact<-fact*c

c<-c+1

FinMientras

Si t MOD 8=0 entonces

g=tr*(-1)

Sino

g=tr*1

Fin Si

r<-x+z

z<-x

x<-r

tu=z*(fact)

pr=tu/g
Escribir " ",tu "/",g "=",pr

res=res+(tu/g)

Fin Para

Escribir "El Resultado Que Se Obtiene de la Fracción: ",res

Escribir "GRACIAS POR SU ATENCION"

FinProceso

Ejercicio 8.- Encontrar el valor de la siguiente expresión, hasta n.

𝟏𝒑! 𝟏𝒑! 𝟐𝒑! 𝟑𝒑! 𝟓𝒑! 𝟖𝒑!


− + − + − .….𝒏
𝟒! 𝟖! 𝟏𝟐! 𝟏𝟔! 𝟏𝟖! 𝟐𝟎!

Proceso ejercicio8

Escribir "Ingrese el valor de p"

Leer p

Escribir "Ingrese el número de repeticiones a calcular"

Leer n

f<-0

g<-1

fb=0

Para cont<-0 Hasta n-1 Con Paso 1 Hacer

Si cont=0 Entonces

ex=1

Sino

Mientras fb<cont Hacer

ex=f+g

f=g

g=ex

fb=fb+1

Fin Mientras
Fin Si

Fac=1

Para k<-1 Hasta p Con Paso 1 Hacer

Fac=k*Fac

Fin Para

num=4+(4*cont)

Fac2=1

Para k<-1 Hasta num Con Paso 1 Hacer

Fac2=k*Fac2

Fin Para

sig=(-1)^cont

Var=(sig*ex*Fac)/(Fac2)

R=R+Var

Fin Para

Escribir " ", R

FinProceso

Ejercicio 9.- Encontrar el valor de la siguiente expresión, hasta n.

𝒑𝒒𝟏 𝒑𝒒𝟏 𝒑𝒒𝟐 𝒑𝒒𝟑 𝒑𝒒𝟓 𝒑𝒒𝟖


− + − + − ….𝒏
𝟐𝒓 𝟒𝒓 𝟐𝒓 𝟒𝒓 𝟐𝒓 𝟒𝒓

Proceso Ejercicio_9

ESCRIBIR "INGRESE EL VALOR PARA P"

LEER P

ESCRIBIR "INGRERSE UN VALOR PARA Q"

LEER Q

ESCRIBIR "INGRERSE UN VALOR PARA R"


LEER R

ESCRIBIR "INGRERSE LA CANTIDAD DE N QUE DESEA LA SERIE"

LEER N

D=1

E=0

i1=0

c1=1

b1=1

Para I<-1 Hasta N Con Paso 1 Hacer

ESCRIBIR D

D=D+E

E=D-E

i1=i1+2

NUN=(P*Q)^D

DEN=i1*b1

DIV=NUN/DEN

si i mod 2 = 1 Entonces

k3=k3+DIV

Sino

p2=DIV*(-1)

k4=k4+p2

FinSi

Fin Para

RES=k3+k4

Escribir "la respuesta es ", RES


FinProceso

Ejercicio 10.- Encontrar el valor de la siguiente expresión, hasta n.

𝒑𝒒𝟏 𝒑𝒒𝟏 𝒑𝒒𝟐 𝒑𝒒𝟑 𝒑𝒒𝟓 𝒑𝒒𝟖


− + − + − ….𝒏
𝟐𝒓𝟔 𝟒𝒓𝟑 𝟐𝒓𝟔 𝟒𝒓𝟑 𝟐𝒓𝟔 𝟒𝒓𝟑
Algoritmo sin_titulo Escribir "Ingrese el valor de p" Leer p Escribir "Ingrese el valor de q" Leer q Escribir "Ingrese el valor de r"
Leer s Escribir "Ingrese el número de repeticiones a calcular" Leer n f<-0 g<-1 fb=0 Var=0 R=0 Para cont<-0 Hasta n-1 Con
Paso 1 Hacer Si cont=0 Entonces ex=1 Sino Mientras fb<cont Hacer ex=f+g f=g g=ex fb=fb+1 Fin Mientras Fin Si Si cont Es
Multiplo De 2 Entonces num=2 Sino num=4 Fin Si Si cont Es Multiplo De 2 Entonces ex2=6 Sino ex2=3 Fin Si sig=(-1)^cont
Var=(sig*(p*q)^ex)/(num*s)^ex2 R=R+Var Fin Para Escribir " ", R FinProceso