Vous êtes sur la page 1sur 8

Tutorial realizado por: www.GarciaGaston.com.

ar

CONFIGURAR RIP EN PACKET TRACER

Este tutorial es para que comprendan cómo funciona y cómo se configura el protocolo de
enrutamiento RIP. Como van a ver, no la configuración básica no tiene grandes complicaciones.

En el gráfico pueden ver la topología que vamos a usar y que tienen armada y funcionando en
Packet Tracer. La finalidad del ejercicio es que se pueda enrutar tráfico entre las redes
192.168.1.0/24, 192.168.2.0/24 y 192.168.3.0/24 utilizando el protocolo de enrutamiento RIP.

Observaciones: Por limitaciones del Packet Tracer no pude ha realizar ninguna config compleja. La
idea original del tutorial era configurar RIP Versión 1 y 2 al mismo tiempo, pero no soporta los
comandos “ip rip send version” e “ip rip receive version”, ni otras tantas. Igualmente para lo
básico el tutorial les va a servir.
PASO 1 - Configuración de los Hosts

Host 1

IP: 192.168.1.2
Máscara: 255.255.255.0
Default Gateway: 192.168.1.1

Host 2

IP: 192.168.2.2
Máscara: 255.255.255.0
Default Gateway: 192.168.2.1

Host 3

IP: 192.168.3.2
Máscara: 255.255.255.0
Default Gateway: 192.168.3.1

Observaciones: El default gateway (puerta de enlace) para los hosts es la interfaz del router
conectada a la red a la cual pertenece el host. En este caso es la FastEthernet 0/0 de cada router.
PASO 2 - Configuración Básica de los Routers

Router A

Router>enable
Router#config terminal
Router(config)#hostname RouterA
RouterA(config)#interface fastethernet 0/0
RouterA(config-if)#ip address 192.168.1.1 255.255.255.0
RouterA(config-if)#no shutdown
RouterA(config-if)#exit
RouterA(config)#interface serial 0/0
RouterA(config-if)#ip address 10.0.0.2 255.0.0.0
RouterA(config-if)#no shutdown

Router B

Router>enable
Router#config terminal
Router(config)#hostname RouterB
RouterB(config)#interface fastethernet 0/0
RouterB(config-if)#ip address 192.168.2.1 255.255.255.0
RouterB(config-if)#no shutdown
RouterB(config-if)#exit
RouterB(config)#interface serial 0/0
RouterB(config-if)#ip address 10.0.0.1 255.0.0.0
RouterB(config-if)#clock rate 56000
RouterB(config-if)#no shutdown
RouterB(config-if)#exit
RouterB(config)#interface serial 0/1
RouterB(config-if)#ip address 11.0.0.1 255.0.0.0
RouterB(config-if)#clock rate 56000
RouterB(config-if)#no shutdown

Router C

Router>enable
Router#config terminal
Router(config)#hostname RouterC
RouterC(config)#interface fastethernet 0/0
RouterC(config-if)#ip address 192.168.3.1 255.255.255.0
RouterC(config-if)#no shutdown
RouterC(config-if)#exit
RouterC(config)#interface serial 0/1
RouterC(config-if)#ip address 11.0.0.2 255.0.0.0
RouterC(config-if)#no shutdown

Observaciones: Con los routers así configurados tienen que tener conectividad básica entre todos
los dispositivos. Si tienen dudas hagan desde los routers, en el modo exec privilegiado (#), un
“show cdp neighbors” y en el resultado, si está todo bien configurado, les deben aparecer los
routers y switchs directamente conectados, si no les aparece alguno revisen la configuración porque
algo mal hicieron.
PASO 3 - Configurar de RIP

El ejercicio lo voy a hacer usando RIP Versión 2, pero omitiendo la línea “version 2” toma por
defecto la Versión 1 de RIP.

Router A

RouterA>enable
RouterA#config terminal
RouterA(config)# router rip
RouterA(config-router)# network 10.0.0.0
RouterA(config-router)# network 192.168.1.0
RouterA(config-router)# version 2

Observaciones: Con el comando “network” publicamos las redes directamente conectadas al


RouterA (10.0.0.0 y 192.168.1.0), noten que solo se pone la dirección de red, sin la máscara.

RouterB

RouterB>enable
RouterB#config terminal
RouterB(config)# router rip
RouterB(config-router)# network 10.0.0.0
RouterB(config-router)# network 11.0.0.0
RouterB(config-router)# network 192.168.2.0
RouterB(config-router)# version 2

Observaciones: Con el comando “network” publicamos las redes directamente conectadas al


RouterA (10.0.0.0, 11.0.0.0 y 192.168.2.0), noten que solo se pone la dirección de red, sin la
máscara.

RouterC

RouterC>enable
RouterC#config terminal
RouterC(config)# router rip
RouterC(config-router)# network 11.0.0.0
RouterC(config-router)# network 192.168.3.0
RouterC(config-router)# version 2

Observaciones: Con el comando “network” publicamos las redes directamente conectadas al


RouterA (11.0.0.0 y 192.168.3.0), noten que solo se pone la dirección de red, sin la máscara.
Comprobación de Conectividad entre Dispositivos

Antes de configurar RIP tienen que estar seguros de que todos los dispositivos vecinos de la
topología se están viendo.
Una de las formas es usando el comando “show cdp neighbors” desde cada router que nos mostrará
en su resultado los routers y switchs directamente conectados a el, si no aparece alguno hay algo
mal configurado.

Otra cosa que tienen que probar es que los hosts se comuniquen con el “default gateway” (puerta de
enlace) de la red, esto lo pueden hace con un ping desde un host a la IP de la interfaz del router
conectada a la red a la que pertenece el host.

Resultado “Show CDP Neighbors” en RouterA

Resultado “Show CDP Neighbors” en RouterB

Resultado “Show CDP Neighbors” en RouterC

Observaciones: En el caso que no esté habilitado el protocolo CDP, lo habilitan desde:


RouterX(config)# cdp run.
Comprobación de RIP

El comando “show ip route” muestra la tabla de enrutamiento del dispositivo. Las rutas marcadas
con “C” pertenecen a las redes directamente conectadas, las marcadas con “R” son las rutas
aprendidas mediante el protocolo de enrutamiento RIP.

Resultado “Show IP Route” en RouterA

Observaciones: En el RouterA la lectura será la siguiente: Todo tráfico con destino a las redes
192.168.2.0, 192.168.3.0 y 11.0.0.0 será enviado por la interfaz serial 0/0 y fue aprendido mediante
la publicación RIP enviada por la interfaz 10.0.0.1 del RouterB.

Resultado “Show IP Route” en RouterB

Observaciones: En el RouterB la lectura será la siguiente: Todo tráfico con destino a la red
192.168.1.0 será enviado por la interfaz serial 0/0 y fue aprendido mediante la publicación RIP
enviada por la interfaz 10.0.0.2 del RouterA. Todo tráfico con destino a la red 192.168.3.0 será
enviado por la interfaz serial 0/1 y fue aprendido mediante la publicación RIP enviada por la
interfaz 11.0.0.2 del RouterC.
Resultado “Show IP Route” en RouterC

Observaciones: En el RouterC la lectura será la siguiente: Todo tráfico con destino a las redes
192.168.1.0, 192.168.2.0 y 10.0.0.0 será enviado por la interfaz serial 0/1 y fue aprendido mediante
la publicación RIP enviada por la interfaz 11.0.0.1 del RouterB.
Comprobación del Ejercicio

Para comprobar el ejercicio solo basta con hacer ping desde los host 1, 2 y 3 y si son todos exitosos
el ejercicio está ok.

Les dejo la captura de la comprobación del ejercicio. Como podrán ver funciona.