Vous êtes sur la page 1sur 7

CONCEPTS DE BASE DE CISCO CALLMANAGER EXPRESS -

PARTIE 2
Notre article précédent, Concepts de base de Cisco CallManager Express - Première partie, traitait des concepts de
base du CCME et de son fonctionnement . Cet article se poursuit avec les concepts de base Cisco CallManager
Express examinera et analysera les ePhone , concepts ePhone-dn , comment configurer les téléphones IP et
les considérations voip bande passante .

EPHONE & EPHONE-DN

Le système Cisco CallManager Express consiste en un routeur (ou simplement une "boîte" pour la série UC 500) qui
sert de passerelle vocale (PBX) et en un ou plusieurs VLAN qui connectent les téléphones IP et les périphériques
téléphoniques au routeur.

Tous les types de PBX sont constitués de téléphones physiques et de leurs numéros de répertoire internes
(extensions). Le même concept s'applique dans CallManager Express. Les téléphones physiques sont appelés
« ephone », ce qui signifie « téléphone Ethernet » et les numéros de répertoire, « ephone-dn », ou « numéro de
téléphone Ethernet »:

Un ephone peut représenter tout type / modèle de téléphone physique disponible et pris en charge par
Cisco. CallManager Express reconnaîtra un périphérique téléphonique physique à partir de sa configuration ephone,
qui contient également l'adresse MAC du périphérique.

Par exemple, un téléphone IP Cisco 7945 avec une adresse MAC de 0027.0D3F.30B8 représente le téléphone
électronique. Le numéro de répertoire 32 attribué à ce téléphone représente le numéro ephone-dn.

Les numéros de répertoire sont attribués aux boutons de ligne sur les téléphones lors de la configuration.

Cela signifie que chaque téléphone IP physique doit être configuré en tant que téléphone électronique . Le Cisco
CallManager Express reconnaîtra le téléphone physique à partir du paramètre Adresse MAC de configuration du
téléphone.
La configuration d'un téléphone IP dans CME est un processus simple et implique la création d'une entrée ephone et
ephone-dn.

Le téléphone portable contient l'adresse MAC du téléphone et la configuration des boutons, tandis que l'ephone-dn le
numéro de répertoire attribué au téléphone IP.

Dans l'exemple ci-dessus, la configuration de l' ephone 1 lie le premier bouton du téléphone (bouton 1) à l' ephone-dn
20 . Depuis que ephone-dn 20 a été configuré avec le numéro de répertoire 300 , le numéro de répertoire 300 est
attribué au téléphone IP.

Pour nous assurer de comprendre ce concept, considérons l'exemple suivant:

En utilisant le même scénario, nous avons créé trois entrées ephone-dn, soit un total de trois numéros de
répertoire. Nous aimerions maintenant attribuer le numéro de répertoire 380 au numéro de téléphone 1 du téléphone
1. Il suffit de mapper le bouton 1 sur ephone-dnapproprié contenant le numéro 380 , à savoir ephone-dn 22 . Pour ce
faire, nous émettons la commande bouton 1:22 sous la configuration de l' ephone 1 . Le téléphone IP 1 a maintenant
le numéro de répertoire 380!

BANDE PASSANTE VOIP - CODECS

Les appels VoIP, comme toute autre ressource réseau, nécessitent de la bande passante. La quantité de bande
passante requise par appel est régie par le type de codec configuré par le système. Les séries Cisco
CME et UC500 prennent en charge une variété de codecs différents, ce qui rend le système extrêmement flexible pour
répondre à toutes les exigences.
Par défaut, le codec utilisé par Call Manager Express et la série UC500 est G.711, qui requiert une bande passante de
64 Kbit / s - la même quantité de bande passante utilisée par les fournisseurs de télécommunications pour un
appel. Notez que 64Kbps est la charge utile de données. Cela signifie que, lorsqu'il est capturé dans un paquet
Ethernet , la bande passante totale correspond à la charge utile de données plus la surcharge du paquet IP, ce qui
porte le montant total à 87,2 Kbps . Il s’agit de la bande passante réelle requise par appel et par téléphone sur un
réseau Ethernet.

La quantité de 87,2 Kbps peut ne pas sembler importante pour un réseau Ethernet, cependant, lorsque nous devons
passer l'appel sur un réseau WAN, cela change complètement. Les réseaux WAN nécessitent des applications et des
services optimisés en bande passanteet il n'y a pas d'exception pour les appels VoIP.

Pour cette raison, lorsque nous traitons de situations nécessitant un contrôle optimisé de la bande passante, nous
passons à différents codecs nécessitant une bande passante beaucoup plus réduite, ce qui nous permet
essentiellement de conserver une bande passante précieuse et de l'argent. Dans ces cas, le codec G.729 est
généralement préféré, ne nécessitant que 31,2 Kbps , une économie généreuse de 56 Kbps ! En pratique, cela signifie
que vous pouvez presser près de trois appels VoIP G.729 en utilisant la même quantité de bande passante requise
par un appel VoIP G.711 !

Outre la différence évidente entre les exigences de bande passante pour chaque codec, il existe également une
différence notable dans la qualité de l'appel, le G.711 étant de loin supérieur au G.729. Pour vous aider à donner un
exemple, la qualité d’un appel G.711 est similaire à celle d’un appel passé entre deux lignes fixes RNIS, alors qu’un bon
exemple de la qualité G.729 serait un appel entre deux téléphones mobiles.

Considérant que la qualité des appels téléphoniques mobiles est acceptable pour tout le monde aujourd'hui, peu de
gens se plaindraient s'ils avaient la même qualité entre les appels site à site.

Bien sûr, il existe d’autres codecs qui nécessitent une bande passante différente, mais les deux plus importants et les
plus populaires sont les codecs G.711 et G.729 . Ces codecs peuvent être davantage configurés pour modifier leurs
besoins en bande passante, mais c'est un sujet à traiter à l'avenir.

RÉSUMÉ DE L'ARTICLE

Cet article portait sur l'introduction de Call Manager Express de Cisco, qui s'exécute sur les routeurs Cisco et les
appliances de la série UC 500 (y compris les UC520, UC540 et UC560). Les concepts de base des technologies VoIP ont
été introduits, ainsi que quelques importantes théories de configuration liées au fonctionnement de CME.

Si vous avez trouvé cet article utile, nous vous saurions gré de le partager avec d'autres personnes en utilisant les
services fournis dans le coin supérieur gauche de cet article. Le partage de nos articles ne prend qu'une minute de
votre temps et permet à Firewall.cx de toucher davantage de personnes par le biais de tels services. Les utilisateurs
intéressés peuvent également lire notre article sur les concepts de base de Cisco CallManager Express - Partie 1 .
COMMENT CONFIGURER UN ROUTEUR SUR UN STICK -
ROUTEUR 802.1Q VERS UN ROUTEUR CISCO
Router-on-a-stick est un terme fréquemment utilisé pour décrire une installation composée d'un routeur et d'un
commutateur connectés à l'aide d'un lien Ethernet configuré en tant que liaison de jonction 802.1q. Dans cette
configuration, le commutateur est configuré avec plusieurs VLAN et le routeur effectue tout le routage entre les différents
réseaux / VLAN.

Alors que certains pensent que le terme "routeur sur bâton" semble un peu ridicule, c'est un terme très populaire et
couramment utilisé dans les réseaux où aucun commutateur de couche 3 n'existe. Un bon exemple de configuration
routeur sur stick (qui est également celle que nous allons couvrir) serait une installation Call Manager Express où il est
nécessaire de scinder le réseau VoIP, constitué de votre adresse IP Cisco. Dispositifs téléphoniques, depuis votre réseau
de données où se trouvent tous les postes de travail et serveurs.

EXEMPLE DE SCÉNARIO
Notre exemple est basé sur un scénario que vous êtes le plus susceptible de rencontrer lorsque vous traitez avec des
réseaux VoIP. Étant donné que les implémentations VoIP exigent que vous sépariez le réseau voix et le réseau de
données afin de router les paquets entre eux, vous avez besoin d'un commutateur de couche 3 ou d'un routeur. Cette
configuration garantit la disponibilité et la stabilité du service VoIP, en particulier pendant les heures de pointe du trafic
sur votre réseau.

Les paquets exécutés entre les VLAN sont acheminés via le routeur CCME connecté au commutateur à l'aide d'un port
physique configuré en tant que port de ligne réseau aux deux extrémités (commutateur et routeur). Si vous souhaitez en
savoir plus sur le routage de VLAN et la théorie de VLAN, vous pouvez visiter notre section populaire VLAN qui couvre
tous les sujets et termes liés trouvés dans cet article.

Cet exemple vous montrera comment configurer un routeur et un commutateur Cisco afin de créer un lien de liaison entre
eux et de faire en sorte que le routeur achemine les paquets entre vos VLAN.

Ce diagramme montre une illustration de la configuration ci-dessus.

ÉTAPE 1 - CONFIGURATION DU COMMUTATEUR


La première étape consiste à créer les deux VLAN requis sur notre commutateur Cisco et à les configurer avec une
adresse IP. Puisque tous les switch Cisco contiennent VLAN1 (VLAN par défaut), il suffit de créer un VLAN2:

SW1# configure terminal


SW1(config)# vlan2
SW1(config-vlan)# name voice
SW1(config-vlan)# exit
SW1(config)# interface vlan1
SW1(config-if)# description Data Vlan
SW1(config-if)# ip address 192.168.0.2 255.255.255.0
SW1(config-if)# exit
SW1(config)# interface vlan2
SW1(config-if)# description Voice Vlan
SW1(config-if)# ip address 192.168.2.2 255.255.255.0
SW1(config-if)# exit
SW1 # configure le terminal
SW1 (config) # vlan2
SW1 (config-vlan) # nom voix
SW1 (config-vlan) # sortie
SW1 (config) # interface vlan1 #
SW1 (config-if) # description Données Vlan
SW1 (config-if) # adresse ip 192.168.0.2 255.255.255.0
SW1 (config-if) # sortie
SW1 (config) # interface vlan2
SW1 (config-if) # description Voix Vlan
SW1 (config-if) # adresse ip 192.168.2.2 255.255.255.0
SW1 (config-if) # exit

Ensuite, nous devons créer le port de coffre qui se connectera au routeur. Pour ce faire, nous avons sélectionné le port
GigabitEthernet 0/1 (port 1):

SW1# configure terminal


SW1(config)# interface gigabitethernet 0/1
SW1(config-if)# description Trunk-to-Router
SW1(config-if)# switchport trunk encapsulation dot1q
SW1(config-if)# switchport mode trunk
SW1(config-if)# spanning-tree portfast trunk
SW1 # configure le terminal
SW1 (config) # interface gigabitethernet 0/1
SW1 (config-if) # description Trunk-to-Router
SW1 (config-if) # encapsulation de tronc switchport dot1q
SW1 (config-if) # tronc en mode switchport
SW1 ( config-if) # spanning-tree tronc de port

Pour éliminer toute confusion, ces commandes donnent les instructions suivantes au commutateur:

1) Définir la jonction pour utiliser le protocole 802.1q

2) Définir le port spécifique en mode trunk

3) Activez la fonction de jonction de spanning-tree pour assurer que le port transmettra les paquets immédiatement
lorsqu'il est connecté à un périphérique, par exemple un routeur. Remarque: La commande spanning-tree portfast
trunk ne doit jamais être utilisée sur les ports qui se connectent à un autre commutateur, afin d'éviter toute boucle sur le
réseau.

Les étapes ci-dessus complètent la configuration côté commutateur.


ÉTAPE 2 - CONFIGURATION DU ROUTEUR
Nous devons suivre une configuration similaire pour notre routeur afin de permettre la communication avec notre
commutateur et de permettre à tout le trafic VLAN de passer et d’acheminer au besoin.

La création d'un lien de jonction sur un port de routeur n'est pas très différente du processus utilisé ci-dessus. Nous
créons le port de jonction sur une interface physique, mais nous devons créer une sous-interface pour chaque VLAN.

Encore une fois, c'est un processus assez simple et facile à comprendre une fois que vous l'avez fait au moins une fois.

R1# configure terminal


R1(config)# interface gigabitethernet0/1
R1(config-if)# no ip address
R1(config-if)# duplex auto
R1(config-if)# speed auto
R1(config-if)# interface gigabitethernet0/1.1
R1(config-subif)# description Data VLAN
R1(config-subif)# encapsulation dot1q 1 native
R1(config-subif)# ip address 192.168.0.1 255.255.255.0
R1(config-subif)# ip nat inside
R1(config-subif)# ip virtual-reassembly
R1(config-subif)# interface gigabitethernet0/1.2
R1(config-subif)# description Voice VLAN
R1(config-subif)# encapsulation dot1q 2
R1(config-subif)# ip address 192.168.2.1 255.255.255.0
R1(config-subif)# ip nat inside
R1(config-subif)# ip virtual-reassembly
R1 # configure le terminal
R1 (config) # interface gigabitethernet0 / 1
R1 (config-if) # pas d'adresse IP
R1 (config-if) # duplex automatique
R1 (config-if) # vitesse automatique
R1 (config-if) # interface gigabitethernet0 /1.1
R1 (config-subif) # description VLAN de données
R1 (config-subif) # encapsulation dot1q 1
R1 natif (config-subif) # adresse ip 192.168.0.1 255.255.255.0
R1 (config-subif) # ip nat intérieur
R1 ( config-subif) # ip réassemblage virtuel
R1 (config-subif) # interface gigabitethernet0 / 1.2
R1 (config-subif) # description VLAN voix
R1 (config-subif) # encapsulation dot1q 2
R1 (config-subif) # adresse ip 192.168.2.1 255.255.255.0
R1 (config-subif) # ip nat à l'intérieur de
R1 (config-subif) # ip-réassemblage virtuel

Afin de former une liaison principale avec notre commutateur, il est nécessaire de créer une sous-interface pour chaque
VLAN configuré sur notre commutateur. Après avoir créé la sous-interface, nous lui attribuons une adresse IP et
définissons le type d'encapsulation sur 802.1q, ainsi que le VLAN auquel appartient la sous-interface.

Par exemple, la commande encapsulation dot1q 2 définit l'encapsulation 802.1q et définit la sous-interface sur VLAN 2.
Le paramètre natif utilisé pour la sous- interface gigabitethernet0 / 1.1 indique au routeur que le vlan natif est VLAN 1.
Il s'agit d'un paramètre par défaut pour chaque commutateur Cisco. et doit donc également correspondre au routeur.

La commande ip virtual -askembly est généralement lancée automatiquement par Cisco IOS (nous l'avons incluse pour
vous montrer la commande) et constitue une mesure de sécurité permettant d'éviter le débordement de la mémoire
tampon et de contrôler l'utilisation de la mémoire lors d'une attaque de paquets fragmentés pouvant se renverser. les
ressources de votre routeur. Cette commande est ajoutée automatiquement lorsque vous activez le service NAT à l'aide
de la commande ip nat inside . Plus d'informations sur la configuration NAT peuvent être obtenues dans nos articles sur
la configuration NAT du routeur Cisco.
RÉSUMÉ DE L'ARTICLE
Cet article expliquait l'utilisation de configurations de routeur sur bâton et montrait comment vous pouvez configurer un
lien de jonction 802.1q entre un commutateur et un routeur Cisco. Les configurations de routeur sur commutateur sont
extrêmement utiles dans les environnements dépourvus de commutateur de couche 3, fournissant des services de
routage inter-VLAN avec un routeur et une interface, ce qui permet de réduire considérablement les coûts de routage
interne.

Il est toujours préférable d'utiliser un routeur avec une interface Gigabit Ethernet pour vous assurer que vous disposez
de suffisamment de bande passante pour gérer de grandes quantités de transferts de données si nécessaire.

Si vous avez trouvé cet article utile, nous vous serions reconnaissants de le partager avec d'autres personnes en utilisant
les services fournis dans le coin supérieur gauche de cet article. Le partage de nos articles ne prend qu'une minute de
votre temps et permet à Firewall.cx de toucher davantage de personnes par le biais de tels services.