Vous êtes sur la page 1sur 5

routage statik

ag2(config)#ip route 172.16.16.0 255.255.248.0 172.16.30.73

Router#erase startup-config supp la conf du router

no ip domain-lookup

show ip interface brief

show ip route

reload
R1#show ip protocols (+affiche silya résumé ou pa)

ripv1

r1(config)#router rip

r1(config-router)#network 192.168.1.0

r1(config-router)#network 192.168.2.0

r1(config-router)#passive-interface fa0/0

r1#show ip route

r1#debug ip rip pour afficher les messages RIP envoyé et reçus

r1(config)#no router rip

r2(config)#ip route 0.0.0.0 0.0.0.0 s0/0/1(du r3) route par defaut

r3(config)#ip route 172.30.0.0 255.255.0.0 s0/0/0(du r2) route statik

r1#clear ip route * supprime la table routage est la relance (comme reset)

• La principale limite du protocole RIPv1 est qu’il s’agit d’un protocole de


routage par classe.

• RIPv1 n’incluent pas le masque de sous-réseau avec l’adresse réseau


dans les mises à jour de routage.
• Problèmes d’utilisation du RIPV1 avec les sous-réseaux discontinus ou les
réseaux qui utilisent le masquage de sous-réseau de longueur variable
VLSM.

• rip v1 ne peut etre utilisé si deux parties continues sont discontinues

• Périodiquement chaque 30 secondes

• Valeur 16 correspond à l'infini

rip v2

 emporte le mask
 maj chak 30secondes
 si sans maj apres180 sec metrike=16
 si sans maj apres240 sec reso exclu du rip
 metrik=nb saut = nb routeur
 dist admin utile kan ilya +eurs protocoles.
 La distance Administrative est une valeur qui représente le protocole. rip(tjr=120)
ospf=110
 si les 2 réso ne sont napart pa au meme reso paren il pren le mask de la
classe du réso a emmener.
 si meme reso parent il prend le mask du réso aukel la maj
circule(intermediaire)
 partie continue: meme reso parent et meme mask
 peu etre utilisé si 2 réso continu sont discontinus (on supp le résumé
automatic)
 peu etre utilisé ds le vlsm

R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#network 172.30.0.0 (tout les réso connectés)

R3(config-router)#passive-interface fa0/0

R3(config-router)#passive-interface loopback 0
R3(config-router)#passive-interface loopback 1

R3(config-router)#exit

R3(config-router)#no au

R3(config)#exit

R3(config)#ip route 0.0.0.0 0.0.0. 0 ....


siege(config-router)#ver
siege(config-router)#version 2
siege(config-router)#de
siege(config-router)#default-information o
siege(config-router)#default-information originate

R3#debug ip rip

ospf

 cout (metric): 64 ligne rouge -- 1 ligne noires

r1(config)#router ospf 1(ou2ou3)

r1(config-router)#network 172.16.1.16 0.0.0.15 area 0 (prendre le mask inverse


telkilé)

r1(config-router)#network 192.168.10.0 0.0.0.3 area 0

r1(config-router)#network 192.168.10.4 0.0.0.3 area 0

r1(config-router)#passive-interface fa0/0

r1#show ip protocls (affiche le protocol et lid du router)

r1#show ip ospf (affiche le protocol et lid du router)

r1#show ip ospf interface(affiche le protocol et lid du router)


r1#show ip ospf neighbor (affiche lid du voisin ospf)

r1#show ip route

r1#show ip ospf interface (affiche les couts des interfaces)

r1(config)#interface se0/0/0

r1(config-if)#bandwidth 64 (bande passante)

OU

r1(config)#interface se0/0/0

r1(config-if)#ip ospf cost 64

r1(config-if)#interface se0/0/1

r1(config-if)#ip ospf cost 64

r1#show ip ospf interface (affiche les couts des interfaces)

route satitike vers fai:

Siege(config)#ip route 0.0.0.0 0.0.0.0 209.165.202.130 (du routeur suivant fai)


R2(config-router)#redistribute static OU
Siege(config-router)#default-information originate : pour emmener cette info
ds la miajour ospf vers les otre rout

FAI(config)#ip route 192.168.40.0 255.255.255.0 209.165.202.129 (du routeur


suivant)

REDISTRIBUTION:

router ospf 1

tunisloc2(config-router)#redistribute rip metric 50 metric-type 1 subnets

metric50(cou ospf) metric-type 2(garde la metric) metric-type1(1 ajoute les


metric des reso rencontré)
tunisloc2(config)#router rip

tunisloc2(config-router)#redistribute ospf 1 metric 5

iegetlocal2(config)#router rip
siegetlocal2(config-router)#ve
siegetlocal2(config-router)#version 2
siegetlocal2(config-router)#ref
siegetlocal2(config-router)#red
siegetlocal2(config-router)#redistribute os
siegetlocal2(config-router)#redistribute ospf 1 metric 5
siegetlocal2(config-router)#redistribute ospf 1

siegetlocal2(config)#router os
siegetlocal2(config)#router ospf 1
siegetlocal2(config-router)#red
siegetlocal2(config-router)#redistribute r
siegetlocal2(config-router)#redistribute rip