Vous êtes sur la page 1sur 8

Conception des réseaux locaux commutés

Description d'un commutateur :

Un commutateur est un équipement réseau de couche 2. Il en existe une grande variété avec des
caractéristiques différentes:

• Nombre de ports / Type de port (10/100 Mbits, gigabit)


• Type de commutation (Strore and Forward, Cut Through)
• Facilité d'installation en armoire

Les différents types de commutation :

• Store and forward: Le commutateur attend d’avoir reçu toute la trame avant de la transmettre.
Cette méthode offre une grande vérification d’erreur car le commutateur a le temps de vérifier la
valeur FCS.

• Cut Through: Dès que l’adresse de destination est connue, la trame commence à être commutée.
Ce mode est plus rapide que le précédent. Il existe différentes variantes de ce type de commutation:

Fragment Free: Filtrage des fragments de collision (inférieur à 64 octets). Le commutateur


attend d'avoir reçu les 64 premiers octets avant de commencer à transmettre la trame.

Fast Forward: Pas de vérification d’erreurs. La trame est transmise dès que l'adresse de
destination est identifiée.

Les VLAN :

VLAN (Virtual LAN) est un ensemble d’unités regroupées en domaine de broadcast quel que soit
l’emplacement de leur segment physique.
Les principales différences entre la commutation traditionnelle et les LAN virtuels sont:

• Les LAN virtuels fonctionnent au niveau des couches 2 et 3 du modèle OSI.


• La communication inter LAN virtuels est assurée par le routage de couche 3.
• Les LAN virtuels fournissent une méthode de contrôle des broadcasts.
• Les LAN virtuels permettent d’effectuer une segmentation selon certains critères:
o Des collègues travaillant dans le même service.
o Une équipe partageant le même applicatif.

1
ingénieur chansa ngonga
VTP

Virtual Trunking Protocol, protocole propriétaire Cisco permet, aux commutateurs et routeurs qui
l’implémentent, d'échanger des informations de configuration des VLAN. Il permet donc de
redistribuer une configuration à d'autres commutateurs évitant par la même occasion à
l'administrateur de faire des erreurs, en se trompant par exemple de nom de VLAN. VTP diffuse ses
mises à jour au sein du domaine VTP toutes les 5 min ou lorsqu'une modification a lieu.

Modes VTP

Vous pouvez configurer un commutateur pour opérer dans n'importe lequel de ces modes VTP :

 Serveur : En mode de serveur VTP, vous pouvez créer, modifier, et supprimer des VLAN et
spécifier d'autres paramètres de configuration, tels que la version VTP et l'élagage VTP, pour
le domaine entier VTP. Les serveurs VTP annoncent leur configuration VLAN à d'autres
commutateurs dans le même domaine VTP et synchronisent leur configuration VLAN avec
d'autres commutateurs selon les annonces reçues via d'autres liaisons de jonction. Le
Serveur VTP est le mode par défaut.
 Client : Les clients VTP se comportent la même manière que les serveurs VTP, mais vous ne
pouvez pas créer, changer, ou supprimer des VLAN sur un client VTP.
 Transparent : Les commutateurs VTP transparents ne participent pas à VTP. Un
commutateur VTP transparent n'annonce pas sa configuration VLAN et ne synchronise pas sa
configuration VLAN selon les annonces reçues, mais les commutateurs transparents
transmettent des annonces VTP qu'ils reçoivent par leurs ports de jonction dans VTP Version

Les mises à jour VTP comportent:

• Un numéro de révision (Revision Number) qui est incrémenté à chaque nouvelle diffusion. Cela
permet aux commutateurs de savoir s'ils sont à jour.
• Les noms et numéro de VLAN.

Définir un switch comme un serveur VTP :

Switch(config)# vtp domain ISGIM


Switch(config)# vtp mode server
Switch(config)# vtp password khair123

Définir un switch comme un client VTP :

Switch(config)# vtp domain ISGIM


Switch(config)# vtp mode client
Switch(config)# vtp password khair123

Remarque : Il est nécessaire de créer l'agrégation sur le serveur


VTP

ingénieur chansa ngonga


STP

Spanning-Tree Protocol : empêche certains ports de transmettre en mettant les ports dans un état
de blocage ou dans un état de transmission, afin qu'il n'y ait qu'un seul chemin possible entre deux
segments de LAN.

Le commutateur qui détient l'identifiant de pont le plus bas (Bridge ID) est élu racine. Le Bridge ID de
8 octets est composé d'une priorité sur 2 octets, suivi par l'adresse MAC du port émetteur. Tous les
ports du commutateur racine sont placés en état de transmission par le protocole STP .

Fonctionnement de STP

Une topologie physique physique redondante fournira des chemins multiples visant à améliorer la
fiabilité d'un réseau. Toutefois, elle présente le désavantage de créer des boucles dans le réseau.
Pour résoudre ce problème, STP crée au sein de cette topologie redondante un chemin sans boucle
basé sur le chemin le plus court. Ce chemin est établi en fonction de la somme des coûts de liens
entre les commutateurs. Ce coût est une valeur inverse à la vitesse d'un port, car un lien rapide aura
un coût moins élevé qu'un lien lent. Aussi, un chemin sans boucle suppose que certains ports soient
bloqués et pas d'autres. STP échange régulièrement des informations (appelées des BPDU - Bridge
Protocol Data Unit) afin qu'une éventuelle modification de topologie puisse être adaptée sans
boucle.

STP est activé par défaut sur les commutateurs Cisco, il crée un chemin sans boucles
automatiquement entre eux.

Sélection d'un commutateur Root

Le commutateur Root (principal) sera le point central de l'arbre STP. le choix de celui-ci dans
l'architecture du réseau peut avoir son importance. Toutefois, une bonne pratique consistera à
limiter la taille des domaines de diffusion et à concentrer géographiquement les VLANs.

Par défaut, le commutateur qui aura l'identifiant ID la plus faible sera élu Root. L'ID su commutateur
comporte deux parties :

 d'une part, la priorité (2 octets) et,


 d'autre part, l'adresse MAC (6 octets).

La priorité 802.1d est d'une valeur de 32768 (0x8000) par défaut (ce sont des multiples de 4096, sur
16 bits). Par exemple, un commutateur avec une priorité par défaut de 32768 et une adresse MAC
00:A0:C5:12:34:56 prendra l'ID 8000:00A0:C512:3456. On peut changer la priorité d'un commutateur
avec la commande :

Switch(config)# spanning-tree vlan 1 root primary


ou
Switch(config)# spanning-tree vlan vlan-id priority priority

3
Ingénieur chansa ngonga Georges
Sélection d'un port Root pour les commutateurs non-Root.

Les autres commutateurs vont sélectionner un seul port Root qui aura le chemin le plus court vers le
commutateur Root. Normalement, un port Root est en état « forwarding », également.

Le coût est calculé inversement à sa qualité.

Vitesse du lien Coût Plage de coût recommandée


4 Mbps 250 100 to 1000
10 Mbps 100 50 to 600
16 Mbps 62 40 to 400
10 0Mbps 19 10 to 60
1Gbps 4 3 to 10
10Gbps 2 1 to 5

Ce coût peut être modifié. S'il s'agit d'un port configuré en mode Access (qui connecte un
périphérique terminal), la commande de configuration est :

(config)#interface fa0/2
(config-if)#spanning-tree cost ” cost”

S'il s'agit d'un port en mode Trunk (qui connecte un autre commutateur pour transporter du trafic de
plusieurs VLANs), la commande de configuration est :

(config)#interface fa0/2
(config-if)#spanning-tree vlan 1 cost “cost”

A noter aussi qu'en cas de coût égaux, c'est la priorité la plus faible (d'une valeur de 0 à 255) qui
emporte le choix (elle est de 128 par défaut) en déterminant l'ID du port composé de 2 octets
(priorité + numéro STP du port) :

Sur un port en mode Access :

(config)#interface fa0/10
(config-if)#spanning-tree port-priority priority ‘0-240’

Sur un port en mode trunk :

(config)#interface fa0/1
(config-if)#spanning-tree vlan vlan-id port-priority “priority “

Fixer un Switch comme un pont secondaire :


Switch(config)# spanning-tree vlan 1 root secondary

Changer la priorité d’un Switch :


Switch(config)# spanning-tree vlan 1 priority ‘0-61440’

4
Ingénieur chansa ngonga Georges
Sélection d'un port désigné pour chaque segment

Pour chaque segment physique, domaine de collision ou lien, il y a un port Designated. Le port
Designated est celui qui a le chemin le plus court vers le commutateur Root. Un port Designated est
normalement en état « forwarding », autrement dit, envoie et reçoit du trafic de données.

Tous les autres sont des ports Non-Designated en état « blocking », c'est-à-dire bloquant tout trafic
de données mais restant à l'écoute des BPDU.

En bref

1 commutateur Root par réseau dont tous les ports sont Designated
1 port Root par commutateur Non-Root
1 port Designated par domaine de collision (liaison)
tous les autres ports sont Non-Designated
--------------------------------------------------------------------------------------------------------------------------------------

Réseau sans fil

Un réseau sans fil (Wireless network) est, comme son nom l'indique, un réseau dans lequel au moins
deux terminaux : ordinateur portable, PDA … peuvent Communiquer sans liaison filaire.

Il existe deux modèles de déploiement :

• Le mode infrastructure : permet de connecter les ordinateurs équipés d'une carte réseau Wifi entre
eux via un ou plusieurs points d'accès qui agissent comme des concentrateurs.

• Le mode « Ad-Hoc » : permet de connecter directement les ordinateurs équipés d'une carte réseau
Wifi, sans utiliser un matériel tiers tel qu'un point d'accès.

Les normes de Wifi :

• 802.11a : norme pour les réseaux locaux utilisant comme fréquence le 5 GHz pour des transferts
jusqu´à 54 Mbps.

• 802.11b : autre norme pour les réseaux locaux, utilisant le 2,4 GHz avec une bande passante
maximale de 11 Mbps.

• 802.11g : norme la plus aboutie pour les réseaux étendus, exploite le 2,4 GHz avec des débits
maximums de 54 Mbps.

5
Ingénieur chansa ngonga Georges
Les avantages de réseau sans fils (WIFI) :

• les coûts sont nettement plus réduits.


• l'installation d'un réseau câblé est un vrai casse-tête autant pour les bâtiments anciens.
• les clients vont apprécier la mobilité : la portée en plein air d'un réseau wifi est de 100 mètres.

Les équipements WIFI :

•Linksys-WRT54G : est un routeur Wifi produit par Linksys. Il permet de partager une con-nexion
Internet vers des ordinate.

• Hot spot est un dispositif électronique servant à amplifier un signal numérique ainsi d’étendre la
distance maximale entre l’émetteur et le récepteur.

• CPL (courant porteur en ligne) permet de se connecter à internet en utilisant le réseau électrique
existant.

Sécurité d'un WIFI :

• WEP : consiste à définir une clé sécrète qui doit être déclarée au niveau de chaque adaptateur sans
fil du réseau ainsi que sur le point d'accès. Cependant, le WEP possède un grand nombre de failles, le
rendant vulnérable. En effet, le cryptage RC4 présente des faiblesses. La clé de session partagée par
toutes les stations est- nous le savons - statique.

• WPA :protocole de sécurisation des réseaux sans fil offrant une meilleure sécurité que le WEP car il
est destiné à en combler les faiblesses. Ainsi, le WPA permet d'utiliser une clé par station connectée
à un réseau sans fil, alors que le WEP, lui, utilisait la même clé pour tout le réseau sans fil. Les clés
WPA sont en effet générées et distribuées de façon automatique par le point d'accès sans fil - qui
doit être compatible avec le WPA.

• Le WAP2, tout comme son prédécesseur - le WPA - assure le cryptage ainsi que l'intégrité des
données mais offre de nouvelles fonctionnalités de sécurité telles que le « Key Caching » et la « Pré-
Authentification ».

6
Ingénieur chansa ngonga Georges
Les commandes :
configuration de base des commutateurs

sco pour les connexions console.

Switch(config)#hostname Comm1
Comm1(config)#enable secret class
Comm1(config)#no ip domain-lookup
Comm1(config)#line console 0
Comm1(config-line)#password cisco
Comm1(config-line)#login
Comm1(config-line)#logging synchronous
Comm1(config-line)#exec-timeout 15
Comm1(config-line)#line vty 0 15
Comm1(config-line)#password cisco
Comm1(config-line)#login
Comm1(config-line)#logging synchronous 15

Deactivation de tous les ports à l’aide de la commande shutdown

Comm1(config)#interface range fa0/1-24


Comm1(config-if-range)#shutdown
Comm1(config-if-range)#interface range gi0/1-2
Comm1(config-if-range)#shutdown

réactivation des ports utilisateur en mode access

Comm1(config)#interface fa0/3
Comm1(config-if)#switchport mode access
Comm1(config-if)#no shutdown

activation des ports agrégés sur Comm1

Comm1(config-if-range)#interface range fa0/1, fa0/2


Comm1(config-if-range)#switchport mode trunk
Comm1(config-if-range)#no shutdown

Création du vlan 1

Comm1(config)#vlan 1
Comm1(config-vlan)#name administration

7
Ingénieur chansa ngonga Georges
Configuration de l’adresse de l’interface de gestion sur les trois commutateurs

Comm1(config)#interface vlan1
Comm1(config-if)#ip address 172.17.10.1 255.255.255.0
Comm1(config-if)#no shutdown

Filtrage des vlans sur un port uplink

Comm1(config)#interface fa 0/1
Comm1(config-if)#switchport trunk allowed vlan add 2,3
Comm1(config-if)#switchport trunk allowed vlan remove 3

Configuration de la sécurité d’un port d’accès

Comm1(config)#interface fastethernet 0/18


Comm1(config-if)#switchport port-security
Comm1(config-if)#switchport mode access
Comm1(config-if)#switchport port-security maximum 2
Comm1(config-if)#switchport port-security mac-address sticky / ou
Comm1(config-if)#switchport port-security mac-address 0003.E4B3.817B "exemple"
Comm1(config-if)#switchport port-security violation shutdown

spanning-tree

Comm1(config)#spanning-tree vlan 1 priority 4096


Comm1(config)#spanning-tree vlan 10 priority 4096

Configuration du protocole VTP

Comm1(config)#vtp domain isgim


Comm1(config)#vtp mode server
Comm1(config)#vtp password 12345

Comm1(config)#vtp domain isgim


Comm1(config)#vtp mode client
Comm1(config)#vtp password 12345

Commande nonegociate

Comm1(config)#interface range fas 0/1 – 10


Comm1(config-if-range)#switchport nonegotiate

Les commands de verification


Comm1#show interface vlan1
Comm1#show ip interface vlan1
Comm1#show spanning-tree
Comm1#show port-security
Comm1#show mac-address-table
Comm1#show port-security
8
Ingénieur chansa ngonga Georges

Vous aimerez peut-être aussi