Vous êtes sur la page 1sur 2

DHCPv6

L’utilisation de DHCPv6 n’est pas requise pour la connectivité client IPv6 si SLAAC est déjà déployée. Il y a deux
modes de fonctionnement pour DHCPv6 appelé Stateless (sans état) et Stateful (avec état). Le mode sans état DHCPv6
est utilisé pour fournir aux clients des informations réseau supplémentaire qui ne sont pas disponibles dans l’annonce de
routeur, mais pas une adresse IPv6, comme cela est déjà prévu par SLAAC. Ces informations peuvent inclure le nom de
domaine DNS, serveurs DNS et les autres options DHCP spécifiques au fournisseur. Cette configuration de l’interface
est un routeur Cisco IOS IPv6 d’application sans état DHCPv6 avec SLAAC activé :
ipv6 unicast-routing
ipv6 dhcp pool IPV6_DHCPPOOL
address prefix 2001:db8:5:10::/64
domain-name cisco.com
dns-server 2001:db8:6:6::1
interface Vlan20
description IPv6-DHCP-Stateless
ip address 192.168.20.1 255.255.255.0
ipv6 nd other-config-flag
ipv6 dhcp server IPV6_DHCPPOOL
ipv6 address 2001:DB8:0:20::1/64
end

L’option DHCPv6 Stateful, également connu sous le nom de mode managé, fonctionne de manière similaire à DHCPv4
qu’il attribue des adresses uniques à chaque client au lieu du client générant les 64 derniers bits de l’adresse comme
SLAAC. Cette configuration de l’interface est un routeur Cisco IOS IPv6 d’application avec état DHCPv6 sur un
commutateur local :
ipv6 unicast-routing
ipv6 dhcp pool IPV6_DHCPPOOL
address prefix 2001:db8:5:10::/64
domain-name cisco.com
dns-server 2001:db8:6:6::1
interface Vlan20
description IPv6-DHCP-Stateful
ip address 192.168.20.1 255.255.255.0
ipv6 address 2001:DB8:0:20::1/64
ipv6 nd prefix 2001:DB8:0:20::/64 no-advertise
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 dhcp server IPV6_DHCPPOOL
end
Cette configuration de l’interface est un routeur Cisco IOS IPv6 d’application avec état DHCPv6 sur un serveur DHCP
externe :
ipv6 unicast-routing
domain-name cisco.com
dns-server 2001:db8:6:6::1
interface Vlan20
description IPv6-DHCP-Stateful
ip address 192.168.20.1 255.255.255.0
ipv6 address 2001:DB8:0:20::1/64
ipv6 nd prefix 2001:DB8:0:20::/64 no-advertise
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
ipv6 dhcp_relay destination 2001:DB8:0:20::2
end
Autoconfig Managed Config Flag

Server is configured:
!
ipv6 dhcp pool dhcpv6pool
prefix-delegation pool localipv6pool lifetime 1800 600
dns-server 2001::1
domain-name cisco.com
!
ipv6 local pool localipv6pool 2001::/64 64
!
interface FastEthernet0/0
ipv6 address 2001::1/64
ipv6 nd managed-config-flag
ipv6 enable
ipv6 dhcp server dhcpv6pool
!

Configurer autoconfig et DHCP sur le client et passer par le mode simulation pour observer :
Stateful address: 2001:1::2D0:BCFF:FEAC:AA43/64
Stateless address: 2001::2D0:BCFF:FEAC:AA43/64

ipv6 dhcp pool dhcpPool


dns-server 2001::10
domain-name cisco.com

interface FastEthernet0/0
ipv6 address 2001::1/64
ipv6 mtu 1500
ipv6 nd other-config-flag
ipv6 enable
ipv6 dhcp server dhcpPool

Configurer autoconfig et DHCP sur le client et passer par le mode simulation pour observer.

Vous aimerez peut-être aussi