Vous êtes sur la page 1sur 7

Travaux Pratiques

TP sur le routage inter-


VLAN.doc

1ère année
Routage inter-VLAN Page:1/7

Extrait du référentiel : BTS Systèmes Numériques option A (Informatique et Réseaux) Niveau(x)


S7. Réseaux, télécommunications et modes de
transmission

S7.2. Concepts fondamentaux des Équipements réseau : connecteur, carte


réseaux réseau, commutateur, pont, 3
routeur, etc.
Modèle en couches et protocoles de 3
l’Internet : IP, ICMP, ARP, UDP,TCP, etc.

Objectifs du TP :
- Configuration initiale du routage inter-VLAN :
- fonctionnement du routage inter-VLAN
- le routage inter-VLAN existant
- la méthode router-on-a-stick
- Exercice :
- routage inter-VLAN

Support d’activité :
- Logiciels : Cisco Packet Tracer, suite bureautique
- Internet
- Ce document au format PDF

Vous rédigerez un compte-rendu numérique


Résumez les questions avant de répondre
Pensez aux captures d’écran pour imager votre compte-rendu
Sauvegardez votre travail régulièrement !
Des modifications peuvent exister selon la version du logiciel utilisée
Travaux Pratiques
TP sur le routage inter-
VLAN.doc

1ère année
Routage inter-VLAN Page:2/7

CONFIGURATION INITIALE DU ROUTAGE INTER-VLAN

FONCTIONNEMENT DU ROUTAGE INTER-VLAN

La segmentation des réseaux par des VLAN :

- améliore les perfformances (en réduisant le nombre de collisions) ;


- améliore la sécurité (séparation du trafic) ;
- facilite la gestion (classification du trafic) ;
- réduits les coûts dans un réseau convergé (utilisation d’un même média pour les données, la
voix, la vidéo).

Les ports d’accès sont placés dans un VLAN tandis que les agrégations trunks permettent de faire
circuler plusieurs VLAN au sein d’un même câble entre les commutateurs.

Cependant, étant donné que ces VLAN ont segmenté le réseau, il faut un périphérique de couche
3 (OSI) pour permettre la communication entre les différents VLAN.

LE ROUTAGE INTER-VLAN EXISTANT

La méthode la plus basique appelée routage inter-VLAN sur plusieurs interfaces, consiste à
utiliser une interface physique du routeur pour chaque VLAN. Tous les ports du commutateur sont
alors placés en mode accès dans le VLAN approprié.

Chaque interface du routeur participant au routage inter-VLAN existant doit avoir une adresse IP
définie dans un des sous-réseau utilisés.

Cette approche est identique à celle adoptée pour router les informations entre deux réseaux
physiques distincts.

Question 1

À l’aide du logiciel « Cisco Packet Tracer », en vous aidant des informations ci-dessous et page
suivante, réalisez puis configurez la topologie réseau.

Routage inter-VLAN sur plusieurs interfaces


Travaux Pratiques
TP sur le routage inter-
VLAN.doc

1ère année
Routage inter-VLAN Page:3/7

Masque de Passerelle par


Périphérique Interface Adresse IP VLAN / Trunk
sous-réseau défaut
RT-01 G0/0 192.168.10.1 255.255.255.0

G0/1 192.168.20.1 255.255.255.0

SW-01 VLAN 10* 192.168.10.2 255.255.255.0 VLAN 10 192.168.10.1

SW-01 F0/1 VLAN 10

SW-01 F0/2 VLAN 20

SW-01 G0/1 VLAN 10

SW-01 G0/2 VLAN 20

SW-01 F0/24 Trunk

SW-02 VLAN 10* 192.168.10.3 255.255.255.0 VLAN 10 192.168.10.1

SW-02 F0/1 VLAN 10

SW-02 F0/2 VLAN 20

SW-02 F0/24 Trunk

PC-11 F/0 192.168.10.51 255.255.255.0 192.168.10.1

PC-12 F/0 192.168.10.52 255.255.255.0 192.168.10.1

PC-21 F/0 192.168.20.51 255.255.255.0 192.168.20.1

PC-22 F/0 192.168.20.52 255.255.255.0 192.168.20.1

* VLAN natif

Pensez à sécuriser vos commutateurs. Vous désactiverez administrativement les interfaces


non utilisées (voir TP « sécurisation des ports d’un commutateur »).

Pour configurer le Trunk sur le commutateur SW-01 :


SW-01(config)#interface F0/24
SW-01(config-if)#description "TRUNK vers SW-02:F0/24"
SW-01(config-if)#switchport mode trunk
SW-01(config-if)#switchport trunk allowed vlan 1,10,20
SW-01(config-if)#switchport trunk native vlan 10

Question 2

Une fois la configuration terminée (sauf pour le routeur), les périphériques d’un même VLAN
doivent pouvoir se joindre. Si ce n’est pas le cas, il vous faudra revoir votre configuration.

APPELEZ LE PROFESSEUR POUR VALIDER AVANT DE POURSUIVRE

Question 3

Donnez les trames étiquetées entre les deux commutateurs et relevez le champ VID.
Travaux Pratiques
TP sur le routage inter-
VLAN.doc

1ère année
Routage inter-VLAN Page:4/7

Question 4

Configurez les interfaces du routeur et donnez la table de routage.

Le réseau 192.168.10.0/24 doit être directement connecté à l’interface G0/0 et le réseau


192.168.20.0/24 à l’interface G0/1.

Question 5

Le routeur configuré, montrez qu’il est possible maintenant de communiquer entre VLAN.

Cette approche très simple à une limitation évidente : le nombre d’interfaces disponibles
sur le routeur. En effet, que faire si 3 VLAN, 10 VLAN ou 50 VLAN sont nécessaires ?

Même s’il est possible d’ajouter des cartes Ethernet additionnelles sur certains routeurs, il reste la
limitation du nombre d’emplacements. Sans compter le prix et le nombre de ports nécessaires sur
le commutateur !

Il ne faut pas confondre cette technique avec l’utilisation de plusieurs liens physiques
rassemblés logiquement pour réaliser un seul lien logique, appelé EtherChannel chez
Cisco et Trunk chez d’autres fabricants.

LE ROUTAGE INTER-VLAN ROUTER-ON-A-STICK

Pourquoi ne pas utiliser la même technique entre un routeur et un commutateur qu’entre deux
commutateurs ? Autrement dit, pourquoi ne pas utiliser un trunk entre le routeur et le
commutateur ?

En fait, sur les routeurs modernes, la fonctionnalité a été ajoutée et il est désormais possible de
créer une agrégation sur une interface de routeur, l’interface physique étant subdivisée en sous-
interfaces logiques. Il n’y a maintenant plus de limitation physique au nombre de VLAN mais
simplement une limitation logicielle (souvent d’origine commerciale).

La méthode de routage inter-VLAN router-on-a-stick ne nécessite qu’une seule interface physique


sur un routeur et une interface sur un commutateur.

Question 6

En vous aidant des informations page suivante, réalisez puis configurez (sauf le routeur) la
topologie réseau.
Travaux Pratiques
TP sur le routage inter-
VLAN.doc

1ère année
Routage inter-VLAN Page:5/7

Routage inter-VLAN router-on-a-stick

Masque de Passerelle par


Périphérique Interface Adresse IP VLAN / Trunk
sous-réseau défaut
RT-01 G0/0.10 192.168.10.1 255.255.255.0 VLAN 10

G0/0.20 192.168.20.1 255.255.255.0 VLAN 20

SW-01 VLAN 10* 192.168.10.2 255.255.255.0 VLAN 10 192.168.10.1

SW-01 F0/1 VLAN 10

SW-01 F0/2 VLAN 20

SW-01 G0/1 Trunk

SW-01 F0/24 Trunk

Pour le routeur :

Dans un premier temps, vous activez l’interface physique sans lui adjoindre d’adresse IP.

RT-01(config)#interface G0/0
RT-01 (config-if)#description "Trunk vers SW-01:G0/1"
RT-01(config-if)#no ip address
RT-01 (config-if)#no shutdown

Vous allez maintenant créer une sous-interface par VLAN.

RT-01(config-subif)#description "Sous-interface VLAN 10"


RT-01(config-subif)#encapsulation dot1q 10 native
RT-01(config-subif)#ip address 192.168.10.1 255.255.255.0
RT-01(config-subif)#exit
RT-01(config)#interface G0/0.20
RT-01(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.20, changed state to up

RT-01(config-subif)#description "Sous-interface VLAN 20"


Travaux Pratiques
TP sur le routage inter-
VLAN.doc

1ère année
Routage inter-VLAN Page:6/7

RT-01(config-subif)#encapsulation dot1q 20
RT-01(config-subif)#ip address 192.168.20.1 255.255.255.0
RT-01(config-subif)#exit

Le choix du numéro des sous-interfaces (.10 et .20) respectivement pour les VLAN 10 et
20 est laissé à la discrétion de l’administrateur mais une bonne pratique consiste à utiliser
le même numéro que le numéro de VLAN.

Il est obligatoire de spécifier le type d’encapsulation, ici 802.1Q (dot1q).

Question 7

Regardez la configuration des interfaces.

RT-01#sh ip inter br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet0/0.10 192.168.10.1 YES manual up up
GigabitEthernet0/0.20 192.168.20.1 YES manual up up
GigabitEthernet0/1 unassigned YES unset admin. down down
Vlan1 unassigned YES unset admin. down down

Les deux sous-interfaces logiques G0/0.10 et G0.0.20 sont opérationnelles.

Question 8

Donnez la table de routage.

Vous devez apercevoir une route pour chacun des sous-réseaux (C) en plus des adresses
de liens local (L).

Question 9

Vérifiez la connectivité du réseau à l’aide de la commande tracert 192.168.20.52 lancée depuis


PC-11.

Le PC-11 du VLAN 10 doit passer par sa passerelle pour pouvoir joindre PC-22 dans le VLAN 20.

L’équivalent de la commande tracert sous Linux est traceroute.


Pour rappel , la commande traceroute n’est rien d’autre qu’une série de ping dont le TTL
est incrémenté de 1.
Travaux Pratiques
TP sur le routage inter-
VLAN.doc

1ère année
Routage inter-VLAN Page:7/7

EXERCICE

ROUTAGE INTER-VLAN

Question 10

Tout en respectant les informations ci-dessous, proposez un plan d’adressage puis réalisez et
configurez la topologie réseau.
Réseau : 172.16.8.0/24

APPELEZ LE PROFESSEUR POUR VALIDER