Vous êtes sur la page 1sur 7

MIN

=MIN(valeur1;valeur2;valeur3;….) =MIN(11;5;17;23;2;41)
=MIN(cellule1;cellule2;cellule3;…) =MIN(A1;B13;R5;C3)
1 =MIN(plage) =MIN(C15:F15)
Calcule le minimum, la plus petite valeur d'une plage, qu'ils soient des valeurs indiquées
directement dans la fonction, des cellules, une plage comme une ligne, une colonne ou encore
un tableau de données.
MAX
=MAX(valeur1;valeur2;valeur3;….) =MAX(11;5;17;23;2;41)
=MAX(cellule1;cellule2;cellule3;…) =MAX(A1;B13;R5;C3)
2 =MAX(plage) =MAX(C15:F15)
Calcule le maximum, la plus grande valeur d'une plage, qu'ils soient des valeurs indiquées
directement dans la fonction, des cellules, une ligne, une colonne ou encore un tableau de
données.
MOYENNE
=MOYENNE(valeur1;valeur2;valeur3;….) =MOYENNE(11;5;17;23;2;41)
=MOYENNE(cellule1;cellule2;cellule3;…) =MOYENNE(A1;B13;R5;C3)
3 =MOYENNE(plage) =MOYENNE(C15:F15)
Calcule la moyenne des valeurs d'un plage, qu'ils soient des valeurs indiquées directement dans
la fonction, des cellules, une ligne, une colonne ou encore un tableau de données.

Exmpl B C D E F G
24 Appels Lundi Mardi Mercredi Jeudi Vendredi
25 Amina 169 72 156 76 238
26 Brahim 266 247 70 69 259
27 Chaimae 221 111 162 115 139
28 Dounia 136 132 82 228 218
29 Elias 296 76 78 240 290
30 Farid 218 119 120 219 180
31 Ghita 179 181 71 65 246

Q Quelle est la meilleure performance des téléopérateurs ?


R =MAX(C25:G31) 296
Q Quelle est la pire performance des téléopérateurs ?
R =MIN(C25:G31) 65
Q Quelle est en moyenne le nombre d'appels effectué par téléop et par jour ?
R =MOYENNE(C25:G31) 164,11
Q Quelle est la meilleure performance de Brahim
R =MAX(C26:G26) 266
Q Quelle est la pire performance pour Venredi
R =MIN(G25:G31) 139
Q Combien en moyenne Chaimae a elle passé d'appels ?
R =MOYENNE(C27:G27) 149,6
Q Lundi, Mardi, MAX d'appels de : Amina, Brahim, Farid et Ghita ?
R =MAX(C25:D26;C30:D31) 266
Q Lundi, Mercredi, Vendredi, MIN d'appels de : Amina, Chaimae, Elias et Ghita ?
R =MIN(C25;E25;G25;C27;E27;G27;C29;E29;G29;G31;E31;C31) 71
Q Quelle est la Moyenne des max de Lundi , Mercredi et Vendredi ?
R =MOYENNE(MAX(C25:C31);MAX(E25:E31);MAX(G25:G31)) 249,33
NB
=NB(valeur1;valeur2;valeur3;….) =NB(11;"0";17;"alpha";2;#N/A)
=NB(cellule1;cellule2;cellule3;…) =NB(A1;B13;R5;C3)
4 =NB(plage) =NB(C15:F25)
Calcule le nombre de valeurs numériques dans une plage, que ce soit une ligne, une colonne ou
un tableau de données.
NBVAL
=NB(valeur1;valeur2;valeur3;….) =NBVAL(A1;B13;R5;C3)
=NBVAL(cellule1;cellule2;cellule3;…) =NBVAL(C15:F15)
5 =NBVAL(plage) =NBVAL(E3:E14)
Calcule le nombre de cellules non vides d'une plage, que ce soit, une ligne, une colonne ou un
tableau de données.
NB.VIDE
=NB.VIDE(cellule1;cellule2;cellule3;…) =NB.VIDE(A1;B13;R5;C3)
6 =NB.VIDE(plage) =NB.VIDE(C15:F25)
Calcule le nombre de cellules vides d'une plage, que ce soit une ligne, une colonne ou un
tableau de données.

Exmpl B C D E F G
70 Tickets Lundi Mardi Mercredi Jeudi Vendredi
71 Guichet 1 HS 102 128 93
72 Guichet 2 148 HS
73 Guichet 3 154 99 HS 82 82
74 Guichet 4 88 HS 72
75 Guichet 5 HS 118 113 131
76 Guichet 6 182 68 160 121
77 Guichet 7 166 95 HS 88

Q Combien de jours les guichets sont ouverts ?


R =NBVAL(C70:G70) 5
Q Combien de guichets sont disponibles ?
R =NBVAL(B71:B77) 7
Q Combien de fois les guichets ont été Hors Service (HS) pendant le semaine ?
R =NBVAL(C71:G77) - NB(C71:G77) 6
R =NB.SI(C71:G77;"HS") 6 =NB.SI(C71:G77;"*") 6
R =(G80*G82) - NB(C71:G77) - NB.VIDE(C71:G77) 6
Q Combien de fois les guichets n'ont rien vendu pour cette semaine ?
R =NB.VIDE(C71:G77) 9
NB.SI
=NB.SI(plage_ligne;critère) =NB.SI(A22:D22;"alpha")
=NB.SI(plage_colonne;critère) =NB.SI(A22:A32;">=22")
7 =NB.SI(plage_table;critère) =NB.SI(A22:D32;"<>charlie")
Calcule le nombre de cellules d'une plage donnée qui vérifient un critère donné; c’est-à-dire
que cette fonction teste chaque cellule de la plage et vérifie si celle-ci se conforme au critère
indiqué.
NB.SI.ENS
=NB.SI.ENS(plage1;critère1;plage2;critère2;plage3;critère3;...)
=NB.SI.ENS(A1:A10;"A*" ; B1:B10;">=" & E11 ; C1:C10;"<" & MOYENNE(C1:C10))
=NB.SI.ENS(A1:D10;"<>22")
8 Calcule le nombre de fois où un ou plusieurs critères sont vérifiés sur une ou plusieurs plages
de test ; chaque plage de test est suivie par le critère qui lui correspond, Excel va passer de plage
en plage en vérifiant pour chaqune les cellules qui y sont conforme au critère de la plage en
cours de test.

Exmpl B C D E F G
118 Facture Client Montant Virement Livraison Gain
119 F1704-11 COBOIS 336 275,00 24/05/2017 Casa 13 451,00
120 F1703-02 IRON LTD 397 581,00 20/04/2017 Eljadida 15 903,24
121 F1704-23 ALLIAGEM 482 325,00 16/05/2017 Casa 9 646,50
122 F1704-34 COBOIS 447 023,00 13/05/2017 Safi 40 232,07
123 F1702-15 COBOIS 320 370,00 09/03/2017 Témara 16 018,50
124 F1703-06 ALLIAGEM 171 525,00 19/04/2017 Safi 10 291,50
125 F1701-27 IRON LTD 475 484,00 12/02/2017 Safi 42 793,56
126 F1704-28 ALLIAGEM 275 436,00 18/05/2017 Témara 13 771,80
127 F1703-29 COBOIS 190 548,00 14/02/2017 Casa 13 338,36
128 F1702-30 ALLIAGEM 102 302,00 15/02/2017 Témara 10 230,20
129 F1701-31 IRON LTD 290 982,00 16/02/2017 Témara 20 368,74
130 F1704-32 COBOIS 303 418,00 27/05/2017 Eljadida 18 205,08

Q Combien de factures traitées pour : COBOIS (Liste Déroulante)


R =NB.SI(C119:C130;E132) 5
Q Combien de factures dont les montants sont de plus de 300 000,00 ?
R =NB.SI(D119:D130;">300000") 7
Q Combien de factures pour lesquelles les gains sont plus bas que la moyenne ?
R =NB.SI(G119:G130;"<" & MOYENNE(G119:G130)) 9
Q Combien de livraisons faites pour : COBOIS Sur Casa
R =NB.SI.ENS(C119:C130;E138;F119:F130;G138) 2
Q Combien de factures émises pour le mois 04 / 2017 payées avant le 20/05/2017 ?
R =NB.SI.ENS(B119:B130;"F1704*";E119:E130;"<20/05/2017") 3
Q Combien de factures représentant 10% ou plus du C.A réalisé ?
R =NB.SI.ENS(D119:D130;">=" & 10%*SOMME(D119:D130)) 4
Q Factures du mois 02/2017 ,livraison à Témara , gains d'au moins 10 000,00 ? 2
R =NB.SI.ENS(B119:B130;"F1702-??";F119:F130;"Témara";G119:G130;">=10000")
SOMME
=SOMME(plage_ligne) =SOMME(A22:D22)
=SOMME(plage_colonne) =SOMME(A22:A32)
9 =SOMME(plage_table) =SOMME(A22:D32)
Calcule la somme des valeurs d'une plage, que ce soit une ligne, une colonne, des valeurs, des
cellules ou un tableau ou meme plusieurs plages séparés par ";"
SOMME.SI
=SOMME.SI(plage_de_test ; critère ; plage_de_somme)
plage_de_test Plage où va être testé le critère cellule par cellule
10 critère Critère de test qui va être vérifié sur plage_de_test
plage_de_somme Plage où va être calculée la somme
Calcule la somme des éléments de "plage_de_somme" qui correspondent aux éléments de
"plage_de_test" pour lequelles le critère est vrai.
SOMME.SI.ENS
=SOMME.SI.ENS(plage_somme;plage_test_1;critère_1;plage_test_2;critère_2; …)
plage_somme Plage où va être calculée la somme
plage_test_1;critère_1 1ère plage de test suivie de son critère de test.
plage_test_2;critère_2 2ème plage de test suivie de son critère de test.
11 … On ajoute n'importe quel nombre de plages et leurs tests…
Calcule la somme des éléments de "plage_de_somme" qui correspondent à chacun des éléments
de chaque "plage_de_test" qui répond à son critère; chaque plage test sera vérifiée cellule par
cellule selon le critère de celle-ci, à la fin Excel ne gardrera que les cellules qui répondent à tous
les critères et retournera la somme de ces cellules.

Exmpl B C D E F G
176 Facture Client Montant Virement Livraison Gain
177 F1704-11 COBOIS 336 275,00 24/05/2017 Casa 13 451,00
178 F1703-02 IRON LTD 397 581,00 20/04/2017 Eljadida 15 903,24
179 F1704-23 ALLIAGEM 482 325,00 16/05/2017 Casa 9 646,50
180 F1704-34 COBOIS 447 023,00 13/05/2017 Safi 40 232,07
181 F1702-15 COBOIS 320 370,00 09/03/2017 Témara 16 018,50
182 F1703-06 ALLIAGEM 171 525,00 19/04/2017 Safi 10 291,50
183 F1701-27 IRON LTD 475 484,00 12/02/2017 Safi 42 793,56
184 F1704-28 ALLIAGEM 275 436,00 18/05/2017 Témara 13 771,80
185 F1703-29 COBOIS 190 548,00 14/02/2017 Casa 13 338,36
186 F1702-30 ALLIAGEM 102 302,00 15/02/2017 Témara 10 230,20
187 F1701-31 IRON LTD 290 982,00 16/02/2017 Témara 20 368,74
188 F1704-32 ALLIAGEM 303 418,00 27/05/2017 Eljadida 18 205,08

Q Total Montants 3 793 269,00 Total Gains 224 250,55


R =SOMME(D177:D188) =SOMME(G177:G188)
Q Somme de valeurs 113,00 Somme Cellules/Plages 1 769 700,00
R =SOMME(22;10;19;82;-16;-4) =SOMME(D177;D180:D181;D183;D185)
Q Montants pour COBOIS 1 294 216,00 Gains Mois 04/2017 95 306,45
R =SOMME.SI(C177:C188;"COBOIS";D177:D188) =SOMME.SI(B177:B188;"F1704*";G177:G188)
Q Montant factures mois 04/2017 payées avant le 20/05/2017 ? 1 204 784,00
R =SOMME.SI.ENS(D177:D188;B177:B188;"F1704*";E177:E188;"<20/05/2017")
Q Gain réalisé avec COBOIS aveclivraison à Casa et Témara ? 42 807,86
=SOMME.SI.ENS(G177:G188;C177:C188;"COBOIS";F177:F188;"Casa") +
R
SOMME.SI.ENS(G177:G188;C177:C188;"COBOIS";F177:F188;"Témara")
RECHERCHEV
=RECHERCHEV(clé_recherche;tablev_recherche;pos_col_résultat;approximation)
clé_recherche Mot clé à la base duquel va s'effectuer la recherche
tablev_recherche Tableau vertical de données, qui commence par la colonne qui
coniendrait la "clé_recherche"
pos_col_résultat Position (dans tablev_recherche) de la colonne de laquelle on va
extraire le résultat, exmpl : 3ème collonne -> 3 …
approximation VRAI ou 1 pour une recherche approximative (sur la
12 clé_recherche), FAUX ou 0 pour une recherche exacte.
Recherche la valeur qui correspond à la "clé_recherche" dans la colonne de résultats, indiquée
par sa position dans la "tablev_recherche", quand la recherche est exacte, la fonction renvoie le
résultat trouvé si la clé existe dans la 1ère colonne de "tablev_recherche", sinon elle renvoie
#N/A; mais si la recherche est approximative, la fonction envoi le résultat qui correspond soit à
"clé_recherche" si elle existe, soit à une clé qui est la plus grande valeur qui soit inférieur à
"clé_recherche" (dans ce cas les données devraient être triées en ordre croissant).

RECHERCHEH
=RECHERCHEH(clé_recherche;tableh_recherche;pos_ligne_résultat;approximation)
clé_recherche Mot clé à la base duquel va s'effectuer la recherche
tableh_recherche Tableau horizontal de données, qui commence par la ligne qui
coniendrait la "clé_recherche"
pos_ligne_résultat Position (dans tableh_recherche) de la ligne de laquelle on va
extraire le résultat, exmpl : 3ème ligne -> 3 …
13 approximation VRAI ou 1 pour une recherche approximative (sur la
clé_recherche), FAUX ou 0 pour une recherche exacte.
Recherche la valeur qui correspond à la "clé_recherche" dans la ligne de résultats, indiquée par
sa position dans la "tableh_recherche", quand la recherche est exacte, la fonction renvoie le
résultat trouvé si la clé existe dans la 1ère ligne de "tableh_recherche", sinon elle renvoie #N/A;
mais si la recherche est approximative, la fonction renvoie le résultat qui correspond soit à
"clé_recherche" si elle existe, soit à une clé qui est la plus grande valeur qui soit inférieur à
"clé_recherche" (dans ce cas les données devraient être triées en ordre croissant).

Exmpl B C D E F G
234 CNE Nom 1ère Année 2ème Année 3ème Année Moy. Gén
235 3248951235 Mounir 12,00 10,00 13,00 11,67
236 4587621385 Batoul 11,00 8,00 8,00 9,00
237 6841023540 Karim 14,00 14,00 8,00 12,00
238 7845102361 Dalal 14,00 15,00 15,00 14,67

240 Type CNE 3000000000 4000000000 5000000000 6000000000 7000000000


241 Région Ain Borja Bernoussi Ain Sebaa Hay Hassani Anfa

Q Moyenne obtenue en 2ème Année par l'étudiant 4587621385 ? 8,00


R =RECHERCHEV("4587621385";B234:G238;4;VRAI)
Q Moyenne Générale de : Dalal Pour l'Année 3 15,00
R =RECHERCHEV(D245;C234:G238;F245+1;0)
Q Moyenne Générale de karim ? 12,00
R =RECHERCHEH("Moy. Gén";B234:G238;4;0) =RECHERCHEV("Karim";C234:G238;5;FAUX)
Q De quelle région est l'étudiante Batoul, dont le CNE est 4587621385 ? Bernoussi
R =RECHERCHEH("4587621385";B240:G241;2;VRAI)
EQUIV
=EQUIV(valeur_recherchée;plage_recherche;type_recherche)
valeur_recherchée Valeur que l'on recherche.
plage_recherche Ligne ou colonne de données, dans laquelle va s'effectuer la
recherche et qui coniendrait la "valeur_recherchée".
type de recherche 1 : Approximation, Données triées en ordre croissant, valeur la
14 plus élevée inférieure à "clé_recherche".
0 : Reherche exacte de la "clé_rechercheé.
-1 : Approximation, Données triées en ordre décroissant, valeur
la plus petite qui soit supérieure à "clé_recherche".
Renvoie la position relative de la valeur recherchée dans la plage de recherche, par exemple,
dans une ligne qui contient {13;24;35}, EQUIV(24;ligne;0) va renvoyer 2 car 24 est à la 2ème
position dans cette plage.
INDEX
=INDEX(plage_recherche;position_ligne;position_colonne)
plage_recherche Plage d'où la fonction INDEX va extraire la valeur souhaitée,
cette plage peut être une ligne, une colonne ou un tableau.
position_ligne Position relative de la ligne où se trouverait la valeur souhaitée.

position_colonne Position relative de la colonne où se trouverait la valeur


15 souhaitée.
- Dans une colonne, on utilise INDEX(colonne ; position_dans_colonne).
- Dans une colonne, on utilise INDEX(ligne ; position_dans_ligne).
- Dans un tableau 2D, on utilise INDEX(matrice ;position_ligne; position_colonne).
Dans le cas d'une matrice, la fonction réccupère la valeur qui se trouve à l'intersection de la ligne
et la colonne indiquées par leurs positions, par exemple : INDEX(A1:D9;7;3) extrait la valeur à
l'intersection de la ligne 7 et la colonne 3.

En combinant les fonctions EQUIV et INDEX, on peut effectuer des recherches dans toutes les
directions, ainsi, EQUIV nous permet d'avoir les positions des clés de recherches qu'on peut ensuite
fournir à la fonction INDEX qui va les utiliser pour extraitre la valeur dans ces positions.

Exmpl B C D E F G
284 CNE Nom 1ère Année 2ème Année 3ème Année Moy. Gén
285 3248951235 Mounir 12,00 10,00 13,00 11,67
286 4587621385 Batoul 11,00 8,00 8,00 9,00
287 6841023540 Karim 14,00 14,00 8,00 12,00
288 7845102361 Dalal 14,00 15,00 15,00 14,67

Q Quelle est la position du CNE 6841023540 dans la colonne CNE ? 4


R =EQUIV("6841023540";B284:B288;0)
Q Quelle est la position de "Moy. Gén" dans la ligne des titres ? 6
R =EQUIV("Moy. Gén";B284:G284;0)
Q Quelle est la moyenne générale de l'étudiant 6841023540 ? 12,00
R =INDEX(B284:G288;4;6)
Q Qui a eu la meilleure note en 2ème Année ? Dalal
R =INDEX(C284:C288;EQUIV(MAX(E285:E288);E284:E288;0))
Q Moyenne de Karim dont le CNE est "6841023540" en "3ème Année" ? 8,00
R =INDEX(B284:G288;EQUIV("6841023540";B284:B288;0);EQUIV("3ème Année";B284:G284;0))
ET
=ET(test_logique1;test_logique2;test_logique3;…)
Table de Vérité ET() VRAI FAUX
VRAI VRAI FAUX
16 FAUX FAUX FAUX
Retourne VRAI ou FAUX , selon l'opération logique ET, retourne VRAI si tous les tests logiques
qu'elle traite sont VRAIS; il suffit qu'un seul test soit FAUX pour que la fonction retourne FAUX.

OU
=OU(test_logique1;test_logique2;test_logique3;…)
Table de Vérité OU() VRAI FAUX
VRAI VRAI VRAI
17 FAUX VRAI FAUX
Retourne VRAI ou FAUX , selon l'opération logique ET, retourne FAUX si tous les tests logiques
qu'elle traite sont FAUX; il suffit qu'un seul test soit VRAI pour que la fonction retourne VRAI.

SI
=SI(test_logique;valeur_si_test_vrai;valeur_si_test_faux)
test_logique test logique que la fonction va traiter, on peut y mettre une
condition ou un test logique avec les fonctions ET() , OU().
valeur_si_test_vrai valeur à mettre si le test logique est vrai.
18 valeur_si_test_faux valeur à mettre si le test logique est faux.
test la véracité de "test_logique", s'il s'avère VRAI, afficher "valeur_si_test_vrai", sinon si le test
est faux, afficher "valeur_si_test_faux", le "test_logique" peut etre une condition simple ou une
combinaison logique de tests ET() et OU(); Les valeurs indiquées peuvent ètre des nombres, du
texte, des calculs et des opérations ou meme des fonctions à executer.

Exmpl B C D E F G
330 Étudiant Note Gén Accepté(e) ? Soutien ? Note Soutien Décision
331 Amine 11,32 Recalé OUI 13,27 Passer
332 Zineb 10,03 Recalé OUI 9,49 Repasser
333 Brahim 14,47 Accepté NON Passer
334 Yassmine 11,94 Recalé OUI 14,19 Passer
Note de référence 12,00 Mention de la Classe Médiocre
Q Est-ce que Amine et Yassmine ont tous les deux eu la moyenne ? FAUX
R =ET(C331>=C335;C334>=C335)
Q Est-ce qu'au moins un des étudiants a eu la moyenne ? VRAI
R =NB.SI(C331:C334;">=" & C335) > 0
Mention de la Classe : "Bonne" si la moyenne de la classe est >= la note de référence,
Q
"Médiocre" sinon.
R =SI(MOYENNE(C331:C334) >=C335;"Bonne";"Médiocre")
Q Est-ce que Zineb a eu une note de 11 ou plus ? NON
R =SI(RECHERCHEV("Zineb";B330:C334;2;0) >= 11;"OUI";"NON")
Q Colonne "Accepté(e) ?" , Sont acceptés ceux dont la note >= Note de référence.
R =SI(C331>=$C$335;"Accepté";"Recalé")
Q Colonne "Soutien" , Ont des cours de soutien ceux qui sont recalés.
R =SI(D331="Recalé","OUI";"NON)
Q Colonne "Décision" , Vont repasser l'exam ceux dont la note de soutien <= 12.
R =SI(ET(E331="OUI";F331<=$C$335);"Repasser";"Passer")