Vous êtes sur la page 1sur 4

Calcul de la TVA (HT ou TTC)

La TVA c'est une taxe qui s'ajoute lors de la vente d'un produit ou d'un service. Pour les entreprises, cette taxe
s'ajouter lorsque vous vendez un produit mais se déduit lorsque c'est l'entreprise qui achète un produit.

Calcul de la TVA
Dans le calcul de la TVA vous avez 2 éléments à prendre en compte

• Le prix du produit
• La taxe à appliquer (toujours exprimée en pourcentage)

Calcul de la taxe seule

Si nous avons un produit qui vaut 45 et un taux de TVA de 20% le calcul de la TVA s'obtient simplement avec cette
opération

=45*20%

Mais plus généralement, les données sont dans des cellules. Donc, il faut créer une formule qui va récupérer les
références des cellules comme ici

=B4*C1

Calcul du prix TTC

Le prix TTC (toute taxe comprise) c'est l'addition du prix hors taxe (HT) et de la taxe calculée. On peut donc écrire en
D2

=B4+C4

Mais il est aussi possible d'effectuer le calcul du prix TTC sans passer par le calcul du montant de la taxe. Le calcul sera
la suivant :

=45+45*20%

• On utilise une première fois le prix de notre produit (45)


• Puis on utilise de nouveau cette valeur pour en calculer la taxe (45*20%)
• Le total est donc de 54

Mais vous avez certainement constaté que la valeur 45 est présente 2 fois dans l'opération. On peut donc utiliser une
règle mathématique qui permet de réduire l'écriture.

=45*1+45*20%

Et maintenant on isole la valeur 45 comme ceci

=45*(1+20%)
En replaçant les valeurs par les références des cellules, l'écriture devient celle-ci

=B4*(1+C1)

Recopie de la formule

Si maintenant vous avez un document qui contient plusieurs produits, la recopie de la formule précédente va engendrer
des erreurs.

En effet, si vous recopier la formule précédente, voilà le résultat que vous allez obtenir. Il y a des erreurs car comme

vous le constatez, vous ne restez pas tout le temps en C1

C'est pourquoi, dans ce cas de figure, il faut verrouiller la référence de la cellule C1 avec le symbole $. L'occasion de
relire l'article sur les références bloquées ou pas.

La formule s'écrit alors

=B4*(1+$C$1)

Déduire la TVA
Maintenant, faisons l'opération inverse à savoir, retirer la TVA d'un produit acheté.
Calculer le prix net du produit

Le prix net d'un bien s'obtient en divisant le prix TTC par la TVA +1

=B4/(1+$C$1)

Calculer la taxe seule

Maintenant, si vous voulez juste calculer la taxe que vous avez payé, vous pouvez bien sur faire la différence entre le
prix TTC et le prix HT.

Mais vous pouvez aussi reprendre la formule précédente en rajoutant la TVA dans le numérateur.

=(B4*$C$1)/(1+$C$1)

Gérer plusieurs niveaux de TVA


Dans la plus part des pays (sauf au Danemark), il n'y a pas un seul niveau de TVA mais plusieurs (TVA normal, TVA
réduite).

Dans le document suivant, nous avons un tableau qui retrace les différents taux de TVA. Chaque taux est identifié par un
code unique (1, 2 ou 3 dans notre exemple).
Avec la fonction RECHERCHEV nous allons rechercher l'identifiant du taux de TVA et l'incorporer dans le tableau
principal.

La formule dans notre exemple est

=RECHERCHEV(B2;$G$3:$I$5;3;0)

Maintenant pour calculer le prix TTC de nos produits en fonction des différents niveaux de taxe, la formule devient

=C2*(1+RECHERCHEV(B2;$G$3:$I$5;3;0))