Vous êtes sur la page 1sur 2

Skills Commands CCNA2

1.

Full configuration

Hostname
Router>enable : goto priveledge mode
Router#config terminal : goto global config mode , use conf t
Router(config)#hostname lab_Z : set hostname of the router

Password: priv. mode


Router(config)#enable secret class : password for priv.mode if
passw. encryption is on
Router(config)#enable password cisco : password for priv.mode if
passw. encryption is off

Password: console
Router(config)#line console 0 : console 0
Router(config-line)#password cisco : console password
Router(config-line)#login

Password: telnet
Router(config)#line vty 0 4 : configure telnet
Router(config-line)#password cisco : telnet password
Router(config-line)#login

Banner
Router(config)#banner motd #message#

Interfaces: s2/0
Router(config)#interface s2/0
Router(config-if)#ip address (adres) (subnet)
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000 : only if DCE, not for DTE!
Router(config-if)#exit

Interfaces: fa0/0
Router(config)#interface fa0/0
Router(config-if)#ip address (adres) (subnet)
Router(config-if)# no shutdown

Interfaces: loopback 0
Router(config)#interface lo 0
Router(config-if)#ip address (adres) (subnet)

Routing protocols - RIP


Router(config)#router rip
Router(config-router)#network 192.5.5.0 :(network part of the address)
Router(config-router)#network …

Rip version2
Router(config)# router rip
Router(config-router)# version 2
Skills Commands CCNA2
2.

Routing protocols - EIGRP


Router(config)#router eigrp 1
Router(config-router)#network 192.5.5.0 0.0.0.255 :(network part of the address +
wildcardmask)
Router(config-router)#network …

Router(config-router)#no auto-summary

Router(config-router)#redistribute static

Routing protocols - OSPF


Router(config)#router ospf 1
Router(config-router)#network 192.5.5.0 0.0.0.255 area 0 :(network part of the address +
wildcard)
Router(config-router)#network …

Router(config-router)#default-information originate

OSPF timers (must be the same on both routers)


Router(config-if)#ip ospf hello-interval 10
Router(config-if)#ip ospf dead-interval 40

Static routes
Destination mask Default gateway or outgoing interface
GAD(config)#ip route 192.168.16.0 255.255.255.0 192.168.15.2
GAD(config)#ip route 192.168.16.0 255.255.255.0 s0

Default route
GAD(config)# ip route 0.0.0.0 0.0.0.0 192.168.15.2
GAD(config)# ip route 0.0.0.0 0.0.0.0 lo 0

Checking
Router#sh run : show running config
Router#sh start : show startup config
Router#sh cdp neighbors
Router#sh ip route
Router#sh ip protocols
Router#debug ip rip
Router#ping
Router#trace

Other commands
Router(config)#service password-encryption
Description ….
no CDP run : disable cdp on a global level
no CDP enable : disable cdp on an interface
Ctrl-Shift-6, then x : stop telnet
Debug ip rip
Debup ip icmp