Vous êtes sur la page 1sur 23

TOGNON Bignon Hans Kadoukpe

Présentation de projet (Algebre de Boole )


Retardataire

PARTIE A:
1.Écriture et implémentation dans ALGOBOX de l’algorithme 1 permettant d’obtenir le milieu d’un
segment à partir de deux points du plan ( en se situant dans un cadre géométrique).

Algortihme Milieu_Segment
Variables:Xa, Xb, Ya, Yb: Reel;
Debut
//Indication a l’utilisateur
Ecrire(“Ce programme permet d’obtenir le milieu d’un segment forme de deux points,”);
Ecrire(“qui delimitent ses extremites.\n”);
Ecrire(“Entrez l’abcisse du premier point de votre segment:”);
Lire(Xa);
Ecrire(“Entrez l’ordonnee du premier point de votre segment:”);
Lire(Ya);
Ecrire(“Entrez l’abcisse du second point de votre segment:”);
Lire(Xb);
Ecrire(“Entrez l’ordonnee du second point de votre segment:”);
Lire(Yb);
Ecrire(“L’abcisse et l’ordonnee du point milieu de votre segment sont respectivement:\n”);
Ecrire((Xa + Xb)/2, “ et ”, (Ya + Yb)/2);
//Parentheses utilisees pour specifier la priorite des operations
Fin

IMPLEMENTATION DANS ALGOBOX


L’implémentation dans Algobox donne l’algorithme présenté comme suit:
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

On teste l’algorithme en partant de deux points fictifs A(2;2) et B(6;3), et on voit ainsi qu’il est
parfaitement fonctionnel:

On obtient bien le couple (4;2,5) qui correspond aux coordonnées du point milieu du segment formé
par ces deux points.

2.Écriture et implémentation dans ALGOBOX, de l’algorithme permettant d’obtenir 3x – 4 à partir


de x(en se situant dans un cadre numérique).

Algorithme Image_x
Variable: x: Reel;
Debut
//On donne une indication a l’utilisateur sur l’utilite de l’algorithme
Ecrire(“Programme determinant l’image d’un reel x par la fonction f(x) = 3x – 4.\n”);
Ecrire(“Entrez une valeur pour x:”);
Lire(x);
Ecrire(”f(“, x, “) = ”, 3*x – 4);
Fin

IMPLEMENTATION DANS ALGOBOX


Voici l’algorithme une fois implémenté dans algobox:
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

On teste notre algorithme en lui soumettant différentes valeurs :

3. Écriture et implémentation dans ALGOBOX, d’un a;gorithme permettant d’obtenir la


moyenne pondérée de plusieurs notes avec des coefficients quelconques et un nombre
de matières non connu d’avance.

Algorithme Moyennes_ponderees
Variables: i, Coefficient, Nombre_Matieres: Entier;
Somme_Coefficients, Somme_Notes_Ponderees, Note: Reel;
Debut
Ecrire(“Ce programme permet le calcul de moyennes a partir de notes pondérées\n”);
Ecrire(“Entrez le nombre de matières constituant la moyenne:”);
Lire(Nombre_Matieres);
i =1;
Somme_Coefficients = 0;
Somme_Notes_Ponderees = 0;
TantQue (i <= Nombre_Matieres) Faire
Debut
Ecrire(“Entrez la note de la matiere numero”, i);
Lire(Note);
Ecrire(“Entrer le coefficient de la matiere numero”, i);
Lire(Coefficient);
Somme_Coefficient = Somme_Coefficient + Coefficient;
Somme_Notes_Ponderees = Somme_Notes_Ponderees + (Note * Coefficient);
i= i+ 1;
Fin
Ecrire(“La moyenne calculée donne:”, Somme_Notes_Ponderees / Somme_Coefficient);
Fin

IMPLEMENTATION DANS ALGOBOX


TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

4. Ecriture et implémentation dans ALGOBOX d’un algorithme qui permet


de calculer une remise de t % sur un prix p.

Algorithme Remise
Variables: remise, prix: Reel
Debut
Ecrire(“Calcul d’une remise de t% sur un prix p.\n”);
Ecrire(“Entrez le prix de votre article:”);
Lire(prix);
Ecrire(“Entrez le taux de remise”);
Lire(remise) ;
Ecrire(“La remise vaut:”);
Ecrire(prix * remise / 100);
Fin

IMPLEMENTATION DANS ALGOBOX


TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Il fonctionne correctement comme en témoigne l’exemple ci-dessous:

5 Ecriture et implémentation dans ALGOBOX d’un algorithme qui permet


de calculer le prix final (après une remise).

Algorithme Prix_remise
Variables: remise, prix: Reel
Debut
Ecrire(“Calcul d’un prix p apres une remise de t%. \n”);
Ecrire(“Entrez le prix initial de votre article:”);
Lire(prix);
Ecrire(“Entrez le taux de remise”);
Lire(remise) ;
Ecrire(“Le prix, apres remise vaut:”);
Ecrire(prix - prix * remise / 100);
// Du fait de la priorite des operateurs ,inutile d’utiliser les parentheses.
Fin

IMPLEMENTATION DANS ALGOBOX


TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

6. Ecrire un algorithme qui permet de calculer le prix HT connaissant le


prix TTC et le taux de TVA
Sachant que le prix TTC = HT + TVA , on déduit que le prix HT en fonction du prix TTC et
de la TVA soit HT = TTC - TVA or TVA = HT * t ,t étant le taux de la TVA, c’est à-dire que le prix
HT vaut , en fonction du taux de TVA et du prix TTC , TTC / (1 + t).

Algorithme Prix_HT
Variables: taux, ttc: Reel;
Debut
Ecrire(“Determination du prix HT en fonction du prix TTC, d’un taux de TVA de t%.\n”);
Ecrire(“Entrez la valeur du taux de la TVA:”);
Lire(taux);
Ecrire(“Entrez le prix TTC:”);
Lire(ttc);
Ecrire(“Le prix HT vaut:”, ttc / (1 + taux));
Fin

IMPLEMENTATION DANS ALGOBOX


TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

7.Ecriture d’un algorithme déterminant le taux de TVA (en pourcentage)


connaissant le prix HT et le prix TTC.
Sachant que TTC = HT + (HT * Taux) alors Taux vaut (TTC – HT) / HT

Algorithme Taux_TVA
Variables: ht, ttc: Reel;
Debut
Ecrire(“Determination du taux de TVA en fonction des prix TTC et HT .\n”);
Ecrire(“Entrez le prix HT:”);
Lire(ht);
Ecrire(“Entrez le prix TTC:”);
Lire(ttc);
Ecrire(“Le taux de TVA vaut:”, ((ttc – ht) / ht), “%”);
Fin

IMPLEMENTATION DANS ALGOBOX


TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

PARTIE B:
1-Complétion des propositions P1, P2, P3, P4 et P5:

P1: Si AB² + AC² = BC² , alors le triangle ABC est rectangle en A.


P2: Si ⃗ u =a ⃗v , a є R, Alors ⃗u ( x , y ) et ⃗v ( x ' , y ') dans un repère orthonormé (O,I,J)sont
colinéaires
P3: Si , alors les points A, B et C sont alignés sinon ils ne sont pas alignés
P4: Si mon âge est supérieur à 18 ans , alors je peux paaser mon permis de conduire sinon je ne
peux pas.
P5:
· Si je téléphone 3h par mois, alors jedois choisir le forfait <<liberto>>
· Si je téléphone plus de 6h par mois alors je dois choisir le forfait <<freedom>>

2-Conception des aalgorithmes pour chaque proposition:


- P1: Si AB² + AC² = BC² , alors le triangle ABC est rectangle en A.
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Algorithme Triangle_rect
Variables: AB, BC, AC: Reel;
Debut

Ecrire(“Entrer la longueur du coté AB:”);


Lire(AB);
Ecrire(“Entrer la longueur du coté BC:”);
Lire(BC);
Ecrire(“Entrer la longueur du coté AC:”);
Lire(AC);
Si ((AB * AB) + (AC * AC) == (BC * BC)) Alors
Ecrire(“ABC est rectangle en A.”);
Sinon
Ecrire(“ABC n’est pas rectangle en A.”);
FinSi
Fin

- P2:P2: Si ⃗ u =a ⃗v , a є R, Alors ⃗
u ( x , y ) et ⃗v ( x ' , y ') dans un repère orthonormé (O,I,J),
sont colinéaires

Algorithme Colinearite
Variables: x1, y1, x2, y2: Reel;
Debut
Ecrire(“Entrez l’abcisse du premier vecteur:”)
Lire(x1);
Ecrire(“Entrez l’ordonnée du premier vecteur:”)
Lire(y1);
Ecrire(“Entrez l’abcisse du second vecteur:”)
Lire(x2);
Ecrire(“Entrez l’ordonnée du second vecteur:”)
Lire(y2);
Si((x1 > x2 ET y1 > y2 ET (x1 / x2) == (y1 /y2)) OU (x2 > x1 ET y2 > y1 ET (x2 / x1) == (y2
/y1)) )Alors
Ecrire(“Les deux vecteurs sont colinéaires.”);
Sinon
Ecrire(“Les deux vecteurs ne sont pas colinéaires.”);
FinSi
FIn

- P4: Si mon âge est supérieur à 18 ans , alors je peux passer mon permis de conduire sinon je ne
peux pas.

Algorithme Permis
Variable: age: Entier;
Debut
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

age = -1;//Pour rentrer dans notre boucle


TantQue (age <= 0)Faire
Debut
Ecrire(“Entrez votre age pour savoir si vous pouvez passer le permis de conduire:”);
Lire(age);
Fin
Si (age < 18) Alors
Ecrire(“Vous ne pouvez pas passer le permis.”);
Sinon
Ecrire(“Vous pouvez passer le permis.”);
FinSi
Fin

- P5:
· Si je téléphone 3h par mois, alors je dois choisir le forfait <<liberto>>
· Si je téléphone plus de 6h par mois alors je dois choisir le forfait <<freedom>>

Algorithme Forfait_telephone
Variable: duree_appel: Entier;
Debut:
duree_appel = -1;//Pour rentrer dans notre boucle
TantQue ( duree_appel <= 0)Faire
Debut
Ecrire(“Entrez le nombre d’heures passées au téléphone par mois pour savoir le forfait
à choisir:”);
Lire(duree_appel);
Fin
Si (duree_appel > 6) Alors
Ecrire(“Optez pour le forfait freedom.”);
Sinon
Ecrire(“Optez pour le forfait liberto”);
FinSi
Fin

3-Implémentation algobox:
P1:
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

P2:

P4:
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

P5:
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

PARTIE C:
1-Etapes de calcul
Tout d’abord, explicitons les formules qui nous permettront d’effectuer les différents calculs:
t∗TTCsr TTCar
TVA=t∗HT = =TTCsr−HT TTCsr=HT (1+t)= =TVA+ HT
1+t 1−tr
TTCar=TTCsr−(TTCsr∗tr )=(1−tr)TTCsr

TVA TTCsr 100∗( TTCsr−TTCar)


HT = = =TTCsr−TVA tr= avec TVA = Taxe sur valeur
t 1+t TTCsr
ajoutée, TTCsr = Toutes Taxes Comprises sans remise, TTCar = Toutes Taxes Comprises avec
remise, t = Taux de TVA, tr = Taux de remise,
HT = Hors Taxes.
On se sert maintenant de la calculatrice pour effectuer nos différents calculs:
Pour le maïs, nous disposons du prix TTCsr et du taux de remise; on peut donc determiner dans
un premier temps, le prix TTCar suivant la formule précédente.
Les touches utilisées sur la calculatrice sont des plus basiques comme on peut le voir sur la capture
suivante:

Les zones encerclées


délimitent les touches qui seront utilisées pour effectuer tout calcul.
Dans le cas du calcul que nous voulions faire , il nous a suffi de remplacer les valeurs données pour
le maïs, dans notre formule.La capture précédente montre donc que le prix TTCar pour le maïs vaut
980 f.
Poursuivons les calculs pour le maïs:
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

HT Maïs TVA Maïs

Les captures ci-dessous explicitent les calculs effectués pour le reste des articles:

<--TVA
<-- TTC sans remise
<-- Taux de remise

Paracétamol

<-- TTC sans remise


<--HT

<--TVA

Whisky
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

<--TVA

<--TTC sans remise


←TTC avec remise

Telephone portable

←-Taux de remise

<--HT
<--TVA

Chloroquine

←-Taux de remise
<--HT

<--TVA

Carpes
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

←-Taux de remise
<--HT

<--TVA

Mil

←-TTC sans remise


←-TTC avec remise

<--TVA

Bière de luxe importée

←-TTC avec remise


<--HT

<--TVA

Cahier
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Produits Prix total TTC Prix HT Taxe de valeur Prix total TTC Taux de remise
sans remise ajoutée avec remise
Maïs 1000 f 930,2325 f 69,7674 f 980 f 2%

Paracétamol 189,9 f 180 f 9,9 f 170 f 10,4792%

Whisky 15789,47 f 13324,447 f 2465,023 f 15000 f 5%

Téléphone 5375 f 5000 f 375 f 4837,5 f 10%


Portable
(produit
courant)
Chloroquine 500 f 473,93 f 26,06 f 480 f 4%

Carpes 785 f 744,0758 f 40,9242 f 700 f 10,828%


(poissons)
Mil 1100 f 1042,654 f 57,346 f 1000f 9,09%

Bière de luxe 622,125 f 525 f 97,125 f 603,4612 f 3%


importée
Cahier de 100 f 93,023 f 6,97 f 90 f 10%
fabrication
locale(courant)

2-Algorithme
Algorithme Comptabilite
Variables:choix: Entier;
Fonction TVA() Retourne Vide;
Fonction TTCsr() Retourne Vide;
Fonction TTCar() Retourne Vide;
Fonction TR() Retourne Vide;
Fonction HT() Retourne Vide;
Debut
Ecrire(“Faites votre choix:”);
Ecrire(“1-Calcul de la TVA\n2-Calcul du TTC sans remise”);
Ecrire(“3-Calcul du TTC avec remise\n4-Calcul du HT”;
Ecrire(“5-Calcul du Taux de reduction”.);
choix = 0;
TantQue(choix <=0 ET choix >=6)Faire
Debut
Ecrire(“Entrez le numero correspondant:”);
Lire(choix);
Fin
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Si(choix == 1)Alors
TVA();
FinSi
Si(choix == 2)Alors
TTCsr();
FinSi
Si(choix == 3)Alors
TTCar();
FinSi
Si (choix == 4)Alors
HT();
FinSi
Si(choix == 5)Alors
TR();
FinSi
Fin
Fonction TVA() Retourne Vide
Variables:ttc, taux,HT:Reel;
Debut
Ecrire(“Calcul de TVA en fonction de:”);
Ecrire(“1- HT et taux de TVA”);
Ecrire(“2- HT et TTC sans remise”);
Ecrire(“3- TTC sans remise et taux de TVA”);
TantQue(choix <= 0 ET choix >=4)Faire
Debut
Lire(choix);
Fin
Si(choix == 1)Alors
Debut
Ecrire(“Entrez le prix HT”);
Lire(HT);
Ecrire(“Entrez le taux de TVA”);
Lire(taux);
Ecrire(“TVA = ”, HT * taux);
Fin
FinSi
Si(choix == 2)Alors
Debut
Ecrire(“Entrez le prix HT”);
Lire(HT);
Ecrire(“Entrez le prix TTC”);
Lire(ttc);
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Ecrire(“TVA = ”, ttc - HT);


Fin
FinSi
Si(choix == 3)Alors
Debut
Ecrire(“Entrez le prix TTC sans remise”);
Lire(ttc);
Ecrire(“Entrez le taux de TVA”);
Lire(taux);
Ecrire(“TVA = ”, (t * ttc)/ (1 + t));
Fin
FinSi
Fin

Fonction TTCsr() Retourne Vide


Variables:ttc, taux,HT:Reel;
Debut
Ecrire(“Calcul de TTCsr en fonction de:”);
Ecrire(“1- HT et taux de TVA”);
Ecrire(“2- HT et TVA”);
Ecrire(“3- TTC avec renise et taux de réduction ”);
TantQue(choix <= 0 ET choix >=4)Faire
Debut
Lire(choix);
Fin
Si(choix == 1)Alors
Debut
Ecrire(“Entrez le prix HT”);
Lire(HT);
Ecrire(“Entrez le taux de TVA”);
Lire(taux);
Ecrire(“TTCsr = ”, HT (1 + taux));
Fin
FinSi
Si(choix == 2)Alors
Debut
Ecrire(“Entrez le prix HT”);
Lire(HT);
Ecrire(“Entrez la TVA”);
Lire(ttc);
Ecrire(“TVA = ”, TVA + HT);
Fin
FinSi
Si(choix == 3)Alors
Debut
Ecrire(“Entrez le prix TTC avec remise”);
Lire(ttc);
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Ecrire(“Entrez le taux de reduction”);


Lire(taux);
Ecrire(“TVA = ”, ttc/ (1 - taux));
Fin
FinSi
Fin
Fonction HT() Retourne Vide
Variables:ttc, taux,TVa:Reel;
Debut
Ecrire(“Calcul de HT en fonction de:”);
Ecrire(“1- TVAet taux de TVA”);
Ecrire(“2- taux de TVA et TTC sans remise”);
Ecrire(“3- TTC sans remise et de TVA”);
TantQue(choix <= 0 ET choix >=4)Faire
Debut
Lire(choix);
Fin
Si(choix == 1)Alors
Debut
Ecrire(“Entrez le prix HT”);
Lire(HT);
Ecrire(“Entrez le taux de TVA”);
Lire(taux);
Ecrire(“HT = ”, TVA / taux );
Fin
FinSi
Si(choix == 2)Alors
Debut
Ecrire(“Entrez le prix HT”);
Lire(HT);
Ecrire(“Entrez le prix TTC”);
Lire(ttc);
Ecrire(“HT = ”, ttc / (1+taux));
Fin
FinSi
Si(choix == 3)Alors
Debut
Ecrire(“Entrez le prix TTC sans remise”);
Lire(ttc);
Ecrire(“Entrez le taux de TVA”);
Lire(taux);
Ecrire(“HT = ”, ttc - TVA);
Fin
FinSi
Fin
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Fonction TR() Retourne Vide


Variables:ttc, ttcsr:Reel;
Debut
Ecrire(“Entrez le Ttc avec remise:”);
Lire(ttc);
Ecrire(“Entrez le Ttc sans remise:”);
Lire(ttcsr) ;
Ecrire(“Taux de reduction = ”, 100(ttcsr – ttc) / ttcsr, “%.”);
Fin
Fonction TTCar() Retourne Vide
Variables:ttc, taux:Reel;
Debut
Ecrire(“Entrez le Ttc avec remise:”);
Lire(ttc);
Ecrire(“Entrez le taux de remise:”);
Lire(taux) ;
Ecrire(“TTcar = “ , ttc(1 - taux));
Fin
3-Algobox:
PARTIE D:

Ces équations sont toutes des équations du premier degré, c’est-à-dire de la forme ax + b = c,
(a,b,c) є R* x R².La solution à ces équations se déduit donc aisément , à savoir qu’elle est de la
forme x = (c- b) / a.On peut donc ecrire un seul algorithme pour toutes les trois équations.

1-Ecrivons un algorithme informatique pour toutes les trois equations:

Algorithme Resolution_Eqn_Deg_1
Variables: a, b, c: Reel;
Debut
Ecrire(“Résolution des équations de la forme ax + b = c.\n”);
Ecrire(“Entrez la valeur de a pour votre équation:);
Lire(a);
Ecrire(“Entrez la valeur de b pour votre équation:”);
Lire(b);
Ecrire(“Entrez la valeur de c pour votre équation:);
Lire(c);
Ecrire(“La solution a l’équation, “, a, “x + “, b, “ = “, c, “ est x = ”, (c – b) / a );
Fin

2-Realisation de l’algorithme avec ALGOBOX

L’algorithme rédigé dans ALGOBOX donne le résultat suivant:


TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire

Les captures suivantes montrent qu’il fonctionne bien , chacune des trois équations y étant
résolues:
TOGNON Bignon Hans Kadoukpe
Présentation de projet (Algebre de Boole )
Retardataire