Vous êtes sur la page 1sur 5

Routage Dynamique: IGRP

1. INTRODUCTION
Dans les précédents Tutos, nous avons étudié quelques protocoles de Routages dynamique
(RIP, RIPv2); nous continuerons sur cette lancé en étudiant aujourd'hui un autre protocole de
Routage qui n'est autre que le IGRP.
IGRP est un protocole de Routage de type Vecteur de distance conçu entre autres pour
surmonter les limitations du protocole RIP. En effet avec le protocole IGRP, nous avons les
propriétés suivantes:

 Insensibilité à la taille du réseau


 Réponse rapide aux modifications du Réseau
 Plusieurs métriques (Bande passante, charge, fiabilité, MTU) regroupées en une seule
metrique sophistiquée grâce à une formule ajustable.

Notons encore que le protocole IGRP est un protocole de routage Classfull, donc ne supporte
pas les masques de sous-réseaux de taille variable. Nous verrons plus tard une autre variante
de ce protocole (EIGRP) développée par CISCO permettant de tenir en compte des masques
de sous-réseaux de taille variable.

2. SCHEMA DE TRAVAIL
Réalisez sur Packet tracer le schéma suivant et attribuez conformément à celui-ci, des
adresses IP aux différentes interfaces en utilisant les commandes se situant à la section pré
configuration.
Pré-configuration

Tapez successivement les commandes suivantes pour configurer les différentes interfaces des
Routeurs:

 Routeur 1

Routeur1>en
Routeur1#conf t
Routeur1(config)#interface FastEthernet0/0
Routeur1(config-if)#ip address 172.16.255.254 255.255.0.0
Routeur1(config-if)# no sh
Routeur1(config-if)#exit
Routeur1(config)#interface FastEthernet1/0
Routeur1(config-if)#ip address 192.168.12.1 255.255.255.0
Routeur1(config-if)# no sh
Routeur1(config-if)#exit
Routeur1(config)#interface FastEthernet1/1
Routeur1(config-if)#ip address 192.168.13.1 255.255.255.0
Routeur1(config-if)#no sh
Routeur1(config-if)#end

 Routeur 2
Routeur2>en
Routeur2#conf t
Routeur2(config)#interface FastEthernet1/0
Routeur2(config-if)#ip address 192.168.12.254 255.255.255.0
Routeur2(config-if)# no sh
Routeur2(config-if)#exit
Routeur2(config)#interface FastEthernet1/1
Routeur2(config-if)#ip address 192.168.23.254 255.255.255.0
Routeur2(config-if)#no sh
Routeur2(config-if)#end

 Routeur 3

Routeur3>en
Routeur3#conf t
Routeur3(config)#interface FastEthernet0/0
Routeur3(config-if)#ip address 172.17.255.254 255.255.0.0
Routeur3(config-if)# no sh
Routeur3(config-if)#exit
Routeur3(config)#interface FastEthernet1/0
Routeur3(config-if)#ip address 192.168.23.1 255.255.255.0
Routeur3(config-if)# no sh
Routeur3(config-if)#exit
Routeur3(config)#interface FastEthernet1/1
Routeur3(config-if)#ip address 192.168.13.254 255.255.255.0
Routeur3(config-if)#no sh
Routeur3(config-if)#end

Après cette étape, toutes les interfaces doivent passer à l'état UP. Assurez-vous qu'elles le sont
avant de passer à la section suivante.

CONFIGURATION DU PROTOCOLE
IGRP
La configuration de IGRP sur un routeur Cisco est semblable au protocole RIP (RIPv1),
d'ailleurs si vous l'avez remarqué on a repris le même schéma ci-dessus.
Les deux commandes principales sont:

(config)#router igrp [sys_auto]


(config-router)#network [@réseau]

La première permet d'activer le routage IGRP dans le système autonome spécifié ( un


nombre entier, par exemple 150). La seconde associe un réseau au routage IGRP. En général
on associe tous les réseaux qui sont directement connectés au Routeur en question.
Supposons pour la suite que tous les routeurs sur le schéma se trouvent dans le même système
autonome 150.
Il ne reste plus qu'à taper les commandes suivantes sur les trois Routeurs pour configurer le
protocole IGRP dans votre réseau:

 Routeur 1

Il y'a trois réseaux qui sont directement liés au Routeur 1, ce sont: 172.16.0.0, 192.168.12.0 et
192.168.13.0

Routeur1(config)#router igrp 150


Routeur1(config-router)#network 172.16.0.0
Routeur1(config-router)#network 192.168.12.0
Routeur1(config-router)#network 192.168.13.0
Routeur1(config-router)#end
Routeur1#wr

 Routeur 2

Les réseaux qui sont directement connectés au routeur 2 sont: 192.168.12.0 et 192.168.23.0.

Routeur2(config)#router igrp 150


Routeur2(config-router)#network 192.168.12.0
Routeur2(config-router)#network 192.168.23.0
Routeur2(config-router)#end
Routeur2#wr

 Routeur 3

Les réseaux qui sont directement connectés au routeur 3 sont: 172.17.0.0, 192.168.13.0 et
192.168.23.0.

Routeur3(config)#router igrp 150


Routeur3(config-router)#network 172.17.0.0
Routeur3(config-router)#network 192.168.13.0
Routeur3(config-router)#network 192.168.23.0
Routeur3(config-router)#end
Routeur3#wr

A l'issue de cette étape, le protocole IGRP sera complètement opérationnel dans votre réseau
et vous pouvez vous en apercevoir en utilisant quelques commandes spéciales de vérification
telles que "Show ip route", "Traceroute" ou même un PING entre deux équipements qui ne se
trouvent pas dans le même réseau.
Nous n'allons pas analyser ces résultats ici, je vous laisse le soin de consulter Ce Tuto pour
refaire la même chose car les schémas sont identiques.
Notez seulement qu'à la sortie de la commande show ip route, les routes configurées en IGRP
seront précédées de la lettre I.