Vous êtes sur la page 1sur 30

Département Télécommunications, Réseaux & Informatique (TRI)

ENSA
ECOLE NATIONALE DES
SCIENCES APPLIQUEES D’EL JADIDA

DEPARTEMENT
TELECOMMUNICATIONS,
RESEAUX & INFORMATIQUE

Module: Commutation réseaux & Routage avancé

Cours 3 : Routage RIP

Prof. A. Dahbi
1 ère année (ISIC)
2018-2019
1
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Routage RIP : Introduction

• Il est créé pour être utilisé dans de petits réseaux.


Département Télécommunications, Réseaux & Informatique (TRI)

• Utilise un algorithme de type vecteur de distances : échange périodique des


tables de routage entre les voisins (Chaque réseau de destination est un
vecteur avec une métrique vers un voisin et une direction donnée.)

• La seule mesure qu’il utilise pour le choix du chemin d’accès est le nombre
de sauts (nombre de routeurs traversés)

• Les destinations avec des routes dont le nombre de sauts est supérieur à
15 sont inaccessibles.

• Chaque entrée dans la table de routage apprise par RIP a une distance
administrative par défaut de 120.

• Un réseau directement connecté a une métrique de 0.

2
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Fonctionnement de RIP

Exemple
ENSAJ - Département de Télécommunications

• si on déclare une interface E0 avec l'adresse 10.0.0.1/8 et une interface


S0 avec l'adresse 11.0.0.1/8, vous aurez dans la table de routage :
– 10.0.0.0 via Eth0 (10.0.0.1) - Coût = 0 - Connected
– 11.0.0.0 via Ser0 (11.0.0.1) - Coût = 0 - Connected

• Ceci indique que les réseaux 10.0.0.0 et 11.0.0.0 sont respectivement


accessibles par les interfaces E0 et S0 où ils sont directement connectés.
Le coût de la route est donc = 0 !

3
Pr. A. Dahbi Cours : Réseaux 3 – Routage avancé
Fonctionnement de RIP

• Exemple
ENSAJ - Département de Télécommunications

• Chaque routeur commence par émettre des updates RIP sur toutes ses
interfaces. Ces updates contenaient la totalité de leur table de routage, sauf
le réseau sur lequel est émis l'update. (inutile d'indiquer le réseau 10.0.0.0
aux routeurs qui sont sur ce réseau )

• Pour chaque réseau annoncé, le routeur associe, dans l'update, la valeur


de métrique qu'il a dans sa table de routage.

4
Pr. A. Dahbi Cours : Réseaux 3 – Routage avancé
Fonctionnement de RIP

Le routeur qui traite l'update examine chaque entrée comme suit:


Département Télécommunications, Réseaux & Informatique (TRI)

5
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Traitement d’un exemple RIP
Département Télécommunications, Réseaux & Informatique (TRI)

Phase 1 : Configuration
• Soit le réseau ci-aprés composé des
routeurs R1, R2, R3 et R4 interconnectant
les réseaux IP 10.0.0.0 à 13.0.0.0.
• Programmer sur chacune des interfaces
les adresses IP et les masques associés.
• Au départ, les routeurs connaissent les
réseaux qui leurs sont directement
raccordés

Phase 2 : Activation de RIP


• Activation du process RIP au niveau de
chaque routeur.
• au plus tard dans les 30s chaque routeur
émet un premier update.

6
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Traitement d’un exemple RIP
Département Télécommunications, Réseaux & Informatique (TRI)

Le schéma ci-contre présente le contenu


des updates.
• les updates contiennent la table de routage
de chaque routeur.
• Chaque entrée est constituée de l‘@réseau
annoncée et d'un coût associé.
• les updates sont émis sur toutes les
interfaces de chaque routeur
• le numéro du réseau sur lequel est émis
l'update n'est pas inscrit dans l'update. Par
exemple sur l’interface E1 du routeur R1, le
réseau 11.0.0.0 n’est pas émis

7
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Traitement d’un exemple RIP
Département Télécommunications, Réseaux & Informatique (TRI)

Phase 3 : 1ère maj des TR


• Chaque routeur examine les updates reçus. Il incrémente de 1 les coûts annoncés.

• Tous les routeurs ajoutent dans leurs tables les destinations qui ne leurs sont pas
encore connues.

• Si une entrée est déjà connue, le routeur compare le coût annoncé et l'adresse de
l'émetteur de l'update :

– Si même next-hop que l'adresse de l'émetteur, l’entrée est remplacée avec celle
de l’update (après avoir incrémenté de 1 le coût indiqué dans l'update) :
– Sinon, si le coût de l'update est inférieur à celui de la TR (après avoir incrémenté
de 1 le coût indiqué dans l'update), l'entrée de l'update remplace celle de la table.
– si le coût est identique, l'update est ajouté (équilibrage de charge)
– si le coût est supérieure, l'update est ignorée

8
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Traitement d’un exemple RIP

R1
Des Pass Métrique
Le schéma ci-contre illustre le contenu des 10.0.0.0 C 0
Département Télécommunications, Réseaux & Informatique (TRI)

TR’s après traitement du 1er update par les 11.0.0.0 C 0


routeurs (t0 + 30s). 12.0.0.0 11.0.0.2 1
11.0.0.3 1
• R1 a reçu deux annonces pour 12.0.0.0, une
R2
de la part de R2 et une autre de R3. RIP Des Pass Métrique
installe les deux 11.0.0.0 C 0
12.0.0.0 C 0
10.0.0.0 11.0.0.1 1
• Il en est de même pour R4 vis à vis de 13.0.0.0 12.0.0.3 1
l'annonce simultanée de 11.0.0.0 par R2 et R3
R3. Des Pass Métrique
11.0.0.0 C 0
12.0.0.0 C 0
• A noter également que R2 reçoit, par son 10.0.0.0 11.0.0.1 1
13.0.0.0 12.0.0.3 1
interface E1, une annonce de R3 pour le
R4
réseau 11.0.0.0, R2 l'ignore puisqu'il a accès à Des Pass Métrique
ce réseau directement par E0. 12.0.0.0 C 0
13.0.0.0 C 0
11.0.0.0 12.0.0.1 1
A remarquer que R1 ne connaît tjrs pas le réseau 12.0.0.2 1
13.0.0.0 et que R4 ne connaît pas 10.0.0.0. Il va
falloir attendre le prochain update !

9
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Traitement d’un exemple : RIP
R1
Des Pass Métrique
10.0.0.0 C 0
11.0.0.0 C 0
Département Télécommunications, Réseaux & Informatique (TRI)

Phase 4 : 2ème mise à jour de table (t0 + 60s) 12.0.0.0 11.0.0.2 1


11.0.0.3 1
13.0.0.0 11.0.0.2 2
• Dans le schéma suivant, chaque routeur 11.0.0.3 2
ajoute les entrées qui lui sont inconnues et R2
ignore les entrées présentant un coût Des Pass Métrique
supérieur ou égal. 11.0.0.0 C 0
12.0.0.0 C 0
10.0.0.0 11.0.0.1 1
Après ce traitement : 13.0.0.0 12.0.0.3 1

• les tables de R2 et R3 n'ont pas été modifiée, R3


Des Pass Métrique
elles avaient déjà toutes les informations
11.0.0.0 C 0
nécessaires 12.0.0.0 C 0
10.0.0.0 11.0.0.1 1
• R1 a appris la route pour 13.0.0.0 (via R2 et 13.0.0.0 12.0.0.3 1

R3) et R4 a appris la route pour 10.0.0.0 (via R4


Des Pass Métrique
R2 et R3 également).
12.0.0.0 C 0
13.0.0.0 C 0
• Enfin, tous les réseaux sont connus par tous 11.0.0.0 12.0.0.1 1
les routeurs ! 12.0.0.2 1
10.0.0.0 12.0.0.1 2
12.0.0.2 2
10
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Les mises à jours

(Minuteur de mise à jour)


Département Télécommunications, Réseaux & Informatique (TRI)

11
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Mise à jour déclenchée
Département Télécommunications, Réseaux & Informatique (TRI)

• Si une route est inaccessible, une mise à jour est envoyée immédiatement
aux voisins. cette solution assure que tous les routeurs ont la
connaissance des routes inaccessibles avant l’expiration du minuteur de
mise à jour.

• Cette solution permet d’améliorer le temps de convergence.

12
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
RIPv2 : améliorations par rapport à RIPv1
Département Télécommunications, Réseaux & Informatique (TRI)

• RIP-v1 est un protocole classfull  ne peut pas gérer des routes pour
des sous-réseaux à VLSM.

• RIP-v2 est un protocole classless  peut gérer des routes pour des
sous-réseaux à VLSM.

• RIP-V2 peut fonctionner en mode broadcast (compatible avec RIP-v1)


et en mode multicast ! (Adresse de multicast : 224.0.0.9 pour les
routeurs RIP)

• Authentification par mot de passe (Sécurisation des échanges entres


les routeurs)

13
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Configuration du protocole RIP
Département Télécommunications, Réseaux & Informatique (TRI)

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.13.0

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 192.168.14.0
R2(config-router)#network 192.168.13.0

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 192.168.14.0
R3(config-router)#network 172.31.0.0
14
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Vérification de la configuration RIP
Département Télécommunications, Réseaux & Informatique (TRI)

15
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Exercice

Etant donnée la topologie du réseau ci-dessous. Tous les routeurs utilisent


le protocole RIP
Département Télécommunications, Réseaux & Informatique (TRI)

Res
B

Etat initial (routeur A) Dest R M


A Direct 0

1. Donner la table des autres routeur à l’état initial

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Etat initial
Département Télécommunications, Réseaux & Informatique (TRI)

A Dest R M B Dest R M C Dest R M


A Direct 0 B Direct 0 C Direct 0

D Dest R M
D Direct 0

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Update 1
Département Télécommunications, Réseaux & Informatique (TRI)

2. Donner la table de routage des différents routeur

Update 2

3. Donner la table de routage des différents routeur

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Update 1
Département Télécommunications, Réseaux & Informatique (TRI)

A Dest R M B Dest R M C Dest R M


A Direct 0 B Direct 0 C Direct 0
A A 1

D Dest R M
D Direct 0
A A 1

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Update 2
Département Télécommunications, Réseaux & Informatique (TRI)

A Dest R M B Dest R M C Dest R M


A Direct 0 B Direct 0 C Direct 0
B B 1 A A 1 D D 1
D D 1 A D 2

D Dest R M
D Direct 0
A A 1

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Update 3
Département Télécommunications, Réseaux & Informatique (TRI)

4. Donner la table de routage des différents routeur

Update 4 Update 5

5. Donner la table de routage des différents routeur


Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Update 3
Département Télécommunications, Réseaux & Informatique (TRI)

A Dest R M B Dest R M C Dest R M


A Direct 0 B Direct 0 C Direct 0
B B 1 A A 1 D D 1
D D 1 D A 2 A D 2

D Dest R M
D Direct 0
A A 1
B A 2
C C 1

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Update 4
A

A Dest R M B Dest R M C Dest R M


Département Télécommunications, Réseaux & Informatique (TRI)

A Direct 0 B Direct 0 C Direct 0


B B 1 A A 1 D D 1
D D 1 D A 2 A D 2
A B 2
B B 1

D Dest R M
D Direct 0
A A 1
B A 2
B C 2
C C 1

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Update 5
A

A Dest R M B Dest R M C Dest R M


Département Télécommunications, Réseaux & Informatique (TRI)

A Direct 0 B Direct 0 C Direct 0


B B 1 A A 1 D D 1
D D 1 D A 2 A D 2
C D 2 D C 2 A B 2
C B 2 C C 1 B B 1

D Dest R M
D Direct 0
A A 1
B A 2
B C 2
C C 1
Conclusion :
- Le réseau converge lorsque tous les routeurs ont construit des tables de
routage homogènes
- Le temps de convergence dépond de la taille du réseau
- RIP utilise l’équilibrage de charge

Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP


Annexe

Algorithme d’envoi de routes


Département Télécommunications, Réseaux & Informatique (TRI)

25
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Annexe

Règle 1 : Réseaux discontinus


Département Télécommunications, Réseaux & Informatique (TRI)

26
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Annexe

Résumé de route
Département Télécommunications, Réseaux & Informatique (TRI)

27
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Annexe
Réseaux discontinus
Département Télécommunications, Réseaux & Informatique (TRI)

28
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP
Département Télécommunications, Réseaux & Informatique (TRI)
Annexe

Pr. A. Dahbi : dahbi_aziz@yahoo.fr


Routage RIP
29
Annexe
Illustration de la règle 2
Département Télécommunications, Réseaux & Informatique (TRI)

30
Pr. A. Dahbi : dahbi_aziz@yahoo.fr Routage RIP

Vous aimerez peut-être aussi