Vous êtes sur la page 1sur 4

Le collaborateur doit effectuer 41heures par semaine, soit 8:12 par jour ou au format décimal 8.

2
nombre
On veut une colonne à droite du total par jour qui indique si on a effectué plus ou moins que les heures imposées d'heures 8:12 (format horaire)
Et on veut le total positif ou négatif pour le mois soit 8.2 (format décimal - simple division de 41 p

Excel joue à la pointeuse ….. 00:03:00


matin après-midi spécial =SI(J7=0;"";SI(J7>$L$2;J7
Total + ou - par en format
Planning mensuel Départ Fin Départ Fin Départ Fin
heures rapport 8:12 décimal 1er SI : si le nombre décim
Friday - 01 Jan 2010 8:00 12:00 13:00 17:15 8:15 00:03:00 0.05 alors le résultat est systém
#ADDIN? 7:00 12:00 14:30 15:42 6:12 02:00:00 -2 soit 8:12 - 0:00
#ADDIN? 0:00
#ADDIN? 0:00 2ème SI : on teste si le tota
#ADDIN? 7:15 11:45 14:00 16:15 6:45 01:27:00 -1.45 et on calcule la différence.
#ADDIN? 7:00 12:00 12:30 18:15 10:45 02:33:00 2.55 Format horaire = simple pr
#ADDIN? 7:00 12:00 12:00 22:00 15:00 06:48:00 6.8 ==>
#ADDIN? 0:00
#ADDIN? 0:00
#ADDIN? 0:00 COULEUR = format cond
#ADDIN? 0:00
#ADDIN? 0:00
#ADDIN? 0:00
#ADDIN? 0:00
#ADDIN? 0:00
#ADDIN? 0:00 Le format conditionnel test
#ADDIN? 0:00 Si celui-ci est au-dessous d
#ADDIN? 0:00 Si celui-ci est au-dessus de
#ADDIN? 0:00
#ADDIN? 0:00 L'horrible longue formule
#ADDIN? 0:00 0.05
#ADDIN? 0:00 =SI(ESTERREUR(SI(J7>$
#ADDIN? 0:00 Il faut convertir le résultat h
#ADDIN? 0:00
#ADDIN? 0:00 SI(J7>$M$2;(HEURE(L7)*
#ADDIN? 0:00 Si total horaire sup à 8:12 a
#ADDIN? 0:00
#ADDIN? 0:00 Le hic visuel comme d'hab
#ADDIN? 0:00 Donc l'immense ESTERRE
#ADDIN? 0:00
#ADDIN? 0:00 Le total pouvant être tantôt
5.95 positif et rouge-gras en nég
Total
mensuel 46:57 ###
05:57:00 AM
Tous les problèmes viennent du fait qu'il est impossible d'afficher ou même de travailler avec des heures négatives : on obtient que des ######### De nouveau, le résultat déc
Mais le format décimal n'est pas évident à lire et à comprendre : donc il faut calculer en décimal et afficher en format horaire …. Si le total est positif : OK n
Si le total est négatif : des
Convertir un format horaire en nombre décimal
Voici donc la formule : =(S
Trouvé sur Internet deux solutions : une de Microsoft et une autre de quelqu'un sur un forum Si le total est positif alors c
Cela ne met pas le - devan

Microsoft :

Forum : 01:27:00 en décimal 1.45 =(HEURE(A58)*60+MINUTE(A58))/60


Je préfère celle-là …

Convertir un format décimal en format horaire

Diviser par 24 et passer en format horaire 7.5 ###


Attention pour les minutes, il faut diviser par 60 …. !
cimal - simple division de 41 par 5)

=SI(J7=0;"";SI(J7>$L$2;J7-$L$2;$L$2-J7))

1er SI : si le nombre décimal = 0 alors vide. Si on ne prévoit pas cela


alors le résultat est systématiquement 8:12:00 car du coup c'est la condition 2 qui est réalisée
soit 8:12 - 0:00

2ème SI : on teste si le total journalier est supérieur à 8:12 ou non


et on calcule la différence. Attention, on ne peut pas afficher un résultat horaire NEGATIF
Format horaire = simple préférence d'affichage
on obtient un résultat horaire mais celui-ci ne fait
donc pas la différence entre un résultat positif ou négatif

COULEUR = format conditionnel

Le format conditionnel teste le total HORAIRE journalier


Si celui-ci est au-dessous de 8:12, le résultat aurait dû être négatif
Si celui-ci est au-dessus de 8:12, le résultat est réellement positif

L'horrible longue formule !

=SI(ESTERREUR(SI(J7>$M$2;(HEURE(L7)*60+MINUTE(L7))/60;-(HEURE(L7)*60+MINUTE(L7))/60));"";SI(J7>$M$2;(HEURE(L7)*60+MINUTE(L7))/60;-(HEURE(L7)*60+MINUTE(L7))/60))
Il faut convertir le résultat horaire en une valeur décimal positive pour les cellules bleues et négative pour les rouges !!!!

-
SI(J7>$M$2;(HEURE(L7)*60+MINUTE(L7))/60; (HEURE(L7)*60+MINUTE(L7))/60)
Si total horaire sup à 8:12 alors convertir le résultat horaire bleu en décimal positif, sinon le convertir aussi mais mettre un moins devant

Le hic visuel comme d'hab avec ce genre de formule, c'est que dessous lorsque le calcul n'était pas encore fait, on obtenait une valeur d'erreur - moche
Donc l'immense ESTERREUR reprend simplement toute le calcul, le teste en erreur et ne met rien si la condition est remplie

Le total pouvant être tantôt positif ou négatif : donc format conditionnel pour bleu-gras en
positif et rouge-gras en négatif

De nouveau, le résultat décimal général au-dessus est souhaité en format horaire, plus parlant.
Si le total est positif : OK no problem
Si le total est négatif : des #### puisque l'on ne peut pas afficher de format horaire négatif !

Voici donc la formule : =(SI(M38>0;M38/24;ABS(M38/24)))


Si le total est positif alors conversion traditionnelle au format horaire - sinon (donc négatif) idem mais en valeur absolue
Cela ne met pas le - devant mais au moins on obtient un résultat AFFICHE et pas des ### ! Et on sait si c'est pos-neg par la couleur du total au-dessus