Vous êtes sur la page 1sur 16

Life Connecting…

CONFIGURATION RÉSEAU - 4
QoS & ToS sur MiKroTik

WIICOM SARL
QoS & ToS

Sommaire
1 Introduction..............................................................................................................................2

2 Conditions préalables à la configuration.................................................................................2

2.1 Identification et priorisation du trafic selon l’IUT............................................................3

2.2 Identifier le trafic SIP........................................................................................................4

2.2.1 Marquer les connexions SIP......................................................................................4

2.2.2 Marquer les paquets SIP............................................................................................5

2.3 Identifier le trafic RTP......................................................................................................6

2.3.1 Marquer les connexions RTP.....................................................................................6

2.3.2 Marquer les paquets RTP...........................................................................................7

2.4 Vérification des règles de marquage.................................................................................9

3 Classification des Types de Services (ToS).............................................................................9

4 Réglage de la Bande Passante................................................................................................10

4.1 Comment régler la BP d’une interface ?.........................................................................10

4.1.1 Cas du trafic RTP 440k............................................................................................11

4.1.2 Cas du trafic SIP à 325k..........................................................................................11

4.1.3 Cas du trafic INCONNU à 3M................................................................................11

4.1.4 Vérification des règles.............................................................................................12

4.2 Objectif du besoin en QoS..............................................................................................13

4.3 Finalité............................................................................................................................13

5 Région de Yaoundé................................................................................................................14

5.1 8.1 Réseau Téléphonique & Connectique.......................................................................14

6 Conclusion.............................................................................................................................15

1
QoS & ToS

1 Introduction
Ce quatrième volet du document consacré à la configuration du réseau
"téléphonique" et "connectique" de WIICOM SARL se focalise sur les aspects non
évoqués depuis la première partie de la configuration MPLS. En effet dans le présent
document il est question après avoir évoqué les questions de VLAN et de MPLS-TE, de
s’étendre sur les notions de QoS (Qualité de Service).
Avant toute configurations efficaces des routeurs, nous commencerons par :
 Nous rassurer que toutes les configurations précédentes sont bien archivées,
 Identifier les différents types de trafics auxquels s’intéresser selon SIP et RTP,
 Définir une priorisation de ces différents trafics pour le réseau client de WiiCom
suivant les recommandations de l’UIT (Union International des
Télécommunications),
 Marquer et catégoriser ces paquets de trafic,
 Procéder à des configurations appropriées du réseau Téléphone et Connectique.

2 Conditions préalables à la configuration


Dans les précédents documents nous avons vu comment sauvegarder les
configurations de nos routeurs. Désormais il est question de vérifier la config QoS qui est
dans le routeur avant toute manipulation. Voici la commande :

/ip firewall mangle


Print (pour afficher)
Remove [find] (pour formater l’existant QoS)
Test de Bande Passante:

Tool bandwidth-test address=a.b.c.d protocol=tcp direction=both


Tool bandwidth-test address= a.b.c.d protocol=udp direction=both

2
QoS & ToS

2.1 Identification et priorisation du trafic selon l’IUT


Ceci est la table QoS selon l’IUT :

Voici par exemple les temps de réponses exigés par l’IUT pour la VoIP :

3
QoS & ToS
Voici comment changer une priorité 0 en priorité 7:
/ip firewall mangle
set 0 new-priority=7

Voici comment ajouter les priorités 3 en priorité 6:


/ip firewall mangle
add action=set-priority chain=output new-priority=3
protocol=udp
add action=set-priority chain=output new-priority=6
protocol=tcp

Mettre le Serveur VoIP en 2e priorité dans le Firewall:

/ip firewall mangle


chain=prerouting action=set-priority newpriority=6 src-address="VoIP-SRV"

 Affecter l'interface d'entrée du Routeur vers le Serveru VoIP:

/interface bridge filter


chain=forward action=set-priority new-priority=from-ingress

 Ainsi que l'interface de sortie vers les utilisateurs:

/interface bridge filter


chain=forward action=set-priority new-priority=from-ingress

2.2 Identifier le trafic SIP


2.2.1 Marquer les connexions SIP
Voici la commande :

4
QoS & ToS
/ip firewall mangle
Add chain=forward dst-address=1.2.3.4
protocol=tcp dst-port=5060 action=markconnection
new-connection-mark=sipconnection

Résultat :

2.2.2 Marquer les paquets SIP


Voici la commande :
/ip firewall mangle
Add chain=forward
connection-mark=sip-connection
add action=mark-packet
new-packet-mark=SIP

5
QoS & ToS
Résultat :

2.3

Identifier le trafic RTP


2.3.1 Marquer les connexions RTP
Voici la commande :
/ip firewall mangle
Add action=mark-connection chain=forward dstaddress=1.2.3.4
New-connection-mark=rtpconnection
Port=10000-20000 protocol=udp

6
QoS & ToS
Résultat :

2.3.2 Marquer les paquets RTP


Voici la commande :
/ipfirewall mangle
Add action=mark-packet chain=forward

7
QoS & ToS
Connection-mark=rtp-connection new-packetmark=RTP
Résultat :

2.4 Vérification des règles de marquage

8
QoS & ToS
Après avoir marqué les trafics SIP et RTP qui sont les priorités d’un réseau MPLS en
termes de QoS, voici comment vérifier que ce qui a été précédemment configuré
marche :

3 Classification des Types de Services (ToS)


Après avoir fait le préalable ci-dessus pour la QoS du MPLS, il est maintenant
question d’identifier les Types de Services de ce réseau opérateur. L’IUT reconnait les
ToS selon le protocole DSCP. Par exemple la valeur décimale du DSCP est 46 pour la
VoIP.

Voici le Tableau utilisé pour attribuer un niveau de priorité au trafic réseau suivant la

ToS :

9
QoS & ToS
Voici comment changer le DSCP d’un ToS :

4 Réglage de la Bande Passante


4.1 Comment régler la BP d’une interface ?
A l’aide du menu Queue nous allons pouvoir
approfondir ce qui précède en montrant comment
limiter le débit d’une interface de service à fin de
garantir QoS ainsi définie.

Voici la commande pour une Inteface WAN


(Ether1), Gatway :

/queue tree
Add limit-at=4M max-limit=4M
name=upload
parent=ether1-gateway
priority=1 queue=default

10
QoS & ToS
4.1.1 Cas du trafic RTP 440k
/queue tree
Add limit-at=440k
max-limit=440k
name=upload_pri_1
packet-mark=RTP
parent=upload
priority=1
queue=default

4.1.2 Cas du trafic SIP à 325k


/queue tree
Add limit-at=325k
max-limit=325k
name=upload_pri_2
packet-mark=SIP
parent=upload
priority=2
queue=default

4.1.3 Cas du trafic INCONNU à 3M


/queue tree
Add limit-at=3M
max-limit=3M
name=upload_pri_2
packet-mark=no mark
parent=upload
priority=8
queue=default

11
QoS & ToS
4.1.4 Vérification des règles
Il faut simplement activer l’onglet “Dropped” de « Show Columns » Dans le menu

‘Queue’

Résultat :

12
QoS & ToS

4.2 Objectif du besoin en QoS

4.3 Finalité

13
QoS & ToS

5 Région de Yaoundé
5.1 8.1 Réseau Téléphonique & Connectique
Etant donné que les configurations QoS & ToS sont identiques à tous le réseau
opérateur WiiCom pour un souci de qualité linéaire et dans le respect des protocoles de
l’IUT ; les étapes suivantes seront respectées dans tous les Routeurs du Backbone de
WiiCom (P et PE), ainsi que chez certains de nos clients qui disposent de CE :

Nb1: Vérifier la table QoS en place et la vider si nécessaire ;

Etape 1: Marquer la connexion SIP ;

Etape 2: Marquer les paquets SIP ;

Etape 3: Marquer la connexion RTP ;

Etape 4: Marquer les paquets RTP ;

Nb2: Vérifier les règles de marquage ;

Nb3: Vérifier la table ToS à l’aide du protocole DSCP ;

Etape 5: Sinon activer le DSCP/ToS ;

Etape 6: Configurer la bande passante WAN, SIP, RTP et du trafic INCONNU ;

Etape 7: Activer l’onglet ‘Dropped’ ;

Nb4: Vérifier toutes les règles dans l’onglet Dropped ;

14
QoS & ToS

6 Conclusion
Ce document avait pour objectif de présenter la manière recommandée par l’IUT
pour la mise en place de la QoS/ToS dans un réseau opérateur. Les étapes ci-dessus
décrites doivent être scrupuleusement respectées à fin d’avoir une uniformité de la qualité
dans tout le système. Le prochain document va s’appesantir sur la notion de sécurité dans
le réseau MPLS de WiiCom, suivant une politique qui sera ultérieurement définie pour
l’ensemble, ainsi que l’Intranet.

15