Vous êtes sur la page 1sur 1

U NIVERSIT É DE G HARDA ÏA M ÉTHODES NUM ÉRIQUES

FACULT É DES S CIENCES ET T ECHNOLOGIE 2eme G ÉNIE E LEC .


D ÉPARTEMENT DES S CIENCES ET T ECHNIQUES 2014-2015

TP – 06 Interpolation polynômiale (Lagrange)

But du TP tel que :


Implémentation d’un code Matlab n
x − xj
pour trouver l’unique polynôme d’in-
terpolation de degrés n − 1 qui passe
Li ( x ) = ∏ xi − x j
j =1
par n points donnés par la méthode de j 6 =i
Lagrange.
En utilisant les expressions symbo-
1. Préambule liques sous Matlab, on obtient le po-
lynôme d’interpolation en suivant l’al-
Soit l’ensemble des coordonnées
gorithme suivant :
des points suivants :
Lire x, y
syms t, L, p
x 1 6 4 3 2 5
p←0
y 1 1 3 4 1 5 pour i = 1 → n faire
Li ← 1
pour j = 1 → n faire
a. Trouver l’unique polynôme de si j 6= i alors
degrés cinq qui passe par les six t − xj
points précédents en utilisant la Li ← Li ×
xi − x j
fonction polyfit de Matlab. fin si
b. Dessiner le graphe du polynôme ob- fin pour
tenu en utilisant plot et polyfit et p ← p + Li × yi
s’assuser qu’il passe par les points fin pour
donnés. afficher p

a. Dessiner le graphe du polynôme ob-


2. Méthode de Lagrange tenu et s’assurer qu’il passe par les
points donnés.
L’unique polynôme de degrés n − 1
b. Comparer le polynôme obtenu avec
qui passe par les n points est donné par :
le polynôme obtenu par polyfit.
n c. Dessiner sur le même graphe les
p( x ) = ∑ Li ( x ) yi deux polynômes et s’assurer qu’il se
superposent parfaitement.
i =1

Page 1/1 H. Bouderba