Vous êtes sur la page 1sur 11

ESGIS – Master1 SRS CCNP ROUTE 2019

EIGRP FC, FS, LOAD BALANCING,


SUMMARIZATION, AUTHENTICATION

NB : ce TP est réalisé sur le simulateur Eve-ng.

PARTIE 1 : Le Processus DUAL (10 pts)

Question 1 : Calcul du métrique EIGRP (03 pts)

Pour voir les coefficients utilisés, faire : show ip eigrp 100


K1=1, K2=0, K3=1, K4=0, K5=0
Quelle est la formule usuelle ?

Soit la topologie ci-dessous :

M. DOMAN 1|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

Calculez la valeur du métrique eigrp pour


atteindre le réseau 192.168.1.0/24

Question 2 : Successor, Feasible Successor, FC, FD, AD (04 pts)


Définissez les termes suivants :

Advertised Distance: ……………………………………………………………………..

…………………………….………………………………………………………………

……………………………….……………………………………………………………

Feasible Distance: ……..……..…………………………………………………………..

…………………………….………………………………………………………………

……………………………….……………………………………………………………

Successor: ………………………………………………………………………………..

…………………………….………………………………………………………………

……………………………….……………………………………………………………

Feasiblility Condition: …..…………………………...…………………………………..

…………………………….………………………………………………………………

M. DOMAN 2|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

……………………………….……………………………………………………………

Feasible Successor: ………..……………………………………………………………..

…………………………….………………………………………………………………

……………………………….……………………………………………………………

Question 3 : Détermination des routes eigrp (03 pts)

On vous propose le réseau eigrp ci-dessus. Remplissez correctement le tableau proposé

pour le calcul effectué par R1 s’il veut joindre le réseau 10.1.1.0/24.

Neighbor AD ou RD FD Successor ? FS ?

M. DOMAN 3|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

PARTIE 2 : Configuration Eigrp (10 pts)

Question 4 : Topologie (05 pts)

Réalisez la topologie sur le simulateur Eve-ng, adressez les équipements

convenablement et faites les tests de connectivité de proche en proche.

Question 5 : commandes basiques (02 pts)


Sur R1, effectuez les commandes suivantes :

router eigrp 111


no auto-summary
network 192.168.1.0 0.0.0.255
network 192.168.2.0 0.0.0.255
network 10.1.1.0 0.0.0.0

Listez les commandes pour les autres routeurs dans le tableau

M. DOMAN 4|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

R2 R3 R4
router eigrp …………….. router eigrp …………….. router eigrp ……………..
no auto-summary no auto-summary no auto-summary
network 192.168.2.0 network …………………. network ………………….
network …………………. network …………………. network ………………….
network …………………. network …………………. network ………………….

Question 6: commandes de vérification (03 pts)


Pour consulter la table de routage des routeurs, faites : show ip route ou show ip route
eigrp. Que signifient les valeurs entre crochets ?
……………………………………………………………………………………………

……………………………………………………………………………………………

Pour consulter la base de données de voisinage, faites : show ip eigrp neighbors.


Pour consulter la base de données topologique, faites : show ip eigrp topology.
Effectuez la dernière commande sur R2. Quelle remarque faites-vous pour le réseau
10.10.10.0/24 ?
……………………………………………………………………………………………

……………………………………………………………………………………………

……………………………………………………………………………………………

Qui est le successor pour cette route ? …………………………………………………

Qui est le feasible successor ? ………………………………………………………….

PARTIE 3: Load Balancing (10 pts)

Question 7 : Unequal load balancing (06 pts)


Le calcul de la variance :

Sur R2 effectuez la commande show ip eigrp topology et regardez à nouveau les


données pour le réseau 10.10.10.0/24. Divisez la valeur de distance proposée par R3

M. DOMAN 5|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

par la FD. Vous arrondissez à l’entier supérieur vous obtenez ainsi la valeur de la
variance.
𝐷𝑖𝑠𝑡𝑎𝑛𝑐𝑒 𝑎𝑛𝑜𝑟𝑚𝑎𝑙𝑒
𝑣𝑎𝑟𝑖𝑎𝑛𝑐𝑒 = = =
𝐹𝑒𝑎𝑠𝑖𝑏𝑙𝑒 𝐷𝑖𝑎𝑠𝑡𝑎𝑛𝑐𝑒

Allez sur R2 et configurez la variance pour que la route secondaire soit injectée dans la

table de routage :

Router eigrp 111


Variance …….
End

Sur R2 faites à nouveau show ip route eigrp. Que remarquez-vous concernant le réseau

10.10.10.0/24 ? …………………………………………………………………………..

……………………………………………………………………………………………

……………………………………………………………………………………………

La variance permet de faire le load balancing pour les routes qui ne devraient pas

figurer dans la table de routage. Sur R2 faites traceroute 10.10.10.2

Resultat ? ……………………………………………………………………………….

…………………………………………………………………………………………..

…………………………………………………………………………………………..

Question 8 : Equal load balancing (04 pts)


Sur R2 supprimez la variance. Allez sur l’interface série s1/0 mettez la bande passante

à 512 Mbps. Faites show ip route eigrp. Que remarquez-vous concernant le réseau

10.10.10.0/24 ? …………………………………………………………………………..

……………………………………………………………………………………………

M. DOMAN 6|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

PARTIE 4 : Configuration du Summary (10 pts)

Question 9: topologie pour le résumé des routes (04 pts)


Réalisez la topologie sur le simulateur Eve-ng.

Configurez le routage eigrp sur les routeurs. Système Autonome (AS) a le numéro 11.

Question 10: calcul pour le résumé des routes (03 pts)


Faites le calcul nécessaire pour résumer les routes suivantes : 172.16.0.0/24,

172.16.1.0/24, 172.16.2.0/24 et 172.16.3.0/24 en travaillant sur le 3e octet.

Quel est le nombre de bits réseau ? …………………..………….

Quel est le nouveau masque ? ……………………..…………….

Quelle est l’adresse du résumé ? ………………..……………….

Faites le même calcul pour les réseaux : 10.1.1.0/30, 10.1.1.4/30, 10.1.1.8/30 et

10.1.1.12/30. Sur quel octet allez-vous résumer ? ……………………………..

M. DOMAN 7|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

Quel est le nombre de bits réseau ? …………………..………….

Quel est le nouveau masque ? ……………………..…………….

Quelle est l’adresse du résumé ? ………………..……………….

Question 11 : Configuration du résumé des routes (03 pts)


En résumant les routes, vous voulez alléger la table de routage transmise à R6 par R5.

Donc le résumé se fera sur l’interface de sortie de R5 vers R6 (s1/0)

interface s1/0
ip summary-address eigrp 11 172.16……….0 255.255……...0

Sur R5, faites : show ip protocols eigrp 11

Sur R5, faites : show ip route eigrp. Remarques ? ………………………………………

……………………………………………………………………………………………

……………………………………………………………………………………………

Configurez le résumé pour les réseaux 10.1.1.x/30. Listez vos commandes :

……………………………………………………………………………………………

……………………………………………………………………………………………

M. DOMAN 8|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

PARTIE 5 : Filtrage de route et authentification (10 pts)


Reprenez la topologie du TP précédent. Supprimez les résumés effectués sur le réseau
172. et le réseau 10.

Question 12 : Filtrage des routes avec ACL (03 pts)


Sur R5, on veut filtrer le réseau 172.16.3.0/24 de la base de données Eigrp :

access-list 1 deny 172.16.3.0 0.0.0.255


access-list 1 permit any
router eigrp 11
distribute-list 1 in
exit

Regardez dans la base de données Eigrp de R5, que constatez-vous ?

……………………………………………………………………………………………

……………………………………………………………………………………………

Regardez dans la table de routage de R5, que constatez-vous ?

……………………………………………………………………………………………

……………………………………………………………………………………………

M. DOMAN 9|Page
ESGIS – Master1 SRS CCNP ROUTE 2019

Question 13 : Filtrage des routes avec Prefix-List (02 pts)


Sur R5, on veut filtrer le réseau 172.16.3.0/24 de la base de données Eigrp :

ip prefix-list MIIR deny 172.16.3.0/24


ip prefix-list MIIR permit 0.0.0.0/0 le 32
router eigrp 11
no distribute-list 1 out
distribute-list prefix MIIR in
exit

Regardez dans la base de données Eigrp de R5, que constatez-vous ?

……………………………………………………………………………………………

……………………………………………………………………………………………

Regardez dans la table de routage de R5, que constatez-vous ?

……………………………………………………………………………………………

……………………………………………………………………………………………

Question 14 : Filtrage des routes avec Route-Map (02 pts)


Sur R5, on veut filtrer le réseau 172.16.3.0/24 de la base de données Eigrp :

access-list 1 deny 172.16.3.0 0.0.0.255


access-list 1 permit any
route-map ESGIS
match address 1
router eigrp 11
no distribute-list prefix MIIR out
distribute-list route-map ESGIS in
exit

Regardez dans la table de routage de R5, que constatez-vous ?

……………………………………………………………………………………………

……………………………………………………………………………………………

M. DOMAN 10 | P a g e
ESGIS – Master1 SRS CCNP ROUTE 2019

Question 15 : Authentification Eigrp (03 pts)


De nombreuses attaques peuvent être menées contre le routage automatique. Pour

contrevenir à ces méfaits, il est important de procéder à l’authentification des routeurs

dans le processus Eigrp ; le chiffrement des données pourra aussi être envisagé. Sur

deux routeurs adjacents, faites la configuration suivante :

Sur R1 :

conf t
key chain SECU
key 1
key-string cisco123
int s1/0
ip authentication key-chain eigrp 11 SECU
ip authentication mode eigrp 11 md5

Sur R5 :

conf t
key chain SECU1
key 1
key-string cisco123
int s1/0
ip authentication key-chain eigrp 11 SECU1
ip authentication mode eigrp 11 md5

M. DOMAN 11 | P a g e