Vous êtes sur la page 1sur 11

Bitácora de trabajo.

Semana1

3/03/009

No tengo conocimientos de señales infrarroja, pero encontré varios


configuraciones para la conexión, buscaré cual es la mas apropiada para el
proyecto.

4/03/009

Usare la configuración base-receptor, que consta de un fototransistor y de


un fotodiodo, falta buscarlos en el mercado.

5/03/009

Tenia pensado utilizar el fototransistor nte3120 pero su hoja de datos no es


completa, gran dificultad porque quería armar como el circuito de la “tipical
aplications”.

Existe el op598, este si tienen circuitos sugeridos por el fabricante, pero hay
que verificar si existe en el mercado y a que precio.

07/03/009

Compre el fotodiodo y el fototransistor, pero hice las pruebas con una


fuente que no se regulaba correctamente, y el multímetro se quedo sin
batería, tendré que buscar otra fuente de 5V para probar de nuevo, aunque
creo que se quemaron los elementos porque hasta cuando funciono el
multimetro marco 9v.

Semana 2

9/03/009

Ya tengo la fuente, pero no hay resultados, funciona la fuente, marca los 5V.
Quizás si se quemaron los elementos, a comprar otros.

10/03/009

Hice una prueba extrema, coloque el fotodiodo y el fototransistor demasiado


cerca, además que se recalienta al extremo, de nuevo se quemaron.

11/03/009

Encontré un circuito práctico, funciono por un instante, pero al parecer se


quemó rápidamente, además que el circuito tiene poca potencia y tengo
que acercar demasiado al emisor y al receptor, y es inservible para el
propósito.

Debo de encontrar un circuito que me permita tener la distancia suficiente


entre el emisor y receptor para que entre el recipiente de agua.
12/03/009

Como en otras ocasiones se me quemó el emisor, quizás por utilizar valores


de resistencias con valores pequeños, pero tengo un rango de valores con el
que puedo trabajar, que son entre 20 ohm y 10k ohm, con sus limitaciones
de luz y por hecho de distancia.

13/03/09

Utilice dos circuitos diferentes para el receptor, pero ninguno funciona, falta
por probar uno, que es con el lm555, al parecer es confiable, esperemos de
resultado.

14/03/009

El circuito con el lm555 tampoco funciono, pero ya tengo otro, que si


trabaja, pero su salida de voltaje es demasiado baja, tendré que amplificar
esa salida para poder manipular con facilidad la señal.

Semana 3

16/03/009

El problema surge en la amplificación, ya que la salida del receptor es de


0.1v (nivel bajo), y de 1.7v (nivel alto) , crea la dificultad de que al
amplificarla a 5vmax, el voltaje de 0.1 subirá a 2.5v, lo que también es nivel
alto, lo que en conclusión me dice que este circuito tampoco sirve.

17/03/009

Ahora tengo un diseño hecho por mí, por supuesto basándome en otros
también, y que funciona como se esperaba, incluso con distancias mayores
a los ya utilizados, lastimosamente solo funciona un fototransistor de 4 que
tengo, esperare a mañana para comprar el que falta y probar los 2 sensores.

18/03/009

Los dos sensores trabajan bien, entregan los voltajes que necesito, además
ya construí la lógica combinacional para el control de las luces de 110v.
Están representadas por leds, se podría decir que falta la etapa de potencia.

Semana 4

23/03/009

Utilizando el triac bt 136 y el moc3021 esta lista la etapa de potencia, pero


tuve problemas con las pruebas respectivas, me confundí con los terminales
T1 yT2 del triac, pero su corrección no fue difícil, ahora falta la conexión de
los focos de 110V.

24/03/009

No se enciende un foco, y no encuentro el error, lo demás esta correcto.

25/03/009

El problema del foco fue un cable que no se conecto de forma correcta al


optoacoplador (pin6) con el gate del triac, ya funciona, habría que hacer las
pruebas con el recipiente.

27/03/009

Antes de hacer las pruebas con el recipiente arme dos pedestales para las
pruebas de control de encendido de los focos, ahora el problema es cuadrar
la línea de los sensores,.

Además ya encargue la elaboración del recipiente.

Semana 5

30/03/009

Ya esta listo el recipiente, pero tiene fugas en algunas partes y no puedo


usarlo, haré que reparen esos escapes.

01/04/009

Ya arreglado el recipiente, hice las pruebas correspondientes y todo


funciona, logré con dificultad cuadrar los sensores, pero se mueve de
repente, pensare en una posible solución.

02/04/009

Realizando varias experimentaciones, con los flotadores, pero encontré que


el agua si esta cortando la señal del emisor, tengo que hacer mas pruebas,
pero si es correcto no tendré que usar los flotadores.

05/04/009

Instale los pedestales en una base, y se cuadran sin conflicto, y luego de 10


pruebas todas fueron favorables al diseño sin flotadores, pero tengo que
hacer mas pruebas

Semana 6

06/04/009

Sigue funcionando, pero la señal infrarroja no se corta efectivamente, quizás


el receptor no conmuta correctamente.

09/04/009
Al revisar la señal en el osciloscopio, se observa que existe fluctuaciones de
la señal de salida del sensor que no permite el buen desempeño del circuito,
lo que ocasiona que las luces no se enciendan o apaguen en el tiempo
correcto., se intentaré utilizar otros dispositivos para la lógica
combinacional.

10/04/009

Conecte un seguidor de tensión después del receptor, pero no conmuta,


puede que la impedancia del receptor sea baja, tendré que encontrar otra
solución.

Semana 7

13/04/009

Cambie las compuertas or y and por unas nor y nand, con smitt trigger, que
mejoraron los resultados, pero son insuficientes, pero también utilice un
latch que perfecciono la conmutación de las luces, con esto el problema
esta solucionado.

14/04/009

Empecé a sondear la parte digital del proyecto, para esto necesito de un


sensor de distancia, existen varios como el infrarrojo y el ultrasonido, de los
dos el ultrasonido es el menos aconsejable para este caso, es costoso y al
parecer las señales debe de ser dirigidas a un micro controlador

15/04/009

Encontré un sensor infrarrojo analógico muy versátil, su costo no es tan


elevado como el infrarrojo, su funcionamiento es sencillo igual que su
conexión.

16/04/009

Al hacer pruebas con el sensor, los voltajes de salida son diferentes


dependiendo del material que se refleje, en papel blanco trabaja a un 90%,
mientras que en le agua un 30%

18/04/009

El sensor trabaja de 10cm a 90cm, dando voltajes de 1.3c a 2.3v. (PARA LAS
DISTANCIAS QUE REQUIERO), lo que me obliga a hacer un amplificador
sumador que vaya de 0v. a 5v.,

Semana 8

20/04/009
El sumador no funciona, la salida se satura, probablemente el amplificador
se esta saturando.

23/04/009

Sigue persistiendo el problema, lo que me temo es que conecte las


resistencias muy bajas a la entrada del amplificador (1K), necesito una
impedancia alta, como de 1M, quizás ahí si funcione el sumador.

25/04/009

Ya tengo listo la amplificación del sensor, ahora me centrare en la


visualización de los en los displays.

Para esto voy a seguir el principio de construcción de un multimetro digital,


el cual me sugiere utilizar contadores, registro, y el decodificador.

Para mi proyecto utilizare tres de cada uno, ya que el volumen del recipiente
necesita de tres displays.

Semana 9

27/04/009

Empezando por los contadores, el diseño lo realice en Proteus, la conexión


des sencilla, pero falta la implementación en la realidad.

29/04/009

Utilizando el 74ls191, me di cuenta que necesitaba una condición adicional


para que cuente hasta el 1001 (9), ya que originalmente lo hace hasta el
1111 (15), pero buscando circuitos integrados, encontré un contador que
cuenta en decadas (del 0 al 9), el 74ls193, que me facilita la conexión.

2/05/009

Conecte tal y como funciona en Proteus, y el conteo se da simultáneamente


ascendente y descendente, debido a algún error de enlace entre los pines.

Semana 10

4/05/009

Haciendo las conexiones de la tabla de verdad de las hojas de datos, el


conteo se realiza satisfactoriamente para los tres dígitos, ahora tengo que
hacer lo mismo con los registros.

5/05/009

Para los registro utilizare los 74ls194, que son registro que me permiten
trabajar del modo paralelo-paralelo, puesto que los datos de entrada y
salida serán de esta manera.
7/05/009

Realice las conexiones dispuestas en la hoja de datos, el registro no


funciona, tengo sospechas de que es el protoboard, porque el primer
registro salta del proto no se conecta como debería.

8/05/009

Revisando las conexiones y verificando continuidad en las conexiones,


encuentro cables desconectados, los que siendo bien conectados, hicieron
funcionar bien a los registros.

9/05/009

Ya tengo los contadores, los registros y los números mostrando en displays,


debo de hacer sus respectivos osciladores, el más rápido debe de ser para
los registros y el de menos velocidad para los contadores

Semana 11

11/05/009

Los osciladores se construyeron con el 74ls14, en frecuencias de 8KHz y


800kHz, la más alta para los registros

12/05/009

Tengo que hacer una corrección, hice un cortocircuito y algunos elementos


dejaron de funcionar, 2 contadores y d0s registros, los decodificadores
funcionan, tengo que reemplazarlos por nuevos.

13/*05/009

Ya cambie los elementos inservibles, he hice pruebas con los registros y os


contadores, con su respectivo oscilador.

Ahora el siguiente paso es convertir esos valores de bcd en analógicos,


como nos pauta el libro.

14/05/009

No existe el conversor de bcd a analógico, utilizare un convertidor de bcd a


binario, (74ls183) y luego uno de binario a analógico.

15/05/009

No existe en el mercado el (74ls183), lo cual crea una dificultad, la posible


solución es realizar un contador binario de 8bits que vaya a la misma
velocidad que el contador que va a los displays.

Semana 12

18/05/009
El contador 74ls191 funciona bien, va de 0 a 255 (dec), por lo que faltaría
conectar un dac para tener la salida analógica que va al comparador.

20/05/009

Se utilizó el dac 0808, su conexión esta hecha y revisada, pero al hacer las
mediciones de voltajes en la salida no hay resultados.

21/05/009

Se hizo observaciones en l osciloscopio, y la salida del dac nos muestra un


voltaje que no varia, y teóricamente conocemos que tienen que darnos una
rampa que va de 0 a Vref. Quizás el dac este defectuoso, o puede ser el
amplificador.

23/05/009

Al trabajar con otro dac, parece que los valores que se registros en cada pin
si se ve reflejada en la salida del amplificador del dac, se tendrá que
verificar en el osciloscopio.

Semana 13

25/05/009

Se probó el dac con el voltaje de referencia 5V. las entradas digitales y su


salida analógica fue la expuesta en la siguiente tabla:

In digital out analógico (V) valor decimal

11111111 4.9 255

10000000 2.55 128

00000000 0 0

Ya verificado el funcionamiento del dac, conecte los contadores ba las


entradas del da, y la señal resultante vista en el osciloscopio fue una rampa
creciente que va de 0 a 4.89V.

Después de la verificación del dac, comprobé que el factor calculado (2.94)


para los osciladores, hace que el contador del los displays y el contador del
dac vayan sincronizados; así cuando el contador de displays llegó al 750, el
contador del dac llego a 255(4.9V.).(Todas estas pruebas fueron realizadas
con una frecuencia de 5Hz para dac y 14.986 para el de display y fuente
regulada de laboratorio.)

27/05/009

Ya tengo uno de los voltajes que va al comparador, ahora falta acondicionar


la señal del sensor, esta será amplificada 5Vmax para que sea comparada
con la señal de salida del dac.
28/05/009

El voltaje amplificado del sensor, lo observé en el osciloscopio, y al vaciar y


llenar el recipiente, los voltajes no son lineales, la mitad del recipiente no es
la mitad de señal del sensor, lo que puede decirnos de que la señal del
sensor es logarítmica.

En los voltajes bajos, cada intervalo es grande, lo que quiere decir que
mientras mas alto sea el voltaje, menores son los saltos entre cada nivel de
voltaje.

30/05/009

Una probable solución es utilizar un circuito anti logarítmico para que se


linealice la señal.

Semana 14

1/06/009

Se trabajó con el circuito logarítmico, ahora os saltos son inversos, en


niveles altos de voltajes esos saltos son grandes, mientras que en voltajes
bajos los saltos son pequeños, lo mejor será dibujar la señal para saber que
curva nos resulta.

3/06/009

El gráfico es de distancia- tiempo y la curva que obtenemos es una


parábola, la que resulta de los datos encontrados experimentalmente.

4/06/009

Lo que se prevé es que la solución mas adecuada es utilizar la estadística


(mínimos cuadrados) para linealizar la señal.

5/06/009

Para halla r la ecuación de linealidad tenemos varios cálculos, los que no


tengo claro pero que no son complicados.

Semana 15

8/06/009

Hice los cálculos manualmente, con 15 muestras conseguidas de llenar y


vaciar el agua constantemente, algo salió mal, se linealiza pero la
pendiente es cero, lo que es un error grave que debo corregir, o mejor es
hacer esos cálculos en una hoja de Excel.

9/06/009
Ya aprendí a calcular los mínimos cuadrados en Excel, y para linealizar una
curva del existen varias maneras, tendré que ver cual es la mas cercana a la
señal original que entrega el sensor.

11/06/009

Formando varias curvas que se acercan a la original, la mas efectiva parece


que es de la forma polinómica de 5to grado, ahora el inconveniente será
implementar toda esa ecuación en circuito para el acople con el sensor.

12/06/009

Para la implementación de la ecuación, necesité de 6 amplificadores


operacionales, los que harán las operaciones necesarias como son la
multiplicación y la suma.

13/06/009

Ya esta todo el circuito conectados en el protoboard, ahora hace falta


verificar en el osciloscopio para ver si en verdad se linealizó la señal del
sensor.

Semana 16

15/05/009

Intente conectar todos los amplificadores operacionales para que entre en


función la ecuación, lastimosamente hubo algún corto y se quemaron cuatro
amplificadores, no se cual fue el error, pero anticipo que el protoboard que
utilice fue prestado, y quizás los amplificadores se saturaron y se
quemaron.

17/06/009

Al fracasar en el intento de implementar la ecuación de 5to grado, verifiqué


que las tres conexiones del sensor esté perfecto, después llené y vacié con
el recipiente para ver que ocurría, impresionantemente los voltajes de
salida del sensor fueron los esperados, cuando había liquido en la mitad del
recipiente, la salida del sensor (ya amplificado) entregó 2.5v, lleno, 5v. y
vacio 0.17v. Lo que me indica que los cables del sensor no estaban
correctamente conectados.

18/06/009

En este día verifiqué lo ocurrido ayer en el osciloscopio, y las varias pruebas


realizadas fueron satisfactorias, la señal ya es lineal. Y no necesito ningún
otro circuito más que el del amplificador de la señal.
19/06/009

Confirmé de nuevo la linealización de la señal, y el resultado es el mismo.


Ahora tengo que centrarme en el siguiente punto, hacer que lo mostrado en
el display no cambia a menos que el nivel de agua varíe.

Semana 17

22/06/009

He tomado conciencia en otro error, los contadores 74ls191 del dac no


tienen un reset, el cual es necesario para que pueda mostrar los números en
el display sin que este cambie sin que el voltaje del sensor y también lo
haga.

23/06/009

Utilizaré el 74ls93, contador que tienen dos master reset, pero uno es
suficiente para su tarea.

24/06/009

Hice experimentos en los que ya puedo ver el volumen de agua del


recipiente en el display pero solamente cuando se llena este, necesito de
dos monoestables que hagan que se pueda visualizar el volumen de agua
cuando se esta vaciando el recipiente.

Ya pensé en una lógica combinacional que ya implemente en el circuito,


esta diseñados de dos flip flop tipo d (biestables) que según mi diseño
actuaran como monoestables que pondrán en cero los contadores cada que
lleguen al voltaje de referencia (voltaje entregada por el sensor, ahora falta
ajustar la oscilación del contador que va al dac.

25/06/009

Haciendo una calibración previa de la amplificación del voltaje del sensor el


resultado fue que ya se puede ver el volumen de agua en el deposito,
independientemente de que sea con llenado o vaciado,. La parte digital esta
concluida, ahora se tienen que acoplar las dos partes, la de volumen con la
de encendido de focos de 110v.

Semana 18
29/06/009

Al unir las dos parte, parece que existe una caída de tensión, lo que no
permite el funcionamiento de las dos partes, si utilizo un transformados con
mayor consumo de corriente pueda que esto deje de suceder.

2/07/009

Hoy en la mañana hice las pruebas con las fuentes de laboratorio, y nada
funciona, ni los sensores infrarrojos ni la visualización en los displays. Al
integrado dejo de funcionar.

En la tarde revise detenidamente cada cable y cada integrado y estoy


seguro que un contador dejo de funcionar. Para comprobar esto comprare
otro mañana a ver que sucede.

3/07/009

Efectivamente; reemplacé el contador dañado y funciono con antes, aunque


el problema sigue siendo la caída de tensión en el circuito.

Semana 19

6/07/009

De nuevo utilice las fuentes del laboratorio, y todo ya esta listo, funciona
como se planteó al principio del proyecto, falta encontrar una solución para
la fuente.

9/07/009

Para la fuente cambie de un transformador de 1.5A a uno de 2A y os


resultados son insatisfactorios, por un momento todo esta bien, pero luego
de cierto tiempo hay una caída de tensión.

También percibí que el regulador de 5v. (7805) esta calentándose


demasiado lo que puede originar el problema de la caída de tensión, quizás
si corrijo eso el problema se solucionaría

10/07009

Usando el transformados de 1.5A y un pequeño disipador para el regulador


de 5v. Todo el circuito funciona correctamente y el tiempo que yo desee, sin
caídas de tensión, y sin averías.