Vous êtes sur la page 1sur 4

Algo 2.

QCM Correction

Soit l'algorithme suivant :

Algorithme …

Variables t[8], i : Entiers

Début
t[1] <- 0
Pour i <- 2 à 8
t[i] <- t[i – 1] + 1
Fin Pour
Afficher(t[8])
Fin

1. L'algorithme ci-dessus affiche :


{ 1
z 7
{ 15

Soit l'algorithme suivant :

Algorithme …

Variables t[9], i, nbre : Entiers

Début
Pour i <- 1 à 9
t[i] <- i
Fin Pour
Pour i <- 1 à 9
Si t[i] Mod 2 = 0 Alors
nbre <- nbre + 1
Fin Si
Fin Pour
Afficher(nbre)
Fin

Mod est l'opérateur modulo.

2. L'algorithme ci-dessus affiche :


{ 4
{ 5
z N'importe quelle valeur ! (car la variable "nbre" n'est pas initialisée)
Soit l'algorithme suivant :

Algorithme …

Variables t[10], i, s : Entiers

Début
s <- 0
Pour i <- 1 à 10
t[i] <- Aléatoire(10)
s <- s + t[i]
Fin Pour
Afficher(s)
Fin

Aléatoire(n) est une fonction qui retourne un entier aléatoire compris entre 0 et n-1.

3. La valeur maximale pouvant être prise par s et affichée par cet algorithme
est :
z 90
{ 99
{ 100

Soit l'algorithme suivant :

Algorithme …

Variables t[7], i : Entiers

Début
Pour i <- 1 à 7
t[i] <- i
Fin Pour
Pour i <- 1 à 7
t[8 – i] <- t[i]
Fin Pour
Fin

4. Après l'exécution de la deuxième boucle "Pour…", le tableau t contient :


{ 1, 2, 3, 4, 5, 6, 7
{ 7, 6, 5, 4, 3, 2, 1
z 1, 2, 3, 4, 3, 2, 1
Soit l'algorithme suivant :

Algorithme …

Variables t[6], i, j, s : Entiers

Début
Pour i <- 1 à 6
t[i] <- 1
Fin Pour
s <- 0
Pour i <- 1 à 6
Pour j <- i à 6
s <- s + t[j]
Fin Pour
Fin Pour
Afficher(s)
Fin

5. L'instruction "Afficher(…)" de l'algorithme ci-dessus affiche :


{ 6
z 21
{ 36

Soit l'algorithme suivant :

Algorithme …

Variables i, k : Entiers

Fonction F(D i : Entier , D j : Entier) : Entier


Début
i <- i + 1
j <- j + 2
Retourner(i + j)
Fin Fonction

Début
i <- 1
k <- 2
Afficher(F(i, k))
Fin

6. L'instruction "Afficher(…)" de l'algorithme ci-dessus affiche :


{ 2
{ 4
z 6

7. Après affichage de la valeur de "F(i, k)", les variables "i" et "k" valent :
z 1 et 2
{ 2 et 2
{ 2 et 4
Soit l'algorithme suivant :

Algorithme …

Variables i, k : Entiers

Fonction F(D i : Entier , R j : Entier) : Entier


Début
i <- i + 1
j <- j + 2
Retourner(i + j)
Fin Fonction

Début
i <- 1
k <- 2
Afficher(F(i, k))
Fin

8. Après affichage de la valeur de "F(i, k)", les variables "i" et "k" valent :
{ 1 et 2
z 1 et 4
{ 2 et 4

Soit l'algorithme suivant :

Algorithme …

Variables i, k : Entiers

Fonction F(R i : Entier, R j : Entier) : Entier


Début
i <- i + 1
j <- j + 2
k <- i + j
Retourner(i + j)
Fin Fonction

Début
i <- 1
k <- 2
Afficher(F(i, k))
Fin

9. L'instruction "Afficher(…)" de l'algorithme ci-dessus affiche :


{ 4
{ 6
z 8 (la valeur retournée par la fonction est (i + j) donc, ici, (i + k) puisque c’est la
variable k qui est passée à la fonction "F()" par référence, soit (2 + 6), soit 8 !)

10. Après affichage de la valeur de "F(i, k)", les variables "i" et "k" valent :
{ 2 et 2
{ 2 et 4
z 2 et 6

Vous aimerez peut-être aussi