Vous êtes sur la page 1sur 8

2.3.

8 : Configuration de la gestion de base des commutateurs

Configuration d’interface pour VLAN99


S1(config)#interface vlan 99
S1(config-if)#

Configuration de VLAN99 avec 172.17.99.11/24 et activation de l’interface


S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown

Configuration d’interface pour Fa0/18


S1(config-if)#interface fa0/18
S1(config-if)#
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 99

Configuration pour la ligne de console


S1(config)#line console 0
S1(config-line)#
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
S1#

Modification du nombre de commandes dans la mémoire tampon de l’historique


S1#show history
S1(config)#line console 0
S1(config-line)#history size 35
S1(config-line)#line vty 0 4
S1(config-line)#history size 35

Version logicielle Cisco IOS en cours de chargement images Cisco IOS chargées dans la
mémoire Flash
S1#show version
S1#show flash
S1(config)#boot system flash:/c2960-lanbase-mz.122-25.SEE1.bin

Configuration de la vitesse et du mode bidirectionnel


S1(config)#interface fa0/18
S1(config-if)#duplex full
S1(config-if)#speed 100
Configuration de l’adresse MAC statique pour le serveur TFTP
S1(config)#mac-address-table static 0060.3EDD.19A3 vlan 99 int fa0/24
S1#show mac-address-table

Mode de configuration d’interface pour Fa0/24


S1#configure terminal
S1(config)#interface fa0/24
S1(config-if)#
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 99

Sauvegarde de la configuration initiale sur le serveur


S1#copy startup-config tftp:
Address or name of remote host []? 172.17.99.31
Destination filename [S1-confg]? [Entrée]

2.4.7 : Configuration de la sécurité des commutateurs

S1 VLAN99 172.17.99.11 255.255.255.0


PC1 Carte réseau 172.17.99.21 255.255.255.0
PC2 Carte réseau 172.17.99.32 255.255.255.0

Configuration du mot de passe du mode privilégié


S1(config)#enable secret class

Configuration du terminal virtuel et des mots de passe de console


S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#

Configuration du chiffrement de mot de passe


S1(config)#service password-encryption
S1(config)#
Configuration et test de la bannière MOTD
S1(config)#banner motd &Authorized Access Only&
S1(config)#end [or exit]
S1#exit

Configuration de la sécurité du port dynamique

Activation de VLAN99
S1(config)#interface vlan 99
S1(config-if)#no shutdown

Passage au mode de configuration d’interface pour FastEthernet 0/18 et activation de la


sécurité du port
S1(config-if)#interface fa0/18
S1(config-if)#switchport port-security

Configuration du nombre maximum d’adresses MAC


S1(config-if)#switchport port-security maximum 1

Configuration du port pour ajouter l’adresse MAC à la configuration en cours


S1(config-if)#switchport port-security mac-address sticky

Configuration du port pour un arrêt automatique


S1(config-if)#switchport port-security violation shutdown

Confirmation de l’apprentissage par le commutateur S1 de l’adresse MAC pour PC1


S1#show mac-address-table
S1#show running-config

Test de la sécurité du port dynamique


S1#show interface fa0/18 (err-disabled)
S1#show port-security interface fa0/18 (Security Violation Count : 1)

Restauration de la connexion entre PC1 et le commutateur S1 et réinitialisation de la


sécurité du port
S1(config)#interface fa0/18
S1(config-if)#shutdown
S1(config-if)#no shutdown
S1(config-if)#exit
S1(config)#
Désactivation de l’interface Fa0/17
S1(config)#interface fa0/17
S1(config-if)#shutdown

2.5.1 : Configuration de base d’un commutateur

PC1 Carte réseau 172.17.99.21 255.255.255.0 172.17.99.1


PC2 Carte réseau 172.17.99.22 255.255.255.0 172.17.99.1
S1 VLAN99 172.17.99.11 255.255.255.0 172.17.99.1

Suppression d’une configuration existante sur un commutateur

Suppression du fichier d’informations de la base de données VLAN


Switch#delete flash:vlan.dat
Delete filename [vlan.dat]? [Entrée]
Delete flash:vlan.dat? [confirm] [Entrée]

Suppression du fichier de configuration initiale du commutateur de la mémoire vive non


volatile (NVRAM)
Switch#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue?
[confirm] [Entrée]
[OK]
Erase of nvram: complete

Vérification de la suppression des informations du réseau local virtuel


Switch#show vlan brief

Rechargement du commutateur
Switch#reload
Proceed with reload? [confirm] [Entrée]
Press RETURN to get started! [Entrée]
Switch>

Examinez la configuration en cours d’exécution en exécutant la commande


show runningconfig

Examinez le contenu actuel de la mémoire vive non volatile (NVRAM) en exécutant la


commande
show startup-config.
Examinez les caractéristiques de l’interface virtuelle VLAN1 en exécutant la commande
show interface vlan1.

À présent, affichez les propriétés IP de l’interface à l’aide de la commande


show ip interface vlan1.

Informations du logiciel Cisco IOS à l’aide de la commande


show version.

Examen des interfaces Fast EthernetSwitch


#show interface fastethernet 0/18

Examen des informations du réseau local virtuel


show vlan

Examen de la mémoire Flash


dir flash: ou show flash

Enregistrement du fichier de configuration initiale


Switch(config)#hostname S1
S1(config)#exit
S1#
Switch#copy running-config startup-config
Destination filename [startup-config]? [entrée]
Building configuration...
[OK]

Création d’une configuration de base de commutateur


S1#configure terminal
S1(config)#hostname S1
S1(config)#exit

S1#configure terminal
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#exit
S1(config)#
S1(config)#enable secret class

Configuration de l’adresse de la couche 3 du commutateur


S1(config)#vlan 99
S1(config-vlan)#exit
S1(config)#interface vlan99
S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown
S1(config-if)#exit

Affectation des ports sur le réseau local virtuel du commutateur


S1(config)#interface fa0/1
S1(config-if)#switchport access vlan 99
S1(config-if)#interface fa0/8
S1(config-if)#switchport access vlan 99
S1(config-if)#interface fa0/18
S1(config-if)#switchport access vlan 99
S1(config-if)#exit

Définition de la passerelle par défaut du commutateur


S1(config)#ip default-gateway 172.17.99.1
S1(config)#exit

Vérification des paramètres des réseaux locaux de gestion


S1#show interface vlan 99
S1#show interface fastethernet 0/18

Enregistrement de la configuration
S1#copy running-config startup-config
Destination filename [startup-config]?[Entrée]
Building configuration...
[OK]
S1#

Examen du fichier de configuration initiale


show startup-config (NVRAM)

Gestion de la table d’adresses MAC


S1#show mac-address-table

Effacement de la table d’adresses MAC


S1#clear mac-address-table dynamic
Vérification des résultats
S1#show mac-address-table

Configuration d’une adresse MAC statique


S1(config)#mac-address-table static 0002.16E8.C285 vlan 99 interface
fastethernet 0/18
S1(config)#end

Suppression de l’entrée MAC statique


S1(config)#no mac-address-table static 0002.16E8.C285 vlan 99 interface
fastethernet 0/18
S1(config)#end

Vérification des résultats


show mac-addresstable static

Identification des adresses MAC apprises par le commutateur


show mac-address-table

Liste des options de sécurité des ports


S1# configure terminal
S1(config)#interface fastethernet 0/18
S1(config-if)#switchport port-security ?
mac-address Secure mac address
maximum Max secure addresses
violation Security violation mode

Configuration de la sécurité sur un port d’accès


S1(config-if)#switchport mode access
S1(config-if)#switchport port-security
S1(config-if)#switchport port-security maximum 2
S1(config-if)#switchport port-security mac-address sticky
S1(config-if)#switchport port-security violation shutdown
S1(config-if)#exit
Vérification des résultats
show port-security interface fa0/18

Examen du fichier de configuration en cours


S1#show running-config

Modification des paramètres de sécurité sur un port


S1(config-if)#switchport port-security maximum 1

Vérification des résultats


show port-security interface fa0/18

Réactivation du port
S1#configure terminal
S1(config)#interface fastethernet 0/18
S1(config-if)#no shutdown
S1(config-if)#end