Vous êtes sur la page 1sur 2

Fenêtre 1 « Fenêtre de départ »

PRISE DE FOCUS FENETRE 1

HCréationSiInexistant(EXPRESS_amis)
TableSupprimeTout(Table1)
HLitPremier(EXPRESS_amis,IDamis)
TANTQUE PAS HEnDehors()
TableAjoute(Table1,EXPRESS_amis.Nom+TAB+EXPRESS_amis.Prénom+TAB+EXPRESS_
amis.Télephone+TAB+EXPRESS_amis.IDamis)
HLitSuivant(EXPRESS_amis)
ExécuteTraitement(NumeroLigne,trtProcédure)
FIN

ENTREE DE TABLE 1
ExécuteTraitement(NumeroLigne,trtProcédure)

CLIC SUR BOUTON 1 « AJOUTTER »

Ouvre(EXPRESS_Fenêtre2)

CLIC SUR BOUTON 2 « SUPPRIMER »

HLitRecherche(EXPRESS_amis,IDamis,Colonne4)
SI H.Trouve ALORS
HSupprime(EXPRESS_amis)
Info ("la suppression est bien fait")
ExécuteTraitement(EXPRESS_Fenêtre1,trtPriseFocus)
SINON
Info ("rien à supprimer")
TableAffiche(Table1)
ExécuteTraitement(NumeroLigne,trtProcédure)
FIN

CLIC SUR BOUTON 3 « MODIFFIER »

HLitRecherche(EXPRESS_amis,IDamis,Colonne4)
SI HTrouve() ALORS
Ouvre(EXPRESS_Fenêtre3)
HModifie(EXPRESS_amis)
Info ("la modification est bien fait")
ExécuteTraitement(NumeroLigne,trtProcédure)
SINON
Info ("Rien à Modiffier")
FIN

CLIC SUR BOUTON 4 « IMPRIMER »

iAperçu(i100)
iImprimeEtat(EXPRESS_etat_amis)

CLIC SUR BOUTON 4 « QUITTER »

Ferme
PROCEDURE LOCALE « NUMEROLIGNE»

PROCEDURE NumeroLigne()
NumLigne est un entier=1
NbrEnr est un entier=TableOccurrence(Table1)
TANTQUE NbrEnr >0
TableSelectPlus(Table1,NumLigne)
Table1.Colonne5=NumLigne
NumLigne=NumLigne+1
NbrEnr=NbrEnr-1
FIN
Saisie1= NumLigne-1

Fenêtre 2 « Fenêtre d’ajout »


CLIC SUR BOUTON 1 « VALIDER »

EcranVersFichier(EXPRESS_Fenêtre2)
SI Nom = "" OU Prénom = "" ALORS
Info("Les fichiers sont vide.")
SINON
HAjoute(EXPRESS_amis)
TableAffiche(EXPRESS_amis.Table1)
FIN
Ferme()

Fenêtre 3 « Fenêtre de Modification »


CLIC SUR BOUTON 1 « VALIDER »

EcranVersFichier()
HModifie(EXPRESS_amis)
Ferme()