Vous êtes sur la page 1sur 12

Configuration des paramètres

de base d’un Routeur

Karim Masmoudi

mirak.masmoudi@yahoo.fr

Configuration des paramètres de


base d’un Routeur
Lors de la configuration d’un routeur, certaines tâches de base sont
effectuées, notamment :
* Effacement et rechargement de la configuration
* Attribution d’un nom au routeur
* Désactivez la recherche DNS
* Configuration d’une bannière
K. Masmoudi

* Synchronisation des messages de l’IOS et de l’entrée de commande


* Configuration du mot de passe pour le mode d’exécution
* Configuration du mot de passe de la console
* Configuration des mots de passe pour les lignes de terminal virtuel
* Configuration des interfaces IPv4
* Configuration des interfaces IPv6
* Enregistrement des modifications apportées au routeur
* Vérification de la configuration de base et des opérations de routage.
2
CCNA2

1
Configuration des paramètres de
base d’un Routeur
Effacement et rechargement de la configuration
Router#erase
Router# erase startup-
startup-config
Router#reload
Router# reload
Attribution d’un nom au routeur
- Passez tout d’abord en mode de configuration globale.
Router#config terminal
- Appliquez ensuite un nom d’hôte unique au routeur.
K. Masmoudi

Désactivez la recherche DNS


R1(config)# no ip domain
domain--lookup
Configuration d’une bannière
R1(config)#banner
R1(config)# banner motd # Message #
Ou
R1(config)#banner
R1(config)# banner motd & Message &
3
CCNA2

Configuration des paramètres de


base d’un Routeur
Configuration du mot de passe pour le mode d’exécution privilégié.
R1(config)# enable secret mot de passe
Configuration du mot de passe de la console
R1(
R1(config
config)#
)#line
line console 0
R1(
R1(config
config--line)#
line)#password
password mot de passe
R1(
R1(config
config--line)#
line)#login
login
K. Masmoudi

R1(
R1(config
config--line)#
line)#exit
exit
Configuration des mots de passe pour les lignes de terminal virtuel
R1(
R1(config
config)#
)#line
line vty 0 4
R1(
R1(config
config--line)#
line)#password
password mot de passe
R1(
R1(config
config--line)#
line)#login
login
R1(
R1(config
config--line)#
line)#exit
exit
Cryptage des mots de passe des consoles et des lignes vty dans les fichiers
de configuration en cours et de démarrage (startup)
R1 (config
(config)#
)# service password
password--encryption 4
CCNA2

2
Configuration des paramètres de
base d’un Routeur
Configuration du mot de passe de la console et des lignes de terminal
virtuel
K. Masmoudi

5
CCNA2

Configuration des paramètres de


base d’un Routeur
Synchronisation des messages de l’IOS et de l’entrée de commande
K. Masmoudi

6
CCNA2

3
Configuration des paramètres de
base d’un Routeur
Configuration des interfaces IPv4
R1#config t
R1(config)# interface type number
R1(config--if)# ip address ip-
R1(config ip-address subnet
subnet--mask
R1(config--if)# description description (Max 240)
R1(config
R1(config--if)# no shutdown
R1(config
K. Masmoudi

7
CCNA2

Configuration des paramètres de


base d’un Routeur
Configuration des interfaces IPv4
● Configuration d’une interface Gigabitethernet 0/0
R1#config t
R1(config)# interface Gigabitethernet 0/0
R1(config--if)# ip address 192.168.10.1 255.255.255.0
R1(config
R1(config--if)# description Link to LAN1
R1(config
K. Masmoudi

R1(config--if)# no shutdown
R1(config
R1(config--if)# exit
R1(config
● Chaque interface appartient à un réseau différent
R1#config
R1#config t
R1(config)# interface Gigabitethernet 0/1
R1(config--if)# ip address 192.168.11.1 255.255.255.0
R1(config
R1(config--if)# description Link to LAN2
R1(config
R1(config--if)# no shutdown
R1(config
R1(config--if)# exit
R1(config 8
CCNA2

4
Configuration des paramètres de
base d’un Routeur
Configuration des interfaces IPv4

● Configuration d’une interface Série 0/0/0

R1#config
R1#config t

R1(config)# interface Serial 0/0/0

R1(config--if)# ip address 209.165.200.225 255.255.255.252


R1(config
K. Masmoudi

R1(config--if)# description Link to R2


R1(config

R1(config--if)# clock rate 128000


R1(config

R1(config--if)# no shutdown
R1(config

R1(config--if)# exit
R1(config

Enregistrement des modifications apportées au routeur

R1#copy
R1#copy running
running--config startup-
startup-config
9
CCNA2

Configuration des paramètres de


base d’un Routeur
Configuration des interfaces IPv4
● Configuration d'une interface de bouclage :
- C’est une interface logique interne au routeur.
- Elle n'est pas affectée à un port physique et ne peut donc jamais être
connectée à un autre périphérique.
- Elle est considérée comme une interface logicielle qui est
K. Masmoudi

automatiquement placée en état « up », tant que le routeur fonctionne.


- Elle est utile en cas de test et de gestion d'un périphérique Cisco IOS, car
elle garantit qu'au moins une interface est toujours disponible.

R1(config)# interface loopback numéro

R1(config--if)# ip address ip
R1(config ip--address subnet-
subnet-mask

R1(config--if)# exit
R1(config
10
CCNA2

5
Configuration des paramètres de
base d’un Routeur
Configuration des interfaces IPv4
K. Masmoudi

11
CCNA2

Configuration des paramètres de


base d’un Routeur
Vérification de la configuration de base IPv4
● R1#show ip interface brief
Affiche un résumé de toutes les interfaces, notamment l'adresse IPv4 de
l'interface et son état de fonctionnement actuel.
● R1#show ip route
Affiche le contenu de la table de routage IPv4 stocké dans la mémoire vive.
● R1#show running
running--config
K. Masmoudi

Affiche la configuration actuelle (RAM)


● R1#show startup
startup--config
Affiche la configuration sauvgardée (NVRAM)
● R1#show running
running--config interface interface
interface--id
Affiche les commandes configurées sur l'interface spécifiée
● R1#show interfaces
Affiche des informations sur l'interface et le nombre de flux de paquets pour
toutes les interfaces du périphérique
● R1#show ip interface
Affiche des informations sur IPv4 relatives à toutes les interfaces d'un routeur.
12
CCNA2

6
Configuration des paramètres de
base d’un Routeur
Vérification de la configuration de base IPv4
K. Masmoudi

13
CCNA2

Configuration des paramètres de


base d’un Routeur
Configuration des interfaces IPv6
R1#config
R1#config t
R1(config)# interface type number
R1(config--if)# ipv6 address ipv6-
R1(config ipv6-address
address//prefix-
prefix-length [link
link--local | eui-
eui-64]
R1(config--if)# description description (Max 240)
R1(config
R1(config--if)# no shutdown
R1(config
K. Masmoudi

14
CCNA2

7
Configuration des paramètres de
base d’un Routeur
Configuration des interfaces IPv6
● R1(config
R1(config--if)# ipv6 address ipv6
ipv6--address /prefix
prefix--length

Crée une adresse IPv6 de monodiffusion globale comme indiqué.

● R1(config
R1(config--if)# ipv6 address ipv6
ipv6--address /prefix
prefix--length eui-
eui-64

Configure une adresse IPv6 de monodiffusion globale au moyen du


K. Masmoudi

processus EUI-
EUI-64.

● R1(config
R1(config--if)# ipv6 address ipv6
ipv6--address /prefix
prefix--length link
link--local

Configure une adresse link


link--local statique sur l'interface utilisée à la place

de l'adresse link
link--local qui est automatiquement configurée lorsque

l'adresse IPv6 de monodiffusion globale est attribuée à l'interface ou

activée via la commande d'interface ipv6 enable.


enable.

15
CCNA2

Configuration des paramètres de


base d’un Routeur
Configuration des interfaces IPv6
● Configuration d’une interface Gigabitethernet 0/0
R1#config
R1#config t
R1(config)# interface Gigabitethernet 0/0
R1(config--if)# ipv6 address 2001:db8:
R1(config 2001:db8:acad
acad:1::1/64
:1::1/64
R1(config--if)# description Link to LAN1
R1(config
K. Masmoudi

R1(config--if)# no shutdown
R1(config

● Chaque interface appartient à un réseau différent


R1#config
R1#config t
R1(config)# interface Gigabitethernet 0/1
R1(config--if)# ipv6 address 2001:db8:
R1(config 2001:db8:acad
acad:2::1/64
:2::1/64
R1(config--if)# description Link to LAN2
R1(config
R1(config--if)# no shutdown
R1(config
16
CCNA2

8
Configuration des paramètres de
base d’un Routeur
Configuration des interfaces IPv6
● Configuration d’une interface Série 0/0/0
R1#config
R1#config t
R1(config)# interface Serial 0/0/0
R1(config--if)# ipv6 address 2001:db8:
R1(config 2001:db8:acad
acad:3::1/64
:3::1/64
R1(config--if)# description Link to R2
R1(config
K. Masmoudi

R1(config--if)# clock rate 128000


R1(config
R1(config--if)# no shutdown
R1(config
R1(config--if)# exit
R1(config
Enregistrement des modifications apportées au routeur
R1#copy
R1#copy running
running--config startup-
startup-config

Activation du protocole IPvIPv66 : Le routeur commence à envoyer des


messages d'annonce Pv Pv6
6 depuis l'interface et pour permettre aux routeurs
IPv6
IPv6 de transmettre le trafic.
trafic.
R1(config)# ipv6
ipv6 unicast-
unicast-routing 17
CCNA2

Configuration des paramètres de


base d’un Routeur
Configuration des interfaces IPv6
K. Masmoudi

18
CCNA2

9
Configuration des paramètres de
base d’un Routeur
Configuration IPv6 de l’interface d’un PC
K. Masmoudi

19
CCNA2

Configuration des paramètres de


base d’un Routeur
Vérification de la configuration de base IPv6
● R1#show ipv6 interface brief
Affiche un résumé de toutes les interfaces, notamment l'adresse IPv4 de
l'interface et son état de fonctionnement actuel.
● R1#show ipv6 route
Affiche le contenu de la table de routage IPv4 stocké dans la mémoire vive.
● R1#show running
running--config
K. Masmoudi

Affiche la configuration actuelle (RAM)


● R1#show startup
startup--config
Affiche la configuration sauvgardée (NVRAM)
● R1#show running
running--config interface interface
interface--id
Affiche les commandes configurées sur l'interface spécifiée
● R1#show interfaces
Affiche des informations sur l'interface et le nombre de flux de paquets pour
toutes les interfaces du périphérique
● R1#show ipv6 interface
Affiche des informations sur IPv4 relatives à toutes les interfaces d'un routeur.
20
CCNA2

10
Configuration des paramètres de
base d’un Routeur
Vérification de la configuration de base IPv6
K. Masmoudi

21
CCNA2

Configuration des paramètres de


base d’un Routeur
Vérification de la configuration de base IPv6
K. Masmoudi

22
CCNA2

11
Configuration des paramètres de
base d’un Routeur
Filtrage des résultats de commande show
Les commandes de filtrage permettent d'afficher des sections de
résultat spécifiques.

● Section : affiche l'intégralité de la section commençant par l'expression de


K. Masmoudi

filtrage..
filtrage
● include : inclut toutes les lignes de résultat correspondant à l'expression de
filtrage
● exclude : exclut toutes les lignes de résultat correspondant à l'expression
de filtrage
● begin : affiche toutes les lignes de résultat à partir d'un certain point, en
commençant par la ligne qui correspond à l'expression de filtrage.
filtrage.

23
CCNA2

Configuration des paramètres de


base d’un Routeur
Filtrage des résultats de commande show
K. Masmoudi

24
CCNA2

12