Vous êtes sur la page 1sur 42

Fiche 

Technique Apprentissage : Dernière Mise à jour


14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

1. SE CONNECTER À L’ÉQUIPEMENT...........................................................................................................................................3
1.1. MÉTHODE ACCÈS À DISTANCE (CONNEXION TELNET OU SSH)................................................................................................3
1.2. CONFIGURATION DU TERMINAL LOCAL....................................................................................................................................3
1.3. ACCÈS AUX MODES DE CONFIGURATION CISCO.......................................................................................................................3
1.4. ACCESSION À UNE COMMANDE................................................................................................................................................5
1.5. COMMANDES SPÉCIALES...........................................................................................................................................................5
1.6. NUMÉROTATION DES INTERFACES (PORTS) SUR LES SWITCHS & ROUTEURS...........................................................................5
1.7. SUPPRIMER UNE COMMANDE....................................................................................................................................................6
1.8. LES COMMANDES : PING OU SHOW.........................................................................................................................................6
2. COMMANDES SYSTÈME............................................................................................................................................................7
2.1. SAUVEGARDER UNE CONFIGURATION......................................................................................................................................7
2.2. PASSAGE AU MODE CONFIGURATION USINE.............................................................................................................................7
3. COMMANDES DE CONFIGURATION DE BASE....................................................................................................................8
3.1. INVALIDER LA RECHERCHE DNS SUR UN ROUTEUR.................................................................................................................8
3.2. SUPPRIMER LES MESSAGES D’ALERTE......................................................................................................................................8
3.3. DONNER UN NOM AU SWITCH...................................................................................................................................................8
3.4. CRÉER UN CONTRÔLE D’ACCÈS USERNAME AU SWITCH...........................................................................................................8
3.5. CRÉER UN MOT DE PASSE ADMINISTRATEUR ENABLE..............................................................................................................8
3.6. CRÉER UN MOT DE PASSE D’ACCÈS À DISTANCE TELNET (EX : 5 SESSIONS POSSIBLES)..........................................................8
3.7. CRYPTER TOUS LES MOTS DE PASSE DU FICHIER DE CONFIGURATION.....................................................................................8
3.8. CONFIGURER UN MOT DE PASSE D’ACCÈS À DISTANCE EN MODE SSH....................................................................................9
3.9. CONFIGURER UNE CONNEXION D’ADMINISTRATION À DISTANCE SÉCURISÉE AVEC SSH........................................................9
3.10. CRÉER UNE BANNIÈRE DE PRÉSENTATION SUR LE SWITCH OU ROUTEUR...............................................................................10
3.11. INSÉRER UNE DESCRIPTION DANS UNE COMMANDE...............................................................................................................10
4. CONFIGURATION DES SWITCHS..........................................................................................................................................11
4.1. CONFIGURATION DES INTERFACES PHYSIQUES (PORTS).........................................................................................................11
4.1.1. Pour configurer les caractéristiques physiques d’un port sur une interface...................................................................11
4.1.2. Configurer les caractéristiques d’une liste de ports sur une interface............................................................................11
5. CONFIGURATION DES VLAN.................................................................................................................................................12
5.1. CRÉATION DE VLAN.............................................................................................................................................................12
5.2. AFFECTATION DE PORTS AUX VLAN.....................................................................................................................................12
5.3. AFFECTATION DE PORTS D’ACCÈS VLANS :..........................................................................................................................13
5.4. AFFECTATION D’UNE LISTE DE PORTS D’ACCÈS VLANS.......................................................................................................13
5.5. CONFIGURATION DES INTERFACES PHYSIQUES EN MODE TRUNK...........................................................................................13
5.6. SUPPRESSION DE VLAN.........................................................................................................................................................13
5.7. RESTRICTION DE TRAFIC VLAN..............................................................................................................................................14
5.8. ATTRIBUTION D’UNE ADRESSE IP DE GESTION AU SWITCH....................................................................................................14
5.9. AFFECTER UNE ADRESSE IP DE PASSERELLE PAR DÉFAUT AU COMMUTATEUR.....................................................................14
5.10. CONFIGURATION D’UN VLAN NATIF.......................................................................................................................................15
5.11. SÉCURISATION DES PORTS PAR FILTRAGE MAC....................................................................................................................15
5.12. CONFIGURER UN VLAN DATA ET UN VLAN VOIX SUR UNE INTERFACE 802.1Q..................................................................15
5.13. VISUALISATION DES CONFIGURATIONS..................................................................................................................................16
6. CONFIGURATION DU SPANNING-TREE.............................................................................................................................17
6.1. INVALIDER LE SPANNING TREE...............................................................................................................................................18
6.2. CONFIGURATION DE LIEN ETHERCHANNEL............................................................................................................................19
7. CONFIGURATION DES ROUTEURS......................................................................................................................................20
7.1. LES INTERFACES.....................................................................................................................................................................20
7.1.1. Configuration des interfaces LAN....................................................................................................................................20
7.1.2. Configuration des interfaces WAN série..........................................................................................................................20
7.1.3. Configuration des interfaces WAN RNIS..........................................................................................................................20
7.2. CONFIGURATION DE ROUTES STATIQUES................................................................................................................................21
7.3. CONFIGURATION D’UNE ROUTE PAR DÉFAUT.........................................................................................................................21
7.4. VISUALISATION DE LA TABLE DE ROUTAGE...........................................................................................................................21

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 1/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.5. CONFIGURATION DE BASE DU ROUTAGE DYNAMIQUE RIP ET EIGRP...................................................................................22


7.6. CONFIGURATION AVANCÉE DU ROUTAGE DYNAMIQUE RIP...................................................................................................22
7.6.1. Annoncer une route par défaut.........................................................................................................................................22
7.6.2. Invalider la propagation de messages de mises à jour RIP.............................................................................................22
7.6.3. Supprimer le résumé automatique de route......................................................................................................................22
7.6.4. Désactiver le routage dynamique RIP sur le routeur.......................................................................................................23
7.7. DÉPANNAGE RIP V2..............................................................................................................................................................23
7.8. CONFIGURATION AVANCÉE DU ROUTAGE DYNAMIQUE OSPF...............................................................................................24
7.8.1. Configuration de l’ID du routeur :...................................................................................................................................24
7.8.2. Configuration d’une interface de loopback du routeur :.................................................................................................24
7.8.3. Configuration du coût de la bande passante d’une liaison..............................................................................................24
7.8.4. Annonce OSPF de route par défaut..................................................................................................................................25
7.8.5. Modification des timers d’intervalle OSPF......................................................................................................................25
7.8.6. Désactivation de paquets de mises à jour.........................................................................................................................25
7.8.7. Désactivation du routage OSPF.......................................................................................................................................25
7.8.8.................................................................................................................................................................................................26
7.8.9. Vérification des paramètres OSPF...................................................................................................................................26
7.9. CONFIGURATION DES SOUS INTERFACES VLAN....................................................................................................................27
7.9.1. Configuration du routeur :...............................................................................................................................................27
7.10. CONFIGURATION D’UNE INFRASTRUCTURE DE VLAN EN RÉSEAU WIFI..............................................................................28
8. CONFIGURATION DES APPLICATIONS RÉSEAU.............................................................................................................30
8.1. CONFIGURATION DES FONCTIONS DHCP SUR LE ROUTEUR...................................................................................................30
8.1.1. Activer le service DHCP...................................................................................................................................................30
8.1.2. Configuration du serveur DHCP du routeur....................................................................................................................30
8.1.3. Visualiser la configuration DHCP...................................................................................................................................31
8.1.4. Configuration de la fonction relais...................................................................................................................................31
8.2. CONFIGURATION DES ACLS...................................................................................................................................................32
8.2.1. Configuration des ACL standards....................................................................................................................................32
8.2.2. Configuration des ACL étendues......................................................................................................................................33
8.2.3. Application d’une liste d’ACL à une interface.................................................................................................................33
8.2.4. Visualisation des listes d’accès........................................................................................................................................33
8.3. CONFIGURATION DES NAT....................................................................................................................................................34
8.3.1. Configuration NAT statique..............................................................................................................................................34
8.3.2. Configuration NAT dynamique.........................................................................................................................................34
8.3.3. Configuration de la surcharge NAT (PAT)......................................................................................................................35
8.3.4. Configuration de la redirection de port (Port Forwarding)............................................................................................35
8.3.5. Dépannage NAT................................................................................................................................................................35
9. SERVEUR TFTP...........................................................................................................................................................................36
9.1. SAUVEGARDE DE CONFIGURATION EN COURS........................................................................................................................36
9.2. RESTAURATION D’UN FICHIER DE CONFIGURATION...............................................................................................................36
9.3. SAUVEGARDE DE L’IOS.........................................................................................................................................................36
9.4. RESTAURATION DE L’IOS......................................................................................................................................................36
9.5. RESTAURER UN IOS SOUS ROMMON (IOS ERROR)................................................................................................................37
9.6. RESTAURER UN IOS SOUS ROMMON (IOS OK)......................................................................................................................37
9.7. CONFIGURATION DE L’INTERFACE DE GESTION DU SWITCH/ROUTEUR...................................................................................38
10. OUTILS DE DÉPANNAGE....................................................................................................................................................38

11. RÉSOLUTION DE PB.............................................................................................................................................................39


11.1. RÉTABLIR UN ROUTEUR BLOQUÉ EN MODE MONITEUR ROM (ROMMON)............................................................................40
11.2. PB DE CONFIGURATION MODE CLIENT....................................................................................................................................40
11.3. FONCTION MONITORING (ESPIONNAGE DE PORT)...................................................................................................................40
11.4. POINTS D’ACCÈS WIFI AIRONET............................................................................................................................................41
12. Liste des principales commandes...............................................................................................................................................42

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 2/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

1. Se connecter à l’équipement

1.1. Méthode accès à distance (connexion Telnet ou SSH)


 Connecter un PC (carte réseau) sur un accès RJ45 du switch ou routeur.
 Ouvrir l’invite de commande CMD Windows et l’application Telnet (Linux ou Windows)
 Taper la commande telnet 192.168.1.1 dans l’invite de commande c:\chemin\>
 Tapez le mot de passe. La connexion est établie
 L’invite de commande du switch ou routeur vous est proposée.

1.2. Configuration du terminal local


 Connecter un PC au switch/routeur avec son câble console V24 (câble bleu)
 Ouvrir l’application windows de gestion Interface série (Hyper terminal ou TeraTerm ou
autre).
 La configuration de l’interface série est 9600b/s, 8bits, 1 stop, no parity
 Allumer le switch/routeur
 Attendre la fin de l’initialisation (10 à 20 sec)
 Appuyer sur entrée puis attendre l’invite de commande :
switch>
L’équipement est maintenant près à recevoir des commandes de configuration.

1.3. Accès aux modes de configuration Cisco


Sur un équipement Cisco, il existe 4 niveaux hiérarchiques d’accès. Chaque accès autorise un
certain type de commandes.

 Mode utilisateur  router>


 Mode privilégié  router#
 Mode Configuration  router(config)#
 Mode Configuration d’interface  router(config-if)#
Etc…

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 3/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

Modes d’Accès

Le tableau ci-dessous décrit en détail les différents modes d’accès au périphérique ainsi que les
droits associés. Attention !! le mode User ne donne accès à aucune fonction de configuration.

Niveau Méthode d’accès Description


Switch> Touche Entrée Mode User

Switch# Commande enable ou en Mode Privilège

Switch(config)# Commande configure Mode global configuration


terminal ou conf t

Switch(config-if)# Commande interface [N° Configuration d’interface


interface]

Switch(config-vlan)# Commande vlan [N°vlan] Configuration de vlan

Switch(config-router)# Commande router [Type] Configuration du routage

Switch(config-line)# Commande line [N° Configuration d’interface console


console]

Tableau 2 – Modes de commandes CLI

Quitter un niveau :
Les commandes end ou touches clavier Ctrl + Z renvoient directement au mode privilège
quelque soit le niveau dans lequel on se trouve.

La commande exit fait redescendre au niveau directement inférieur.


Exemple : si l’on se trouve dans le mode Switch(config-router)#, la commande exit
ramène au mode Switch(config)#

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 4/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

1.4. Accession à une commande


Pour accéder à une commande de configuration spécifique il est nécessaire d’entrer dans le mode
approprié. Par exemple pour configurer une interface, il faut tout d’abord entrer dans le mode de
configuration « switch(config)# » puis effectuer la commande (voir tableau ci-dessus).
L’accès aux commandes s’effectue suivant un mode intuitif. On peut exécuter par exemple la
commande complète show configuration ou bien n’entrer que le début des syntaxes : sh conf .
Il est aussi possible lorsque l’on se trouve dans un mode approprié de ne taper que le début d’une
commande, l’interpréteur peut alors compléter la commande si l’on use de la touche clavier TAB.
Si l’interpréteur ne peut compléter la commande, cela signifie que, soit la commande est erronée, soit
la commande ne peut être effectuée dans le niveau hiérarchique en cours. Ceci est un bon moyen de
vérification du bien fondé d’une commande.

1.5. Commandes spéciales


Une commande intéressante est la commande ?. Elle correspond au Help que l’on trouve dans tant
d’autres applications.
Il existe des aides à tous les niveaux de commandes ; dans les menus principaux et les sous-menus.

Les touches clavier et rappellent respectivement l’historique des commandes


précédentes et suivantes.

1.6. Numérotation des interfaces (ports) sur les switchs & routeurs

Les différents types d’interfaces sont (pour les plus importantes) :


Les interfaces Ethernet (10BaseT) nommées Eth0/1 ou e0/1
Les interfaces FastEthernet (100BaseT) nommées FastEthernet0/1 ou Fa0/1
Les interfaces GigabitEthernet (1000BaseT) nommées GigaEthernet1/1 ou Gi1/1
Les interfaces série nommées serial1/1 ou se1/1

Une numérotation de type  « interface FastEthernet 0/4 » désigne :


Le N° de l’Etage (ici le switch 0) et le Numéro du port (ici le 4)

Une numérotation de type  « interface Ethernet 1/2 » désigne :


Le N° de l’Etage (ici la carte additionnelle Etage 1) et le Numéro du port (ici le 2)

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 5/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

1.7. Supprimer une commande.


Pour supprimer une commande, il suffit de faire la négation de cette commande en rappelant
exactement la commande et tous les paramètres de celle-ci. La commande de négation doit
s’effectuer dans le niveau approprié, celui dans lequel avait été exécutée la commande. Attention
au respect de la syntaxe !

Exemple : Supprimer la configuration IP de l’interface FastEthernet 0/1


Switch#conf terminal
Switch(config)#int fa0/1
Switch(config-if)#no ip address
Switch(config-if)#end
Switch#

Supprimer le vlan 10 sur le commutateur


Switch#conf terminal
Switch(config)#no vlan 10
Switch(config)#end
Switch#

1.8. Les commandes : ping ou show


Switch#ping <adresseIP>  Teste la connectivité entre le switch et l’équipement dont
d’adresse IP désignée par l’argument.

La commande ci-dessous affiche la table d’adresse ARP dans le switch. Cette table est mise à jour
au fur et à mesure du trafic sur le réseau.
Switch# show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.0.2.112 120 0000.a710.4baf ARPA Ethernet3
AppleTalk 4028.5 29 0000.0c01.0e56 SNAP Ethernet2
Internet 192.0.2.114 105 0000.a710.859b ARPA Ethernet3
AppleTalk 4028.9 - 0000.0c02.a03c SNAP Ethernet2
Internet 192.0.2.121 42 0000.a710.68cd ARPA Ethernet

La commande ci-dessous affiche le contenu du fichier de configuration en cours de fonctionnement


présent dans la mémoire RAM (running-config).
Switch# show run

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 6/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

2. Commandes système
Dans tous les équipements switchs/routeurs/passerelles CISCO, on distingue 2 types de
configurations : la Running configuration et la startup configuration.
La Running configuration est celle, en cours d’exécution, qui fait tourner le switch/routeur. C’est la
configuration qui est en mémoire RAM c'est-à-dire non sauvegardée.
La start-up configuration est stockée en NVRAM (équivalente au disque dur). Celle-ci est chargée
dans la running configuration au démarrage du switch/routeur.

Running
config Commande
copy running-config
startup-config
Commande Boot
WR Startup
Editeur de
config
commande

IOS Cisco

Lorsqu’on effectue des commandes en CLI, celles-ci sont mémorisées. Pour lire la configuration on
effectue la commande show running-config si l’on se trouve dans le mode enable. On peut alors
tester la modification.

2.1. Sauvegarder une configuration


Switch#copy running-config startup-config ou encore:
Switch# copy run sta
Destination filename [startup-config]?  confirmer par la touche entrée
Building configuration...
[OK]
Switch#

2.2. Passage au mode configuration usine


Switch#erase startup-config
Switch#reload

le switch/routeur se reinitialise (attendre 20/30 sec)

Traces de chargement du système

Voulez vous démarrer la configuration automatique ? yes/no ? n
Switch> ici on est arrive à la fin du chargement de la configuration usine.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 7/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

3. Commandes de configuration de base


3.1. Invalider la recherche DNS sur un routeur
Router(config)#no ip domain-lookup
Cette commande permet d’éviter au routeur des recherches systématiques d’adresse IP vers un
serveur de domaine

3.2. Supprimer les messages d’alerte


Router(config)#no logging console
Cette commande permet de supprimer l’affichage des messages d’état intempestifs envoyés sur la
console.

3.3. Donner un nom au switch 


Switch#conf t
Switch(config)#hostname ADMIN  donne le nom ADMIN au switch
Switch(config)#

3.4. Créer un contrôle d’accès username au switch


Demande un username et un mot de passe pour entrer dans le mode enable
Router# conf t
Router(config)#username admin password cisco
Router(config)#end
Router#

3.5. Créer un mot de passe administrateur Enable


Pour protéger l’entrée dans le mode de configuration deux commandes sont possibles :
Switch# conf t
Switch(config)#enable password password  le password est en clair
Ou bien :
Switch(config)#enable secret password  le password est crypté

3.6. Créer un mot de passe d’accès à distance Telnet (ex : 5 sessions possibles)
Router(config)#line vty 0 4
Router(config-line)#password password
Router(config-line)#login
Router(config-line)#exit
Router(config)#
Attention !! Le mode accès à distance vous permet d’entrer en mode User uniquement. Vous devez
en plus, créer un mot de passe Administrateur enable pour entrer dans le mode de configuration.

3.7. Crypter tous les mots de passe du fichier de configuration


La commande ci-dessous permet de crypter les mots de passe afin qu’ils ne puissent être visibles
par une personne tierce lors de l’édition du fichier de configuration.
Router(config)#service password-encryption
Router(config)#

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 8/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

3.8. Configurer un mot de passe d’accès à distance en mode SSH


ADMIN(config)#line vty 0 4
ADMIN(config-line)#transport input ssh
ADMIN(config-line)#login
ADMIN(config-line)#exit
ADMIN(config)#

3.9. Configurer une connexion d’administration à distance sécurisée avec SSH


Pour sécuriser les accès d’administration à distance sur les routeurs ou les switch, il est nécessaire
d’utiliser un protocole de transport en mode crypté comme SSH. SSH est une application de
connexion à distance qui assure l’échange des données en mode crypté en utilisant des clés de
chiffrement.
Il faut tout d’abord configurer un nom et déclarer le switch ou routeur dans un domaine.
Router(config)#hostname Charlie
Charlie(config)#ip domain-name domaine.local
Puis on configure les mots de passe d’entrée enable et username
Charlie(config)#enable secret admin
Charlie(config)#username admin password admin
Charlie(config)#service password-encryption
Ensuite on configure les paramètres de base SSH
Charlie(config)# crypto key generate rsa
How many bits in the modulus [512] : 1024
Charlie(config)# ip ssh version 2
Charlie(config)# ip ssh time-out 90
Charlie(config)# ip ssh authentication-retries 2
Charlie(config)#

On configure enfin les paramètres spécifiques SSH

Option pour empêcher tout autre protocole que SSH d’entrer sur un routeur ou switch
Charlie(config)# line vty 0 15
Charlie(config-line)# transport input ssh
Charlie(config-line)#login local
Charlie(config-line)# exit

Pour supprimer SSH


Charlie(config)#crypto key zeroize rsa

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 9/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

3.10. Créer une bannière de présentation sur le switch ou routeur


Affiche une bannière sur la console dès l’entrée dans le mode configuration de l’équipement. La
bannière est un texte défini par l’administrateur qui est affiché lors de chaque entrée dans le mode
enable. Le texte doit être inscrit entre les 2 bannières #.
Switch#conf t
Switch(config)# banner motd # Ceci est un site sécurisé. Seules les personnes
autorisées sont admises ! #
Switch(config)#

3.11. Insérer une description dans une commande


L’indicateur ! permet d’insérer un commentaire dans la commande de configuration afin de donner
une information explicative dans le fichier de configuration.

Switch(config)# ! Ceci est une description  n’est pas pris en compte comme une
commande
Switch(config-if)#

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 10/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

4. Configuration des switchs


4.1. Configuration des interfaces physiques (ports)
Un switch supporte deux types d’interfaces : les ports physiques et les VLANs.
Les ports physiques sont de type Ethernet ou bien FastEthernet ou encore GigabitEthernet
(10/100/1000Mb/s) ou enfin 10GigabitEthernet(10/100/1000/10000Mb/s).
Les règles de nommage des ports sur un switch (ou routeur) s’établissent comme suit :
Sur un port Fa n/p : n= N° d’équipement et p le N° de port. (ex : Fa0/5 = Interface
FastEthernet switch N° 0, port N° 5)

Fa0/1 Fa0/8 Gi0/1

Les ports Ethernet 10Mb/s sont nommés Ethernet (ex : Eth 0/1), les ports 100 Mb/s sont nommés
FastEthernet (ex : Fa 0/n) et les ports 1000 Mb/s nommés GigabitEthernet (Gi 0/n).
La configuration des interfaces permet de fixer les caractéristiques physiques des ports (débit, mode
duplex, état up/down…)

4.1.1. Pour configurer les caractéristiques physiques d’un port sur une interface
Switch#conf t
Switch(config)#interface fastethernet 0/3  Il s’agit du port 3
Switch(config-if)#speed 100  force le débit à 100Mb/s
Switch(config-if)#duplex full  force le mode en full duplex
Switch(config-if)#mdix auto  force l’auto détection de câble (droit/croisé)
Switch(config-if)# end
Switch#

4.1.2. Configurer les caractéristiques d’une liste de ports sur une interface
Switch#conf t
Switch(config)#int range fa 0/1 - 8  commande appliquée sur les ports 1 à 8
Switch(config-if-range)#speed 100  force le débit à 100Mb/s
Switch(config-if-range)#duplex full  force le mode en full duplex
Switch(config-if-range)# end
Switch#

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 11/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

5. Configuration des VLAN

5.1. Création de VLAN


Pour créer des VLAN, on déclare un numéro logique d’identifiant à chaque VLAN. On affecte
aussi un nom associé au numéro du VLAN. Le nom d’un VLAN est optionnel et n’a qu’un
caractère administratif.
Switch#conf t
Switch(config)#vlan 10  Le VLAN N° 10
Switch(config-vlan)#name VENTES  Le nom (Optionnel)
Switch(config-vlan)#exit  ici on descend d’un niveau sans quitter le mode
de configuration
Switch(config)#vlan 20
Switch(config-vlan)#name TECHNO
Switch(config-vlan)#exit

5.2. Affectation de ports aux VLAN


Un port physique peut être configuré en mode trunk ou en mode access. Un port Trunk
véhicule un trafic agrégé c'est-à-dire provenant de plusieurs sources de Vlan. Un port trunk ne
peut être raccordé qu’à un autre port Trunk (switch, routeur ou passerelle).
Un port access véhicule un trafic ne provenant que d’une seule source VLAN, c’est pourquoi il
ne peut être connecté qu’à un poste terminal (poste, serveur, imprimante).

Pour affecter des ports à un Vlan, il faut tout d’abord définir le mode du port puis y associer le
Vlan. Pour ce qui concerne les ports trunk, il n’y a pas d’affectation de Vlan. Seul le type de port
doit être déclaré.
il est possible de restreindre une liste de Vlan autorisés à transmettre sur un port Trunk
(commande « trunk allowed »).

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 12/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

5.3. Affectation de ports d’accès VLANs :


Switch#conf t
Switch(config)#interface fastEthernet 0/1  on travaille sur le port Fa 0/1
Switch(config-if)#switchport mode access  on définit le mode accès sur le Fa 0/1
Switch(config-if)#switchport access vlan 10  le port 1 est affecté au Vlan 10
Switch(config-if)#exit  on descend d’un niveau

5.4. Affectation d’une liste de ports d’accès VLANs 


De la même façon que l’on peut affecter un port à un VLAN, il est possible d’affecter une liste de
ports à un VLAN sur une seule ligne de commande.
Switch#conf t
Switch(config)#int range fa 0/2 - 6  on travaille sur les ports Fa 2 à 6
Switch(config-if-range)#switchport mode access  on définit le mode accès sur les Fa 2 à 6
Switch(config-if-range)#switchport access vlan 10  les port 2 à 6 sont affectés au Vlan 10
Switch(config-if-range)#no shutdown  force l’activation du port
Switch(config-if-range)#end
Switch#

5.5. Configuration des interfaces physiques en mode Trunk


La configuration des interfaces Trunk s’effectue comme suit :

Switch#conf t  passage en mode configuration


Switch(config)#int fa 0/1  on travaille sur le port 0/1
Switch(config-if)# switchport mode trunk  Configuration du mode trunk
Switch(config-if)#end
Switch#

5.6. Suppression de VLAN


Pour supprimer un VLAN, il faut entrer dans le menu de configuration par la commande ″conf t″ puis
effectuer la commande suivante :
Switch#conf t
Switch(config)#no vlan 10
Switch(config-if)#end

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 13/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

5.7. Restriction de trafic Vlan


Cette fonction permet de restreindre un trafic VLAN sur un port trunk.

Switch#conf t  passage en mode configuration


Switch(config)#int Gi 1/2  on travaille sur le port gigabit 1/1
Switch(config-if)# switchport mode trunk  Configuration du mode trunk
Switch(config-if)#switchport trunk allowed vlan 1,2  autorise les VLAN 1,2 à utiliser ce port
Switch(config-if-range)#no shutdown  force l’activation du port
Switch(config-if)#end
Switch#
Note :
Autoriser un ou plusieurs Vlan sur un port trunk interdit implicitement le trafic provenant de tous
les autres Vlan,
Si la commande ″switchport trunk allowed…″ n’est pas présente, tous les VLAN sont autorisés
sans restriction.

5.8. Attribution d’une adresse IP de gestion au switch


Pour administrer un commutateur à distance via une console Telnet ou SSH ou pour accéder au
commutateur par un navigateur, vous devez attribuer une adresse IP et un masque de sous réseau
au Switch.
Cette adresse IP est attribuée sur une interface VLAN crée au titre du Vlan de gestion. On peut ainsi
accéder à distance sur le switch en utilisant cette adresse IP.
Switch#conf t
Switch(config)#int vlan 99  par exemple sur le VLAN 99.
Switch(config-if)#ip address 172.17.99.11 255.255.255.0
Switch(config-if)#exit

5.9. Affecter une adresse IP de passerelle par défaut au commutateur.


Cette fonction indique au commutateur l’adresse IP de la passerelle qui lui permettra de répondre
aux requêtes de l’administrateur.
Switch#conf t
Switch(config)#ip default-gateway 192.168.10.1
Switch(config-if)#exit
Cette commande est obligatoire pour que l’administrateur puisse accéder à l’équipement à distance.
L’équipement doit pouvoir répondre à la requête distante en utilisant cette adresse IP.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 14/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

5.10. Configuration d’un Vlan natif


Un Vlan natif est utilisé sur les interfaces agrégées 802.1Q c'est-à-dire en mode trunk. Un Vlan
déclaré en mode natif transporte des trames non étiquetées sur une interface 802.1Q.
Switch (config)#interface FastEthernet 0/1
Switch (config-if)#switchport mode trunk  L’interface Fa0/1 est configurée en 802.1Q
Switch (config-if)#switchport trunk native vlan 1  Fa0/1 transportera le tafic 802.3
Switch (config-if)#end
Switch #

Dans l’exemple ci-dessus tout trafic non étiqueté est transféré vers le VLAN 1. Ce type de
configuration est spécifiquement utilisé pour le transport du trafic de gestion des commutateurs.

5.11. Sécurisation des ports par filtrage MAC


Pour forcer une adresse MAC sur un port (interdit toute autre @MAC), on effectue la commande
suivante :
Fixer en dur l’adresse MAC sur le port
Switch(config-if)# switchport port-security mac-address 0123.4567.1423.7890
Ou par apprentissage de l'adresse MAC de la 1ère trame qui traversera le port
Switch(config-if)#switchport port-security mac-address sticky

Limiter le nombre de Postes possibles par ports


Switch(config-if)#switchport port-security maximum 2  Seuls 2 postes sont autorisés à
se connecter à ce port

Configurer le port pour se désactiver en cas de violation de sécurité sur ce port


Switch(config-if)#switchport port-security violation shutdown

5.12. Configurer un Vlan Data et un VLAN Voix sur une interface 802.1Q
Ce mode de fonctionnement permet de transporter sur un même accès un trafic voix et donnée. Le
trafic voix issu d’un téléphone IP sera transporté par des trames 802.1Q, le trafic de données issu
d’un PC connecté sur le téléphone IP sera transporté par des trames non étiquetées 802.3.

Switch(config)#interface fastEthernet 0/24


Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 101 native
Switch(config-if-range)#switchport voice vlan 111
Switch(config)#

Dans l’exemple ci-dessus le Vlan 101 (Vlan Data) est en mode natif et transporte donc du trafic non
étiqueté. Le Vlan Voix, lui, transporte le trafic vocal en format 802.1Q. Configuration requise lorsque
l’on utilise un téléphone IP sur lequel est connecté un poste informatique, le téléphone étant
connecté au réseau via sont port Ethernet WAN.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 15/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

5.13. Visualisation des configurations


Les commandes ci-dessous sont utilisées aux fins de maintenance pour visualiser les états des
interfaces et les contenus des tables de configuration.

Pour connaître l’ensemble des commandes de visualisation on effectue la commande suivante :


Switch# show ?
run List access lists  affiche la liste des ACL
arp Arp table  Affiche le contenu de la table ARP
vlan Vlan information  affiche les informations sur les vlan dans la
table du commutateur
---- ----
interfaces  Informations sur les ports

Visualiser l’état des interfaces


Router#show ip protocols  Visualise les paramètres des protocoles de routage configuré
dans le routeur.

Visualiser le contenu de la table d’adresses MAC sur un commutateur


Switch#show mac-address-table  Affiche toutes les adresses MAC apprises par le
switch.

Visualiser les caractéristiques des Vlan


Switch#show vlan  Affiche tous les VLAN configurés et leurs caractéristiques.

Afficher la table de routage d’un routeur


Switch#show ip route  Affiche la table de routage du routeur.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 16/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

6. Configuration du Spanning-tree
Pour rappel l’algorithme Spanning-Tree et ses variantes permettent dans un environnement de
Niveau 2 (switchs), d’éviter les boucles de transmission lorsque des paquets de diffusion transitent
sur les switch.
Cisco a implémenté dans ses Switchs 3 variantes de Spanning-Tree :
 PVST+ utilisant l’algorithme STP (802.1D) maintenant obsolète car trop lent à converger.
 Rapid-PVST+ utilisant l’algorithme RSTP (802.1W) qui possède des capacités de
convergence plus rapide avec dans la majorité des cas, un basculement inférieur à la
seconde.
 MSTP utilisant l’algorithme Standardisé Multiple Spanning-Tree (802.1s). Dans ce cas on
peut grouper plusieurs Vlan sur une seule instance Spanning-tree.

SW1
Boucle de
diffusion

SW2 SW3

Le principe du spanning-tree consiste à bloquer un port d’un switch participant à la boucle de


diffusion. Le critère de décision s’effectue sur la base de l’élection d’un switch racine décidant quel
port bloquer.
Par défaut, le protocole STP exécute automatiquement la configuration sur le Vlan 1.Pour modifier la
distribution STP, il est nécessaire de configurer manuellement les paramètres STP.

Il est possible d’attribuer manuellement le statut de pont racine (root bridge) à un Switch si l’on
souhaite modifier la configuration STP d’un réseau local. On peut, de la même façon attribuer un
pont racine de secours (root secondary) à un Switch.

SW1(config)#spanning-tree mode rapid-pvst  sélection du mode STP


SW1(config)#spanning-tree vlan 10 root primary  le switch 1 est choisi comme pont racine
principal (root bridge) pour le VLAN 10

SW2(config)#spanning-tree mode rapid-pvst  sélection du mode STP


SW2(config)#spanning-tree vlan 10 root secondary  le switch 2 est choisi comme pont
racine de secours (root secondary)
Il est aussi possible de configurer manuellement les paramètres internes STP qui sont la valeur de
priorité BID (Bridge IDentifier) d’un Vlan, la valeur de priorité de port d’un Vlan ou d’une interface, le
coût d’une liaison et les timers STP.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 17/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

On peut aussi modifier les critères de choix STP en modifiant le paramètre de priorité :
Exemple de configuration d’une priorité de 28774 à un pont Vlan :
SW2(config)#spanning-tree vlan N° vlan priority 28774  priorité BID d’un Vlan
!!! Le nombre priority doit être un multiple de 4096

On peut aussi modifier les critères de choix STP en modifiant le paramètre de coût :
Exemple de configuration d’un coût d’une interface :
SW2(config)#interface fa0/24
SW2(config-if)#spanning-tree cost 8  coût de 8 sur l’interface Fa0/24
Vérification de configuration du spanning-tree
SW2#show spanning-tree ou encore
SW2# show spanning-tree detail ou encore
SW2# show spanning-tree vlan 10

Note : Le protocole spanning-tree ne se justifie que sur les liaisons supportées par les ports trunk.

6.1. Invalider le spanning tree


Le spanning tree est automatiquement validé par défaut sur le Vlan 1 du commutateur. On invalide le
spanning tree seulement si l’on a l’assurance qu’aucune boucle ne peut être présente dans le
réseau. La commande ci-dessous invalide le STP sur le commutateur.
SW2(config)#no spanning-tree vlan 1

Sur les liaisons en mode accès, l’exécution du protocole spanning-tree n’a pas d’utilité. Ce protocole
occupe de la ressource CPU inutilement, il est donc recommandé de réduire le traitement du
protocole STP sur ces liaisons.
La commande ci-dessous permet de raccourcir le délai de traitement du spanning-tree sur les ports
en mode accès.
SW2(config)#int range fa0/1 - 5
SW2(config-if)#switchport mode access
SW2(config-if)#spanning-tree portfast
SW2(config-if)#end

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 18/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

6.2. Configuration de lien EtherChannel


Un lien Etherchannel permet de regrouper plusieurs liaisons Ethernet (jusqu’à 8 liaisons) d’un débit
donné en 1 liaison agrégée à haut débit.
Ce groupement est appliqué aux interfaces entre switchs en mode trunk. Les interfaces doivent être
regroupées sur un N° logique de groupe (ci-dessous = 1). Il est possible de créer plusieurs groupes
indépendants de liens Etherchannel.

2 liens FastEthernet 1Gb/s 


1 lien logique Etherchannel 2Gb/s

Fa 0/23
Fa 0/24

Switch(config)# interface range GigabitEthernet 0/23 - 24


Switch(config-if-range)# channel-group 1 mode on

Après avoir affecté des ports Ethernet au Port-Channel 1, on configure le mode et les autorisations
qui seront appliquées à ce port logique (Port Channel 1). Il est nécessaire de désactiver le protocole
cisco de gestion automatique de trunk DTP.

switch# configure terminal


switch(config)# interface Port-channel 1  On applique le mode Trunk sur l’interface
logique Etherchannel
switch(config-if)# switchport mode trunk
switch(config-if)# switchport nonegotiate  Désactivation de la négociation automatique
Cisco DTP

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 19/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7. Configuration des routeurs


Quelque soit le type de routeur, sa configuration concerne :
- 1 La configuration de ses interfaces (affecter une adresse IP + masque)
- 2 L’activation des interfaces configurées
- 3 La configuration de la route par défaut si nécessaire
- 4 La configuration manuelle de routes si nécessaire
- 5 La configuration des sous interfaces VLAN si nécessaire
- 6 La configuration du protocole de routage dynamique si nécessaire

7.1. Les interfaces


Un routeur possède des interfaces WAN, des interfaces LAN, des interfaces Vlan, des sous
interfaces et des interfaces de bouclage (Loopback).
L’interface WAN permet de connecter le routeur à un réseau longue distance opérateur (réseau
étendu). L’interface LAN assure la gestion du réseau local, les sous interfaces sont utilisées pour
les VLAN et les interfaces de bouclage pour des fonctions internes au routeur.
Il est nécessaire d’affecter à chacune de ces interfaces une adresse IP si l’on veut activer les
fonctions de routage au routeur.
Les interfaces peuvent être de type Ethernet, VLAN, Série, RNIS, DSL, Voice (Téléphonie) etc...

7.1.1. Configuration des interfaces LAN


Routeur>enable
Routeur#conf t
Routeur(config)#interface Fa 0/1  Sélection de l’interface
Routeur(config-if)#ip address 149.164.0.1 255.255.0.0  affectation d’une adresse IP fixe
Routeur(config-if)#no shutdown  force l’activation de l’interface
Routeur(config-if)#exit
Routeur(config)#

7.1.2. Configuration des interfaces WAN série


Routeur(config)#interface serial 0/0  Interface série
Routeur(config-if)# ip address 192.168.10.1 255.255.255.0  adresse IP du LAN
Routeur(config-if)#clock rate 128000  Mode DCE au débit de 128Kb/s
Routeur(config-if)# no shutdown  force l’activation de l’interface
Routeur(config-if)#end
Routeur#

7.1.3. Configuration des interfaces WAN RNIS


Routeur(config)#interface bri 0/1  Interface RNIS débit de base BRI
Routeur(config-bri)# no ip address
Routeur(config-bri)# isdn switch-type basic-net3  Type de protocole réseau (Net3)
Router(config-if)# isdn layer1-emulate user/network  Mode Terminal ou Réseau
Routeur(config-bri)# isdn overlap-receiving  Numérotation par chevauchement
Routeur(config-bri)# isdn incoming-voice voice  appel entrant voix traités en mode voix
Routeur(config-bri)# isdn static-tei 0  N° de terminal fixe = 0
Routeur(config-bri)# end

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 20/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.2. Configuration de routes statiques


La configuration de route statique permet de forcer une route sur le routeur vers une destination
déterminée. On configure l’adresse IP réseau de destination, le masque associé à ce réseau et
l’adresse IP de la passerelle pour atteindre ce réseau.
Routeur>enable
Routeur#conf t
Routeur(config)#ip route 196.29.46.0 255.255.255.0 172.16.14.1
Routeur(config)#end
Routeur#

7.3. Configuration d’une route par défaut


La fonction de route par défaut permet de router les paquets dont l’adresse IP destinataire
n’appartient pas à un réseau connu. Cette configuration s’effectue sur le dernier routeur du
réseau en vis-à-vis du routeur d’accès à Internet
Routeur#conf t
Routeur(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1 création d’une route par défaut
Routeur(config)#end
Routeur#
La commande ci-dessus signifie : pour joindre n’importe quel autre réseau de n’importe quel
masque, il faut passer par la passerelle d’adresse IP 172.16.0.1. Cette commande est
généralement utilisée pour le routage vers les réseaux de l’Internet.

7.4. Visualisation de la table de routage


Pour vérifier la table de routage d’un routeur, on utilise la commande show.
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - Periodic downloaded static route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0  route par défaut
10.0.0.0/24 is subnetted, 2 subnets
C 10.10.10.0 is directly connected, FastEthernet0/1
C 10.10.20.0 is directly connected, Ethernet0/0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
R 172.16.0.0/16 [120/1] via 10.10.10.1, 00:00:20, FastEthernet0/1
S 172.16.1.0/24 [1/0] via 10.10.10.1
C 192.168.1.0/24 is directly connected, FastEthernet0/0

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 21/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.5. Configuration de base du routage dynamique RIP et EIGRP


Les protocoles de routage dynamique étudiés ici sont RIP V1, RIP V2, EIGRP et OSPF.
Activation du protocole de routage (ici le protocole RIP)
Routeur#conf t
Routeur(config)#router rip
Routeur(config-router)#version 2 (ou version 1) RIP de version 2 (ou 1)
Routeur(config-router)#network 192.168.20.0 Réseau directement connecté au routeur
Routeur(config-router)#network 192.168.30.0 Réseau directement connecté au routeur
Routeur(config-router)#end
Routeur#
Routeur#conf t
Routeur(config)#router eigrp 1 configure le protocole eigrp pour l’instance 1
Routeur(config-router)#network 192.168.20.0 Réseau directement connecté
Routeur(config-router)#network 192.168.30.0 Réseau directement connecté
Routeur(config-router)#end
Routeur#

7.6. Configuration avancée du routage dynamique RIP

7.6.1. Annoncer une route par défaut


Lorsqu’un routeur possède une route par défaut, par exemple pour une connexion à Internet, il doit
pouvoir annoncer aux autres routeurs qu’il héberge cette route dans sa configuration.
La commande ″default-information originate″ permet au routeur d’effectuer cette annonce.
Routeur(config)#router rip
Router(config-router)#default-information originate
Routeur(config-router)#end
Routeur#

7.6.2. Invalider la propagation de messages de mises à jour RIP


La commande ci-dessous désactive la transmission des messages de mise à jour RIP sur les
interfaces d’accès.
Router(config-router)#passive-interface FastEthernet 0/1

7.6.3. Supprimer le résumé automatique de route


Le résumé de route c'est-à-dire la synthèse d’un ensemble de routes (adresses IP) par une route
principale (adresse IP parent) est validé par défaut dans le routeur. Cette fonction peut, dans certain
cas, créer une confusion dans le choix d’une route. Pour éviter cela on invalide la fonction de
résumé.
Router(config)#router rip
Router(config-router)#no auto-summary
Router(config-router)#end

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 22/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.6.4. Désactiver le routage dynamique RIP sur le routeur


Pour désactiver l’algorithme de routage RIP, on effectue la commande suivante dans le menu de
configuration :
Routeur#conf t
Router(config)#no router rip
Router(config)#
Dans ce cas, tous les paramétrages RIP effectués précédemment sont perdus.

7.7. Dépannage RIP V2


La commande ci-dessous permet d’afficher les messages de modification de la table de routage
lorsqu’une nouvelle entrée est ajoutée ou bien lorsqu’un changement d’état d’une entrée intervient.
Router#debug ip routing

La commande ci-dessous permet de Visualiser les messages de mises à jour RIP


Router#debug ip rip

La commande ci-dessous permet de visualiser les paramètres des protocoles de routage.


Router#show ip protocols

La commande ci-dessous permet de visualiser la table de routage du routeur.


Router#show ip route

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 23/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.8. Configuration avancée du routage dynamique OSPF


OSPF est activé à l’aide de la commande de configuration globale router ospf < id > ou id signifie le
N° de l’instance OSPF (plusieurs instance OSPF possibles dans un routeur).
Routeur#conf t
Routeur(config)#router ospf 1 processus ospf N° 1 (plusieurs processus possibles)
Routeur(config-router)#network 172.16.10.0 0.0.0.255 area 0 réseau + masque inversé
Routeur(config-router)#network 172.16.20.0 0.0.0.15 area 0 réseau + masque inversé
Routeur(config-router)#network 172.16.30.0 0.0.0.3 area 0 réseau + masque inversé
Routeur(config-router)#end

Le paramètre area désigne la zone de couverture OSPF. Ce paramètre doit être identique sur tous
les routeurs d’une même zone. Le masque inversé dans lequel les bits à 1 passent à 0 et
inversement. Ceci est une convention de notation normalisée par l’organisme International IETF.

7.8.1. Configuration de l’ID du routeur :


Routeur#conf t
Routeur(config)#router ospf 1 configure le protocole ospf pour l’instance 1
Routeur(config-router)#router-id 10.10.10.1

7.8.2. Configuration d’une interface de loopback du routeur :


Routeur(config)#interface loopback 1
Routeur(config-if)ip address 10.1.1.1 255.255.255.255

7.8.3. Configuration du coût de la bande passante d’une liaison


La bande passante est liée au type d’interface sur laquelle est connecté le routeur. Pour les
interfaces de type Ethernet ou la valeur est fixée respectivement à 10 pour Ethernet et à 1 pour
FastEthernet ou GigabitEthernet.
Pour les interfaces WAN (RNIS , Serial, E1/T1, Frame Relay ou ATM), les valeurs sont configurables
suivant le type d’interface. Elles sont paramétrables de 64 Kb/s à 2048Kb/s suivant les valeurs :
64, 128, 256, 512, 1024, 1544 et 2048.
La commande bandwidth est utilisée pour modifier la valeur de la bande passante utilisée dans le
calcul de la métrique de coût OSPF. Elle ne définit pas le débit réel de l’interface comme le fait la
commande ″clock rate″.
Routeur(config)#interface serial 0/0/0
Routeur(config)# bandwidth 256 valeur de débit de la liaison
Ce paramètre doit être configuré à l’identique des deux cotés de la liaison.
Outre la commande bandwidth, on peut utiliser la commande ip ospf cost qui permet de configurer
directement le coût d’une interface.
Router(config)#interface serial 0/0/0
Router(config-if)#ip ospf cost 1562 Valeur de coût pour une interface à 64Kb/s
La valeur de coût est une valeur qui n’est pas obligatoirement liée à la bande passante de l’interface.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 24/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.8.4. Annonce OSPF de route par défaut


Lorsqu’un routeur possède une route par défaut, par exemple pour une connexion à Internet, il doit
pouvoir annoncer aux autres routeurs qu’il héberge cette route dans sa configuration.
La commande ″default-information originate″ permet au routeur d’effectuer cette annonce.
Routeur(config)#router ospf 1
Router(config-router)#default-information originate
Routeur(config-router)#end
Routeur#

7.8.5. Modification des timers d’intervalle OSPF


Les intervalles sont des minuteurs qui permettent de régler les émissions de messages Hello
(Intervalle Hello) et la surveillance en cas d’absence de messages Hello (Intervalle Dead).
Les intervalles Dead et Hello OSPF peuvent être modifiés manuellement à l’aide des commandes
d’interface suivantes :
Router(config-if)#ip ospf hello-interval <secondes>
Router(config-if)#ip ospf dead-interval <secondes>

7.8.6. Désactivation de paquets de mises à jour


Cette commende empêche la transmission des mises à jour de routage sur une interface de routeur
tout en autorisant l’annonce de ce réseau aux autres routeurs (cas où cette interface n’est pas
équipée d’un routeur OSPF).
Router(config-router)#passive-interface FastEthernet 0/1  Désactive l’envoi de messages
Hello sur cette interface

7.8.7. Désactivation du routage OSPF


Pour désactiver l’algorithme de routage OSPF, on effectue la commande suivante dans le menu de
configuration :
Routeur#conf t
Router(config)#no router ospf 1
Router(config)#
Dans ce cas, tous les paramétrages OSPF effectués précédemment sont perdus.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 25/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.8.8.

7.8.9. Vérification des paramètres OSPF


Pour vérifier l’ID de routeur en cours, on peut utiliser les commandes suivantes :
Routeur#show ip protocols
Ou bien : Routeur#show ip ospf
Ou encore : Routeur#show ip ospf interface

Pour vérifier et réparer les relations de voisinage OSPF

Si un voisinage n’est pas établit, aucune entrée n’est affichée dans la table.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 26/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.9. Configuration des sous interfaces VLAN


Les sous interfaces VLAN offrent la possibilité de concentrer un trafic provenant de plusieurs sous
réseaux Vlan sur une interface physique du routeur. Ces sous interfaces permettent au routeur de
faire communiquer les VLAN entre eux.
Il faut alors attacher les sous interfaces Vlan sur l’interface physique du routeur. La figure ci-
dessous montre le principe d’attachement

Interface VLAN 10
physique LAN
Interface FastEth 0/1
physique Switch
LAN Routeur
Fa 0/1.10 Fa 0/1.20

Fa 0/1.30 VLAN 20

Interface Fa0/1
en mode Trunk

VLAN 30

7.9.1. Configuration du routeur :


Router#conf t
Router(config)#interface Fa0/1 Interface physique Fa0/1
Router(config-if)#no shutdown on active l’interface physique principale
Router(config-if)#exit
Router(config)#interface Fa 0/1.10 sous interface VLAN 10
Router(config-subif)#encapsulation dot1Q 10 on traite les trames 802.1Q pour le vlan 10
Router(config-subif)#ip address 172.16.10.1 255.255.255.0 affecte 1 adresse IP à l’interface
Router(config-subif)#exit
Router(config)#interface Fa0/1.20 sous interface VLAN 20
Router(config-subif)#encapsulation dot1Q 20 on traite les trames 802.1Q pour le vlan 20
Router(config-subif)#ip address 172.16.20.1 255.255.255.0 affecte 1 adresse IP à la passerelle
VLAN20
Router(config-subif)#exit
Router(config)#interface Fa0/1.30 sous interface VLAN 30
Router(config-subif)#encapsulation dot1Q 30 on traite les trames 802.1Q pour le vlan 30
Router(config-subif)#ip address 172.16.30.1 255.255.255.0 affecte 1 adresse IP à l’interface
Router(config-subif)# end
Router#

Dans ce cas, les postes des 3 VLAN sont à même de communiquer entre eux. Si l’on omet de
déclarer une des trois sous interfaces, le VLAN correspondant ne sera plus joignable.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 27/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

7.10. Configuration d’une infrastructure de VLAN en réseau WIFI


En mode infrastructure, un client Wifi ne pourra s'associer qu'avec un seul point d'accès (AP) dans
un seul SSID. Par contre, un point d'accès pourra fournir ses services sous la bannière de plusieurs
SSIDs.
Utilisant les propriétés WIFI on va créer des Vlan par SSID. On configurera un premier SSID sans
authentification pour une utilisation libre sur Internet (VLAN Invité) et un deuxième SSID avec
authentification pour les employés (Vlan Entreprise).
Le schéma type du réseau est le suivant

Configuration des interfaces Radio SSID sans authentification


AP1(config)#interface dot11radio 0  Interface radio 2,4Ghz (type 0)
AP1(config-if)#ssid Guest1  Affecter un nom de SSID
AP1(config-if-ssid)#vlan 2  Affecter le SSID au VLAN 2
AP1(config-if-ssid)#authentication open  pas d’authentification
Ap1(config-if-ssid)#guest-mode  permet à un client d’entrer sur le réseau
sans procedure d’association
AP1(config-if-ssid)#exit

On configure ensuite un SSID avec authentification (ici authentification à clef partagée).


AP1(config)#interface dot11radio 0  Interface radio 2,4Ghz (type 0)
AP1(config-if)#ssid entreprise  Affecter un nom de SSID
AP1(config-if-ssid)#vlan 3  affecter le SSID au vlan 3
AP1(config-if-ssid)#encryption vlan 3 mode cipher aes-ccm
 Authentification à clef partagée
On configurera par la suite le mode d’authentification.
AP1(config-if-ssid)#authentication key-management wpa version 2
AP1(config-if)#wpa-psk ascii lechevalblancdhenryquatre  configurer le code pass-
phrase
AP1(config-if-ssid)#exit

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 28/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

Il faut créer ensuite autant de sous interfaces radio et Ethernet qu’il y a de VLAN. Dans ce réseau, le
point d’accès ne fonctionne qu’au niveau de la couche 2 (commutation) il faudra configurer pour
chaque sous interface un pontage
AP1(config)#interface dot11radio 0.2  Déclare la sous interface radio 2
AP1(config-subif)#encapsulation dot1q 2  mode trunk
AP1(config-subif)#bridge-group 2  on lui affecte un identifiant de pont
AP1(config-subif)#exit
AP1(config)#interface Fastethernet 0.2  Déclare la sous interface FastEth 2
AP1(config-subif)#encapsulation dot1q 2  mode trunk
AP1(config-subif)#bridge-group 2  on affecte le même identifiant de pont qui
devient dès lors lié à l’interface radio.
AP1(config-subif)#exit
AP1(config)#interface dot11radio 0.3
AP1(config-subif)#encapsulation dot1q 3
AP1(config-subif)#bridge-group 3
AP1(config-subif)#exit
AP1(config)#interface Fastethernet 0.3
AP1(config-subif)#encapsulation dot1q 3
AP1(config-subif)#bridge-group 3
AP1(config-subif)#exit

On configure ensuite le switch. Il faut tout d’abord créer les VLAN, affectation des ports accès à
chaque VLAN et enfin configurer les ports trunk de liaison avec l’AP et le routeur.

Voir chapitres page 12.

Il faut enfin configurer les sous interfaces sur le routeur


R1(config)#interface Fastethernet 0/0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Fastethernet 0/0.2
R1(config-subif)#encapsulation dot1q 2
R1(config-subif)#ip address 192.168.2.254 255.255.255.0
R1(config-subif)#exit
R1(config)#interface Fastethernet 0/0.3
R1(config-subif)#encapsulation dot1q 3
R1(config-subif)#ip address 192.168.3.254 255.255.255.0
R1(config-subif)#exit

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 29/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

8. Configuration des applications réseau


8.1. Configuration des fonctions DHCP sur le routeur
Les routeurs sont, pour la plupart d’entre eux, équipés d’un serveur DHCP qu’il est possible d’activer.
Les principaux paramètres DHCP sont :
La plage d’adresse gérée par le serveur
La plage des adresses exclues
Le bail,
L’adresse fixe du routeur par défaut
L’adresse fixe du DNS (primaire et/ou secondaire)
L’option permettant de définir l’adresse du serveur TFTP

8.1.1. Activer le service DHCP


Le service DHCP est valide par défaut dans les équipements cisco mais il peut être nécessaire de
forcer l’activation ou la désactivation du service dans l’équipement. Pour cela on effectue la
commande suivante :
Router(config)#service dhcp  activation du service
Router(config)#no service dhcp  désactivation du service
Router(config)#

8.1.2. Configuration du serveur DHCP du routeur


Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.19  plage d’exclusion
Router(config)#ip dhcp excluded-address 192.168.1.100 192.168.1.254  plage d’exclusion
Router(config)#ip dhcp pool <nom>
Router(dhcp-config)#network 192.168.1.0 255.255.255.0  adresse réseau gérée par le serveur
Router(dhcp-config)#default-router 192.168.1.254  adresse passerelle par défaut
Switch(dhcp-config)#option 150 192.168.1.254  spécifie l’adresse IP du serveur TFTP
Router(dhcp-config)#dns-server 192.168.1.254
Router(dhcp-config)#exit
Router(config)#

Dans l’exemple ci-dessus, le serveur DHCP assure la gestion de la plage d’adresse 192.168.1.20 à
192.168.1.99. Les adresses 192.168.1.1 à 19 et 192.168.1.101 à 254 sont réservées.

Pour configurer le bail qui définit la date limite de validité de l’adresse IP, on effectue la commande
suivante :
Router(dhcp-config)# lease {days [hours][minutes] | infinite}
Par exemple la commande : #lease 2 4 45  définit un bail de 2 jours, 4heures et 45min.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 30/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

8.1.3. Visualiser la configuration DHCP


Pour visualiser les configurations DHCP, on utilise les commandes show options, pool et
statistics comme ci-dessous :
Router#show ip dhcp import  visualiser les options
Router# show ip dhcp pool  visualiser les pools d’adresses pour les postes
Router# show ip dhcp server statistics  visualiser les statistiques du serveur DHCP

8.1.4. Configuration de la fonction relais


Une fonction DHCP relais doit être configurée dans un routeur si un serveur DHCP à l’extérieur
du LAN doit assurer la gestion des postes de ce LAN. La fonction DHCP relais sera implémentée
dans tous les routeurs qui assurent l’intermédiaire entre le serveur DHCP et les postes externes.
Ceci est aussi vrai pour les serveur DNS ou TFTP.
Dans l’exemple ci-contre les commandes sont :
Sur l’interface 10.0.0.2 :
router(config-if)# ip helper-address 20.0.0.2
router(config-if)# ip helper-address 20.0.0.3
router(config-if)# ip helper-address 20.0.0.4

On renseigne au routeur l’adresse du serveur DHCP qui


doit assurer l’adressage dynamique des postes du LAN.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 31/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

8.2. Configuration des ACLs


Les listes de contrôle d’accès permettent de contrôler le trafic entrant et sortant d’un réseau. Ce contrôle est
effectué au niveau des interfaces du routeur.
Listes de contrôle d’accès entrantes : les paquets entrants sont traités avant d’être routés vers l’interface
de sortie. Le paquet n’est soumis à l’algorithme de routage qu’après le traitement par l’ACL.
Listes de contrôle d’accès sortantes : les paquets entrants sont tout d’abord soumis au routage vers
l’interface de sortie puis traités par les règles ACL.
Les listes de contrôle d’accès sont de 2 types :
Les listes de contrôle d’accès standard permettent d’autoriser ou refuser des paquets sur la base de
l’adresse IP source. Les listes ACL standard sont identifiées par des numéros dans les plages de N° 1 à 99 et
1300 à 1999.
Les listes de contrôle d’accès étendues filtrent les paquets IP en fonction de plusieurs attributs, dont le type
de protocole, l’adresse IP source, l’adresse IP de destination, les ports TCP ou UDP source, les ports TCP ou
UDP de destination et informations facultatives pour une meilleure précision du contrôle. Les listes ACL
étendues dans les plages de N° 100 à 199 et 2000 à 2699.
Les ACL sont traitées dans l’ordre dans lequel elles ont été configurées. Si une condition est rencontrée dans
une ACL, le paquet est traité et les conditions suivantes ne sont plus analysées. Lorsqu’une ACL est crée, une
instruction implicite ″Deny all″ qui signifie « toutes autres adresses refusées » est introduite dans le routeur.

8.2.1. Configuration des ACL standards


La syntaxe d’une commande ACL standard est :
Access-list <N° ACL> <Action (Deny ou permit ou remark)> <@IP source> <masque générique>
La commande suivante :
Router(config)#access-list 20 permit 192.168.16.0 0.0.0.255
Crée une ACL N° 20 qui autorise tout trafic provenant de la source 192.168.16.0 à 192.168.16.255. Le
masque inverse 0.0.0.255 indique en réalité un masque de /24 et donc les 256 adresses autorisées.

La commande suivante :
Router(config)#access-list 21 deny 192.168.20.0 0.0.0.127
Indique que la liste 21 n’autorise pas les 128 adresses 192.168.20.0 à 127 à transiter dans le routeur.

On peut aussi composer une liste de contrôle qui autorise une partie des adresses d’un réseau à
bénéficier des ressources d’accès. Par exemple, la commandes suivante :
Router(config)#access-list 10 permit 192.168.16.0 0.0.0.240
Router(config)#access-list 10 deny 192.168.16.0 0.0.0.15
Autorise la plage d’adresses 198.168.16.16 à 192.168.16.240 à utiliser les ressources du réseau.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 32/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

8.2.2. Configuration des ACL étendues


La syntaxe des commandes ACL étendues est la suivante :
Access-list <N° ACL> < Action (Deny ou permit ou remark)> <protocole> <@IP source>
<mask Gen> <@IP dest> <mask Gen> <opérateur (facultatif)> <port (facultatif)>
<established (facultatif)>
La commande suivante :
Router(config)#access-list 110 deny tcp 192.168.45.0 0.0.0.255 192.168.50.2 0.0.0.0 eq telnet
Interdit à tous les postes du réseau source 192.168.45.0 (masque 0.0.0.255) l’accès au port telnet dont
l’adresse IP est 192.168.50.2 (masque inverse 0.0.0.0)
Dans les commandes suivantes :
R1(config)#access-list 103 permit tcp 192.168.10.0 0.0.0.255 any eq 80
R1(config)#access-list 103 permit tcp 192.168.10.0 0.0.0.255 any eq 443
R1(config)#access-list 104 permit tcp any 192.168.10.0 0.0.0.255 established

La liste de contrôle d’accès 103 autorise le trafic en provenance de toute adresse du réseau


192.168.10.0 (masque inverse 0.0.0.255) à accéder à n’importe quelle @IP destination (any), à
condition que le trafic soit transféré vers les ports 80 (HTTP) et 443 (HTTPS).
Le paramètre established de la 3ème commande n’est applicable qu’aux connexions tcp. Il permet à
toutes réponses provenant des requêtes d’une connexion tcp préétablie de transiter dans le routeur.
Sans paramètre established dans l’instruction de la liste de contrôle d’accès, les clients peuvent envoyer
le trafic vers un serveur Web mais ils ne peuvent pas le recevoir.

Les commandes suivantes :


R1(config)#access-list 103 permit udp 0.0.0.0 0.0.0.255 any eq bootps
R1(config)#access-list 103 permit udp 172.16.20.0 0.0.0.255 any eq domain
Autorisent l’accès à tous les membres du réseau local au serveur DHCP (1ère commande) et pour les
postes du réseau 192.168.20.0 au serveur de nom de domaine (2ème commande).
La commande ci-dessous supprime la liste de contrôle d’accès N° 103 :
R1(config)#no access-list 103

8.2.3. Application d’une liste d’ACL à une interface


Après configuration, une liste de contrôle d’accès standard ou étendue doit être attachée à une interface
physique pour être effective. Ceci est réalisé par les commandes suivantes :
R1(config)# interface Fa0/0
Router(config-if)#ip access-group 103 out (filtre les paquets en sortie de l’interface)
Router(config-if)#ip access-group 104 in (filtre les paquets en entrée de l’interface)

8.2.4. Visualisation des listes d’accès


Les commandes ci-dessous permettent de vérifier les listes d’accès configurées dans le routeur.
show access-lists [ number | name ] visualise toutes les ACL quelque soit l'interface
show ip access-lists [ number | name ] : visualise les ACL uniquement liés au protocole IP
La commande ci-dessous supprime la liste de contrôle d’accès N° 103 de l’interface fa0/1:
R1(config)#interface fa0/1
R1(config-if)#no access-group 103 in

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 33/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

8.3. Configuration des NAT

Configurer une passerelle NAT nécessite de bien définir les interfaces entre les réseaux privé et public.

Réseau Privé
Réseau Public
Internet
Adresse Locale Adresse Globale Adresse Globale
Interne interne externe

8.3.1. Configuration NAT statique.


Configurer une table NAT statique consiste à établir une relation 1 sur 1 entre adresses IP du réseau
privé et adresses IP du réseau public.
R1(config)#ip nat inside source static 192.168.1.11 203.121.45.17
Cette commande associe de façon statique l’adresse IP publique configurée sur le routeur (@IP globale
interne) 203.121.45.17 à l’équipement du réseau privé 192.168.1.11.
Pour permettre au routeur d’effectuer la translation, il faut configurer ses interfaces internes et externes.
Les commandes ci-dessous effectuent la configuration des interfaces internes et externes de la
passerelle NAT.
R1(config)#interface fa0/0  C’est l’interface coté réseau privé
R1(config-if)#ip nat inside  interface locale interne
R1(config)# interface Fa0/1  C’est l’interface coté réseau public
R1(config_if)# ip nat outside  interface globale interne

8.3.2. Configuration NAT dynamique


Il s’agit de configurer un pool d’adresses publiques qui seront partagées par les équipements du réseau
privé.
Pour déclarer une fonction NAT dynamique il est préférable d’associer à chaque pool d’adresses
publiques une liste de contrôle d’accès qui n’autorisera que les adresses devant être traduites.
La commande :
Router(config)#ip nat pool Plage1 195.74.55.1 195.74.55.30 netmask 255.255.255.224
Router(config)#access-list 1 permit 172.16.0.0 0.0.255.255
Router(config)#ip nat inside source list 1 pool plage1
Déclare une plage Plage1 d’adresses IP publiques et le masque associé puis définit une liste
d’autorisation d’accès sur la plage d’adresses privées 172.16.0.1 à 172.16.255.254.
On lie enfin le pool d’adresses NAT plage1 à la restriction d’accès sur les adresses privées.

Il faut maintenant déclarer la fonction NAT sur les interfaces physiques de la passerelle.
R1(config)#interface fa0/0  C’est l’interface coté réseau privé
R1(config-if)#ip nat inside  interface locale interne
R1(config)# interface Fa0/1  C’est l’interface coté réseau public
R1(config-if)# ip nat outside  interface globale interne

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 34/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

8.3.3. Configuration de la surcharge NAT (PAT)


La fonction surcharge NAT ou NAT/PAT permet à un pool d’adresses IP privées de se partager une
adresse IP publique.
Il faut tout d’abord définir une liste d’accès standard autorisant les postes à traverser le routeur.
Router(config)#access-list 11 permit 192.168.62.0 0.0.0.255
Il faut ensuite associer l’ACL à l’interface qui doit exécuter la translation d’adresse PAT. Il s’agit de
l’interface coté réseau public (global inside).
Router(config)#ip nat inside source list 11 interface Fa0/1 overload

Il faut enfin déclarer la fonction NAT sur les interfaces physiques de la passerelle.
R1(config)#interface fa0/0  C’est l’interface coté réseau privé
R1(config-if)#ip nat inside  interface locale interne
R1(config)# interface Fa0/1  C’est l’interface coté réseau public
R1(config-if)# ip nat outside  interface globale interne

8.3.4. Configuration de la redirection de port (Port Forwarding)


Cette fonction est utile lorsqu’il est nécessaire d’accéder à un serveur à partir d’une station externe au réseau
de l’entreprise. Par exemple si l’on veut de chez soi se connecter au serveur WEB Intranet de sa société.
La redirection de port permet alors de rediriger une connexion externe vers le serveur via son numéro de port
et son adresse IP.
On définit tout d’abord une liste d’accès permettant d’autoriser un trafic entrant (ici de toute @IP vers toute
@IP)
Router(config)#access-list 101 permit ip any any
On associe ensuite cette liste à la fonction NAT/PAT sur l’interface publique pour permettre l’accès à Iinternet.
R1(config)#ip nat inside source list 101 interface Fa0/1 overload
R1(config-if)#exit
On déclare ensuite La fonction redirection de port dans le routeur.
R1(config)#ip nat inside source static tcp 192.168.1.254 80 201.89.49.1 80

Le traffic tcp entrant dont le port destinataire est http qui arrive sur l’interface publique 201.89.49.1 sur le port
80 est redirigé vers le serveur http d’adresse 192.168.1.254.

8.3.5. Dépannage NAT


Les commandes ci-dessous permettent d’examiner et analyser une configuration NAT :
R1#show ip nat translations
Affiche la table de translation NAT
R1#show ip nat statistics
Affiche les statistiques sur les translations survenues sur le routeur.
R1#debug ip nat [verbose]
Trace les évènements NAT sur le routeur

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 35/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

9. Serveur TFTP
Le serveur TFTP est le composant principal d’un réseau pour assurer les mises à jour et les
configurations des équipements de ce réseau. Il héberge tous les fichiers et les environnements
système qui permettent aux équipements d’un réseau de récupérer automatiquement les nouvelles
mises à jour.

9.1. Sauvegarde de configuration en cours


Copier la configuration du switch/routeur vers le serveur TFTP.
Switch> enable
Switch# copy running-config tftp
Address or name of remote host [ ]? 192.168.46.250  @IP du serveur TFTP
Destination filename [r1-confg]?  fichier de config par défaut
!!......!
19470 bytes copied in 3.912 secs (4977 bytes/sec)
Switch#

9.2. Restauration d’un fichier de configuration


Soit à récupérer une configuration d’un serveur TFTP vers le switch/routeur
Switch> enable
Switch# copy tftp running-config
-------
Switch#

9.3. Sauvegarde de l’IOS


L’IOS est le système d’exploitation des équipements de réseau Cisco, pour des raisons de sécurité il
peut être utile d’effectuer une sauvegarde de ce système.
Copier l’IOS dans le serveur TFTP:
router# copy flash:<nom.fichier.bin> tftp:
Source filename [ ]? c2600-ipbasek9-mz.124-8.bin
Address or name of remote host [ ]? 192.168.1.10
Destination filename [c2600-ipbasek9-mz.124-8.bin]? toto.bin

Writing c2600-ipbasek9-mz.124-8.bin...!!!!!!!!!!!!!!!!!! - - - - !!!!!!!! [OK - 13169700 bytes]

9.4. Restauration de l’IOS


Cette procédure a pour but de réinstaller l’image de référence du système d’exploitation IOS sur un
routeur CISCO lorsque celle-ci a été effacée de la mémoire flash ou doit être tout simplement
changé.
Le transfert de l’image se fait par TFTP.
Router#copy tftp flash :
On doit arriver au résultat ci-dessous :
Loading c2600-ipbasek9-mz.124-8.bin from 192.168.1.10: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! etc…
!!!!!!!!!!!!!!!!!!!!!!!!!!!!![OK - 13169700 bytes]

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 36/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

9.5. Restaurer un IOS sous Rommon (IOS error)


S’il est nécessaire de restaurer un IOS alors que le routeur ne peut démarrer ou bien que l’IOS n’est
pas accessible, il faut accéder au BIOS de l’équipement afin de procéder à la restauration en mode
manuel.
Pour accéder au BIOS du routeur c'est-à-dire en mode rommon, on appuie sur les touches clavier
<ctrl> + <arrêt défil> ou bien <Alt> + <b> et attendre le prompt rommon 1 comme ci-dessous. Une
fois le prompt affiché procéder comme suit

rommon 1 > IP_ADDRESS=172.26.1.106 adresse IP du routeur


rommon 2 > IP_SUBNET_MASK=255.255.0.0 son masque
rommon 3 > DEFAULT_GATEWAY=172.26.1.106 passerelle (routeur)
rommon 4 > TFTP_SERVER=172.26.1.2 adresse serveur TFTP
rommon 5 > TFTP_FILE=c1700-sv3y-mz.122-13.bin nom fichier IOS
rommon 6 > tftpdnld
Confirmer la restauration par :
Do you wish to continue? y/n: [n]: y
Le téléchargement de l’image commence :
Receiving c1700-sv3y-mz.122-13.bin from 172.26.1.2!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! etc
Une fois l’installation terminé procéder au rechargement de l’IOS
rommon 7 > boot
program load complete, entry point: 0x80008000, size: 0x3d70d0
Self decompressing the image :
#############################################################################################
########################################## [OK]

9.6. Restaurer un IOS sous Rommon (IOS ok)


Pour restaurer ou mettre à jour un IOS si l’IOS du routeur ou switch est opérationnel, procéder
comme suit :
Au démarrage faire <Ctrl> + <break> puis sous rommon 1 faire confreg 0x2101
Sous rommon2 faire <reset>. On doit alors passer en mode boot. A la fin du boot on fait :
Router(boot)>en
Router(boot)#conf t
Router(boot)(config)#int Fax/x
Router(boot)(config-if)#ip addresse <ip> <mask>
Router(boot)(config-if)#no shut
Router(boot)(config-if)#exit
Router(boot)(config)#ip default-gateway <ip>
Router(boot)(config)#exit
Router(boot)# copy tftp flash:
---
Router(boot)#conf t
Router(boot)(config)#config-register 0x2102
Router(boot)(config)#exit
Router(boot)#reload  il faut redémarrer le routeur.
System configuration has been changed – Save ? yes/no  taper y puis entrée

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 37/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

9.7. Configuration de l’interface de gestion du switch/routeur


Pour accéder à l’interface de gestion des périphériques de réseau (switch, routeurs, AP ou
passerelles), il est nécessaire de configurer auparavant les adresses IP de chaque équipement. Si le
serveur de sauvegarde se trouve à l’extérieur du réseau, il faut alors configurer en plus l’adresse de
la passerelle de sortie.

Switch(config)#interface vlan 99  Vlan de gestion


Switch(config-if)#ip address 192.168.99.1 255.255.255.0  adresse IP interface (VLAN99)
Switch(config-if)#end
Switch#

Ne pas oublier de déclarer la passerelle si le serveur TFTP est en dehors du réseau :


Switch(config)#ip default-gateway 192.168.99.254

10. Outils de dépannage

Visualiser les voisins CDP


Switch#show cdp neighbors detail

Afficher l’état des interfaces avec CDP


Switch#show cdp interface

Visualiser le sommaire d’une interface


Switch#show ip interface brief

Visualiser la table d’adresses MAC


Switch#show mac-address-table

Vider la table d’adresses MAC


Switch#Clear mac-address-table dynamic

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 38/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

11. Résolution de pb
Les procédures de récupération de mot de passe dépendent du type d’équipement (routeur ou
switch).
Perte de mot de passe - Cas des routeurs famille 2800, 3700 etc
La perte du mot de passe ne peut être contournée que par la modification du config-register.
Power off
Power ON
CRTL BREAK
rommon 1> confreg 0x2142  on change de registre de configuration
rommon 2> tapez reset  on redémarre le routeur

- - - init du routeur - - -

Switch> enable
Switch# copy startup-config running-config 
Switch# configure terminal.
Switch# enable secret <password>  configure le nouveau password
Switch#copy running-config startup-config  sauvegarde de la nouvelle configuration

Perte de mot de passe - Cas des switch famille 29xx etc..


Power off
Appui sur BP mode
Power on
Invite  switch :
Relâchez bouton mode

Tapez :
Switch: flash_init
- - - boot - - -
Switch: load_helper
---
Switch: dir flash:
Switch: rename Flash:config.text flash:config.backup  pour se débarrasser du fichier
config.text
Switch : boot
---
Would you like to enter the initial configuration dialog ? [yes / no] tapez n puis entrée
Switch>enable
Switch#copy flash:config.text system:running-config
Confirmez

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 39/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

11.1. Rétablir un routeur bloqué en mode moniteur ROM (ROMmon)


Ce processus n’est nécessaire qu’en cas urgence, lorsqu’un utilisateur a supprimé ou effacé l’IOS et
qu’il est impossible de télécharger une nouvelle version de ce système à partir d’un serveur TFTP.
Démarrez le routeur bloqué et utilisez la séquence Ctrl – Break afin d’accéder au mode « ROM
Monitor ». Une des invites de commande possibles telles que
rommon 1 >
A partir de l’invite de commande « ROM Monitor », utilisez la commande dir flash: puis entrée.
L’appareil renvoie :
rommon 3 >dir flash:
File size Checksum File name
3307884 bytes (0x804b4c)0x6ba0 c1700-ny-mz.121-6.bin
rommon 4 >
Démarrez à partir de n’importe quelle image qui est répertoriée à l’étape précédente.
rommon 5 >boot flash:c1700-ny-mz.121-6.bin
program load complete, entry point: 0x80008000, size: 0x804a30
Self decompressing the image : ###################################
########...

11.2. Pb de configuration mode client


Un problème pour configurer le switch (vlan, interfaces…). Le switch est peut-être configuré en mode
client. Reconfigurer le en mode serveur.
Switch(config)#vtp server mode

11.3. Fonction monitoring (espionnage de port)


Créer un port de monitoring (trace)
Il est possible d’affecter un port d’un switch ou routeur à une fonction de surveillance de trafic sur un
port particulier.
On peut alors brancher un PC analyseur de trame sur ce port et surveiller les trames échangées. Le
port sur lequel on branche le PC est le port source et le port destinataire est celui sur lequel on
récupère le trafic.

Switch(config)#monitor session 1 source interface FastEthernet 0/6


Switch(config)#monitor session 1 destination interface FastEthernet 0/4 encapsulation replicate
Switch(config)#end
Ici le trafic sur le port 6 est répliqué sur le port 4. Session 1 désigne un numéro de session.

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 40/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

11.4. Points d’accès WIFI Aironet


Conversion du système d’exploitation LWAPP/CAPWAPP vers le système IOC Cisco Autonomous.
Dans ce mode, on utilise le démarrage en mode configuration par défaut (touche mode).
Vous avez au préalable installé un serveur TFTP sur votre PC et stocké le fichier binaire
correspondant à la version d’IOS de votre AP dans un dossier (ex : c1200-k9w7-tar.123-7.ja.tar) que
vous avez déclaré dans TFTP.
- Appuyer sur le bouton Mode puis branchez l’alimentation de l’AP
-

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 41/42


Fiche Technique Apprentissage : Dernière Mise à jour
14/01/2021
Interface de commande CLI CISCO Ref : FTA 08

12. Liste des principales commandes

Mode Liste commandes description


User : Switch> enable Passage au niveau global config
Privilege User : ? Commandes d’interrogation
Switch# show configuration
show VLAN
show interfaces
show ip route
show ip interfaces
show ip protocols
configure terminal Passage au niveau global
disable
Copy Sauvegarde, restauration
Erase effacement
Ping
traceroute
Global Config : interface < type > Passage en mode config-if
switch (config)# ip routing
no ip routing
ip route
no ip route
vlan < identifier> Passage en mode config-vlan
ping
enable password Modifier le password enable
router < rip | ospf | eigrp >

Interface : arp
switch(config-if)# mode, speed, flowcontrol… Config de l’interface Ethernet
ip address
shutdown / no shutdown désactive / active le port
mac-address
VLAN : switchport Activer le niveau 2 switch
switch(config-vlan)# no switchport Désactiver le niveau 2 switch
Routeur : router rip
switch(config-router)# router ospf

Line : switch(config-line)# Vty 0 4 Console Telnet (4 sessions)

Les principales commandes :


enable : pour entrer dans le menu de configuration du switch/routeur.
show : pour visualiser des éléments (équipements, interfaces, configuration, VLAN…)
configure terminal : entrer dans le mode de configuration général
no <instruction> : no est la négation qui supprime la commande <instruction>

FICHES TECHNIQUE D’APPRENTISSAGE - COMMANDES CLI CISCO PAGE : 42/42

Vous aimerez peut-être aussi