Vous êtes sur la page 1sur 13

Les fonctions avancées Excel : niveau 3

Excel, comment utiliser les fonctions : SOUS.TOTAL, SI, NB.SI, SOMME.SI, MOYENNE, ET,
OU, RECHERCHEV, les tableaux croisés dynamiques.

 1. Utiliser les fonctions du tableur :


o a- La fonction SI
o b. Les fonctions NB.SI, SOMME.SI et NBVAL
o c. Les fonctions MOYENNE, ECART-TYPE ET MODE
o d. La fonction RECHERCHEV
o e. La fonction SOUS.TOTAL
o f. les opérations logiques ET, OU
 2. le formatage conditionnel
 3. le controle de la saisie des données
 4. Importer des données
 5. le tableau croisé dynamique

La fonction SI

Comment marche la fonction SI dans Excel ?

La fonction SI sert à vérifier une condition et à faire un 1er calcul si c’est vrai et à faire un


autre calcul si c’est faux.

La fonction SI comporte donc 3 parties :

 Une condition, qui doit pouvoir être calculée à partir d’autres cellules et donner un
résultat vrai ou faux. Exemples : A1 > 10, B1 = C1…
 Un 1er calcul  au cas où la condition a donné la valeur : vrai,
 Un autre calcul au cas où la condition a donné la valeur : faux

syntaxe : SI(<condition>;<calcul si vrai>;<calcul si faux>)

dans cet exemple, on souhaite


vérifier si la taille saisie en cellule B2 est supérieure à 1,90 mètres afin d’afficher si c’est
vrai “géant” en colonne C ou si c’est faux d’afficher “normal”

saisir dans la cellule C2 :  =SI(B2>1,90; “géant“; “normal”)

– la condition est : B2>1,9
– le calcul si vrai est : “géant“
– le calcul si faux est : “normal“
Exo_fonction_SI_1

Cas de plusieurs SI imbriqués

Lorsque plusieurs conditions doivent être vérifiées,  la fonction SI pourra inclure


comme expression si vrai  ou expression si faux un calcul utilisant lui-même la fonction SI.

ici on souhaite vérifier si l’âge


saisi en cellule B2 est supérieur à 62 ans si c’est vrai on affiche “senior” et si c’est faux alors
on vérifie encore si l’âge est cependant supérieur à 18 ans et si c’est vrai alors on
affiche “adulte” sinon si c’est faux on affiche “enfant”

saisir dans la cellule C2 :  =SI(B2>62; “senior”;SI(B2>18; “adulte”; “enfant”))

– la condition 1 est : B2>62


– le calcul si vrai est : “senior”
– le calcul si faux est : SI(B2>18;“adulte”;“enfant”)
avec
– la condition 2 est : B2>18
– le calcul si vrai est : “adulte”
– le calcul si faux est : “enfant”

les fonctions ‘NB.SI’ , SOMME.SI’ et NBVAL


1- La fonction NB.SI

Elle permet de compter le nombre de cellules qui répondent à un critère ; par exemple,


pour compter le nombre de fois où une valeur apparaît dans une série de données.

Syntaxe : NB.SI(plage; critères)

saisir dans la cellule B6 :


=NB.SI(A2:A5; “pommes”)
ici on compte le nombre de cellules contenant « pommes » dans les cellules A2 à A5. Le résultat
est 2.

saisir dans la cellule B7 :  =NB.SI(A2:A5;A4)

Compte le nombre de cellules contenant « pêches » (à l’aide du critère dans A4) dans les cellules
A2 à A5. Le résultat est 1.

saisir dans la cellule B8 :  =NB.SI(B2:B5; “>55”)

Compte le nombre de cellules dont la valeur est supérieure à 55 dans les cellules B2 à B5. Le
résultat est 2.

Exo_fonction_NBSI_2

2- La fonction SOMME.SI

Elle permet de calculer la somme des valeurs d’une plage qui répond au critère spécifié.

Syntaxe : SOMME.SI(plage;critère;[somme_plage]) avec :

 la plage c’est la plage de cellules sur laquelle le critère sera calculé.


 le critère est calculé sur la plage
 La somme_plage  est facultative. Cellules réelles à ajouter, si la somme porte sur
d’autres cellules que celles qui sont spécifiées dans l’argument plage.

saisir dans la
cellule D11 :  =SOMME.SI(D2:D10;“>2000”;F2:F10)

ici on compte le nombre de bouteilles dont l’année est supérieure à l’an 2000. Le résultat est 18.
saisir dans la cellule D12 :  =SOMME.SI(F2:F10;“>6”)

on fait la somme des bouteilles de quantité >6, le résultat est 12.

saisir dans la cellule D13 :  =SOMME.SI(E2:E10;“>15”;F2:F10)

ici on compte le nombre de bouteilles dont l’age est > 15 ans.

saisir dans la cellule D14 :  =SOMME.SI(A2:A10;“Blanc”;F2:F10)

ici on compte le nombre de bouteilles de Blanc.

Exo_fonction_SOMMESI_2

3- la fonction ‘NBVAL’

La fonction NBVAL compte le nombre de valeurs (cellules non vides) dans une plage.

syntaxe : NBVAL(plagedevaleurs)

saisir dans la cellule A1 :  =NBVAL(A3:A6)

ici on compte le nombre d’élèves de la classe. Le résultat est 4.

Cette fonction est très utile lorsque on veut compter de longues listes de valeurs.

Nota : La fonction NBVAL ne compte pas les cellules vides.

Exo_fonction_NBVAL_1

les fonctions Moyenne, Ecartype et Mode


1- La fonction Moyenne

Elle sert à effectuer la moyenne des valeurs d’une série de données.

syntaxe : MOYENNE(plage de cellules)          


saisir dans la cellule B2 :  =MOYENNE(A2:A12)

ici on indique qu’on souhaite faire la moyenne des notes depuis A2 jusqu’à A12. Le résultat
est 11.
 

Exo_fonction_MOYENNE_1

2- La fonction Ecartype

Elle sert à calculer l’écart-type d’une plage de valeurs. L’écart-type est la zone autour de la
moyenne dans laquelle se situe la plupart des valeurs.

syntaxe : ECARTYPE(plage de cellules)      

saisir dans la cellule B2 :  =ECARTYPE(A2:A12)

ici on indique qu’on souhaite calculer l’écart-type des notes depuis A2 jusqu’à A12. Le résultat
est 4.

Exo_fonction_ECARTYPE_1

 
3- La fonction Mode

Elle sert à calculer l’élément le plus répandu dans une série de données.

syntaxe : MODE(plage de cellules)      

saisir dans la cellule B2 :  =MODE(A2:A12)

ici on indique qu’on recherche la note la plus fréquente sur la plage A2:A12. Le résultat est 8,
donc la note la plus répandue est 8.

Exo_fonction_MODE_1

Astuce : la formule =NB.SI(A2:A12;MODE(A2:A12)) permet de calculer combien de fois apparait


l’élément le plus répandu dans la liste. Le résultat est 3.

4- Rappel sur la courbe de Gauss

Bien souvent les séries de données suivent une courbe de Gauss, c’est à dire que :
 

68% des valeurs sont distribuées à + ou – un écart-type autour de la moyenne

95% des valeurs sont distribuées à + ou – 2 écart-types autour de la moyenne

Exo_courbe_Gauss

la fonction ‘RECHERCHEV’

Comment marche la fonction RECHERCHEV dans Excel ?

La fonction RECHERCHEV permet de rechercher des éléments dans un tableau ou une plage


par ligne.

syntaxe : RECHERCHEV(valeur_cherchée; table_matrice; no_index_col; “Faux”)

 table_matrice : plage de cellules dans laquelle la fonction recherche


la valeur_cherchée
 no_index_col  : numéro de colonne dans la table_matrice qui contient la valeur de retour
(la colonne la plus à gauche de table-matrice correspondant à 1)
Saisir
dans la cellule D11 : =RECHERCHEV(“Hautes-Alpes”;B2:D10;2;FAUX)
ici on indique la préfecture correspondant au numéro choisi. Le résultat est Gap.

Saisir dans la cellule D12 : =RECHERCHEV(3;A2:D10;2;FAUX)


indique le département à partir de son numéro (ici 3). Le résultat est Allier pour le numéro 3.

Saisir dans la
cellule D13 : =SI(RECHERCHEV(9;A2:D10;2;FAUX)=“Ariège”;“trouvé”;“introuvable”)
vérifie si le département ayant pour numéro 9 est effectivement “Ariège”. Le résultat
est trouvé.

Exo_fonction_RECHERCHEV_1

Astuce : L’argument FAUX signifie qu’on n’accepte pas d’approximation du résultat.


Il est systématiquement à ajouter à la fin de la fonction RECHERCHEV.

Autre exemple

Saisir dans la
cellule B9 : =RECHERCHEV(B8;B2:C6;2;FAUX)
Saisir dans la cellule B8 l’article (ex : C) dont on veut connaître le prix. Le résultat est 200.

Exo_fonction_RECHERCHEV_2
Les fonctions mathématiques : SOUS TOTAL
Descriptif : Renvoie un sous-total dans une liste ou une base de données.
Syntaxe : SOUS.TOTAL(no_fonction;réf1;réf2;...)
no_fonction représente le nombre compris entre 1 et 11 indiquant quelle fonction utiliser
pour calculer les sous-totaux.
réf1, réf2, ... représentent les plages sur lesquelles on veut calculer un sous-total.
Note : La fonction sous-total ne prend pas en compte les autres sous-totaux présents dans
une plage de calcul. Cela permet d'éviter les doubles comptages de valeurs. La fonction sous-
total présente un intérêt majeur lorsqu'elle est utilisée avec l'assistant Sous-Totaux. Nous
allons observer deux cas. Un cas de sous-total basique (pour expliquer le fonctionnement de
la fonction) et un cas plus avancé pour étudier le fonctionnement de l'assistant.

Exemple : Soit un tableau présentant le nombre de produits (A, B et C) vendu par personne
et par mois. Le tableau comporte une ligne par personne et par type de produit.

L'objectif est de calculer un sous-total par type de produit.

Aperçu du tableau :

Nous allons insérer une ligne entre la ligne 9 et la ligne 10 et y calculer notre sous-total. Le
calcul réalisé sera une somme (Il est important de bien trier les données avant de calculer le
sous-total. Dans notre cas, les données doivent être triées par type de produit).
Aperçu :

Les critères sont (pour la ligne 10) :


no_fonction : 9 (correspond à une somme, cf. tableau ci-dessus)
Réf1 : D3:D9

La formule sera :
=SOUS.TOTAL(9;D3:D9)

les opérations logiques ET, OU

Comment marche les fonctions logiques ET, OU dans Excel ?

1- Les conditions simples

Les conditions simples sont de la forme : A1 > 10, B1 = C1  …

Elles n’utilisent que 2 valeurs pour les comparer avec une opérateur de comparaison <, >, =,
<=,  >= et <>.
2- Les conditions complexes

Les conditions plus complexes utilisent des opérations logiques ET, OU etc, qui vont permettre
de combiner le résultat de plusieurs conditions.

Syntaxe : ET(condition 1;condition 2; …) ou OU(condition 1;condition 2; …)

Saisir dans la cellule D2 : =ET(B2>1,9;C2>95)

ici on teste les 2 conditions :  B2 > 1.90 et C2 > 105.


on affiche VRAI uniquement si et seulement si le résultat des 2 conditions est vrai sinon on
affiche FAUX.

Exo_fonction_ET_1

Autre exemple

Saisir dans
la cellule D2 : =SI(ET(B2=“M”;C2=“Maître”);“Bonjour Maître”; SI(ET(B2=“F”;C2=“Maître”);“Bonjour
Maîtresse”; “Bonjour l’élève”))

ici on teste les 2 conditions :  B2 = “M” et C2 = “Maître”.


si Vrai on affiche Bonjour Maître
sinon on teste les 2 conditions : B2 = “F” et C2 = “Maître”
si Vrai alors on affiche Bonjour Maîtresse sinon Bonjour l’élève

Exo_fonction_ET_2

Mise en forme conditionnelle Excel

Comment marche la mise en forme conditionnelle Excel ?

Présenter différemment selon les valeurs des données


La mise en forme conditionnelle (ou formatage conditionnel ) applique un format (ombrage
de cellule, couleur de police ou de cadre) automatiquement si une condition particulière est
remplie (dépendant de la valeur de la cellule).

La plupart des tableurs proposent de choisir interactivement :

 la condition qui sera testée parmi : est égal à, est supérieur à, est inférieur à …, la
valeur de comparaison à utiliser,
 et le style de formatage à utiliser – un style existant ou un nouveau style créé pour
l’occasion – quand la condition est vérifiée.

Plusieurs conditions et formats peuvent être saisis successivement. A l’affichage, selon la valeur
de la cellule, c’est le format correspondant à la première condition vérifiée, qui sera utilisé.

exemple sur Excel – télécharger le fichier : formatage conditionnel

Ce formatage a été obtenu avec Excel avec la fonction mise en forme conditionnelle de


l’onglet “accueil” obtenue à l’issue du paramétrage suivant :