Vous êtes sur la page 1sur 5

Packet Tracer 

: configuration de GRE Topologie

Tunneling fournit un mécanisme pour le transport de paquets d'un protocole à l'intérieur d'un autre
protocole. Le protocole qui est transporté est appelé protocole passager, et le protocole qui est
utilisé pour transporter le protocole passager est appelé protocole de transport.
Generic Routing Encapsulation (GRE) est un des mécanismes de tunneling qu'utilise IP comme
protocole de transport et peut être utilisé pour transporter différents protocoles. Les tunnels se
comportent comme des liens point à point virtuels qui ont deux extrémités identifiées comme tunnel
source et tunnel destination.

Table d'adressage

Masque de Passerelle par


Appareil Interface Adresse IP sous-réseau défaut

G0/0 192.168.1.1 255.255.255.0 N/A


RA S0/0/0 64.103.211.2 255.255.255.252 N/A
Tunnel 0 10.10.10.1 255.255.255.252 N/A
G0/0 192.168.2.1 255.255.255.0 N/A
RB S0/0/0 209.165.122.2 255.255.255.252 N/A
Tunnel 0 10.10.10.2 255.255.255.252 N/A
PC-A Carte réseau 192.168.1.2 255.255.255.0 192.168.1.1
PC-C Carte réseau 192.168.2.2 255.255.255.0 192.168.2.1

Objectifs
Partie 1 : vérification de la connectivité du routeur
Partie 2 : configuration de tunnels GRE
Partie 3 : vérification de la connectivité du PC

© 2017 Cisco et/ou ses filiales. Tous droits réservés. Ceci est un document public de Cisco. Page 1 sur 5
Packet Tracer : configuration de GRE

Scénario
Vous êtes l'administrateur réseau d'une entreprise qui souhaite installer un tunnel GRE vers un bureau
distant. Les deux réseaux sont configurés localement et n'ont besoin que du tunnel configuré.

Partie 1 : Vérification de la connectivité du routeur


Étape 1 : Envoi d'une requête ping de RB vers RA.
a. Utilisez la commande show ip interface brief sur RA pour déterminer l'adresse IP du port S0/0/0.
64.103.211.2
b. À partir de RB, envoyez une requête ping à l'adresse IP du port S0/0/0 de RA.

Étape 2 : Envoi d'une requête ping de PCA à PCB.


Essayez d'envoyer une requête ping à l'adresse IP de PCA à partir de PCB. Nous recommencerons ce test
après avoir configuré le tunnel GRE. Quels étaient les résultats des requêtes ping ? Pourquoi ?
Les requêtes ping ont échoué, car il n'existe aucune route vers la destination (tunnel pas encore configuré).

Partie 2 : Configuration de tunnels GRE


Étape 1 : Configuration de l'interface du tunnel 0 de RA.
a. Passez en mode de configuration pour le tunnel 0 de RA.
RA(config)# interface tunnel 0
b. Configurez l'adresse IP comme indiqué dans la table d'adressage.
RA(config-if)# ip address 10.10.10.1 255.255.255.252
c. Définissez la source et la destination des points d'extrémité du tunnel 0.
RA(config-if)# tunnel source s0/0/0
RA(config-if)# tunnel destination 209.165.122.2
d. Configurez le tunnel 0 de manière à transmettre le trafic IP sur GRE.
RA(config-if)# tunnel mode gre ip
e. L'interface du tunnel 0 devrait déjà être active. Si ce n'est pas le cas, traitez cette interface comme toute
autre.
RA(config-if)# no shutdown

Étape 2 : configuration de l'interface du tunnel 0 de RB.


Répétez les étapes 1a à e avec RB. Veillez à modifier l'adressage IP, selon le cas.
RB(config)# interface tunnel 0
RB(config-if)# ip address 10.10.10.2 255.255.255.252
RB(config-if)# tunnel source s0/0/0
RB(config-if)# tunnel destination 64.103.211.2
RB(config-if)# tunnel mode gre ip
RB(config-if)# no shutdown

© 2017 Cisco et/ou ses filiales. Tous droits réservés. Ceci est un document public de Cisco. Page 2 sur 5
Packet Tracer : configuration de GRE

Étape 3 : configuration d'une route pour le trafic IP privé.


Établissez une route entre les réseaux 192.168.X.X en utilisant le réseau 10.10.10.0/30 en guise de
destination.
RA(config)# ip route 192.168.2.0 255.255.255.0 10.10.10.2
RB(config)# ip route 192.168.1.0 255.255.255.0 10.10.10.1

Partie 3 : vérification de la connectivité du routeur


Étape 1 : envoi d'une requête ping de PCA à PCB.
Essayez d'envoyer une requête ping à l'adresse IP de PCA à partir de PCB. La requête ping devrait aboutir.

Étape 2 : traçage du chemin entre PCA et PCB.


Essayez de suivre le chemin de PCA à PCB. Notez l'absence d'adresses IP publiques dans les résultats.

Configurations des appareils

Routeur RA
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname RA
license udi pid CISCO2911/K9 sn FTX15242579
spanning-tree mode pvst
interface Tunnel0
ip address 10.10.10.1 255.255.255.252
tunnel source Serial0/0/0
tunnel destination 209.165.122.2
tunnel mode gre ip
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
interface Serial0/0/0
ip address 64.103.211.2 255.255.255.252
interface Serial0/0/1
no ip address
shutdown

© 2017 Cisco et/ou ses filiales. Tous droits réservés. Ceci est un document public de Cisco. Page 3 sur 5
Packet Tracer : configuration de GRE

interface Vlan1
no ip address
shutdown
ip classless
ip route 192.168.2.0 255.255.255.0 10.10.10.2
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
line con 0
line aux 0
line vty 0 4
login
end

Routeur RB
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
license udi pid CISCO2911/K9 sn FTX152497Z4
spanning-tree mode pvst
interface Tunnel0
ip address 10.10.10.2 255.255.255.252
tunnel source Serial0/0/0
tunnel destination 64.103.211.2
tunnel mode gre ip
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 209.165.122.2 255.255.255.252
!
interface Serial0/0/1
no ip address
shutdown
interface Vlan1
no ip address
shutdown
ip classless
ip route 192.168.1.0 255.255.255.0 10.10.10.1

© 2017 Cisco et/ou ses filiales. Tous droits réservés. Ceci est un document public de Cisco. Page 4 sur 5
Packet Tracer : configuration de GRE

ip route 0.0.0.0 0.0.0.0 Serial0/0/0


line con 0
line aux 0
line vty 0 4
login
end

© 2017 Cisco et/ou ses filiales. Tous droits réservés. Ceci est un document public de Cisco. Page 5 sur 5

Vous aimerez peut-être aussi