Vous êtes sur la page 1sur 3

Sciences Economiques – Semestre 3 – Cours d’Algorithmique

COURS ALGORITHMIQUE – PARTIE 2

SCIENCES ECONOMIQUES - SEMESTRE 3 – 2019/2020

A. DRISSI / A. ELOUARDIGHI
Sciences Economiques – Semestre 3 – Cours d’Algorithmique

IV- Les boucles :

La boucle Tant que :


Elle permet de répéter l’exécution d’un bloc d’instructions jusqu’à ce qu’une condition Cond (de type
booléen) devienne fausse.

TantQue Cond
instruction1

Instructionk
FinTantQue

Exemple : lecture d’une réponse jusqu’à ce que le résultat soit juste

Variable Rep en numérique


Début
Ecrire « Quelle est le résultat de la somme : 2 + 2 ? »
Lire Rep
TantQue Rep <> 4
Ecrire « Faux. Recommencez ! »
Lire Rep
FinTantQue
Ecrire « Juste. Bravo ! »
Fin

La boucle itérative :

Elle permet de répéter l’exécution d’un bloc d’instructions jusqu’à ce qu’un compteur Compt (de type
numérique) atteigne une valeur préalablement fixée.

Pour Compt ← début à fin


instruction1

Instructionk
FinPour

Exemple : affichage des carrées des chiffres allant de 1 à 9

Variable Compt, Var en numérique


Début
Pour Compt ← 1 à 9
Var ← Compt * Compt
Ecrire «le carré de », Compt, « est : », Var
FinPour
Fin

Remarque :
L’exemple précédant, peut être écrit en utilisant une boucle TantQue :
Variable Compt, Var en numérique
Début
Compt←1
TantQue Compt < 10
Var ← Compt * Compt
Ecrire «le carré de », Compt, « est : », Var
Compt← Compt + 1
FinTantQue
Fin
Sciences Economiques – Semestre 3 – Cours d’Algorithmique

Autres exemples :

1- algorithme qui affiche la table de multiplication d’un nombre choisi par l’utilisateur

Variables N, i en numérique
Debut
Ecrire "Entrez un nombre : "
Lire N
Ecrire "La table de multiplication de ce nombre est : "
Pour i ← 1 à 10
Ecrire N, " x ", i, " = ", n*i
FinPour
Fin

2- algorithme qui calcule la factorielle d’un nombre choisi par l’utilisateur

Variables N, i, F en numérique
Debut
Ecrire "Entrez un nombre : "
Lire N
F←1
Pour i ← 2 à N
F←F*i
FinPour
Ecrire "La factorielle est : ", F
Fin

Exercices :

1- Ecrire un algorithme qui demande 10 nombres positifs et qui détermine le plus grand d’entre eux et
l’affiche.

2- Ecrire un algorithme qui calcule la moyenne arithmétique de notes. L’algorithme demande le


nombre N de ces notes. Ensuite, il demande d’entrer les notes et affiche la moyenne.

3- Dans un magasin, on accorde une remise aux clients en fonction du total des produits achetés. On
note Som le total des achats avant remise.
Si Som<1000 alors la remise est nulle.
Si 1000<=Som<1500 alors la remise est de 10%.
Si 1500 <= Som alors la remise est de 15%.
Ecrire un algorithme qui demande au client d’entrer le nombre des produits qu’il a achetés, puis les
prix de ces produits. L’algorithme soit affiché le prix total des produits après application de la remise.