Vous êtes sur la page 1sur 6

Commandes Routage

Commandes de Configuration

Commande Exemple Fonction


Configuration et Adressage de l’ILC
Configuration de Base d’un Routeur
Router#config t
Router#config t
Router(config)#hostname Attribution d’un nom au Routeur
Router(config)#hostname R1
name
R1(config)#enable secret R1(config)#enable secret
Mot de Passe enable secret
password class
R1(config)#line console 0 R1(config)#line console 0
R1(config-line)#password R1(config-line)#password
Mot de Passe de Console
password cisco
R1(config-line)#login R1(config-line)#login
R1(config)#vty 0 4 R1(config)#vty 0 4
R1(config-line)#password R1(config-line)#password
Mot de Passe de Terminal Virtuel
password cisco
R1(config-line)#login R1(config-line)#login
R1(config)#banner motd # R1(config)#banner motd Configuration d’une Bannière du
message # #Authorized Access Only# Message du Jour
R1(config)#interface type R1(config)#interface fa0/1
number R1(config-if)#ip address
R1(config-if)#ip address 192.168.1.0
adresse_ip masque 255.255.255.0 Configuration d’une Interface
R1(config-if)#description R1(config-if)#description
description R1 LAN
R1(config-if)#no shutdown R1(config-if)#no shutdown

R1(config)#interface type R1(config)#interface


number se0/0/0 spécifier toute vitesse de
R1(config-if)# clock rate R1(config-if)# clock rate synchronisation valide
valeur 64000

Enregistrement des modifications


R1#copy running-config startup-config
apportées à un Routeur
Recharger le système de la
R1#copy startup-config running-config
Mémoire NVRAM

Fait par Souhaib EL BEJAOUI


Ancien Stagiaire à ISTICG Berrechid (Promotion 2009/2011)
Sauvegarder une copie de fichier
R1#copy running-config tftp de configuration sur un Serveur
TFTP
Utiliser une copie de fichier de
R1#copy tftp running-config configuration stocké sur un
Serveur TFTP
Supprimer le fichier de
R1#erase startup-config
configuration et redémarrer le
R1#reload
Routeur avec la commande reload

Configuration des Routes Statiques


Active l’historique du terminal.
R1(config)#ip route
Vous pouvez exécuter cette
adresse_ip masque R1(config)#ip route
commande en mode utilisateur ou
interface_sortie
en mode d’exécution privilégié

Protocole RIP version 1 (Routing Information Protocol)


Activation du Protocole RIP
R1(config)#router rip
R1(config)#router rip
R1(config-router)# network Active le processus de routage
R1(config-router)# network
directly-connected- RIP et lui associer un Réseau
192.168.13.0
classful-network-address

Interfaces passives
R1(config)#router rip R1(config)#router rip
R1(config-router)#passive- R1(config-router)#passive- Désactivation des mises à jour
interface type_number interface fa0/1

Propagation de la Route par défaut dans RIPv1


R1(config)#router rip Propagation d’une Route par
R1(config-router)#default-information originate défaut

Configuration du Routeur pour l’envoi et la réception des Paquets


Configure le logiciel afin qu’il
R1(config)#router rip
puisse recevoir et envoyer les
R1(config-router)#version 1|2
Paquets RIP Version 1 ou 2
R1(config)#int type_num R1(config)#int fa0/1 Configure une interface afin
R1(config-if)#ip rip send R1(config-if)#ip rip send qu’elle n’envoie uniquement des
vesrion 1 vesrion 1 des Paquets RIP Version 1
R1(config)#int type_num R1(config)#int fa0/1 Configure une interface afin
R1(config-if)#ip rip send R1(config-if)#ip rip send qu’elle n’envoie uniquement des
vesrion 2 vesrion 2 des Paquets RIP Version 2
R1(config)#int type_num R1(config)#int fa0/1 Configure une interface pour
R1(config-if)#ip rip send R1(config-if)#ip rip send envoyer des Paquets RIP Version

Fait par Souhaib EL BEJAOUI


Ancien Stagiaire à ISTICG Berrechid (Promotion 2009/2011)
vesrion 1 2 vesrion 1 2 1 ou 2
R1(config)#int type_num R1(config)#int fa0/1 Configure une interface pour
R1(config-if)#ip rip R1(config-if)#ip rip receive qu’elle ne reçoive uniquement que
receive vesrion 1 vesrion 1 des Paquets RIP Version 1
R1(config)#int type_num R1(config)#int fa0/1 Configure une interface pour
R1(config-if)#ip rip R1(config-if)#ip rip receive qu’elle ne reçoive uniquement que
receive vesrion 2 vesrion 2 des Paquets RIP Version 2
R1(config)#int type_num R1(config)#int fa0/1 Configure une interface pour
R1(config-if)#ip rip R1(config-if)#ip rip receive qu’elle puisse reçoive des Paquets
receive vesrion 1 2 vesrion 1 2 RIP Version 1 ou 2
configuration additionnelles
R1(config)#router rip Annoncer les routes statiques
R1(config-router)#redistribute static dans les mises à jour RIP

Protocole RIPv2
Activation de RIPv2
R1(config)#router rip Activation du Protocole RIP
R1(config-router)#version 2 version 2

Désactivation du Résumé Automatique dans RIPv2


Désactivation de résumé
R1(config)#router rip
automatique. Cette commande
R1(config-router)#no auto-summary
n’est pas disponible dans RIPv1

Protocole EIGRP
Configurer EIGRP de Base
R1(config)#router eigrp Identifier le Système Autonome
R1(config)#router eigrp 1
autonomous-system du Protocole EIGRP
R1(config)#router eigrp
R1(config)#router eigrp 1
autonomous-system
R1(config-router)#network Activer le Protocole EIGRP
R1(config-router)#network
172.16.0.0
network-address

Configuration de la Bande Passante


R1(config)#int type_num
R1(config)#int s0/0/0 modifier la mesure de bande
R1(config-if)#bandwidth
R1(config-if)#bandwidth 64 passante
valeur_kilobits

Désactivation du Résumé Automatique


R1(config)#router eigrp 1 Désactiver le résumé
R1(config)#no auto-summary automatique
Ajout de nouveaux Réseaux Locaux – Interface de Bouclage
R1(config)#interface R1(config)#int loopback 0 Ajout et configuration d’une

Fait par Souhaib EL BEJAOUI


Ancien Stagiaire à ISTICG Berrechid (Promotion 2009/2011)
type_number R1(config-if)#ip address interface de Bouclage
R1(config-if)#ip address 192.168.2.1
adresse_ip masque 255.255.255.0

Réglage du Protocol EIGRP


R1(config)#interface
type_number
R1(config)#interface int
R1(config-if)#bandwidth configurer le pourcentage de
s0/0/1
valeur bande passante pouvant être
R1(config-if)#bandwidth 64
R1(config-if)#ip utilisé par le protocole EIGRP sur
R1(config-if)#ip bandwidth-
bandwidth-percent eigrp une interface
percent eigrp 1 50
système_autonome
number_percent

Configuration des intervalles des Paquets Hello et des Temps d’Attente


R1(config)#interface
type_number
R1(config-if)#ip hello- R1(config)#interface s0/0/0
interval eigrp R1(config-if)#ip hello-
configurer un intervalle et un
système_autonome interval eigrp 1 60
Temps d’Attente Hello
number_secondes R1(config-if)#ip hold-time
R1(config-if)#ip hold-time eigrp 1 180
eigrp système_autonome
number_secondes

Protocole OSPF
Configuration de Base de OSPF
R1(config)#router ospf
R1(config)#router ospf 1 Activation du Protocole OSPF
système_autonome
R1(config)#router ospf
système_autonome R1(config)#router ospf 1
Router(config-Router)# Router(config-Router)# Configuration des sous-réseaux
network adresse_réseau network 172.16.1.16 OSPF
masque_générique area 0.0.0.15 area 0
area-id
ID de Routeur OSPF
R1(config)#router ospf remplace les adresses de
process-id bouclage et les adresses IP
R1(config-router)#router- d’interface physique pour la
id ip-address détermination des ID de routeur
R1(config)#interface R1(config)#interface
Configure l’adresse IP de
loopback number loopback 0
l’interface de Bouclage
R1(config-if)#ip address R1(config-if)#ip address

Fait par Souhaib EL BEJAOUI


Ancien Stagiaire à ISTICG Berrechid (Promotion 2009/2011)
ip-address masque 10.1.1.1 255.255.255.255
Modification du coût de la liaison
R1(config)#interface R1(config)#interface serial
type_number 0/0/0 spécifier directement le coût
R1(config-if)#ip ospf cost R1(config-if)#ip ospf cost d’une interface
valeur 1562
Priorité d’interface OSPF
R1(config)#interface
R1(config)#interface fa0/0
type_number Modification de la priorité de
Router(config-if)#ip ospf
Router(config-if)#ip ospf l’interface OSPF
priority 100
priority {0 - 255}
Réglage du Protocole OSPF
R1(config)#router ospf
R1(config)#router ospf 1
système_autonome
R1(config-router)# auto- Modification de la Bande
R1(config-router)# auto-
cost reference-bandwidth Passante de Référence
cost reference-bandwidth
10000
valeur (en Mbits/s)
R1(config)#interface
R1(config)#interface s0/0/0
type_number
Router(config-if)#ip ospf
Router(config-if)#ip ospf Modification des Minuteurs Hello
hello-interval 5
hello-interval seconds et Dead
Router(config-if)#ip ospf
Router(config-if)#ip ospf
dead-interval 20
dead-interval seconds

Fait par Souhaib EL BEJAOUI


Ancien Stagiaire à ISTICG Berrechid (Promotion 2009/2011)
Commandes de Vérification
Commandes Fonction
R1#show running-config
R1#show ip route Affiche le contenu de la Table de Routage
Affiche les Routes directement connectées
R1#show ip route connected
“C”
Affiche les entrées routant vers une
R1#show ip route address
destination particulière
R1#show ip interface brief
Vérifie l’état et les statistiques des
R1#show ip interfaces
interfaces
Affiche les protocoles de Routage utilisés
R1#show ip protocols
pour l’acheminement du trafic
affiche les mises à jour du routage RIP lors
R1#debug ip rip
de leur envoi et de leur réception
R1#show ip rip database
R1#show ip route rip Affiche les Routes RIP “R”
R1#show ip route igrp Affiche les Routes IGRP "I"
R1#show ip route static Affiche les Routes manuellement configurées
R1#clear counters Remettre les compteurs à zéro
R1#show cdp neighbors detail Affiche des infos sur les unites directement
connectées
R1#show controllers Détermine le type de câble connecté sans
avoir à l’inspecter

Fait par Souhaib EL BEJAOUI


Ancien Stagiaire à ISTICG Berrechid (Promotion 2009/2011)

Vous aimerez peut-être aussi