Vous êtes sur la page 1sur 39

TP3: Microsoft Excel

TP N°3: Microsoft Excel

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Fonctions avancées sous Excel

1. Utiliser les fonctions du tableur :


a- La fonction SI
b. Les fonctions NB.SI, SOMME.SI et NBVAL
c. Les fonctions MOYENNE, ECART-TYPE ET MODE
d. La fonction RECHERCHEV
e. les opérations logiques ET, OU
2. Le formatage conditionnel
3. Le contrôle de la saisie des données
4. Créer une base de données sous Excel

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 1 : La fonction SI

• La fonction SI sert à vérifier une condition et à faire un 1er calcul si c’est vrai et à
faire un autre calcul si c’est faux.
• La fonction SI comporte donc 3 parties :
 Une condition, qui doit pouvoir être calculée à partir d’autres cellules et donner
un résultat vrai ou faux. Exemples : A1 > 10, B1 = C1…
 Un 1er calcul au cas où la condition a donné la valeur : vrai,
 Un autre calcul au cas où la condition a donné la valeur : faux

Syntaxe : SI(<condition>;<calcul si vrai>;<calcul si faux>)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 01 : Fonction SI

1. Lancer un nouveau classeur (enregistrer sous Atelier01.xls).


2. Nommer la première feuille Fonction-Si.
3. Construire et compléter le tableau suivant :

Fonction Si
Ici on souhaite vérifier si l’âge
saisi en cellule B2 est supérieur
Prénom Age Catégorie
à 18 ans si c’est vrai on
affiche « adulte » et si c’est
Karim 45
faux alors on affiche autre.
Samira 65
Rachida 12
Nora 18
Ahmed 20 =SI(B2>18; “adulte“; “autre”)
Karim 70
Samira 51
Rachida 16
Nora 10

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 01 : Fonction SI Imbriquée

1. Dans le même classeur Atelier01.xls,créer une deuxième feuille nommée Fonction-Si-


Imbriquée.
3.Reprendre le même tableau.
Fonction Si Imbriquée
Maintenant, on souhaite vérifier
Prénom Age Catégorie si l’âge saisi en cellule B2 est
supérieur à 62 ans si c’est
Karim 45
vrai on affiche « senior » et si
Samira 65 c’est faux alors on vérifie
Rachida 12 encore si l’âge est cependant
Nora 18 supérieur à 18 ans et si c’est
Ahmed 20 vrai alors on
Karim 70 affiche « adulte » sinon si c’est
Samira 51 faux on affiche « enfant ».
Rachida 16
Nora 10

=SI(B2>62; “senior”;SI(B2>18; “adulte”;


“enfant”))

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 02 :les fonctions ‘NB.SI’ , SOMME.SI’ et NBVAL

1- La fonction NB.SI
Permet de compter le nombre de cellules qui répondent à un critère ; par exemple,
pour compter le nombre de fois où une valeur apparaît dans une série de données.

Syntaxe : NB.SI(plage; critères)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 02 : Fonction NB.SI

1. Lancer un nouveau classeur (enregistrer sous Atelier02.xls).


2. Nommer la première feuille Fonction-NB-Si.
3. Construire et compléter le tableau suivant :

ici on compte le nombre de cellules contenant


« pommes » dans les cellules A2 à A5.
ici on compte le nombre de cellules contenant
« pêches » dans les cellules A2 à A5.
=NB.SI(A2:A5; “pommes”) ici on compte le nombre de cellules dont la
valeur est supérieure à 55 dans les cellules B2 à
=NB.SI(A2:A5;A4) B5
=NB.SI(B2:B5; “>55”)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

2- La fonction SOMME.SI

Elle permet de calculer la somme des valeurs d’une plage qui répond au critère spécifié.

Syntaxe : SOMME.SI(plage;critère;[somme_plage])

Atelier 02 : Fonction SOMME.SI

1. Dans le même classeur Atelier02.xls,créer une deuxième feuille nommée Fonction-


SommeSi.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

1. Compter le nombre de bouteilles dont l’année est supérieure à l’an 2000.


2. Compter le nombre de bouteilles de quantité >6.
3. Compter le nombre de bouteilles dont l’âge est > 15 ans.
4. Compter le nombre de bouteilles blanches.

=SOMME.SI(D2:D10;“>2000”;F2:F10)

=SOMME.SI(F2:F10;“>6”)

=SOMME.SI(E2:E10;“>15”;F2:F10)

=SOMME.SI(A2:A10;“Blanc”;F2:F10)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

3- La fonction NBVAL

La fonction NBVAL compte le nombre de valeurs (cellules non vides) dans une plage.

Syntaxe : NBVAL(plagedevaleurs)

Atelier 02 : Fonction NBVAL

1. Dans le même classeur Atelier02.xls,créer une troisième feuille nommée Fonction-


NBVAL.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

1. Compter le nombre d’élèves de la classe.

=NBVAL(A3:A7)

Cette fonction est très utile lorsque on veut


compter de longues listes de valeurs.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 03 : Les fonctions MOYENNE, ECART-TYPE


ET MODE

1- La fonction MOYENNE

Sert à effectuer la moyenne des valeurs d’une série de données.

Syntaxe : MOYENNE(plage de cellules)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 03 : Fonction MOYENNE

1. Lancer un nouveau classeur (enregistrer sous Atelier03.xls).


2. Nommer la première feuille Fonction-Moyenne.
3. Construire et compléter le tableau suivant :
4. Calculer la moyenne des notes.

=MOYENNE(A2:A14)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

2- La fonction Ecartype

Sert à calculer l’écart-type d’une plage de valeurs. L’écart-type est la zone autour de la
moyenne dans laquelle se situe la plupart des valeurs.

Syntaxe : ECARTYPE(plage de cellules)

Atelier 03 : Fonction Ecartype

1. Dans le même classeur Atelier03.xls,créer une deuxième feuille nommée Fonction-


Ecartype.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

1. Calculer l’écart type des notes.

=ECARTYPE(A2:A14)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

3- La fonction Mode

Sert à calculer l’élément le plus répandu dans une série de données.

Syntaxe : MODE(plage de cellules)

Atelier 03 : Fonction Mode

1. Dans le même classeur Atelier03.xls,créer une troisième feuille nommée Fonction-


Mode.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

1. Recherche la note la plus fréquente sur la plage A2:A4.

=Mode(A2:A14)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 04 :la fonction ‘RECHERCHEV’

1- La fonction RECHERCHEV

Permet de rechercher des éléments dans une table ou une plage par ligne.

Syntaxe : RECHERCHEV(valeur_cherchée; table_matrice; no_index_col; “Faux”)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 04 :la fonction ‘RECHERCHEV’


1. Lancer un nouveau classeur (enregistrer sous Atelier04.xls).
2. Nommer la première feuille Fonction-Recherchev.
3. Construire et compléter le tableau suivant :

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 04 :la fonction ‘RECHERCHEV’


1. Chercher la préfecture correspondant au département 4.
2. Chercher le département correspondant au Numéro 3.
3. Tester si le département de N°9 est dép9

=RECHERCHEV("dép4";B2:D10;2;
FAUX)

=RECHERCHEV(3;A2:D10;2;FAUX)

=SI(RECHERCHEV(9;A2:D10;2;F
AUX)="dép9";"trouvé";"introuva
ble")

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 05 : Les opérations logiques ET, OU

1- Les conditions simples


Les conditions simples sont de la forme : A1 > 10, B1 = C1 …
Elles n’utilisent que 2 valeurs pour les comparer avec une opérateur de
comparaison <, >, =, <=, >= et <>.

2- Les conditions complexes


Les conditions plus complexes utilisent des opérations logiques ET, OU etc, qui vont
permettre de combiner le résultat de plusieurs conditions.
Syntaxe : ET(condition 1;condition 2; …) ou OU(condition 1;condition 2; …)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 05 : Les opérations logiques ET, OU

1. Lancer un nouveau classeur (enregistrer sous Atelier05.xls).


2. Nommer la première feuille Opérateurs-et-ou.
3. Construire et compléter le tableau suivant :

=SI(ET(B2="M";C2="Prof");"B
onjour
Formateur";SI(ET(B2="F";C2="
Prof");"Bonjour
Formatrice";"Bonjour
Stagiaire"))

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 06 : Le formatage conditionnel

Le formatage conditionnel consiste à attribuer à une cellule ou à un ensemble de


cellules un formatage qui dépende de la valeur de cette ou ces cellules.
La plupart des tableurs proposent de choisir interactivement :
 la condition qui sera testée parmi : est égal à, est supérieur à, est inférieur à …, la
valeur de comparaison à utiliser,
 et le style de formatage à utiliser – un style existant ou un nouveau style créé pour
l’occasion – quand la condition est vérifiée.
Plusieurs conditions et formats peuvent être saisis successivement. A l’affichage, selon la
valeur de la cellule, c’est le format correspondant à la première condition vérifiée, qui
sera utilisé.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 06 : Le formatage conditionnel

1. Lancer un nouveau classeur (enregistrer sous Atelier06.xls).


2. Nommer la première feuille formatage-conditionnel.
3. Construire et compléter le tableau suivant :

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 06 : Le formatage conditionnel

1. Dans la colonne Etat, afficher l’état payé une fois la date de paiement est saisie,
afficher l’état impayé dans le cas contraire,

2. Définir la mise en forme conditionnelle suivante.


• Impayé  Remplissage en rouge.
• Payé  Remplissage en vert.

=SI(F8="";"impayé
";"payé")

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 06 : Le formatage conditionnel

1. Dans le même classeur Atelier06.xls,créer une deuxième feuille nommée formatage-


conditionnel2.
2. Construire et compléter le tableau ci-dessous.
3. Changer le type de la colonne délai de paiement par : 0\ "jours" et la colonne date
d’envoi par date.
4. Afficher les retards de paiement en fonction de la date du jour : Remplissage en vert.
(Mise en forme conditionnelle  Nouvelle règle Utiliser une formule pour déterminer
pour quelles cellules le format sera appliqué.

=AUJOURDHUI()-$F7>$G7

Date d’envoi Délai de paiement

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 07 : Le contrôle de la saisie des données

La validation des données est une fonctionnalité Excel qui permet de contrôler
le type de données et les valeurs que les utilisateurs saisissent dans une cellule ou plage
de cellules.
Par exemple, vous pouvez souhaiter :
1. Vous assurer que seuls des nombres entiers ou décimaux soient saisis
2. Limiter les choix disponibles en utilisant une liste des valeurs autorisées
3. Restreindre la saisie des données à une certaine plage de dates ou d’heures
4. Imposer que le texte saisi fasse une certaine longueur de caractères
5. Imposer que les valeurs saisies soient comprises entre un min et un max

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 07 : Le contrôle de la saisie des données


1. Lancer un nouveau classeur (enregistrer sous Atelier07.xls).
2. Nommer la première feuille contrôle-saisie.
3. Construire et compléter le tableau suivant en limitant la saisie de la colonne filière à
une liste de valeurs définies dans la plage de cellules F6:F10.

Liste
déroulante

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel

Atelier 08 : Créer une base de données sous Excel

1. Lancer un nouveau classeur (enregistrer sous Atelier08.xls).


2. Nommer la première feuille BD.
3. Créer une base de données contenant comme entêtes des noms et prénoms, date de
naissance, filière.
4. Remplir les notes pour deux contrôles et les dates de naissances, comprises entre 96 et
99.
5. Indiquer en bas de la colonne : note maximale, moyenne, note minimale pour chacun
des contrôles.
6. Créer une colonne moyenne qui pondère le premier contrôle par 1, le second par 2.
7. Trier votre base de données par ordre alphabétique de A à Z (Noms des stagiaires).
8 . Filtrer vos données par filière.

Excel est un outil très puissant pour analyser des données. Les fonctionnalités de tri et de
filtre font partie des plus fréquemment utilisées à cet effet.
• Pour modifier l’ordre de vos données, vous pouvez les trier.
• Pour vous focaliser sur un ensemble de données particulier, vous pouvez filtrer une
plage de cellules ou une table.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 09 :

1. Lancer un nouveau classeur (enregistrer sous Atelier09.xls).


2. Nommer la première feuille Mon-premier-tableur.
3. Construire et compléter le tableau suivant :

Notes d'Informatique

Noms des Contrôles


N° Filière Somme Moyenne
élèves
Contrôle 1 Contrôle 2 Contrôle 3
1 Karim SEO 12 10 15
2 Samira SPV 16 19 13
3 Rachida SST 17 18 14
4 Nora EEB 6 10 12
5 Ahmed SEO 15 12 10
6 Karim SPV 8 12 11
7 Samira SST 9 10 11
8 Rachida EEB 11 15 16
9 Nora SEO 12 14 19

Note maximale
Note minimale
Mme. ZROURI Amira Ingénieur d’état en Informatique
TP3: Microsoft Excel
Atelier 09 :

4. Ajouter une colonne résultat contenant soit la valeur Admis ou Refusé selon la
moyenne.

Utiliser la fonction SI ==> =SI (d2<10;"refusé";"Admis")

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 10 :

1. Lancer un nouveau classeur (enregistrer sous Atelier10.xls).


2. Nommer la première feuille Ma-première-facture.
3. Construire et compléter le tableau suivant :

Factures

Prix
N° Désignation Quantité P.H.T
Unitaire

Article 1 Disque dur 8 900


Article 2 Souris 12 82
Article 3 Clavier 16 130
Article 4 Carte Mère 10 700 à
Article 5 Ecran 16 650
Article 6 Unité Centrale 3 450
Article 7 Clé USB 20 250
Article 8 Scanner 18 500 Total H.T
Article 9 Imprimante 12 550 TVA
Total T.T.C

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 10:

Indications :

Calcul des formules :

 PHT=Prix unitaire * Quantité


 TOTAL HT=Somme des PUT
 TVA=Total HT * 20%
 TOTAL TTC=Total HT + TVA

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 11:

1. Lancer un nouveau classeur (enregistrer sous Atelier11.xls).


2. Nommer la première feuille Facture.
3. Dans cette feuille, construire et compléter le tableau suivant :
Factures

Désignation Quantité Prix Unitaire Montant

Produit1 8 900
Produit2 12 82
Produit3 16 130
Produit4 10 700
Produit5 16 650
Produit6 3 450
Produit7 20 250
Produit8 18 500 Min Montant
Produit9 82 870
Max Montant
Produit10 12 550
Moyenne

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 11:

Renseignements Complémentaires:

• Pour changer la bordure du tableau :

Sélectionner le tableau  Bouton droit Format de la cellule / Bordures.

• Pour régler la largeur des colonnes:

Sélectionner les colonnes  Bouton droit Largeur des colonnes (15,00).

• Pour changer la bordure du tableau :

Sélectionner le tableau  Bouton droit Format de la cellule / Bordures.

3. Compléter le tableau.

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 12:
1. Lancer un nouveau classeur (enregistrer sous Atelier12.xls).
2. Nommer la première feuille Fonctions-Avancées.
3. Construire et compléter le tableau suivant :
STATISTIQUES DE VENTES
Département Montant vente
Nombre de Montant
Financier 1 500,00 €
Industriel 200,00 €
Département Ventes Total
Direction des projets 3 620,00 € Financier
Qualité 2 500,00 € Industriel
Direction des achats 6 200,00 € Direction des projets
Formations 3 600,00 € Qualité
Direction des achats
Ressources humaines 1 400,00 € Formations
Financier 1 900,00 €
Ressources humaines
Industriel 1 500,00 €
Qualité 200,00 €
Direction des achats 1 500,00 €
Formations 200,00 €
Ressources humaines 1 500,00 €
Total des ventes

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 12:

1. Calculer le total des ventes.


2. Dans le tableau 2 ,calculer le nombre de ventes par département.
• La syntaxe générale est la suivante : =NB.SI(plage_de_cellules;critère)
• NB.SI(A3:A16;A3) avec A3 « financier », A16;A3 « financier : ressources
humaines »

3. Dans la colonne Montant Total Calculer le montant de vente par département en


utilisant la Fonction SOMME.SI.
• La syntaxe générale est la suivante :
=SOMMME.SI(plage_de_cellules;critère;plage_à_totaliser)
• SOMME.SI(tableau;" financier ";$B$3:$B$18)

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 12:

1. Dans le même classeur, nommer la deuxième feuille Mon- deuxième -tableur.


2. Dans cette feuille, construire et compléter le tableau suivant :

Mme. ZROURI Amira Ingénieur d’état en Informatique


TP3: Microsoft Excel
Atelier 12:
3. Appliquer les mises en forme suivantes :
• Titre principal : Centré par rapport au tableau, Rouge, 16, police Times New
Roman.
• Libellés : Centré, Rose, 10,
• Le reste : Centré, Bleu foncé,
• Format de la cellule Prix unitaire : Monétaire, 3 chiffres après la virgule, symbole
MAD
• Appliquer les mêmes mises en forme des cellules pour les colonnes Total HT
Sem1, Total HT Sem 2, Montant TVA et Total

4. Compléter le tableau en utilisant les formules suivantes :


• Total HT Semestre 1 = Prix unitaire * Ventes Semestre 1
• Total HT Semestre 2 = Prix unitaire * Ventes Semestre 2
• Montant TVA = (Total HT Semestre 1 + Total HT Semestre 2) * 20%
• Total = Total HT Semestre 1 + Total HT Semestre 2 + Montant TVA
• Totaux = Total de chaque vente
• Meilleures Ventes = Maximum (Total)

5. Présenter le tableau tel qu’il est (bordure).


6. Représenter graphiquement en secteurs les Prix unitaire en fonction des Articles.

Mme. ZROURI Amira Ingénieur d’état en Informatique