Vous êtes sur la page 1sur 33

Mise en œuvre de la

qualité de service
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Sommaire
I Mise en œuvre de la QoS au niveau de la couche 2...........................................................3
Introduction........................................................................................................................3
Schéma d'une liaison téléphonique...................................................................................3
Étape 1 Mettre en place le réseau.....................................................................................4
Étape 2 Configuration des hôtes reliés au commutateur..................................................5
Étape 3 Vérification de la connectivité entre poste...........................................................6
Étape 4 configuration du commutateur et de l'adaptateur.................................................6
Étape 5 Vérification de la connectivité...............................................................................7
Étape 6 Configuration du routeur......................................................................................8
Étape 7 Vérification de fonctionnement des téléphones.................................................11
Schéma d'une liaison téléphonique IP............................................................................13
Lien avec le protocole TCP et RTP.................................................................................14
Étape 8 Ajout et configuration d'un nouveau téléphone IP..............................................15

II Mise en œuvre de la QoS au niveau de la couche 3........................................................17


Schéma d'un réseau clients serveur....................................................................................17
Plan d'adressage..................................................................................................................18
Etape 1 Configurations des machines.............................................................................18
Étape 2 Vérification de la connectivité.............................................................................19
Etape 3 Activation du serveur WEB.................................................................................21
Etape 4 Activation du QoS sur le routeur........................................................................22
Etape 5 Générer un trafique WEB et vérifications du marquage....................................24
Etape 6 Repérage graphiquement de l'application stratégique......................................25
Etape 7 Répartir la bande passante avec Low Latence Queuing (LLQ).........................26

Conclusion.......................................................................................................................33

2/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

I Mise en œuvre de la QoS au niveau de la couche 2

Introduction

Avec Packet Tracer (simulateur réseau) nous allons voir comment fonctionne le QoS (Quality of
Service) définit sur un commutateur, au niveau de la couche 2 (liaison de données, exemple :
Ethernet) et la couche 3 (réseau, exemple : IP), puisque la qualité de service est assuré au niveau de
c'est deux couches.
Le QoS ne s’arrête pas qu'au qualité de service. En effet, car il permet aussi de définir les priorités
sur les trafics tel que l'http, circulant dans le réseau.

Schéma d'une liaison téléphonique

3/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Étape 1 Mettre en place le réseau

Dans un premier temps pour commencer, on réalise le réseau virtuellement avec Packet Tracer.

Affectation des ports du commutateur

FastEthernet 0/1 IP Phonr0


FastEthernet 0/2 PC1
FastEthernet 0/3 Router0
FastEthernet 0/4 IP Phone1
FastEthernet 0/5 Home VoIP0

4/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Étape 2 Configuration des hôtes reliés au commutateur

On configure les hôtes pour qu'il puissent faire partie théoriquement du réseau.

Attribution d'adresse IP pour l'hôte 0 :

puis pour l'hôte 1, la même manipulation est nécessaire.

Maintenant, on va configurer l'adaptateur relié au téléphone car ce dernier étant analogique, il ne


peut pas avoir d'adresse IP :

5/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Étape 3 Vérification de la connectivité entre poste

Test de PC0 (hôte 0) vers PC1 (hôte 1)

Test de PC1 (hôte 1) vers PC0 (hôte 0)

Comme démontré dans les images ci-dessus, on voit bien que nos deux hôtes peuvent communiqués
entre.

Étape 4 configuration du commutateur et de l'adaptateur

Sur le mode console du commutateur, on configure les ports Fastethernet 0/1 - 2 – 4 et 5.

Configuration de l'interface 0/1 :

Switch(config)#interface fastEthernet 0/1


Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport voice vlan 1
Switch(config-if)#mls qos trust device cisco-phone
Switch(config-if)#exit

6/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Configuration de l'interface 0/4 et 5:

Switch(config)#interface range fastEthernet 0/4 - 5


Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport voice vlan 1
Switch(config-if-range)#exit

Configuration de l'interface 0/2 :

Switch(config)#interface fastEthernet 0/2


Switch(config-if)#switchport mode access
Switch(config-if)#exit

Nous pouvons voir avec la syntaxe cisco show mls qos interface fa0/1 , que la QoS affiche bien
cisco-phone :

Switch#show mls qos interface fastEthernet 0/1

FastEthernet0/1
trust state: not trusted
trusted mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map

Trust device: cisco-phone

qos mode: port-based

Étape 5 Vérification de la connectivité

Test de PC0 (hôte 0) vers PC1 (hôte 1)

7/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Test de PC1 (hôte 1) vers PC0 (hôte 0)

Pour le moment les deux hôtes arrivent toujours à se joindre.

Étape 6 Configuration du routeur

Tout d'abord, on va attribuer au routeur sa passerelle interne (qui se trouve dans notre réseau).

Ensuite, nous allons nous intéresser au serveur DHCP puisque ce dernier va attribuer une adresse IP
automatiquement à nos téléphones. Pour ce faire, on va configurer la passerelle interne du routeur
pour qu'elle puisse faire office de DHCP.

Avec ip dhcp pool (nom de la zone), le routeur fera office de DHCP.


La commande suivante (network (adresse IP) (masque)), pour définir le réseau.
Puis les commandes qui suivent vont nous permettre de préciser au routeur qu'il doit attribuer une
adresse IP (puisqu'il est DHCP) au téléphones en passant par cette interface, dont la source de cette
conséquence est l'option 150.

8/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Nous allons maintenant configurer le service téléphonique du routeur. Dans un premier temps, on va
noter l'adresse MAC pour chaque téléphone.

IP Phone 0 : 00.01.C7.1B.D1.B7
IP Phone 1 : 00.02.CA.E6.E5.8D
Home VoIP0 : 00.09.7C.98.BD.01

Une fois les adresse MAC récupéré, on configure le service téléphonique.

On entre dans la configuration téléphonique


Router(config)#telephony-service

On déclare le nombre maximum de téléphones


Router(config-telephony)#max-ephones 3

On déclare le nombre maximum de numéro q'un téléphone peut avoir


Router(config-telephony)#max-dn 3

On indique le serveur (son adres IP et le port utilisé)


Router(config-telephony)#ip source-address 192.168.10.1 port 2005

On déclare le rang que le serveur DHCP pourra attribuer d'adresse IP


Router(config-telephony)#auto assign 1 to 5

Dans cette partie, on entre simplement dans le téléphone voulue puis on


lui attribut son numéro d'appel

Router(config)#ephone-dn 1
Router(config-ephone-dn)#number 1001
Router(config-ephone-dn)#exit

Router(config)#ephone-dn 2
Router(config-ephone-dn)#number 1005
Router(config-ephone-dn)#exit

Router(config)#ephone-dn 3
Router(config-ephone-dn)#number 1010
Router(config-ephone-dn)#exit

9/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Comme le résultat nous l'indique, les trois téléphones ont bien reçut
leur adresse IP et par al suite enregistrer sur le serveur DHCP.

IP Phone1
%IPPHONE-6-REGISTER: ephone-1 IP:192.168.10.3 Socket:2 DeviceType:Phone
has registered.

Home VoIP0
%IPPHONE-6-REGISTER: ephone-2 IP:192.168.10.2 Socket:2 DeviceType:Phone
has registered.

IP Phone0
%IPPHONE-6-REGISTER: ephone-3 IP:192.168.10.4 Socket:2 DeviceType:Phone
has registered.

On peut tout de même vérifier l'enregistrement des téléphones via la commande show suivie de la
syntaxe dédier aux téléphones :

Router#show running-config

....

ephone 1
device-security-mode none
mac-address 0001.C71B.D1B7
type 7960
button 1:2
!
ephone 2
device-security-mode none
mac-address 0009.7C98.BD01
type ata
button 1:3
!
ephone 3
device-security-mode none
mac-address 0002.4AE6.E58D
type 7960
button 1:1

....

Si le résultat de la commande show nous indiques nos 3 edphone, alors les téléphones sont
enregistrés.

10/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Étape 7 Vérification de fonctionnement des téléphones

On va commencer par noter les adresses IP et numéros des téléphones.

Il se peut que les adresse IP ont était changer à cause du redémarrage du routeur.

IP Phone0

IP Phone1

11/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Home VoIP

Puis on va tester la connectivité entre le routeur et les trois téléphones. Donc à partir du routeur on
applique un ping :

Router#ping 192.168.10.4

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.10.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

Router#ping 192.168.10.3

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.10.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/2 ms

Router#ping 192.168.10.2

Type escape sequence to abort.


Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/8/18 ms

12/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Pour chaque téléphone, le routeur arrive bien à les joindre et ce qui prouve qu'ils ont bien reçu leur
adresse IP.

Notre teste de maintenant, va ce centrer sur le téléphone IP Phone0 et IP Phone1. Donc le but est
que l'IP Phone0 puisse joindre l'IP Phone1.

Schéma d'une liaison téléphonique IP

13/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Lien avec le protocole TCP et RTP

Dans un premier temps, le protocole de transport TCP (Transmission Control Protocol) va permettre
à l'IP Phone0 de joindre le commutateur puis le routeur (office de serveur DHCP) tout en assurant la
transmission des packets.

Ensuite, le routeur va répondre au téléphone (IP Phone0) dans le sens inverse, pour lui confirmer
qu'il est bien enregistré.

Par la suite l'IP Phone0 va pouvoir essayer de joindre l'IP Phone1 en envoyant une requête au
serveur DHCP. Et donc ce dernier va permettre la liaison entre eux.

Et en dernière étape , le RTP (Real-time Transport Protocol) qui permet le transport de données en
temps réel. Va simplement permettre de transporter les packets de façon répétitive jusqu'à la fin de
la conversation entre les téléphones.

14/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Étape 8 Ajout et configuration d'un nouveau téléphone IP

On va supposer qu'un nouvelle agent de l'infrastructure à besoin d'un téléphone. Donc le principe et
le même, on va simplement configurer le port (où le nouveau téléphone est relié) du commutateur,
puis déclarer le nouveau téléphone (IP Phone2) sur le routeur (on tant que serveur DHCP).

On commence par configurer le port 6 du commutateur (puisque c'est ici


qu'est relié l'IP Phone2
Switch#configure terminal
Switch(config)#interface fastEthernet 0/6
Switch(config-if)#switchport voice vlan 1
Switch(config-if)#end

Ensuite, on déclare qu'il y aura non pas 3 mais 4 maximum de téléphones


Router#configure terminal
Router(config)#telephony-service
Router(config-telephony)#max-ephones 4
Router(config-telephony)#max-dn 4
Router(config-telephony)#exit

Et enfin, on lui ajoute son numéro (donc le 1011)


Router(config)#ephone-dn 4
Router(config-ephone-dn)#number 1011
Router(config-ephone-dn)#end

Réponse du routeur : IP Phone2 est bien enregistré


%IPPHONE-6-REGISTER: ephone-4 IP:192.168.10.5 Socket:2 DeviceType:Phone
has registered.

Le DeviceType nous indique bien que le téléphone IP Phone2 est enregistré.

On peut éventuellement faire un show suivie de sa syntaxe pour avoir la certitude :

Router# show running-configuration


...

ephone-dn 4
number 1011

15/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

!
ephone 1
device-security-mode none
mac-address 0001.C71B.D1B7
type 7960
button 1:2
!
ephone 2
device-security-mode none
mac-address 0009.7C98.BD01
type ata
button 1:3
!
ephone 3
device-security-mode none
mac-address 0002.4AE6.E58D
type 7960
button 1:1
!

ephone 4
device-security-mode none
mac-address 000C.8592.EC4D
type 7960
button 1:4

...

Pour finir, on vérifie que notre téléphone a bien son adresse IP dans Packet Tracer.

16/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Ainsi que son numéro :

II Mise en œuvre de la QoS au niveau de la couche 3

Schéma d'un réseau clients serveur

17/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Plan d'adressage

Machines Adresse IP Masque de sous réseau


PC0 192.168.1.1 255.255.255.0
PC1 192.168.1.2 255.255.255.0
PC2 192.168.1.3 255.255.255.0
PC3 192.168.1.4 255.255.255.0
PC4 192.168.2.2 255.255.255.0
Serveur0 192.168.2.1 255.255.255.0
Routeur0-FA 0/0 192.168.2.254 255.255.255.0
Routeur0 FA 0/1 192.168.1.254 255.255.255.0

Etape 1 Configurations des machines

Pour débuter cette deuxième partie, nous allons configurer chaque hôtes ainsi que le serveur et le
routeur. Puisque le but dans un premier temps, étant la communications entre eux.

Configuration IP du PC0 (hôte 0) :

Concernant les autres PC (PC1, 2 et 3) et le Serveur0, la manipulation est exactement la même juste
ils n'auront pas la même IP et la passerelle.

18/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Configuration du Routeur :

Nommage du Routeur
Router#configure terminal
Router(config)#hostname Routeur0

Attribution d'adresse IP pour l’interface 0/0


Routeur0(config)#interface fastEthernet 0/0
Routeur0(config-if)#ip address 192.168.2.254 255.255.255.0
Routeur0(config-if)#no shutdown
Routeur0(config-if)#exit

Attribution d'adresse IP pour l’interface 0/0


Routeur0(config)#interface fastEthernet 0/1
Routeur0(config-if)#ip address 192.168.1.254 255.255.255.0
Routeur0(config-if)#no shutdown
Routeur0(config-if)#exit

Étape 2 Vérification de la connectivité

Pour commencer, après avoir configuré l'adresse IP des hôtes ainsi que le serveur du réseau. Nous
allons tester ces derniers, pour vérifier si les communications du réseau 192.168.1.0 /24
fonctionnent. On appliquant le protocole ICMP (envoie d'un ping).

Configuration IP du PC0, et envoie d'un pingà partir de PC0 vers le PC1 :

lien opérationnelle !

19/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Ensuite, envoie de plusieurs autre ping vers PC2 et PC3 :

lien également opérationnelle !

Maintenant , nous allons tester les communications du réseau 192.168.2.0 /24. Donc pour vérifier si
le PC4, le Serveur0 et l'interface (appartenant à ce réseau) du routeur peuvent communiquer entre
eux.

Envoie d'une requête ping à partir de PC4 vers le Serveur0, puis la passerelle du routeur :

Lien opération concernant ce réseau.

20/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Et enfin, nos testes vont ce finir par la communication entre PC0 (appartenant au réseau
192.168.1.0) et le Serveur0 (appartenant au réseau 192.168.2.0).

La connectivité entre les feux réseau est positive !

Etape 3 Activation du serveur WEB

Nous allons activer le service http dans l'onglet de configuration du serveur (bien entendue sur
Packet tracer).

21/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Après sur l'onglet Desktop, il faut cliquer sur Web Browser pour simuler démarrer le moteur
graphique HTML de Packet tracer.

Ensuite, une fois que l'on a saisie l'adresse IP du serveur, on aperçoit que l'on accède bien à la page
par défaut du Serveur0 :

Etape 4 Activation du QoS sur le routeur

Pour pouvoir appliquer le QoS au niveau de la couche 3, il est nécessaire d'apporter des
modifications au routeur puisque ce dernier s'occupe de la couche 3 du modèle TCP/IP.

22/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Donc sur le routeur en mod configuration globale

Routeur0>enable
Routeur0#configure terminal

Nous allons créer une class-map qui se nommera critique et qui visera le protocole http. Pour faire
simple, nous allons simplement définir le trafic émanant du protocole HTTP en priorité 7.

Routeur0(config)#class-map match-all critique


Routeur0(config-cmap)#match protocol http
Routeur0(config-cmap)#exit

Routeur0(config)#policy-map markingpolicy
Routeur0(config-pmap)#class critique
Routeur0(config-pmap-c)#set precedence 7
Routeur0(config-pmap-c)#end

Après cette configuration, on va appliquer la stratégie nommée markingpolicy sur l'interface 0/0.

(config-if)#service-policy input markingpolicy

Et enfin, on vérifie notre stratégie sur l'interface 0/0 :

Routeur0#show policy-map interface fastEthernet 0/0

FastEthernet0/0
Service-policy input: markingpolicy
Class-map: critique (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol http
QoS Set
precedence 7
Packets marked 0

Class-map: class-default (match-any)


0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

On aperçoit bien que notre stratégie est active même si pour le moment aucun trafic n'a était
marqué.

23/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Etape 5 Générer un trafique WEB et vérifications du marquage

Avant d’enchaîner cette étape, nous allons essayer d'afficher en http la page Web du serveur0 à parti
du PC0.

On aperçoit bien que le PC0 appartenant au réseau 192.168.1.0, traverse le routeur pour envoyer
une requête http du serveur0 appartenant au réseau 192.168.2.0 qui lui répond. Et donc on peut
afficher la page Web sans problème.

On appliquant un show suivie de la syntaxe approprié dans le Routeur0, on remarque que la


stratégie à bine était marqué et donc le routeur à comprit que le paquet en question ayant le
protocole http, devait être inscrit sur la stratégie.

24/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Etape 6 Repérage graphiquement de l'application stratégique

Nous allons établir un teste graphique pour voir comment notre stratégie QoS s'applique après le
trafique TCP.

Après que le trafique TCP à était transmis au Serveur0 puis retransmis (comme réponse) au PC0.
Le trafique HTTP (enveloppe de couleur violette) débute avec le PC0 :

Une fois que le trafique HTTP à était transmis à partir du PC0 vers le Serveur0, ce dernier répond
au PC0 en renvoyant donc ce même trafique. Cependant, le trafique sera marqué au moment il
traversera le Routeur sur sa passerelle FastEthernet 0/0 (correspondant à l'interface configurée
précédemment).

D'où l'enveloppe violette marqué en vert :

25/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Etape 7 Répartir la bande passante avec Low Latence Queuing


(LLQ)

Dans cette partie, nous allons répartir la bande passante en quatre pourcentage. Pour le trafic http
40 % sera déclaré, 20 % pour le trafic icmp, 15 % pour le protocole de routage rip et 25 % pour le
reste (tcp, …).

Dans le routeur, nous allons dans un premier temps, supprimer les anciennes configurations liées au
QoS :

Routeur0#configure terminal

Routeur0(config)#no class-map critique


% Class-map critique is being used
À ce moment là, on remarque que le routeur nous répond, qu'il ne peut pas
supprimer la stratégie critique.
Routeur0(config)#exit

Pour cela, nous allons essayer de voir qu'elle est la politique qui utilise
notre stratégie.
Routeur0#show policy-map
Policy Map markingpolicy
Class critique
set precedence 7

Une fois prit connaissance de la politique (même si l'on sait de base que
c'est markingpolicy, puisqu'elle est la seul), on supprime cette dernière.
Routeur0#configure terminal
Routeur0(config)#no policy-map markingpolicy
Routeur0(config)#exit

On vérifie si elle est bien supprimée.


Routeur0#show policy-map markingpolicy

Puis on essaye encore une fois de supprimer la stratégie critique.


Routeur0#configure terminal
Routeur0(config)#no class-map critique
Routeur0(config)#exit
On aperçoit que cette fois si, le routeur ne répond pas. Donc on sous entend
qu'elle n'est plus utilisé.

Et enfin, on établie un show au niveau de l'interface 0/0 pour confirmer que


la politique a était supprimée.
Routeur0#show policy-map interface fastEthernet 0/0

26/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Maintenant, nous allons créer trois stratégies désignant le protocole HTTP, ICMP et le protocole
RIP. Puisque se sont c'est trois protocoles qui doivent partager la bande passante.

Routeur0#configure terminal

Création de la stratégie trafhttp


Routeur0(config)#class-map match-all trafhttp
Routeur0(config-cmap)#match protocol http
Routeur0(config-cmap)#exit

Création de la stratégie traficmp


Routeur0(config)#class-map match-all traficmp
Routeur0(config-cmap)#match protocol icmp
Routeur0(config-cmap)#exit

Création de la stratégie trafrip


Routeur0(config)#class-map match-all trafrip
Routeur0(config-cmap)#match protocol rip
Routeur0(config-cmap)#exit

Ensuite on peut appliquer un show, pour voir si nos stratégie (class-map) ont bien étaient déclarées

Routeur0#show class-map
Class Map match-any class-default (id 0)
Match any
Class Map match-all trafhttp (id 1)
Match protocol http
Class Map match-all traficmp (id 2)
Match protocol icmp
Class Map match-all trafrip (id 3)
Match protocol rip

Ce qui est le cas.

27/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Concernant la suite de l'étape, nous allons créer une stratégie comportant les différents trafiques à
définir (en pourcentage) sur la bande passante, que l'on va nommer limitraf :

Routeur0(config)#policy-map limitraf

On limite le trafique http à 40 %


Routeur0(config-pmap)#class trafhttp
Routeur0(config-pmap-c)#bandwidth percent 40
Routeur0(config-pmap-c)#exit

On limite le trafique icmp à 20 %


Routeur0(config-pmap)#class traficmp
Routeur0(config-pmap-c)#bandwidth percent 20
Routeur0(config-pmap-c)#exit

On limite le trafique rip à 15 %


Routeur0(config-pmap)#class trafrip
Routeur0(config-pmap-c)#bandwidth percent 15
Routeur0(config-pmap-c)#exit

on définit sur la classe par défaut, le WFQ (Weighted fair queuing)


pour donner des files d'attente (ici 1024 queues (file d'attente) en
tout), contenant chacune maximum 50 paquets.
Routeur0(config-pmap)#class class-default
Routeur0(config-pmap-c)#fair-queue 1024
Routeur0(config-pmap-c)#queue-limit 50
Routeur0(config-pmap-c)#end

Le WFQ consiste à séparer les connexions, et à leur attribuer successivement et équitablement une
possibilité de faire passer leurs paquets : cela permet donc de s'assurer qu'aucune application, même
très demandeuse de débit, n'en écrasera d'autres.

28/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Pour vérifier notre configuration sur la politique, on applique un show policy-map :

Routeur0#show policy-map
Policy Map limitraf
Class trafhttp
Bandwidth 40 (%) Max Threshold 64 (packets)
Class traficmp
Bandwidth 20 (%) Max Threshold 64 (packets)
Class trafrip
Bandwidth 15 (%) Max Threshold 64 (packets)
Class class-default
Flow based Fair Queueing
Bandwidth 0 (kbps) Max Threshold 50 (packets)

Après la vérification, nous devons applique notre stratégie sur l'interface fastethernet 0/0 :

Routeur0##configure terminal

Routeur0(config)#interface fastEthernet 0/0


Routeur0(config-if)#service-policy output limitraf
Routeur0(config-if)#end

On va tout de même, réaliser un show pour voir notre configurations établie sur l'interface
fastetherent 0/0 :

Routeur0#show policy-map interface fastEthernet 0/0


FastEthernet0/0

Service-policy output: limitraf

Class-map: trafhttp (match-all)


0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol http
Queueing
Output Queue: Conversation 265
Bandwidth 40 (%)
Bandwidth 40000 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

29/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Class-map: traficmp (match-all)


0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol icmp
Queueing
Output Queue: Conversation 266
Bandwidth 20 (%)
Bandwidth 20000 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: trafrip (match-all)


0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol rip
Queueing
Output Queue: Conversation 267
Bandwidth 15 (%)
Bandwidth 15000 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)


0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum number of Hashed Queues 1024
Bandwidth 75000 (kbps)Max Threshold 50 (packets)
(total queued/total drops/no-buffer drops) 0/0/0

On peut noter que la bande passante total de l'interface fastethernet 0/0 est de 150 000 kb/s
soit 18 750 ko/s (150 000 / 8).

Maintenant nous allons appliquer un teste de communication entre PC0 et Serveur0. Pour voir si les
paquets envoyées via le protocole icmp sont indiquées sur le routeur. Si c'est le cas, alors la
déclaration de la stratégie en sortie sur l'interface fastethernet 0/0, est fonctionnelle.

30/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Envoie d'une requête ping depuis PC0 vers le Serveur0 (192.168.2.1).

Remarque : 4 paquets on était envoyées.On sous entent que le routeur devra ajouter 4 paquets sur
la stratégie traficmp définit sur son interface fastethernet 0/0.

Au moment où le paquet traverse le retour puis en sortant de l'interface fastethernet 0/0, le paquet
est ajouté sur la stratégie traficmp.

Paquet ICMP

31/33
MOUSSAOUI Houssam LAMDAOUAR Mohamed BTS SIO2 SISR - 22/09/2015

Pour confirmer le schéma ci-dessus, on se dirige sur le routeur et on applique un show policy-map
interface fastethernet 0/0 :

….

Class-map: traficmp (match-all)


4 packets, 384 bytes
5 minute offered rate 12 bps, drop rate 0 bps
Match: protocol icmp
Queueing
Output Queue: Conversation 266
Bandwidth 20 (%)
Bandwidth 20000 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

….

On voit bien que le routeur a ajouté 4 paquets sur la stratégie traficmp et donc par la suite établie les
20 % sur la bande passante.

Si on choisi de faire le teste pour un autre trafique pare exemple le http, on aura exactement la
même fonction établie par le routeur simplement, la différence étant qu'il ajoutera n paquets sur la
stratégie trafhttp. Sans oublier que la bande passante pour ce trafique jouera toujours sur 40 % soit
40 000 kb/s.

32/33
MOUSSAOUI Houssam BTS SIO2 - 22/09/2015

Conclusion

Le QoS qui permet la qualité de service ainsi que la priorité, va nous permettre donc de rendre
prioritaire certain trafic tels que la téléphonie ou bien la vidéo au sein d'un réseau. Et donc limiter la
bande passante sur un trafic considérer non prioritaire tel que la navigation sur le web par exemple.

Vue que l'on a définit le QoS au niveau de la couche 2, certains appareilles ont besoin d'être précisé
dans un groupe de flux séparés différemment (VLAN) comme dans le cas où un PC traverse un
téléphone IP pour joindre tel machine, forcément le téléphone en question doit être déclaré dans des
VLAN différent puisqu'il génère du flux audio alors que le PC lui génère un autre flux.

On a appris également, que pour la qualité de service au niveau de la couche 3. Il est nécessaire au
sein d'un routeur, de créer des class plus précisément des stratégies, qui vont nous permettre
d'établir une priorité sur un trafique(http, icmp, rip, etc...).
Et donc ce dernier, peut être segmenté en plusieurs pourcentage sur la bande passante d'un réseau
(défit généralement sur un routeur).

33/33