Vous êtes sur la page 1sur 9

Pr. K.

SATORI FSDM-FES

Travaux dirigés/ Algorithmique I


Série 2
Exercice 1 :
Ecrire un algorithme qui affiche la valeur absolue d’un réel.

Exercice 2 :
Ecrire un algorithme qui affiche la partie entière inférieure de la racine carrée d’un entier
positif donné n.

Exercice 3 :
Ecrire un algorithme qui à partir d’un nombre entier strictement positif affiche VRAI si ce
nombre est pair et FAUX sinon.
Exercice 4 :
Ecrire un algorithme qui permet de déterminer le maximum et le minimum de 4 nombres
entrés par l’utilisateur.
Exercice 5 :
Ecrire un algorithme qui permet de calculer la moyenne de trois notes N1, N2 et N3, de
coefficients C1, C2 et C3 respectivement, et d’afficher la mention comme suit :
- «Faible » : si moyenne<10
- « Passable » : si 10<=moyenne <12
- « A. bien » : si 12<=moyenne <14
- « Bien » : si 14<=moyenne <16
- « T. bien » : si 16<=moyenne <18
- « Excellent » : si 18<= moyenne <20
Exercice 6 :
Ecrire un algorithme qui
• Lit 3 notes puis
• Calcule la moyenne, et Si la moyenne est :
- supérieure à 10, affiche le message « Module validé »
- Inférieur à 5, affiche le message « Note éliminatoire »
- Dans le reste des cas, affiche le message « Rattrapage »
Exercice 7 :
Ecrire un algorithme qui :
• Demande le nombre de notes que l’utilisateur veut saisir, puis
• Saisit les notes de l’utilisateur et vérifie que chaque note est entre 0 et 20. Si ce n’est
pas le cas, l’utilisateur doit ressaisir la note.
• Affiche la moyenne
Exercice 8:
Ecrire un algorithme qui affiche le menu suivant :
***Calcul de la surface***
C : Cercle
T : Triangle
R : Rectangle
Tapez votre choix : C, R ou T
Et calcule ensuite la surface de l’objet, selon le choix (C, T ou R).

1/2
Pr. K. SATORI FSDM-FES

Exercice 9 :
Ecrire un algorithme, qui calcule pour un entier positif donné n la valeur de n !

Exercice 10 :
Ecrire un algorithme qui permet de saisir un entier strictement positif N et d’afficher s’il
est premier ou non. Un nombre est dit premier s’il est divisible uniquement par 1 et par lui-
même.

Exercice 11 :
Ecrire un algorithme qui demande à l’utilisateur d’entrer N nombres, de calculer et
d’afficher ensuite :
- La moyenne des nombres positifs.
- Le produit des nombres négatifs.

Exercice 12:
Ecrire un algorithme qui permet de saisir un nombre puis détermine s’il appartient à un
intervalle donné, sachant que les extrémités de l’intervalle sont fixées par l’utilisateur.

Exercice 13:
Ecrire un algorithme qui demande un nombre compris entre 10 et 20, jusqu’à ce que la
réponse convienne. En cas de réponse supérieure à 20, on fera apparaître un message : « Plus
petit ! », et inversement, « Plus grand ! » si le nombre est inférieur à 10.

Exercice 14 :
Ecrire un algorithme, puissance, qui à partir d’un réel x et d’une valeur entière positive n,
calcule xn.

Webographie

▪http://pise.info/algo/introduction.htm
▪https://www.cours-gratuit.com/cours-algorithme/cours-et-exercices-complet-algorithmes-en-pdf

2/2
Faculté des Sciences Dhar El Mahraz Département d’informatique

Travaux dirigés : Algorithmique

Correction de la série n°2


Exercice 1 :
Algorithme valeurAbsolue
Variables val, résultat : Réel
Début
Ecrire"Entrer un réel"
Lire val
Si (val ≥ 0) Alors
résultat ← val
Sinon
résultat ← - val
Fin Si
Ecrire"La valeur absolue de", val, "est", résultat
Fin

Exercice 2 :
Algorithme racineEntière
Variables n, racine : Entier
Début
racine ← 1
Ecrire"Entrer un entier positif"
Lire n
Tant que racine*racine ≤ n Faire
racine ← racine +1
Fin Tant que
Ecrire"La racine entière de",n,"est",racine-1
Fin

Exercice3 :
Algorithme TestPair
Variable val : Entier
Début
Ecrire"Entrer un entier strictement positif"
Lire val
Si (val mod 2 = 0) Alors
Ecrire "Vrai"
Sinon
Ecrire"Faux"
Fin Si
Fin

1
Exercice 4 :
Algorithme MaxMin
Variables a, b, c, d, max, min : Réel
Début
Ecrire "Entrer 4 nombres :"
Lire a, b, c, d
Si (a>b) Alors
min ← b
max ← a
Sinon
min ← a
max ← b
Fin Si
Si (max<c) Alors
max ← c
Sinon
Si (min>c) Alors
min ← c
Fin Ss
Fin Si
Si (max<d) Alors
max ← d
Sinon
Si (min>d) Alors
min ← d
Fin Si
Fin Si
Ecrire"Le max est : ", max," et le min est : ", min
Fin

Exercice5 :
Algorithme mention
Variables N: réel
Début
Ecrire "Entrer la note :"
Lire N
Si N<10 Alors
Ecrire "Faible "
Sinon
Si N<12 Alors
Ecrire "Passable "
Sinon
Si N<14 Alors
Ecrire "A.bien "
Sinon
Si N<16 Alors
Ecrire "Bien "
Sinon
Si N<18 Alors

2
Ecrire "T. bien "
Sinon
Ecrire "Excellent "
Fin Si
Fin Si
Fin Si
Fin Si
Fin Si
Fin

Exercice 6 :
Algorithme moyenneTrNotes
Variables a,b,c, moy : Réel
Début
Ecrire "Entrer trois notes"
Lire a,b,c
moy ← (a+b+c)/3
Si (moy ≥ 10) Alors
Ecrire "Module validé"
Sinon
Si (moy< 5)Alors
Ecrire "Note éliminatoire"
Sinon
Ecrire "Rattrapage"
Fin Si
Fin Si
Fin

Exercice 7 :
Algorithme moyenneNotes
Variables Nbnote, i : Entier
VariablesS, note: Réel
Début
S←0
Ecrire "Entrer le nombre de notes à saisir"
Lire Nbnote
Pour i←1 à Nbnote Faire
Ecrire "Entrer une note"
Lire note
Tant que note <0 ou note >20 Faire
Ecrire "Entrer une note"
Lire note
Fin Tant que
S ← S + note
Fin Pour
Ecrire "La moyenne est", S / Nbnote
Fin

3
Autre solution de l’exercice 7
Le bloc en couleur rouge (ci-dessus) peut être remplacé par :
Répéter
Ecrire "Entrer une note"
Lire note
Tant que (note<0 ou note>20)
Les autres parties de l’algorithme restent les mêmes.

Exercice 8 :
Algorithme Surface
Variables r, a, b, l, h, S : Réel
Variablech : caractère
Début
Ecrire "***Calcul de la surface***"
Ecrire "C : Cercle"
Ecrire "T : Triangle"
Ecrire "R : Rectangle"
Ecrire "Tapez votre choix : C, R ou T "
Lire ch
Si (ch="C" ou ch= "c") Alors
Lire r
S←3,14*r*r
Ecrire "La surface du cercle est : ", S
Sinon
Si (ch="T" ou ch= "t") Alors
Lire a, b
S←a*b/2
Ecrire "La surface du triangle est : ", S
Sinon
Si (ch="R" ou ch= "r") Alors
Lire l, h
S←l*h
Ecrire "La surface du rectangle est : ", S
Sinon
Ecrire "Erreur de saisie"
Fin Si
Fin Si
Fin Si

Fin

Exercice9 :
Algorithme Factorielle
Variables i, n, fact : Entier
Début
fact ←1
Ecrire "Entrer un nombre"
Lire n
Pour i←1 à n Faire

4
fact ← i * fact
Fin Pour
Ecrire "La factorielle de ", n, "est ", fact
Fin

Exercice 10 :
Algorithme Premier
Variables i, j, N: Entier

Début
Ecrire "Entrer un entier strictement positif"
Lire N
j←0
Pour i←2 à N-1 Faire
Si (N mod 2 =0) Alors
j←j+1
Fin Si
Fin Pour
Si (j=0) Alors
Ecrire "Le nombre", N,"est premier"
Sinon
Ecrire Le nombre", N, "n’est premier"
Fin Si
Fin

Exercice 11 :
Algorithme ProduitMoyenne
Variables N, nb, S, Moy, Prod : Réel
Variable i, nbneg, nbpos : Entier
Début
Ecrire "Entrer N :"
Lire N
Prod←1
S←0
nbneg←0
nbpos ←0
Pour i←1 à N
Ecrire "Entrer un nombre:"
Lire nb
Si nb<0 Alors
Prod←Prod*nb
nbneg←nbneg+1
Sinon
S←S + nb
nbpos← nbpos +1
Fin Si
Fin Pour
Si (nbpos>0) Alors
Ecrire "La moyenne des nombres positifs est :", S/nbpos

5
Sinon
Ecrire "Pas de nombres positifs :"
Fin Si
Si (nbneg>0) Alors
Ecrire "Le produit des nombres négatifs est :", Prod
Sinon
Ecrire "Pas de nombres négatifs :"
Fin Si
Fin

Exercice 12 :
Algorithme Intervalle
Variables bsup, binf, N : Réel
Début
Répéter
Ecrire "Entrez une borne inférieure de l’intervalle"
Lire binf
Ecrire "Entrez une borne supérieure de l’intervalle"
Lire bsup
Tant que (binf>bsup)
Ecrire "Entrez un nombre "
Lire N
Si (N≥ binf et N≤ bsup) Alors
Ecrire "Le nombre ", N, "appartient à l’intervalle [ ", binf, " ", bsup, "] "
Sinon
Ecrire "Le nombre ", N, "n’appartient pas à l’intervalle [ ", binf, " ", bsup, "] "
Fin Si
Fin

Exercice 13 :
Algorithme GrandPetit
Variable N : Réel
Début
N←0
Ecrire "Entrez un nombre"
Tant que (N < 10 ou N > 20) Faire
Lire N
Si N < 10 Alors
Ecrire "Plus grand !"
Sinon
Si N > 20 Alors
Ecrire "Plus petit !"
FinSi
Fin Tant que
Fin

6
Autre solution de l’exercice 13

Algorithme GrandPetit
Variable N : Réel
Début
Répéter
Ecrire "Entrez un nombre"
Lire N
Si N < 10 Alors
Ecrire "Plus grand !"
Sinon
Si N > 20 Alors
Ecrire "Plus petit !"
FinSi
Tant que (N < 10 ou N > 20)

Fin

Exercice 14 :
Algorithme Puissance
Variablei, n: Entier
Variable x, p:Réel
Début
p ←1
Ecrire "Donner un nombre réel : x et un nombre entier : n"
Lire x,n
Pour i=1 à n Faire
p←p*x
Fin Pour
Ecrire "x à la puissance n est :", p
Fin

Vous aimerez peut-être aussi