Vous êtes sur la page 1sur 135

UNIVERSITE SIDI MOHAMMED BEN ABDALLAH

FACULTE DES SCIENCES DHAR EL MEHRAZ

Département d’Informatique

Algorithmique I
Section: S2 (SMA, SMI)

Pr. Khalid SATORI


khalid.satori@usmba.ac.ma
Introduction (1)

➢ Algorithme: Procédure décrivant, étape par étape, une méthode


permettant de résoudre un problème.

➢ Un algorithme, c’est une suite d’instructions, qui une fois exécutée


correctement, conduit à un résultat donné.

➢ Un algorithme doit contenir uniquement des instructions


compréhensibles par celui qui devra l’exécuter.

➢ Mot provenant du nom d’un mathématicien arabe du 9ème siècle El-


Khawarizmi

➢ C’est la base de tout programme informatique.

2
Introduction (2)

Construire un algorithme, c’est avant tout :

❑ Analyser l’énoncé du problème afin de définir l’ensemble des

objets à manipuler pour obtenir un résultat. donc :

❑ Trouver le cheminement logique des tâches à fournir à

l’ordinateur pour qu’il les exécute.

3
Introduction (3)

Vous avez déjà fait de l'algorithmique, parce qu'on utilise


des algorithmes dans notre vie quotidienne, voici
quelques exemples :;

4
➢Indiquer un chemin à un touriste égaré

5
➢ Ecrire une recette de cuisine

6
➢Résoudre une équation mathématique

7
◼ On peut dire que l'algorithme est
une démarche à suivre pour résoudre un
problème.

8
Introduction (4)

➢ Exemple: l’algorithme du café chaud.

9
Comment faire un café chaud non sucré ? Chaque mot a son importance,
et «non sucré» est aussi important que «café» ou «chaud». Le terme «non
sucré» implique qu’il n’est pas nécessaire de prendre du sucre ni une
petite cuillère.

Nous allons
➢ Définir les objets manipulés.
➢ Lister les opérations
➢ Ordonner la liste des opérations

Supposons que, pour réaliser notre café, nous soyons en possession des ustensiles
et ingrédients suivants :
café moulu, filtre , eau , pichet , cafetière électrique , tasse, électricité , table

10
Introduction (5)
Exemple: Comment construire une maison, les étapes à faire
Nous allons
➢ Définir les besoins.
➢ Lister les opérations
➢ Ordonner la liste des opérations
▪ L'étude de sol
▪ Le terrassement
▪ L'excavation
▪ Les fondations
▪ L’assainissement
▪ Le soubassement
▪ Le Plancher
▪ L'élévation
▪ La charpente
▪ La toiture
▪ Les menuiseries extérieures

11
Introduction (6)

Informations
en entrée

Algorithme informatique
=
procédure de calcul

Rigueur Scientifique IMPORTANT !


Informations
Sinon, information de sortie erronée
en sortie

12
Exemple de problème (1)

Calculer la surface de disque: S = π*R2

Calculer le volume de cylindre: V = H * π* r2

a*x + b = 0 Solution : x = - b / a (suivant le cas)

Je veux informatiser ce problème et le rendre exploitable à travers


mon ordinateur. Qu’est ce que je dois faire ?
13
Exemple de problème (2)

Soit une sphère de rayon r et de


diamètre d.
L’aire A de la surface extérieure de cette
sphère est calculée de la façon suivante :

A = 4πr² = πd²

Je veux informatiser ce problème et le rendre exploitable à travers


mon ordinateur. Qu’est ce que je dois faire ?
14
Exemple de problème (3)

Calcul de l'aire d'un hexagone régulier:


Un hexagone régulier est un polygone à 6 côtés,
de même longueur.

Soit a la longueur d’un côté, l’aire A d’un


hexagone régulier est égale à :

Je veux informatiser ce problème et le rendre exploitable à travers mon


ordinateur. Qu’est ce que je dois faire ?

15
Notion d’algorithme (1)
Activité
Calculer la surface d’un disque de rayon r et préciser les données connues, le
résultat à chercher et le traitement à faire ?

Étapes de résolution d’un problème

Pour résoudre un problème à l’aide d’un algorithme il faut :

1. Comprendre le problème posé

2. Préciser les données fournies (entrées) et les résultats que l’on désire
obtenir (sorties).

3. Déterminer le processus de transformation des données en résultats


c.à.d. la méthode de résolution.

16
Notion d’algorithme (2)
Exemple
Calculer la surface de disque: S = π*r2 , préciser les données fournies, le
résultat à chercher la surface et traitement à faire.
Solution

Les données d’entrées : les valeurs de π et r

Le résultat que l’on désire obtenir : la valeur de S


S = π*r2

✓Afficher le résultat (S)

17
Exemple:
Calculer les surfaces Blues des dessins (a) et (b)

(a) (b)

(S = π*R2 -5 * π*r2 )
(S = 5 * (π*R2 -5 * π*r2 )

18
Notion d’algorithme (3)
Exemple
Calculer le volume de cylindre: V = h * π* r2 , préciser les données
fournies, le résultat à chercher le volume et traitement à faire.
Solution
➢1er étape :

Les données d’entrées : les valeurs de π, h et r

➢ ème
2 étape :
Le résultat que l’on désire obtenir : la valeur de V
V = h * π* r2

➢3 ème étape : L’équation


✓ afficher le résultat (V)

19
Exemple

Calculer les surfaces des cylindres des dessins (a) et (b)

(b)
(a)

20
Notion d’algorithme (4)
Schéma de résolution informatique d’un problème

Problème
Les données fournies

Analyse La méthode de résolution.

Les résultats à chercher

Ecriture d’un algorithme

Traduire l’algo en un Programme

Résolution informatique d’un problème

21
Notion d’algorithme (5)

Définition de l’algorithme
Un algorithme est une suite finie d’instructions, qui doivent être
exécutées dans un ordre bien déterminé pour résoudre un problème.

Instruction: c’est une opération élémentaire qui produit un effet spécifié en


un temps fini.

Caractéristiques d’un algorithme


Un algorithme doit :

➢ Donner le même résultat pour les mêmes données,

➢ être défini et précis,

➢ être lisible et compréhensible.


22
Phases d’un algorithme (1)

Un algorithme doit être lisible de tous. Son intérêt, c’est d’être


codé dans un langage informatique afin qu’une machine
(ordinateur, calculatrice, etc.) puisse l’exécuter rapidement et
efficacement.

Les trois phases d’un algorithme sont, dans l’ordre :


1. l’entrée des données
2. le traitement des données
3. la sortie des résultats
23
Exemple d’algorithme
Exemple
Résoudre l’équation a*x+b=0, préciser les données fournies, le résultat à
chercher et la méthode de résolution
Solution

Les données d’entrées : les valeurs de a et b

Le résultat que l’on désire obtenir : les valeurs de x


✓ Si a # 0 alors x= -b/a
✓ Si a=0 et b=0 alors l’équation admet une infinité de solution
✓ Si a=0 et b#0 alors l’équation n’admet pas de solution

: La méthode de résolution
✓Afficher (x)

24
Phases d’un algorithme
Structure d’un algorithme

Algorithme nom-algorithme Entête


Variable nom-variable : type_variable Déclaration
Début
Instruction 1 ;
Instruction 2 ;
Instruction 3 ; Corps : les taches à exécuter.
............
Instruction n ;
Fin

25
Structure générale d’un algorithme

Algorithme Titre du Problème


✓ Déclaration des Constantes
Déclaration ✓ Déclaration des Variables
✓ Déclaration des Tableaux
✓ Déclaration des Procédures et Fonctions

Début
Manipulation Actions
FIN

26
Exemple d’un algorithme (1)

On veut calculer : y = 2x2 – 2x + 1

Algorithme Calcul 1
Variables :
x, y : nombres réels
Entrée :
Saisir x
Traitement :
y reçoit 2x2 – 2x + 1 ou y ← 2*x*x - 2*x + 1
Sortie :
Afficher y
27
Exemple d’un algorithme (2)

On veut calculer : y = 2 x² - 8

Algorithme Calcul 1
Variables :
x, y : nombres réels
Entrée :
Saisir x
Traitement :
y reçoit 2 x² - 8 ou y ← 2 *x*x - 8
Sortie :
Afficher y
Tester pour x = 2 et pour x = 5
28
Exemple d’un algorithme (3)
Calcul de : 2 x² - 8

Algorithme: Calcul (Changement de variables)


Variable x : réel
Début
Saisir x
Affecter à x : x² ou x ← x*x
Affecter à x : x – 4 ou x ← x - 4
Affecter à x : 2x ou x ← 2*x
Afficher x
Fin
Tester pour x = 2 et pour x = 5
29
Exemple d’un algorithme (4)

Calcul de : l’aire d’un rectangle

Algorithme: Aire rectangle


Variables Aire, a , b : Entier
Début
Saisir a et b
Affecter à Aire : a*b ou Aire ← a*b
Afficher Aire
Fin

30
Exemple d’un algorithme (5)

Calcul de : l’aire d’un rectangle (Changement de variables)

Algorithme: Aire rectangle1


Variables a , b : Entier
Début
Saisir a et b
Affecter à a : a*b ou a ← a*b
Afficher a
Fin
31
Déclaration des Objets

32
Données d’un algorithme (1)

Définition:
Les données sont des informations nécessaires au déroulement d’un
algorithme. On distingue deux catégories : les constantes et les variables.
1. Les constantes
Une constante est une donnée fixe qui ne varie pas durant l’exécution d’un
algorithme. Une constante est caractérisée par son nom et sa valeur (fixe).
➢ Syntaxe

Constante Nom _Constante = valeur ;

➢ Exemple
Constante Pi =3,14 ;
Constante B = 10 ;
Constante Mois = ‘Janvier' ;
33
Données d’un algorithme (2)

2. Les variables
Une variable est un objet dont le contenu peut être modifié par une
action durant l’exécution d’un algorithme. Une variable est caractérisée
par son nom, sa valeur et son type.
➢ Syntaxe

Variable Nom_Variable : Type ;

➢ Exemple
Variable nb_élèves : entier ;
Variable note : réel ;
Variable Prénom : chaines de caractères ;
Variable B : booléen ;
Variable OP: caractère ;
34
Données d’un algorithme (3)

Variable A, B, C: Entier ;

A ← 10
B ← 20
C ← 30
B←C
A←B
C←A

Résultat :

B = 30
A = 30
C = 30

35
Données d’un algorithme (4)

3. Les types de données

Remarque

Une variable de type numérique ne peut pas recevoir une chaine de


caractères ou booléen.

36
Données d’un algorithme (5)

Type Entier

C’est l’ensemble des nombres entiers positifs ou négatifs.

Syntaxe de la déclaration :

Variable variable1,variable2,… : Entier

Exemple :
Variable a,b : Entier a et b sont, par exemple,
les coefficients de
l’équation : ax + b = 0
37
Données d’un algorithme (6)

Type Réel

C’est l’ensemble des nombres réels, c’est à dire les


nombres décimaux sans limitation.

Syntaxe de la déclaration :

Variable variable1, variable2,… : Réel

Exemple :
Variable x, y : Réel

38
Données d’un algorithme (7)

Type Chaîne de caractères

C’est une suite de caractères, c’est à dire des


combinaisons de caractères (lettres, chiffres, symboles..).
Syntaxe de la déclaration :

Variable variable1,variable2,… : Caractère

Exemple :
Variable Nom, Catégorie : Caractère

39
Données d’un algorithme (8)

Type Booléen

Il s’agit des objets qui ne peuvent prendre que deux valeurs vrai
ou faux.

Syntaxe de la déclaration :

Variable variable1,variable2,… : Booléen

Exemple :
Variable Décision : Booléen

40
Instructions de base (1)

1. L’affectation
L’affectation est une opération qui consiste à attribuer une valeur ou
expression à une variable. Elle est représentée par une flèche orientée à
gauche : .
➢ Syntaxe

Variable Valeur ou expression

➢ Exemple
A 4 : la variable A reçoit la valeur 4
Nb A+5 : la variable Nb reçoit le contenu de A plus 5
Nom ‘Bonjour' : la variable Nom reçoit la valeur salut
41
Instructions de base (2)
Exercice 1:
◼ Quelles seront les valeurs des variables A et B après exécution des instructions
suivantes ?
Variables A, B : Entier
Début
A←1
B←A+3
A←3
Fin

Correction 1
Les valeurs des variables après l’exécution sont :
A←1 A=1 B=?
B ←A+3 A=1 B=4
A←3 A=3 B=4

42
Instructions de base (3)
Exercice 2:
◼ Quelles seront les valeurs des variables A , B et C après exécution des instructions suivantes ?
Variables A, B, C : Entier
Début
A←5
B←A+4
A←A+1
B←A–4
C←A+B+3
Fin

Correction 2
Les valeurs des variables après l’exécution sont :
A←5 A=5 B=? C=?
B←A+4 A=5 B=9 C=?
A←A+1 A=6 B=9 C=?
B←A-4 A=6 B=2 C=?
C←A+B+3 A=6 B =2 C = 11

43
Instructions de base (4)

Exercice 3:
◼ Quelles seront les valeurs des variables A , B et C après exécution des instructions suivantes ?
Variables A, B, C en Caractères
Début
A ← "423"
B ← "12"
C←A+B
Fin

Correction 3
Les valeurs des variables après l’exécution sont :
A ← "423 " A = 423 B=? C=?
B ← "12 " A = 423 B = 12 C=?
C←A+B A = 423 B = 12 C : erreur
Pour faire la concaténation
C ← A & B A = 423 B = 12 C : 42312

44
Instructions de base (5)
2. L’écriture
L’écriture est une instruction qui permet d'afficher le contenu d’une
variables ou/et un message sur l'écran.
➢ Syntaxe

Ecrire (variable);
Ecrire ('message');
Ecrire ('message', variable);

➢ Exemple
Soit A est une variable.
Ecrire (A) : signifie affiché sur l’écran le contenu de la variable A.
Ecrire (‘Bonjour!') : signifie affiché sur l’écran le message suivant:
Bonjour!

45
Instructions de base (6)
3. La lecture
La lecture est une instruction qui permet de lire des données tapées au
clavier.
Syntaxe

Lire (variable1) ;
Lire (variable2) ;
Lire (variable1, variable2) ;

Exemple
Lire (nombre) ;
Lire (Nb1,Nb2) ;

46
Instructions de base (7)
Exercice 4
Écrire un algorithme qui demande un nombre et qui affiche un message
’Bonjour’ et aussi le double de ce nombre.

Solution 4

Algorithme: nombre

Variable x: entier
Début
Ecrire (‘donner un nombre entier’)
Lire (x)
Ecrire (‘Bonjour‘, 2*x)
Fin

47
Instructions de base (8)
Exercice 5
Ecrire un algorithme qui demande à l’utilisateur d’entrer deux nombres pour
a et b, de calculer c = b2 – 4*a*b et d’afficher le résultat.

Solution 5

Algorithme: Equation

Variable a, b, c: Entier
Début
Ecrire (‘donner les valeurs de a et b’)
Lire (a, b)
c ← b*b - 4*a*b
Ecrire (‘La solution est: ‘, c)
Fin

48
Instructions de base (9)
Exercice 6 :
Déterminer le montant à payer en TTC pour l'achat de deux produits dont on
connaît les prix. Le Taux de TVA de 20 %.
HT: Hors Taxes, TTC: Toutes Taxes Comprises, TVA: Taxe sur la Valeur Ajoutée

Programme Facture
Constante TauxTVA = 0,2
Variables prix1, prix2, totalHT, totalTTC, TVA : réel
Début
Afficher (‘Entrer le prix du premier produit HT : ‘) (Afficher = Ecrire)
Saisir (prix1) (Saisir = Lire)
Afficher (‘Entrer le prix du deuxième produit HT : ‘)
Saisir (prix2)
totalHT ← prix1 + prix2
TVA ← totalHT * taux_TVA
totalTTC ← totalHT + TVA
Afficher (‘Le total à payer est de’, totalTTC)
Fin 49
Instructions de base (10)
Exercice 7
On dispose de trois variables A, B et C. Ecrivez un algorithme transférant à
B la valeur de A, à C la valeur de B et à A la valeur de C.

Algorithme permutation_3_nombres //{permute 3 nombres}


Variables A, B, C, D: Entier
Début
Ecrire (’Donner les valeurs de: A , B et C: ‘) ;
Lire (A, B, C) ;
Ecrire (‘Avant permutation ‘)
Ecrire (‘A vaut : ‘,A, ‘ B vaut : ‘,B, ‘C vaut : ‘,C)
D←C;
C← B ;
B←A;
A←D;
Ecrire (‘Après permutation ‘) ;
Ecrire (‘A vaut : ‘,A, ‘B vaut : ‘,B, ‘ C vaut : ‘,C) ;
Fin

50
Expressions et Opérateurs (1)

1. Opérateurs
Un opérateur est un signe qui relie deux valeurs, pour produire un résultat.
Exemple : +,-,*,/ ,^,<,et, non, ou,….

51
Expressions et Opérateurs (2)
Expressions

Une expression est un ensemble de valeurs reliées par des opérateurs, et

équivalent à une seule valeur.

Exemple : 4+2, 5*6, 4<9, A>6, C+B,…

Algorithme:
Variable a, b, c: entier
Début
Ecrire (‘donner les valeurs de a, b et c’)
Lire (a, b, c)
Ecrire ( a+b, a+c, b+c, a-b, b-c, a*c, b*c)
Fin

52
Autres objets à déclarer (1)

Type Tableau
Un tableau permet de représenter un ensemble de valeurs ayant des
propriétés communes et appartenant toutes au même type. Ces variables sont
identifiées par un même nom, mais un numéro de repère(indice) pour chacun.

Exemple on cherche à calculer la moyenne de 12 notes


Moy ← (N1+N2+N3+N4+N5+N6+N7+N8+N9+N10+N11+N12)/12

Au lieu de déclarer 12 variables on déclare un tableau Note [12]

53
Déclaration d’un tableau

Syntaxe

Variable nomVariable : TypeVariable [ dimension ]

Exemple:

Variable Note : Entier [ 12 ]


Constante NTEMPMAX = 366
Variable temps : Réel [ NTEMPMAX ]

54
Autres objets à déclarer (2)

Les Fonctions et les procédures

Ce sont des sous-programmes auxquels on peut faire référence à


l’intérieur d’un programme . Ils sont conçus pour éviter les répétitions et pour
découper des programmes jugés trop longs; ce qui facilite la lisibilité du
programme principal.

Procédure nom_procédure (param1 :type1 ; param2, param3 :type2) ;


Fonction (param1 :type1 ; param2 :type2) : Type_fonction ;

55
Autres objets à déclarer (2)
Les Fonctions et les procédures
fonction pi(): réel
Début pi
retourner 3.1415926535897931
Fin pi

procedure aide ()
Début aide
écrire ("Aide du programme Machine. " )
écrire (" l’option -o permet de définir le fichier sortie")
écrire (" l’option -h donne ce message")
Fin aide 56
Manipulation des Objets

57
Structure d’un algorithme

Partie I Nom d’algorithme

Déclaration:
Partie II
Type: constante, réel, booléen, charactère

Manipulation:
Début
Action 1
Partie III Action 2
….
Fin
58
Instruction et Action

Définition :
On appelle instruction toute commande élémentaire que
l’on doit appliquer sur des objets pour avoir des sorties bien
définies.
Définition :
Une action est un événement qui change l’état d’un objet
d’un état initial donné à un état final désiré. Une action a une durée
d’exécution finie et un effet propre et bien défini. Chaque action
porte sur des objets sur lesquels elle s’exécute :

L‘action est une seule instruction ou un groupe d’instructions

59
La Structure de la partie manipulation

La partie manipulation doit commencer par le mot


DEBUT et se termine par le mot FIN.
DEBUT
Instruction 1
Instruction 2
…….
……. Action
Instruction n

FIN

60
Les instructions d’un Algorithme

La partie manipulation utilise les différents objets déclarés


dans la partie déclaration et leur applique des opérations afin de
retourner le(s) résultat(s) attendu(s) par le programmeur. Pour ce fait,
il y a différentes actions, dites instructions, à savoir :
➢ Instructions de dialogue Homme-Machine; Ecrire ( ), Lire ( )
➢ Instructions d’affectation ; ((TVA : réel) ←20.6 (Titre :
chaîne) ←"Résultat " )

➢ Instructions à structure alternative; (SI … ALORS …


SINON … FSI)

➢ Instructions à structure répétitive (Boucles).

➢ Etc…
61
Instructions de dialogue Homme-Machine

L’affichage des informations:


Pour faire comprendre qu’il faut afficher des informations
à l’écran, on utilise l’instruction écrire qui obéit à la syntaxe
suivante :

Écrire (Variable ou ‘ Message’ )

Exemples : Écrire (‘ Saisissez la valeur de a ’)


Écrire (‘ Saisissez la valeur de b ’)
Écrire (‘ Saisissez les valeurs de a et b ’)
Écrire (‘Le résultat trouvé est :’, r )
Écrire (r)
62
Instruction Homme-Machine

La saisie des informations:


Pour indiquer dans un algorithme que telle donnée doit
être lue par le système, on utilise l’instruction lire qui obéit à la
syntaxe suivante :

Lire (variable)

Exemple :
Écrire (‘ Saisissez la valeur de a ’)
Lire (a)

63
Instruction d’affectation

Définition:
C’est le stockage d’une valeur à un endroit
spécifique(variable). Pour affecter une valeur à une variable, on
écrit:

Variable Valeur

Exemple :
Variable valeur 1 + valeur 2
Variable valeur 1 * valeur 2
Variable valeur1 + variable1

64
Exercice (1)
Quels résultats produit l’algorithme suivant ? Les types de variables
sont-ils corrects?, donner le nombre des variables et des instructions.
Algorithme : Calcul
Déclaration

Variable A: Entier
C,B : Réel
D : caractère
E : Booléen
Début
A ← 30
B ←A+ 2*A
Écrire ('B=' , B)
C ← (B - A)/4
Manipulation

B←C/5
D ← ‘Bonsoir’
E ← (A > 40) Ou (C < B)
Écrire('les valeurs obtenues sont : A = ' , A ,
'B = ' ,B , ' C = ', C , ' D = ', D, ' E = ', E)
Fin
65
Solution
Solution(1)

A ← 30 A = 30
B←A+2 *A
Écrire ('B=' , B) B = 90
C ← (B - A)/4 C = 15
B←C/5 B=3
D ← ‘Bonsoir’ D = Bonsoir
E ← (A > 40) Ou (C < B) Faux
Écrire ('les valeurs obtenues sont : A = ' , A ,
'B = ' ,B , ' C = ', C , ' D = ', D, ' E = ', E)

A = 30 B=3 C = 15 D = Bonsoir E = Faux

Le nombre des variables : 5; le nombre des instructions : 8

66
Exercice (2)

Énoncé:
Écrire l’algorithme permettant de calculer le volume d’un
cylindre connaissant son rayon et sa hauteur :
Surface =  * Rayon2
Volume = Hauteur * Surface

Entrée : Manipulation Sortie :


La valeur du rayon Le volume calculé

La valeur de la hauteur

67
Solution (2)
Algorithme: volume de cylindre
Déclaration :
Constante Pi=3.14
Variable Rayon : Entier * Donnée d’entrée*
Variable Hauteur : Entier * Donnée d’entrée*
Variable Surface : Réel
Variable Volume : Réel * Donnée de sortie*

Manipulation :
DEBUT
Écrire ( 'Saisir les valeurs du rayon et de la hauteur' )
Lire (Rayon, Hauteur)
Surface ⎯ Rayon * Rayon * Pi
Volume ⎯ Surface * Hauteur
Écrire (' Le volume du cylindre est : ', Volume)
FIN
68
Exercice (3)

Connaissant les notes obtenues par un élève dans 3 matières et leurs


coefficients, écrire un algorithme qui permet de calculer la moyenne de
l’élève.).

Moy  (N1*C1+N2*C2+N3*C3) / (C1+C2+C3)

69
Solution (3)
Algorithme moyenne_3_note
Déclaration :
Variable N1, N2, N3, C1, C2, C3 , Moy: Réel * Donnée d’entrée*
Manipulation :
Début
Ecrire (‘Entrer les trois notes’)
Lire (N1, N2, N3)
Ecrire (‘Entrer les trois coefficients ‘)
Lire (C1, C2, C3)
Moy  (N1*C1+N2*C2+N3*C3) / (C1+C2+C3)
Ecrire (‘La moyenne est :’, Moy)
Fin

70
Exercice (4)

Exemple :
Écrire l’algorithme qui permet de déterminer le salaire mensuel
d’un commercial sachant que ce salaire comporte un montant fixe de 3000
DH et une commission qui représente 5% du chiffre d’affaire réalisé par
mois.

71
Solution (4)

Algorithme : Commission
Déclaration :
Constante M = 3000
Variable CA : Entier * Donnée d’entrée*
Com : Réel * Donnée intermédiaire*
Sal : Réel * Donnée de sortie*
Manipulation :
DEBUT
Écrire ('Donner le chiffre d’affaire mensuel en DHS')
Lire (CA)
Com ⎯ CA * 5/100
Sal ⎯ Com + M
Écrire ('Le salaire mensuel est de : ', Sal, ' en DHS ' )
FIN
72
Les opérateurs arithmétiques

Opérateur Signification

+ Addition

- Soustraction

* Multiplication

/ Division

% ou mod Modulo : le reste de la division de 2


valeurs entières
div Division entière
73
Exemple d’utilisation

25 / 4 = 6.25

25 div 4 = 6

25 mod 4 = 25 % 4 = 1

75 / 6 = 12.5

75 div 6 = 12

75 mod 6 = 75 % 6 = 3

74
Les opérateurs de comparaison

Pour exprimer les conditions, on utilise les opérateurs conditionnels suivants :

Opérateur Signification
= Égal
< Inférieur
> Supérieur
<= Inférieur ou égal
>= Supérieur ou égal
<> différent

75
Les opérateurs logiques de relation

On peut combiner des conditions à l’aide des opérateurs logiques :

Opérateur Signification
Et Et logique

Ou Ou logique

Non Négation logique

Ou = Xor Ou exclusif

76
Exemple d’utilisation

Le XOR (ou OU exclusif) fonctionne de la manière


suivante. Pour que "Condition1 XOR Condition2" soit VRAI, il
faut que soit Condition1 soit VRAI, soit que Condition2 soit
VRAI. Si toutes les deux sont fausses, ou que toutes les deux sont
VRAI, alors le résultat global est considéré comme FAUX.

Le XOR est donc l'équivalent du "ou bien" du langage courant

77
Exercice (6)

Ecrire un algorithme qui exprime un nombre N de


secondes sous forme d'heures, minutes , secondes. Application
numérique: N= 5750 s

78
Solution (6)

Algorithme : Conversion HMS

Variables SEC, MIN, H : Entier


Début
Ecrire (" Donnez le nombre des secondes : ? ")
Lire (SEC);

MIN ⎯ SEC div 60


H ⎯ MIN div 60
SEC ⎯ SEC mod 60
MIN ⎯ MIN mod 60

Ecrire ("----- Conversion effectuée -----")


Ecrire (H, ':', MIN, ':', SEC)
Fin

Exemple : 5750 S 1H , 35 MIN et 50 S


79
Priorités des opérateurs

Priorité de *, / div et % par rapport à + et -


5 + 9 * 3 = 32 et non 42
5*9+3 = 48 et non 60
Pour les opérateurs de même priorité, associativité à partir de la
gauche
15 / 5 * 3 = 9 et non 1
5 – 2 + 4 = 7 et non –1
On peut utiliser des parenthèses pour changer l’ordre des
opérations :
15 / (5 * 3) = 1
(5 + 9 ) * 3 = 42

80
Instructions à structure alternative (1)

Les conditions :

On appelle condition simple toute expression de la forme :

Variable 1 Opérateur Variable 2

81
Instructions à structure alternative (2)

L’instruction Si :
Pour exprimer le fait que des instructions vont être
exécutées dans un cas alors que d’autres instructions peuvent être
exécutées dans l’autre cas, on utilise une structure alternative.
Syntaxe :

Si condition alors
Actions 1
[ Sinon
Actions 2] Option Facultative
Finsi
82
Instructions à structure alternative (3)

Exemples : Titre : Test 2


Titre : Test 1 Variable x : entier
Variable x : entier Début
Début Écrire ('Saisir un entier x ')
Écrire ('Saisir un entier x ') Lire (x)
Lire (x) Si (x > 0) alors
Si (x > 0) alors Écrire (' x est un nombre positif ')
Écrire('x est un nombre positif ') Sinon
Finsi Écrire (' x est un nombre négatif ou nul')
Fin Finsi
Fin

83
Exercice (8)

Ecrire un algorithme qui permet de déterminer si un triangle


ABC est rectangle en C.
B

84
Solution (8)
Solutions: Algo 1
Algorithme Triangle-rectangle-en-C
Variables AB, AC, BC, x , y : nombres réels
Début
// Entrée:
Ecrire (‘ Entrer la valeur de AB ‘)
Lire (AB)
Ecrire (‘Entrer la valeur de AC ‘)
Lire (AC)
Ecrire (‘Entrer la valeur de BC ‘)
Lire (BC)
// Traitement :
x AB*AB
y AC*AC+BC*BC
Si (x = y) Alors
Ecrire (‘Le triangle ABC est rectangle en C’)
Sinon
Ecrire (‘Le triangle ABC n’est pas rectangle en C’)
Fin Si
Fin
85
Exercice (9)
Ecrire un Algorithme qui demande à l’utilisateur trois nombres entiers (ou réels), puis affiche le
plus grand des trois.

Titre : maximum
Variable n1, n2, n3, max : Entier
Début
Écrire (‘Donner les trois nombres ')
Lire (n1, n2, n3)
Si (n1 > n2) et (n1 > n3)
Alors max n1
Sinon
Si (n2 > n1) et (n2 > n3)
Alors max n2
Sinon max n3
Finsi
Finsi
Écrire (‘ Le plus grand des trois est:’, max)
Fin

86
Exercice (10)

Exemple :
Dans l’exercice (3) où on a calculé la moyenne générale, Afficher
‘Admis’ si un étudiant a une moyenne générale >=10 et Afficher ‘Ajourné’ dans
le cas contraire (Moyenne générale < 10).

Solution : …………….(Reste de l’algorithme)


Si (Moy >= 10) alors
Écrire ('Admis')
Sinon
Écrire ('Ajourné')
Finsi
FIN
87
Exercice (11)

Exercice :

Écrire l’algorithme qui permet de déterminer le


salaire mensuel d’un commercial sachant que ce salaire
comporte un montant fixe de 3000 DH et une commission
qui représente 5% du chiffre d’affaire réalisé par mois si ce
chiffre est inférieur à 30000 et de 10 % dans le cas contraire.

88
Solution (11)
Algorithme : Commission
Déclaration :
Constante M = 3000
Variable CA : Entier * Donnée d’entrée*
Com : Réel * Donnée intermédiaire*
Sal : Réel * Donnée de sortie*
Manipulation :
DEBUT
Écrire ('Donner le chiffre d’affaire mensuel en DHS')
Lire(CA)
Si (CA < 30000) Alors
Com ⎯ CA * 0.05
Sinon
Com ⎯ CA * 0.1
Finsi

Sal ⎯ Com + M
Écrire ('Le salaire mensuel est de : ', Sal , 'DHS')

FIN K. SATORI 89
Exercice (12)

Le Parking « courte durée » d’un aéroport permet aux automobilistes


de stationner leur voiture pendant 4 heures au plus. Il est gratuit pendant la
première demi-heure et devient payant dès la 31ème minute. Entre 31 minutes
et 2 heures (limites incluses), le prix est de 5 DH. Ensuite, entre 2 et 3 heures
(limite incluses), le prix est de 6 DH, enfin entre 3 et 4 heures (limite incluse),
il est de 8 DH.
Ecrire un Algorithme qui demande à l’utilisateur quels sont ses horaires
d’entrée et de sortie sur le Parking, puis affiche le prix à payer.

90
Solution (12)
Algorithme : Prix Parking
Déclaration :
Variable H_ent, M_ent: Entier * Donnée d’entrée*
H_sor, M_sor: Entier * Donnée d’entrée*
Dm: Entier * Durée en minute *
Prix : Entier * Donnée de sortie*
Manipulation :
DEBUT
Écrire ('Donner l’heure et la minute d’entrée')
Lire(H_ent, M_ent)
Écrire ('Donner l’heure et la minute de sortie')
Lire(H_sor, M_sor)
Dm = (H_sor – H_ent) * 60 + (M_sor- M_ent)
Si (Dm < 30) Alors
Prix ⎯ 0,00
Finsi

Si (30 < Dm) et (Dm < 120) alors


Prix ⎯ 5,00
Finsi

Si (120 < Dm) et (Dm < 180) alors


Prix ⎯ 6,00
Finsi

Si (180 < Dm) alors


Prix ⎯ 8,00
Finsi

Écrire (‘Le Prix à payer est : ‘, Prix , ‘Dhs')


FIN 91
Algorithme : Prix Parking
Déclaration :
Variable H_ent, M_ent: Entier * Donnée d’entrée*
H_sor, M_sor: Entier * Donnée d’entrée*
Dm: Entier * Durée en minute *
Prix : Entier * Donnée de sortie*
Manipulation :
Début
Écrire ('Donner l’heure et la minute d’entrée')
Lire (H_ent, M_ent)
Écrire ('Donner l’heure et la minute de sortie')
Lire (H_sor, M_sor)
Dm = (H_sor – H_ent) * 60 + (M_sor- M_ent)
Si (Dm < 30) alors
Prix ⎯ 0,0
Sinon
Si (Dm <120) alors Prix ⎯ 5,00
Sinon
Si (Dm <180) alors Prix ⎯ 6,00

Sinon
Prix ⎯ 8,00
FinSi
FinSi
FinSi

Écrire (‘Le Prix à payer est : ‘, Prix , ‘Dhs')

FIN 92
Instructions à structure alternative (4)
Sélective Si-Sinon-Si

Syntaxe
Si condition1 Alors
instructions1
Sinon Si condition 2 Alors
instructions 2
Sinon Si...
...
Sinon Si condition N Alors
instructions N
Sinon
instructions N+1
FinSi
93
Exercice (11)

Exercice :

Écrire l’algorithme qui permet de déterminer l’état de


l’eau en fonction de la température en degrés Celsius
1. Inférieur à zéro de la glace.
2. Inférieur ou égal à 25° confortable
3. Inférieur à 100 très chaude
4. Supérieur à 100 de vapeur

94
Instructions à structure alternative (5)
Algorithme (Version Si-Sinon-Si)

Algorithme température
Variable temp : Entier
Début
Ecrire ( " Donner la température de l'eau? " )
Lire ( temp )
Si ( temp <= 0 ) Alors
Ecrire ( "C'est de la glace" )
Sinon Si ( temp <= 25 ) Alors
Ecrire ( "C'est confortable" )
Sinon Si ( temp < 100 ) Alors
Ecrire ( "C'est très chaud" )
Sinon
Ecrire ( "C'est de la vapeur" )
Fin Si
Fin
95
Instructions à structure alternative (7)

Sélective Selon
L’instruction Selon Cas :

L’instruction Selon cas constitue une structure alternative à la


forme en bloc [Si … Alors …Sinon…] et permet de formuler de
manière plus simple le choix du groupe d’instructions.

96
Instructions à structure alternative (8)

Syntaxe :

Selon Cas variable Faire


Cas Valeur 1
Actions 1
Cas Valeur 2, Valeur3, Valeur 4
Actions 2
Cas Valeur 5 à Valeur 7
Actions 3
..
..
Sinon Cas
Actions N
Fin Selon
97
Exercice (13)
Exemple
Afficher le nom correspondant au chiffre saisie au clavier (entre 0 et 5).
Algorithme Nom_chiffre ;
Variable n : entier ;
Début
Ecrire ('donnez votre chiffre entre 0 et 5 : ') ; Lire (n) ;
Selon cas n faire
Cas 0 Ecrire (' Zéro') ;
Cas 1 Ecrire ('Un') ;
Cas 2 Ecrire ('Deux') ;
Cas 3 Ecrire ('Trois') ;
Cas 4 Ecrire (‘Quatre') ;
Cas 5 Ecrire (‘Cinq') ;
Sinon Cas
Ecrire ('vous n’avez pas respecter la demande ') ;
Fin Selon
Fin.

98
Exercice (14)

Ecrire L'algorithme qui demande le numéro du mois (entier), puis


affiche le nombre de jours du mois. Il utilise une structure Selon en
regroupant les étiquettes de mois à 31 jours (mois de janvier, mars, mai,
juillet, août, octobre et décembre), les mois à 30 jours (mois d'avril, juin,
septembre et novembre) et le cas de février (28 ou 29 jours). Dans tous les
autres cas, il indique que le numéro de mois n'est pas valide.

99
Solution (14)
Algorithme jours des mois
Variable mois : Entier
Début
écrire ( "De quel mois s'agit-il? " )
lire ( mois )
Selon cas ( mois ) Faire
Cas 1 , 3 , 5 , 7 , 8 , 10 , 12
écrire ( " Cas des mois numéro 1,3,5,7,8,10,12" )
écrire ( " Nombre de jours : 31" )
Cas 4 , 6 , 9 , 11
écrire ( " Cas des mois numéro 4,6,9,11" )
écrire ( " Nombre de jours : 30" )
Cas 2
écrire ( " Cas du mois de février" )
écrire ( " Nombre de jours : 28 ou 29" )
Sinon Cas
écrire ( " Cas Autre" )
écrire ( " Ce mois n'existe pas" )
Fin Selon
Fin
100
EXERCICE (15)
Écrire un algorithme qui à partir d’un nombre compris entre 1 et 7 affiche le
jour correspondant ?
Algorithme jours_semaine :
Variable jour : entier ;
Début
Ecrire ("Saisir une valeur : ") ;
Lire (jour) ;
Selon cas (jour ) Faire
Cas 1 : Ecrire ("Lundi")
Cas 2 : Ecrire ("Mardi")
Cas 3 : Ecrire ("Mercredi")
Cas 4 : Ecrire ("Jeudi")
Cas 5 : Ecrire ("Vendredi")
Cas 6 : Ecrire ("Samedi")
Cas 7 : Ecrire ("Dimanche")
Sinon cas
Ecrire ("Jour invalide")
Fin selon
Fin 101
Instructions à structure répétitive (1)

Problème :
Écrire un algorithme permettant d’afficher 300 fois le message :
‘‘bonjour tout le monde’’.

Solution Classique :

Début
Écrire (' Bonjour tout le monde ') 1
Écrire (' Bonjour tout le monde ') 2
.
.
Écrire (' Bonjour tout le monde ') 300
Fin

102
Instructions à structure répétitive (2)
Boucle « Tant que Faire »
L’instruction Tant que :
On utilise cette instruction pour exécuter des actions tant
qu’une condition est réalisée.
Syntaxe :
<initialisation>
Tant que Condition Faire

<bloc de traitement>
<bloc de contrôle> Action
Fin tant que
103
Instructions à structure répétitive (3)
Boucle « Tant que Faire »

Solution de l’exercice précédent :


Variable i : Entier
DEBUT
i ⎯ 0 * Initialisation *
Tant que (i < 300) Faire
Écrire (' Bonjour tout le monde ')
i  i+1
Fin tant que
FIN
104
Instructions à structure répétitive (4)
Boucle « Tant que Faire »
Exercice : Afficher tous les multiples de 9 inférieurs à 485
Titre : Multiples de 9
Variable M, i : Entier *i: variable intermédiaire: compteur*
DEBUT
i ⎯ 1 * initialisation de la boucle*
M ⎯ 9
Tant que (M < 485) Faire
Écrire (M , ' est un multiple de 9 ' )
M ⎯ i * 9
i  i+1 * incrémentation du compteur *
Fin tant que
FIN
105
Exercice (16)

Ecrire un algorithme qui demande un nombre compris


entre 10 et 20, jusqu’à ce que la réponse convienne. En
cas de réponse supérieure à 20, on fera apparaître un
message : « Plus petit ! », et inversement, « Plus grand ! »
si le nombre est inférieur à 10.

106
Solution (16)
Algorithme entre 10 et 20

Variable N : Entier
Début
Ecrire ("Entrez un nombre entre 10 et 20")
Lire (N)
Tantque N < 10 ou N > 20

Si N < 10 Alors
Ecrire ("Plus grand !")
SinonSi N > 20 Alors
Ecrire ("Plus petit !")
FinSi
FinTantQue
Fin
107
Instructions à structure répétitive (5)
Boucle « Tant que Faire »
Exemple 1: Dans cet algorithme combien de fois la boucle est- elle exécutée ?
Titre : Boucle1
Variable i , y : Entier
i = variable intermédiaire
Début = compteur
i i  i+1 = incrémentation
du compteur
y0
Tant que (i<7) faire
i  i+1
y  y+i
Écrire (' y = ' , y)
Fin Tant que
Fin 108
Instructions à structure répétitive (6)
Boucle « Faire jusqu’à »

L’instruction Faire jusqu’à :


On utilise cette instruction pour exécuter des actions
jusqu'à ce que une condition soit remplie.

Syntaxe :
<Initialisation>
Faire
<bloc de traitement>
<bloc de progression > Action
Jusqu’à Condition
109
Instructions à structure répétitive (7)
Boucle « Faire jusqu’à »
Exemple
Titre : Boucle2
Variable i , y : Entier
Début
i
y0
Faire Valeurs de y ?
i  i+1
y  y+i
Écrire (' y = ' , y)
Jusqu’à (i <7)
Fin
110
Instructions à structure répétitive (8)
Boucle « Faire jusqu’à »
Exemple
Titre : Boucle3
Variable i , y : Entier
Début
i
y0
Faire Donner les valeurs de y
i  i+1
y  y+i
Écrire (' y = ' , y)
Jusqu’à (i = 7)
Fin
111
Instructions à structure répétitive (9)
Boucle « Faire jusqu’à »

Exercice :

Écrire un algorithme permettant de calculer, pour un entier


N> 0, la somme :
SN = 1 + 2 + 3 + …… + N

Écrire un algorithme permettant de calculer, pour un entier


N> 0, la somme :
SN = 1 + 6 + 11 + …… + N+5

112
Instructions à structure répétitive (10)
Boucle « Faire jusqu’à »
Solution :
Variable N,S, i : Entier
DEBUT
Écrire (' Saisir une valeur entière positive :')
Lire (N)
S ⎯ 1 * initialisation de la boucle*
i ⎯ 0
Faire
i ⎯ i + 1
S ⎯ S + i
jusqu’à (i > =N)
Écrire (' La somme : S = ', S)
FIN 113
Instructions à structure répétitive (10)

Boucle « Faire jusqu’à »


Solution :
Variable N,S, i : Entier
DEBUT
Écrire (' Saisir une valeur entière positive :')
Lire (N)
S ⎯ 0 * initialisation de la boucle*
i ⎯ 1
Écrire (S)
Faire
i ⎯ i + 5
S ⎯ S + i
jusqu’à (i > =N)
Écrire (' La somme : S = ', S)
FIN
114
Instructions à structure répétitive (11)
Boucle « Faire jusqu’à »

Exercice :

Écrire un algorithme permettant de calculer la somme :


Sn = 1 + 1/2 + 1/3 + …… + 1/n

115
Instructions à structure répétitive (11)
Boucle « Faire jusqu’à »
Solution :
Variable N,S, i : Entier
DEBUT
Écrire (' Saisir une valeur entière positive :')
Lire (N)
S ⎯ 0 * initialisation de la boucle*
i ⎯ 1
Faire
S ⎯ S + 1/i
i ⎯ i + 1
jusqu’à (i > =N)
Écrire (' La somme : S = ', S)
FIN 116
Instructions à structure répétitive (12)
Boucle « Pour »
L’instruction Pour :
La spécification de cette instruction c’est qu’elle
limite le nombre de fois où doit se répéter le bloc Action
Syntaxe : La boucle est
<Initialisation> Inconditionnelle
On connaît à priori le
nombre d'itérations
Pour variable ⎯ valeur1 à valeur2 faire

<Bloc de traitement>
Action
Fin Pour
117
Instructions à structure répétitive (13)
Boucle « Pour »

Exercice :

Écrire un algorithme permettant le calcul du Factoriel d’un


entier N > 0 donné : N !

118
Instructions à structure répétitive (14)
Solution :

Titre : Factoriel
Variable N : Entier
i : Entier * i variable intermédiaire
F : Entier i = compteur *
DEBUT
Écrire (' Saisir une valeur entière N > 0 ')
Lire (N )
F 1 * initialisation de la boucle*
Pour i  1 à N Faire
F  F*i
Fin Pour
Écrire (' Le factoriel de ', N , ' est : ' , F)
FIN
119
Instructions à structure répétitive (15)
Boucle « Pour »

Exercice :

Écrire l’algorithme permettant de calculer la


moyenne des notes de N étudiants.

120
Instructions à structure répétitive (16)
Solution :

Titre : Moyenne
Variable N, i : Entier
note, S, Moy : Réel
DEBUT
Écrire (' Saisir le nombre d’étudiants: ')
Lire (N)
S ⎯⎯ 0 * initialisation de la boucle*
Pour i  1 à N faire
Écrire (' Saisir la note de l’étudiant ' , i , ' : ')
Lire (note)
S ⎯⎯ S + note
Fin Pour
Moy ⎯⎯ S/N
Écrire (' La moyenne est : ', Moy)
FIN
121
Instructions à structure répétitive (17)
Boucle « Pour »
Exercice
Écrire un algorithme permettant d’afficher les lettres de l’alphabet.
Solution :
Titre : alphabet
Variable lettre: Caractère
* parcourir les lettres de l'alphabet*
Début
Pour lettre  ' a ' à lettre = ' z ' Faire
Écrire(lettre)
FinPour
Fin
122
Instructions à structure répétitive (18)
Quelle répétition ou Boucle choisir ?

Si nombre d'itérations connu Alors


Boucle Pour
Sinon
Si itération exécutée au moins une fois Alors
Boucle Faire jusqu’à
Sinon
Boucle Tant que faire

123
Instructions à structure répétitive (19)
Boucles « Tant que faire » et « Faire jusqu’à »

Remarques: Soient T une condition et R l’action. Alors il y a équivalence


entre les boucles Tant que faire et Faire jusqu’à. La syntaxe est la suivante:
▪ Si T alors
◼ Tant Que T faire Faire
R ~ R
Fin Tant Que Jusqu ’à non(T)
FinSi
Et
◼ Faire ▪ R
Tant Que non(T) faire
R ~ R
jusqu ’à T Fin Tant Que
124
Instructions à structure répétitive (20)
Boucle « Pour »

Exercice :

1- Écrire un algorithme permettant de déterminer le Nème


terme d’une suite numérique connaissant son premier terme
et ses coefficients a et b et tels que:
Un = a * Un-1 + b  1  n N
2- Écrire un algorithme permettant de définir le rang N
et le terme correspondant de la suite tels que UN > 1000

125
Instructions à structure répétitive (21)

Solution :
1) Le nombre d’itérations est connu : Boucle Pour

Variable N, i : Entier
Variable a, b, S : Réel
Début
Écrire (' Saisir la valeur de N: ')
Lire (N)
Écrire ('Saisir la valeur du premier terme S et les coefs a et b:')
Lire (S , a, b )
Pour i  1 à N faire
S ⎯⎯ a * S + b
Fin Pour
Écrire ( ' Le Nème terme de la suite est : ', S )
Fin
126
Instructions à structure répétitive (22)
Solution :
2) Le nombre d’itérations inconnu : Boucle Faire jusqu’à

Variable N : Entier
Variable a, b, S : Réel
DEBUT
Écrire ('Saisir la valeur du premier terme et les coefs a et b:')
Lire (S , a, b)
N ⎯ 0
Faire
S ⎯⎯ a * S + b
N ⎯ N + 1
Jusqu’à S > 1000
Écrire (' Le Nème terme de la suite est : ', S)
Écrire (' Le rang est : ', N )
FIN 127
Instructions à structure répétitive (23)

Boucle « Pour »

Exercice :

Écrire un algorithme permettant de calculer la somme :


Sn(x) = 1/x + 2/x2 + 3 /x3 + …… + n /xn

128
Instructions à structure répétitive (24)
Solution :

Variable n, i : Entier
Variable S, prod : Réel
Début
Écrire (' Saisir l’ordre x et n: ')
Lire (x, n)
S ⎯⎯ 0
prod ⎯⎯ 1
Pour i  1 à N faire
Prod ⎯⎯ prod*x
S ⎯⎯ S + i/prod
Fin Pour
Écrire ( ' La somme est : ', S )
FIN
129
Introduction aux tableaux
Déclaration tab[N] : entier
On accède (en lecture ou en écriture) à la i ème valeur de
tableau tab en utilisant la syntaxe suivante :

Par exemple si tab est un tableau de 10 entiers (tab :


Tableau[1..10 ] d’Entier )

tab[2] ←-5 met la valeur -5 dans la 2 ème case du tableau

En considérant le cas où a est une variable de type Entier,


a ←tab[2] met la valeur de la 2 ème case du tableau tab dans a,
c’est-à-dire -5

lire(tab[1]) met l’entier saisi par l’utilisateur dans la première


case du tableau
130
Introduction aux tableaux (2)

Exercice 1

Ecrire un algorithme permettant de calculer et


d’afficher la moyenne des notes d’une promo saisie
par le Prof.

131
Introduction aux tableaux (3)

Algorithme moyenne des notes

Variable Somme, nbEleves, i : Entier,


Notes[100] : Réel (un tableau des réels)
Début
somme ← 0
répéter
écrire("Nombre d’élèves (maximum 100) :")
lire(nbEleves)
jusqu’à ce que (nbEleves>0) et (nbEleves ≤ 100)

132
Introduction aux tableaux (4)

pour i ←1 à nbEleves faire


écrire("Note de l’eleve numero ",i," :")
lire(lesNotes[i])
Fin pour
pour i ←1 à nbEleves faire
somme ← somme + Notes[i]
Fin pour
écrire("La moyenne est de :", somme/nbEleves)
Fin
133
Références:
▪ Annie Tartier et Alain Vailly « Premiers pas en algorithmique », 320 p, Edition
marketing, Ellipses, Paris Cedex. 2014.

webographie
▪ http://pise.info/algo/introduction.htm
▪ https://www.cours-gratuit.com/cours-algorithme/cours-et-exercices-complet-algorithmes-
en-pdf

134
FIN

135

Vous aimerez peut-être aussi