Vous êtes sur la page 1sur 81

Protocoles Avancées

Chap : Introduction au routage

Rhouma Rhouma
https://sites.google.com/site/rhoouma

Lebanese International University (LIU) en Mauritanie

Juin 2015

1 / 81
Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

2 / 81
Qu’est ce qu’un routeur ?

Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

3 / 81
Qu’est ce qu’un routeur ?

Vu de face/arrière d’un routeur

4 / 81
Qu’est ce qu’un routeur ?

composants materiels

5 / 81
Qu’est ce qu’un routeur ?

composants materiels

6 / 81
Qu’est ce qu’un routeur ?

Internetwork Operating System

7 / 81
Qu’est ce qu’un routeur ?

Qu’est ce qu’un routeur ?

8 / 81
Qu’est ce qu’un routeur ?

Qu’est ce qu’un routeur ?

9 / 81
Qu’est ce qu’un routeur ?

Qu’est ce qu’un routeur ?

10 / 81
Qu’est ce qu’un routeur ?

@ Destination du paquet IP

11 / 81
Qu’est ce qu’un routeur ?

Réseaux directement connectés C

12 / 81
Qu’est ce qu’un routeur ?

Configuration de base d’un routeur

13 / 81
Qu’est ce qu’un routeur ?

Configurer un password pour l’acces console et Telnet :


R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit

14 / 81
Qu’est ce qu’un routeur ?

Configuration de base d’un routeur

15 / 81
Qu’est ce qu’un routeur ?

configurer une adresse IP à une interface :


R1(config)#interface Serial0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
Donner une description au routeur :
Router(config-if)#description Salle01
activation de l’interface :
Router(config-if)#no shutdown
Appliquez les commandes de configuration d’interface à toutes les
autres interfaces à configurer :
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#description R1 LAN
R1(config-if)#no shutdown

16 / 81
Qu’est ce qu’un routeur ?

Vérification de la configuration de routeur de base


show running-config

17 / 81
Qu’est ce qu’un routeur ?

show interfaces

18 / 81
Qu’est ce qu’un routeur ?

show ip route

19 / 81
Qu’est ce qu’un routeur ?

show startup-config donne le meme resultat que show


running-config sauf si sauf la configuration en cours est
enregistrée dans la mémoire vive non volatile à l’aide de la
commande copy running-config startup-config.

20 / 81
Qu’est ce qu’un routeur ?

show ip interface brief : Il s’agit d’un outil utile de dépannage et


d’un moyen rapide de déterminer l’état de toutes les interfaces du
routeur.

21 / 81
Routage statique ou dynamique ?

Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

22 / 81
Routage statique ou dynamique ?

Routage statique S

23 / 81
Routage statique ou dynamique ?

Quand utiliser les routes statiques ?


Un réseau ne comporte que quelques routeurs. Dans ce cas,
l’utilisation d’un protocole de routage dynamique ne présente
aucun bénéfice substantiel. Par contre, le routage dynamique peut
accroître la charge administrative.
Un réseau est connecté à Internet via un seul FAI. Il n’est pas
nécessaire d’utiliser un protocole de routage dynamique sur cette
liaison car le FAI représente le seul point de sortie vers Internet.
Une route statique inclut l’adresse réseau et le masque de
sous-réseau du réseau distant, ainsi que l’adresse IP du routeur
du tronçon suivant ou de l’interface de sortie. Les routes statiques
sont indiquées par le code S dans la table de routage.
la table de routage doit d’abord contenir les réseaux directement
connectés utilisés pour accéder aux réseaux distants, avant de
pouvoir utiliser tout routage statique ou dynamique.

24 / 81
Routage statique ou dynamique ?

Algorithmes de routage dynamique

25 / 81
Routage statique ou dynamique ?

Comparaison routage statique/dynamique

26 / 81
Routage statique ou dynamique ?

Système Autonome

Un système autonome (SA), également appelé domaine de routage,


est un ensemble de routeurs dont l’administration est commune. Le
réseau interne d’une société et le réseau d’un fournisseur de services
Internet en sont des exemples. Dans la mesure où Internet repose sur
le concept de système autonome, deux types de protocoles de
routage sont nécessaires : des protocoles de routage intérieurs et
extérieurs. Ces protocoles sont les suivants :
Les protocoles IGP (Interior Gateway Protocols) sont utilisés pour
le routage interne du système autonome.
Les protocoles EGP (Exterior Gateway Protocol) sont utilisés pour
le routage entre systèmes autonomes.

27 / 81
Routage statique ou dynamique ?

Protocoles IGP et EGP

28 / 81
Routage statique ou dynamique ?

BGP

les protocoles EGP sont conçus pour être utilisés entre différents
systèmes autonomes contrôlées par des administrations
distinctes.
BGP est le seul protocole de routage EGP actuellement viable
utilisé par Internet.
BGP est un protocole à vecteur de chemin qui peut utiliser de
nombreux attributs différents pour mesurer des routes.
Les FAI sont confrontés à des problèmes souvent plus importants
que le simple choix du chemin le plus rapide.
Le protocole BGP est généralement utilisé par les FAI pour
communiquer entre eux ou avec une société.

29 / 81
Routage statique ou dynamique ?

Routage dynamique

30 / 81
Routage statique ou dynamique ?

Routage dynamique

Dans la figure, R1 a reçu automatiquement les informations nécessaires concernant le


réseau 192.168.4.0/24 en provenance de R2, via le protocole de routage dynamique RIP
(Routing Information Protocol).
Les protocoles de routage dynamique sont utilisés par les routeurs pour partager des
informations sur l’accessibilité et l’état des réseaux distants. Les protocoles de routage
dynamique effectuent plusieurs tâches, notamment :
la détection de réseaux ;
la mise à jour des tables de routage.
Après la découverte initiale du réseau, les protocoles de routage dynamique mettent à jour
et gèrent les réseaux dans leurs tables de routage.
Les protocoles de routage dynamique ne déterminent pas seulement le meilleur chemin
pour rejoindre tel ou tel réseau, ils déterminent également un nouveau meilleur chemin si
le chemin initial devient inutilisable (ou si la topologie change).
Les routeurs utilisant des protocoles de routage dynamique partagent automatiquement
des informations de routage avec d’autres routeurs et prennent en compte toute
modification de la topologie, sans nécessiter l’intervention de l’administrateur réseau.

31 / 81
Routage statique ou dynamique ?

Meilleur chemin et mesure

Si la métrique "sauts" comme utilisé par RIP : meilleur chemin est


PC1-R1-R3-PC2
Si la métrique "bande passante" comme utilisé par OSPF :
meilleur chemin est PC1-R1-R2-R3-PC2
32 / 81
Routage statique ou dynamique ?

identification du meilleur chemin

Réseau directement connecté : si l’adresse IP de destination du paquet appartient à un


périphérique sur un réseau directement connecté à une des interfaces du routeur, ce
paquet est transféré directement à ce périphérique.
Réseau distant : si l’adresse IP de destination du paquet appartient à un réseau distant, le
paquet est transféré à un autre routeur. Les réseaux distants peuvent être atteints
uniquement en transférant les paquets à un autre routeur.
Aucune route déterminée : si l’adresse IP de destination du paquet n’appartient ni à un
réseau connecté ni à un réseau distant, et que le routeur ne possède pas de route par
défaut, le paquet est abandonné. Le routeur envoie un message ICMP de destination
inaccessible à l’adresse IP source du paquet.
33 / 81
Exemple de routage d’un paquet

Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

34 / 81
Exemple de routage d’un paquet

Exemple de tranfert d’un paquet

35 / 81
Exemple de routage d’un paquet

36 / 81
Exemple de routage d’un paquet

37 / 81
Exemple de routage d’un paquet

38 / 81
Exemple de routage d’un paquet

vérification de connexion

39 / 81
Mesures et Metriques

Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

40 / 81
Mesures et Metriques

Mesures
La mesure est utilisée pour déterminer quel chemin est préférable
en présence de plusieurs chemins vers le même réseau distant.
RIP utilise le nombre de sauts. EIGRP utilise une combinaison de
bande passante et de délai. OSPF fait appel à la bande passante.

41 / 81
Mesures et Metriques

Exemple de mesure dans RIP

42 / 81
Mesures et Metriques

Exemple de mesure dans RIP

43 / 81
Mesures et Metriques

distance administrative
La distance administrative (AD) définit la préférence d’une source de
routage.
Chaque source de routage est classée par ordre de priorité, du plus
préférable au moins préférable, à l’aide d’une valeur de distance
administrative.
Les routeurs Cisco utilisent la distance administrative (AD) pour
sélectionner le meilleur chemin lors de la découverte du même réseau
de destination à partir d’au moins deux sources de routage différentes.
La distance administrative est une valeur entière comprise entre
0 et 255. Plus la valeur est faible, plus la source de la route est
privilégiée. Une distance administrative de 0 est idéale.
Seul un réseau directement connecté a une distance administrative
égale à 0, laquelle ne peut pas être modifiée.
Une distance administrative de 255 signifie que le routeur ne se fiera
pas à la source de cette route et qu’elle ne sera pas installée dans la
table de routage.

44 / 81
Mesures et Metriques

exemple

45 / 81
Mesures et Metriques

Distances administratives par défaut

46 / 81
VLSM et CIDR

Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

47 / 81
VLSM et CIDR

Routage par classe ou sans classe

48 / 81
VLSM et CIDR

Routage par classe ou sans classe


Protocoles de routage par classe : Les protocoles de routage par classe
n’envoient pas d’informations sur les masques de sous-réseau dans les
mises à jour de routage. Les premiers protocoles de routage comme
RIP étaient des protocoles par classe. Les adresses réseau étaient alors
allouées en fonction de classes (A, B ou C). Il n’était pas nécessaire que
le protocole de routage inclue le masque de sous-réseau dans la mise à
jour de routage, car le masque de réseau pouvait être déterminé en
fonction du premier octet de l’adresse réseau. En d’autres termes, les
protocoles de routage par classe ne prennent pas en charge les
masques de sous-réseau de longueur variable (VLSM). Exemples :
RIPv1 et IGRP.
Protocoles de routage sans classe : es protocoles de routage sans
classe incluent le masque de sous-réseau avec l’adresse réseau dans
les mises à jour de routage. Les réseaux actuels ne sont plus alloués en
fonction de classes et le masque de sous-réseau ne peut pas être
déterminé par la valeur du premier octet. Les protocoles de routage sans
classe sont requis dans la plupart des réseaux actuels, car ils prennent
en charge les masques de sous-réseau de longueur variable (VLSM),
les réseaux discontinus. exemples : RIPv2, EIGRP, OSPF, IS-IS et BGP. 49 / 81
VLSM et CIDR

Routage par classe ou sans classe

50 / 81
VLSM et CIDR

Routage par classe

R1 sait que le sous-réseau 172.16.1.0 appartient au même réseau par classe principal
que l’interface sortante. Par conséquent, il envoie à R2 une mise à jour RIP contenant le
sous-réseau 172.16.1.0. Lorsque R2 reçoit la mise à jour, il applique le masque de
sous-réseau d’interface réceptrice (/24) à la mise à jour et ajoute 172.16.1.0 à la table de
routage.

51 / 81
VLSM et CIDR

Routage par classe

Lors de l’envoi des mises à jour à R3, R2 regroupe les


sous-réseaux 172.16.1.0/24, 172.16.2.0/24 et 172.16.3.0/24 dans
le réseau par classe principal 172.16.0.0. Aucun sous-réseau de
R3 n’appartenant à 172.16.0.0, il applique le masque par classe
d’un réseau de classe B (/16).

52 / 81
VLSM et CIDR

Adressage sans classe


En 1993, l’IETF introduit le routage interdomaine sans classe
(CIDR) (RFC 1517). Le CIDR permet :
une utilisation plus efficace de l’espace d’adressage IPv4 ;
une agrégation du préfixe réduisant la taille des tables de routage.

53 / 81
VLSM et CIDR

Les protocoles RIPv2, EIGRP, OSPF, IS-IS et BGP font partie des
protocoles de routage sans classe. Ces protocoles de routage
incluent le masque de sous-réseau et l’adresse réseau dans leurs
mises à jour de routage. Les protocoles de routage sans classe
sont nécessaires lorsque le masque ne peut pas être supposé ou
déterminé par la valeur du premier octet.

54 / 81
VLSM et CIDR

les réseaux 172.16.0.0/16, 172.17.0.0/16, 172.18.0.0/16 et


172.19.0.0/16 peuvent être regroupés par 172.16.0.0/14.

55 / 81
VLSM et CIDR

Avec un protocole de routage sans classe, R2 annonce à R3 le


réseau 172.16.0.0 avec le masque /14. R3 peut installer la route
de super-réseau 172.16.0.0/14 dans sa table de routage, et de ce
fait R3 devient accessible aux réseaux 172.16.0.0/16,
172.17.0.0/16, 172.18.0.0/16 et 172.19.0.0/16.
Si le routeur R2 envoie l’information de résumé du routage
172.16.0.0 sans le masque /14, R3 applique le masque par classe
par défaut /16. En effet, dans un scénario de protocole de routage
par classe, R3 ne connaît pas les réseaux 172.17.0.0/16,
172.18.0.0/16 et 172.19.0.0/16.

56 / 81
VLSM et CIDR

VLSM et adressage IP

57 / 81
VLSM et CIDR

VLSM et adressage IP

58 / 81
VLSM et CIDR

VLSM et adressage IP

59 / 81
Commandes cisco pour routage statique

Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

60 / 81
Commandes cisco pour routage statique

commande Cisco pour configurer une route statique

61 / 81
Commandes cisco pour routage statique

exemple

62 / 81
Commandes cisco pour routage statique

etape 1 : d’abord routes connectés

63 / 81
Commandes cisco pour routage statique

etape 2 : configuration de la route statique

64 / 81
Commandes cisco pour routage statique

etape 3 : configuration des routes manquantes

65 / 81
Commandes cisco pour routage statique

etape 4 : configuration de R2 et R3

66 / 81
Commandes cisco pour routage statique

etape 5 :

67 / 81
Commandes cisco pour routage statique

etape 6 : verification de la conectivité

68 / 81
Commandes cisco pour routage statique

69 / 81
Commandes cisco pour routage statique

70 / 81
Commandes cisco pour routage statique

71 / 81
Commandes cisco pour routage statique

Résumé de routage avec routage statique


Le CIDR ignore les limitations des classes et autorise le résumé
avec les masques inférieurs à celui du masque par classe par
défaut. Ce type de résumé permet de réduire le nombre d’entrées
dans les mises à jour de routage et de diminuer le nombre
d’entrées dans les tables de routage locales. Il permet également
de réduire la bande passante utilisée pour les mises à jour de
routage et d’effectuer des recherches plus rapidement dans les
tables de routage.

72 / 81
Commandes cisco pour routage statique

Calcul de résumé de routage

73 / 81
Commandes cisco pour routage statique

exemple : Routes statiques résumés

Dans l’exemple, le routeur R3 possède trois routes statiques. Les


trois routes transfèrent du trafic vers la même interface
Serial0/0/1.

Les trois routes utilisant la même interface de sortie, elles peuvent


être résumées vers le réseau unique 172.16.0.0 255.255.252.0 et
nous pouvons créer un seul résumé du routage.

74 / 81
Commandes cisco pour routage statique

calcul de resumé

75 / 81
Commandes cisco pour routage statique

76 / 81
Route statique par défaut

Plan

1 Qu’est ce qu’un routeur ?

2 Routage statique ou dynamique ?

3 Exemple de routage d’un paquet

4 Mesures et Metriques

5 VLSM et CIDR

6 Commandes cisco pour routage statique

7 Route statique par défaut

77 / 81
Route statique par défaut

routeur d’extrémité
Une route statique par défaut est une route qui correspond à tous les paquets. Les routes
statiques par défaut sont utilisées :
Quand aucune autre route de la table de routage ne correspond à l’adresse IP de
destination du paquet, en d’autres termes, en l’absence d’une correspondance plus
spécifique. Couramment utilisées lors de la connexion d’un routeur de périphérie d’une
société au réseau du FAI.
Lorsqu’un routeur n’est connecté qu’à un seul autre routeur. Ce cas est appelé « routeur
d’extrémité ».

78 / 81
Route statique par défaut

syntaxe

La syntaxe pour une route statique par défaut est similaire à toute
autre route statique, à l’exception du fait que l’adresse réseau est
0.0.0.0 et que le masque de sous-réseau est 0.0.0.0 :
Router(config)#ip route 0.0.0.0 0.0.0.0 [exit-interface | ip-address ]
L’adresse et le masque réseau 0.0.0.0 0.0.0.0 sont appelés route
« à quatre zéros ».
R1 est un routeur d’extrémité. Il est connecté uniquement à R2.
Actuellement, R1 a trois routes statiques, utilisées pour atteindre
tous les réseaux distants dans notre topologie :
ip route 172.16.1.0 255.255.255.0 serial 0/0/0
ip route 192.168.1.0 255.255.255.0 serial 0/0/0
ip route 192.168.2.0 255.255.255.0 serial 0/0/0

79 / 81
Route statique par défaut

comment faire ?

Le routeur R1 constitue un candidat idéal pour que toutes ses


routes statiques soient remplacées par une route unique par
défaut. Tout d’abord, supprimez les trois routes statiques :
R1(config)#no ip route 172.16.1.0 255.255.255.0 serial 0/0/0
R1(config)#no ip route 192.168.1.0 255.255.255.0 serial 0/0/0
R1(config)#no ip route 192.168.2.0 255.255.255.0 serial 0/0/0
Ensuite, configurez la route statique par défaut unique à l’aide de
la même interface de sortie Serial 0/0/0 que les trois routes
statiques précédentes :
R1(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0/0

80 / 81
Route statique par défaut

verification

81 / 81