Vous êtes sur la page 1sur 39

Asterisk code 1

1
COMPILATION DES TPs RESEAUX – Licence 2

 Public concerné
 Objectifs
- Etudiants en Licence
- Prise en main des routeurs à l’aide
- Passionnés du réseau
des routeurs et switchs de type
- Débutants dans l’utilisation du
Cisco.
simulateur Packet Tracer
- Avoir des notions de découpage
réseau  Caractéristiques
- Avoir des Notions de routage Durée : 20 min (Par TP)
(Statiques et dynamiques) N° de l’éditeur : +221 77 262 30 77
- Maitrise des Vlans Référence : Prise en main de Packet
Tracer
 Programme général
Support Libre de téléchargement
Contact : ecole.ec2lt@gmail.com 1 – Introduction
L’éditeur du support :
2 – Présentation d’un routeur
Abdelrahim Ibrahim-Mahamat
(Année 2011 - 2012) 3 – Routage, Protocoles de routage

 Pré-requis 4 – Routage statique


- Etre passionné du réseau
5 – Routage dynamique
- Avoir des bases dans l’adressage réseau
6 – Commandes et Configurations

2
INTRODUCTION

Les techniques de transfert de paquets doivent permettre de transférer une


trame arrivant dans un nœud vers une ligne de sortie. Les techniques qui
permettent ce transfert sont de deux types : le routage et la commutation. Le
routage consiste à déterminer le meilleur chemin pour les paquets et la
commutation qui permet de commuter ceux-ci vers les interfaces appropriées.

Cependant, nous allons tenter de définir le routeur et voir, les différents


types de routage, les commandes, la configuration riche en capture d’écran.

PRSENTATION DU ROUTEUR

Un routeur est un élément intermédiaire dans un réseau informatique


assurant le routage de paquets entre réseaux indépendants. Ce routage est réalisé
selon un ensemble de règles formant la table de routage. C’est un équipement de
couche réseaux (3) du modèle OSI.

Il est constitué de :

Processeur(UC) : Il exécute l’instruction du système d’exploitation IOS. Ses


principales fonctions sont, entre autres, l’initialisation du système, le routage et le
contrôle de l’interface réseau.

RAM (Randon Access Memory) : Elle gère la table de routage et la file d’attente,
contient la cache ARP. Elle sert de mémoire temporaire pour les fichiers de
configurations à la mise sous tension du routeur. Elle perd son contenu si la
machine est mise hors tension.

NVRAM (Non volatile) : Assure le stockage de fichier de configuration de


démarrage. Elle conserve son contenu lors de la mise hors tension du routeur.

Flash : emplacement par défaut de l’image du système d’exploitation (Ios file).

ROM (Randon Only Memory) : Elle gère les instructions du test automatique de

3
mise sous tension (power on self test ou le POST) de démarrage. Il charge les IOS
de la mémoire flash vers la mémoire vive.

Interfaces : Connexion réseau à travers lesquelles les paquets entrent et sortent


du routeur, elles peuvent être sur la carte mère ou sur un module séparé.

Port console : Fournit un accès au routeur à travers une ligne RS232 (ligne série
asynchrone) pour la gestion et la configuration du routeur.

ROUTAGE

Le routage est le processus de transmission de paquets entre des segments


réseaux connectés. Chaque paquet entrant ou sortant est appelé paquet IP
(contient une adresse source et destination). Un routeur utilise des logiciels pour
créer des tables de routage. Ces tables regroupent dans un nœud réseau
quelconque les données utilisées pour déterminer une route ou retransmettre un
message reçu pour qu’il puisse atteindre sa destination. Ces tables contiennent
des informations indiquant quelle interface matérielle du routeur est l'itinéraire
de départ qui permettra aux paquets d'arriver à leurs destinations finales.

4
Alors que les protocoles de routage fournissent le système d’adresse logique qui
rend le routage possible. Ces protocoles de routage servent à gérer la table de
routage des routeurs. Ils permettent au routeur de communiquer et ainsi de
partager des informations de routages dont ils se servent pour construire la table
de routage.

Il existe plusieurs protocoles de routage, tels que :

RIP (Routing Information Protocol)

OSPF (Open Shortest Path First)

EIGRP (Enhanced Interior Gateway Routing Protocol)

LE ROUTAGE STATIQUE

Dans le cas du routage, la table de routage est entrée manuellement par un


administrateur. Le routeur statique ne partage pas d’informations avec les autres
routeurs. Il peut être utilisé pour des petits réseaux.

Syntaxe :

IP route [adresse de réseau de destination] [masque de réseau] [adresse de


l’interface appropriée]

Exemple :

Router(config)#ip route 192.168.1.0 255.255.255.0 172.10.0.1

LE ROUTAGE DYNAMIQUE

Le routeur construit lui-même sa table de routage en fonction des


informations qu’il reçoit des protocoles de routage. Le routeur sélectionne la
route la mieux adaptée à un paquet où à un datagramme circulant dans le réseau.

5
A la fin de chaque circuit, le routeur décide du chemin convenant le mieux en
utilisant les informations d’état du réseau transmises d’un routeur à l’autre par
des protocoles d’acheminement d’information.

Syntaxe :

Router [nom du protocole]

Network [adresse de réseau concernée]

Network [adresse de réseau concernée]

Exemple :

Router(config-router)#router rip

Router(config-router)#network 192.168.1.0

Router(config-router)#network 192.168.2.0

COMMANDES ET CONFIGURATIONS

 Les commandes :

Voici quelques commandes susceptibles de vous permettre de faire des


configurations basiques. De ce fait, nous allons les lister de la manière suivante :

Quand on démarre un routeur Cisco, c’est la ligne suivante qui s’affiche, donc on
choisi l’option « no » pour ne pas accepter de continuer le dialogue.

Continue with configuration dialog? [Yes/no]: no

Router>enable : pour passer en mode privilégié

Router#configure terminal : pour passer en mode de configuration globale

6
o Pour gérer l’Affichage

Router#show running-config : Affiche la configuration courante

Router#show startup-config : Affiche la configuration de démarrage

Router#show version : Affiche la version de l’IOS

Router#showip interface brief : Affiche les informations IP sur toutes les


interfaces.

Router#showcontrollers serial 0/0 : Affiche les informations sur le câblesérie.

Router#showip route : Affiche la table de routage.

Router#show access-lists : Affiche les listes de contrôles d’accès.

o Sauvegarde et restauration des fichiers de configuration

Router#enable : Entrer en mode privilégié

Router#configure terminal : Entrer dans le mode de configuration global.

Router(config)#hostname Abdelrahim : Changer le nom du routeur.

Router#copy running-config startup-config : Copier la configuration courante vers


la configuration de démarrage du routeur.

Router#copy running-config tftp : Copier la configuration vers un serveur tftp.

Router#erase startup-config : Effacer le fichier de configuration de démarrage

Router#reload : Redémarrer le routeur

o Configuration d’une interface

Router(config)#interface fastEthernet 0/0 : Entrer dans le mode de configuration


de l’interface fastEthernet 0/0

Router(config)#interfaceFastEthernet 0/0.1 : Entrer dans le mode de

7
configuration de la sous interface FastEthernet 0/0.1

Router(config-subinf)#encapsulation dot1q 10 : Attribution d’une sous Interface


au vlan 20

Router(config-if)#ipaddress 192.168.1.60 255.255.255.0 : Configure l’adresse IP


et le masque

Router(config-if)#clock rate 64000 : Configuration du clock rate (câble série DCE)

Router(config-if)#no shutdown : Activer l’interface

Router (config)#ipdhcp pool EC2LT : Pour créer un serveur dhcp

Router(dhcp-config)#network 192.168.1.0 255.255.255.0 : Pour définir la plage


d'adresse

Router (config)#ipdhcp pool excluded-address (Adresse début) (Adresse fin) :


Exclure des adresses IP pour des faits bien spécifiques

Router(dhcp-config)#default-router 192.168.1.1 : Pour indiquer au pc leurs


passerelle

Router(config)#router rip: Pour définir un protocole de routage

Router(config-router)#network 192.168.1.0 : pour renseigner la table de routage

Router#vlandatabase : Entrer dans le mode de création cde vlan

Switch(vlan)#vlan 10 name RTN : Créer un vlan 10 de nom RTN

Switch(config-if)#switchport mode acces : Configurer un port en mode access

Switch(config-if)#switchportaccesvlan 10: Attribution d’un port au vlan 10

Switch(confi g-if)#switchport mode trunk : Déclaration d’un port trunk

8
 CONFIGURATION

Nous préférons montrer d’autres configurations ci-dessous. De ce fait, nous avons


choisi comme outil de simulation, le logiciel Packet tracer.

Les TP sont répartis de la manière suivante :

TP N° 1 : Configuration d’un routeur avec un serveur dhcp et Routage RIP

Figure 1 : Architecture du TP N° 1

Tâche 1 : Nous allons configurer les interfaces, mettre en place un serveur DHCP, et ensuite le routage
dynamique avec comme protocole de routage RIP. Il faudrait mettre le clock rate 64000 seulement sur
l’interface qui à l’horloge.

9
NB : Même chose pour les autres, mais en modifiant les paramètres suivants :
- Les adresses ip des interfaces
- Les passerelles des réseaux
- Activer les interfaces réseaux

10
TP N° 2 : Connexion des machines sur un Switch Cisco

VLAN niveau 1 (par port) : Vlan repartis

Pour créer les vlan, on doit se mettre en mode privilégié et taper la


commande :

vlan database. Tandis que pour l’attribution des ports aux différents vlan on doit
se mettre en monde de configuration globale et en se connectant sur l’interface
comme le montre la configuration suivante.

Figure 2 : Vlan Repartis

11
NB : Même chose pour les autres interfaces.

12
TP N° 3 : Inter-vlan

13
 Configuration du Switch

14
 Configuration du routeur

15
TP N° 4 : Attribution des adresses dynamique pour chaque vlan par le routeur du réseau.

Pour ce TP, nous considérons la même architecture que le TP N° 3 ainsi que


les configurations. Mais sauf qu’au niveau du routeur, nous allons mettre en
place des serveurs DHCP pour les différents vlan tout en utilisant les adresses
des sous interfaces comme Gateway des celui-ci.
Configuration du Switch (voir le TPN°3).

 Configuration du routeur

TP N° 5 : Attribution des adresses dynamique pour chaque vlan par un serveur du réseau

Tâche1 : Switch

- Création des vlan

- Attribution des ports aux vlan

16
- Déclaration du port qui lie le Switch au routeur comme trunk

- Sur le port qui lie le Switch au serveur, il faudrait lui dire de prendre tous les vlans.

Tâche2 : Sur le Routeur

- Sur le fa0/0, faut faire no IP address et l’activer.

- Création des sous interfaces.

- Attribution des vlan aux sous interfaces par l’encapsulation.

- Attribution des adresses aux sous interfaces

- Indiquer aux clients le serveur qui fournit les adresses. C’est à dire sur chaque sous interface des vlans.

Tâche3 : Sur le serveur,

- Nous allons cocher la partie configuration,


- Puis dhcp et créer des pools en remplissant les cases : poolname=vlan10, gw=add de sous interface,
start ip add=addr de sous réseau, maxnum=nbre max

17
Nous avons comme architecture le schéma suivant :

Sur le Switch :

18
Sur le Routeur :

19
Sur le Serveur : Clic sur le serveur cocher l’onglet configuration, cliquer ensuite
sur dhcp, puis commencer par remplir les informations de la manière suivante :

20
21
TP N° 6 : Mise en place des vlan data et voice

Tâche : L’objectif est de mettre en place deux vlan :

- Un pour les donnée(data) machines,et un pour la voix(voice) pour les telephones.

Sur le Switch :

- Création des vlan data et voiçe.

- Attribution des pors aux vlan.

- Déclaration du port qui le switch au routeur comme trunk.

Sur le routeur :

-Sur le port fa0/0, faut faire no shutdown et no ip add.

- Création des sous- interfaces un pour les données et l’autre pour la Voix

- Attribution des adresses aux sous interfaces par l’encapsulation.

- Mise en place d’un serveur DHCP par vlan.

L’architecture est le suivant :

22
Config du Switch :

23
Configuration du routeur :

24
25
TP N° 7 : Vlan VTP ET STP

 Vlan VTP

Etape1 : Un switch plus vlan 10, 20, 30

26
Etape2 : Relier un autre switch par un trunk comme client

Une fois configurer comme client, il aura une copie de la base de donnée des vlan. Dans ce cas, adhérons
des machines aux vlan et faisons le teste.

NB : N’oublier d’attribuer les ports de switch client aux différents vlan. Car la base de données ne crée
que les vlans.

27
Configuration des deux switchs, un serveur et l’autre client comme l’illustre l’architecture précédent.

Sur le Switch serveur on a déjà créé les vlan comme le montre l’étape 1.Donc nous passons directement
à la configuration de VTP.

28
29
Configuration de switch client

On constate que le serveur a transmis au client que des vlan. Donc c’est à l’administrateur de
configurer sur le client les ports aux différents vlan.

30
Attribution des ports aux différents vlan

31
Vérifions à l’aide de la commande show vlan ou show vlan brief :

Etape 3 : Mettre un switch au milieu pour jouer le rôle de transparent. ET, le Switch transparent se
trouve entre le Switch client et le Switch serveur. Nous conservons la même configuration précédente et
nous allons que configurer le Switch transparent.

NB : Il faudrait mettre le trunk sur toutes les interfaces qui lient les switchs entre eux.

32
L’architecture est la suivante :

33
Configuration du Switch transparent

 Le protocole STP

Intérêt : Le STP gère la gestion des boucles en reseau.il peut arriver dans la mise en œuvre d’un réseau de
mettre en boucle les nœuds du réseau. Cela a pour conséquence de mettre hors service le réseau tout
entier.

Pour voir l’intérêt de cette partie, veillez à ce que le protocole STP soit désactivé (sur packet tracer)

Tâche à faire avant le câblage :

no spanning-tree mode : désactivation du mode spanning sur le switch

no spanning-treeportfast default : désactivation du mode STP par défaut

.no spanning-treevlan 1: désactivation du spanning-tree dans la gestion de vlan1

34
On distingue plusieurs types de boucles :

Figure : Création d’une boucle réseau entre deux switchs (1)

Figure : Création d’une boucle réseau entre deux switchs (2)

Figure : Création d’une boucle réseau entre deux switchs (3)

35
Configuration :

Après cette configuration, on pourra donc relier les machines.

36
TP N° 8 : ACCESS LISTES CONTROLES(ACL)

Les ACL permettent de mettre en place une certaines règles de permission, d’interdiction et
d’autorisation au niveau de routeurs

Dans l’architecture qui suit, nous allons interdire aux différents départements de communiquer entre
eux mais sauf que l’info va communiquer avec tous les départements (c.-à-d., secrétariats entre eux et
les comptables entre eux). Pour cela, il nous serait nécessaire d’appliquer les ACL.

Puisque nous avons déjà vu plus haut la plupart des configurations, nous allons donc montrer seulement
la configuration des access-listes.

37
Configuration des ACL sur les deux sites :

38
39

Vous aimerez peut-être aussi