Vous êtes sur la page 1sur 5

Programmation Logo

I. Introduction
1. Définitions
 Logo est un langage de programmation.
 Une instruction : Une commande : Une primitive : est un ordre qui permet d’effectuer une
opération donnée.
 Un programme informatique est un ensemble d’instructions.
 La programmation est l’ensemble des activités qui permettent l’écriture des programmes
informatiques.
 Un langage de programmation est constitué de plusieurs mots qui lui sont propres et qui
permettent de rédiger un programme.
2. Exemples :
 Il existe plusieurs langages de programmation : BASIC, PASCAL, LOGO, VB, …
 Il existe plusieurs versions de LOGO : XLOGO, JFLOGO, MWSLOGO, WINLOGO,…
II. Fenêtre de XLOGO
Lorsque on lance Xlogo « Double cliquer sur l’icône XLogo » on obtient la fenêtre
suivante :
Barre de titre
Barre de menus
Barre de commande

Zone de desin

Barre d’outils

L’historique Deux boutons

1 Pr : M.BOUSSOUF
III. Commandes (primitives, ordres) de base
1. Tableau des primitives de base
Ordres=primitives arguments fonction
Avance, av N : nombre de pas Commande à la tortue d’avancer de n pas.
Recule, re N : nombre de pas Commande à la tortue de reculer de n pas.
Commande à la tortue d’effectuer une rotation de
Tournedroite, td N : angle
n degrés à droite
Commande à la tortue d’effectuer une rotation de
Tournegauche, tg N : angle n degrés à gauche
Cercle R : nombre Trace un cercle de rayon R autour de la tortue
Montretortue, mt Aucun Rend la tortue visible.
Cachetortue, ct Aucun Rend la tortue invisible pour l’utilisateur.
Efface l’écran et réinitialise la tortue à sa position
Videecran, ve Aucun initiale.
Efface la zone de dessin mais la tortue reste au
Nettoie Aucun même endroit.

Gomme, go Aucun La tortue efface tous les traits qu’elle rencontre.


Levecrayon, lc Aucun La tortue n’écrit pas lorsqu’elle se déplace.
Baissecryon, bc Aucun La tortue écrit lorsqu’elle se déplace.
Fixe la couleur du crayon.
Quelques valeurs typiques :
'fcc 236' pour avoir du blanc.
'fcc 237' pour avoir du jaune.
'fcc 238' pour avoir du rose.
'fcc 239' pour avoir du bleu ciel.
'fcc 240' pour avoir du rouge.
Fixecouleurcrayon, fcc A : entier 'fcc 241' pour avoir du vert.
'fcc 242' pour avoir du bleu marine.
'fcc 243' pour avoir du gris clair.
'fcc 245' pour avoir du violet.
'fcc 247' pour avoir du marron.
'fcc 248' pour avoir du gris foncé.
'fcc 255' pour avoir du noir.
'fcc hasard 256' pour avoir une couleur au hasard.
Fixecouleurfond, fcfg A : entier Fixe la couleur du fond de l’écran.
*Fixetaillecrayon, ftc = fec N : nombre Fixe l'épaisseur du trait du crayon en pixel
Permet de remplir une forme fermée par une
Remplis N : nombre
couleur non-blanche.
Permet de répéter n fois les instructions qui se
Repete n [instructions] N : nombre
trouve entre les accolades.
*Origine Aucun Fixe la position de la tortue au départ (0,0).

2 Pr : M.BOUSSOUF
2. Remarques :
 Les primitives av, re ont une entrée mesurée en pas de la tortue.
 Les primitives td, tg ont une entrée mesurée en degrés.
 Il y a d’autres primitives qui n’ont pas d’entrée comme : lc, bc, ve, mt, ct …
 Pas de différence entre av et AV : minuscule / majuscule.
 Il est possible de créer une forme géométrique complexe avec un nombre minimal
d’instructions en utilisant la commande repete.
IV. Activités & exercices
Imaginez la tortue comme un animal infatigable mais aussi aveugle, sourd, amnésique et un peu
idiot.
1. Activité N°1 carré
Donnez la primitive qui correspond à chaque situation.

position
………... ………... ………........... ………........... ………...........
de départ
2. Activité N°2 triangle équilatéral
Donnez la primitive qui correspond à chaque situation.

position de
………..…... ………..…... ……..…........... ……….............
départ
3. Activité N°3 hexagone
Complétez les primitives pour dessiner la figure suivant :
ve
av ….. td ….. av ….. td …..
av ….. td ….. av ….. td …..
av ….. td ….. av ….. td …..
ct
Un hexagone
4. Activité N°4 pentagone
Complétez les primitives pour dessiner la figure suivant :
ve
av ….. td ….. av ….. td …..
av ….. td ….. av ….. td …..
av ….. td …..
ct
Un pentagone
5. règles :
Pour tracer un polygone de N côtés égaux, la tortue doit effectuer une rotation de 360/N.
Soit l’angle interne du polygone : 180 - 360/N
Exemples :
 Pour tracer un triangle équilatéral, la tortue doit effectuer une rotation de 360/3 = 120.

3 Pr : M.BOUSSOUF
 Pour tracer un carré, la tortue doit effectuer une rotation de 360/4 = 90.
 Pour tracer un pentagone, la tortue doit effectuer une rotation de 360/5 = 72.
 Pour tracer un hexagone, la tortue doit effectuer une rotation de 360/6 = 60.
 Et ainsi de suite.
6. Activité N°5 une maison
A partir des dessins d’un carré et d’un triangle équilatéral, construire une maison.
ve
av 100 td 90 av 100 td 90 av 100 td 90 av 100 td 90 carré
av 100 td 30
av 100 td 120 av 100 td 120 av 100 td 120 triangle équilatéral
ct

7. Activité N°6 un rectangle


Quel est le rôle des commandes :
primitives Rôle
VE …………………………………………………….
av 100
TG 90 …………………………………………………….
av 100
LC …………………………………………………….
av 50 tg 90
BC …………………………………………………….
av 100 tg 90 av 100
8. Activité N°7
Dessinez le carré ci-contre dont le côté mesure 100 points (ou pas de la tortue).

ve
av 100 td 90 av 100 td 90
av 100 td 90 av 100
td 45 re 100 av 200
ct

V. La répétition
La primitive REPETE permet de grouper les instructions qui se répètent en une seule commande.
Repete N [instructions] Permet de répéter N fois les instructions qui se trouve entre les accolades.
Par exemple :
pour dessiner un carré on répète 4 fois les instructions « av 100 td 90 » alors on note :
REPETE 4 [av 100 td 90]
1. Activité
Utilisez la commande repete pour tracer les polygones :
polygone instructions résultats
ve
Un triangle équilatéral. repete 3[av 100 td 120]
ct
ve
Un carré. repete 4[av 100 td 90]
ct
ve
Un rectangle. repete 2[av 50 td 90 av 100 td 90]
ct

4 Pr : M.BOUSSOUF
ve
Un pentagone.
repete 5[av 100 td 72]
ct
Ve
Un hexagone repete 6 [AV 100 TD 60]
ct
Ve
Un heptagone repete 7 [AV 100 TD 360/7]
ct

Ve
Un octogone repete 8 [AV 100 TD 360/8]
ct

Ve
Un ennéagone repete 9 [AV 100 TD 360/9]
ct

Ve
Un décagone repete 10 [AV 100 TD 360/10]
ct
Ve
Un cercle Repete 360[av 1 td 1]
ct

Papillon
Donner un programme qui trace un papillon on se basant sur le programme d’un cercle

Ve
Repete 360[av 1 td 1]
Repete 360[av 2 td 1]
Repete 360[av 3 td 1]

Repete 360[av 1 tg 1]
Repete 360[av 2 tg 1]
Repete 360[av 3 tg 1]

Re 120
Av 240
Td 45
Av 20 re 20
Tg 90
Av 20
Ct

5 Pr : M.BOUSSOUF

Vous aimerez peut-être aussi