Vous êtes sur la page 1sur 8

TEAN05_C13_Internet_Y_BGP

==================================

PREGUNTAS DE EVALUACI�N 2
=========================

Stub -> Suprimir LSA Tipo 5/tipo4/tipo3

Router no puede recibir rutas Externas, Suymarizaciones Externas y Sumarizaciones


Internas.

0 E2
0 E2
0 IA
==========
O IA
O IA
O IA
O*IA 0.0.0.0/0

Totally Stub -> Suprimir LSA Tipo 5/tipo4/tipo3 y Rutas IA

Resultado ser�

R7 solo debe ver:

O*IA 0.0.0.0/0
O
O
O
O
O
O

int fa0/1
no shut
ip add 10.232.57.1 255.255.255.252
!

router ospf 1
router-id 10.255.255.5
!
int fa0/1
ip ospf 1 area 57
!
int lo0
ip add 10.255.255.5 255.255.255.255
ip ospf 1 area 57

=============================

int fa0/1
no shut
ip add 10.232.57.2 255.255.255.252
router ospf 1
router-id 10.255.255.7
!
int fa0/1
ip ospf 1 area 57
!
int lo0
ip add 10.255.255.7 255.255.255.255
ip ospf 1 area 57

O*E2

O*E1 ->

========================================================================

Router ISP1 (R1)


hostname ISP1
!
int lo0
ip add 10.255.255.1 255.255.255.255
!
interface Lo1
description ISP1 Internet Network
ip address 10.1.1.1 255.255.255.0
!
interface fa0/0
description ISP1 -> ITA
ip address 10.0.0.1 255.255.255.252

no shutdown
!

end

============================================

Router ITA (R2)


hostname ITA
!
int lo0
ip add 10.255.255.2 255.255.255.255
!

interface Lo1
description Core router network link 1
ip address 192.168.0.1 255.255.255.0
!
interface Lo2
description Core router network link 2
ip address 192.168.1.1 255.255.255.0
!
interface fa0/0
description ITA -> ISP1
ip address 10.0.0.2 255.255.255.252
no shutdown
interface fa0/1
description ITA -> ISP2
ip address 172.16.0.2 255.255.255.252

no shutdown
!
end

============================================
Router ISP2 (R3)
hostname ISP2
!
int lo0
ip add 10.255.255.3 255.255.255.255
!

interface Lo1
description ISP2 Internet Network
ip address 172.16.1.1 255.255.255.0
!
interface fa0/1
description ISP2 -> ITA
ip address 172.16.0.1 255.255.255.252
no shutdown
!
end

ip prefix 0.0.0.0/0

route-map NOMBRE permit 10


match
set metric
set metric-type

route-map NOMBRE permit 20


!

Unidad 3: Internet y BGP


========================

- Conexi�n a Internet tradicional


- Conexi�n a Internet Protocolo de enrutamiento
- IP P�blicos

IP Privadas
Clase A: 10.0.0.0/8 - 10.255.255.255
Clase B: 172.16.0.0/16 - 172.31.255.255
Clase C: 192.168.0.0/24 - 192.168.255.255
Clase D: Multicast 224.0.0.0/8

Las IP Privadas son enrutables usando protocolos de enrutamiento:


EIGRP/OSPF/RIP/Rutas Est�ticas

Las IP P�blicas son enrutadas usando rutas por defecto o Protocolo de enrutamiento
BGP
1.- Conexi�n a Internet tradicional

- Contratar a un ISP
- Arrendar un enlace dedicado a Internet
- Arrendar IP P�blico
- Contrato PYME/HOGAR -> 1 IP P�blica (Din�mica)
- Contrato EMPRESAS -> 8 IP P�blicas (Est�tica)
- NAT
- Descontar 1 (Red)
- Descontar 1 (Broadcast)
- Descontar 1 (ISP)
- Le quedan 5 IP P�blicas

4 Tipos de NAT

NAT Est�tico
============
Traducci�n IPv4 Privada a Publica
Traducci�n 1 a 1

EJM:
ip nat inside source static 192.168.100.200 73.145.89.157
ip nat inside source static 192.168.100.201 73.145.89.158
!
int g0/0
desc WAN_INTERNET
ip nat outside
!
int g0/1
desc LAN
ip nat inside

NAT Din�mico
============
Traducci�n IPv4 Privada a Publica
Traducci�n 1 a 1 de forma din�mica

EJM:
access-list 1 permit 192.168.0.0 0.0.0.255
!
ip nat pool NOMBRE 186.100.0.2 186.100.0.6 255.255.255.248
!
ip nat inside source list 1 pool NOMBRE
!
int g0/0
desc WAN_INTERNET
ip nat outside
!
int g0/1
desc LAN
ip nat inside

PAT Est�tico
============
Traducci�n IPv4 Privada a Publica
Traducci�n muchos a 1

EJM:
access-list 1 permit 192.168.1.0 0.0.0.255
!
ip nat inside source list 1 interface g0/0 overload
!
int g0/0
desc WAN_INTERNET
ip nat outside
!
int g0/1 (g0/0.10)
desc LAN
ip nat inside
!

PAT Din�mico
============

EJM:
access-list 1 permit 172.16.0.0 0.0.0.255
!
ip nat pool NOMBRE 200.0.0.3 200.0.0.4 255.255.255.248
!
ip nat inside source list 1 pool NOMBRE overload
!
int g0/0
desc WAN_INTERNET
ip nat outside
!
int g0/1 (g0/1.10)
desc LAN_EMPRESA
ip nat inside
!
======================================================

R1_EMPRESA
==========

Escenario 1: Est�ticamente (EMPRESAS)


===========

int g0/0
desc WAN_INTERNET_ENTEL
ip add 186.67.45.66 255.255.255.248
!
ip route 0.0.0.0 0.0.0.0 186.67.45.65 name SALIDA_INTERNET_ENTEL
!

Escenario 2: Din�micamente (PYME/HOGAR)-> 1 IP P�blica


===========

int g0/0
no shut
desc WAN_INTERNET_ENTEL
ip add dhcp
!
ip route 0.0.0.0 0.0.0.0 g0/0 name SALIDA_INTERNET_ENTEL
!
EJM:
NAT est�tico con sobrecarga (PAT Est�tico)

Cuando se configura NAT -> Interfaz NVI

#show ip int brief


#show ip nat statistic
#show ip nat translation
#debug ip nat

Resumen
- Tipos de NAT
- Comandos de NAT
- Maneras de conectarse a Internet
- Topolog�a de alta disponibilidad para Internet
- Comandos show
- Fin Cap�tulo 6 CCNP1

=======================================================

Conceptos de BGP
================
BGP es un EGP
BGP: Border Gateway Protocol
EGP: External Gateway Protocolo
Protocolo de enrutamiento para IP P�blicas.

BGP utiliza ASN: N�mero de Sistema Aut�nomo.


ASN se arrienda a la LACNIC.
BGP Publicar a Internet rutas P�blicas arrendadas por parte del cliente.
ISP no arrienda IP P�blicas.
LACNIC arrienda IP P�blicas.
LACNIC arrienda un prefijo /22

BGP Aplicaci�n TCP 179

Hello
Vecindades
UPdate
ACK

BGP
-E-BGP: External
- Diferentes ASN

-I-BGP: Internal
- Mismo ASN

Tabla BGP
- Prefijos BGP
- Atributos BGP

=======================================================

Actividad pr�ctica BGP


======================
1.- Configuraci�n de Adyacencia BGP
===================================

ENTEL (ASN 200)


===============
router bgp 200
bgp router-id 10.255.525.1
neighbor 10.0.0.2 remote-as 100

MOVISTAR (ASN 300)


==================
router bgp 300
bgp router-id 10.255.255.3
neighbor 172.16.0.2 remote-as 100

BANCO_ACME (ASN 100)


====================

router bgp 100


bgp router-id 10.255.525.2
neighbor 10.0.0.1 remote-as 200
neighbor 172.16.0.1 remote-as 300

#sh ip bgp
#sh ip bgp neighbor
#sh ip bgp neighbor | inc BGP (debe decir Established)

2.- Publicaci�n de rutas BGP


============================

BANCO_ACME (ASN 100)


====================
router bgp 100
network 192.168.0.0 mask 255.255.255.0
network 192.168.1.0 mask 255.255.255.0

ENTEL (ASN 200)


===============
router bgp 200
network 10.1.1.0

MOVISTAR (ASN 300)


==================
router bgp 300
network 172.16.1.0 mask 255.255.255.0

#sh ip bgp
#sh ip route bgp

Los Ping deben ir con SOURCE

10.0.0.0/24

* = Ruta V�lida
> = Mejor Ruta

Next-Hop = Pr�ximo Salto


Metric = M�trica de BGP
LocPrf = Local Preference
Weight = Peso
Path = Camino entre Sistemas Aut�nomos

ASN se transforme en un ASN de Tr�nsito


====================================================

3.- Filtro de rutas en BGP

ENTEL ASN100
==================

access-list 1 permit 192.168.0.0 0.0.0.255


access-list 1 permit 192.168.1.0 0.0.0.255

Sumarizada

access-list 1 permit 192.168.0.0 0.0.1.255

BANCO_ACME
==========
router bgp 100
neigh 10.0.0.1 distribute-list 1 out
neigh 172.16.0.1 distribute-list 1 out

ENTEL
#clear ip bgp * soft-> (update)
#clear ip bgp * all -> (Vecindad/No usar en lo real)

4.- Rutas por defecto

ENTEL
=====
router bgp 200
neigh 10.0.0.2 default-originate

Resumen
========
- 4 Tipos de NAT
- E-BGP
- Filtros Listas de distribuci�n
- Inyecci�n de rutas por defecto

Vous aimerez peut-être aussi