Vous êtes sur la page 1sur 21

PROJET TCP/IP

THEME : Routage inter-Vlan


Groupe 5
Absa GUEYE
Cheikh Atab DJIBA
Mbaye Babacar MBODJ

Formateur: Dr JAMES
Plan
Introduction
I. Quelques Rappels sur les VLAN

II. Le Routage Inter VLAN

1) Réseau sans Routage Inter-VLAN

2) Réseau avec Routage Inter-VLAN

III. Cas Pratique d'un Routage Inter-VLAN sur Packet Tracer

1) Affectation des adresses IP, Masques et Passerelles pour les hôtes

2) Configuration des différents commutateurs liés aux hôtes

3) Configuration du commutateur central liant les 3 premiers commutateurs

4) Configuration du Routeur et de ses Sous Interfaces

IV. Quelques Remarques sur le Trunk et le Partage de la Bande Passante dans les
Routage Inter-VLAN

Conclusion
Introduction
De nos jours les réseaux informatiques sont essentiellement basés sur la technologie Ethernet.
Et qui dit Ethernet parle forcément de domaine de collision et de diffusion.
Qu'englobe ces termes ???
Une collision est le fait que des hôtes partageant un même support de communication et émettant
simultanément cause des pertes de communication tout en engendrant la saturation du réseau.
Le nombre d’hôte étant en perpétuel évolution, il était nécessaire de trouver des astuces pour palier à ce
dysfonctionnement d’où l'équipement dénommé commutateur(Switch).
Un commutateur a pour rôle d'éliminer les collisions au niveau du média, comparé au concentrateur(hub),
il permet de régler définitivement le problème de collision entre hôtes du réseau en ne créant qu'un circuit
de communication unique entre 2 hôtes distinctes d'un réseau filaire.
Parlons maintenant des domaines de diffusion...
Leurs fonctions étant d'assurer le fait que n'importe quel hôte puisse transmettre un message à tous les
autres hôtes du réseau. Cependant ils peuvent contribuer à abaisser la qualité du réseau si les hôtes
augmentent.
Pour limiter ces domaines de diffusion, les routeurs nous offrent des solutions. Mais aussi d'autres astuces
logiques sur l'architecture des réseaux comme les VLANs ont permis de répartir les domaines de diffusion
entre équipements connectés.

Ceci dit, ces deux phénomènes des réseaux ont amené les spécialistes à avoir recours à des architectures
plus complexes (maillée, étoilée, ou combinat ion des deux (2))pour plus de fluidité des communications au
niveau des LAN (Local Area Network),d’où le routage Inter-VLAN.

I. QUELQUES RAPPELS SUR LES VLAN

Un VLAN (Virtual Local Area Network ou Virtual LAN, en français Réseau Local Virtuel) est un réseau local
regroupant un ensemble de machines de façon logique et non physique.

Un réseau local virtuel est un regroupement virtuel d'au moins deux périphériques. Ce regroupement peut
s'étendre au-delà de plusieurs commutateurs. Les périphériques sont regroupés sur la base d'un certain
nombre de facteurs suivant la configuration du réseau.

Leurs fonctions principales sont :

• L'Amélioration de la gestion du réseau.


• L'Optimisation de la bande passante
• La Séparation des flux
• La Segmentation : en réduisant la taille d'un domaine de diffusion.
• La Sécurisation: en permettant de créer un ensemble logique isolé pour améliorer la sécurité. Le
seul moyen pour communiquer entre des machines appartenant à des VLAN différents est alors de
passer par un routeur.

II. ROUTAGE INTER-VLAN


Les VLANs bien qu'étant très utilisés car permettant de définir un domaine de diffusion, un cloisonnement
logique au-dessus d’une topologie réseau connue ou à isoler un trafic, néanmoins ils comportent des
inconvénients car ils isolent des segments de réseaux dont on ne voulait pas isoler et empêchent à certains
services de communiquer d’où le routage Inter-VLAN.

Le routage inter-VLAN est un dispositif qui nous permet de faire communiquer nos différents réseaux
virtuels entre eux à travers un routeur :

A ce jour 3 méthodes sont utilisées pour la mise en place d'un routage inter-Vlan et ce sont :

-Avec un commutateur de niveau 3(SVI)


-Avec un lien(physique) par VLAN sur un Routeur (Méthode préhistorique)
-Avec une interface du Routeur pour plusieurs VLANs /ROAS (Router On A Stick) ou Multiplexage

Cette dernière méthode étant la plus en vogue de nos jours, consiste à utiliser une interface physique du
routeur pour plusieurs Vlans en y créant des sous interfaces virtuels alloués à chacun de ces Vlans.

Ce routage inter-Vlan cependant, respecte comme dans tout routage deux (2) principaux règles (comme
énoncés dans l'introduction) que sont :

-L'utilisation d'une interface de Commutation pour délimiter un domaine de collision


-L'utilisation d'une interface de Routage pour délimiter un domaine de diffusion

Sur cette base alors (Règles de Routage), nous allons étudier les réseaux sans et avec Routage Inter-VLAN:

1) Réseau sans le Routage Inter-VLAN


Du point de vue de la conception ces règles nous imposent d'attribuer une interface de routeur pour
chaque vlan créé. De ce fait les commutateurs appartenant à un domaine de diffusion sont dédiés à ce
domaine. Ce qui est contraire à l'efficience des réseaux vu que le nombre de ports des routeurs sont limités
et conditionne de facto le nombre de Vlan à avoir dans le réseau.
• Si on programme le commutateur A avec 2 VLANs distincts pour chacun des hôtes A1 et A2, alors toute
communication entre A1 et A2 sera impossible. De plus, ces deux hôtes ne pourront communiquer avec
d'autres réseaux que si l'interface du routeur RA appartient aux deux VLANs programmés.

Cette situation peut présenter des avantages du point de vue exploitation mais elle dépend beaucoup de la
gestion des interfaces physiques. De ce fait le coût d'administration devient très important dès que le
nombre de réseaux virtuels augmente.

• Si l'utilisateur « associé » au hôte A1 déménage dans un lieu où seul le domaine de diffusion B est
distribué, il est nécessaire d'étendre le domaine de diffusion A jusqu'à ce nouveau lieu. En conséquence, il
faudra installer un nouveau commutateur et câbler de nouvelles prises entre le point de brassage principal
du domaine A et ce lieu.
Donc sur une même infrastructure, on se retrouve rapidement avec des commutateurs saturés pour
lesquels tous les ports disponibles sont utilisés et d'autres commutateurs pour lesquels seuls quelques
ports sont utilisés. Ce scénario démontre à suffisance qu'il est excessivement difficile d'optimiser le parc
des ports de commutateurs avec ce type d'architecture. Le coût de l'infrastructure augmente donc
fortement puisqu'il faut passer par des réinvestissements lourds en câblage et en équipements à chaque
modification des périmètres.

2) Réseau avec le Routage Inter-VLAN

En partant toujours sur la base des deux règles énoncées ci-dessus. Il s'agit maintenant de dissocier les
notions d'interface physique et d'interface de routage. On n'associe plus une interface physique à chaque
domaine de diffusion mais à une interface « virtuelle » du routeur.
Les avantages de cette architecture :

Les avantages de cette architecture sont les suivants :

• Le contrôle d'accès est centralisé au niveau du routeur. Il n'existe plus de « mélange des genres » entre la
programmation des commutateurs et le contrôle d'accès au niveau réseau. Les communications entre les
hôtes d'un même domaine de diffusion ou entre plusieurs domaines de diffusion sont gérées de la même
façon.
On obtient donc de véritables réseaux locaux distribués sur la totalité de l'infrastructure (équipements de
niveau 2 + équipements de niveau 3).
• La gestion du parc des ports de commutation est optimisée. Etant donné que les domaines de diffusion
sont partagés entre tous les équipements, la gestion des évolutions est beaucoup plus souple. Les
déménagements n'entraînent plus de recâblage tant que l'évolution du nombre des hôtes n'implique pas
une augmentation du nombre de ports. Il est donc possible de concentrer l'administration sur un nombre
d'équipements plus faible que dans une architecture sans routage inter-VLAN. De ce fait on amortit et les
coûts CAPEX(Investissement) et OPEX(Opérations) des réseaux, ce qui est un avantage dans un monde où la
concurrence se veut de plus en plus rude.

III. Cas Pratique d'un Routage Inter-VLAN avec Packet Tracer


Dans cette partie nous allons montrer comment nous nous y sommes pris pour parvenir à ce schéma qui
représente un routage inter-VLAN testé sur Packet Tracer.
SCHEMA ILLUSTRATIF
1) Affectation des Adresses IP, Masques et Passerelles pour les hôtes

POSTE/VLAN/ADRESSE IP VLAN /PORTS/MODE


NOMS Hôtes VLAN ID ADRESSE RESEAU ADRESSE IP HOTES SWITCH PORTS MODE VLAN NOM VLAN &
CONNECTE CONNECTE PASSERELLE

PC1 192.168.10.10/24 SWITCH 1 Fa 0/1 ACCESS


PC01 10 192.168.10.0/24 192.168.10.11/24 SWITCH 2 Fa 0/1 ACCESS IT
PC001 192.168.10.12/24 SWITCH 3 Fa 0/1 ACCESS 192.168.10.1
SERVEUR 192.168.20.10/24 SWITCH 1 Fa 0/2 ACCESS
PC02 20 192.168.20.0/24 192.168.20.11/24 SWITCH 2 Fa 0/2 ACCESS DFC
PC002 192.168.20.12/24 SWITCH 3 Fa 0/2 ACCESS 192.168.20.1
PC3 192.168.30.10/24 SWITCH 1 Fa 0/3 ACCESS
PC03 30 192.168.30.0 /24 192.168.30.11/24 SWITCH 2 Fa 0/3 ACCESS DRH
PC003 192.168.30.12/24 SWITCH 3 Fa 0/3 ACCESS 192.168.20.1

Exemple de configuration d’un Hôte


3) Configuration des différents commutateurs liés aux hôtes

CONFIGURATION DU SWITCH 1
Show vlan avant config switch1

Les commandes de configuration :


Switch> enable
Switch# configure terminal
Switch(config)# hostname SW1
SW1(config)# enable secret cisco
SW1(config)# vlan 10
SW1(config-vlan)# name IT
SW1(config-vlan)# vlan 20
SW1(config-vlan)# name DFC
SW1(config-vlan)# vlan 30
SW1(config-vlan)# name DRH
SW1(config-vlan)# exit
SW1(config)# interface fastethernet 0/1
SW1(config-if)# switchport mode access
SW1(config-if)# switchport access vlan 10
SW1(config-if)# switchport access vlan 10
SW1(config-if)# interface fastethernet 0/2
SW1(config-if)# switchport mode access
SW1(config-if)# switchport access vlan 20
SW1(config-if)# interface fastethernet 0/3
SW1(config-if)# switchport mode access
SW1(config-if)# switchport access vlan 30
SW1(config-if)# exit
SW1 (config)# interface range fa0/1-3
SW1 (config)# switchport port-security maximum 1
SW1 (config)# switchport port-security mac-address sticky
SW1(config)# end
SW1#wr
Building configuration...
[OK]

Show vlan après config switch 1


Show vlan SWITCH 2 avant config:

CONFIGURATION DU SWITCH2

Les commandes de configuration :


Switch> enable
Switch# configure terminal
Switch(config)# hostname SW2
SW2(config)# enable secret cisco
SW2(config)# vlan 10
SW2(config-vlan)# name IT
SW2(config-vlan)# vlan 20
SW2(config-vlan)# name DFC
SW2(config-vlan)# vlan 30
SW2(config-vlan)# name DRH
SW2(config-vlan)# exit
SW2(config)# interface fastethernet 0/1
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 10
SW2(config-if)# switchport access vlan 10
SW2(config-if)# interface fastethernet 0/2
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 20
SW2(config-if)# interface fastethernet 0/3
SW2(config-if)# switchport mode access
SW2(config-if)# switchport access vlan 30
SW2(config-if)# exit
SW2 (config)# interface range fa0/1-3
SW2 (config)# switchport port-security maximum 1
SW2 (config)# switchport port-security mac-address sticky
SW2(config)# end
SW2#wr
Building configuration...
[OK]

Show vlan après config SWITCH 2


Show vlan SWITCH 3 avant config:

CONFIGURATION DU SWITCH 3:

Show vlan avant config switch 3:


Les commandes de configuration :

CONFIGURATION SUR LE SWITCH 3


Switch> enable
Switch# configure terminal
Switch(config)# hostname SW3
SW3(config)# enable secret cisco
SW3(config)# vlan 10
SW3(config-vlan)# name IT
SW3(config-vlan)# vlan 20
SW3(config-vlan)# name DFC
SW3(config-vlan)# vlan 30
SW3(config-vlan)# name DRH
SW3(config-vlan)# exit
SW3(config)# interface fastethernet 0/1
SW3(config-if)# switchport mode access
SW3(config-if)# switchport access vlan 10
SW3(config-if)# switchport access vlan 10
SW3(config-if)# interface fastethernet 0/2
SW3(config-if)# switchport mode access
SW3(config-if)# switchport access vlan 20
SW3(config-if)# interface fastethernet 0/3
SW3(config-if)# switchport mode access
SW3(config-if)# switchport access vlan 30
SW3(config-if)# exit
SW3 (config)# interface range fa0/1-3
SW3 (config)# switchport port-security maximum 1
SW3 (config)# switchport port-security mac-address sticky
SW3(config)# end
SW3#wr
Building configuration...
[OK]

Show vlan après config SWITCH 3


1) Configuration du commutateur centrale liant les 3 premiers commutateurs
et le routeur

Switch>enable
Switch#configure terminal
Switch(config)#hostname SWCENTRAL
SWCENTRAL(config)# enable secret cisco
SWCENTRAL(config)#vlan 10
SWCENTRAL(config-vlan)#name IT
SWCENTRAL(config-vlan)#vlan 20
SWCENTRAL(config-vlan)#name DFC
SWCENTRAL(config-vlan)#vlan 30
SWCENTRAL(config-vlan)#name DRH
SWCENTRAL(config-vlan)#exit
SWCENTRAL(config)#interface range fastethernet 0/1-4 (Configuration des interfaces Fa0/1-4 en mode trunk) un
port a mode trunk permet de relier plusieurs switch ou Routeur/switch afin que tous les paquets puisse passer
SWCENTRAL(config-if-range)# switchport mode trunk (pour activer le mode trunk au niveau des Ports)
Après cette commande toutes les interfaces reliant le SWITCH4 des SWITCH1 2 et 3 deviennent en mode trunk
Automatiquement
#show interfaces trunk (pour vérifier la config des trunk)

A PARTIR DE LA TOUS LES PC DU MEME VLAN PEUVENT COMMUNIQUER


MAIS LES PC DE VLAN DIFFERENTS NE PEUVENT PAS COMMUNIQUER

BASE CONFIGURATION DU ROUTEUR

Router>enable
Router#configure terminal
Router(config)#hostname R1 attribuer un nom R1 au routeur
R1(config)#line console 0
R1(config-line)#password cisco sécuriser le routeur avec un mot de passe à l’accès de la console des config
R1(config-line)#end
R1#configure terminal
R1(config)#enable secret cisco sécuriser le routeur avec un mot de passe d’entrée
R1(config)#exit

2) Configuration des sous interfaces du Routeur pour le routage inter-vlan

Router#configure terminal
R1(config)#interface gigabitethernet 0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0 attribuer l’interface 0/0.10 le vlan 10 IT
R1(config-subif)#interface gigabitethernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0 attribuer l’interface 0/0.20 le vlan 20 DFC
R1(config-subif)#interface gigabitethernet 0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0 attribuer l’interface 0/0.30 le vlan 30 DRH
R1(config-subif)#exit
R1(config)#interface gigabitethernet 0/0
R1(config)#no shutdown Active l’interface principale Gigabitethernet 0/0 qui héberge les différentes sous
interfaces 0/0.10 0/0.20 0/0.30
R1(config)#exit
R1#wr sauvegarde la configuration
Building configuration...
[OK]

Vérification de la configuration avec Ping


IV. Quelques Remarques sur le Trunk et le partage de la Bande Passante
dans le Routage Inter-VLAN

Dans cette partie nous allons aborder les notions de Trunk et de Bande Passante en rapport avec le Routage
Inter-VLAN
Le trunk peut être défini comme une connexion physique unique sur laquelle on transmet le trafic de
plusieurs réseaux virtuels.
Les trames qui traversent le trunk sont complétées avec un identificateur de réseau local virtuel (VLAN id).
Cette identification permet aux trames d'être conservées dans un même VLAN (ou domaine de diffusion).
Ce dispositif peut être utilisé:
Entre deux commutateurs
C'est le mode de distribution des réseaux locaux le plus courant.
Entre un commutateur et un hôte
C'est le mode de fonctionnement à surveiller étroitement. Un hôte qui supporte le trunking a la possibilité
d'analyser le trafic de tous les réseaux locaux virtuels.
Entre un commutateur et un routeur
C'est le mode fonctionnement qui permet d'accéder aux fonctions de routage ; donc à l'interconnexion des
réseaux virtuels par routage inter-VLAN.

Cependant le fait que tous les VLANs soient agrégés (trunking), impose le partage la bande passante du
média utilisé. Le trunk peut donc constituer un goulot d'étranglement si la capacité du support utilisé est
insuffisante.

Dès lors il devient intéressant de partager le débit disponible en fond de panier dans les
châssis de commutateurs.

Le choix d'un commutateur ou routeur, s'articule aujourd'hui, de plus en plus autour du rapport entre la
capacité de commutation en millions de paquets par seconde (mpps) et le prix d'achat.

L'augmentation régulière des débits utiles par port favorise l'adoption d'architectures à base de routage
inter-VLAN. Les évolutions techniques des routeurs conduisent à diminuer le nombre de leurs interfaces
alors que les évolutions des commutateurs à augmenter le nombre de ports.

Lors de la conception de la topologie physique d'une architecture, la densité de ports dans un rayon de
90m dans les réseaux filaires cuivre devient un point sensible. Si cette densité est importante, il faudra
recourir à des équipements de type châssis qui permettent d'associer un module de routage à plusieurs
modules de commutation.
Tous ces modules disposent de composants spécialisés interconnectés en fond de panier sur différents bus
eux aussi spécialisés. Si au contraire, la topologie physique est géographiquement plus étalée, on aura
recours à l'agrégation de canaux.

Cette technique permet d'augmenter la capacité utile d'un trunk en distribuant le trafic sur plusieurs
canaux physiques vus comme un seul et unique lien.

CONCLUSION
Cet exposé a présenté les VLAN de manière générale et le routage INTER-VLAN en particulier. Les VLAN
reposent sur des connexions logiques, et non des connexions physiques.
Le routage inter-vlan est un mécanisme qui permet aux administrateurs réseau de créer des domaines de
diffusion logiques capables de s'étendre sur un ou plusieurs commutateurs, quel que soit leur éloignement
géographique. Cette fonctionnalité permet de réduire la taille des domaines de diffusion ou d'autoriser des
groupes ou des utilisateurs à se regrouper de manière logique sans devoir se trouver physiquement au même
endroit.
La commande switchport access vlan permet de créer un VLAN sur un commutateur.
La commande show vlan brief affiche le type d'attribution de VLAN et d'appartenance de tous les ports du
commutateur.
Un port sur un commutateur est soit un port d'accès soit un port trunk.
Les ports d’accès transportent le trafic d’un VLAN spécifique attribué au port.
Un port trunk est par défaut membre de tous les Vlans et achemine par conséquent le trafic de tous les Vlans
L'étiquetage des trames IEEE 802.1Q (encapsulation dot1Q) permet de différencier les trames Ethernet as-
sociées à des VLAN distincts lorsqu'elles traversent des liaisons trunk communes.
Pour activer les liaisons trunk, utilisez la commande switchport mode trunk.
Utilisez la commande show interfaces trunk pour vérifier si un trunk est établi entre les commutateurs.