Vous êtes sur la page 1sur 53

REPUBLIQUE ALGERIENNE DEMOCRATIQUE ET POPULAIRE

MINISTERE DE L’ENSEIGNEMENT SUPERIEUR ET DE LA RECHERCHE


SCIENTIFIQUE
UNIVERSITE M’HAMED BOUGARA – BOUMERDES
FACULTE DES SCIENCES

Relais de trames (Frame Relay)

Département : génie électrique


Option : Télécommunication
Master 1 réseaux et télécommunication

Réalisé par :
 HAMDOUD Mohamed Amine

 HAMADACHE Hicham

Encadré par : M,HADJAR TOUATI

Année universitaire :
2019 /2020

1
1-La problématique :

on veut un protocole de communication économique quil va être comme

un successeur et remplacement de protocole X.25

2-L’objectif :

 assurer à faible coût la transmission de données pour un trafic intermit-

tent entre réseaux locaux (LAN), et entre points de terminaison sur les ré-

seaux étendus (WAN).

3-Introduction : 

L'évolution des technologies, l'avènement des "L.A.N" ont augmenté le be-


soin en débit des utilisateurs, qui ne veulent plus se contenter des
quelques Kilo-octets fournis par X25 pour relier les réseaux. Les opéra-
teurs et les constructeurs se sont donc penchés sur la définition de proto-
coles mieux adaptés, alors on peut dire que :
- Le relais de trames (Frame Relay) est une évolution simplificatrice
de la commutation par paquets X.25 ,
-Principes identiques sans assurer l'intégrité des données et le
contrôle de flux
-Le relais de trames n'utilise que la couche 2 du modèle OSI.
-les paquets sont transportés de nœud en nœud dans les trames,
Pas de mécanisme de reprise au niveau 3

Pourquoi ?
• Un constat : la qualité des supports de transmission c’est considérable-
ment amélioré.
• L’introduction des fibres optiques réduit considérablement le taux d’er-
reur
• Elle permet des reprises de transmissions uniquement de bout en bout.
• La plupart des contrôles réalisés par X.25 deviennent inutile.

2
-Le réseau est constitué d'un ensemble de nœuds interconnectés par

un maillage quelconque.

-Les interconnexions sont des voies à haut débit

4-les mot clés et leur définition (5): 

OSI : (Open Systems Interconnection ) Le modèle OSI est une norme de communication,

en réseau, de tous les systèmes informatiques. C'est un modèle de communications entre ordi-

nateurs proposé par l'ISO

ANSI : American National Standard Institute. C’est un organisme qui développe et publie

des standards pour les USA. ANSI a publié des standards pour la compression de la voix,

pour les réseaux .

ISO : Organisation internationale de normalisation

Bc (Committed Burst Size) : Le flot maximum de données (en bits) que le réseau

autorise à transférer , dans des conditions normales , pendant un intervalle de temps Tc .

Be (Excess Burst Size) : Be est le maximum de données durant la période Tc que


l'utilisateur peut excéder au-dessus de Bc.

HDLC :“ high level data link control procedure ” famille de protocoles évo-
lués orientés bit (pas de notion de caractère) fonctionnant en mode synchrone bidirection-

nel, utilisant une procédure de sécurité de type code cyclique et une anticipation des

échanges (envoi des trames sans attendre les accusés de réception) permettant d'optimi-

ser les lignes. Ce type de protocole normalisé par l'ISO est très utilisé, notamment dans les

réseaux X.25 ou le RNIS.

3
BECN (Backward Explicit Congestion Notification) : Il s'agit d'un bit positionné par le réseau

Frame Relay pour indiquer à un DTE que la procédure pour éviter une congestion est initia-

lisée .

SDLC : “synchronous data link control procedure ”

CCITT : Le comité consultatif International Télégraphique et Télématique est un comité


spécialisé de l'Union Internationale des Télécommunications, elle-même rattachée à l’Orga-

nisation des Nations Unis. Le CCITT est composé des administrations des Postes des diffé-

rents états membres. Son rôle est de concevoir des standards pour relier divers équipe-

ments aux réseaux publics de télécommunications ,

X.25 : un protocole de communication normalisé par commutation de paquets en mode point à


point

LMI : (Local Management Interface)

CLLM (Consolided Link Layer Management)

NNI : Le NNI est désigné pour faire office d'interface entre 2 sous-réseaux Frame Relay.
Le but du NNI est le transfert de données à haute vitesse, congestion, et le transfert d'infor-

mations de circuit.

PVC : Permanent Virtual Circuit

SDLC (Synchronous Data Link Control) : protocole développé par IBM dans le
cadre de son architecture SNA. Protocole orienté bit (pas de notion de caractère), il travaille en

mode synchrone bidirectionnel avec contrôle de redondance cyclique. Il est l'ancêtre des proto-

coles HDLC dont il est très proche.

SVC : Switched Virtuel Circuit

LMI : le protocole Local Management Interface Local Management Interface. Le protocole


LMI sert à contrôler et commander la connexion entre l'utilisateur et le réseau. Il s'assure

4
que le lien entre le réseau et l'utilisateur est actif. Il enregistre l'ajout et la suppression des

PVC ( permanent virtual circuit ). Enfin il délivre des messages d'état sur la disponibilité des

circuits à intervalle régulier

DCLI (Data Link Connexion Identifier) : contient l’identificateur de lien virtuel = champ
d’adresse es DLCI à l'intérieur de la trame Frame Relay sont utilisés pour indiquer les adresses

source et destination pour chaque utilisateur. Quand un utilisateur envoie une trame à un autre utili-

sateur, l'équipement origine place le DLCI destination à l'intérieur de la trame. Au point destination le

réseau place le DLCI de l'équipement origine dans la trame qui doit être envoyé à l'équipement desti-

nation .

SDLC (Synchronous Data Link Control) : protocole développé par IBM dans le cadre de son architec-
ture SNA. Protocole orienté bit (pas de notion de caractère), il travaille en mode synchrone bidirec-

tionnel avec contrôle de redondance cyclique. Il est l'ancêtre des protocoles HDLC dont il est très

proche.

FECN (Forward Explicit Congestion Notification) : indiqué une congestion en amont.

BECN (Backward Explicit Congestion Notification) : indique une congestion en aval.

C/R C/R (Command / Response) : bit non utilisé.

EA (Extended Address) : bit indiquant une extension de l’adressage.

FCS Frame Check Sequence : Le Frame Check Sequence est utilisé pour contrôler que la
trame a été reçue sans erreurs et consiste en deux octets contenant un code cyclique re-

dondant utilisant le polynôme générateur du CCITT (X16X 12X 5 +1).

DE (Discard Eligibility) : bit indiquant les trames préférentielles pour la destruction


en cas de congestion , Le bit DE sert pour indiquer que les trames qui ont été envoyées en

excès du CIR , peuvent être retirées si nécessaires.

5
CIR : Committed Information Rate Le CIR est le débit de données que l'utilisateur est
sur de voir passer dans le réseau à n'importe quel moment et sans aucun problème. Le CIR n'a

aucun lien avec le débit réel de la ligne de l'utilisateur. Un utilisateur peut avoir une ligne a

2Mbps et avoir, par exemple un CIR de 64Kbps. Cela signifie que l'utilisateur sera toujours sur

de passer 64Kbps mais en pic de charge il pourra faire passer sur la ligne jusqu'à 2048Kbps

EIR : Excess Information Rate

CAC : Contrôle d’admission des connexions

T-carrie :

FRAD : Frame Relay Access Device, matériel qui formate les données d'autres réseaux

pour leur utilisation sur un réseau Frame Relay.

AT&T

UNI : Le Frame Relay UNI est un protocole qui permet à l'utilisateur d'accéder à un réseau

public ou privé et d'établir un chemin de communication avec un autre utilisateur à l'inté-

rieur du même réseau.

T-1

RNIS

T-carrier

ATM : (Asynchronous Transfer Mode)

LAPB (Link Access Procedure Balanced) : Version avancée de HDLC . Utilisée

dans la commutation de paquets de réseaux X25.

6
LAPD (Link Access Procedure on the D-Channel) : LAPD est un HDLC dérivé uti-

lisé par RNIS sur lequel est basé le Frame Relay.

SVC : Switched Virtual Circuit.

SNA (Systems Network Architecture)

6-Description de concept de ce réseaux :

6.1-L’historique :

Au cours du temps, de nombreux protocoles de communication ont été dé-

veloppés et implémentés, certains ont connu le succès, d’autres non. Du-

rant les années 60 et 70, c’était commun pour les fabricants d’ordinateurs

de développer leurs propres protocoles qui utilisaient leurs propres envi-

ronnements et pas les autres. Pendant les années 70, IBM publia la pre-

mière spécification d’architecture de communication de données dite ou-

verte sous le nom de SNA (Systems Network Architecture). C’est aussi

dans les années 70 qu’une nouvelle spécification de protocole connue sous

le nom de X25 naquit, introduite non pas par un constructeur d’ordinateur

mais par une organisation de standardisation : le CCITT. Issu des travaux

du CCITT dans les années 80 dans le cadre des travaux sur le RNIS

(normes : I.233 Frame mode bearer services part 1, Q.922 ISDN data link

layer specification for frame mode bearer services, Q.933 ISDN signal-

ling specification for frame mode bearer services, I.370 congestion ma-

7
nagement for the ISDN frame relaying bearer service, I.372 et I.555) le

Frame Relay a été défini comme un protocole de transfert de données

caractérisé par des temps de transit sur le réseaux faibles et une cor-

rection d’erreur très limité (de telles caractéristiques permettaient de

mieux s’adapter à la qualité des lignes qui évoluait vers des taux d’er-

reur de plus en plus faibles). Certains constructeurs ont jugé que le

protocole méritait un intérêt particulier et ont implémenté une version

en dehors du monde du RNIS. Ce groupe, connu sous le nom de groupe

des quatre (DEC, Northern Telecom, Cisco and Stratacom) produisit un

document le 18 Septembre 1990 connu sous le nom de Frame Relay

Specification with Extensions – based on Proposed T1S1 Standards. Ce

document fut proposé à tout vendeur désireux de l’implémenter. Un se-

cond groupe de vendeurs fut créé quelques mois après cette proposi-

tion, le Frame Relay Forum, pour développer cette technologie.

6.2-La technologie de Frame Relay :

Le but d’une commutation au niveau de la liaison, qui se décline en com-

mutation de trames et en relayage de trames, est d’améliorer en perfor-


8
mance la commutation de paquets (ex : X25) en simplifiant le nombre de

niveaux de l’architecture à prendre en compte. En reportant la commuta-

tion au niveau 2 de l’architecture, on simplifie considérablement le travail

des nœud ,Le relais de trames encapsule les données dans une unité de

taille variable appelée trame ‘’HDC’’ (figure 1) et laisse les points de termi-

naison se charger des corrections d'erreurs (la retransmission de don-

nées), ce qui accélère globalement la transmission des données. Pour la

plupart des services, le réseau fournit un circuit virtuel permanent (PVC) :

le client voit une connexion dédiée continue sans payer une ligne louée à

plein temps, tandis que le fournisseur de services identifie le chemin de

chaque trame jusqu'à sa destination et peut facturer à l'utilisation. Les cir-

cuits virtuels commutés (SVC), en revanche, sont des connexions tempo-

raires détruites après le transfert complet des données

figure 1 :

9
Les circuits virtuels :

- Un circuit virtuel défini un chemin logique entre 2 extrémités (2 Frame

Relay DTE): • Permet de créer une connexion point à point entre deux équi-

pements à travers un WAN sans qu'il y ait réellement de circuit physique qui

les relie.

-Les routeurs utilisent des data-link connection identifier (DLCI) comme

adresses Frame Relay :

• Les DLCI permettent de désigner les circuits virtuels

(VC) qui seront utilisés pour transmettre les données vers la destination

-Il existe deux types de circuits virtuels : permanents (PVC) et commu-

tés (SVC) :

• Les PVC sont pré-configurées par l'opérateur lors de l'abonnement

• Les SVC sont établis dynamiquement à l'initiative de l'usager.

10
- PVC est le circuit le plus courant dans Frame Relay :

• Établissement d'un circuit permanent qui est utilisé pour des échanges

fréquents de données entre des DTE à travers un réseau Frame Relay,Ils corres-

pondent à des VC pré-configurés.

-SVC utilise des circuits temporaires pour des transferts

occasionnels entre des DTE.

• Le caractère temporaire nécessite un établissement de la communication

puis une déconnexion pour chaque connexion.

-A chaque circuit virtuel est associé un identifiant de connexion:

• Une table est utilisée par le provider pour faire le routage vers les bonnes

sorties car désigner uniquement l'interface n'est pas suffisant.

• Dans Frame Relay, c'est un Data-Link ConnectionIdentifier(DLCI)

6.3-Architecturale de ce réseau :

6.1 La trame Frame Relay

11
La plupart des protocoles (comme X25 ou SNA) utilisent une trame dérivée

de la “ high level data link control procedure ” HDLC ou de la “synchronous

data link control procedure ” SDLC. LAPD est le dérivé de HDLC utilisé dans

le RNIS sur lequel le Frame Relay est basé. Comme le Frame Relay n’implé-

mente pas toutes les fonctions du HDLC, quelques éléments ont été omis et

d’autres ont été regroupés : c’est le cas des champs d’adresse et de contrôle

qui ont été regroupés dans un champ simple de type “ header ” et appelé lui

aussi champ d’adresse.

Les champs suivant du HDLC ont été conservés :

- Le Flag : de type 01111110

Comme tous les flag, ils indiquent la fin ou le début d’une trame et permet la

synchronisation. Pour éviter que cette séquence de bits ne se retrouve de

nouveau à l’intérieur de la trame, on ajoute un 0 après une séquence de 5 bits

à 1. De la même façon, le récepteur recherchera lui aussi 5 bits à 1 et enlève-

ra le bit à 0 qui suit cette séquence.

- Le champ d’information :

Il contient les données de l’utilisateur (données “ brutes ” ou trames prove-

nant d’autres protocoles et encapsulées).

Le Frame Relay Forum recommande une taille de 1600 octets avec une taille

minimale de 1 octets. Ces données sont transmises sans être interprétées.

- Le FCS ou Frame Check Sequence :

12
C’est un champ qui sert à s’assurer que la trame n’a pas été transmise avec

des erreurs. Il fait 2 octets et correspond au polynôme (x16 + x12 + x5 + 1) dé-

fini par le CCITT. Le Frame Check Sequence effectue un contrôle sur tous les

bits de la trame à l’exception des entêtes et enqueues. Voyons maintenant les

spécificités de la trame Frame Relay :

- Le champ adresse : constitué des 6 bits de poids fort du premier

octet et des 4 bits de poids fort du second octet. Concaténés, ces 10 bits

forment l’adresse qui représente l’adresse d’un utilisateur du réseau Frame

Relay, et on l’appelle plus couramment Digital Link Connexion Identifier. Nous

verrons par la suite que cette adresse peut être étendue sur 24 bits.

- Le bit CR (Commande / Response indication bit) : inutilisé ce bit

est passé de façon transparente sur le réseau

13
- Le bit EA (extended adress bit) : ce bit permet d’étendre

l’adressage : si le bit EA est à 0 cela veut dire que l’adresse se poursuit dans

l’octet suivant jusqu’à ce que le bit EA soit mis à 1. Malgré tout le standard

Frame Relay est une adresse sur 2 octets. - Les bits FECN/BECN (Forward/

Backward Explicit Congestion Notification bit) : ces 2 bits permettent d’indi-

quer à l’utilisateur qu’une congestion a eu lieu dans un sens ou dans l’autre.

FECN est mis à 1 si une congestion a eu lieu dans le sens de traversée de la

trame. BECN indique une congestion dans le sens opposé de transport de la

trame. Malgré tout il n’y a aucune obligation pour l’utilisateur du système de

réception de tenir compte de cette information. Nous verrons par la suite les

mécanismes liés aux congestions… - Le bit DE (Discard Eligibility) : ce bit sert

lui aussi dans les situations de congestion : sa mise à un permet de notifier

au réseau que cette trame peut être détruite en cas de congestion car elle

dépasse le CIR (cf. : supra). Il peut être mis à un par l’utilisateur ou le réseau.

Il faut aussi noter que des trames n’ayant pas le bit DE à un peuvent aussi

être détruite en cas de congestion si nécessaire… Tous les champs ci-dessus

doivent être présent dans chaque trame qui est transportée entre 2 sys-

tèmes. Il est important de noter qu’à l’intérieur du protocole Frame Relay, il

n’y a aucune obligation ou mécanisme permettant de passer des messages

de signalisation entre utilisateurs (Le protocole LMI – Local Management In-

terface que nous verrons par la suite va dans ce sens). Une autre remarque à

propos de la comparaison Frame Relay / HDLC : le Frame Relay ne possède

14
pas d’informations de séquencement entre trames et donc ne nécessite pas

de numéro de séquence ou de messages de contrôle pour confirmer la ré-

ception.

6.2-gestion des erreurs :

Nous allons voir comment le protocole Frame Relay gère les erreurs dans

les trames.

Le principe général du Frame Relay est que si une trame est bonne, elle est

envoyé à son destinataire en suivant la “route ” appropriée. Par contre, s’il y a

un problème sur le réseau, par exemple une congestion, les nœuds du ré-

seau sont autorisés à détruire la trame pour corriger le problème.

De plus, ces mêmes nœuds peuvent détruire les trames jugées invalides

sans prévenir le destinataire. Sont déclarées invalides, les trames de la

forme suivante :

- une trame qui a moins de 5 octets entre l’entête et l’enqueue,

- une trame dont le FCS (contrôle de type CRC) est invalide,

- une trame qui ne contient pas une adresse valide,

- une trame qui contient un DLCI non supporté (voir le paragraphe sur le

DLCI)

- une trame qui dépasse la taille configurée entre l’utilisateur et le réseau

15
- une trame qui ne possède pas une entête ou une enqueue

En ce qui concerne le traitement des trames qui dépasseraient la longueur

maximale, le groupe des quatre laissait libre au constructeur l’implémenta-

tion de la procédure à effectuer (qui était en général de détruire la trame).

Par contre l’implémentation du CCITT et de l’ANSI y ajoute 2 alternatives sup-

plémentaires :

- faire suivre une partie de la trame jusqu’au destinataire puis détruire la

trame (utile pour certains types d’équipement qui ne bufferisent pas complè-

tement chaque trame avant de l’envoyer sur le réseau)

- faire suivre toute la trame jusqu’au destinataire avec un FCS correct (ce

type d’implémentation sera très peu utilisé car la plupart des matériels ont

des buffers qui sont configurés pour une taille maximale fixe)

De plus, certaines règles doivent être respectées :

- en cas de non transmission de données, on doit envoyer des flags sur le ré-

seau frame relay,

- le réseau ne peut pas lire ou modifier les données contenues dans le champ

de données de la trame Frame Relay, à l’exception de celles contenues dans

la trame utilisés par le protocole LMI (que nous verrons dans la suite)

- un des DLCI est réservé pour le protocole LMI et ne peut donc être utilisé

16
6.3.3-Adressage (DLCI)

L’adressage en Frame Relay s’effectue en donnant un numéro de circuit vir-

tuel entre l’utilisateur et le réseau et n’a qu’une valeur locale. Ces identifica-

teurs locaux sont nommés par le sigle DLCI pour Digital Link Connexion Iden-

tifier. Ils peuvent désigner des circuits virtuels permanents (PVC) comme des

circuits virtuels commutés (SVC). Leur fonction correspond à celle des LCN,

Logical Circuit Number, de X25. Pour mieux illustrer cette valeur locale d’un

DLCI voici un schéma :

17
Nous voyons bien dans cet exemple que l’utilisateur A et l’utilisateur B uti-

lisent un même DLCI sans que cela ne pose un quelconque problème de part

la valeur locale de cet identificateur.

Comme les DLCI n’ont seulement qu’une valeur locale, il est de la responsa-

bilité du réseau de faire la liaison entre le DLCI de départ de le DLCI d’arrivée

en passant par différent “ réseaux ” de DLCI à l’intérieur du réseau Frame Re-

lay.

Voici comment fonctionne l’attribution des DLCI au niveau d’un nœud de ré-

seau :

- chaque nœud possède une table de commutation qui associe à un DLCI sur

une voie entrante un DLCI sur une voie sortante ainsi qu’une voie de sortie.

- A l’arrivée d’une trame, le nœud de commutation va effectuer le processus

suivant : lecture de la valeur du DLCI, lecture dans l’entrée de la voie d’arri-

vée la voie de sortie, remplacement de la valeur du champ DLCI de la trame

par la nouvelle valeur, mise dans la file d’émission de la voie indiquée dans la

table de la trame

18
6.3.4-CLLM

19
20
Un des problèmes majeurs avec les mécanismes de gestion de congestion à

l’intérieur du protocole Frame Relay est que les messages de notification de

congestion (FECN et BECN) sont transportés à l’intérieur des trames de don-

nées et ne sont pas envoyés à l’utilisateur s’il ne les sollicite pas (à l’inverse

des autres protocoles synchrones qui fournissent des flots de messages de

contrôle séparés). Le principal problème de ce type de fonctionnement est le

manque de possibilité d’informer l’utilisateur qu’il congestionne le réseau s’il

n’y a pas de données qui passe dans la direction opposée. Le protocole Frame

Relay repose sur la mise à 1 du bit FECN dans les données qui sont envoyées

à destination, ce qui amène celui qui a envoyé les données à diminuer son

trafic momentanément. Ce type de procédure est non seulement, irréaliste,

mais probablement difficile à mettre en œuvre car elle demande une coordi-

nation du contrôle de flux entre chaque extrémités. Pour que la procédure de

contrôle de flux FECN marche, les périphériques des utilisateurs doivent co-

ordonner leurs protocoles de haut niveau de telle manière qu’un FECN reçu

au niveau de la trame signalera aux niveaux supérieurs qu’une baisse du taux

de transfert doit être signalé à l’utilisateur distant.

Cette situation a amené l’ANSI et le CCITT à développer un mécanisme op-

tionnel appelé Consolidated Link Layer Management (CLLM). CLLM est utilisé

sur un DLCI séparé de celui du flux de donnée et existe pour passer des mes-

sages de contrôle de niveau couche de liaison du réseau vers l’utilisateur.

Avec un champ d’adresse de 2 octets, le DLCI 1023 est utilisé pour le CLLM.

21
Quand un nœud du réseau est congestionné, il peut soit utilisé les bits FECN

ou BECN à l’intérieur de trames de données sur le DLCI de l’utilisateur, soit le

message CLLM sur un DLCI de management, ou les deux. Le message CLLM

contient une liste de DLCI qui peuvent causer la congestion, et demande im-

plicitement que le propriétaire du DLCI suspende temporairement la trans-

mission . Il est aussi possible que le message CLLM transporte une liste de

DLCI non actifs. Bien que ces DLCI ne causent pas de congestion, le message

indique à l’utilisateur du réseau Frame Relay que ces DLCI ne doivent pas

être activés sinon ils pourront probablement aggraver la congestion

Le message CLLM (pour un champ d’adresse de 2 octets) est représenté

dans le schéma ci dessous et est contraint à la même taille maximale qu’une

trame de typ e Frame Relay. Il peut être nécessaire d’envoyer plus qu’un

message CLLM si la liste de tous les DLCI affectés ne tient pas dans une

seule trame. Les formats pour des DLCI de 3 et 4 octets ont été défini dans

les spécifications ANSI/CCITT mais nous les omettrons de cet exposé pour

plus de clarté.

Le message CLLM provient de l’implémentation ISDN du Frame Relay. A

l’intérieur du réseau ISDN, le CLLM serait envoyé à l’intérieur d’une trame

LAPD XID (exchange identification) à travers le canal D de l’ISDN. Le format

du message est resté inchangé quand il a été transmis à l’implémentation

non ISDN du Frame Relay, même si beaucoup de champs ne sont pas exacte-

ment en rapport.

22
6.5-LMI :

-LMI est un standard pour la signalisation entre DTE et les commutateurs

Frame Relay:

• Il est responsable de l'administration des connexions et du maintien du

statuts entre les périphériques.

- Il supporte les mécanismes suivants:

• Un maintien en vie de la connexion (fonction keepalive). En cas de panne du

lien d'accès, l'absence de messages keepalive indiquera l'indisponibilité de la

ligne.

• Des informations sur le status des PVC : existence de nouveaux PVC et

suppression des existants, informations d'intégrité sur les PVC

• Adressage global : donne une signification global au système d'adressage

au lieu d'une signification locale

- Les LMI ont été développé indépendamment de Frame Relay et mis en place

avant. Ainsi il existe 3 LMI (Cisco, ITU, ANSI) incompatibles entre-eux :

• Cisco utilise le DLCI 1023 pour les messages ƒ ANSI et l'ITU utilisent le

DLCI 0

- En raison des types différents de LMI, il est préconisé de laisser le type par

défaut sur l'équipement (DTE et DCE).

23
-Grâce à « l'autosense » (LMI autosensing), le DTE va essayer de se mettre

d'accord avec le type de LMI du DCE.

24
6.6-L’ENCAPSULATION :

Généralités

-Le relais de trames assure le transport de protocoles divers (X.25, TCP/IP).

-Encapsulation ou tunneling

- Architecture générale.

-Normalisation

• Encapsulation X.25 ANSI/TI.617 Annexe G

• Multi-protocole RFC 1490

25
L’encapsulation X.25

-Transport X.25 dans le relais de trames

- La trame LAP-B est directement encapsulée dans la trame FR

-Encapsulation de la trame LAP-B

26
L’ENCAPSULATION MULTI-PROTOCOLES

-Utilise la trame non numérotée de LAP-D

-Champs

• PAD. Utilisé pour l’alignement. Prend la valeur 0x00.

• Contrôle. Valeur 0x03.

• NLPID. Identifie le protocole encapsulé.

27
6.3.7-Inverse ARP :

- Inverse ARP a été développé pour fournir un mécanisme à l'association de

DLCI dynamique à des adresses de couche 3:

• Fonctionne de la même manière que ARP sur un LAN

• Sur IP, avec ARP, le matériel connaît l'adresse IP est souhaite connaître

l'adresse MAC.

• Avec Inverse ARP, le routeur connaît l'adresse de la couche 2 qui est le DLCI

et souhaite connaître l'adresse de couche 3.

6.4-Les usages de ce réseau :

Avec l'arrivée de services haut débit tels que le DSL, le modem câble, le WAN

Ethernet (service Ethernet point à point sur fibre optique), le VPN et le MPLS,

Frame Relay a perdu de son intérêt comme solution d'accès au WAN. Cepen-

dant, la solution Frame Relay est toujours utilisée pour la connexion WAN

dans certains endroits du monde,

Une entreprise peut choisir un niveau de qualité de service et privilégier cer-

taines trames au détriment d'autres. Un certain nombre de fournisseurs de

services, dont AT&T, proposent le relais de trames, disponible sur des lignes

T-1 fractionnées ou sur des réseaux T-carrier complets. Le relais de trames

complète le RNIS et fournit un service de milieu de gamme entre ce dernier,

28
qui offre une bande passante à 128 Kbit/s, et l'ATM (Asynchronous Transfer

Mode), qui fonctionne à peu près comme le relais de trames, mais à un débit

de 155,520 Mbit/s ou 622,080 Mbit/s.

Volonté d ’augmenter les débits offerts aux utilisateurs , Le Frame Relay re-

présente une “ bonne affaire ” pour la plupart des opérateurs : de nom-

breuses offres sont donc disponibles ,

6.5-Les avantages et les incovénients de ce réseau :

6.5.1 les avantages :

Frame Relay offre plus de bande passante, et une meilleure fiabilité et une

plus grande résilience que les lignes privées ou les lignes louées.

Prenons l'exemple d'un grand réseau d'entreprise pour illustrer les avan-
tages du WAN Frame Relay. Dans l'exemple présenté dans la figure, la socié-
té SPAN Engineering possède cinq campus en Amérique du Nord. Comme
c'est le cas pour la plupart des entreprises, les besoins en bande passante de
SPAN sont variables.
Le premier point à prendre en considération est la bande passante néces-
saire à chaque site. Pour les employés travaillant depuis le siège social, la
connexion de Chicago-New York doit avoir un débit maximal de 256 kbit/s.
Trois autres sites en besoin d'un débit maximal de 48 kbit/s pour se connec-
ter au siège social, alors que la connexion entre les bureaux de New York et
de Dallas ne nécessite que 12 kbit/s.
Avant l'existence de Frame Relay, SPAN Engineering louait trois lignes dé-
diées.
Remarque : les valeurs de bande passante utilisées dans ce chapitre pour les
exemples de ligne louée et de Frame Relay ne correspondent pas nécessai-

29
rement à la bande passante actuelle. Les valeurs de bande passante utilisée
dans ce chapitre sont mentionnées uniquement à titre de comparaison.

6.5.2- les incovénients :

Cette technologie comporte quelques inconvénients, dont :

 -  Capacité de vérification des erreurs et fiabilité minime (laissées aux proto-

coles de couches supérieures).

 - Affecte le fonctionnement de certains aspects (Split Horizon, broadcasts,

etc.).

 - Ne diffuse pas les broadcasts. Pour en effectuer, il faut envoyer un paquet

à chaque destination du réseau.

30
7- Travail â réaliser :

7.1-Le diagramme principal :

31
Interface physique – Inverse-arp activé

R1>enable

R1#configure terminal

R1(config)#interface Serial 0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#ip address 192.168.0.1 255.255.255.0

R1(config-if)#no shutdown

Interface physique – Inverse-arp désactivé

R1>en

R1#configure terminal

R1(config)#interface Serial 0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no frame-relay inverse-arp

R1(config-if)#ip address 192.168.0.1 255.255.255.0

R1(config-if)#frame-relay map ip 192.168.0.2 200 broadcast

R1(config-if)#frame-relay map ip 192.168.0.3 300 broadcast

R1(config-if)#no shutdown

32
Subinterface multipoint – Inverse-arp activé

R1>en

R1#configure terminal

R1(config)#interface Serial 0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no shutdown R1(config-if)#exit

R1(config)#interface Serial 0/0.1 multipoint

R1(config-subif)#frame-relay interface-dlci 200

R1(config-subif)#frame-relay interface-dlci 300

R1(config-subif)#ip address 192.168.0.1 255.255.255.0

Subinterface multipoint – Inverse-arp désactivé

R1>enable

R1#configure terminal

R1(config)#interface Serial 0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no frame-relay inverse-arp

R1(config-if)#no shutdown R1(config-if)#exit

R1(config)#interface Serial 0/0.1 multipoint

33
R1(config-subif)#no frame-relay inverse-arp

R1(config-subif)#ip address 192.168.0.1 255.255.255.0

R1(config-subif)#frame-relay map ip 192.168.0.2 200 broadcast

R1(config-subif)#frame-relay map ip 192.168.0.3 300 broadcast

Subinterface point-to-point – Inverse-arp activé

R1>en

R1#configure terminal

R1(config)#interface Serial 0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no shutdown R1(config-if)#exit

R1(config)#interface Serial 0/0.200 point-to-point

R1(config-subif)#ip address 192.168.0.1 255.255.255.252

R1(config-subif)#exit

R1(config)#interface Serial 0/0.300 point-to-point

R1(config-subif)#ip address 192.168.0.5 255.255.255.252

R1(config-subif)#exit

34
Subinterface point-to-point – Inverse-arp désactivé

R1>enable

R1#configure terminal

R1(config)#interface Serial 0/0

R1(config-if)#encapsulation frame-relay

R1(config-if)#no frame-relay inverse-arp

R1(config-if)#no shutdown R1(config-if)#exit

R1(config)#interface Serial 0/0.200 point-to-point

R1(config-subif)#no frame-relay inverse-arp

R1(config-subif)#frame-relay interface-dlci 200

R1(config-subif)#ip address 192.168.0.1 255.255.255.252

R1(config-subif)#exit

R1(config)#interface Serial 0/0.300 point-to-point

R1(config-subif)#no frame-relay inverse-arp

R1(config-subif)#frame-relay interface-dlci 300

R1(config-subif)#ip address 192.168.0.5 255.255.255.252

R1(config-subif)#exit

35
7.2- les équipements et logicielles utilisées :

 la réalisation de travail ça sera avec le logiciel packet tracer :

on est besoin de 3 Router-pt et un cloud-pt ( frame relay switches ) et 3

pc-t et câblage Serial et Ethernet

7.3- le principe de fonctionnement :

On va créer 3 réseaux différent entre un cloud et on va configurer le dlci dans

le cloud pour permettre a chaque réseaux de se connecter a l’autre réseaux

pour une transmissions uniquement de bout en bout

36
7.3- les étapes dédiées :

1ermennt on va crée un réseau comme suit  de la figure 1:

figure 1

37
1-configurer l adressage des pc’s :

voici la configuration de pc 1 :

la meme chose pour les autres pc avec :

pc2 :

adresses ip : 172,16,0,100

masque sous réseau : 255,255,255,0

passerelle : 192,168,1,1
38
pc3 :

adresse ip : 172,16,0,100

masque sous réseau : 255,255,255,0

passerelle 192,168,1,1

2-configuration les interfaces des router comme suit :

la mème chose pour R1 et R2 avec les adresse com suit de figure 1

39
3-configuration le routage rip sure les routers :

par les commandes suivants :

40
4- la configuration de cloud :

la configurration de DLCi :

on fait la meme chose pour serial0 et serial1 pour que on peut faire la

configuration de frame relay  suivante,

41
la configuration de frame relay :

pour qu’elle soit comme ca :

42
5- Configuration de frame relay sur les routers :

pour R1

par les commandes suivants :

43
pour R2 :

par les commandes suivants :

44
pour R3 :

par les commandes suivants :

45
6-tester la connectivité :

maintenant pour qu'on peut savoir si le frame relay est dans le bon fonction-

nement on va faire un ping

46
Le frame relay avec les sous interface

1-on va crée le même chemin de réseau présidant :

2-effectuer les même étapes jusque l’étape 4 ,,,,,,,

47
3-Configuration de frame relay et les sous-interrfaces sur les routers :

pour R1

par les commandes suivants :

48
pour R2 

par les commandes suivants :

49
pour R3

par les commandes suivants :

50
4-tester la connectivité :

on va tester encore une fois si le frame relay est dans le bon fonctione-

ment mais celle fois ci avec les sous interfaces

y on’a une connectivité entre les réseaux donc le frame relay est dans

le bon fonctionnement , le travail est bien faite ^^

51
8- Conclusion :

- Implantation facile

- Performances supérieures à X.25

-Ce n’est probablement qu’une techniqueintermédiaire (pas adapté au mul-

media)

-Liaisons Louées (Très utilisé aux USA)

- Accès par Numéris

Le Frame Relay est actuellement un protocole d’interconnexion beaucoup

moins médiatisé et beaucoup moins connu que son grand rival : l’ATM. Malgré

tout, on peut le considérer comme un concurrent sérieux de ce dernier grâce

aux avantages que celui possède sur son adversaire : - le coût des déploie-

ments est beaucoup plus faible, - sa technologie proche de X25 facilite la

transition avec ce protocole, dominant encore le marché des interconnexions

de réseaux locaux européens , Frame Relay est encore au début de sa courbe

de croissance en Europe et la plupart des opérateurs poussent leurs clients à

passer de X25 à F rame Relay, service souvent facturé à un coût identique

pour un débit pouvant être temporairement supérieur ce qui satisfait

les attentes des utilisateurs.

Le Frame Relay est donc un protocole qu’il ne faut pas ignorer et dont on

sera sûrement amené à entendre parler dans les années à venir !

52
Bibliographie

Site du Frame Relay Forum : www.frforum.com Tout sur…le Frame Relay :

www.starburstcom.com/frelay.htm

Club tuto informatique ;

https://clubtutoinformatique.blogspot.com/2013/07/technologie-frame-

relay.html#:~:text=%C2%B7%20Utilise%20le%20multiplexage%20pour

%20partager,aux%20protocoles%20de%20couches%20sup%C3%A9rieures).

Guide complet de configuration et de dépannage de Frame Relay :

https://www.cisco.com/c/fr_ca/support/docs/wan/frame-relay/16563-12.html

wikipedia :

https://fr.wikipedia.org/wiki/Relais_de_trames

Livre : CCNA ICND, Exam Certification Guide

YouTube :

https://www.youtube.com/watch?v=F926ApfBMfQ&t=8s

https://www.youtube.com/watch?v=OAYWsODDIRU

,,,,,,,,,,

53

Vous aimerez peut-être aussi