Vous êtes sur la page 1sur 2

Semestre 2 - 3 Sciences et Techniques Matière : Informatique

Mini projet
Jeu: Deviner l’ordre des chiffres
Soit le jeu suivant:
- On demande le nombre Donner le nombre des entiers=5
des entiers n 10, 56, 5, 82,12
Deviner l’ordre de ces chiffres: Donner l’entier n°0=10 Donner l’entier n°0=10
- Afficher n entiers générés Donner l’entier n°0=5 Donner l’entier n°1=12 Donner l’entier n°1=12
aléatoirement (entre 1 et Donner l’entier n°1=12 Donner l’entier n°2=5 Donner l’entier n°2=56
100) Donner l’entier n°2=10 Donner l’entier n°3=82 Donner l’entier n°3=82
Donner l’entier n°3=82 Donner l’entier n°4=56 Donner l’entier n°4=5
- Deviner l’ordre de ces Donner l’entier n°4=56 10,12, X, 82, X 10,12, 56, 82, 5
chiffres. X , 12, X, 82, X
- Aprés chaque essai, afficher l’entier s’il est dans la position exacte 0 1 2 3 4
et X dans le cas contraire. T 10 12 56 82 5
Travail à faire:
1) Quelle structure de données, on pourra utiliser pour stocker les n entiers à générer
Aléatoirement ?
..............................................................................................................................
2) Quelle structure de données, on pourra utiliser pour stocker les n entiers à saisir ?
..............................................................................................................................
3) Comment déclarer un tableau T, de 5 entiers ?
..............................................................................................................................
4) Quelle bibliothèque à importer avant d’utiliser les tableaux dans Python ?
..............................................................................................................................
5) Soit l’algorithme suivant :
Algorithme jeu Donner une implémentation en python
Début ............................................................................................
Ecrire("Donner le nombre des entiers=") ............................................................................................
Lire (n) ............................................................................................
............................................................................................
Pour i de 0 à n-1 faire ............................................................................................
T[i]← Aléa(1,100) ............................................................................................
Finpour ............................................................................................
............................................................................................
Pour i de 0 à n-1 faire ............................................................................................
Ecrire("L’entier n°",i ,"=",T[i]) ............................................................................................
FinPour ............................................................................................
Fin ............................................................................................
6) On va mélanger le éléments du tableau (changer leurs positions) en utilisant un module à développer
ultérieurement en algorithmique melanger(T,n), en Python il existe un module pr édéfini permettant de faire cette
tâche, lequel:........................ , quelle est la bibliothèque à importer pour pouvoir utiliser ce module: ........................
7) On demande les propositions de l’utilisateur, à stocker dans un autre tableau T1:
Pour i de 0 à n-1 faire Donner une implémentation en python
Ecrire("Donner l’entier n°",i ,"=") ............................................................................................
Lire (T1[i]) ............................................................................................
FinPour ............................................................................................
............................................................................................
............................................................................................

Prof:N.DHIFALLAH Année scolaire 2020-2021


Semestre 2 - 3 Sciences et Techniques Matière : Informatique
8) Pour comparer les éléments entre tableau T et T1 0 1 32 4
T 10 12 56 82 5
On va utiliser la boucle suivante: Implémentation en python:
0 1 2 3 4
Pour i de 0 à n-1 faire .................................................. T1 10 5 56 12 82
Si T[i]=T1[i] alors Ecrire(T[i]) ..................................................
Sinon Ecrire("X") ..................................................
FinSi ..................................................
FinPour
9) Faire une boucle infinie sur la saisie de proposition, la comparaison et l’affichage de résultat (en Python).
10) Pour arrêter la boucle lorsque chaque nombre est dans sa bonne position, on va utiliser l’algorithme suivant:
Suite algorithme jeu : Donner une implémentation en python
Ecrire("Deviner l’ordre de ces chiffres:") ............................................................................................
Répéter ............................................................................................
ok←Vrai ............................................................................................
Pour i de 0 à n-1 faire ............................................................................................
Ecrire("Donner l’entier n°",i ,"=") ............................................................................................
Lire (T1[i]) ............................................................................................
FinPour ............................................................................................
Pour i de 0 à n-1 faire ............................................................................................
Si T[i]=T1[i] alors Ecrire(T[i]) ............................................................................................
............................................................................................
Sinon Ecrire("X")
............................................................................................
ok←Faux ............................................................................................
FinSi ............................................................................................
FinPour ............................................................................................
Jusqu’a ok=Vrai ............................................................................................
11) Modifier le programme pour donner nb essais (nb=n-1) seulement , enfin afficher le message “Bravo”
lorsque ok=vrai et “Perdu” dans le cas contraire. Donner l’algorithme final du jeu proposé :
Suite algorithme jeu : Donner une implémentation en python
Ecrire("Deviner l’ordre de ces chiffres:") ............................................................................................
nb←0 ............................................................................................
Répéter ............................................................................................
nb←nb+1 ............................................................................................
ok←Vrai ............................................................................................
Pour i de 0 à n-1 faire ............................................................................................
Ecrire("Donner l’entier n°",i ,"=") ............................................................................................
Lire (T1[i]) ............................................................................................
FinPour ............................................................................................
............................................................................................
Pour i de 0 à n-1 faire
............................................................................................
Si T[i]=T1[i] alors Ecrire(T[i]) ............................................................................................
Sinon Ecrire("X") ............................................................................................
ok←Faux ............................................................................................
FinSi ............................................................................................
FinPour ............................................................................................
Jusqu’a (ok=Vrai) ou (nb=nb-1) ............................................................................................
Si ok=vrai alors Ecrire("Bravo") ............................................................................................
Sinon Ecrire("Perdu") ............................................................................................
Finsi T.D.O ............................................................................................
Objet Type/Nature
................................. .................................
................................. .................................
................................. .................................
Remarque:
La fonction print affiche l'a rgument qu'on lui passe entre .................................... ..........................................
parenthèses ensuite, ajoute par défaut un retour à ligne .
Donc print() provoque .................................................. .................................... ..........................................
En python on peut modifier ce comportement en ajoutant le mot ................................... ..........................................
clé end=’ ’ pour éviter un retour à la ligne . Ne pas afficher une ..........................................
Reprendre l’affichage des éléments de T séparés par des virgule pour la dernière
virgules: valeur: ..........................................

Prof:N.DHIFALLAH Année scolaire 2020-2021

Vous aimerez peut-être aussi