Vous êtes sur la page 1sur 7

Routage dynamique RIPv2

Version 2.0

11/03/2015
BTS SIO SISR
Brochard Florent
BTS SIO ITIC PARIS

Sommaire
I. Qu’est-ce que le routage dynamique ? ........................................................................................... 3
II. Qu’est-ce que le protocole RIP ? ..................................................................................................... 3
III. Plan d’adressage .......................................................................................................................... 3
IV. Configuration des switches ......................................................................................................... 4
V. Configuration des routeurs ............................................................................................................. 5
VI. Routage dynamique RIP .............................................................................................................. 6
VII. Liste des routes sur les routeurs ................................................................................................. 6

Brochard Florent Rip V2 Page 2 sur 7


BTS SIO ITIC PARIS

I. Qu’est-ce que le routage dynamique ?

Le routage dynamique permet de créer automatique des routes dans un réseau. Il permet de
faciliter l’administration de grands réseaux mais consomme de la bande passante et augmente les
risques au niveau de la sécurité. Il existe plusieurs protocoles permettant le routage dynamique.
Nous utiliserons ici le protocole RIP v2 pour mettre en place le routage dynamique.

II. Qu’est-ce que le protocole RIP ?

Le protocole RIP (Routing Information Protocole) est protocole de vecteur distance c'est-à-
dire que ce protocole va calculer la route par rapport au nombre de routeur que celui va traverser
(hops) et choisir le route la plus courte. Il utilise donc la métrique. La taille du chemin réseau est
limitée à 15 routeurs.

III. Plan d’adressage

Equipement Vlan/interface Adresse IP Masque Passerelle


PC0 Vlan 10 172.16.10.1 255.255.255.0 172.16.10.254
PC1 Vlan 10 172.16.10.2 255.255.255.0 172.16.10.254
PC2 Vlan 20 172.16.20.1 255.255.255.0 172.16.20.254
PC3 Vlan 20 172.16.20.2 255.255.255.0 172.16.20.254

Brochard Florent Rip V2 Page 3 sur 7


BTS SIO ITIC PARIS

PC4 Vlan 30 192.168.30.1 255.255.255.0 192.168.30.254


PC5 Vlan 30 192.168.30.2 255.255.255.0 192.168.30.254
Routeur0 Fa0/0.10 172.16.10.254 255.255.255.0
Se0/1/0 10.10.10.1 255.255.255.252
Routeur1 Fa0/0.30 192.168.30.1 255.255.255.0
Se0/1/1 20.20.20.1 255.255.255.252
Routeur2 Fa0/0.20 172.16.20.254 255.255.255.0
Se0/1/0 10.10.10.2 255.255.255.252
Se0/1/1 20.20.20.2 255.255.255.252

IV. Configuration des switches

Switch0>en
Switch0#conf t
Switch0(config)#vlan 10
Switch0(config-vlan)#exit
Switch0(config)#int range fa0/1 – 2
Switch0(config-if-range)#switchport mode access
Switch0(config-if-range)#switchport access vlan 10
Switch0(config-if-range)#no shut
Switch0(config-if-range)#exit
Switch0(config)#int fa0/24
Switch0(config-if)#switchport mode trunk
Switch0(config-if)#switchport trunk allowed vlan all
Switch0(config-if)#no shut
Switch0(config-if)#exit

Switch1>en
Switch1#conf t
Switch1(config)#vlan 30
Switch1(config-vlan)#exit
Switch1(config)#int range fa0/1 – 2
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access vlan 30
Switch1(config-if-range)#no shut
Switch1(config-if-range)#exit
Switch1(config)#int fa0/24
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#switchport trunk allowed vlan all
Switch1(config-if)#no shut
Switch1(config-if)#exit

Switch2>en
Switch2#conf t
Switch2(config)#vlan 20
Switch2(config-vlan)#exit
Switch2(config)#int range fa0/1 – 2
Switch2(config-if-range)#switchport mode access
Switch2(config-if-range)#switchport access vlan 20

Brochard Florent Rip V2 Page 4 sur 7


BTS SIO ITIC PARIS

Switch2(config-if-range)#no shut
Switch2(config-if-range)#exit
Switch2(config)#int fa0/24
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#switchport trunk allowed vlan all
Switch2(config-if)#no shut
Switch2(config-if)#exit

V. Configuration des routeurs

Routeur0>en
Routeur0#conf t
Routeur0(config)#int fa0/0.10
Routeur0(config-subif)#encapsulation dot1q 10
Routeur0(config-subif)#ip address 172.16.10.254 255.255.255.0
Routeur0(config-subif)#no shut
Routeur0(config-subif)#exit
Routeur0(config)#int se0/1/0
Routeur0(config-if)#ip address 10.10.10.1 255.255.255.252
Routeur0(config-if)#no shut
Routeur0(config-if)#exit

Routeur1>en
Routeur1#conf t
Routeur1(config)#int fa0/0.30
Routeur1(config-subif)#encapsulation dot1q 30
Routeur1(config-subif)#ip address 192.168.30.254 255.255.255.0
Routeur1(config-subif)#no shut
Routeur1(config-subif)#exit
Routeur1(config)#int se0/1/1
Routeur1(config-if)#ip address 20.20.20.1 255.255.255.252
Routeur1(config-if)#no shut
Routeur1(config-if)#exit

Routeur2>en
Routeur2#conf t
Routeur2(config)#int fa0/0.20
Routeur2(config-subif)#encapsulation dot1q 20
Routeur2(config-subif)#ip address 172.16.20.254 255.255.255.0
Routeur2(config-subif)#no shut
Routeur2(config-subif)#exit
Routeur2(config)#int se0/1/0
Routeur2(config-if)#ip address 10.10.10.2 255.255.255.252
Routeur2(config-if)#no shut
Routeur2(config-if)#exit
Routeur2(config)#int se0/1/1
Routeur2(config-if)#ip address 20.20.20.2 255.255.255.252
Routeur2(config-if)#no shut
Routeur2(config-if)#exit

Brochard Florent Rip V2 Page 5 sur 7


BTS SIO ITIC PARIS

VI. Routage dynamique RIP

Routeur0(config)#router rip
Routeur0(config – router)#version 2
Routeur0(config – router)#no auto-summary
Routeur0(config – router)#network 10.10.10.0
Routeur0(config – router)#network 172.16.10.0
Routeur0(config – router)#passive-interface fa0/0

Routeur1(config)#router rip
Routeur1(config – router)#version 2
Routeur1(config – router)#no auto-summary
Routeur1(config – router)#network 20.20.20.0
Routeur1(config – router)#network 192.168.30.0
Routeur1(config – router)#passive-interface fa0/0

Routeur2(config)#router rip
Routeur2(config – router)#version 2
Routeur2(config – router)#no auto-summary
Routeur2(config – router)#network 10.10.10.0
Routeur2(config – router)#network 20.20.20.0
Routeur2(config – router)#network 172.16.20.0
Routeur2(config – router)#passive-interface fa0/0

VII. Liste des routes sur les routeurs

Routeur0

Routeur1

Brochard Florent Rip V2 Page 6 sur 7


BTS SIO ITIC PARIS

Routeur2

Brochard Florent Rip V2 Page 7 sur 7

Vous aimerez peut-être aussi