Vous êtes sur la page 1sur 11

RÉPUBLIQUE ALGÉRIENNE DÉMOCRATIQUE ET POPULAIRE

MINISTÈRE DE L’ENSEIGNEMENT SUPÉRIEUR ET DE LA RECHERCHE SCIENTIFIQUE

Université Djillali Liabes de Sidi- Bel-Abbes


Faculté de Génie Électrique
Département De Télécommunications

Master Télécommunications

Compte rendu

Ayant pour sujet

TP 02 : Configuration avancé d’un


service voip
Présenté par :

Mr. Badi Alaa Eddine

Année universitaire : 2021-2022
Objectif : implémentation d’un service voip étendue entre deux entreprises distantes
géographiquement.

Introduction :
Dans ce TP nous allons voir comment élargir un service voip avec une connexion internet pour
relié deux entreprises.

Manipulation :

Partie 1 : Configuration des switches :


On commence à configurer nos 2 switches et créer des vlan (data et VOIP) avec les commandes
suivantes :
Partie 2 : Configuration du routeur :
 Passant maintenant à configuration de notre routeur 0 qui relie notre switch avec l’ISP. Et
on continue avec les autres routeurs qui suit :

Routeur 0 :

Routeur 1 : (ISP)


Routeur 3 :

 On passe maintenant à la configuration de nos PC, pour mettre les adresses IP DHCP, et
on essaye de faire un ping entre les deux pcs pour vérifier si la liaison entre les deux
réseaux est bien établie. Comme suit :

Configuration du service VOIP :


 Passant maintenant à la configuration de nos téléphone VOIP, en appliquant pour chaque
téléphone la même configuration mais en changent le numéro attribuer comme suit :
Rq : ces configurations votre être injecter dans notre routeur, vu que notre téléphone VOIP ne
peux pas être configurer directement.
Donc notre téléphone IP 1 prendra le numéro 1001
Et le deuxième prendra le numéro : 1002, la configuration de notre deuxième téléphone est
comme suit :

 Attribuons maintenant le chemin qu’ils doit prendre pour établir une communication
entre les deux téléphone IP, comme suit :

Routeur 0 :
dial-peer voice 1 voip

destination-pattern 1002

session target ipv4:192.168.2.1

end

Routeur 1 :
dial-peer voice 2 voip

destination-pattern 1001

session target ipv4:192.168.0.1

end
 Vérification du fonctionnement des téléphones IP :
Testant a présent si les deux téléphones peuvent faire une communication entre eux, comme
suit :

Donc notre communication et notre liaison a été faite avec succès, nos téléphones ont tout les
deux des numéros et une adresse ip, et en même temps ils peuvent communiquer sans aucuns
soucis.
On peut aussi vérifier à partir de la commande ‘’Show ephone’’ dans les deux routeurs comme
suit :

Routeur 0 :

Routeur 1 :

Donc sa nous confirme que nos deux téléphones ont une adresse mac unique, et un numéro de téléphone
accompagner d’une adresse ip.
Configuration de la nouvelle topologie :

Pour rajouter une nouvelle interface a notre ‘’ISP’’ il faudra sauvegarder la configuration avec la
commande ‘’WR’’

 Ensuite il faut ajouter une interface dans les paramètre du routeur comme suit :
 Maintenant on passe à la liaison du nouveau routeur avec l’ISP et la configuration se fait
comme suit :

Switch 2 :
vlan 22
name data
exit
interface fastEthernet0/1
switchport mode trunk
switchport trunk allowed vlan 11,22
interface fastEthernet0/2
switchport mode access
switchport access vlan 22
vlan 11
name voip
exit
interface fastEthernet0/3
switchport mode access
switchport voice vlan 11

 Passant maintenant au routeurs :

Routeur 3 :
int f0/0
ip add 172.16.1.1 255.255.255.0
no shu
int f0/1
no shu
int f0/1.11
encapsulation dot1Q 11
ip add 192.168.4.1 255.255.255.0
int f0/1.22
encapsulation dot1Q 22
ip add 192.168.5.1 255.255.255.0
exit
router eigrp 1
network 192.168.4.0
network 192.168.5.0
network 172.16.1.0 0.0.0.255
no auto-summary
Configuration DHCP :

ip dhcp pool voix

network 192.168.4.0 255.255.255.0

default-router 192.168.4.1

option 150 ip 192.168.4.1

exit

ip dhcp pool data

network 192.168.5.0 255.255.255.0

default-router 192.168.5.1
exit

ip dhcp excluded-address 192.168.5.1

router eigrp 1

network 192.168.4.0

network 192.168.5.0

network 172.16.1.0 0.0.0.255

no auto-summary

ip dhcp pool voix

network 192.168.4.0 255.255.255.0

default-router 192.168.4.1

option 150 ip 192.168.4.1

exit

ip dhcp pool data

network 192.168.5.0 255.255.255.0

default-router 192.168.5.1

exit

ip dhcp excluded-address 192.168.5.1

Configuration du telephone VOIP:

Telephony-service

Max-ephones 1

Max-dn 1

Ip source-address 192.168.4.1 port 2000

Create cnf-files

Ephone-dn 1

Number 1003

Exit

Ephone 1

Type 7960

Button 1:1

Exit
 Passant maintenant au routeur 2 (ISP) pour ajouter l’adresse ip du routeur 3 :

Interface Ethernet0/1/0

Ip address 172.16.1.2 255.255.255.0

No shu

Router eigrp 1

Net 172.16.1.0 0.0.0.255

No auto-summary

ex

 Maintenant passant au configuration des chemin pour avoir une communication entre les
téléphone VOIP :

Routeur 0 : (pour téléphone 1 vers 3)


Dial-peer voice 3 voip

Destination-pattern 1003

Session target ipv4:192.168.4.1

End

Routeur 1 : (pour telephone 2 vers 3)


Dial-peer voice 3 voip

Destination-pattern 1003

Session target ipv4:192.168.4.1

End

Routeur 3 : ( pour telephone 3 vers 2 et 1) 


Dial-peer voice 1 voip

Destination-pattern 1001

Session target ipv4:192.168.0.1

End

Dial-peer voice 2 voip

Destination-pattern 1002

Session target ipv4:192.168.2.1

End
 Vérifions maintenant si la communication entre les trois ephone se font avec succès comme suit :

Téléphone 3 vers 1 : connexion établie (et vice versa)

Téléphone 3 vers 1 (et vice versa) connexion établie

Et donc voila notre configuration a été faite avec succès ! et la communication est établie !

Vous aimerez peut-être aussi