Vous êtes sur la page 1sur 1

1 Correction Série de Révision 3 Mathématiques Trimestre 1

Exercice N°1 :
Instruction Code en python Résultat en python Type de résultat

ch ← "je suis en 3 éme année" ch="je suis en 3 éme année" je suis en 3 éme année Chaîne de caractères

X ← racine carré (long(ch)) X=math.sqrt(len(ch)) 4.69 Réel


N ← arrondi(X) N= round(X) 5 Entier
C ← ch[N] C=ch[N] i caractère
P ← pos("suis",ch) P=ch.find(("suis") 3 Entier
A ← valeur(ch[12])*2 A=int(ch[11])*2 6 Entier
R← pos("An",ch)>0 R=pos("An",ch)>0 False Booléen

Exercice N°2 :
Algorithme Programme en python

Algorithme bissextile A=-1


Début while A<=0:
Répéter A=int(input("Donner une année > 0:"))
Ecrire ("Donner une année > 0:") if A%4==0 and A%100!=0 or A%400==0:
Lire(A) print (A,"est bissextile")
Jusqu’à (A>0) else:
Si (A mod 4=0 ET A mod 100 ≠0) OU (A mod 400=0) Alors print (A,"n'est pas bissextile")
Ecrire ((A,"est bissextile")
Sinon TDO
Ecrire (A,"n'est pas bissextile") Objet Type/Nature
Fin si A Entier/variable
Fin
Exercice N°3 :
Algorithme Programme en python

Algorithme multiples3 for i in range (10,101):


Début if i % 3==0:
Pour i de 10 à 100 faire print(i)
Si i mod 3=0 alors
Ecrire (i) TDO
Fin si (A>0) Objet Type/Nature
Fin pour i Entier/variable
Fin

Exercice N°4 :
Algorithme Programme en python

Algorithme multiples3 from random import *


Début n=randint(2,5)
n←aléa(2,5) print(n)
Pour i de 1 à n faire Tab=['']*n
Ecrire ("donner le mot ",i," : ") for i in range (n):
Lire(Tab[i]) Tab[i]=input("donner le mot "+str(i+1)+" : ")
Fin pour for i in range(n):
Pour i de 1 à n faire if Tab[i].find("A")>=0:
Si pos("A",Tab[i])>0) alors print(Tab[i])
Ecrire(Tab[i]) TDO
Fin si Objet Type/Nature
Fin pour Tab Tableau de n chaines
Fin n,i Entier/variable

Prof : Nejla Mahjoub Abdellatif

Vous aimerez peut-être aussi