Vous êtes sur la page 1sur 20

Techniques et langage de

programmation structuré.

Les Tableaux Partie 1


Parcours Licence Professionnelle
2021-2022
Prof: MEZUI GUY
Plan
1-Définition d’un tableau
2-Intérêt des tableaux
3-Types et tailles d’un tableaux
PLAN 4-Notion Statique et Dynamique
5- Déclarer un tableau
6- Initialiser un tableau
7- Parcourir un tableau
8- QUIZ
1. Définition d’un tableau
1. Un tableau : Représentation
T1 0 5 3 1 10
• C’est une variable portant un nom
et divisée en cases alignées les unes T2 5.1 6.6 1.8 4.2 9.7 4.6
aux autres sur un même axe. T3 A G E S ‘\0’
• C’est aussi un ensemble de valeurs
portant le même nom de variable et T4
6 78 809 3
repérées par un nombre. 0 5 2 1

Remarque: T1, T2, T3 et T4 sont les noms des tableaux ou des variables.
2-Intérêt des tableaux

• Le tableau permet de rassembler plusieurs


variables en une seule variable;
• Il permet également d’ordonner ou de trier les
informations;
• Rechercher les éléments parmi les plusieurs.
• Faire les opérations et traitements complexes
comme les matrices, géométries....etc.
3-Type et taille des tableaux
3.1. Types de tableaux : Représentation
T1 0 5 3 1 10
• Le tableau T1 et T4 n’ont que des valeurs entières
dans chaque case ou des nombres entiers dans
T2 5.1 6.6 1.8 4.2 9.7 4.6
chaque case. Donc ils sont de type entier.
• Le tableau T2 n’a que des valeurs décimales ou des T3 A G E S ‘\0’
nombres décimaux. Donc il est de type réel ou
décimal. 6 78 809 3
T4
• Le tableau T 3 n’a que des caractères. Donc il est 0 5 2 1
de type caractères.
NB: On peut aussi avoir un tableau de type booléen dont les valeurs ne seront que : Vrai (True) ou Faux (False)
3-Type et taille des tableaux
3.2. Interprétations: Représentation
• On lit:
-T1 est un tableau de 1 ligne et de 5 colonnes T1 0 5 3 1 10
-T2 est un tableau de 1 ligne et de 6 colonnes
-T3 est un tableau de 1 ligne et de 5 colonnes T2 5.1 6.6 1.8 4.2 9.7 4.6
-T4 est un tableau de 2 lignes et de 4 colonnes
T3 A G E S ‘\0’
Déduction: Nous pouvons donc dire que les tableaux T1,T2
et T3 sont des tableaux de dimension 1 tandis que le tableau 6 78 809 3
T4
T4 est de dimensions 2. 0 5 2 1
Remarque: Un tableau dont le nombre de lignes est supérieur
ou égal à 2 est considéré comme un tableau à 2 dimensions.
3-Types et tailles des tableaux
3.3. La taille d’un tableaux : Représentation
• La taille d’un tableau est le nombre maximale T1 0 5 3 1 10
d’éléments que peut contenir ce tableau.
• Dans le tableau T1 on a 5 éléments, donc le T2 5.1 6.6 1.8 4.2 9.7 4.6
tableau T1 est de taille 5.
• Le tableau T2 est de taille 6. T3 A G E S ‘\0’
• Dans le tableau T4 on a 2 lignes et 4 colonnes,
donc le tableau T4 est de taille 2 et 4 6 78 809 3
T4
• Quelle es la taille du tableau T3 ? 0 5 2 1
4-Notion Statique et Dynamique
Statique: Dynamique:
• Un tableau est dit statique si sa taille et • Un tableau est dit dynamique si sa taille et sa
dimension peuvent changer pendant le
sa dimension ne changent pas pendant traitement de l’algorithme et qu’elles ne sont
traitement de l’algorithme et qu’elles connues au préalables.
sont connues au préalables. • Exemple:

7 9 80 9
• C’est le cas des tableaux T1, T2, T3 et T4
T5 5 56 0
2 6
4- Déclarer un tableau
4.1. Tableau à une dimension Syntaxes :
• Un tableau à une dimension doit être déclaré, • Déclarons les tableaux T1, T2
1)
en précisant le nombre d’éléments (la taille ) Variable T1 : Tableau (5) entier ;
et le type de valeurs qu’il contiendra. Variable T2 : Tableau (6 ) réel ;
2)
•Formule: Variable Tableau: T1[5] entier
Il y a deux manières de déclarer un tableau à une dimension: Variable Tableau: T2[6] réel ;
1) Variable Tableau : nom du tableau[taille] type- éléments
• Déclarer le tableau T3 ?
2) Variable Nom du tableau : Tableau (taille) type-éléments
5- Déclarer un tableau
4.2. Tableau à deux dimensions Syntaxes :
• Déclarons le tableau T5
• Un tableau à deux dimensions doit être
déclaré, en précisant le nombre de lignes, le 1)
nombre de colonnes et le type de valeurs qu’il Variable T5 : Tableau (2, 4) entiers ;
contiendra.
2)
•Formule: Variable Tableau: T5[2] [4] entiers

Il y a deux manières de déclarer un tableau à deux dimensions:


1) Variable Nom du tableau : Tableau (nombre-lignes, nombre-colonnes) type-éléments
2) Variable Tableau : nom du tableau[nombre-lignes] [nombre-colonnes] type- éléments
6- Initialiser un tableau
Comme toute variable, un tableau peut être initialisé lors Remarques :
de sa définition. Par exemple :
1) En général, les tableaux sont initialisés par
T1[5] ← { 0, 5, 3, 1, 10 } ; l'indication de la liste des éléments du tableau
T2[5] ← { 5.1, 6.6, 1.8, 4.2, 9.7, 4.6} ; entre accolades.

T3[5] ← { ‘A’, ‘G’, ‘E’, ‘S’, ‘\0’ } ; 2) On peut initialiser une partie du tableau
seulement (forcément les premiers
T4(2,5) ←{ {6, 78, 809, 3}, {0, 5, 2, 1} }
éléments). Les éléments restants sont alors
automatiquement mis à 0 par le
compilateur.
• Peut on initialiser le tableau T5 ? Justifier votre réponse.
7- Parcourir un tableau
Le parcours d’un tableau se fait case par case ou bien Représentation :
élément par élément en utilisant une boucle et un Soit j l’indice ou le compteur.
indice de parcours. j=3 j=4
j=0 j=1 j=2
• L’indice de parcours est aussi appelé compteur. T1 0 5 3 1 10
• On accède en lecture ou en écriture à la valeur T1[0] T1[1] T1[2] T1[3] T1[4]
d’un tableau en utilisant la syntaxe suivante :
nom de tableau [indice ] ; Syntaxe pour afficher les valeurs 5, 1 et 10 :
Ecrire(T1[1]) =>on affiche 5
Ecrire(T1[3]) =>on affiche 1
• Donner la syntaxe pour afficher les valeurs 0 et 3 du tableau T1 ? Ecrire(T1[4]) =>on affiche 10
7- Parcourir un tableau
Pour afficher tous les éléments du tableau T1, on Représentation :
utilise la boucle Soit j l’indice ou le compteur.
Syntaxe pour afficher toutes les valeurs du tableau T1: j=0 j=1 j=2 j=3 j=4
pour j=0 à 4 faire T1 0 5 3 1 10
Ecrire(T1[j]);
T1[0] T1[1] T1[2] T1[3] T1[4]
Fin pour
On aura à la sortie: 0 5 3 1 10

• Donner la syntaxe pour afficher toutes les valeurs du tableau T2 ?


6- Parcourir un tableau
Remplacer respectivement les valeurs 5, 1 et 10 du Représentation :
tableau T1 par les 9, 2 et 30 Soit j l’indice ou le compteur.
Syntaxe pour remplacer: j=0 j=1 j=2 j=3 j=4
T1[1] ← 9 ; T1 0 5 3 1 10
T1[3] ← 2;
T1[0] T1[1] T1[2] T1[3] T1[4]
T1[4] ← 30 ;
On aura à la sortie: T1 0 9 3 2 30

• Donner la syntaxe pour remplacer respectivement les valeurs 0


et 3 par 34 et 14 du tableau T1 ?
7- Parcourir un tableau
Remplacer respectivement toutes les valeurs du tableau
T2 par 1.1, 1.2, 1.3, 1.4, 1.5, 1.6 saisies au clavier Représentation :
Soit j l’indice ou le compteur.
Syntaxe pour afficher toutes les valeurs du tableau T1: j=0 j=1 j=2 j=3 j=4 j=5
pour j=0 à 5 faire T2 5.1 6.6 1.8 4.2 9.7 4.6
Lire(j)
Fin pour T2[0] T2[1] T2[2] T2[3] T2[4] T2[5]
On aura à la sortie: 1.1 1.2 1.3 1.4 1.5 1.6

• Donner la syntaxe pour afficher toutes les valeurs du tableau T2 ?


Exemples

Exemple 1 Exemple 2
1. Ecrire un algorithme qui demande 1. Ecrire un algorithme qui demande
à l’utilisateur de remplir un tableau à l’utilisateur de remplir deux
de taille 5 et affiche le carré de tableau de même taille 6 et calcul
chaque valeur saisie. leur produit.
2. Traduire cet algorithme en C. 2. Traduire cet algorithme en C.
Solutions
1. Algorithme : Carre_Tableau 2. Algorithme : Produit_Tableaux
Variables i, j: entiers Variables i, j: entiers
Tableau: T1[5], T2[5] réels Tableau: T1[6], T2[6], T3[6] réels
Début Début
Ecrire (‘Remplissez votre tableau!!’); Ecrire (‘Remplissez vos deux tableau!!’);
pour i ← 1 à 5 faire pour i ← 1 à 6 faire
Lire(T1[i]); Lire(T1[i], T2[i]);
T2[i] ← (T1[i] * T1[i]); T 3[i] ← (T1[i] * T2[i]);
Fin Pour Fin Pour
pour j ← 0 à 4 faire pour j ← 0 à 5 faire
Ecrire (T2[j]); Ecrire (T3[j]);
Fin Pour Fin Pour
Fin Fin
Solution pour Exemple 1
Solution pour Exemple 2
QUIZ

Vous aimerez peut-être aussi