Vous êtes sur la page 1sur 40

IGA TP Matériels d’interconnexion

TP .1 : PRISE EN MAIN D’UN ROUTEUR

OBJECTIFS.

• Se familiariser avec le mode setup du routeur.


• Définir le nom identifiant le routeur.
• Configurer la bannière du message du jour.

Nota: Pour le bon déroulement de ce labo, le professeur aura pris soin, avant la séance, de supprimer la configuration de
démarrage startup-config et de redémarrer le routeur.

MAQUETTE.

ÉTAPE 1 - CONNECTEZ-VOUS AU ROUTEUR ET ACCEDEZ AU MODE PRIVILEGIE.

1. Entrez la commande d'aide. La commande setup est-elle disponible ?

ÉTAPE 2 - PASSEZ EN MODE SETUP.

2. Entrez setup à l'invite de commandes. La commande setup permet d’exécuter une routine de configuration initiale
interactive appelée « dialogue de configuration système ». Le routeur vous demande si vous voulez poursuivre avec le
dialogue de configuration. Entrez yes ou appuyez sur la touche <entrée> pour poursuivre. Quelle est l'importance du mot
inclus entre crochets ?
3. Le routeur vous demande si vous voulez d'abord consulter le sommaire des interfaces en cours. Appuyez sur la touche
<entrée> ou entrez yes. Complétez le tableau ci-dessous avec les informations fournies.
Interface Adresse IP OK Méthode État Protocole
4. Configurez les paramètres généraux (nom d'hôte, mot de passe, …) du routeur en répondant aux questions posées.
5. Vous pouvez ensuite configurer une (et une seule) interface de communication. Configurez les paramètres de l'interface
Ethernet 0 du routeur en répondant aux questions posées.
6. Le routeur affiche le script de commande de configuration qu'il a généré à partir des informations que vous avez
données, puis il vous demande si vous voulez enregistrer cette configuration. Répondez yes à la question " Use this
configuration? ". Où cette configuration at-elle été enregistrée ?

1
IGA TP Matériels d’interconnexion

ÉTAPE 3 - AFFICHEZ LES FICHIERS DE LA CONFIGURATION ACTIVE ET DE LA CONFIGURATION DE


SAUVEGARDE.

7. Tapez show running-config à l'invite du routeur. Comparez le nom d'hôte de la configuration active avec celui affiché
par l'invite du routeur. Ces noms sont-ils identiques ?
8. Tapez show startup-config à l'invite du routeur. Le nom d'hôte et celui affiché par l'invite du routeur sont-ils identiques
?

ÉTAPE 4 - PASSEZ EN MODE DE CONFIGURATION GLOBALE.

9. Tapez configure terminal à l'invite du routeur. Quelle invite affiche le routeur ?


10. Entrez la commande d'aide en tapant ? À l'invite du routeur. La commande hostname figure-t-elle parmi les options de
commande ?
11. Entrez la commande d'aide associée à la commande en tapant hostname ? à l'invite du routeur. Quelle est la réponse du
routeur ?

ÉTAPE 5 - CONFIGUREZ LE NOM D'HOTE DU ROUTEUR.

12. Entrez hostname votre_prénom à l'invite du routeur. L'invite du routeur a-t-elle changé ?
13. Tapez exit à l'invite du routeur pour revenir à l'invite du mode privilégié puis tapez show running-config. Le nom
d'hôte du routeur apparaît-il dans le fichier de configuration active ?
14. Tapez show startup-config à l'invite du routeur. Le nom d'hôte est-il identique ?

2
IGA TP Matériels d’interconnexion

TP .2 : CONFIGURATIONS DES MOTS DE PASSE D’UN ROUTEUR

OBJECTIFS.

• Configurer un mot de passe pour la connexion à la console en mode utilisateur.


• Configurer un mot de passe pour les sessions de terminal virtuel (Telnet).
• Configurer un mot de passe enable secret pour le mode privilégié.

MAQUETTE.

ÉTAPE 1 : CONNECTEZ-VOUS AU ROUTEUR EN MODE UTILISATEUR.

1. Connectez-vous au routeur et ouvrez une session.


2. Quelle est l’invite affichée par le routeur ?
__________________________________________________________________________
3. Que signifie-t-elle ?
__________________________________________________________________________

ÉTAPE 2 : CONNECTEZ-VOUS AU ROUTEUR EN MODE PRIVILEGIE.

1. Entrez enable à l'invite du mode utilisateur.


Router>enable
2. Quelle est l’invite affichée par le routeur ?
__________________________________________________________________________
3. Que signifie-t-elle ?
__________________________________________________________________________

ÉTAPE 3 : PASSEZ EN MODE DE CONFIGURATION GLOBALE.

1. Entrez configure terminal à l’invite du mode privilégié.


Router#configure terminal
2. Quelle est l’invite affichée par le routeur ?________________________________________
3. Que signifie-t-elle ?
__________________________________________________________________________

ÉTAPE 4 : ENTREZ LE NOM D’HOTE GAD POUR CE ROUTEUR.

1. Entrez hostname GAD à l’invite.


Router(config)#hostname GAD
2. Quelle est l’invite affichée par le routeur ?
__________________________________________________________________________
3. Que signifie-t-elle ?
__________________________________________________________________________
3
IGA TP Matériels d’interconnexion

ÉTAPE 5 : CONFIGUREZ ET QUITTEZ.

Configurez le mot de passe de console et quittez la ligne de console :


GAD(config)#line console 0
GAD(config-line)#password cisco
GAD(config-line)#login
GAD(config-line)#exit
GAD(config)#

ÉTAPE 6 : CONFIGUREZ ET QUITTEZ.

Configurez le mot de passe sur les lignes de terminal virtuel et quittez le mode ligne :
GAD(config)#line vty 0 4
GAD(config-line)#password cisco
GAD(config-line)#login
GAD(config-line)#exit
GAD(config)#

ÉTAPE 7 : CONFIGUREZ LE MOT DE PASSE ENABLE.

Configurez le mot de passe enable sur le routeur et quittez le mode de configuration global.
GAD(config)#enable password cisco
GAD(config)#exit

ÉTAPE 8 : REPASSEZ EN MODE UTILISATEUR.

Repassez en mode utilisateur en entrant la commande disable :


GAD#disable

ÉTAPE 9 : REPASSEZ EN MODE PRIVILEGIE.

Une invite vous demande d'entrer un mode passe. Entrez cisco. Les caractères ne seront pas apparents sur la ligne.
GAD>enable
Password:cisco

ÉTAPE 10 : REPASSEZ EN MODE CONFIGURATION.

Repassez en mode configuration en entrant configure terminal :


GAD#configure terminal

ÉTAPE 11 : CONFIGUREZ LE MOT DE PASSE ENABLE SECRET.

Configurez le mot de passe enable secret et quittez le mode de configuration global :


GAD(config)#enable secret class
GAD(config)#exit

Remarque :
Souvenez-vous que le mot de passe enable secret est crypté dans l'affichage de la configuration. Ne tapez pas
enable secret password class, sinon le mot de passe secret sera password, et non class.

ÉTAPE 12 : REPASSEZ EN MODE UTILISATEUR.

Repassez en mode utilisateur en entrant la commande disable :


GAD#disable
GAD>

4
IGA TP Matériels d’interconnexion

ÉTAPE 13 : REPASSEZ EN MODE PRIVILEGIE.

Une invite vous demande d’entrer un mot de passe. Entrez cisco. Les caractères n’apparaîtront pas sur la ligne. Si
cela échoue, continuez jusqu’à ce que le message bad secrets s’affiche :
GAD>enable
Password:cisco
Password:cisco
Password:cisco
% Bad secrets
ÉTAPE 14 : REPASSEZ EN MODE PRIVILEGIE.

Une invite vous demande d’entrer un mode passe. Entrez class. Les caractères n’apparaîtront pas sur la ligne :
GAD>enable
Password:class
GAD#

Remarque :

Le mot de passe enable secret a préséance sur le mot de passe enable. Ainsi, lorsqu’un mot de passe enable secret
est entré, le mot de passe enable n’est plus accepté.

ÉTAPE 15 : AFFICHEZ LA CONFIGURATION COURANTE DES ROUTEURS.

GAD#show running-config
1. Y a-t-il un mot de passe crypté ? ______________________________________________
2. Y a t-il d’autres mots de passe ? _______________________________________________
3. Un des autres mots de passe est-il crypté ? _______________________________________
Après avoir réalisé les étapes précédentes, déconnectez-vous en tapant exit.

5
IGA TP Matériels d’interconnexion

TP .3 : CONFIGURATION DES INTERFACES SERIE / ETHERNET

OBJECTIFS.

• Configurer une interface série sur chacun des deux routeurs pour qu’ils puissent communiquer.
• Configurer une interface Ethernet sur le routeur avec une adresse IP et un masque de sous-réseau.

1. ATELIER 1

IL s’agit de configurer une interface Ethernet sur le routeur avec une adresse IP et un masque de sous-réseau.

MAQUETTE.

ÉTAPE 1 : CONFIGUREZ LE NOM D’HOTE ET LES MOTS DE PASSE SUR LE ROUTEUR GAD.

Sur le routeur, passez en mode de configuration globale et configurez le nom d’hôte, la console, le terminal
virtuel et les mots de passe enable, comme indiqué dans le tableau.

ÉTAPE 2 : CONFIGUREZ L’INTERFACE FASTETHERNET 0.

GAD(config)#interface fastEthernet 0
GAD(config-if)#ip address 192.168.14.1 255.255.255.0
GAD(config-if)#no shutdown
GAD(config-if)#exit
GAD (config)#exit

ÉTAPE 3 : ENREGISTREZ LA CONFIGURATION.

En mode privilégié, remplacez la configuration de démarrage par la configuration courante :


GAD#copy running-config startup-config

ÉTAPE 4 : AFFICHEZ LES INFORMATIONS DE CONFIGURATION DE FASTETHERNET 0.

GAD#show interface fastethernet 0


1. Indiquez au moins trois caractéristiques découvertes grâce à l’exécution de cette commande.
2. FastEthernet0 est __________________. Le protocole de ligne est __________________.
3. L’adresse Internet est _____________________.
4. Encapsulation _________________________
5. À quelle couche du modèle OSI la notion « d’encapsulation » fait-elle référence ? _________
Après avoir réalisé les étapes précédentes, déconnectez-vous en tapant exit.

6
IGA TP Matériels d’interconnexion

2. ATELIER 2.

IL s’agit de configurer une interface série sur chacun des deux routeurs pour qu’ils puissent communiquer.

MAQUETTE.

ÉTAPE 1 : CONFIGURATION DE BASE DU ROUTEUR.

Connectez les routeurs comme indiqué dans le schéma. Pour ce TP, vous avez besoin d’un câble série null et de
deux câbles console.

ÉTAPE 2 : CONFIGUREZ LE NOM ET LES MOTS DE PASSE DU ROUTEUR 1.

1. Sur le routeur 1, passez en mode de configuration globale et configurez le nom d'hôte comme indiqué dans le
tableau.
2. Configurez la console, le terminal virtuel et les mots de passe enable.

ÉTAPE 3 : CONFIGUREZ L’INTERFACE SERIE SERIAL 0.

À partir du mode de configuration globale, configurez l’interface série Serial 0 sur le routeur GAD.
Reportez-vous au relevé des interfaces.
GAD(config)#interface serial 0
GAD(config-if)#ip address 192.168.15.1 255.255.255.0
GAD(config-if)#clock rate 56000
GAD(config-if)#no shutdown
GAD(config-if)#exit
GAD(config)#exit

ÉTAPE 4 : ENREGISTREZ LA CONFIGURATION COURANTE.

En mode privilégié, remplacez la configuration de démarrage par la configuration courante :


GAD#copy running-config startup-config

7
IGA TP Matériels d’interconnexion

ÉTAPE 5 : AFFICHEZ LES INFORMATIONS SUR L’INTERFACE SERIE 0 SUR GAD.

1. Entrez la commande show interface serial 0 sur GAD. Reportez-vous au relevé des interfaces.
GAD#show interface serial 0
Les caractéristiques de l’interface Serial 0 s’affichent.
Indiquez au moins trois caractéristiques découvertes grâce à l’exécution de cette commande.
2. Serial 0 est ___________________. Le protocole de ligne est___________________ .
3. L’adresse Internet est _____________________.
4. Encapsulation _________________________
5. À quelle couche du modèle OSI la notion « d’encapsulation » fait-elle référence ? ________________
6. Bien que l'interface série soit configurée, la commande show interface serial 0 indique qu'elle est inactive.
Pourquoi ? ______________________________________________________________

ÉTAPE 6 : CONFIGUREZ LE NOM ET LES MOTS DE PASSE DU ROUTEUR 2.

Sur le routeur Birmingham, passez en mode de configuration globale. Configurez le nom d’hôte, la console, le
terminal virtuel et les mots de passe enable comme illustré dans le tableau précédent.

ÉTAPE 7 : CONFIGUREZ L'INTERFACE SERIE SERIAL 0.

À partir du mode configure terminal, configurez l’interface série Serial 0 sur le routeur BHM.
Reportez-vous au relevé des interfaces.
BHM(config)#interface serial 0
BHM(config-if)#ip address 192.168.15.2 255.255.255.0
BHM(config-if)#no shutdown
BHM(config-if)#exit
BHM(config)#exit

ÉTAPE 8 : ENREGISTREZ LA CONFIGURATION COURANTE.

En mode privilégié, remplacez la configuration de démarrage par la configuration courante :


BHM#copy running-config startup-config

ÉTAPE 9 : AFFICHEZ LES INFORMATIONS SUR L’INTERFACE SERIE 0 SUR BHM.

1. Entrez la commande show interface serial 0 sur BHM. Reportez-vous au relevé des interfaces.
BHM#show interface serial 0
Les caractéristiques de l’interface Serial 0 s’affichent.
Indiquez au moins trois caractéristiques découvertes grâce à l’exécution de cette commande.
2. Serial 0 est ___________________, le protocole de ligne est ___________________.
3. L’adresse Internet est _____________________. Encapsulation _______________________
4. Quelle est la différence entre l’état de ligne et de protocole précédemment enregistré sur GAD?
___________________________________________________________________________
Pourquoi ? ___________________________________________________________________

ÉTAPE 10 : ASSUREZ-VOUS QUE LA CONNEXION RESEAU FONCTIONNE CORRECTEMENT.

1. Envoyez un requête ping à l’interface série de l’autre routeur.


BHM#ping 192.168.15.1
GAD#ping 192.168.15.2
2. À partir de GAD, envoyez une requête ping à l’interface série du routeur BHM. La requête ping a-t-elle réussi ?
_________________
3. À partir de BHM, envoyez une requête ping à l’interface série du routeur GAD. La requête ping a-t-elle réussi ?
4. Si la réponse aux deux questions est non, vérifiez les configurations des routeurs pour trouver les
erreurs. Puis, relancez des requêtes ping jusqu'à ce que la réponse aux deux questions soit ouiAprès avoir réalisé
les étapes précédentes, déconnectez-vous en tapant exit.

8
IGA TP Matériels d’interconnexion

TP .4 : ADRESSAGE ET CALCUL VLSM

OBJECTIFS.

À l’issue de cet exercice, vous serez en mesure d’effectuer les tâches suivantes :

• Déterminer le nombre de sous-réseaux nécessaires


• Déterminer le nombre d’hôtes nécessaires pour chaque sous-réseau
• Concevoir un système d'adressage adapté à l'aide de la technique VLSM
• Attribuer des paires d’adresses et de masques de sous-réseau aux interfaces des périphériques
• Examiner l’utilisation de l’espace d’adressage réseau disponible

DIAGRAMME DE TOPOLOGIE

9
IGA TP Matériels d’interconnexion

TABLE D’ADRESSAGE

Périphérique Interface Adresse IP Masque de sous-réseau Passerelle par défaut

Fa0/0 s/o
Fa0/1 s/o
HQ
S0/0/0 s/o
S0/0/1 s/o
Fa0/0 s/o
Fa0/1 s/o
Branch1
S0/0/0 s/o
S0/0/1 s/o
Fa0/0 s/o
Fa0/1 s/o
Branch2
S0/0/0 s/o
S0/0/1 s/o

SCENARIO

Dans cet exercice, les adresses réseau 192.168.1.0/24 vous sont attribuées : elles vous permettent de créer des sous-réseaux
et de fournir l’adressage IP du réseau présenté dans le diagramme de topologie. La technologie VLSM sera utilisée pour
répondre aux exigences d’adressage du réseau 192.168.1.0/24. Le réseau a les exigences d’adressage suivantes :
• Le réseau local LAN1 de HQ a besoin de 50 adresses IP hôtes.
• Le réseau local LAN2 de HQ a besoin de 50 adresses IP hôtes.
• Le réseau local LAN1 de Branch1 a besoin de 20 adresses IP hôtes.
• Le réseau local LAN2 de Branch1 a besoin de 20 adresses IP hôtes.
• Le réseau local LAN1 de Branch2 a besoin de 12 adresses IP hôtes.
• Le réseau local LAN2 de Branch2 a besoin de 12 adresses IP hôtes.
• La liaison entre HQ et Branch1 nécessite une adresse IP à chaque extrémité.
• La liaison entre HQ et Branch2 nécessite une adresse IP à chaque extrémité.
• La liaison entre Branch1 et Branch2 nécessite une adresse IP à chaque extrémité.

(Remarque : n’oubliez pas que les interfaces des périphériques réseau sont également des adresses IP hôte et figurent
dans les exigences d’adressage ci-dessus).

TACHE 1 : EXAMEN DE LA CONFIGURATION RESEAU NECESSAIRE

Examinez la configuration nécessaire et répondez aux questions ci-dessous. N’oubliez pas que des adresses IP sont
nécessaires pour chaque interface de réseau local.
1. Quel est le nombre de sous-réseaux nécessaires ? _______
2. Quel est le nombre maximal d’adresses IP nécessaires par sous-réseau ? _______
3. Quel est le nombre d’adresses IP nécessaires pour chacun des réseaux locaux de Branch1 ? _______
4. Quel est le nombre d’adresses IP nécessaires pour chacun des réseaux locaux de Branch2 ? _______
5. Quel est le nombre d’adresses IP nécessaires pour chaque liaison de réseau étendu (WAN) entre les routeurs ?
_______
6. Quel est le nombre total d’adresses IP nécessaires ? _______

10
IGA TP Matériels d’interconnexion

7. Quel est le nombre total d’adresses IP disponibles sur le réseau 192.168.1.0/24 ? _______
8. Les exigences d’adressage réseau peuvent-elles être satisfaites avec le réseau 192.168.1.0/24 ? _______

TACHE 2 : CONCEPTION D’UN SYSTEME D’ADRESSAGE IP

ÉTAPE 1 : DEFINITION DES INFORMATIONS DE SOUS-RESEAU POUR LE OU LES SEGMENTS DE


RESEAU LES PLUS ETENDUS

Dans cet exemple, les deux réseaux locaux LAN de HQ sont les sous-réseaux les plus étendus.
1. Quel est le nombre d’adresses IP nécessaires pour chaque réseau local ? _______
2. Quel est le plus petit sous-réseau susceptible de remplir cette condition ? _______
3. Quel est le nombre maximal d’adresses IP pouvant être attribuées dans ce petit sous-réseau ? _______

ÉTAPE 2 : ATTRIBUTION DE SOUS-RESEAUX AUX RESEAUX LOCAUX DE HQ

Commencez au début du réseau 192.168.1.0/24.


1. Attribuez le premier sous-réseau disponible au réseau local LAN1 de HQ.
2. Complétez le tableau ci-dessous avec les informations correctes.

SOUS-RESEAU DU RESEAU LOCAL LAN1 DE HQ

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

3. Attribuez le sous-réseau disponible suivant au réseau local LAN2 de HQ.


4. Complétez le tableau ci-dessous avec les informations correctes.

SOUS-RESEAU DU RESEAU LOCAL LAN2 DE HQ

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

ÉTAPE 3 : DEFINITION DES INFORMATIONS DE SOUS-RESEAU POUR LE OU LES SEGMENTS DE


RESEAU SUIVANTS LES PLUS ETENDUS

Dans cet exemple, les deux réseaux locaux de Branch1 sont les deuxièmes sous-réseaux les plus étendus.
1. Quel est le nombre d’adresses IP nécessaires pour chaque réseau local ? _______
2. Quel est le plus petit sous-réseau susceptible de remplir cette condition ? _______
3. Quel est le nombre maximal d’adresses IP pouvant être attribuées dans ce petit sous-réseau ? _______

ÉTAPE 4 : ATTRIBUTION D’UN SOUS-RESEAU AUX RESEAUX LOCAUX DE BRANCH1

Commencez par l’adresse IP qui suit les sous-réseaux du réseau local de HQ.
1. Attribuez le sous-réseau suivant au réseau local LAN1 de Branch1.
2. Complétez le tableau ci-dessous avec les informations correctes.

11
IGA TP Matériels d’interconnexion

SOUS-RESEAU DU RESEAU LOCAL LAN1 DE BRANCH1

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

3. Attribuez le sous-réseau disponible suivant au réseau local LAN2 de Branch1.


4. Complétez le tableau ci-dessous avec les informations correctes.

SOUS-RESEAU DU RESEAU LOCAL LAN2 DE BRANCH1

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

ÉTAPE 5 : DEFINITION DES INFORMATIONS DE SOUS-RESEAU POUR LE OU LES SEGMENTS DE


RESEAU SUIVANTS LES PLUS ETENDUS

Dans cet exemple, les deux réseaux locaux de Branch2 sont les sous-réseaux les plus étendus.
1. Quel est le nombre d’adresses IP nécessaires pour chaque réseau local ? _______
2. Quel est le plus petit sous-réseau susceptible de remplir cette condition ? _______
3. Quel est le nombre maximal d’adresses IP pouvant être attribuées dans ce petit sous-réseau ? _______

ÉTAPE 6 : ATTRIBUTION DES SOUS-RESEAUX AUX RESEAUX LOCAUX DE BRANCH2

Commencez par l’adresse IP qui suit les sous-réseaux du réseau local de Branch1.
1. Attribuez le sous-réseau suivant au réseau local LAN1 de Branch2. Complétez le tableau ci-dessous avec les
informations correctes.

SOUS-RESEAU DU RESEAU LOCAL LAN1 DE BRANCH2

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

2. Attribuez le sous-réseau disponible suivant au réseau local LAN2 de Branch2.


3. Complétez le tableau ci-dessous avec les informations correctes.

SOUS-RESEAU DU RESEAU LOCAL LAN2 DE BRANCH2

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

ÉTAPE 7 : DEFINITION DES INFORMATIONS DE SOUS-RESEAU POUR LES LIAISONS ENTRE LES
ROUTEURS

1. Quel est le nombre d’adresses IP nécessaires pour chaque liaison ? _______


2. Quel est le plus petit sous-réseau susceptible de remplir cette condition ? _______
3. Quel est le nombre maximal d’adresses IP pouvant être attribuées dans ce petit sous-réseau ? _______

12
IGA TP Matériels d’interconnexion

ÉTAPE 8 : ATTRIBUTION DES SOUS-RESEAUX AUX LIAISONS

Commencez par l’adresse IP qui suit les sous-réseaux du réseau local de Branch2.
1. Attribuez le sous-réseau disponible suivant à la liaison entre les routeurs HQ et Branch1.
2. Complétez le tableau ci-dessous avec les informations correctes.

LIAISON ENTRE HQ ET LE SOUS-RESEAU BRANCH1

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

3. Attribuez le sous-réseau disponible suivant à la liaison entre les routeurs HQ et Branch2.


4. Complétez le tableau ci-dessous avec les informations correctes.

LIAISON ENTRE HQ ET LE SOUS-RESEAU BRANCH2

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

5. Attribuez le sous-réseau disponible suivant à la liaison entre les routeurs de Branch1 et de Branch2.
6. Complétez le tableau ci-dessous avec les informations correctes.

LIAISON ENTRE LES SOUS-RESEAUX BRANCH1 ET BRANCH2

Adresse réseau Masque de sous- Masque de Première adresse Dernière adresse Adresse
réseau décimal sous-réseau IP utilisable IP utilisable de diffusion
CIDR

TACHE 3 : ATTRIBUTION D’ADRESSES IP AUX PERIPHERIQUES RESEAU

Attribuez les adresses appropriées aux interfaces des périphériques. Les informations sur les adresses à utiliser figurent
dans le tableau d’adressage sous le diagramme de topologie.

ÉTAPE 1 : ATTRIBUTION D’ADRESSES AU ROUTEUR HQ

1. Attribuez la première adresse hôte valide de sous-réseau du réseau local LAN1 de HQ à l’interface du réseau local
Fa0/0.
2. Attribuez la première adresse hôte valide de sous-réseau du réseau local LAN2 de HQ à l’interface du réseau local
Fa0/1.
3. Attribuez la première adresse hôte valide de la liaison entre le sous-réseau de HQ et Branch1 à l’interface S0/0/0.
4. Attribuez la première adresse hôte valide de la liaison entre le sous-réseau de HQ et Branch2 à l’interface S0/0/1.

ÉTAPE 2 : ATTRIBUTION D’ADRESSES AU ROUTEUR BRANCH1

1. Attribuez la première adresse hôte valide de sous-réseau du réseau local LAN1 de Branch1 à l’interface du réseau
local Fa0/0.
2. Attribuez la première adresse hôte valide de sous-réseau du réseau local LAN2 de Branch1 à l’interface du réseau
local Fa0/1.
3. Attribuez la première adresse hôte valide de la liaison entre le sous-réseau Branch1 et HQ à l’interface S0/0/0.
4. Attribuez la première adresse hôte valide de la liaison entre les sous-réseaux Branch1 et Branch2 à l’interface
S0/0/1.

13
IGA TP Matériels d’interconnexion

ÉTAPE 3 : ATTRIBUTION DES ADRESSES AU ROUTEUR BRANCH2

1. Attribuez la première adresse hôte valide de sous-réseau du réseau local LAN1 de Branch2 à l’interface du réseau
local Fa0/0.
2. Attribuez la première adresse hôte valide de sous-réseau du réseau local LAN2 de Branch2 à l’interface du réseau
local Fa0/1.
3. Attribuez la dernière adresse hôte valide de la liaison entre HQ et le sous-réseau Branch2 à l’interface S0/0/1.
4. Attribuez la dernière adresse hôte valide de la liaison entre les sous-réseaux Branch1 et Branch2 à l’interface
S0/0/0.

14
IGA TP Matériels d’interconnexion

TP .5 : CONFIGURATION DES ROUTES STATIQUES

OBJECTIFS.

Configurer des routes statiques entre des routeurs pour permettre le transfert de données sans utiliser de protocoles
de routage dynamiques.

MAQUETTE.

ÉTAPE 1 : CONFIGUREZ LES DEUX ROUTEURS.

Passez en mode de configuration globale et configurez le nom d'hôte comme indiqué dans le tableau.
Configurez ensuite la console, le terminal virtuel et les mots de passe enable. Configurez les interfaces et les tables
d’hôtes IP. Ne configurez aucun protocole de routage

ÉTAPE 2 : CONFIGUREZ LES STATIONS DE TRAVAIL.

Configurez les postes de travail avec les adresses IP, les masques de sous réseau et les passerelles par défaut
appropriés.
1. La configuration pour l’hôte connecté au routeur Gasden est :
Adresse IP 192.168.14.2
Masque de sous réseau : 255.255.255.0
Passerelle par défaut 192.168.14.1
2. La configuration pour l’hôte connecté au routeur Birmingham est :
Adresse IP 192.168.16.2
Masque de sous réseau : 255.255.255.0
Passerelle par défaut 192.168.16.1
3. Vérifiez la connectivité entre les postes de travail à l’aide de la commande ping.
Du poste de travail connectée au router GAD, utilisez ping vers le poste de travail connecté au routeur BHM
C:\>ping 192.168.16.2
4. La requête ping a-t-elle abouti ? ______________________________________________
5. Pourquoi la requête ping a-t-elle échoué ? _______________________________________
6. En se basant sur les informations données par la commande show ip route utilisée sur les routeurs GAD et BHM,
est-ce qu’un hôte situé sur le réseau 192.168.16.0 peut se connecter à un hôte situé sur le réseau 192.168.14.0 ?
_______________________________________

15
IGA TP Matériels d’interconnexion

ÉTAPE 3 : VERIFIEZ L’ETAT DE L’INTERFACE.

7. Vérifiez les interfaces des deux routeurs à l’aide de la commande show ip interface brief.
8. Les interfaces nécessaires sont-elles toutes actives ? _______________________________

ÉTAPE 4 : VERIFIEZ LES ENREGISTREMENTS DE LA TABLE DE ROUTAGE.

9. Lancez la commande show ip route pour visualiser la table de routage IP du routeur GAD.
GAD>show ip route
output eliminated
Gateway of last resort is not set
C 192.168.14.0/24 is directly connected, FastEthernet0
C 192.168.15.0/24 is directly connected, Serial0
10. Utilisez la commande show ip route pour visualiser la table de routage IP du routeur BHM.
BHM>show ip route
Output eliminated.
Gateway of last resort is not set
C 192.168.15.0/24 is directly connected, Serial0
C 192.168.16.0/24 is directly connected, FastEthernet0
11. Toutes les routes nécessaires sont-elles dans les tables de routage ? ___________________
12. Est-ce qu’un hôte du réseau 192.168.16.0 peut voir un hôte du réseau 192.168.14.0 ? _______
Si une route permettant d'atteindre le réseau destination où l'hôte de destination est situé n’est pas liée au routeur
auquel l’hôte est connecté, ce dernier sera dans l'impossibilité de l'atteindre via le routeur en question.

ÉTAPE 5 : AJOUTEZ DES ROUTES STATIQUES.

13. Comment pouvez-vous changer cette situation de sorte que les hôtes puissent mutuellement s’envoyer des requêtes
ping ?
_______________________________________________________________________________
14. En mode de configuration globale, ajoutez une route statique sur le Routeur 1 vers le réseau 192.168.16.0 et sur le
Routeur 2 vers le réseau 192.168.14.0.
GAD(config)#ip route 192.168.16.0 255.255.255.0 192.168.15.2
BHM(config)#ip route 192.168.14.0 255.255.255.0 192.168.15.1
15. Pourquoi une route statique est-elle requise sur les deux routeurs ?
_______________________________________________________________________________

ÉTAPE 6 : VERIFIEZ LES NOUVELLES ROUTES.

16. Utilisez la commande show ip route pour visualiser la table de routage IP du routeur GAD.
GAD>show ip route
17. Lancez la commande show ip route pour visualiser la table de routage IP du routeur BHM.
BHM>show ip route
18. Toutes les routes nécessaires sont-elles dans les tables de routage ? _______________________
19. Est-ce qu’un hôte du réseau 192.168.16.0 peut voir un hôte du réseau 192.168.14.0 ? ____________

ÉTAPE 7 : ENVOYEZ UNE NOUVELLE REQUETE PING D'UN HOTE A L'AUTRE.

Vérifiez la connectivité entre postes de travail en utilisant une requête ping.


Du poste de travail attaché au routeur GAD, utilisez ping vers le poste de travail attaché au réseau BHM.
C:\>ping 192.168.16.2
Si la requête ping n’a pas abouti, vérifiez dans la table de routage que les routes statiques ont été entrées
correctement.
Après avoir réalisé les étapes précédentes, déconnectez-vous en entrant exit.

16
IGA TP Matériels d’interconnexion

TP .6 : GESTION DES FICHIERS DE CONFIGURATION AVEC TFTP

OBJECTIFS.

• Sauvegarder une copie d’un fichier de configuration de routeur.


• Recharger le fichier de configuration de sauvegarde dans la RAM d’un routeur à partir d’un serveur TFTP.
• Enregistrer la nouvelle configuration courante en NVRAM.

MAQUETTE.

ÉTAPE 1 : CONFIGUREZ LE ROUTEUR GADSDEN.

20. Configurer le nom d’hôte, les mots de passe, les interfaces et les tables d’hôtes sur le routeur.
21. Vérifiez les configurations des routeurs en exécutant la commande show running-config sur chaque routeur. Si la
commande ne s’exécute pas correctement, corrigez les erreurs de configuration et relancez la vérification.

ÉTAPE 2 : CONFIGUREZ LA STATION DE TRAVAIL.

Voici la configuration de l’hôte connecté au routeur Gadsden :


Adresse IP 192.168.14.2
Masque de sous-réseau IP 255.255.255.0
Passerelle par défaut 192.168.14.1

ÉTAPE 3 : CONNECTEZ-VOUS AU ROUTEUR EN MODE UTILISATEUR.

Connectez-vous au routeur Gadsden et ouvrez une session.

ÉTAPE 4 : DEMARRAGE ET CONFIGURATION DU SERVEUR TFTP CISCO.

Vérifier avec l'enseignant où le serveur TFTP est installé sur la station de travail des étudiants.

ÉTAPE 5 : VERIFIEZ LA CONNECTIVITE.

Envoyez une requête ping au serveur TFTP à partir du routeur Gadsden.


Si la requête ping échoue, corrigez les configurations de l’hôte et du routeur pour résoudre le problème.

17
IGA TP Matériels d’interconnexion

ÉTAPE 6 : COPIEZ LA CONFIGURATION COURANTE VERS LE SERVEUR TFTP.

22. Avant de copier les fichiers, vérifiez que le serveur TFTP fonctionne.
23. Consignez l’adresse IP du serveur TFTP. ______________________________
24. Entrez la commande copy running-config tftp. Suivez les invites :
GAD#copy running-config tftp
Address or name of remote host []? 192.168.14.2
Destination filename [gad-confg]? startup-config
!!
667 bytes copied in 0.036 secs (18528 bytes/sec)
ÉTAPE 7 : VERIFIEZ LE TRANSFERT VERS LE SERVEUR TFTP.

Vérifiez le fichier journal du serveur TFTP. Cliquez sur View > Log File.
Les informations affichées doivent être similaires à celles-ci :
Thu Sep 16 14:10:08 2004: Receiving ‘startup-config’ file from 192.168.14.1 in binary mode
Thu Sep 16 14:11:14 2004: Successful.

ÉTAPE 8 : COPIEZ LA CONFIGURATION DE DEMARRAGE A PARTIR DU SERVEUR TFTP.

25. Maintenant que le fichier «startup-config» est sauvegardé, nous allons tester cette image en restaurant le fichier
dans le routeur. Assumons que la configuration sur le routeur GAD s’est corrompue. Pour simuler ceci, changez le
nom du routeur de «GAD» à «Router».
26. Maintenant que la configuration de démarrage est sauvegardée, testez cette image ainsi que la procédure.
Restaurez le fichier sur le routeur.
27. D’abord, vérifiez si le serveur TFTP fonctionne, s’il partage un réseau avec le routeur et s’il est accessible depuis
le routeur. Envoyez une requête ping concernant son adresse IP.
28. Quelle est l’adresse IP du serveur TFTP ? ______________________________
29. Pour effectuer la copie à partir de l’invite du mode privilégié, tapez copy tftp running-config.
Appuyez sur Entrée.
Router#copy tftp running-config
Address or name of remote host []? 192.168.14.2
Source filename []? startup-config
Destination filename [running-config]? [Entrée]
Accessing tftp://192.168.14.2/startup-config...
Loading startup-config from 192.168.14.2 (via FastEthernet0): !
[OK - 667 bytes]
667 bytes copied in 9.584 secs (70 bytes/sec)
GAD#

ÉTAPE 9 : ENREGISTREZ LA NOUVELLE CONFIGURATION COURANTE.

Enregistrez la nouvelle configuration courante en NVRAM à l’aide de la commande suivante :


GAD#copy running-config startup-config
Destination filename [startup-config]?[Entrée]
Building configuration...
[OK]

ÉTAPE 10 : TESTEZ LE FICHIER RESTAURE.

Si l’invite du routeur a changé comme l’indique la dernière ligne qui s’affiche à l’étape 8, c’est que le fichier a été
chargé. Entrez la commande show startup-config pour vérifier la configuration tout entière.

ÉTAPE 11 : VERIFIEZ LES CONDITIONS D’INTERFACE.

Lorsque ce fichier est restauré, les interfaces sont désactivées par défaut, à moins que le fichier de configuration
ait été modifié et qu’une ligne de commande no shutdown ait été entrée après chaque profil d’interface.
Après avoir réalisé les étapes précédentes, déconnectez-vous en tapant exit.

18
IGA TP Matériels d’interconnexion

TP .7 : GESTION DES IMAGES DE L’IOS AVEC TFTP

OBJECTIFS.

Sauvegarder une copie de l’IOS d’un routeur de la mémoire flash vers un serveur TFTP.
Recharger l’image de l’IOS de sauvegarde d’un serveur TFTP sur la mémoire flash d’un routeur.

MAQUETTE.

PREREQUIS/PREPARATION.

À des fins de documentation et de récupération, il est important de conserver des copies de sauvegarde des images
de l’IOS d’un routeur. Celles-ci peuvent être stockées dans un emplacement central tel qu’un serveur TFTP et
extraites si nécessaire.
Installez un réseau similaire à celui du schéma précédent.
Lancez une session HyperTerminal.

ÉTAPE 1 : CONFIGUREZ LE ROUTEUR GAD.

30. Configurer le nom d’hôte, les mots de passe, les interfaces et les tables d’hôtes sur le routeur.
31. Vérifiez la configuration de travail du routeur en utilisant la commande show runningconfig.
Si la commande ne s’exécute pas correctement, corrigez les erreurs de configuration et relancez la vérification.

ÉTAPE 2 : CONFIGUREZ LA STATION DE TRAVAIL.

Voici la configuration de l’hôte connecté au routeur Gadsden :


Adresse IP 192.168.14.2
Masque de sous-réseau IP 255.255.255.0
Passerelle par défaut 192.168.14.1

ÉTAPE 3 : COLLECTEZ DES INFORMATIONS POUR DOCUMENTER LE NOUVEAU ROUTEUR.

32. Entrez la commande show version.


33. Quelle est la valeur actuelle du registre de configuration ?____0x ____________________
34. De combien de mémoire flash ce routeur dispose-t-il ? _____________________________
35. Y a-t-il au moins 4 Mo (4096 Ko) de mémoire flash ? _______________________________
36. Quel est le numéro de version de la ROM de démarrage ? ___________________________
37. Est-ce une ROM de démarrage de version 5.2 ou ultérieure ? ________________________

19
IGA TP Matériels d’interconnexion

ÉTAPE 4 : COLLECTEZ DES INFORMATIONS SUPPLEMENTAIRES POUR DOCUMENTER LE NOUVEAU


ROUTEUR.

38. Entrez la commande show flash.


39. Un fichier est-il déjà stocké en mémoire flash ? ____________________________________
40. Si oui, quel est son nom exact ? _______________________________________________
41. Quelle quantité de mémoire flash est disponible ou inutilisée ? _________________________
ÉTAPE 5 : DEMARREZ ET CONFIGUREZ LE SERVEUR TFTP CISCO.

Demandez au professeur l’adresse IP du serveur TFTP Cisco.

ÉTAPE 6 : VERIFIEZ LA CONNECTIVITE.

Effectuez une requête ping à partir du routeur Gadsden.


Si la requête ping échoue, corrigez les configurations de l’hôte et du routeur pour résoudre le problème.

ÉTAPE 7 : COPIEZ L’IOS VERS LE SERVEUR TFTP.

42. Avant de copier le fichier, vérifiez que le serveur TFTP fonctionne.


43. Quelle est l’adresse IP du serveur TFTP ? ______________________________________
44. À partir de la session en mode console, entrez show flash.
45. Quel est le nom et la taille de l’image de l’IOS stockée en mémoire flash ?
_______________________________________________________________________________________________
46. Quels attributs peuvent être identifiés à partir des codes du nom du fichier de l’IOS ?
_______________________________________________________________________

ÉTAPE 8 : COPIEZ L’IMAGE DE L’IOS VERS LE SERVEUR TFTP.

À partir de la session en mode console et à partir du mode privilégié, entrez la commande copy flash tftp. À
l’invite, entrez l’adresse IP du serveur TFTP :
GAD#copy flash tftp
Source filename []? flash:c1700-y-mz.122-11.T.bin
Address or name of remote host []? 192.168.14.2
Destination filename [c1700-y-mz.122-11.T.bin]? y
Les noms des fichiers dépendront de l’IOS et de la plateforme utilisés. Le nom du fichier pour votre
système a été déterminé lors de l’étape (4c).
Après avoir entré cette commande et répondu aux demandes du processus, l’étudiant doit voir les informations
suivantes s’afficher sur la console. N’interrompez pas ce processus.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
4284648 bytes copied in 34.012 secs (125975 bytes/sec)

ÉTAPE 9 : VERIFIEZ LE TRANSFERT VERS LE SERVEUR TFTP.

47. Vérifiez le fichier journal du serveur TFTP en cliquant sur View > Log File.
Les informations qui s’affichent doivent être similaires à celles-ci :
Mon Sep 16 14:10:08 2002: Receiving ‘c1700-y-mz.122-11.T.bin’ in binary
modeMon Sep 16 14:11:14 2002: Successful.
48. Vérifiez la taille de l’image flash dans le répertoire du serveur TFTP. Pour ce faire, cliquez sur :
View > Options.
Le répertoire racine du serveur TFTP s’affiche. Il doit être similaire au suivant, à moins que les répertoires par
défaut n’aient été modifiés :
C:\Program Files\Cisco Systems\Cisco TFTP Server
49. Repérez ce répertoire à l’aide du gestionnaire de fichiers. Examinez la liste détaillée du fichier.
La longueur du fichier dans la commande show flash doit être identique à celle du fichier stocké sur le serveur
TFTP. Si les fichiers ne sont pas identiques, consultez votre professeur.

20
IGA TP Matériels d’interconnexion

ÉTAPE 10 : COPIEZ L’IMAGE DE L’IOS A PARTIR DU SERVEUR TFTP.

50. Maintenant que l’IOS est sauvegardé, l’image doit être testée et l’IOS restauré sur le routeur.
Vérifiez à nouveau que le serveur TFTP fonctionne, s’il partage un réseau avec le routeur et s’il est accessible
depuis le routeur. Envoyez une requête concernant l’adresse IP du serveur TFTP.
51. Consignez l’adresse IP du serveur TFTP. _______________________________________
52. Effectuez la copie à partir de l’invite du mode privilégié. Quand interrogé sur le « Destination filename », utilisez
le nom du fichier déterminé lors de l’étape 9.
GAD#copy tftp flash
Address or name of remote host []?192.168.14.2
Source filename []?c1700-y-mz.122-11.T.bin
Destination filename [c1700-y-mz.122-11.T.bin]? [Entrée]
Accessing tftp://192.168.14.2/c1700-y-mz.122-11.T.bin...
Erase flash: before copying? [confirm][Entrée]
Erasing the flash filesystem will remove all files! Continue?
[confirm][Entrée]
Erasing device...
eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
...erased
Erase of flash: complete
Loading c1700-y-mz.122-11.T.bin from 192.168.14.2 (via FastEthernet0):!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK -4284648 bytes]
Verifying checksum... OK (0x9C8A)
4284648 bytes copied in 26.584 secs (555739 bytes/sec)
53. Le routeur peut demander l’effacement de la mémoire flash. Y a t-il assez de mémoire flash disponible pour
accueillir l’image ? _____________
54. Si la mémoire flash est effacée, que se produit-il sur l’écran de console du routeur ?
_______________________________________________________________________
55. Quelle est la taille du fichier en cours de chargement ? ____________________N’interrompez pas ce processus.
56. Que s’est-il produit sur l’écran de console du routeur lors du téléchargement du fichier ?
_______________________________________________________________________
57. La vérification a-t-elle été exécutée correctement ? __________________
58. L’opération a t-elle réussi dans l’ensemble ? __________________

ÉTAPE 11 : TESTEZ L’IMAGE DE L’IOS RESTAUREE.

59. Vérifiez que l’image du routeur est correcte. Mettez le routeur hors tension puis sous tension et observez le
processus de démarrage pour vous assurer qu’il n’y a pas d’erreurs de mémoire flash.
En l’absence d’erreur, l’IOS du routeur doit avoir démarré correctement.
60. Vérifiez de façon plus approfondie l’image de l’IOS stockée en mémoire flash en lançant la commande show
version. Les informations qui s’affichent doivent être similaires à :
System image file is "flash:c1700-y-mz.122-11.T.bin"
Après avoir réalisé les étapes précédentes, déconnectez-vous en tapant exit.

21
IGA TP Matériels d’interconnexion

TP .8 : PROCEDURES DE RECUPERATION DE MOT DE PASSE


OBJECTIFS.

Accéder à un routeur avec un mot de passe (enable) de mode privilégié inconnu.

MAQUETTE.

Remarque : Configurez le nom d’hôte et les mots de passe sur le routeur.


Demandez à un professeur ou à un autre étudiant de configurer une configuration de base avec un mot de passe
enable secret. Exécutez copy running-config startup-config et rechargez le routeur.
Remarque : La version du programme HyperTerminal fournie avec Windows 95, 98, NT et 2000 a été
développée pour Microsoft par Hilgraeve. Certaines versions peuvent ne pas exécuter de séquence d’« interruption
» comme l’exige la technique de récupération des mots de passe sur les routeurs Cisco. Dans ce cas, une mise à
niveau, appelée HyperTerminal Private Edition (PE), est disponible gratuitement à des fins personnelles ou de
formation. Vous pouvez télécharger ce programme à l’adresse : http://www.hilgraeve.com

ÉTAPE 1 : TENTEZ DE VOUS CONNECTER AU ROUTEUR.

Réalisez les connexions de console nécessaires et établissez une session HyperTerminal avec le routeur. Tentez de
vous connecter au routeur à l’aide du mot de passe enable cisco. Le résultat doit être similaire à celui-ci :
Router>enable
Password:
Password:
Password:
% Bad secrets
Router>

ÉTAPE 2 : DOCUMENTEZ LA VALEUR DE REGISTRE DE CONFIGURATION ACTUELLE.

61. A l’invite du mode utilisateur, tapez show version.


62. Consignez la valeur affichée pour le registre de configuration ___________. Par exemple 0x2102.

ÉTAPE 3 : PASSEZ EN MODE MONITEUR ROM.

Mettez le routeur hors tension, attentez quelques secondes, puis remettez-le sous tension.
Dès que le routeur affiche « System Bootstrap, Version … » sur l’écran HyperTerminal, appuyez simultanément
sur la touche Ctrl et sur la touche Attn. Le routeur démarre alors en mode moniteur ROM.
En fonction du matériel de routeur, l’une des différentes invites telles que : « rommon 1 > » ou simplement « > »
peut s’afficher.

22
IGA – 3ISI Matériels d’interconnexion

ÉTAPE 4 : EXAMINEZ L’AIDE DU MODE MONITEUR ROM.

Tapez ?

ÉTAPE 5 : MODIFIEZ LA VALEUR DU REGISTRE DE CONFIGURATION POUR DEMARRER SANS


CHARGER LE FICHIER DE CONFIGURATION.

À partir du mode moniteur ROM, tapez confreg 0x2142 pour modifier le registre de configuration.
rommon 2 >confreg 0x2142
Certains anciens routeurs risquent de ne pas reconnaître la commande confreg. Dans ce cas, utilisez la commande
suivante :
>o/r 0x2142

ÉTAPE 6 : REDEMARREZ LE ROUTEUR.

À partir du mode moniteur ROM, tapez reset ou mettez le routeur hors tension puis sous tension.
rommon 2 >reset
À cause de la nouvelle valeur du registre de configuration, le routeur ne charge pas le fichier de configuration. Le
système demande :
“Would you like to enter the initial configuration dialog? [yes]:
Entrez no et appuyez sur Entrée.

ÉTAPE 7 : PASSEZ EN MODE PRIVILEGIE ET CHANGEZ DE MOT DE PASSE.

63. Maintenant, à l’invite du mode utilisateur Router>, tapez enable et appuyez sur Entrée pour passer en mode
privilégié sans mot de passe.
64. Utilisez la commande copy startup-config running-config pour restaurer la configuration de routeur existante.
Puisque l’utilisateur est déjà en mode privilégié, aucun mot de passe n’est nécessaire.
65. Tapez configure terminal pour passer en mode de configuration globale.
66. Dans le mode de configuration globale, tapez enable secret class pour modifier le mot de passe enable secret.
67. Toujours en mode de configuration globale, tapez config-register xxxxxxx. xxxxxxx est la valeur du registre de
configuration originale enregistrée à l’étape 2. Appuyez sur Entrée.
68. Utilisez la combinaison Ctrl z pour retourner en mode privilégié.
69. Utilisez la commande copy running-config startup-config pour enregistrer la nouvelle configuration.
70. Avant de redémarrer le routeur, vérifiez la nouvelle valeur du registre de configuration.
À partir de l’invite du mode privilégié, entrez la commande show version et appuyez sur Entrée.
71. La dernière ligne qui s’affiche doit être :
Configuration register is 0x2142 (will be 0x2102 at next reload).
72. Utilisez la commande reload pour redémarrer le routeur.

ÉTAPE 8 : VERIFIEZ LE NOUVEAU MOT DE PASSE ET LA NOUVELLE CONFIGURATION.

Lors du rechargement du routeur, le mot de passe doit être class.


Après avoir réalisé les étapes précédentes, déconnectez-vous en tapant exit.

23
IGA – 3ISI Matériels d’interconnexion

TP .9 : SAUVEGARDE ET RESTAURATION DES FICHIERS DE CONFIGURATION

OBJECTIFS.

• Récupérer sur la station de travail la configuration active d’un routeur ou celle de démarrage par capture de texte
avec l’HyperTerminal et enregistrement dans un fichier ASCII.
• Retouchez avec un éditeur de texte le scénario de commandes contenu dans un fichier ASCII.
• Implanter une nouvelle configuration sur le routeur par collage de texte avec l’HyperTerminal.
• Importer et exporter par le réseau la configuration active ou de démarrage d’un routeur en utilisant le service
fourni par TFTP (Trivial File Transfer Protocol).

MAQUETTE.

ÉTAPE 1 – VISUALISEZ LES FICHIERS DE CONFIGURATION RUNNING-CONFIG ET STARTUP-CONFIG


SUR LE ROUTEUR.

1. Connectez-vous au routeur et ouvrez une session en mode utilisateur. Entrez le mot de passe cisco si un message vous y
invite. Entrez la commande show running-config pour visualiser la configuration active sur le routeur puis la commande
show startupconfig pour visualiser la configuration de démarrage.
Qu’a répondu le routeur à chaque fois?
2. Basculez en mode privilégié. Pouvez-vous maintenant afficher la configuration active du routeur ainsi que sa
configuration de démarrage ?

ÉTAPE 2 – RECUPERER LE FICHIER RUNNING-CONFIG SUR LA STATION DE TRAVAIL AVEC


L’HYPERTERMINAL.

3. Entrez la commande show running-config. Le scénario de commande relatif à la configuration active s’affiche à l’écran,
avec arrêt du défilement page par page. Appuyez sur la barre d'espacement à chaque fois que l'invite " -More - " apparaît
pour poursuivre le défilement.
4. A l’aide de la souris et de la barrette de défilement avant/arrière, sélectionnez la zone de texte correspondant au scénario
de commande du running-config. Ce scénario débute juste après la ligne affichant Current configuration et s’arrête après
celle affichant end.
5. Dans l’HyperTerminal, cliquez sur le menu Edition Copier.
6. Pour récupérer le texte ainsi capturé, lancez un éditeur de texte type Bloc-Note et cliquez sur le menu Edition Coller.
Enregistrez le fichier ASCII sous le nom que vous voulez, dans le répertoire « C:\cisco\TFTP32\repertoire ftp ». Fermez
l’éditeur de texte.
Nota : Pour récupérer la configuration de démarrage, on procède de la même manière en entrant show startup-config à
l’étape 2.3 au lieu de show running-config.

24
IGA – 3ISI Matériels d’interconnexion

ÉTAPE 3 – MODIFIEZ LE SCENARIO DE COMMANDE DANS LE FICHIER ASCII.

7. On va modifier arbitrairement le fichier de configuration que l’on a récupéré sur notre station de travail. Lancez l’éditeur
de texte, ouvrez le fichier ASCII que vous avez créé à l’étape 2.6.
8. Pour l’exercice, nous allons modifier un élément de configuration qui n’intervient pas sur le bon fonctionnement du
routeur : Le motif de la bannière d’accueil. Localisez la ligne de commande définissant ce motif de la bannière d’accueil.
Modifiez ce motif à votre convenance.
Enregistrez les modifications dans le fichier ASCII.

ÉTAPE 4 - EFFACEZ LA CONFIGURATION DE DEMARRAGE ET REDEMARREZ LE ROUTEUR.

9. A l’invite du routeur, entrez erase startup-config pour effacer la configuration de démarrage. Par précaution, le routeur
fait une demande de confirmation. Validez la demande.
10. Redémarrez le routeur en utilisant la commande reload. Si le routeur vous demande si vous voulez enregistrer la
configuration active, répondez no bien sûr (sinon il reconstruira un fichier startup-config, et le fait de l’avoir effacé n’aura
servi à rien !).
11. Quand le routeur redémarre, il cherche dans la NVRAM le fichier startup-config qui contient sa configuration de
démarrage. Comme il ne le trouve pas, il propose de basculer en mode de dialogue ou mode SETUP pour que l’utilisateur
puisse fixer une configuration initiale.
Quelle question pose-t-il ?
12. Répondre no à la question puis appuyez sur <entrée>. Appuyez une deuxième fois sur cette touche. Quel est le motif
de l'invite de commande ?

ÉTAPE 5 - RECONFIGUREZ LE ROUTEUR A PARTIR DU FICHIER TEXTE QUE VOUS AVEZ


ENREGISTRE.

13. Entrez la commande enable pour basculer en mode privilégié. Pourquoi n'était-il pas nécessaire d'entrer un mot de
passe ?
14. Passez en mode de configuration globale en tapant configure terminal.
15. Dans l’HyperTerminal, cliquez sur le menu Transfert/Envoyer un fichier texte…
Sélectionnez le fichier que vous avez enregistré à l'étape 3.8. Chaque ligne du fichier texte est entrée automatiquement,
comme si vous les saisissiez vous-même.
16. Si besoin (normalement non puisque la commande end qui termine le fichier ASCII a permis de faire automatiquement
l’opération), quittez le mode de configuration global en appuyant simultanément sur les touches <ctrl> et <Z>.
17. La configuration contenue dans le fichier ASCII étant devenue la configuration active de votre routeur, il reste à
l’enregistrer pour qu’elle devienne aussi la configuration de démarrage, en utilisant la commande copy running-config
startup-config.
18. Vérifiez que l’implantation de la nouvelle configuration est correcte : il faut redémarrer le routeur et vérifier ensuite
qu’il fonctionne bien en faisant des tests de connectivité avec plusieurs hôtes de la plateforme.

ÉTAPE 6 - COPIEZ LES FICHIERS DE CONFIGURATION DU ROUTEUR SUR LA STATION DE TRAVAIL


A L’AIDE DE TFTP.

19. Puisqu’il s’agit ici de passer par le réseau pour transférer les fichiers de configuration, on va d’abord vérifier que le
routeur et la station de travail sont capables de communiquer. Testez la connectivité entre le routeur et la station de travail
en utilisant la commande ping. Vous avez initié le test à partir de quel hôte ? Quelle adresse IP avez-vous indiquée ? Le test
a-t-il réussi ?
20. TFTP (Trivial File Transfer Protocol) réalise un service de transfert de fichier. Il est situé au niveau de la couche
application, le transport étant basé sur une connexion TCP/IP. Le transfert de fichier est qualifié de trivial car il n’y a aucun
contrôle d’authentification des usagers (pas de demande de mot de passe, si bien que n’importe qui peut utiliser le service
!). Il fonctionne selon un modèle client-serveur. Pour lancer l’application jouant le rôle serveur sur la station de travail,
double-cliquez sur l’icône associée au programme tftpd32.exe.
21. A l’invite du routeur, entrez copy ? Pour afficher l’aide de la commande. Qu’a affiché le routeur ?
22. Entrez copy running-config ?. Qu’a affiché le routeur ?
23. Entrez la commande copy running-config tftp pour copier la configuration active du routeur vers un serveur TFTP.
Qu’a affiché le routeur ? Que doit-on faire ensuite ?
24. Sous quel nom enregistrez-vous le fichier de configuration running-config sur le serveur TFTP ?

25
IGA – 3ISI Matériels d’interconnexion

25. Confirmez le transfert du fichier de configuration sur le serveur TFTP en appuyant sur la touche <entrée>. Les points
d'exclamation qui s'affichent à l'écran indiquent l'état d'avancement de la procédure de copie du fichier par TFTP. Le
transfert s’est-il déroulé correctement ?

26. Sur le même principe, on veut transférer le fichier de configuration de démarrage du routeur vers la station de travail.
Quelle commande faut-il entrer ? Lancer la commande. Sous quel nom enregistrez-vous le fichier de configuration startup-
config sur le serveur TFTP ?

ÉTAPE 7 - COPIEZ LES FICHIERS DE CONFIGURATION DE LA STATION DE TRAVAIL SUR LE


ROUTEUR A L’AIDE DE TFTP.

27. En utilisant un éditeur de texte, modifiez un des fichiers de configuration que vous avez rapatrié sur la station de travail
en assignant un nouveau nom pour le routeur. Quel fichier avez-vous modifié ?
28. On veut importer ce fichier de configuration de la station de travail vers le routeur pour en faire notre configuration
active. Entrez la commande copy tftp running-config. Qu’a affiché le routeur ? Que doit-on faire ensuite ?
29. Une fois le transfert du fichier réalisé, comment se rend-on compte que la configuration active a changé ?
30. En utilisant un éditeur de texte, modifiez l’autre fichier de configuration que vous avez rapatrié sur la station de travail
en définissant un nouveau motif pour la bannière d’accueil.
Quel fichier avez-vous modifié ?
31. On veut importer ce fichier de configuration de la station de travail vers le routeur pour en faire notre configuration de
démarrage. Quelle commande faut-il entrer sur le routeur ? Qu’a affiché le routeur une fois cette commande entrée ? Que
doit-on faire ensuite ?
32. Une fois le transfert du fichier réalisé, redémarrez le routeur en utilisant la commande reload. Si le routeur vous
demande si vous voulez enregistrer la configuration active, répondez no bien sûr (sinon il reconstruira un fichier startup-
config, et le fait de l’avoir effacé n’aura servi à rien !). Comment se rend-on compte que la configuration de démarrage a
effectivement changé ?

26
IGA – 3ISI Matériels d’interconnexion

TP .10 : CONFIGURATION DE BASE D’UN COMMUTATEUR

OBJECTIFS.

• Configurer un commutateur avec un nom et une adresse IP.


• Configurer des mots de passe pour sécuriser l’accès à l’interface de commande en ligne.
• Configurer les propriétés de vitesse de port et de mode duplex du commutateur pour une interface.
• Enregistrer la configuration courante.
• Afficher l’interface de navigateur du commutateur.

MAQUETTE.

ÉTAPE 1 : ACCEDEZ AU MODE PRIVILEGIE.

a) Le mode privilégié donne accès à toutes les commandes du commutateur. De nombreuses commandes de ce mode
configurent les paramètres d’exploitation. Par conséquent, l’accès privilégié doit être protégé par mot de passe
pour empêcher une utilisation non autorisée. Parmi les commandes du mode privilégié, on retrouve celles du mode
utilisateur, ainsi que la commande configure qui donne accès aux autres modes de commande.
Switch>enable
Switch#
b) Notez que l’invite a changé dans la configuration pour représenter le mode privilégié.

ÉTAPE 2 : EXAMINEZ LA CONFIGURATION ACTUELLE DU COMMUTATEUR.

a) Examinez le fichier de configuration courante actuel :


Switch#show running-config
b) Combien d’interfaces Ethernet ou Fast Ethernet le commutateur comporte-t-il ?
c) Quelle est la plage de valeurs affichée pour les lignes VTY ?
d) Examinez le contenu actuel de la mémoire NVRAM :
Switch#show startup-config
%% Non-volatile configuration memory is not present
e) Pourquoi le commutateur donne-t-il cette réponse ?

ÉTAPE 3 : ATTRIBUEZ UN NOM AU COMMUTATEUR.

a) Entrez enable, puis le mode de configuration. Le mode de configuration permet de gérer le commutateur. Entrez
ALSwitch, le nom que portera ce commutateur par la suite:
Switch#configure terminal
Tapez les commandes de configuration (une par ligne). Terminez en appuyant sur Ctrl-Z.
Switch(config)#hostname ALSwitch
ALSwitch(config)#exit

27
IGA – 3ISI Matériels d’interconnexion

B) Notez que l’invite a changé dans la configuration pour refléter son nouveau nom. Tapez exit ou appuyez sur Ctrl-
Z pour repasser en mode privilégié.

ÉTAPE 4 : EXAMINEZ LA CONFIGURATION COURANTE ACTUELLE.

a) Examinez la configuration courante ci-aprés pour vérifier qu’il n’y a pas de configuration, à l’exception du nom
d’hôte :
ALSwitch#show running-config
b) Des mots de passe ont-ils été définis sur les lignes ?
c) Qu’indique la configuration pour ce qui concerne le nom d’hôte de ce commutateur ?

ÉTAPE 5 : DEFINISSEZ LES MOTS DE PASSE D’ACCES.

Passez en mode de configuration de ligne pour la console. Définissez sur cette ligne le mot de passe cisco pour la
connexion. Configurez les lignes VTY 0 à 15 avec le mot de passe cisco en procédant comme suit:
ALSwitch#configure terminal
Tapez les commandes de configuration (une par ligne). Terminez en appuyant sur Ctrl-Z.
ALSwitch(config)#line con 0
ALSwitch(config-line)#password cisco
ALSwitch(config-line)#login
ALSwitch(config-line)#line vty 0 15
ALSwitch(config-line)#password cisco
ALSwitch(config-line)#login
ALSwitch(config-line)#exit

ÉTAPE 6 : DEFINISSEZ LES MOTS DE PASSE DE MODE DE COMMANDE.

a) Définissez le mot de passe enable à cisco et le mot de passe enable secret à class en procédant comme suit:
ALSwitch(config)#enable password cisco
ALSwitch(config)#enable secret class
b) Quel mot de passe a préséance ? Le mot de passe enable ou le mot de passe enable
secret ?

ÉTAPE 7 : CONFIGUREZ L’ACCES DE COUCHE 3 AU COMMUTATEUR.

a) Définissez l’adresse IP du commutateur à 192.168.1.2 avec un masque de sous-réseau 255.255.255.0:


Remarque: Cela est réalisé sur l’interface VLAN 1 virtuelle interne.
ALSwitch(config)#interface VLAN 1
ALSwitch(config-if)#ip address 192.168.1.2 255.255.255.0
ALSwitch(config-if)#exit
o Définissez la passerelle par défaut du commutateur et le VLAN de gestion par défaut à 192.168.1.1 en
procédant comme suit :
ALSwitch(config)#ip default-gateway 192.168.1.1
ALSwitch(config)#exit

ÉTAPE 8 : VERIFIEZ LES PARAMETRES DES VLAN DE GESTION.

a) Vérifiez les paramètres d’interface sur le VLAN 1 :


ALSwitch#show interface VLAN 1
b) Quelle est la bande passante définie sur cette interface ?
c) Quels sont les états du VLAN : Le VLAN1 est, le protocole de ligne est
d) Activez l’interface virtuelle à l’aide de la commande no shutdown
ALSwitch(config)#interface VLAN 1
ALSwitch(config-if)#no shutdown
ALSwitch(config-if)#exit
e) Quelle est la stratégie de file d’attente en vigueur ?

28
IGA – 3ISI Matériels d’interconnexion

ÉTAPE 9 : ENREGISTREZ LA CONFIGURATION.

a) Vous venez d’achever la configuration de base du commutateur. Sauvegardez le fichier de la configuration


courante en mémoire NVRAM en procédant comme suit :

Remarque : Les modifications apportées seront ainsi conservées en cas de réamorçage du système ou de coupure de
courant.
ALSwitch#copy running-config startup-config
Destination filename [startup-config]?[Entrée]
Building configuration...
[OK]
ALSwitch#

ÉTAPE 10 : EXAMINEZ LE FICHIER DE CONFIGURATION DE DEMARRAGE.

a) Pour voir la configuration qui est stockée en mémoire NVRAM, tapez show startup-config en mode privilégié
(mode enable)
ALSwitch#show startup-config
b) Quelles sont les informations qui s’affichent ?
c) Quelles modifications ont été enregistrées dans le fichier ?

ÉTAPE 11 : QUITTEZ LE COMMUTATEUR.

Quittez l’écran de bienvenue du commutateur en tapant exit :


ALSwitch#exit
Après avoir réalisé les étapes précédentes, déconnectez-vous en tapant exit, puis mettez tous les équipements hors
tension.

29
IGA – 3ISI Matériels d’interconnexion

TP .11 : CONFIGURATION DE VLANS STATIQUES

OBJECTIFS.

• Créer une configuration de commutateur de base et la vérifier.


• Déterminer la version de firmware du commutateur.
• Créer deux VLAN, les nommer et leur affecter des ports membres.

MAQUETTE.

ÉTAPE 1 : CONFIGUREZ LE COMMUTATEUR.

Configurez le nom d'hôte, les mots de passe, ainsi que les paramètres de gestion du LAN. Ces valeurs sont illustrées dans le
tableau. En cas de problème lors de la réalisation de cette configuration, reportez vous au TP consacré à la configuration de
base d’un commutateur.

ÉTAPE 2 : CONFIGUREZ LES HOTES RELIES AU COMMUTATEUR.

Configurez l’hôte pour qu’il utilise le même sous-réseau pour l’adresse, le masque et la passerelle par défaut que sur le
commutateur.

ÉTAPE 3 : VERIFIEZ LA CONNECTIVITE.

a) Pour vérifier que l’hôte et le commutateur sont correctement configurés, envoyez une requête ping au
commutateur à partir de l’hôte.
b) La requête ping a-t-elle abouti ?
c) Si la réponse est non, dépannez les configurations de l’hôte et du commutateur.

ÉTAPE 4 : AFFICHEZ LA VERSION DE L’IOS.

a) Il est très important de connaître la version du système d’exploitation. En effet, selon la version, la façon d’entrer
les commandes peut être différente. Tapez la commande show version à l’invite du mode utilisateur ou du mode
privilégié:
Switch_A#show version
b) Quelle version de l’IOS du commutateur est affichée ?
c) Le commutateur fonctionne-t-il avec la version standard ou la version Entreprise du logiciel ?
d) Quelle est le firmware ou la version de l'IOS installée sur le commutateur?

30
IGA – 3ISI Matériels d’interconnexion

ÉTAPE 5 : AFFICHEZ LES INFORMATIONS D’INTERFACE VLAN.

a) Sur Switch_A, tapez la commande show vlan à l’invite du mode privilégié :


Switch_A#show vlan
b) Quels ports appartiennent au VLAN par défaut ?
c) Combien de VLAN sont configurés par défaut sur le commutateur?
d) Que représente le VLAN 1003 ?
e) Combien de ports comporte le VLAN 1003 ?

ÉTAPE 6 : CREEZ ET NOMMEZ DEUX VLAN.

Entrez les commandes suivantes pour créer et nommer deux VLAN:


Switch_A#vlan database
Switch_A(vlan)#vlan 2 name VLAN2
Switch_A(vlan)#vlan 3 name VLAN3
Switch_A(vlan)#exit

ÉTAPE 7 : AFFICHEZ LES INFORMATIONS D’INTERFACE VLAN.

a) Sur Switch_A, tapez la commande show vlan à l’invite du mode privilégié:


Switch_A#show vlan
b) Y a-t-il de nouveaux VLAN dans la liste ?
c) Des ports leur ont-ils déjà été attribués ?

ÉTAPE 8 : AFFECTEZ DES PORTS A VLAN 2.

L’affectation de ports aux VLAN doit être effectuée à partir du mode d’interface. Entrez les commandes suivantes pour
ajouter le port 2 au VLAN 2:
Switch_A#configure terminal
Switch_A(config)#interface fastethernet 0/2
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#switchport access vlan 2
Switch_A(config-if)#end

ÉTAPE 9 : AFFICHEZ LES INFORMATIONS D’INTERFACE VLAN.

a) Sur Switch_A, tapez la commande show vlan à l’invite du mode privilégié :


Switch_A#show vlan
b) Le port 2 est-il affecté au VLAN 2 ?
c) Le port figure-t-il encore dans le VLAN par défaut ?

ÉTAPE 10 : AFFECTEZ UN PORT AU VLAN 3.

L’affectation de ports aux VLAN doit être effectuée à partir du mode d’interface. Entrez les commandes suivantes pour
ajouter le port 3 au VLAN 3:
Switch_A#configure terminal
Switch_A(config)#interface fastethernet 0/3
Switch_A(config-if)#switchport mode access
Switch_A(config-if)#switchport access vlan 3
Switch_A(config-if)#end

ÉTAPE 11 : EXAMINEZ LES INFORMATIONS D’INTERFACE VLAN.

Sur Switch_A, tapez la commande show vlan à l’invite du mode privilégié :


Switch_A#show vlan
1900:
Switch_A#show vlan-membership
b. Le port 3 est-il affecté au VLAN 3 ?
31
IGA – 3ISI Matériels d’interconnexion

c. Le port figure-t-il encore dans le VLAN par défaut ?

ÉTAPE 12 : EXAMINEZ UNIQUEMENT LES INFORMATIONS DU VLAN 2.

a. Plutôt que d’afficher tous les VLAN, tapez la commande show vlan id 2 à l’invite du mode privilégié:
Switch_A#show vlan id 2
1900:
Switch_A#show vlan 2
b. Cette commande fournit-elle plus d’informations que la commande show VLAN ?

ÉTAPE 13 : EXAMINEZ UNIQUEMENT LES INFORMATIONS SUR VLAN 2 A L’AIDE D’UNE COMMANDE
DIFFERENTE (1900 : IGNOREZ CETTE ETAPE).

a. Plutôt que d’afficher tous les VLAN, tapez la commande show vlan name VLAN2 à l’invite du mode privilégié:
Switch_A#show vlan name VLAN2

b. Cette commande fournit-elle plus d’informations que la commande show VLAN ?


Après avoir réalisé les étapes précédentes, déconnectez-vous en tapant exit, puis mettez tous les équipements hors tension.
Retirez et rangez les câbles et l’adaptateur.

Effacement et rechargement du commutateur

Pour la plupart des TP de CCNA 3 et CCNA 4, il est nécessaire de commencer avec un commutateur non configuré.
L’utilisation d’un commutateur comportant déjà une configuration peut produire des résultats imprévisibles. Ces
instructions permettent de préparer le commutateur avant d’effectuer le TP pour que les options de configuration
précédentes ne créent pas d’interférence.

Vous trouverez ci-après la procédure permettant d’effacer des configurations précédentes et de démarrer avec un
commutateur non configuré. Ces instructions sont fournies pour les commutateurs de la gamme 2900, 2950 et 1900.

Commutateurs de la gamme 2900 et 2950

1. Passez en mode privilégié à l’aide de la commande enable.

Si le système vous demande un mot de passe, entrez class (si cela ne fonctionne pas, demandez de l’aide au professeur).
Switch>enable

2. Supprimez le fichier d’informations de la base de données VLAN.

Switch#delete flash:vlan.dat
Delete filename [vlan.dat]?[Entrée]
Delete flash:vlan.dat? [confirm] [Entrée]
S’il n’y a pas de fichier VLAN, le message suivant s’affiche.
%Error deleting flash:vlan.dat (No such file or directory)

3. Supprimez le fichier de configuration de démarrage du commutateur de la mémoire NVRAM.

Switch#erase startup-config
Vous obtenez le message suivant :
Erasing the nvram filesystem will remove all files! Continue? [confirm]
Appuyez sur Entrée pour confirmer.
La réponse suivante devrait s’afficher :
Erase of nvram: complete

4. Vérifiez que les informations VLAN ont été supprimées.

32
IGA – 3ISI Matériels d’interconnexion

Vérifiez que la configuration VLAN a été supprimée à l’étape 2 à l’aide de la commande show vlan. Si les informations de
la configuration VLAN précédente (autre que celles du VLAN de gestion 1 par défaut) sont toujours présentes, il sera
nécessaire de mettre hors tension puis sous tension le commutateur (redémarrage matériel) plutôt que d’entrer la commande
reload.

Pour le redémarrage matériel du commutateur, ôtez le cordon d’alimentation de l’arrière du commutateur ou débranchez-le.
Ensuite, rebranchez-le.

Si les informations relatives au VLAN ont été supprimées à l’étape 2, passez à l’étape 5 et redémarrez le commutateur à
l’aide de la commande reload.

5. Redémarrage logiciel (à l’aide de la commande reload)

Remarque: Cette étape n’est pas nécessaire si le commutateur a été redémarré à l’aide du démarrage matériel.

a. En mode privilégié, entrez la commande reload.


Switch#reload
Vous obtenez le message suivant :
System configuration has been modified. Save? [yes/no]:

b. Tapez n, puis appuyez sur Entrée.


Vous obtenez le message suivant :
Proceed with reload? [confirm] [Entrée]
La première ligne de la réponse est la suivante:
Reload requested by console.
Après le rechargement du commutateur, la ligne suivante s’affiche:
Would you like to enter the initial configuration dialog? [yes/no]:

c. Tapez n, puis appuyez sur Entrée.


Vous obtenez le message suivant :
Press RETURN to get started! [Entrée]

Commutateurs de la gamme 1900

1. Supprimez les informations VTP (VLAN Trunking Protocol).


#delete vtp
Cette commande réintroduit dans le commutateur les paramètres VTP par défaut définis en usine.
Tous les autres paramètres restent inchangés.
Reset system with VTP parameters set to factory defaults, [Y]es or [N]o?
Tapez y et appuyez sur Entrée.

2. Supprimez le fichier de configuration de démarrage du commutateur de la mémoire NVRAM.


#delete nvram
This command resets the switch with factory defaults. All system parameters will revert to their default factory settings. All
static and dynamic addresses will be removed.
Reset system with factory defaults, [Y]es or [N]o?
Tapez y et appuyez sur Entrée.

33
IGA – 3ISI Matériels d’interconnexion

TP .12 : ROUTAGE DE BASE ENTRE RESEAUX LOCAUX VIRTUELS

OBJECTIFS

• Effectuer des configurations de base sur les commutateurs


• Configurer les interfaces Ethernet sur les ordinateurs hôtes
• Configurer le protocole VTP sur les commutateurs
• Configurer le routeur et le serveur distant de réseau local

DIAGRAMME DE LA TOPOLOGIE

TABLE D’ADRESSAGE

Masque de sous- Passerelle par


Périphérique Interface Adresse IP
réseau défaut
Comm1 VLAN 99 172.17.99.11 255.255.255.0 172.17.99.1
Comm2 VLAN 99 172.17.99.12 255.255.255.0 172.17.99.1
Comm3 VLAN 99 172.17.99.13 255.255.255.0 172.17.99.1
Fa0/0 Voir la table de configuration d’interface N/D
R1
Fa0/1 172.17.50.1 255.255.255.0 N/D
PC1 Carte réseau 172.17.10.21 255.255.255.0 172.17.10.1
PC2 Carte réseau 172.17.20.22 255.255.255.0 172.17.20.1
PC3 Carte réseau 172.17.30.23 255.255.255.0 172.17.30.1
Serveur Carte réseau 172.17.50.254 255.255.255.0 172.17.50.1

34
IGA – 3ISI Matériels d’interconnexion

AFFECTATIONS DE PORTS - COMM2

Ports Affectation Réseau


Fa0/1 - 0/5 Agrégations 802.1q (Natif VLAN 99) 172.17.99.0 /24
Fa0/6 - 0/10 VLAN 30 – Invité(par défaut) 172.17.30.0 /24
Fa0/11 - 0/17 VLAN 10 – Faculté/Personnel 172.17.10.0 /24
Fa0/18 - 0/24 VLAN 20 - Participants 172.17.20.0 /24

TABLE DE CONFIGURATION DE SOUS-INTERFACE : R1

Interface Affectation Adresse IP


Fa0/0.1 VLAN 1 172.17.1.1 /24
Fa0/0.10 VLAN 10 172.17.10.1 /24
Fa0/0.20 VLAN 20 172.17.20.1 /24
Fa0/0.30 VLAN 30 172.17.30.1 /24
Fa0/0.99 VLAN 99 172.17.99.1 /24

TACHE 1 : EXECUTION DES CONFIGURATIONS DE BASE SUR LES COMMUTATEURS

Configurez les commutateurs Comm1, Comm2 et Comm3 en fonction de la table d’adressage et des instructions suivantes :
• Configurez le nom d’hôte du commutateur.
• Désactivez la recherche DNS.
• Configurez la passerelle par défaut.
• Configurez un mot de passe class pour le mode d’exécution.
• Configurez un mot de passe cisco pour les connexions de consoles.
• Configurez un mot de passe cisco pour les connexions vty.
• Configurez la passerelle par défaut sur chaque commutateur.

Switch>enable
Switch#config term
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Comm1
Comm1(config)#enable secret class
Comm1(config)#no ip domain-lookup
Comm1(config)#ip default-gateway 172.17.99.1
Comm1(config)#line console 0
Comm1(config-line)#password cisco
Comm1(config-line)#login
Comm1(config-line)#line vty 0 15
Comm1(config-line)#password cisco
Comm1(config-line)#login
Comm1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
Comm1#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...

35
IGA – 3ISI Matériels d’interconnexion

TACHE .2 : CONFIGURATION DES INTERFACES ETHERNET SUR LES ORDINATEURS HOTES

Configurez les interfaces Ethernet de PC1, PC2 et PC3 avec les adresses IP de la table d’adressage.

TACHE 3 : CONFIGURATION DU PROTOCOLE VTP SUR LES COMMUTATEURS

ÉTAPE 1 : ACTIVATION DES PORTS UTILISATEUR SUR COMM2 EN MODE D’ACCES

Comm2(config)#interface fa0/6
Comm2(config-if)#switchport mode access
Comm2(config-if)#no shutdown
Comm2(config-if)#interface fa0/11
Comm2(config-if)#switchport mode access
Comm2(config-if)#no shutdown
Comm2(config-if)#interface fa0/18
Comm2(config-if)#switchport mode access
Comm2(config-if)#no shutdown

ÉTAPE 2 : CONFIGURATION DU PROTOCOLE VTP

Configurez le protocole VTP sur ces trois commutateurs en utilisant le tableau suivant. Rappelez-vous que les noms de
domaine et mots de passe VTP sont sensibles à la casse.

Nom du Mode de fonctionnement Mot de


Domaine VTP
commutateur VTP passe VTP
Comm1 Server Lab5 cisco
Comm2 Client Lab5 cisco
Comm3 Client Lab5 cisco

Comm1(config)#vtp mode server


Device mode already VTP SERVER.
Comm1(config)#vtp domain Lab6
Changing VTP domain name from NULL to Lab6
Comm1(config)#vtp password cisco
Setting device VLAN database password to cisco
Comm1(config)#end

Comm2(config)#vtp mode client


Setting device to VTP CLIENT mode
Comm2(config)#vtp domain Lab6
Changing VTP domain name from NULL to Lab6
Comm2(config)#vtp password cisco
Setting device VLAN database password to cisco
Comm2(config)#end

Comm3(config)#vtp mode client


Setting device to VTP CLIENT mode
Comm3(config)#vtp domain Lab6
Changing VTP domain name from NULL to Lab6
Comm3(config)#vtp password cisco
Setting device VLAN database password to cisco
Comm3(config)#end

36
IGA – 3ISI Matériels d’interconnexion

ÉTAPE 3 : CONFIGURATION DES PORTS D’AGREGATION ET DESIGNATION DU RESEAU LOCAL


VIRTUEL NATIF POUR LES AGREGATIONS

Configurez Fa0/1 à Fa0/5 en tant que ports d’agrégation, et désignez VLAN 99 comme étant le réseau local virtuel pour ces
agrégations. Ces ports ont été désactivés au début de cet exercice. Ils doivent maintenant être réactivés à l’aide de la
commande no shutdown.
Seules les commandes pour l’interface FastEthernet0/1 de chaque commutateur sont affichées, même si les commandes
doivent être appliquées jusqu’à l’interface FastEthernet0/5.
Comm1(config)#interface fa0/1
Comm1(config-if)#switchport mode trunk
Comm1(config-if)#switchport trunk native vlan 99
Comm1(config-if)#no shutdown
Comm1(config)#end

Comm2(config)#interface fa0/1
Comm2(config-if)#switchport mode trunk
Comm2(config-if)#switchport trunk native vlan 99
Comm2(config-if)#no shutdown
Comm2(config-if)#end

Comm3(config)#interface fa0/1
Comm3(config-if#switchport mode trunk
Comm3(config-if)#switchport trunk native vlan 99
Comm3(config-if)#no shutdown
Comm3(config-if-#end

ÉTAPE 4 : CONFIGURATION DU SERVEUR VTP AVEC LES RESEAUX LOCAUX VIRTUELS

Configurez les réseaux locaux virtuels suivants sur le serveur VTP :

Nom du réseau local


Réseau local virtuel
virtuel
VLAN 99 gestion
VLAN 10 faculté-personnel
VLAN 20 participants
VLAN 30 invité

Comm1(config)#vlan 99
Comm1(config-vlan)#name gestion
Comm1(config)#vlan 10
Comm1(config-vlan)#name faculté-personnel
Comm1(config)#vlan 20
Comm1(config-vlan)#name participants
Comm1(config)#vlan 30
Comm1(config-vlan)#name invité
Comm1(config-vlan)#end

Vérifiez que les réseaux locaux virtuels ont été créés sur Comm1 avec la commande show vlan brief.

37
IGA – 3ISI Matériels d’interconnexion

ÉTAPE 5 : VERIFICATION QUE LES RESEAUX LOCAUX VIRTUELS CREES SUR COMM1 ONT ETE
DISTRIBUES SUR COMM2 ET COMM3

Servez-vous de la commande show vlan brief sur Comm2 et Comm3 pour vérifier que les quatre réseaux locaux virtuels
ont tous été transmis aux commutateurs clients.
Comm2#show vlan brief

Comm3#show vlan brief

ÉTAPE 6 : CONFIGURATION DE L’ADRESSE DE L’INTERFACE DE GESTION SUR LES TROIS


COMMUTATEURS

Comm1(config)#interface vlan99
Comm1(config-if)#ip address 172.17.99.11 255.255.255.0

Comm2(config)#interface vlan99
Comm2(config-if)#ip address 172.17.99.12 255.255.255.0

Comm3(config)#interface vlan99
Comm3(config-if)#ip address 172.17.99.13 255.255.255.0

Vérifiez que les commutateurs sont configurés correctement en envoyant des requêtes ping entre eux. À partir de Comm1,
envoyez une requête ping sur l’interface de gestion de Comm2 et Comm3. À partir de Comm2, envoyez une requête ping
sur l’interface de gestion de Comm3.
Les requêtes ping ont-elles abouti ? ______________________
Si ce n’est pas le cas, dépannez les configurations des commutateurs et recommencez.

ÉTAPE 7 : AFFECTATION DES PORTS DES COMMUTATEURS AUX RESEAUX LOCAUX VIRTUELS SUR
COMM2

Les affectations de ports sont énumérées dans le tableau au début de l’exercice.


Comm2(config)#interface fa0/6
Comm2(config-if)#switchport access vlan 30
Comm2(config-if)#interface fa0/11
Comm2(config-if)#switchport access vlan 10
Comm2(config-if)#interface fa0/18
Comm2(config-if)#switchport access vlan 20
Comm2(config-if)#end
Comm2#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]
Comm2#

ÉTAPE 8 : VERIFICATION DE LA CONNECTIVITE ENTRE RESEAUX LOCAUX VIRTUELS

Ouvrez l’invite de commande sur les trois ordinateurs.


• Envoyez une requête ping entre PC1 et PC2 (172.17.20.22)
• Envoyez une requête ping entre PC2 et PC3 (172.17.30.23)
• Envoyez une requête ping entre PC3 et PC1 (172.17.30.21)
Les requêtes ping ont-elles abouti ? ______________
Sinon, pourquoi ont-elles échoué ?

38
IGA – 3ISI Matériels d’interconnexion

TACHE 4 : CONFIGURATION DU ROUTEUR ET DU SERVEUR DISTANT DE RESEAU LOCAL

ÉTAPE 1 : CREATION D’UNE CONFIGURATION DE BASE SUR LE ROUTEUR

• Configurez le routeur avec le nom d’hôte R1.


• Désactivez la recherche DNS.
• Configurez un mot de passe class pour le mode d’exécution.
• Configurez un mot de passe cisco pour les connexions de consoles.
• Configurez un mot de passe cisco pour les connexions vty.

ÉTAPE 2 : CONFIGURATION DE L’INTERFACE D’AGREGATION SUR R1

Vous venez de démontrer que la connectivité entre réseaux locaux virtuels nécessite un routage sur la couche réseau,
exactement comme la connectivité entre deux réseaux distants. Il existe plusieurs options pour la configuration du routage
entre réseaux locaux virtuels.

La première ressemble à une approche en force. Un périphérique de couche 3, tel qu’un routeur ou un commutateur
compatible couche 3, est connecté à un commutateur de réseau local par le biais de plusieurs connexions, à savoir une
connexion distincte pour chaque réseau local virtuel nécessitant une connectivité entre réseaux locaux virtuels.

Chaque port du commutateur utilisé par le périphérique de couche 3 est configuré dans un réseau local virtuel différent sur
le commutateur. Une fois que les adresses IP sont affectées aux interfaces du périphérique de couche 3, la table de routage
dispose de routes connectées directement pour tous les réseaux locaux virtuels, et le routage entre réseaux locaux virtuels
est activé. Cette approche comporte des limites : nombre de ports Fast Ethernet insuffisant sur les routeurs, sous-utilisation
des ports sur les commutateurs de couche 3 et les routeurs, câblage excessif et configuration manuelle. La topologie utilisée
dans cet exercice n’utilise pas cette approche.

Une autre approche consiste à créer une ou plusieurs connexions Fast Ethernet entre le périphérique de couche 3 (le
routeur) et le commutateur de couche distribution, et de configurer ces connexions en tant qu’agrégations dot1q. Cela
permet d’acheminer le trafic entre réseaux locaux virtuels depuis et vers le périphérique de routage sur une seule
agrégation. Toutefois, cela nécessite que l’interface de couche 3 soit configurée avec plusieurs adresses IP. Pour cela, il
suffit de créer des interfaces virtuelles, appelées sous-interfaces, sur l’un des ports Fast Ethernet du routeur, et de les
configurer pour qu’elles soient compatibles dot1q.

Les étapes suivantes sont nécessaires pour utiliser l’approche de configuration par sous-interface :

• Passez en mode de configuration de sous-interface


• Activez l’encapsulation d’agrégation
• Associez un réseau local virtuel à la sous-interface
• Attribuez une adresse IP du réseau local virtuel à la sous-interface
Les commandes sont les suivantes :

R1(config)#interface fastethernet 0/0


R1(config-if)#no shutdown
R1(config-if)#interface fastethernet 0/0.1
R1(config-subif)#encapsulation dot1q 1
R1(config-subif)#ip address 172.17.1.1 255.255.255.0
R1(config-subif)#interface fastethernet 0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 172.17.10.1 255.255.255.0
R1(config-subif)#interface fastethernet 0/0.20
R1(config-subif)#encapsulation dot1q 20
R1(config-subif)#ip address 172.17.20.1 255.255.255.0
R1(config-subif)#interface fastethernet 0/0.30
R1(config-subif)#encapsulation dot1q 30
R1(config-subif)#ip address 172.17.30.1 255.255.255.0

39
IGA – 3ISI Matériels d’interconnexion

R1(config-subif)#interface fastethernet 0/0.99


R1(config-subif)#encapsulation dot1q 99 native
R1(config-subif)#ip address 172.17.99.1 255.255.255.0

Notez les points suivants de cette configuration :

• L’interface physique est activée à l’aide de la commande no shutdown, car les interfaces du routeur sont
désactivées par défaut. La sous-interface est donc activée par défaut.
• La sous-interface peut être représentée par n’importe quel nombre respectant la règle des 32 bits, même s’il est
recommandé d’affecter le numéro du réseau local virtuel comme numéro d’interface, comme cela a été démontré
dans l’exercice.
• Le réseau local virtuel est spécifié sur le périphérique de couche 3 afin qu’il soit cohérent avec les commutateurs.
Autrement, VLAN 1 est le réseau local virtuel natif par défaut, et aucune communication ne se fait entre le routeur
et le réseau local virtuel de gestion sur les commutateurs.

ÉTAPE 3 : CONFIGURATION DE L’INTERFACE DU SERVEUR DE RESEAU LOCAL SUR R1

R1(config)#interface FastEthernet0/1
R1(config-if)#ip address 172.17.50.1 255.255.255.0
R1(config-if)#description server interface
R1(config-if)#no shutdown
R1(config-if)#end

Six réseaux sont désormais configurés. Vérifiez que vous pouvez acheminer des paquets sur les six en contrôlant la table de
routage sur R1.
R1#show ip route
Si votre table de routage n’affiche pas les six réseaux, corrigez votre configuration et résolvez le problème avant de
continuer.

ÉTAPE 4 : VERIFICATION DU ROUTAGE ENTRE RESEAUX LOCAUX VIRTUELS

À partir de PC1, vérifiez que vous pouvez envoyer des requêtes ping sur le serveur distant (172.17.50.254) et les deux
autres hôtes (172.17.20.22 et 172.17.30.23). Plusieurs requêtes ping seront probablement nécessaires avant que le chemin
de bout en bout ne soit établi.
Ces requêtes ping doivent réussir. Sinon, corrigez votre configuration. Assurez-vous que les passerelles par défaut ont été
définies sur tous les ordinateurs et commutateurs.

TACHE 5 : REMARQUES GENERALES

Dans la tâche 4, vous avez configuré VLAN 99 en tant que réseau local virtuel natif dans la configuration d’interface
Fa0/0.99 du routeur. Pourquoi les paquets provenant du routeur ou des hôtes ont-ils échoué en tentant d’atteindre les
interfaces de gestion du commutateur si le réseau local virtuel natif était laissé par défaut ?

40

Vous aimerez peut-être aussi