Vous êtes sur la page 1sur 34

CCNA 4

Protocole PPP (Point To Point Protocole) : est un protocole de transmission couche 2


modèles OSI Encapsulation ‫التغليف‬

• Base sur HDLC Cisco

Avantage : - Authentification (username + passwor)


PPP peut prendre en plusieurs de d’authentification
• Aucune authentification
• Utilisation de protocole PAP
• Utilisation du protocole CHAP

PPP avec l’authentification PAP :

R1 (config) # username R2 password 123456

R1 (config) # interface s0/0/0

R1 (config-if) # encapsulation ppp

R1 (config-if) # ppp authentification

R1 (config-if) # ppp pap sent-username R1 password 1


R2 (config) # username R1 password 123456

R2 (config) # interface s0/0/0

R2 (config-if) # encapsulation ppp

R2 (config-if) # ppp authentification dent username R2 password 123456

PPP avec l’authentification CHAP


R1 (config) # username R2 password 123456

R1 (config) # interface s0/0/0

R1 (config-if) # encapsulation ppp

R1 (config-if) # ppp authentification chap

R2 (config) # username R1 passord 123456

R2 (config) # interface s0/0/0

R2 (config-if) # encapsulation ppp

R2 (config-if) # ppp authentification chap

PPP avec PAP CHAP


R1 (config- # username R2 password 123456

R1 (config) # interface s0/0/0

R1 (config-if) # encapsulation ppp

R1 (config-if) # ppp authentification pap chap

R1 (config-if) # ppp pap sent-username R1 password 123456

R2 (config) # username R1 password 123456

R2 (config) # interface s0/0/0

R2 (config) # encapsulation ppp

R2 (config-if) # ppp authentification pap chap

R2 (config-if) # ppp pap sent-username R2 password 123456


FRAME RELAY
Frame relay : c’est une technologie utilise un circuit virtuel
➢ en basé un nuage (équipement de la couche 1 ou la couche 2)
➢ encapsulation HDLC (n’es pas changés)

Frame relay n’est pas adresse MAC

SVC (Switched Virtual Circuit) = une fois la connexion terminé entre les deux routeurs les
circuit pas rester

PVC (Permanent Virtual Circuit) = Rester en permanence signifie jusqu'à ce que ça se


termine connexion entre les deux routeurs
ARP inverse = Reverse ARP = RARP (Reverse Adresse Résolution Protocole) = Recherche de @ IP

ARP (Adresse Résolution Protocole) = Recherche de @ MAC

DLCI « Data Link Connexion Identifier »

Les types de mappage :


Statique : utilise l’interface réelle (physique)
(# frame-relay map ip @ « dlci » broadcaste
Dynamique : on utilise des sous-interfaces et des interfaces virtuelles
(# frame-relay interface-dlci « dlci »
Les types de topologie frame relay :
Hub and spoke :
Maillage global : Chaque extrémité est reliée par l’intermédiaire d’un PVC distinct vers
chaque autre destination

Maillage partiel : Egalement appelé topologie en étoile ou "hub-and-spokes". Chaque


extrémité n’est pas reliée à toutes les autres.

Frame relay Point to Point : en utilise une adresse réseau pour chaque « PVC »
PVC (Permanent Virtual Circuit) :

➢ en basé les sous-interface


➢ utilise DLCI (Data Link Connection Identifier)

PRATIQUE : Frame relay point to point


Remarque : diviser l'interface physique pour le routeur principale (hub) les deux
sous-interfaces logique il va deux routeur Contre eux (‫)مقابل معهم‬

+ nous entrons (‫ )ندخل‬l’interface de la Hub


R1 (config) # int s2/0
R1 (config-if) # encapsulation frame-relay
R1 (config-if) # no shutdown

+ nous entrons (‫ )ندخل‬sous-interface 1 er


R1 (config) int s2/0.102 point-to-point
R1 (config-subif) # ip add 10.0.0.1 255.255.255.252
R1 (config-subif) # frame-relay interface-dlci 102

+ nous entrons (‫ )ندخل‬sous interface 2 éme :


R1 (config) # int s2/0.103 point-to-point
R1 (config-subif) # ip add 10.0.0.5 255.255.255.252
R1 (config-subif) # frame-relay interface-dlci 103

+ nous entrons (‫ )ندخل‬l’interface physique


R1 (config) # int s2/0
R1 (config-if) # ip ospf network broadcast (wla ip ospf network point-to-point)

+ nous entrons (‫ )ندخل‬sous-interface 1er


R1 (config) # int s2/0.102
R1 (config-if) # ip ospf network broadcast (wla ip ospf network point-to-point)

+ nous entrons (‫ )ندخل‬sous interface tanya


R1 (config) # int s2/0.103
R1 (config-if) # ip ospf network broadcast (wla ip ospf network point-to-point)

+ Routage ospf :
R1 (config) # router ospf 10
R1 (config-router) # network 212.16.16.0 0.0.0.3 area 0
R1 (config-router) # network 212.16.16.8 0.0.0.3 area 0
R1 (config-router) # network 192.168.2.0 0.0.0.255 area 0

PRATIQUE : Frame relay point to point avec


EIGRP
+ Routage Eigrp:
>> router eigrp 10
>> eigrp router-id 1.1.1.1
>> no auto-sammary
>> network 10……
>> network 192.168………

+ We gonna do same things b nisba les routeurs lakhrin (


spokes ) rir howa bla mandakhlo lchi sous interfaces ! means
kankhadmo f interface physique 3adi

Frame relay Point to Multipoint =


Multipoint : mappage dynamique
Dynamique : on utilise des sous-interfaces et des interfaces virtuelles
R1 (config-if) # frame relay interface-dlci « dlci »

PRATIQUE : Frame relay Multipoint avec


mappage static
Remarque : mappage static we use interface real or we can say
physique and we have only one adresse f topolgy kanfar9oha !

+ Ndakhlo l’interface physique


>> int s2/0 ( Multipoint )
>> ip add 212.16.16.1 255.255.255.248
>> no shutdown
>> encapsulation frame-relay
>> (no frame-relay inverse-arp )
>> frame-relay map ip 212.16.16.2 102 broadcast ( interface dyale
router li baghi nwsal lih and dlci dyali li ghaydini )
>> frame-relay map ip 212.16.16.3 103 broadcast
>> Exit

+ Routage ospf :
Remarque : Pour utilise neighbor on ipv4 ospf
>> R1(config-router)# neighbor 10.1.1.2
---------------------------------------------------------------------------
--------
>> router ospf 10
>> network 212.16.16.0 0.0.0.7 area 0
>> network 192.168.1.0 0.0.0.255 area 0
>> int s2/0
>> ip ospf network broadcast

PRATIQUE : Frame relay Multipoint avec


Mappage Dynamic
Remarque : We must creat one sous interface and we gonna have only
one adresse on topology to use !

+ Sur router R1 :
>> int s2/0
>> no sh
>> encapsulation frame-relay
>> int s2/0.100 multipoint ( dik 100 mn rasek )
>> no sh
>> frame-relay interface-dlci 102
>> frame-relay interface-dlci 103
>> ip add 212.16.16.1 255.255.255.248
>> no sh
+ Routage ospf :
>> router ospf 10
>> network 212.16.16.0 0.0.0.7 area 0
>> network 192.168.1.0 0.0.0.255 area 0
>> int s2/0
>> ip ospf network broadcast
>> int s2/0.100
>> ip ospf network broadcast

+ Sur router R2:


>> int s2/0
>> no sh
>> encapsulation frame-relay
>> int s2/0.200 multipoint ( dik 200 mn rasek )
>> no sh
>> frame-relay interface-dlci 201
>> frame-relay interface-dlci 302
>> ip add 212.16.16.2 255.255.255.248
>> no sh
>> router ospf 10
>> network 212.16.16.0 0.0.0.7 area 0
>> network 192.168.2.0 0.0.0.255 area 0
>> int s2/0
>> ip ospf network broadcast
>> int s2/0.200
>> ip ospf network broadcast

PRATIQUE : Frame relay Multipoint Ipv6


Ospfv3
Remarque 1 : Il faut donner à chaque routeur une adresse de lien locale
différente des autres et nécessaire! Nous utilisons une adresse sur la
topologie!

Remarque 2 : +F point to point imposible ndiro mappage static


+ F ipv6 multipoint Darori always mappage static !
+ F point to point darori mappage dynamic !
>> Btw we are working on topolgy hub and spokes :

+ Sur router R1 :
>> int s0/0/0
>> encapsulation frame-relay
>> ipv6 add 2001:A::1/64
>> ipv6 add fe80::1 link-local
>> no sh
>> frame-relay map ipv6 2001:A::2 102
>> frame-relay map ipv6 2001:A::3 103
>> >> frame-relay map ipv6 fe80::2 102 broadcast
>> >> frame-relay map ipv6 fe80::3 103 broadcast
>>> if) ipv6 ospf network broadcast
>>> if) ipv6 ospf neighbor fe80::2
>>> if) ipv6 ospf neighbor fe80::3

+ Routage ospfv3
Remarque : if we have hub and spoke topology it’s better to give the hub the
highiest id bach ykoun DR hit howa centre
>> ipv6 router ospf 10
>> router-id 5.5.5.5
>> int s0/0/0
>> ipv6 ospf 10 area 0
>> int f0/0
>> ipv6 ospf 10 area 0
+ Sur router R2 :
>> int s0/0/0
>> encapsulation frame-relay
>> ipv6 add 2001:A::2/64
>> ipv6 add fe80::2 link-local
>> no sh
>> frame-relay map ipv6 2001:A::1 201
>> frame-relay map ipv6 fe80::1 201 broadcast
>>> ipv6 ospf network broadcast
>>> ipv6 ospf neighbor fe80::1

+ Routage ospf v3
>> ipv6 router ospf 10
>> router-id 2.2.2.2
>> int s0/0/0
>> ipv6 ospf 10 area 0
>> int f0/0
>> ipv6 ospf 10 area 0
-------------------------------------------------------------------------------

Attention : + Parfois, il est nécessaire de créer le hub ou nous pouvons


dire centrer router howa DR hit howa li kaydozo elih kolchi: ntal3o lih priority
wla na3tiwh akbar ID

+ ip split horizon : on n'en parle pas dans ospf car ospf est
un protocole état de lien! et split horizon est une solution pour les boucles de
routage dans les protocoles vecteur à distance comme RIP,EIGRP
PRATIQUE : Frame relay Point to point Ipv6
EIGRP
>> int s0/0/0.103 point-to-point
>> ipv6 add 2001 :db8 :acad :2 ::1/64
>> ipv6 eigrp 1

Ajouter neighbor dans frame relay EIGRP Ipv6


>> Ipv6 router eigrp 1
>> eigrp router-id 1.1.1.1
>> neighbor fe80 ::2 serial0/1/0

Ajouter neighbor dans frame relay EIGRP Ipv4


>> router eigrp 1
>> >>Neighbor 12.1.1.2 s0/0/0

Ajouter neighbor dans frame relay ospf Ipv6


>> Int s2/0
>> ipv6 ospf neighbor fe80::2

Configuration frame relay ( cloud )


+ Mn ba3d masalina les routeurs ! ghandozo ldik s7aba db
➢ Kandakhlo lkola interface dyale s7aba
➢ Kan ajoutiw les dlci w kangolo kola dlci fin kaydi et mnin
➢ N9adro l9aw interface frame fiha deux dlci bhal interface li katchof f
lhub….hit fih deux sous interfaces alors deux dlci !
➢ « Frame relay » kandakhlo liha f lakhar mnin nsaliw les interfaces dyale
frame !!
➢ Kanrabto bin les serials li kaysifto w les serial li kayjawbo
+ Hadok les deux routeurs ( spokes ) li mabinathomch wahd circuit
maymkanch yhadro binathomsh…khase mappage static
>> fes # int s2/0
>> fes # frame-relay map ip { adresse li baghi twsal liha } { dlci dyalk }
+ puis on a besoin de configurer ospf normal network etc….
+ Even if we finished all normal configurations of ospf Ping sa march pas car
on a besoin un autre special commande :
➢ Ndakhlo l interface physique dyale tout les routeurs w ndiro had
commande :
➢ If# ip ospf network point-to-point

Remarque :
+ Ida ma5demch lik OSPF m3a Frame Relay Ajouter les voisins d'OSPF
manuellement
+ Howa f lowal will tell u wach multipoint wla point to point and ymkan lik ta3raf
aussi rasek ela hsab chhal mn adresse 7atin lik f topology

+ La question dyale mappage static wla dynamic !


>> Multipoint Static : kankhadmo b des interfaces physique
we should inter the interface physique of the router and tap the
command frame-relay ip map…. Kan ajoutiw hadok les réseau li
b3ad w mansawch « Broadcast » f lakhar dyale command
>> Multipoint Dynamic : des sous interfaces wla ymkan
ygolik des interfaces virtual ..we should inter the sous interface
of the router and use the command
#frame-relay interface-dlci 102
#frame-relay interface-dlci 103
Service NAT [NATET PAT]
Réseau locale : utilise de plage des adresse ip privé (n’est pas utilisé internet
Internet : utilise des adresse ip public [(WAN) utilise @ ip public]
NAT ET PAT : la translation d’adresse est un processus générique permettant la
substitution d’une adresse par une autre, et permet ainsi de masquer les adresses privés des
réseaux locaux derrière une adresse publique

Les plages des @ ip privés : nous retable sur internet et (non utilisant internet)
10.0.0.1 10.255.255.254 /8
172.16.0.1 172.31.255.254 /12
192.168.0.1 192.168.255.254 /16

Ce processus existe sous deux variantes NAT et PAT :


NAT (Network Addresss translation) : Transfer les @ ip privés vers @ip publique au
niveau internet
NAT 2 types
• NAT Statique : translate une adresse IP privé avec toujours la même adresse IP publique
globale
• NAT Dynamique : translate une/des adresse IP privés avec adresse IP publique
appartenant à une plage adresse IP publique
PAT (Port Address Translation) : permit à plusieurs adresse IP privé de se
connectés en même temps en utilisant le numéro de ports pour distinguer leur
messages

➢ Différence entre NAT et PAT


>> NAT : + Traduit l’adresse IP privée à l’adresse IP publique.

+ NAT statique et NAT dynamique


+ Chaque machine besoin une adresse public

>> PAT : + il traduit également les adresses IP privées d’un réseau interne à
l’adresse IP publique à l’aide de numéros de port.
+ Traduction du seul adresse ou bien plage
+ Plusieurs hôtes peuvent utiliser la même adresse IP avec des numéros de
port différents.
+ PAT est une forme de NAT dynamique

Configuration avec NAT Statique

Configuration sur R0 :
@ip local interne @ip globale interne

R0 (config) # ip nat inside source static 192.168.1.1 212.12.12.1


R0 (config) # inerface g0/0
R0 (config-if) # ip nat inside
R0 (config-if) # exit
R0 (config) # int s0/0/0
R0 (config-if) # ip nat outside
R0 # show ip nat translations

Configuration avec NAT Dynamique

NAT dynamique => utilise ACL


R2 (config) # ip nat pool TEST [nom de la plage] 212.12.12.1 [1er de l@ ip de la plage]
212.12.12.8 [dernier @ ip de plage netmask] 255.55.255.240 [Masque]
R2 (config) # access-list 1 [1-99] permit [permit (autorise)/deny (loqué)] 192.168.1.0
0.0.0.255 @ ip de réseau transfer/any/any
R2 (config) # ip nat inside source list 1 pool TEST [nom de la plage]
R2 (config) # int g0/0
R2 (config-if) # ip nat inside
# exit
R2 (config) # int g0/0
R2 (config-if) # int s0/0/0
R2 (confi-if) # ip nat outside

Configuration PAT
PAT avec une seul adresse IP publique unique

R4 (config) # access-list 1 permit 192.168.1.0[@ip transfer /any] 0.0.0.255


R4 (config) #ip nat inside source list 1 Interface s0/0/0 Overload
R4 (config) # int g0/0
R4 (config-if) # ip nat inside
# exit
R4 (config) # int s0/0/0
R4 (config) # ip nat outside

PAT avec une plage des adresses IP publique

R6 (config) # access-list 1 permit 192.168.1.0 0.0.0.255


Créer la plage des @ IP globale
R6 (confiig) # ip nat pool TEST 212.12.12.1 212.12.12.8 netmask 255.255.255.240
Créer la liaison entre ACL et le pool
R6 (config) # ip nat inside source list 1 pool TEST overload
R6 (config) # int g0/0
R6 (config-if) # ip nat inside
R6 (config-if) # exit
R6 (config) # ints0/0/0
R6 (config-if) # ip nat outside

Explication et configuration de NETFLOW


NETFLOW : est une technologie de la capture des paquets au niveau d’un routeur ou niveau
switch Multicouche (Niveau3)

Pour entrer Router avec NETFLOW activé


Router (config) # int g0/0
Router (config) # ip flow ingress (entrée)
Ingress : capture des paquet entrée
Router (config) # ip flow egress (sortie)
Egress : capture des paquet sortée
# exit

Router (config) # int g0/0


Router (config) # ip flow ingress
Router (config) # ip flow egress
# exit
Router (config) # ip flow-export version 9(verison par défaut) [version possible 1 5 7 9]
Les données Router collecter ou capturer centraliser de logiciel collecter NETFLOW
Router (config) # ip flow-export destination 192.168.1.2 2055
[Port UDP NETFLOW par défaut 2055 ou4096]
Pour regarde les données capturer
Router # show ip cache flow 2 fois
Router # show ip cache flow
Pour configurer Telnet
R (config) # enable password 123456
# line vty 0 4
# password 123456 pinger pour pc1 Telnet
# login

HTTP, NTP ET SYSLOG


HTTP : - C’est une abréviation de hyper texte Transfer protocole
- C’est un protocole Transfer page web on vous d’internet numéro de port 80
HTTP = HTTP +SSL = 443 (HTTPS)
SSL = Secure ce qui layer
Configuration de HTTP
Pour HTTP : entrer server HTTP-NTP-SYSLOG => services => HTTP(On) HTTPS(On)
Déjà donnez-nous (‫ )عاطيينا‬Html
Welcome to Group 2ATRI
Chanegr packet tracer => URL : http:// 192.168.2.2 (@ serveur)

NTP : c’est une abréviation 2 network time protocole


• C’est un protocole qui permet de synchroniser horloge locale des ordinateurs via
un réseau informatique
NTP : c’est très important de DHCP
NTP : numéro de port 123(UDP)
Pour règles NTP => entrée le server => services => NTP
Pour config NTP une router (R0)
R0 # show clock
# config terminal
# ntp ?
# ntp server 192.168.2.2
# exit
# show clock
SYSLOG : c’est un service des journaux divinement d’un système informatique
SYSLOG : numéro de port 514(UDP)
SYSLOG : deux parties
Partie serveur = créer de fichier journaux
Partie client = envoyer des informations sur le réseau
Pour entrer les serveurs HTTP-NTP-SYSLOG
 Services => syslog (On)
Après entrer le router (R0)
La date et leur n’est pas créer et règles (le même temps)
R1 (config) # logging ?
# logging on (activés les fichier journaux)
# logging 192.168.2.2 créer 2
# logging on à la fois
# logging 192.168.2.2

ACLS

 Une ACL (Access Control List) : permet d’autoriser ou d’interdire des


paquets, que ce soit en entée ou en sortie
 Une ACL est un identifiable par son numéro ou son nom
On trouve trois types des ACLS :
 ACL standard (numéroté) : bloque tous les trafics
 ACL étendue (numéroté) : bloque un ou plusieurs trafics(HTTP) et tout
protocole
 ACL nommée : peut-être de type standard ou étendue

L’avantage principal des ACLS : est donc de fournir une base de sécurité réseau en
filtrant les trafics traversant un routeur
Le principal inconvénient : est malheureusement un traitement supplémentaire à
effectuer pour chaque paquet entrant et/ou sortant du routeur
La configuration des ACLS fait en deux parties :
 Création de l’ACL
 Application de l’ACL sur une interface réseau

# ACL-standard :
NB : les numéros de l’ACL standard sont 1-99 et 1300-1999
Router (config) # access-list [numéro] [permit(autorisé)/deny(bloque)]
[préfixe(@réseau destination ou source)] [masque(MG)]
Ex : router (config) # access-list 1 permit 192.168.3.0 0.0.0.255
Exemple ACL standard :

Solution
1)
2) pour configurer les interfaces
3) pour configurer les hôtes (@ ip +masque+passrelle)
4) pour configurer le routage (é votre choix ( ‫)من اختيار ذيالك‬
5)
 entrer PC1 => desktop => run
PC >ping –t 192.168.1.0
Standard (1-99)
 R0 (config) # access-list 1 deny 192.168.2.0 0.0.0.255
 R0 (config) # int s0/0/0
 # ip access-group 1 in
Pour autorisé host PC1 seulement (‫ )فقط‬bloque une host ‫االخرين‬
 R0 (config) # no access-list 1
Créer ACL bloque ou autorisé une seule machaine
 R0 (config) # access-list 2 permit host 192.168.2.2 (autorisé une
Seulement host)
Bloque tous les host
 R0 (config) # access-list 2 deny any (‫)كتبلوكي االخرين‬
 # int s0/0/0
 # ip access-groupe 2 in

ACL Etendue [source (router source ‫])كيدار في اقرب‬


NB : le numéro de l’ACL Etendue [100-199] et [2000-2699]
ACL Etendue : bloque un plusieurs trafic (HTTP) ou (bloque out le protocole)
Router (config) # access-list {numéro (100-199)} {permit (autorisé) /
deny(bloque, refuser)} {protocole(de la couche 4) TCP/UDP}
{Préfixe source(@source)} {Masque source} {opérateur (eq,neq,lt,gt)}
{Opérande (-numéro de port services-protocole DHCP…)} {established
(établisment)}
Opérande = protocole & opérateur=
‘’eq = egale’’ [eq =53 = bloque DNS (53)]
‘’neq # inégale’’ [bloque tout server ce sauf (‫ )اال استثناء‬DNS(53)]
‘’lt = inférieur’’ [bloque et autorisé tous les numéro de port inférieur <53]
‘’gt = supérieur’’ [bloque et autorisé tous les numéro de port supérieur >53]
DNS 53 : utilise 2 à la fois Protocole TCP ET UDP
Telnet 23 : utilise tcp
Http 80
FTP 21

RIP : utilise le protocole ICMP ping => echo


Exemple ACL Etendue :

- Configurer les interfaces ou routage


- Configurer Telnet
Question
1) Refuser l’accès Telnet de puis laptop0 ver tous les routeurs
 Configurations Telnet tous R0, R1, R2
R0, R1, R2 (config)# line vty 0 4 (0 15)
# password Telnet13
# login
# exit
Password mod configuration secret
R0, R1, R2 (config) # enable secret sec16
 Entre laptop0 pour verifier Telnet de @ ip directement connecté pout router
Pc >Telnet 192.168.1.1
Pc >Telnet 192.168.2.1
Pc >Telnet 92.168.3.1
 Bloque Access sur laptop0 n’est pas entre les router
Entré R0 créer ACL Etendue
R0 (config) # access-list 100 deny tcp host 192.168.1.3 any (tout) eq 23
(N° de port Telnet 23)
R0 (config) # access-list 100 permit ip any any
# int g0/0
# ip access-group 100 in
Pour vérifier une laptop0
Laptop0 bloque Telnet
Pc>telnet 192.168.1.1
Tryying 192.168.1.1…………open
Pc n’est pas bloqué Telnet
2) Refuser l’accès au serveur web(tcp) de puis le réseau 192.168.2.0/24
autoriser
 Pour entrer le router R2
R2 (config) # access-list 101 deny tcp 192.168.3.0 0.0.0.255 host
192.168.2.3 [@ destination (server web)] eq 80 (http)
Web => protocole http(80) => tcp
 Entre exécuter
C:\windows\system32\driver\etc\services
Bloc-notes => ok
R2 (config) # access-list 101 permit ip any any
# int s0/0/1
# ip access-group 10 out
 Pour bloquer @ ip 192.168.2.3 de R2
# Entre server une => est active
# Entre server une => desktop => http (web browser)
 Taper @ ip de serveur web
URL : 192.168.2.3 (pour bloquer de Pc2)
Pc 0 ou Pc1 => n’est pas bloqué @ ip 192.168.2.3
3) Autoriser l’accès au serveur de fichier de puis le réseau 192.168.2.0/24
Refuser tous les autres trafics
 Entrée les Router (R1) autorisé @ 192.168.2.0
R0 (config) # access-list 102 permit tcp 192.1682.0 0.0.0.255 host
192.168.3.3 [@destination (server FTP-DNS)] eq 21(FTP)
 FTP port 21
 Refuser tous les autres trafics
R0 (config) # access-list 102 deny ip any
# int g0/0
# ip access-group 102 in
Server web et server FTP-DNS n’est pas pinger (message ‫)مغيدوزش‬
 Enter server FTP-DNS => services
 FTP => on => username (User FTP)
=> password (123456)
 Afficher
White * Read * Delete * Rename * List *
 ADD (ajouter)
 Entre Pc0 (accéder FTP)
Pc > Ftp 192.168.3.3
4) Refuser l’envoi de ping de puis le Pc0 vers le réseau 192.168.2.0/24 autorisé
tous les autres trafics
 Bloqué ping entre Pc1 et Pc1
Pc0 (router R0 ‫) اقرب هو‬
 Refuser ping (ICMP) de puis le Pc0 ver Pc1 le réseau
R0 (config) # access-list 104 deny icmp host 192.168.1.2 192.168.2.0 0.0.0.255
echo (ping)
 Autoriser tous les autres trafics
R0 (config) # access-list 104 permit ip any any
# int g0/0
# ip access-group 104 in
 Ping entre Pc0 et Pc1 (n’est pas pinger)
 Ping => commande ICMP [echo (ping)]

ACL Nommée (Standard et Etendue)


ACL Nommée : peut-être de type standard ou étendue
 Bloquer la connectivité entre réseau 192.168.1.0 et 192.168.2.0
• Tous les trafics entre réseau 192.168.1.0 et réseau 192.168.2.0
ACL Nommée standard : Router ‫كتكون في أقرب‬
ACL standard : Router la destination ‫كتكون في أقرب‬
 Entrée router R0 créer ACL nommée
R0 (config) # ip access-list ?
Extended Extended Access Lis

Standard Standard Access List


R0 (config) # ip access-list standard STD
R0 (config-std-nacl) # deny 192.168.2.0 0.0.0.255(bloque 192.168.2.0)
R0 (config-std-nacl) # permit any
# exit
# int g0/0
# ip access-group STD out

Exemple :
 Refuser Access du serveur Web (http, tcp)
 Pour réseau 192.168.3.0/24 n’est pas accéder server WEB (bloque 192.168.3.0 pour
R2)
 Une fois écoute serveur web ou un trafic utilise (ACL nommée type Etendue)
ACL Etendue = en passé @ source et @ destination
 Appliqué le plus proche (‫ )أقرب‬router source

R2 (config) # ip access-list Extended ETD (Extended=Etendue)


R2 (config-ext-nacl) # deny tcp 192.168.3.0 0.0.0.255 host 192.168.2.3 eq 80(HTTP)
R2 (config-ext-nacl) # permit ip any any
# exit
R2 (config) # int s0/0/1
# ip acces-group ETD out
 Pour vérifier pour Pc2
Desktop => HTTP (Web browser)
URL : 192.168.2.3
 Pour vérifier de Pc0
Desktop => http (Web browser)
Désactiver pour R0 ACL standard

Services DHCP sur un serveur Router-IPV4

DHCP (Dynamic Host Configuration Protocole) :


Est un protocole fonctionnant en mode client-serveur. Il fournit aux clients une
configuration de couche3 : principalement une adresse (IP), mais aussi des
adresses de passerelle ou de serveur DNS, NETBIOS, noms de domaines,…
Il existe trois types d’allocation d’adresse :
• Automatique : une adresse IP permanente est attribuée
automatiquement
Au client, un mappage statique (mac _ IP) permet de retrouver la même
adresse lors d’une déconnexion / reconnexion.
• Manuel : l’attribution est faite manuellement par l’administrateur réseau
(mappage statique), le protocole DHCP se charge d’envoyer ces
informations au client lors d’une demande.
• Dynamique : l’attribution se fait à la volée. Une IP libre est attribuée à un
client en faisant la demande, pour une durée déterminée.
DHCP 67 pour serveur DHCP 68 pour client

Les messages DHCP : 7 messages


DHCP Discover (chercher client du serveur)
DHCP Offer (envoyé serveur par client)
DHCP Request (Requet envoyer le client de serveur (‫)واش نخدم بيها وال ال‬
DHCP ACK (c’est une aquisé la réception de serveur et du client
DHCP Decline (Rajouter ‫)كي أضف‬
DHCP Nack [not ACK (pas aqusié de reception)]
DHCP Release [c’est-à-dire libérer )‫])مجاني‬
 Si nous avons les clients est de server
Pour déférent nous Avons besoins Agent de relai
 Si nous avons les clients est de serveur
Pour défirent nous avons besoins Agent de relai
Agent de relais DHCP : permet de relier le serveur DHCP avec leurs clients
qui ne sont pas dans le même réseau
Configuration DHCP :
 Configuration d'un pool :
R0 (config) # ip dhcp pool tri

 Exclusion des adresses ipv4 :

R0 (config) # ip dhcp Exluded-address 192.168.1.1 (@ ip exlure)

R0 (config) # ip dhcp Excluded-address 192.168.1.50 192.168.1.70 (nom de la plage)

 Configuration des taches spécifique :

R0 (dhcp-config) # network 192.168.1.0 (@réseau) 0.0.0.255

 Définir le routeur/ l'adresses de passerelle par defaut :

R0 (config-dhcp) # défault-router 192.168.1.1 [@ ip de la passerelle (gateway)]

 Définir un serveur DNS :


R0 (config-dhcp)# domain-name tri.ma (ServeurDNS)

R0 (config-dhcp) # dns-server ‘’@ip serveur DNS’’ (@ tp source serveur DNS)

Définir le routeur un agent de relais


R0 (config) # int g0/0 ou f0/0 (numéro)
# ip helper-address ‘’ @ ip serveur DHCP’’
DHCP sur serveur

Entrée serveur TFTP => service => DHCP


Pour créer 3 plage => 3 LAN => LAN1 /LAN2 /LAN3
POOL NAME : LAN1
Default Gateway : 10.10.10.1
DNS server : 0.0.0.0 ‫مكينش‬
Start IP address : 10.10.10.3 Masque 255.255.255.0
Maximum number of users : 251 (251-3) => add(ajouter)
La même chose : LAN2 => 172.16.1.2 D-Gateway : 255.255.255.0
Maximum number of users : 252 (252-2) => add (ajouter)
La même chose : LAN3 => 192.168.1.1 192.168.1.2 255.255.255.0
=> 252 => add(ajouter)

Clique mode ON
Après
Pc0 => DHCP (oui) static (non)
Pc1 => DHCP (oui) static (non)
Pour R0 => appliqué un agent de relais une interface g0/1 proche du client
R0 (config) # int g0/1
R0 (config-if) # ip helper-address 10.10.10.2
# exit
 Pour entrer Pc0 => desktop => DHCP
DHCP (on)
R1 (config) # int g0/1
# ip helper-address 10.10.10.2
Entrée R0, R1 => pour créer rip v2

R0, R1 (config) # router rip


# version 2
# network 10.10.10.0
# network 212.12.12.0
# network 172.16.1.0
R1 (config) # router rip
# version 2
# network 212.12.12.0
# network 192.168.1.0

DHCP sur Router


Configuration le router DHCP le protocole Rip version 2
Configurer DHCP de router
Entrée router DHCP => clock rate 64000
La même chose AR => clock rate 64000
Pour entrer router DHCP
Créer la plage entre server TFTP ou Pc0
DHCP (config) # ip dhcp excluded-address 10.10.10.1 n’est pas router DHCP défuser
@ 10.10.10.10
Créer la plage
DHCP (dhcp-config) # ip dhcp pool LAN1
DHCP (dhcp-config) # network 10.10.10.0 (diffuser le client) 255.255.255.0
‫نحدد له @ لبغيناها تفرق‬
DHCP (dhcp-config) # default-router 10.10.10.1
DHCP (dhcp-config) # dns-server 10.10.10.2
DHCP (config) # ip dhcp exculeded address 172.16.1.1 ( ‫)مخصهاش تفرق‬
DHCP (config) ip dhcp pool LAN2
DHCP (dhcp-config) # network 172.16.10.0 255.255.255.0
DHCP (dhcp-config) # default-router 172.16.1.1
DHCP (config) # ip dhcp excluded-address 192.168.1.1
# ip dhcp pool LAN
DHCP (config-dhcp) # network 192.168.1.0 255.255.255.0
# default-router 192.168.1.1

Config le router DHCP de protocole Rip version 2


 Entrée serveur TFTP => desktop => DHCP (on)
Pc0 => desktop => DHCP (on)
Pc1 => desktop => DHCP (on)
Pc2 => desktop => DHCP (on)
Pc3 => desktop => DHCP (on)
Pour Pc2 A emporter une @ ip le nôtre
Ecrier Agent de relais pour Router AR
AR (config) # int g0/1
# ip helper-address 212.12.12.1
‫ لمقابل معاه‬int ‫كنذير @ ديال‬
Créer le routage Rip router AR
Voir (‫ )انظر‬les informations pour Router DHCP (virtualisation ‫)تصور‬
DHCPv6 : SLAAC, sans Etat et avec Etat
DHCP : est un protocole qui permet la configuration des hôtes (PC) une
façon Dynamics (port 67et 68)
Protocole de Port de travail (67, 68) diffuser les @ ip les masque, la passerelle
et les autres services d’une façon dynamique
DHCPv6 : et 3 cas possible
▪ SLAAC travaille de
▪ Sans Etat packet tracer
▪ Avec Etat - n’est pas travaillé des packet traces
-Travaille de réalité

Switch pour configurer SDM mode configuration globale


Pour la réalité
Switch > en
# config terminal
# SDM prefer dual ipv4 and ipv6 défault

SLAAC et DHCPv6
(States Les Adresse Auto-config Configuration)
1)-Configuration DHCPv6 pour étapes SLAAC

Pour entre laptop 0 => desktop => auto-config (on)


Pour entrer router0
Activé routage monodiffusion
R0 (config) # ipv6 unicast-routing
R0 (config) # int g0/0
R0 (config-if) # ipv6 address 2001 :db8 :acad :a ::1/64
R0 (config-if) # no shutdown

Pour entrer switch0


Configuration exécuté de la configuration (ipv6 adresse auto-config)
Switch (config) # int vlan 1 (vlan natif)
Switch (config) # ipv6 adresse auto-config

2)- configuration DHCP sans état

Entrée R0
R0 (config) # int g0/0
# ipv6 add 2001 :db8 :acad :a ::1/64
# no shutdown
Créer DHCP (ou configure serveur DHCP
1er =créer la plage
R0 (config) # ipv6 dhcp pool TEST
R0 (config-dhcp) # domain-name tri.ma (nom domain)
R0 (config-dhcp) # dns-domain 2001 :db8 :acad :a ::2 (@ip serveur dns)
Attribuer la plage pour écréer
R0 (config) # int g0/0
R0 (config-if) # ipv6 dhcp server TEST
Des coverte des réseau (ND) Network Discover
R0 (config-if) # ipv6 nd ?
# ipv6 nd other-config-flog
Entrée laptop0 => desktop => ip configuration => ipv6 configuration => DHCP(on)
3)- DHCP avec état
(n’est pas de travail)
Enter le router (R0)
R0 (config) # int g0/0
# ipv6 add 2001 :db8 :acad :a ::1/64
# no shutdown
Créer la plage
R0(config) # ipv6 dchp pool TEST
R0 (config-dhcp) # address prefixe 2001 :db8 :acad :a ::/64
Pour travailler manager
R0 (config) # int g0/0
# ipv6 nd managed-config-flog
# no shutdown
Entrer laptop => desktop => dhcp(on)
Vérification configuration DHCPv6
R0 # ipv6 dhcp binding (client et préfixe)
# show ipv6 pool (pour la plage)
# debug ipv6 dchp détail (pour active debugage de dhcp)
Pour verifier de la client (ex : pc , laptop serveur)
Pc > ip config /all
Pc > ip config /release 6 (la commandede rounovellement )
Pc > ip config /renew 6

Vous aimerez peut-être aussi